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Using Help

 

About Help

 

Adobe Systems Incorporated provides complete documentation in an Adobe PDF-based 
help system. This help system includes information on all tools, commands, and features 
of an application. It is designed for easy on-screen navigation and can also be printed and 
used as a desktop reference. Additionally, it supports third-party screen-reader applica-
tions that run in a Windows environment.

 

Navigating in Help

 

Help opens in an Adobe Acrobat window with the Bookmarks pane open. (If the 
Bookmarks pane is not open, click the Bookmarks tab at the left edge of the window.) 
At the top and bottom of each page is a navigation bar containing links to this page (Using 
Help), the table of contents (Contents), and the index (Index).

To move through pages sequentially, you can click the Next Page  and the Previous 
Page  arrows; click the navigation arrows at the bottom of the page; or click Back to 
return to the last page you viewed.

You can navigate Help topics by using bookmarks, the table of contents, the index, or the 
Search (Acrobat 6) or Find (Acrobat 5) command.

 

To find a topic using bookmarks:

1

 

I

 

n the Bookmarks pane, click the plus sign (+) (Windows) or the right-facing arrow 
(Mac OS) next to a bookmark topic to view its subtopics.

 

2

 

C

 

lick the bookmark to go to that topic.

 

To find a topic using the table of contents:

1

 

C

 

lick Contents in the navigation bar.

 

2

 

On the Contents page, click a topic to go to that topic.

 

3

 

To view a list of subtopics, click the plus sign (+) (Windows) or the right-facing arrow 
(Mac OS) next to the topic name in the Bookmarks pane.

 

To find a topic using the index:

1

 

D

 

o one of the following:

 

•

 

Click Index in the navigation bar, and then click a letter at the top of the page.

 

•

 

Ι

 

n the Bookmarks pane, expand the Index bookmark to view the letter subtopics; 
then click a letter.

 

2

 

Locate the entry you want to view, and click the page number to go to that topic.

 

3

 

To view other entries for the same topic, click Back to return to the same place in the 
index, and then click another page number.
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To find a topic using the Search command (Acrobat 6):

1

 

Choose Edit > Search.

 

2

 

Type a word or phrase in the text box and click Search. Acrobat searches the document 
and displays every occurrence of the word or phrase in the Results area of the Search PDF 
pane.

 

To find a topic using the Find command (Acrobat 5):

1

 

Choose Edit > Find.

 

2

 

Type a word or phrase in the text box and click Find. Acrobat searches the document, 
starting from the current page, and displays the first occurrence.

 

3

 

To find the next occurrence, choose Edit > Find Again.

 

Printing Help

 

Although Help is optimized for on-screen viewing, you can print selected pages or the 
entire file.

 

To print Help:

 

Choose File > Print, or click the Print icon in the Acrobat toolbar.
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Learning Photoshop CS

 

Welcome

 

Welcome to Adobe

 

®

 

 Photoshop

 

®

 

 CS and Adobe ImageReady

 

® 

 

CS, the professional image-
editing standard for photographers, professional designers, and graphics producers.

Photoshop and ImageReady provide a consistent work environment with other Adobe 
applications including Adobe Illustrator

 

®

 

, Adobe InDesign

 

®

 

, Adobe GoLive

 

®

 

, Adobe 
LiveMotion

 

™

 

, Adobe After Effects

 

®

 

, and Adobe Premiere

 

®

 

.

 

Getting help

 

Adobe provides a variety of options for you to learn Photoshop and ImageReady.

 

Finding help on Photoshop features

If you... Try this...

 

Are new to Photoshop • Browse through the information in “Working with 
Photoshop and ImageReady” on page 6.

• See “Looking at the Work Area” on page 12 to get familiar 
with the work area and tools.

• Click Learn the Basics from the Welcome screen. (Choose 
Help > Welcome Screen.)

• Use the How To tips in Help for instructions on common 
tasks such as fixing photos, working with layers, or painting. 
Choose one of the How To tips from the Photoshop or 
ImageReady Help menu.

Are upgrading from an older
version of Photoshop

• See the What’s New information on the Photoshop Welcome 
screen. Choose Help > Welcome Screen.

• Browse through the information in “Working with 
Photoshop and ImageReady” on page 6.

Are looking for a detailed informa-
tion about a feature

• Try searching for the feature in Help or looking it up in the 
index.
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Want to learn new techniques for 
using Photoshop and ImageReady

• See the tutorials on the Adobe Studio Web site at
www.studio.adobe.com. 

• Try one of the techniques in “Tips and Tricks from the 
Experts.” Choose Help > Welcome Screen and click the Tips 
and Tricks link.

Want a PDF version of the 
Photoshop/ImageReady Help

• See the 

 

PhotoshopCSHelp.pdf

 

 file on the CD. 

Want information on keyboard 
shortcuts

• See the Keyboard Shortcuts section of Photoshop Help.

 

Finding Photoshop training resources

If you... Try this...

 

Want to obtain in-depth training • See the tutorials on the Adobe Studio Web site at 
www.studio.adobe.com. 

• Browse the Adobe Press materials at www.adobepress.com 
(English only), and the available training resources at 
www.adobe.com (choose Support > Training).

• For step-by-step lessons, consider the Adobe Classroom in a 
Book series. 

• For in-depth reference information, consider the RealWorld 
series.

Are looking for background
information on Web design

See the Adobe Press section of the Adobe Web site at 
www.adobe.com/misc/books.html.

Want to access the Developer 
Knowledgebase or software
developer kits (SDKs) 

See the Adobe Solutions Network (ASN) section of the Adobe 
Web site at http://partners.adobe.com/asn/photoshop/ 
(English only).

Want information about becoming 
an Adobe Certified Expert, Adobe 
Certified Instructor, or Adobe 
Authorized Learning Provider 

Visit the Partnering with Adobe Web site at 
www.partners.adobe.com. Certification is available for several 
different geographical regions. 

 

Finding help on Photoshop features

If you... Try this...

http://www.studio.adobe.com
http://www.adobe.com
http://www.adobe.com/misc/books.html
http://partners.adobe.com/asn/photoshop/
http://partners.adobe.com
http://www.studio.adobe.com
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Working with Photoshop and ImageReady

 

Photoshop provides a rich graphics toolset for digital photography, print production, Web 
design, and video production.

 

If you work with digital photos

 

•

 

Read “Basic steps for correcting images” on page 174. You’ll get an overview of the 
many tonal and color correction tools in Photoshop.

 

•

 

Process digital camera raw files within Photoshop to get the most control and best 
image quality from these files. See “Working with camera raw image files” on page 71.

 

•

 

Retouch photos, remove dust spots, and correct image flaws while preserving tonality 
and texture. See “Using the Healing Brush tool (Photoshop)” on page 271.

 

•

 

Quickly fix red eye caused by photo flash. See “Using the Color Replacement tool” on 
page 274.

 

•

 

Create panorama photos by stitching multiple images together. See “Creating 
panoramic images using Photomerge (Photoshop)” on page 284.

 

•

 

Manage and preview photos on a digital lightbox using the file browser. See “Using the 
File Browser (Photoshop)” on page 90.

 

•

 

Create a contact sheet of images. See “Creating contact sheets” on page 594.

 

Finding support for Photoshop 

If you... Try this...

 

Want customer or technical
support

• Refer to the technical support card provided with your
software.

• Register your software and receive technical support for up 
to 90 days from the date of your first call (terms may vary 
depending on country of residence).

• See the Adobe Photoshop support page at 
www.adobe.com/support/products/photoshop. html.

• Read the ReadMe file installed with Photoshop for informa-
tion that became available after this guide went to press.

Want answers to common trouble-
shooting questions

Search the Adobe Support Knowledgebase and 
Photoshop  Top Issues at www.adobe.com/support/
products/photoshop. html.

Want to register your copy of 
Photoshop

• Fill out and return the registration card included with your 
software package.

• Access the online registration form at any time by choosing 
Help > Registration.

Want access to a multitude of 
Photoshop-specific information, 
such as downloads, updates, 
patches, plug-ins, and links to user 
forums

Visit the Photoshop pages on Adobe Studio at 
www.studio.adobe.com.

http://www.adobe.com/support/products/photoshop.html
http://www.adobe.com/support/products/photoshop.html
http://www.adobe.com/support/products/photoshop.html
http://www.studio.adobe.com
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•

 

Present your photos in a digital slideshow. See “Creating a PDF presentation” on 
page 598. 

 

•

 

Quickly create a gallery of images for your Web site using one of several professionally 
designed page templates. See “Creating Web photo galleries (Photoshop)” on 
page 500.

 

If you want the color on your prints and monitor to match

 

•

 

Read “An introduction to color management” on page 108.

 

•

 

Use a printer color profile as described in “Basic steps for producing consistent color” on 
page 110 and then use the Photoshop print setting and your printer driver color 
management settings. See “Using color management when printing” on page 612.

 

If you design Web pages

 

•

 

Read the overview of Photoshop and ImageReady Web design tools and learn about 
the ImageReady object-based design tools. See “About designing Web pages with 
Photoshop and ImageReady” on page 471.

 

•

 

Optimize images for efficient Web download. See “About optimization” on page 531.

 

•

 

Manage slices, rollovers, image maps, and animations in the Web Content palette. 
See “Using the Web Content palette” on page 510.

 

•

 

Create instant GIF and SWF animations from layered Photoshop files. See “Animations” 
on page 518.

 

•

 

Export ImageReady designs, animations, and graphics to the Macromedia Flash format. 
See “Saving files in SWF format (ImageReady)” on page 576.

 

If you design video graphics

 

•

 

Use video document presets with action-safe and title-safe guides. See “Saving images 
for use in video” on page 604.

 

•

 

View images on your computer monitor and NTSC external monitor simultaneously 
without distortion. See “Saving images for use in video” on page 604.

 

If you perform the same tasks on several files

 

•

 

Learn to record and play back actions to automate repetitive tasks. See “About actions” 
on page 627.

 

•

 

Write scripts using Visual Basic, Applescript, or Javascript. See the documentation in 
your Photoshop CS/Scripting Guide folder.

 

•

 

Automate graphic production using data sets. See “Creating templates for data-driven 
graphics (ImageReady)” on page 649.
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What’s New in Photoshop CS

 

Photoshop CS for All Users

 

No matter how you use Photoshop CS, you can take advantage of improved file 
management, and better ways to track and securely share your work.

 

Enhanced File Browser

 

In Adobe Photoshop CS, the File Browser comes into its own as 
your digital imaging hub. With flags, keywords, and editable metadata, you can now use 
the File Browser to quickly organize and locate the image assets you need. Perform batch 
procedures on groups of images without having to first open the image files in 
Photoshop. (See “Using the File Browser (Photoshop)” on page 90.)

 

Easily customize your keyboard shortcuts

 

Create, edit, and save multiple keyboard 
shortcut sets for menu items, tools, and palette commands, so the functions that you use 
most are always at your fingertips. (See “Customizing keyboard shortcuts” on page 54.)

 

Quickly create, view, and edit custom file information

 

Use the File Browser to quickly 
search for files using editable metadata, without having to open each file. Fully customize 
your image metadata with custom panels and fields in the File Info dialog, and use the File 
Browser to edit the metadata of one or many images at a time. (See “Adding metadata to 
files” on page 99.)

 

Create slide shows and PDF presentations

 

Easily bind multiple files into a single, 
multi-page Adobe PDF document, complete with optional page transitions and security. 
(See “Creating a PDF presentation” on page 598.)

 

Collaborate with Web photo galleries

 

Use professionally-designed Web Photo Gallery 
templates, including support for client feedback with no extra Web coding required. 
(See “Creating Web photo galleries (Photoshop)” on page 500.)

 

Track your editing history

 

Save your editing history in a external log file and in 
metadata attached to individual files. (See “Working with the Edit History Log” on 
page 38.)

 

Easily access and use multiple filters

 

The new Filter Gallery brings Photoshop CS filters 
into a single, easy-to-use dialog. Now you can access, control, and apply multiple filters at 
once, with a new, larger preview for easier planning of stacked filter effects. (See “Using 
the Filter Gallery” on page 415.)

 

Use enhanced scripting

 

Save time by automating repeated tasks, such as outputting 
your layers to files or saving Layer Comps as separate pages of an Adobe PDF file, using 
custom or new built-in scripts. See the documentation available in your Photoshop CS/
Scripting Guide folder.

 

Customize the Help menu

 

Use the new how-to topics by choosing them from the Help 
menu. Or, create your own how-to topic and have it appear in the Help menu. (For more 
information, choose Help > How to Create How Tos.)
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Photoshop CS for photographers

 

New tools, enhanced features, richer images—Adobe Photoshop CS meets the needs of 
today’s photographer.

 

Control your raw camera images

 

The new generation Camera Raw plug-in is incorpo-
rated directly into Photoshop CS, allowing direct manipulation of raw camera data, for the 
ultimate control over image preprocessing. Camera Raw features new color calibration 
controls, batch processing through the File Browser, and support for most major digital 
camera models. (See “Working with camera raw image files” on page 71.)

 

Comprehensive 16-bit editing

 

All core Photoshop features are now available to 16-bit 
images, including layers, painting, text, and shapes.

 

Match colors fast

 

Apply the color scheme of one image to another, or one layer to 
another, to easily achieve a consistent look between shots in fashion or commercial 
photography. (See “Using the Match Color command (Photoshop)” on page 206.)

 

View live histograms as you work

 

View an image and its histogram simultaneously with 
the new Histogram palette, allowing you to monitor the changes in your image as you 
make them. (See “Using a histogram to view the tonal range of an image (Photoshop)” on 
page 176.)

 

Create lens blur effects

 

Easily produce the effect of highlights taking on the shape of 
the camera lens aperture. Lens Blur can be applied to an entire image or selection, or it can 
use an alpha channel as a depth map. (See “Blur filters” on page 421.)

 

Simulate photo filter effects

 

Customize filter adjustment layers to simulate the effect of 
standard photographic lens filters. (See “Using the Photo Filter command (Photoshop)” on 
page 203.)

 

Easily correct exposure problems

 

Use the Shadow/Highlight adjustment to modify 
shadows and highlights while preserving existing image midtones, easily correcting over- 
and underexposed areas in any image. (See “Using the Shadow/Highlight command 
(Photoshop)” on page 204.)

 

Quickly replace color

 

Effortlessly change the color of any area of an image, while 
retaining the original texture and shading, with the new Color Replacement tool. 
(See “Using the Color Replacement tool” on page 274.)

 

Automatically crop and straighten

 

Take the pain out of scanning multiple images. 
Place one or more photos onto a scanner bed, scan them into Photoshop, and then run 
Crop and Straighten to let Photoshop automatically copy each image into its own 
document and rotate it as necessary. (See “Using the Crop and Straighten Photos 
command (Photoshop)” on page 264.)

 

Create panoramas fast

 

Combine images into seamless panoramas, with each image 
optionally preserved to a separate layer for even more control over the final output. 
(See “Creating panoramic images using Photomerge (Photoshop)” on page 284.)

 

Customize your picture packages

 

Picture Package gives you a variety of ways to easily 
combine multiple images, or multiple instances of one image, in a single print. For 
Photoshop CS, the Picture Package window now allows you to interactively edit existing 
layouts, making it easy to precisely control image position and spacing. (See “Creating 
picture packages” on page 595.)
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Photoshop CS for graphic Designers

 

Explore new possibilities and streamline your work with Photoshop CS innovations for 
graphic designers.

 

Place editable text on a path and in a shape

 

Create and manipulate fully editable text 
on any path, or inside any shape, for eye-catching typographic designs. (See “Creating text 
on a path (Photoshop)” on page 445.)

 

Create alternate designs in a single image

 

Capture multiple design variations as 
individual Layer Comps in a single file; then quickly output them to provide alternates for 
client review. (See“Working with layer comps” on page 405.)

 

Think big with huge document support

 

Create and work with images up to 300,000 by 
300,000 pixels, with up to 56 channels per file. (See “Large Document Format (PSB)” on 
page 586.)

 

Photoshop CS for video and filmmakers

 

Remove the guesswork from designing for DVD, video, and film, and achieve tighter 
integration with motion graphics software such as Adobe

 

®

 

 Premiere

 

®

 

 and Adobe

 

®

 

 After 
Effects

 

®

 

.

 

Create non-square pixel documents

 

Work with different aspect ratios without the 
distortion caused by viewing non-square images on a computer monitor, seeing them 
exactly as they will appear when viewed on a standards-compliant external monitor. 
(See “Saving images for use in video” on page 604.)

 

Choose from video document presets with automatic guides

 

Use new, customizable 
document presets in standard video sizes and aspect ratios, with automatic action-safe 
and title-safe guides, for easier setup and creation of files for DVD, video, and film. (See 
“Saving images for use in video” on page 604.)

 

Easily export layers to files

 

Integrate your layered Photoshop CS artwork with a variety 
of editing and compositing systems more efficiently, using the Export Layers to Files 
command. (See “Exporting layers as files (ImageReady)” on page 579.)

 

ImageReady CS for Web professionals

 

Prepare Web graphics quickly and efficiently with the improved ImageReady CS features 
and interface for Web design and production.

 

Enjoy a Web-focused interface

 

Easily select, group, and manipulate multiple objects 
using automatic Smart Guides, and organize nested object groups up to five levels deep. 
(See “About designing Web pages with Photoshop and ImageReady” on page 471.)

 

Export to Macromedia

 

®

 

 Flash

 

™

 

 (SWF)

 

Export directly to Flash (SWF), with preserved 
vectors and dynamic text including embedded fonts. Export each layer to its own SWF file, 
allowing each file to be opened in Flash as its own symbol on its own layer. (See “Saving 
files in SWF format (ImageReady)” on page 576.)

 

Output enhanced HTML

 

Create leaner, more easily edited HTML, with new controls for 
nested tables, XHTML, and more. (See “About designing Web pages with Photoshop and 
ImageReady” on page 471.)
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Create and edit interactive elements easily with the new Web Content palette. 

 

Fine-tune your control over remote rollover slices with the new point-and-shoot targeting 
system. Create multiple slice sets in a single document, and combine slice sets and layer 
comps to quickly switch among and export different document configurations. 
(See “Using the Web Content palette” on page 510.)

 

Create dynamic content fast with variables and data sets

 

Directly define and edit 
variables and data sets, and easily import database and spreadsheet content for 
automated graphics production. (See “Creating templates for data-driven graphics 
(ImageReady)” on page 649.)

 

Enjoy enhanced automation with conditional actions

 

Using the Insert a Step button 
in the Actions palette, conditional logic can now be inserted in ImageReady CS actions. 
With conditional logic, ImageReady CS will scan for certain image characteristics (aspect 
ratio, dimensions, filename, etc.) and perform a step only if the characteristics match the 
setting in the step. (See “Inserting Conditionals (ImageReady)” on page 631.)

 

Easily export multiple files from selected states

 

Instantly create separate HTML pages 
for each selected state, by outputting multiple files for slices containing selected states. 
This new capability of ImageReady CS makes quick work of designing Web pages where 
different images are displayed in the same area by the state of different rollovers. 
(See “Saving selected rollover states to Web pages” on page 518.)
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Looking at the Work Area

 

Using the Welcome window

 

When you launch Photoshop or ImageReady, the Welcome window automatically 
appears. Use this window to learn about Photoshop or ImageReady by reading tutorials, 
or viewing a movie about new features. In Photoshop, you can also learn how to set up a 
color management system.

 

To use the Welcome window:

1

 

Choose Help > Welcome Screen to display the window if it’s not already open.

 

2

 

Select one of the options in the window to learn more about Photoshop or 
ImageReady.

 

Getting familiar with the work area

 

The Photoshop and ImageReady work area is arranged to help you focus on creating and 
editing images.

Photoshop work area 
A. Menu bar B. Options bar C. Toolbox D. Active image area E. Palette well F. Palettes

About the work area
The work area consists of the following components:

Menu bar The menu bar contains menus for performing tasks. The menus are organized 
by topic. For example, the Layers menu contains commands for working with layers.

A

B

F

E

D

C



Using Help | Contents | Index Back 13  

Adobe Photoshop CS Help Looking at the Work Area 

Using Help | Contents | Index Back 13  

Options bar The options bar provides options for using a tool. (See “Using the options 
bar” on page 18.)

Toolbox The toolbox holds tools for creating and editing images. (See “Using the tools” 
on page 17.)

Palette well (Photoshop) The palette well helps you organize the palettes in your work 
area. (See “Using the palette well” on page 19.)

Palettes Palettes help you monitor and modify images. (See “Using palettes” on page 21.)

Using the toolbox
The first time you start the application, the toolbox appears on the left side of the screen. 
Some tools in the toolbox have options that appear in the context-sensitive tool options 
bar. (See “Using the options bar” on page 18.) These include the tools that let you use type, 
select, paint, draw, sample, edit, move, annotate, and view images. Other tools in the 
toolbox allow you to change foreground/background colors, go to Adobe Online, work in 
different modes, and jump between Photoshop and ImageReady applications.

For more information on the foreground and background color controls, see “Choosing 
foreground and background colors” on page 351.

Toolbox overview (1 of 3)
* Photoshop only
§ ImageReady only

The marquee tools 
make rectangular, 
elliptical, single row, 
and single column 
selections.

The Move tool moves 
selections, layers, and 
guides.

The lasso tools make 
freehand, polygonal 
(straight-edged), and 
magnetic* (snap-to) 
selections.

The Magic Wand tool 
selects similarly 
colored areas.

The Crop tool trims 
images.

The Slice tool creates 
slices.

The Slice Select tool 
selects slices.

The Healing Brush 
tool* paints with a 
sample or pattern to 
repair imperfections 
in a image.
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Toolbox overview (2 of 3)
* Photoshop only 
§ ImageReady only

The Patch tool* 
repairs imperfections 
in a selected area of an 
image using a sample 
or pattern.

The Color 
Replacement tool* 
replaces a selected 
color with a new color.

The Brush tool paints 
brush strokes.

The Pencil tool paints 
hard-edged strokes.

The Clone Stamp 
tool paints with a 
sample of an image.

The Pattern Stamp 
tool* paints with part 
of an image as a 
pattern.

The History Brush 
tool* paints a copy of 
the selected state or 
snapshot into the 
current image 
window.

The Art History 
brush tool* paints 
with stylized strokes 
that simulate the look 
of different paint 
styles, using a 
selected state or 
snapshot.

The Eraser tool 
erases pixels and 
restores parts of an 
image to a previously 
saved state.

The Background 
Eraser tool* erases 
areas to transparency 
by dragging.

The Magic Eraser 
tool erases solid-
colored areas to trans-
parency with a single 
click.

The gradient tools* 
create straight-line, 
radial, angle, reflected, 
and diamond blends 
between colors.
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The Paint Bucket 
tool fills similarly 
colored areas with the 
foreground color.

The Blur tool* blurs 
hard edges in an 
image.

The Sharpen tool* 
sharpens soft edges in 
an image.

The Smudge tool* 
smudges data in an 
image.

The Dodge tool* 
lightens areas in an 
image.

The Burn tool* 
darkens areas in an 
image.

The Sponge tool* 
changes the color 
saturation of an area.

The path selection 
tools* make shape or 
segment selections 
showing anchor 
points, direction lines, 
and direction points.

The type tools create 
type on an image.

The type mask tools* 
create a selection in 
the shape of type.

The pen tools* let 
you draw smooth-
edged paths.

The Custom Shape 
tool* makes 
customized shapes 
selected from a 
custom shape list.
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Toolbox overview (3 of 3)
* Photoshop only
§ ImageReady only

The annotation 
tools* make notes 
and audio annota-
tions that can be 
attached to an image.

The Eyedropper tool 
samples colors in an 
image.

The Measure tool* 
measures distances, 
locations, and angles.

The Hand tool moves 
an image within its 
window. 

The Zoom tool 
magnifies and 
reduces the view of an 
image.

The image map 
tools§ define image 
map areas in an 
image.

The Image Map 
Select tool§ selects 
image maps.

The Toggle Image 
Map Visibility tool§ 
toggles between 
showing and hiding 
image maps.

The Toggle Slices 
Visibility tool§ 
toggles between 
showing and hiding 
slices in an image.

The Preview 
Document tool§ 
previews rollover 
effects directly in 
ImageReady.

The Preview in 
Default Browser 
tool§ previews anima-
tions in a Web 
browser.

The Tab Rectangle 
tool§ draws a long 
rectangles with the 
top corners rounded. 
The Pill Rectangle 
tool§ draws a 
rectangle with 
rounded corners.
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Using the tools
You select a tool by clicking its icon in the toolbox. A small triangle  at the lower right of a 
tool icon indicates hidden tools. Positioning the pointer over a tool displays a tool tip with 
the tool’s name and keyboard shortcut.

Using the selecting tools 
A. Toolbox B. Active tool C. Hidden tools D. Tool name E. Tool shortcut F. Hidden tool triangle

To show or hide the toolbox:

Choose Window > Tools. In the menu, a check mark indicates that the item is showing.

To move the toolbox:

Drag the toolbox by its title bar.

To select a tool:

Do one of the following:

• Click the tool’s icon. If the icon has a small triangle at its lower right corner, hold down 
the mouse button to view the hidden tools. Then, click the tool you want to select.

• Press the tool’s keyboard shortcut. The keyboard shortcut is displayed in its tool tip. 
(See “Keyboard Shortcuts” on page 656.) To cycle through hidden tools, hold down 
Shift and press the tool’s shortcut key.

To enable or disable cycling through a set of hidden tools (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• In Mac OS, choose Photoshop > Preferences > General.

2 Select or deselect Use Shift Key for Tool Switch.

To display or hide tool tips:

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > General.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General.

2 Select or deselect Show Tool Tips. 

Note: Tool tips may not be available in dialog boxes.
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Using the tool pointers
When you select most tools, the pointer matches the tool’s icon. The marquee pointer 
appears by default as cross hairs , the text tool pointer appears as an I-beam , and 
painting tools default to the Brush Size icon. 

Each default pointer has a different hotspot, where an effect or action in the image begins. 
With most tools, you can switch to precise cursors, which appear as cross hairs centered 
around the hotspot.

To set tool pointer appearance:

1 Do one of the following:

• (Photoshop) In Windows, choose Edit > Preferences > Display & Cursors.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > Display & Cursors.

• (ImageReady) In Windows, choose Edit > Preferences > Cursors.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > Cursors.

2 Choose a tool pointer setting in the Preferences screen:

• Click Standard under Painting Cursors, Other Cursors, or both to display pointers as tool 
icons.

• Click Precise under Painting Cursors, Other Cursors, or both to display pointers as cross 
hairs. 

• Click Brush Size under Painting Cursors to display the painting tool cursors as brush 
shapes representing the size of the current brush. Brush Size cursors may not display for 
very large brushes.

3 Click OK.

The Painting Cursors options control the pointers for the following tools:

• (Photoshop) Eraser, Pencil, Paintbrush, Healing Brush, Rubber Stamp, Pattern Stamp, 
Smudge, Blur, Sharpen, Dodge, Burn, and Sponge tools

• (ImageReady) Paintbrush, Pencil, and Eraser tools 

The Other Cursors options control the pointers for the following tools:

• (Photoshop) Marquee, Lasso, Polygonal Lasso, Magic Wand, Crop, Slice, Patch, 
Eyedropper, Pen, Gradient, Line, Paint Bucket, Magnetic Lasso, Magnetic Pen, Freeform 
Pen, Measure, and Color Sampler tools

• (ImageReady) Marquee, Lasso, Magic Wand, Eyedropper, Paint Bucket, and Slice tools

To toggle between standard and precise cursors in some tool pointers, press Caps 
Lock. Press Caps Lock again to return to your original setting.

Using the options bar
Most tools have options that are displayed in the options bar. The options bar is context 
sensitive and changes as different tools are selected. Some settings in the options bar are 
common to several tools (such as painting modes and opacity), and some are specific to 
one tool (such as the Auto Erase setting for the Pencil tool). 
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You can move the options bar anywhere in the work area using the gripper bar, and dock 
it at the top or bottom of the screen. Tool tips appear when you hold the pointer over a 
tool.

Lasso options bar 
A. Gripper bar B. Tool tip

To view tool options in the options bar:

Do one of the following:

• Choose Window > Options. 

• Click a tool in the toolbox.

To return a tool or all tools to the default settings:

Do one of the following:

• Click the tool icon on the options bar, and then choose Reset Tool or Reset All Tools from 
the context menu. 

• (ImageReady) In Windows, choose Edit > Preferences > General, and then click Reset All 
Tools. In Mac OS, choose ImageReady > Preferences > General, and then click Reset All 
Tools.

To move the options bar:

Drag the options bar by the gripper bar at its left edge. 

Using the palette well
The Photoshop options bar includes a palette well that helps you organize and manage 
palettes. The palette well stores, or docks, palettes that you use frequently, without having 
to keep them open on the work area.

The palette well is available only when using a screen resolution greater than 800 pixels x 
600 pixels (a setting of at least 1024 x 768 is recommended).

To dock palettes in the palette well:

Drag the palette’s tab into the palette well so that the palette well is highlighted.

Docking a palette in the palette well

A B
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To use a palette in the palette well:

Click the palette’s tab. The palette remains open until you click outside it or click in the 
palette’s tab.

Docked palette in the palette well

Using tool presets (Photoshop)
You can load, edit, and create libraries of tool presets using the Tool Preset picker in the 
options bar, the Tool Presets palette, and the Preset Manager. You can also save and reuse 
tool settings using tool presets. 

Viewing the Tool Preset picker 
A. Click the Tool Preset picker in the options bar to show the Tool Preset pop-up palette. B. Select a 
preset to change the tool’s options to the preset settings, which will apply each time you select the 
tool (until you choose Reset Tool from the palette menu). C. Uncheck to show all tool presets; check 
to show presets for only the tool selected in the toolbox.

To create a tool preset:

1 Choose a tool, and set the options you want to save as a tool preset in the options bar.

2 Click the Tool Preset button  on the left side of the options bar, or choose Window > 
Tool Presets to display the Tool Presets palette.

3 Do one of the following:

• Click the Create New Tool Preset button .

• Choose New Tool Preset from the palette menu.

4 Enter a name for the tool preset, and click OK.

To choose a tool preset:

Do one of the following:

• Click the Tool Preset picker in the options bar, and select a preset from the pop-up 
palette.

A
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• Choose Window > Tool Presets, and select a preset.

To change the list of presets in the Tool Preset pop-up palette:

Do one of the following:

• To show all loaded presets, choose Show All Tool Presets from the palette menu.

• To sort the presets by tool, choose Sort By Tool from the palette menu.

• To show only the loaded presets for the active tool, choose Show Current Tool Presets 
from the palette menu, or click the Current Tool Only button.

• To create, load, and manage libraries of tool presets, see “Using pop-up palettes” on 
page 24 and “Managing libraries with the Preset Manager (Photoshop)” on page 52.

• To change the display of presets in the pop-up palette, choose Text Only, Small Text, 
or Large Text from the palette menu.

Using palettes
Palettes help you monitor and modify images. You can choose which palettes are visible. 
By default, palettes appear stacked together in groups. You can move palette groups, 
rearrange palettes in their groups, and remove palettes from groups. 

Palettes can also be docked (see “Docking palettes together” on page 22) to keep them 
organized. 

Tips for rearranging the palette display
You can rearrange your palettes to make better use of your work area using the following 
techniques: 

• To make a palette appear at the front of its group, click the palette’s tab, or choose the 
palette name from the Window menu.

• To move an entire palette group, drag its title bar.

• To rearrange or separate a palette group, drag a palette’s tab. Dragging a palette 
outside of an existing group creates a new group. 

• To move a palette to another group, drag the palette’s tab to that group.

• To display a palette menu, position the pointer on the triangle  in the upper right 
corner of the palette, and press the mouse button.

• To change the size of a palette, drag any corner of the palette (Windows) or drag the 
size box at its lower right corner (Mac OS). Not all palettes can be resized.

• To collapse a group to palette titles only, click the Minimize/Maximize box (Windows) or 
the Zoom box (Mac OS), or double-click a palette’s tab. You can still access the menu of 
a collapsed palette.

Click to collapse or expand palette. 
A. Windows B. Mac OS 

A
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• (ImageReady) To show or hide options for palettes that include hidden options (the 
Optimize, Layer Options, and Slice palettes), click the Show Options button  on the 
palette tab to cycle through palette displays, or choose Show Options or Hide Options 
from the palette menu.

Showing and hiding palettes
Sometimes palettes take up too much screen space when you’re working on large images. 
You can easily hide them to give you more room.

To show or hide palettes:

Do one of the following:

• To show a hidden palette, choose the palette name in the Window menu (palette 
names marked with a check are showing in the work area). If the palette you chose was 
docked with other palettes, the docked group will display.

• To hide a palette, choose the palette name in the Windows menu.

• To minimize a palette, click the Minimize button.

• To show or hide all open palettes, the options bar, and the toolbox, press Tab. 

• To show or hide all palettes, press Shift+Tab.

Docking palettes together
Docking palettes together lets you view multiple palettes at the same time and move 
them as a group. Entire palette groups cannot be docked together at once, but you can 
dock the palettes from one group to another, one at a time.

In Photoshop, docked palettes and their locations are saved when you save a workspace.

In Photoshop, you can also store palettes in the palette well of the tool options bar. 
(See “Using the options bar” on page 18.)

To dock palettes together:

Drag a palette’s tab to the bottom of another palette so that the bottom of the target 
palette is highlighted. To move an entire docked group, drag its title bar.

Saving workspaces
The positions of all open palettes and movable dialog boxes are saved when you exit the 
application. By saving a screen layout as a workspace, you’ll be able to return to it, even if 
you move a palette or close the toolbox. Saved workspaces also work with the File 
Browser, allowing you to save your preferred File Browser setup.

You can assign keyboard shortcuts to each workspace so you can then flip through 
them using the keyboard (see “Customizing keyboard shortcuts” on page 54).

To save the current workspace layout:

1 Choose Window > Workspace > Save Workspace. 

2 Enter a name for the workspace, and click OK. 

To choose a workspace:

Choose Window > Workspace, and choose a workspace from the submenu.
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To delete a workspace:

1 Choose Window > Workspace > Delete Workspace. 

2 Select the workspace you want to delete, and click Delete.

To reset palettes to the default positions:

Choose Window > Workspace > Reset Palette Locations.

To save palette locations:

Do one of the following:

• In Windows, choose Edit > Preferences > General, and then select Save Palette 
Locations.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > General, and then select 
Save Palette Locations.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General, and then select 
Save Palette Locations.

To always start with the default palette and dialog box positions:

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > General.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General.

2 Deselect Save Palette Locations. The change takes effect the next time you start the 
application.

Using pop-up sliders
A number of palettes and dialog boxes contain settings that use pop-up sliders (for 
example, the Opacity option in the Layers palette). Pop-up sliders give you a lot of control 
over options. Often a text box accompanies the pop-up slider, so you can type in a specific 
value.

Using different kinds of pop-up sliders 
A. Click to open pop-up slider box. B. Drag slider or angle radius.

You can also “scrub” on pop-up sliders in several palettes. For example, if you hold the 
pointer over the word “Fill” or “Opacity” in the Layers palette, the pointer changes to 

the hand icon . Then you can move the pointer left or right to change the fill or opacity 
percentage.

A
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To use a pop-up slider:

Click the triangle next to the setting to open the pop-up slider box, and drag the slider or 
angle radius to the desired value. Click outside the slider box or press Enter or Return to 
close the slider box. To cancel changes, press the Escape key (Esc).

To increase or decrease values in 10% increments when the pop-up slider box is open, 
hold down Shift and press the Up Arrow or Down Arrow key.

Using pop-up palettes
Pop-up palettes provide easy access to available options for brushes, swatches, gradients, 
styles, patterns, contours, and shapes. You can customize pop-up palettes by renaming 
and deleting items and by loading, saving, and replacing libraries. You can also change the 
display of a pop-up palette to view items by their names, as thumbnail icons, or with both 
names and icons.

Viewing the Brush pop-up palette in the options bar 
A. Click to open the pop-up palette. B. Click to view the pop-up palette menu.

To select an item in a pop-up palette:

1 Click the thumbnail image in the options bar.

2 Click an item in the pop-up palette.

To rename an item in a pop-up palette:

Select an item, click the triangle  in the upper right corner of the pop-up palette, and 
choose the Rename command from the palette menu. Enter a new name.

To delete an item in a pop-up palette:

Do one of the following:

• Select an item, click the triangle  in the upper right corner of the pop-up palette, and 
choose the Delete command from the palette menu.

• Hold down Alt (Windows) or Option (Mac OS) and click an item.

To customize the list of items in a pop-up palette:

1 Click the triangle  in the upper right corner of the pop-up palette to view the palette 
menu. 

A B
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2 To return to the default library, choose the Reset command. You can either replace the 
current list or append the default library to the current list. 

3 To load a different library, do one of the following:

• Choose the Load command to add a library to the current list. Then select the library file 
you want to use, and click Load.

• Choose the Replace command to replace the current list with a different library. Then 
select the library file you want to use, and click Load.

• Choose a library file (displayed at the bottom of the palette menu). Then click OK to 
replace the current list, or click Append to append the current list.

4 To save the current list as a library for later use, choose the Save command. Then enter a 
name for the library file, and click Save.

(Mac OS) You can specify that a file extension is always appended to a library file by 
setting Append File Extension to Always in the File Handling Preferences. You should 

put the extension on a library filename so that you can easily share the libraries across 
operating systems.

To change the display of items in a pop-up palette:

1 Click the triangle  in the upper right corner of the pop-up palette to view the palette 
menu. 

2 Select a view option: Text Only, Small Thumbnail, Large Thumbnail, Small List, or Large 
List.

Using the Info palette 
The Info palette displays information about the color values beneath the pointer and, 
depending on the tool in use, other useful measurements. 

To display the Info palette:

Choose Window > Info.

The Info palette displays the following information:

• When displaying CMYK values, the Info palette displays an exclamation point next to 
the CMYK values if the color beneath the pointer or color sampler is out of the printable 
CMYK color gamut. (See “Identifying out-of-gamut colors (Photoshop)” on page 184.)

• When you use the Marquee tool, the Info palette displays the x- and y-coordinates of 
the pointer position and the width (W) and height (H) of the marquee as you drag. 

• When you use the Crop tool or Zoom tool, the Info palette displays the width (W) and 
height (H) of the marquee as you drag. The palette also shows the angle of rotation of 
the crop marquee.

• When you use the Line tool, Pen tool, or Gradient tool or when you move a selection, 
the Info palette displays the x- and y-coordinates of your starting position, the change 
in X (DX), the change in Y (DY), the angle (A), and the distance (D) as you drag. 

• When you use a two-dimensional transformation command, the Info palette displays 
the percentage change in width (W) and height (H), the angle of rotation (A), and the 
angle of horizontal skew (H) or vertical skew (V).
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• When you use any color adjustment dialog box (for example, Curves), the Info palette 
displays the before and after color values of the pixels beneath the pointer and beneath 
color samplers. (See “Viewing the color values of pixels (Photoshop)” on page 181.)

(ImageReady) The Info palette displays the following information:

• The RGB numeric values for the color beneath the pointer.

• The Opacity value for the pixels beneath the pointer

• The hexadecimal value for the color beneath the pointer

• The index color table position for the color beneath the pointer

• The x- and y-coordinates of the pointer

• The x- and y-coordinates of your starting position (before you click in the image) and 
your ending position (as you drag in the image) when you use the Marquee tool, the 
shape tools, the Crop tool, and the Slice tool

• The width (W) and height (H) of the selection as you drag when you use the Crop tool, 
the shape tools, the Slice tool, or the Zoom tool

• The percentage change in width (W) and height (H), the angle of rotation (A), and the 
angle of horizontal skew (H) or vertical skew (V) when you use a Transform or Free 
Transform command

To change the Info palette options:

1 Choose Palette Options from the Info palette menu.

2 For First Color Readout, choose one of the following display options:

• Actual Color to display values in the current color mode of the image.

• Total Ink to display the total percentage of all CMYK ink at the pointer’s current location, 
based on the values set in the CMYK Setup dialog box.

• Opacity to display the opacity of the current layer. This option does not apply to the 
background.

• Any other option to display the color values in that color mode.

3 For Second Color Readout, choose a display option listed in step 2.

4 For Ruler Units, choose a unit of measurement.

5 If you want to see values for 16-bit images, select Show 16 bit values.

6 Click OK.

To change measurement units, click the crosshair icon in the Info palette for a menu of 
options. To change color readout modes, click the eyedropper icon.
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Using context menus
In addition to the menus at the top of your screen, context menus display commands 
relevant to the active tool, selection, or palette.

Viewing the context menu for using the Eyedropper tool

To display context menus:

1 Position the pointer over an image or palette item.

2 Click with the right mouse button (Windows) or Control-click  (Mac OS). The context 
menu appears where you clicked.

Viewing images
You can change the screen display mode to change the appearance of the Photoshop or 
ImageReady work area. The Hand tool, the zoom tools, the Zoom commands, and the 
Navigator palette let you view different areas of an image at different magnifications. You 
can open additional windows to display several views at once (such as different magnifica-
tions) of an image. 

Changing the screen mode
You can use the screen mode options to view your images on your entire screen. You can 
show or hide the menu bar, title bar, and scroll bars. You can choose from the following: 

• The Standard screen mode is the default view, with menu bars, scrolls bars, and other 
screen elements visible. 

• Full Screen with Menu Bar view enlarges your view of an image but keeps the menu 
bar in view.
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• Full Screen mode allows you to move the image around the screen to view different 
areas.

Dragging an image in Full Screen mode

To change the screen display mode:

Do one of the following:

• To display the default window, with the menu bar at the top and scroll bars on the side, 
choose View > Screen Mode > Standard, or click the Standard button  in the toolbox. 

• To display a full-screen window with a menu bar and a 50% gray background, but no 
title bar or scroll bars, choose View > Screen Mode > Full Screen with Menu Bar view, or 
click the Full Screen with Menu Bar button  in the toolbox. 

• To display a full-screen window with only a black background (no title bar, menu bar, or 
scroll bars), choose View > Screen Mode > Full Screen, or click the Full Screen button  
in the toolbox.

Viewing multiple images 
The document window is where your images appear. You can open multiple windows to 
display different views of the same file. A list of open windows appears in the Window 
menu. Available memory may limit the number of windows per image. 

In Photoshop, you can use the Hand tool’s Scroll All Windows option to scroll through 
all open images. Select it in the options bar and drag in one image to scroll through all 

visible images.

In ImageReady, the document window allows you to switch easily between original and 
optimized views of an image using tabs, and to view the original image and multiple 
versions of an optimized image simultaneously.

To view other open images:

Choose the file name from the bottom of the Windows menu.
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To open multiple views of the same image:

Do one of the following:

• Choose Window > Documents > New Window. 

• (ImageReady) Drag any tab away from the document window.

To arrange multiple windows:

Do one of the following:

• Choose Window > Documents > Cascade to display windows stacked and cascading 
from the upper left to the lower right of the screen.

• Choose Window > Documents > Tile to display windows edge to edge.

To zoom in or out on multiple images (Photoshop):

1 Open one or more images, or copies of a single image.

2 Choose Window > Arrange > Tile to display the images edge to edge.

3 Select the Zoom tool, and then do one of the following:

• Select Zoom All Windows in the options bar, and then click in one of the images. The 
other images zoom in or out at the same magnification.

• Choose Window > Arrange > Match Zoom. Hold Shift and click on one of the images. 
The other images zoom in or out at the same magnification.

To match the location between images (Photoshop):

1 Open one or more images, or multiple copies of a single image.

2 Choose Window > Arrange > Tile.

3 Select the Hand tool, and then do one of the following:

• Select Scroll All Windows in the options bar, and then click an area in one of the images. 
The other images snap to the corresponding area.

• Choose Window > Arrange > Match Location. Hold Shift and click an area of an image. 
The other images snap to the corresponding area.

To match the zoom and location between images (Photoshop):

1 Open one or more images, or multiple copies of a single image.

2 Choose Window > Arrange > Tile.
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3 Choose Window > Arrange > Match Zoom and Location.

Without Match Zoom and Location (left), and after Match Zoom and Location selected (right)

4 Select the Zoom tool  or the Hand tool .

5 Select one of the images, and then choose Window > Arrange > Match Zoom and 
Location.

6 Hold Shift and click an area of an image. The other images magnify to the same 
percentage, and snap to the corresponding area you clicked.

To close windows:

Choose a command:

• Choose File > Close to close the active window.

• Choose File > Close All to close all windows.

Navigating the view area
If the entire image is not visible in the document window, you can navigate to bring 
another area of the image into view.

In Photoshop, you can also use the Navigator palette to quickly change the view of an 
image.

To view another area of an image:

Do one of the following:

• Use the window scroll bars.
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• Select the Hand tool  and drag to pan over the image.

Dragging the Hand tool to view another area of an image

To use the Hand tool while another tool is selected, hold down the spacebar as you 
drag in the image.

To move the view of an image using the Navigator palette (Photoshop):

1 Choose Window > Navigator.

2 Do one of the following:

• Drag the view box in the thumbnail of the image, which represents the boundaries of 
the image window.

• Click in the thumbnail of the image. The new view includes the area you click. 

To change the color of the Navigator palette view box (Photoshop):

1 Choose Palette Options from the Navigator palette menu.

2 Choose a color:

• To use a preset color, choose an option for Color.

• To specify a different color, click the color box, and choose a color.

Magnifying and reducing the view
You can magnify or reduce your view using various methods. The window’s title bar 
displays the zoom percentage (unless the window is too small for the display to fit), as 
does the status bar at the bottom of the window. 

Note: The 100% view of an image displays an image as it will appear in a browser (based 
on the monitor resolution and the image resolution). (See “Understanding image size and 
resolution” on page 62.)

To zoom in:

Do one of the following:

• Select the Zoom tool . The pointer becomes a magnifying glass with a plus sign  in 
its center. Click the area you want to magnify. Each click magnifies the image to the 
next preset percentage, centering the display around the point you click. When the 
image has reached its maximum magnification level of 1600%, the magnifying glass 
appears empty.
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• (Photoshop) Click the Zoom In button  in the options bar to magnify to the next 
preset percentage. When the image has reached its maximum magnification level, the 
command is dimmed.

• Choose View > Zoom In to magnify to the next preset percentage. When the image has 
reached its maximum magnification level, the command is dimmed.

• (Photoshop) Enter a magnification level in the Zoom text box at the lower left of the 
window.

• (ImageReady) Click the Zoom Level pop-up menu at the bottom left of the document 
window, and choose a zoom level.

To zoom out:

Do one of the following:

• Select the Zoom tool. Hold down Alt (Windows) or Option (Mac OS) to activate 
the Zoom Out tool. The pointer becomes a magnifying glass with a minus sign in its 
center . Click the center of the area of the image you want to reduce. Each click 
reduces the view to the previous preset percentage. When the file has reached its 
maximum reduction level, the magnifying glass appears empty.

• Click the Zoom Out button  in the options bar to reduce to the previous preset 
percentage. When the image has reached its maximum reduction level, the command 
is dimmed.

• Choose View > Zoom Out to reduce to the previous preset percentage. When the image 
reaches its maximum reduction level, the command is dimmed.

• (Photoshop) Enter a reduction level in the Zoom text box at the lower left of the 
window.

• (ImageReady) Click the Zoom Level pop-up menu at the lower left of the document 
window, and choose a zoom level.

To magnify by dragging:

1 Select the Zoom tool.

2 Drag over the part of the image you want to magnify.

Dragging the Zoom tool to magnify the view of an image

The area inside the zoom marquee is displayed at the highest possible magnification. To 
move the marquee around the artwork in Photoshop, begin dragging a marquee and then 
hold down the spacebar while dragging the marquee to a new location.
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To display an image at 100%:

Do one of the following:

• Double-click the Zoom tool.

• Choose View > Actual Pixels (Photoshop) or View > Actual Size (ImageReady).

To change the view to fit the screen:

Do one of the following:

• Double-click the Hand tool. 

• Choose View > Fit on Screen.

These options scale both the zoom level and the window size to fit the available screen 
space.

To automatically resize the window when magnifying or reducing the view:

With the Zoom tool active, select Resize Windows to Fit in the options bar. The window 
resizes when you magnify or reduce the view of the image.

When Resize Windows to Fit is deselected (the default), the window maintains a constant 
size regardless of the image’s magnification. This can be helpful when using smaller 
monitors or working with tiled views.

To automatically resize the window when zooming in or out using keyboard 
shortcuts (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• In Mac OS, choose Photoshop > Preferences > General.

2 Select Keyboard Zoom Resizes Windows.

Correcting mistakes
Most operations can be undone if you make a mistake. Alternatively, you can restore all or 
part of an image to its last saved version. But available memory may limit your ability to 
use these options.

For information on how to restore your image to how it looked at any point in the current 
work session, see “About the History palette” on page 34.

To undo the last operation:

Choose Edit > Undo. 

If an operation can’t be undone, the command is dimmed and changes to Can’t Undo.

To redo the last operation:

Choose Edit > Redo.

You can set the Redo keystroke preference to be the same for Photoshop and 
ImageReady. In the General area of the Preferences dialog box, select a preference for 

the Redo key. You can also set the key to toggle between Undo and Redo.
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To free memory used by the Undo command, the History palette, or the Clipboard 
(Photoshop):

Choose Edit > Purge, and choose the item type or buffer you want to clear. If already 
empty, the item type or buffer is dimmed. 

Important: The Purge command permanently clears from memory the operation stored 
by the command or buffer; it cannot be undone. For example, choosing Edit > Purge > 
Histories deletes all history states from the History palette. Use the Purge command when 
the amount of information held in memory is so large that Photoshop’s performance is 
noticeably diminished.

To revert to the last saved version: 

Choose File > Revert.

Note: Revert is added as a history state in the History palette and can be undone.

To restore part of an image to its previously saved version (Photoshop):

Do one of the following:

• Use the History Brush tool  to paint with the selected state or snapshot on the History 
palette. (See “Painting with a state or snapshot of an image (Photoshop)” on page 38.)

• Use the Eraser tool  with the Erase to History option selected. (See “Using the Eraser 
tool” on page 335.)

• Select the area you want to restore, and choose Edit > Fill. For Use, choose History, 
and click OK. (See “Filling and stroking selections and layers” on page 344.)

Note: To restore the image with a snapshot of the initial state of the document, choose 
History Options from the Palette menu and make sure that the Automatically Create First 
Snapshot option is on. 

About the History palette
The History palette lets you jump to any recent state of the image created during the 
current working session. Each time you apply a change to an image, the new state of that 
image is added to the palette.

For example, if you select, paint, and rotate part of an image, each of those states is listed 
separately in the palette. You can then select any of the states, and the image will revert to 
how it looked when that change was first applied. You can then work from that state.

Tips for using the History palette
Note the following guidelines when using the History palette:

• Program-wide changes, such as changes to palettes, color settings, actions, and prefer-
ences, are not changes to a particular image and so are not added to the History 
palette.

• By default, the History palette lists the previous 20 states (Photoshop), or 32 states 
(ImageReady). You can always change the number of states in Preferences. Older states 
are automatically deleted to free more memory for Photoshop. To keep a particular 
state throughout your work session, make a snapshot of the state. For more infor-
mation, see “Making a snapshot of an image (Photoshop)” on page 37.
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• Once you close and reopen the document, all states and snapshots from the last 
working session are cleared from the palette.

• By default, a snapshot of the initial state of the document is displayed at the top of the 
palette. 

• States are added from the top down. That is, the oldest state is at the top of the list, the 
most recent one at the bottom.

• Each state is listed with the name of the tool or command used to change the image.

• By default, selecting a state dims those below. This way you can easily see which 
changes will be discarded if you continue working from the selected state. For infor-
mation on customizing the history options, see “Setting history options (Photoshop)” 
on page 36.

• By default, selecting a state and then changing the image eliminates all states that 
come after.

• If you select a state and then change the image, eliminating the states that came after, 
you can use the Undo command to undo the last change and restore the eliminated 
states. 

• By default, deleting a state deletes that state and those that came after it. If you choose 
the Allow Non-Linear History option, deleting a state deletes just that state. For more 
information, see “Setting history options (Photoshop)” on page 36.

Using the History palette
You can use the History palette to revert to a previous state of an image, to delete an 
image’s states, and (in Photoshop) to create a document from a state or snapshot.

Photoshop History palette 
A. Sets the source for the history brush B. Thumbnail of a snapshot C. History state
D. History state slider

To display the History palette:

Choose Window > History, or click the History palette tab.

To revert to a previous state of an image:

Do any of the following:

• Click the name of the state.

• Drag the slider  at the left of the state up or down to a different state.

A
B

C

D
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• (Photoshop) Choose Step Forward or Step Backward from the palette menu or the Edit 
menu to move to the next or previous state.

To delete one or more states of the image (Photoshop):

Do one of the following:

• Click the name of the state, and choose Delete from the History palette menu to delete 
that change and those that came after it.

• Drag the state to the Trash button  to delete that change and those that came after it.

• Choose Clear History from the palette menu to delete the list of states from the History 
palette, without changing the image. This option doesn’t reduce the amount of 
memory used by Photoshop.

• Hold down Alt (Windows) or Option (Mac OS), and choose Clear History from the 
palette menu to purge the list of states from the History palette without changing the 
image. If you get a message that Photoshop is low on memory, purging states is useful, 
since the command deletes the states from the Undo buffer and frees up memory. You 
can’t undo the Clear History command.

• Choose Edit > Purge > Histories to purge the list of states from the History palette for all 
open documents. You can’t undo this action.

To delete all of an image’s states (ImageReady):

Choose Clear Undo/Redo History from the History palette menu. 

Important: This action cannot be undone.

To create a new document from the selected state or snapshot of the image 
(Photoshop):

Do one of the following:

• Drag a state or snapshot onto the New Document button .

• Select a state or snapshot, and click the New Document button.

• Select a state or snapshot, and choose New Document from the History palette menu.

The history list for the newly created document will be empty.

To save one or more snapshots or image states for use in a later editing session, create 
a new file for each state you save, and save each in a separate file. When you reopen 

your original file, plan to open the other saved files also. You can drag each file’s initial 
snapshot to the original image and thus access the snapshots again from the original 
image’s History palette.

To replace an existing document with a selected state (Photoshop):

Drag the state onto the document.

Setting history options (Photoshop)
You can specify the maximum number of items to include in the History palette and set 
other options that customize the way you work with the palette.

To set history options:

1 Choose History Options from the History palette menu.
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2 Select an option:

• Automatically Create First Snapshot to automatically create a snapshot of the initial 
state of the image when the document is opened.

• Automatically Create New Snapshot When Saving to generate a snapshot every time 
you save.

• Allow Non-Linear History to make changes to a selected state without deleting the 
states that come after. Normally, when you select a state and change the image, all 
states that come after the selected one are deleted. This enables the History palette to 
display a list of the editing steps in the order you made them. By recording states in a 
nonlinear way, you can select a state, make a change to the image, and delete just that 
state. The change will be appended at the end of the list. 

• Show New Snapshot Dialog By Default to force Photoshop to prompt you for snapshot 
names even when using the buttons on the palette.

Making a snapshot of an image (Photoshop)
The Snapshot command lets you make a temporary copy (or snapshot) of any state of the 
image. The new snapshot is added to the list of snapshots at the top of the History palette. 
Selecting a snapshot lets you work from that version of the image. 

Snapshots are similar to the states listed in the History palette, but they offer additional 
advantages:

• You can name a snapshot to make it easy to identify.

• Snapshots can be stored for an entire work session.

• You can compare effects easily. For example, you can take a snapshot before and after 
applying a filter. Then select the first snapshot, and try the same filter with different 
settings. Switch between the snapshots to find the settings you like best.

• With snapshots, you can recover your work easily. When you experiment with a 
complex technique or apply an action, take a snapshot first. If you’re not satisfied with 
the results, you can select the snapshot to undo all the steps.

Important: Snapshots are not saved with the image—closing an image deletes its 
snapshots. Also, unless you select the Allow Non-Linear History option, selecting a 
snapshot and changing the image deletes all of the states currently listed in the History 
palette.

To create a snapshot:

1 Select a state.

2 To automatically create a snapshot, click the New Snapshot button  on the History 
palette, or if Automatically Create New Snapshot When Saving is selected in the history 
options, choose New Snapshot from the History palette menu. 

3 To set options when creating a snapshot, choose New Snapshot from the History 
palette menu, or Alt-click (Windows) or Option-click (Mac OS) the New Snapshot button.

4 Enter the name of the Snapshot in the Name text box.

5 For From, select the snapshot contents:

• Full Document to make a snapshot of all layers in the image at that state

• Merged Layers to make a snapshot that merges all layers in the image at that state
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• Current Layer to make a snapshot of only the currently selected layer at that state

To select a snapshot:

Do any of the following:

• Click the name of the snapshot.

• Drag the slider at the left of the snapshot up or down to a different snapshot.

To rename a snapshot:

Double-click the snapshot and enter a name.

To delete a snapshot:

Do one of the following:

• Select the snapshot, and choose Delete from the palette menu.

• Select the snapshot, and click the Trash button .

• Drag the snapshot to the Trash button.

Painting with a state or snapshot of an image (Photoshop)
The History Brush tool lets you paint a copy of one state or snapshot of an image into the 
current image window. This tool makes a copy, or sample, of the image and then paints 
with it.

For example, you might make a snapshot of a change you made with a painting tool or 
filter (with the Full Document option selected when you create the snapshot). After 
undoing the change to the image, you could use the History Brush tool to apply the 
change selectively to areas of the image. Unless you select a merged snapshot, the History 
Brush tool paints from a layer in the selected state to the same layer in another state.

The History Brush tool copies from one state or snapshot to another, but only at the same 
location. In Photoshop, you can also paint with the art history brush to create special 
effects. (See “Using the Art History Brush tool (Photoshop)” on page 315.)

To paint with a state or snapshot of an image:

1 Select the History Brush tool .

2 Do one of the following in the options bar:

• Specify the opacity and blending mode. (See “Setting options for painting and editing 
tools” on page 331.)

• Choose a brush and set brush options. (See “Working with brushes” on page 317.)

3 In the History palette, click the left column of the state or snapshot to use as the source 
for the History Brush tool.

4 Drag to paint with the History Brush tool.

Working with the Edit History Log
If you need to keep careful track of what’s been done to a file in Photoshop, either for your 
own records, client records, or legal purposes, the Edit History Log keeps a textual history 
of what has been done to an image. You can view the Edit History Log metadata using the 
File Browser or the File Info dialog box (see “Adding metadata to files” on page 99). 
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You can choose to export the text either in an external log file, or you can store the infor-
mation in the metadata of edited files. Logging many editing operations into a file’s 
metadata can increase file size and slow the opening and saving of the file. 

If you need to be able to prove that the log file hasn’t been tampered with, keep the 
edit log in the file’s metadata, and then use Adobe Acrobat to digitally sign the log file.

To set Edit History Log options:

1 In Windows, choose Edit > Preferences > General. In Mac OS, choose Photoshop > 
Preferences > General.

2 In the History Log Options pane, choose one of the following options:

• Metadata to store entries in the metadata of each image.

• Text File to export the text into an external file. You’ll be prompted to name the log file 
and choose the location on your computer where you want to store the file.

• Both to store metadata in the file, and create a text file.

3 From the Edit Log items pop-up menu, choose one of the following options:

• Sessions to include entries for each time Photoshop is launched or exited, and each 
time files are opened and closed (each image’s file name is included).

• Concise to include the text that appears in the history palette in addition to the 
Sessions information.

• Detailed to include the text that appears in the actions palette in addition to the 
Concise information. Choose Detailed if you need to keep a complete history of what 
has been done to files.

• None to turn off the log.

To save the Edit History Log:

1 In Windows, choose Edit > Preferences > General. In Mac OS, choose Photoshop > 
Preferences > General.

2 In the History Log Options pane, click the Choose button.

3 Choose the location where you want to save the log, and then click OK.

Duplicating images
You can duplicate an entire image (including all layers, layer masks, and channels) into 
available memory without saving to disk. In ImageReady, you can also duplicate optimized 
versions of an image.

Using duplicates in ImageReady lets you experiment and then compare several 
versions of the optimized image to the original.

To duplicate an image (Photoshop):

1 Open the image you want to duplicate.

2 Choose Image > Duplicate.

3 Enter a name for the duplicated image.



Using Help | Contents | Index Back 40  

Adobe Photoshop CS Help Looking at the Work Area 

Using Help | Contents | Index Back 40  

4 If you want to duplicate the image without merging the layers, select Duplicate Merged 
Layers Only.

5 Click OK.

To duplicate an image in Photoshop and automatically append the name “copy” to its 
filename, hold down Alt (Windows) or Option (Mac OS) when you choose Image > 

Duplicate.

To duplicate an original image (ImageReady):

1 Open the image you want to duplicate.

2 Select the Original tab at the top of the image window. 

3 Hold down Alt (Windows) or Option (Mac OS), and drag the Original tab from the image 
window, or choose Image > Duplicate.

4 Name the duplicate, specify whether to flatten the layers, and click OK.

To duplicate an optimized image (ImageReady):

1 Open the image you want to duplicate.

2 Select the Optimized tab at the top of the image window. 

3 Hold down Alt (Windows) or Option (Mac OS), and drag the Optimized tab from the 
image window, or choose Image > Duplicate Optimized.

4 Name the duplicate, and click OK.

Note: When you duplicate an image in Optimized, 2-Up, or 4-Up view, the duplicate image 
appears in the Original view in the duplicate image window. If you want a duplicate 
optimized image to appear in the Optimized, 2-Up, or 4-Up view, duplicate the original 
image, and then select the Optimized, 2-Up, or 4-Up tab in the duplicate image window.

Using rulers, columns, the Measure tool, guides, 
and the grid
Rulers, columns, the Measure tool, guides, and the grid help you position images or 
elements precisely across the width or length of an image.

Note: You can also align and distribute parts of an image using the Layers palette. 
(See “Aligning layers” on page 378.)

Using rulers
When visible, rulers appear along the top and left side of the active window. Markers in the 
ruler display the pointer’s position when you move it. Changing the ruler origin (the (0, 0) 
mark on the top and left rulers) lets you measure from a specific point on the image. The 
ruler origin also determines the grid’s point of origin.

To display or hide rulers:

Choose View > Rulers.
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To change the rulers’ zero origin:

1 To snap the ruler origin to guides, slices, or Document bounds, choose View > Snap To, 
then choose any combination of options from the submenu. (See “Using the Snap 
command” on page 246.)

(Photoshop) You can also snap to a grid in addition to guides, slices, and Document 
bounds.

2 Position the pointer over the intersection of the rulers in the upper left corner of the 
window, and drag diagonally down onto the image. A set of cross hairs appears, marking 
the new origin on the rulers.

To make the ruler origin snap to the ruler ticks (Photoshop), hold down Shift as you drag. 

Note: To reset the ruler origin to its default value, double-click the upper left corner of the 
rulers.

Dragging to create new ruler origin and result

To change the rulers’ settings (Photoshop):

1 Do one of the following:

• Double-click a ruler. 

• In Windows, choose Edit > Preferences > Units & Rulers.

• In Windows, right-click the ruler and then choose a new unit from the context menu.

• In Mac OS, choose Photoshop > Preferences > Units & Rulers.

2 For Rulers, choose a unit of measurement.

Note: Changing the units on the Info palette automatically changes the units on the 
rulers. 

3 For Point/Pica Size, choose from the following options:

• PostScript (72 points per inch) if you are printing to a PostScript device.

• Traditional to use printer’s 72.27 points per inch.

4 Click OK.

Using columns (Photoshop)
The New, Image Size, and Canvas Size commands let you specify image width in terms of 
columns. Using columns is convenient when you plan to import an image into a page 
layout program, such as Adobe InDesign®, and you want the image to fit exactly within a 
certain number of columns.
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To specify columns for an image:

1 Do one of the following:

• In Windows, choose Edit > Preferences > Units & Rulers.

• In Mac OS, choose Photoshop > Preferences > Units & Rulers.

2 Enter values for Width and Gutter.

Using the Measure tool (Photoshop)
The Measure tool calculates the distance between any two points in the work area. When 
you measure from one point to another, a nonprinting line is drawn and the options bar 
and Info palette show the following information:

• The starting location (X and Y)

• The horizontal (W) and vertical (H) distances traveled from the x- and y-axes

• The angle measured relative to the axis (A)

• The total distance traveled (D1)

• The two distances traveled (D1 and D2), when you use a protractor

All measurements except the angle are calculated in the unit of measure currently set in 
the Units & Rulers preference dialog box. For information on setting the unit of measure, 
see “Using rulers” on page 40.

To display an existing measuring line:

Select the Measure tool .

To measure between two points:

1 Select the Measure tool .

2 Drag from the starting point to the ending point. Hold down the Shift key to constrain 
the tool to multiples of 45°.

3 To create a protractor from an existing measuring line, Alt-drag (Windows) or Option-
drag (Mac OS) at an angle from one end of the measuring line, or double-click the line and 
drag. Hold down the Shift key to constrain the tool to multiples of 45°.

To edit a measuring line or protractor:

1 Select the Measure tool .

2 Do one of the following:

• To resize the line, drag one end of an existing measuring line. 

• To move the line, place the pointer on the line away from either endpoint, and drag 
the line.

• To remove the line, place the pointer on the line away from either endpoint, and drag 
the line out of the image.

Note: You can drag out a measure line on an image feature that should be horizontal 
or vertical, and then choose Image > Rotate Canvas > Arbitrary. The correct angle of 
rotation required to straighten the image will already be entered into the Rotate Canvas 
dialog box.
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Using guides and the grid
Guides appear as lines that float over the entire image and do not print. You can move, 
remove, or lock a guide to avoid accidentally moving it. 

The grid is useful for laying out elements symmetrically. The grid appears by default as 
nonprinting lines but can also be displayed as dots. 

Guides and grids behave in similar ways:

• Selections, selection borders, and tools snap to a guide or the grid when dragged 
within 8 screen (not image) pixels. Guides also snap to the grid when moved. You can 
turn this feature on and off. 

• Guide spacing, along with guide and grid visibility and snapping, is specific to an image.

• Grid spacing, along with guide and grid color and style, is the same for all images. 

In ImageReady, you can use Smart Guides to help align shapes, slices, and selections. They 
appear automatically when you draw a shape, or create a selection or slide. You can hide 
Smart Guides if you need to.

To show or hide a grid or guides:

Do one of the following:

• (Photoshop) Choose View > Show > Grid. 

• Choose View > Show > Guides.

• Choose View > Extras. This command also shows or hides (Photoshop) selection edges, 
target path, slices, and notes, or (ImageReady) selection edges, slices, image maps, text 
bounds, text baseline, and text selection. (See “Working with Extras” on page 45.)

To place a guide:

1 If the rulers are not visible, choose View > Rulers.

Note: For the most accurate readings, view the image at 100% magnification or use the 
Info palette.

2 Create a guide:

• (Photoshop) Choose View > New Guide. In the dialog box, select Horizontal or Vertical 
orientation, enter a position, and click OK.

• (ImageReady) Choose View > Create Guides. In the dialog box, specify guide options 
and click OK.

• Drag from the horizontal ruler to create a horizontal guide.

Dragging to create a horizontal guide
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• Hold down Alt (Windows) or Option (Mac OS), and drag from the vertical ruler to create 
a horizontal guide.

• Drag from the vertical ruler to create a vertical guide.

• Hold down Alt (Windows) or Option (Mac OS), and drag from the horizontal ruler to 
create a vertical guide.

• (Photoshop) Hold down Shift and drag from the horizontal or vertical ruler to create a 
guide that snaps to the ruler ticks.

The pointer changes to a double-headed arrow  when you drag a guide.

To move a guide:

1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to 
activate the Move tool. (This option does not work with the Hand tool  or the Slice 
tool .)

2 Position the pointer over the guide (the pointer turns into a double-headed arrow).

3 Move the guide in any of the following ways:

• Drag the guide to move it. 

• Change the guide from horizontal to vertical, or vice versa, by holding down Alt 
(Windows) or Option (Mac OS) as you click or drag the guide.

• (Photoshop) Align the guide with the ruler ticks by holding down Shift as you drag the 
guide. The guide will snap to the grid if the grid is visible and View > Snap To > Grid is 
selected.

To lock all guides:

Choose View > Lock Guides.

To remove guides from the image:

Do one of the following:

• To remove a single guide, drag the guide outside the image window.

• To remove all guides, choose View > Clear Guides.

To hide Smart Guides (ImageReady):

View > Show > Smart Guides.

To turn snapping to guides on or off:

Choose View > Snap To > Guides. (See “Using the Snap command” on page 246.)

To turn snapping to the grid on or off:

Choose View > Snap To > Grid. (See “Using the Snap command” on page 246.)

To set guide and grid preferences (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Guides, Grid, & Slices.

• In Mac OS, choose Photoshop > Preferences > Guides, Grid, & Slices.

2 For Color, choose a color for the guides, the grid, or both. If you choose Custom, click 
the color box, choose a color, and click OK. (See “Using the Color palette” on page 353.)
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3 For Style, choose a display option for guides or the grid, or both.

4 For Gridline Every, enter a value for the grid spacing. For Subdivisions, enter a value to 
subdivide the grid. 

If desired, change the units for this option. The Percent option creates a grid that divides 
the image into even sections. For example, choosing 25 for the Percent option creates an 
evenly divided 4-by-4 grid.

5 Click OK.

Working with Extras
Guides, grid, target paths, selection edges, slices, image maps, text bounds, text baselines, 
text selections, and annotations are nonprinting Extras that help you select, move, or edit 
images and objects. You can turn on or off an Extra or any combination of Extras without 
affecting the image. You can also show or hide Extras by choosing the Extras command in 
the View menu.

To show Extras:

Choose View > Extras. A check mark appears next to all shown Extras in the Show 
submenu.

Note: Choosing Extras also shows color samplers, even though color samplers are not an 
option in the Show submenu.

To hide Extras:

With Extras showing, choose View > Extras. A dot (Windows) or a dash (Mac OS) appears 
next to all hidden Extras in the Show submenu. 

Note: Hiding only suppresses the display of Extras. It does not turn off these options.

To show one Extra from a list of hidden Extras:

Choose View > Show and choose an Extra from the submenu. Choosing one of the hidden 
Extras will cause it to show, and turn off all other Extras.

To turn on and off a group of Extras:

Choose View > Show > All to turn on and show all available Extras. Choose View > Show > 
None to turn off all Extras.

Displaying status information (Photoshop)
The status bar at the bottom of the window displays useful information—such as the 
current magnification and file size of the active image, and brief instructions for using the 
active tool.

To show or hide the status bar (Windows only):

Choose Window > Status Bar. A check mark indicates the item is showing.
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Displaying file and image information
Information about the current file size and other features of the image is displayed at the 
bottom of the application window (Windows) or document window (Mac OS).

Note: In ImageReady, if the document window is wide enough, two image information 
boxes appear, enabling you to view two different information options for the image at the 
same time. For more information about original and optimized images, see “ Viewing 
optimized images (ImageReady)” on page 535.

You can also view copyright and authorship information that has been added to the file. 
This information includes standard file information and Digimarc® watermarks. Photoshop 
automatically scans opened images for watermarks using the Digimarc Detect Watermark 
plug-in. If a watermark is detected, Photoshop displays a copyright symbol in the image 
window’s title bar and updates the Copyright & URL area of the File Info dialog box.

To display file information in the document window (Photoshop):

1 Click the triangle in the bottom border of the application window (Windows) or 
document window (Mac OS).

Illustration of file information view options in Photoshop

2 Select a view option:

• Document Size to display information on the amount of data in the image. The number 
on the left represents the printing size of the image—approximately the size of the 
saved, flattened file in Adobe Photoshop format. The number on the right indicates the 
file’s approximate size including layers and channels. 

• Document Profile to display the name of the color profile used by the image.

• Document Dimensions to display the dimensions of the image.

• Scratch Sizes to display information on the amount of RAM and scratch disk used to 
process the image. The number on the left represents the amount of memory that is 
currently being used by the program to display all open images. The number on the 
right represents the total amount of RAM available for processing images.

• Efficiency to display the percentage of time actually doing an operation instead of 
reading or writing the scratch disk. If the value is below 100%, Photoshop is using the 
scratch disk and, therefore, is operating more slowly.

• Timing to display the amount of time it took to complete the last operation.

• Current Tool to view the name of the active tool.
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To display image information in the document window (ImageReady):

1 Click an image information box at the bottom of the document window.

2 Select a view option:

• Original/Optimized File Size to view the original and optimized file size images. The first 
value indicates the original image file size. The second value (present if the original 
image has been optimized) indicates the optimized image file size and file format 
based on the current settings in the Optimize palette. 

• Optimized Information to view the file format, file size, number of colors, and dither 
percentage for the optimized image.

• Image Dimensions to view the image’s pixel dimensions.

• Watermark Strength to view the strength of the Digimarc digital watermark in the 
optimized image, if present. (See “Adding digital copyright information” on page 590.)

• Undo/Redo Status to view the number of undos and redos that are available for the 
image.

• Original in Bytes to view the size of the original, flattened image expressed in bytes.

• Optimized in Bytes to view the size of the optimized image expressed in bytes.

• Optimized Savings to view the percentage of the optimized image file size reduction, 
followed by the difference in bytes between the original and optimized sizes.

• Size/Download Time to view the file size for the optimized image and estimated 
download time using the selected modem speed.

Note: Download times may vary based on Internet traffic and modem compression 
schemes. The value displayed is an approximation.

To view additional file information:

Choose File > File Info. 

To read a Digimarc watermark:

1 Choose Filter > Digimarc > Read Watermark. If the filter finds a watermark, a dialog box 
displays the Creator ID, copyright year (if present), and image attributes.

2 Click OK, or for more information, choose from the following:

• If you have a Web browser installed, click Web Lookup to get more information about 
the owner of the image. This option launches the browser and displays the Digimarc 
Web site, where contact details appear for the given Creator ID.

• Call the phone number listed in the Watermark Information dialog box to get infor-
mation faxed back to you.
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Annotating images (Photoshop)
You can attach note annotations (notes) and audio annotations to an image in Photoshop. 
This is useful for associating review comments, production notes, or other information 
with the image. Because Photoshop annotations are compatible with Adobe Acrobat, you 
can use them to exchange information with Acrobat users as well as Photoshop users.

To circulate a Photoshop document for review in Acrobat, save the document in 
Portable Document Format (PDF) and ask reviewers to use Acrobat to add notes or 

audio annotations. Then import the annotations into Photoshop.

Notes and audio annotations appear as small nonprintable icons on the image. They are 
associated with a location on the image rather than with a layer. You can hide and show 
annotations, open notes to view or edit their contents, and play audio annotations. You 
can also add audio annotations to actions, and set them to play during an action or during 
a pause in an action. (See “Setting playback options (Photoshop)” on page 637.)

Adding notes and audio annotations
You can add notes and audio annotations anywhere on a Photoshop image canvas. 
When you create a note, a resizable window appears for typing text. When you record an 
audio annotation, you must have a microphone plugged into the audio-in port of your 
computer. 

You can import both kinds of annotations from Photoshop documents saved in PDF or 
from Acrobat documents saved in PDF or Form Data Format (FDF).

To create a note:

1 Select the Notes tool .

2 Set options as needed:

• Enter an author name. The name appears in the title bar of the notes window. 

• Choose a font and size for the note text.

• Select a color for the note icon and the title bar of note windows.

3 Click where you want to place the note, or drag to create a custom-sized window. 

4 Click inside the window, and type the text. If you type more text than fits in the note 
window, the scroll bar becomes active. 

Edit the text as needed:

• You can use the standard editing commands for your system (Undo, Cut, Copy, Paste, 
and Select All). In Windows, right-click in the text area and choose the commands from 
the context menu. In Mac OS, choose the commands from the Edit and Select menus. 
You can also use standard keyboard shortcuts for these editing commands.

• If you have the required software for different script systems (for example, Roman, 
Japanese, or Cyrillic) installed on your computer, you can switch between the script 
systems. Right-click (Windows) or Control-click (Mac OS) to display the context menu, 
and then choose a script system.

5 To close the note to an icon, click the close box.

To create an audio annotation:

1 Select the Audio Annotation tool .
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2 Set options as needed:

• Enter an author name. 

• Select a color for the audio annotation icon.

3 Click where you want to place the annotation icon.

4 Click Start and then speak into the microphone. When you’re finished, click Stop. 

To import annotations:

1 Choose File > Import > Annotations.

2 Select a PDF or FDF file that contains annotations, and then click Load. The annotations 
appear in the locations where they were saved in the source document.

Opening and editing annotations
A note or audio annotation icon marks the location of an annotation on an image. When 
you move the pointer over an annotation icon and pause, a message displays the author 
name. You use the icons to open notes or play audio annotations. You can show, hide, or 
move the icons, and edit the contents of notes.

Note: Resizing an image does not resize the annotation icons and note windows. The 
icons and note windows keep their locations relative to the image. Cropping an image 
removes any annotations in the cropped area; you can recover the annotations by 
undoing the Crop command.

To open a note or play an audio annotation:

Double-click the icon:

• If you are opening a note, a window appears, displaying the note text. 

• If you are playing an audio annotation and have a sound card installed, the audio file 
begins to play.

To show or hide annotation icons:

Do one of the following:

• Choose View > Show > Annotations. 

• Choose View > Extras. This command also shows or hides grids, guides, selection edges, 
target paths, and slices.

To edit annotations:

Do any of the following:

• To move an annotation icon, move the pointer over the icon until it turns into an arrow, 
and then drag the icon. You can do this with any tool selected. Moving a note icon does 
not move its note window.

• To move a note window, drag it by the title bar.

• To delete a selected annotation, press Delete.

• To edit the contents of a note, open the note, change any options, and add, delete, or 
change the text. You can use the same editing commands that you use when creating a 
note. (See “Adding notes and audio annotations” on page 48.)
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• To delete all annotations, right-click (Windows) or Control-click (Mac OS) an annotation 
icon to display the context menu, and choose Delete All Annotations. You can also 
delete all annotations by clicking Clear All in the options bar for notes or audio 
annotations. 

Jumping between applications
You can jump between Photoshop and ImageReady to transfer an image between the two 
applications for editing without closing or exiting the originating application. In addition, 
you can jump from ImageReady to other graphics editing applications and HTML editing 
applications installed on your system.

Jumping to an application saves you from having to close the file in one application and 
reopen it in another application. 

Jumping between Photoshop and ImageReady
You can easily jump between Photoshop and ImageReady to use features in both applica-
tions when preparing graphics for the Web or other purposes. Jumping between the 
applications allows you to use the full feature sets of both applications while maintaining 
a streamlined workflow. Files and documents updated in one application can be automat-
ically updated in the other application.

To jump between Photoshop and ImageReady:

Do one of the following:

• Click the Edit In Photoshop button  or Edit In ImageReady button  in the 
toolbox.

• Choose File > Edit in Photoshop or File > Edit in ImageReady.

When jumping between Photoshop and ImageReady, the applications use a temp file for 
transferring changes.

Jumping to other applications
In addition to jumping to current versions of Photoshop, you can jump to other graphics-
editing applications and HTML-editing applications from within Photoshop and 
ImageReady.

When you install Photoshop or ImageReady, Adobe graphics-editing and HTML-editing 
applications currently on your system are added to the Jump To submenu. You can add 
more applications, including non-Adobe applications, to the Jump To submenu.

When you jump to a graphics-editing application, the original file is opened in the desti-
nation application. When you jump to an HTML editor, the optimized file and the HTML file 
are saved and opened in the destination application. If the image contains slices, all files 
for the full image are included. A preference enables files updated in another application 
to be automatically updated in Photoshop or ImageReady, when jumping back.

To jump to another application from ImageReady:

1 Do one of the following:

• Choose File > Jump To, and choose the desired application from the submenu.

• If the desired application doesn’t appear in the Jump To submenu, choose Other 
Graphics Editor or Other HTML Editor to specify the application. 
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2 If the file has been modified since the last save, choose an option in ImageReady for 
saving the file:

• Click Save, and save the file with its current name and location.

• Click Save As, and save the file with a new name, a new location, or both.

To add an application to the Jump To submenu:

1 Create a shortcut (Windows) or an alias (Mac OS) for the application you want to add to 
the menu.

2 Drag the icon for the shortcut or alias into the Jump To Graphics Editor or the Jump To 
HTML Editor folder in the Helpers folder in the Photoshop program folder.

3 Restart ImageReady to view the application in the Jump To submenu.

To automatically update a file when jumping back to ImageReady from another 
application:

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• In Mac OS, choose ImageReady > Preferences > General.

2 Select Auto-Update Files.

Previewing an image in a browser
To get an idea of how an optimized image will look in a Web page, you can preview the 
image in any browser installed on your system. The browser displays the image with a 
caption listing the image’s file type, pixel dimensions, file size, and compression specifica-
tions in the first paragraph, and filename and other HTML information in the second 
paragraph. You can add additional browsers to the menu, and specify which browser will 
be launched when using a keyboard shortcut.

To add a browser:

1 Do one of the following:

• (Photoshop) Choose File > Save for Web, and then choose Edit List from the Select 
Browser menu  . Click the Add button in the Browsers dialog box. 

• (ImageReady) Choose File > Preview In > Edit Browser List. Click the Add button in the 
Edit Browsers List dialog box.

2 In the Preview in Other Browser dialog box, navigate to the browser application on your 
computer, and then click the Open button. The browser name appears in the Browsers 
dialog box.

To add all browsers on your computer:

1 Do one of the following:

• (Photoshop) Choose File > Save for Web, and then choose Edit List from the Select 
Browser menu  . Click the Find All button. All the browsers installed on your 
computer appear. Click the OK button.

• (ImageReady) Choose File > Preview In > Edit Browser List. Click the Find All button. 
All the browsers installed on your computer appear. Click the OK button.
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To preview an optimized image in a browser:

Do one of the following:

• (Photoshop) Choose File > Save for Web, and then choose the browser you want to use 
from the Select Browser menu. (Choose Other to select a browser not listed in the 
submenu.) You can also click the Preview In button  to display the image in the 
default browser.

• (ImageReady) Choose File > Preview In, and then choose an option from the submenu 
(choose Other to select a browser not listed in the submenu), or select a browser from 
the Preview in Browser tool in the toolbox.

Managing libraries with the Preset Manager (Photoshop)
The Preset Manager centralizes management of brushes, swatches, gradients, styles, 
patterns, contours, custom shapes, and preset tools. You can use the Preset Manager to 
change the current set of preset items and create new libraries. Once you load a library in 
the Preset Manager, you can access the library’s items in all locations that the type of 
preset is available, such as the options bar, Styles palette, Gradient Editor dialog box, and 
so on.

When you make a change to most presets, Photoshop prompts you to save the changed 
item as a new preset when you close the image file. This way you won’t lose any existing or 
new presets.

Illustration of rearranging tool presets in the Preset Manager

To display the Preset Manager:

Choose Edit > Preset Manager.

To switch between preset types:

Choose an option from the Preset Type pop-up menu.

To change how items are displayed:

Click the arrow  and choose one of the following: 

• Text Only to display the name of each preset item.

• Small Thumbnail or Large Thumbnail to display a thumbnail of each preset item. 
(These options are not available for tool presets.)

• Small List or Large List to display the name and thumbnail of each preset item. 
(These options are not available for swatch presets.)
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• Stroke Thumbnail to display a sample brush stroke and brush thumbnail of each brush 
preset. (This option is available for brush presets only.)

To load a library of preset items:

Do one of the following:

• Choose a library file from the bottom of the palette menu. Click OK to replace the 
current list, or click Append to append the current list.

• To add a library to the current list, click Load, select the library file you want to add, and 
click Load.

• To replace the current list with a different library, choose Replace Preset Type from the 
palette menu. Select the library file you want to use, and click Load.

Note: Each type of library has its own file extension and default folder in the Presets folder 
in the Photoshop program folder.

To rename presets items:

1 Select a preset item. Shift-click to select multiple items:

2 Do one of the following:

• Click Rename, and then enter a new name for the brush, swatch, and so on. 

• If the Preset Manager is set to display presets as thumbnails, double-click a preset, enter 
a new name, and click OK.

• If the Preset Manager is set to display presets as a list or text only, double-click a preset, 
enter a new name inline, and press Enter (Windows) or Return (Mac OS).

To rearrange preset items:

Drag an item up or down in the list.

To delete preset items:

Do one of the following:

• Select a preset item, and click Delete.

• Alt-click (Windows) or Options-click (Mac OS) the items you want to delete.

To create a new library of presets:

1 Do one of the following:

• To save all the presets in the list as a library, make sure that no items are selected.

• To save a subset of the current list as a library, hold down Shift, and select the items you 
want to save.

2 Click Save Set, choose a location for the library, enter a filename, and click Save.

You can save the library anywhere. However, if you place the library file in the appropriate 
Presets folder inside the Photoshop program folder, the library name will appear at the 
bottom of the palette menu after you restart Photoshop.

To return to the default library of preset items:

Choose Reset Preset Type from the palette menu. You can either replace the current list or 
append the default library to the current list. 
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Customizing keyboard shortcuts
Photoshop provides a set of default keyboard shortcuts for commands and tools. 
However, you can customize keyboard shortcuts to your liking. You can change individual 
shortcuts within a set, and define your own sets of shortcuts.

Click a command row and enter a shortcut key in the empty text box to add a new shortcut.

To define new shortcuts:

1 Choose Edit > Keyboard Shortcuts.

2 Choose a set of shortcuts from the Set menu at the top of the Keyboard Shortcuts 
dialog box (Photoshop Defaults is the only option until you create a new set).

3 Choose a shortcut type (Application Menus, Palette Menus, or Tools) from the Shortcuts 
For menu.

4 In the Shortcut column of the scroll list, select the shortcut you want to modify.

5 Type a new shortcut. After you make changes, the name in the Set menu is suffixed 
with (modified).

If the keyboard shortcut is already assigned to another command or tool in the set, an 
alert informs you that another command or tool has the shortcut. Click Accept to assign 
the shortcut to the new command or tool, and to erase the previously assigned shortcut. 
Once you have reassigned a shortcut, you can click Undo Changes to undo the change, or 
click Accept and Go to Conflict to go to the other command or tool and assign it a new 
shortcut.

6 When you have finished changing shortcuts, do one of the following:

• To discard all changes and exit the dialog box, click Cancel.

• To discard the last saved change without closing the dialog box, click Undo.

• To return a new shortcut to the default, click Use Default.

• To export the displayed set of shortcuts, click Summarize. You can use this HTML file to 
display in a Web browser. 

To define a new set of shortcuts:

1 Do one of the following:

• To create a new set before you change default shortcuts, click the New Set button  
before you begin changing shortcuts.
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• To create a new set that includes any modifications you’ve made, click the New Set 
button  after you’re done changing shortcuts.

2 Save the shortcuts as a file. Enter a name for the new set in the Name text box, and click 
Save. The new key set will appear in the pop-up menu under the new name.

To clear shortcuts from a command or tool:

1 Choose Edit > Keyboard Shortcuts.

2 In the Keyboard Shortcuts dialog box, select the command or tool name whose 
shortcut you want to delete.

3 Click Delete Shortcut. 

To delete an entire set of shortcuts:

1 Choose Edit > Keyboard Shortcuts.

2 In the Set pop-up menu, choose the shortcut set that you want to delete. 

3 Click the Delete Set button  and then OK to exit the dialog box.

Setting preferences 
Numerous program settings are stored in Adobe Photoshop CS Prefs file. Among the 
settings stored in this file are general display options, file-saving options, cursor options, 
transparency options, and options for plug-ins and scratch disks. Most of these options are 
set in the Preferences dialog box. Preference settings are saved each time you exit the 
application.

Unexpected behavior may indicate damaged preferences. By removing damaged 
preferences, you can restore preferences to their default settings. 

To open a preferences dialog box:

1 Do one of the following:

• In Windows, choose Edit > Preferences and choose the desired preference set from the 
submenu.

• (Photoshop) In Mac OS, choose Photoshop > Preferences and choose the desired 
preference set from the submenu.

• (ImageReady) In Mac OS, choose ImageReady > Preferences and choose the desired 
preference set from the submenu.

2 To switch to a different preference set, do one of the following:

• Choose the preference set from the menu at the top of the dialog box.

• Click Next to display the next preference set in the menu list; click Prev to display the 
previous preference set.

For information on a specific preference option, see the Index.

To restore all preferences to their default settings:

Do one of the following:

• Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac OS) 
immediately after launching Photoshop or ImageReady. You will be prompted to delete 
the current settings.
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• In Mac OS, open the Preferences folder in the Library folder, and drag the Adobe 
Photoshop CS Settings folder to the Trash.

New Preferences files will be created the next time you start Photoshop or ImageReady.

Resetting all warning dialogs
Sometimes messages containing warnings or prompts regarding certain situations are 
displayed. You can disable the display of these messages by selecting the Don’t Show 
Again option in the message. You can also globally reset the display of all messages that 
have been disabled.

To reset the display of all warning messages (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• In Mac OS, choose Photoshop > Preferences > General.

2 Click Reset All Warning Dialogs, and click OK.

To turn on or off warning messages (ImageReady):

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• In Mac OS, choose Photoshop > Preferences > General.

2 Deselect or select Disable Warnings, and click OK.

Monitoring operations
A progress bar indicates that an operation is in process. You can interrupt the process or 
have the program notify you when it has finished. 

To cancel operations:

Hold down Esc until the operation in progress has stopped. In Mac OS, you can also press 
Command+period.

To set notification for completion of operations:

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > General.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General.

2 Do one of the following:

• (Photoshop) Select Beep When Done.

• (ImageReady) Select Notify When Done and choose (Mac OS only): System Alert to use 
your system alert for notification or Text to Speech to use a spoken notification.

3 Click OK.
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Closing files and quitting
Closing and quitting is simple. Always make sure that you’ve saved any changes to your 
images before you close images and quit Photoshop or ImageReady.

To close a file:

1 Choose File > Close or File > Close All. 

2 Choose whether or not to save the file:

• Click Yes (Windows) or Save (Mac OS) to save the file. 

• Click No (Windows) or Don’t Save (Mac OS) to close the file without saving it.

To exit Photoshop or ImageReady:

1 Choose File > Exit (Windows) or File > Quit (Mac OS).

2 Choose whether or not to save any open files:

• Click Yes (Windows) or Save (Mac OS) for each open file to save the file.

• Click No (Windows) or Don’t Save (Mac OS) for each open file to close the file without 
saving it.

Using plug-in modules
Plug-in modules are software programs developed by Adobe Systems and by other 
software developers in conjunction with Adobe Systems to add features to Photoshop 
and ImageReady. A number of importing, exporting, and special-effects plug-ins come 
with your program; they are automatically installed in folders inside the Photoshop 
Plug-ins folder. 

You can select an additional plug-ins folder to use compatible plug-ins stored with 
another application. You can also create a shortcut (Windows) or an alias (Mac OS) for a 
plug-in stored in another folder on your system. You can then add the shortcut or alias to 
the Plug-ins folder to use that plug-in with Photoshop and ImageReady.

Once installed, plug-in modules appear as options added to the Import or Export menu; 
as file formats in the Open, Save As, and Export Original (ImageReady) dialog boxes; or as 
filters in the Filter submenus. Photoshop and ImageReady can accommodate a large 
number of plug-ins. However, if the number of installed plug-in modules becomes great 
enough, Photoshop or ImageReady may not be able to list all the plug-ins in their appro-
priate menus. Newly installed plug-ins will then appear in the Filter > Other submenu.

To install an Adobe Systems plug-in module:

Do one of the following:

• Use the plug-in installer, if provided.

• (Windows) Copy the module into the appropriate Plug-ins folder in the Photoshop 
program folder. Make sure that the files are uncompressed.

• (Mac OS) Drag a copy of the module to the appropriate Plug-ins folder in the Photoshop 
program folder. Make sure that the files are uncompressed.

Important: In Mac OS, you cannot launch Photoshop in the Classic environment. Plug-ins 
originally intended to work on Mac OS 9 won’t appear.
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To install a third-party plug-in module:

Follow the installation instructions that came with the plug-in module.

If you cannot run a third-party plug-in, the plug-in may require a legacy Photoshop serial 
number. 

To specify a legacy serial number (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Plug-Ins & Scratch Disk. 

• In Mac OS, choose Photoshop > Preferences > Plug-Ins & Scratch Disk. 

2 Enter the serial number from Photoshop 6.0 or earlier in the Legacy Photoshop Serial 
Number text box.

To select an additional plug-ins folder:

1 Do one of the following:

• (Photoshop) In Mac OS, choose Photoshop > Preferences > Plug-Ins & Scratch Disk. 

• (ImageReady) In Mac OS, choose ImageReady > Preferences > Plug-Ins & Scratch Disk. 

2 Select Additional Plug-ins Folder.

3 Click Choose, and select a folder or directory from the list. Make sure that you do not 
select a location inside the Plug-ins folder. To display the contents of a folder, double-click 
the directory (Windows) or click Open (Mac OS).

4 When you have highlighted the additional plug-ins folder, click OK (Windows) or 
Choose (Mac OS).

5 Restart Photoshop or ImageReady for the plug-ins to take effect.

To suppress the loading of a plug-in or folder of plug-ins:

Add a tilde ~ character at the beginning of the plug-in name, folder, or directory. That file 
(or all files in the folder) will be ignored by the application.

To view information about installed plug-ins:

Do one of the following:

• In Windows, choose Help > About Plug-In and select a plug-in from the submenu.

• (Photoshop) In Mac OS, choose Photoshop > About Plug-In and select a plug-in from 
the submenu. 

• (ImageReady) In Mac OS, choose ImageReady > About Plug-In and select a plug-in from 
the submenu. 

To load a plug-in in only Photoshop or ImageReady:

Install the plug-in either the Adobe Photoshop Only folder or the Adobe ImageReady Only 
folder inside the Plug-ins folder.

Note: Use this procedure when you want to use a plug-in within only Photoshop or 
ImageReady, or when a plug-in may only be compatible with one of the two applications.
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Working with Adobe Version Cue managed projects
Adobe Version Cue™ is an innovative set of features designed to increase your productivity 
when you work alone or collaborate with others. Adobe Version Cue integrates design 
management into your existing workflows within and across the Adobe Creative Suite 
applications, including Adobe GoLive CS, Adobe Illustrator CS, Adobe InDesign CS, and 
Adobe Photoshop CS.

Note: The Adobe Version Cue features are compatible only with the Adobe Version Cue 
Workspace, which is available only as part of the Adobe Creative Suite. 

Adobe Version Cue streamlines the following tasks while you work in the Creative Suite:

• Creating file versions

• Maintaining file security

• Organizing files into private or shared projects

• Browsing with file thumbnails, and searching file information and version comments

• Reviewing file information, comments, and file statuses in private and shared projects 
while you browse

In addition, you can use the Version Cue Workspace Administration for more advanced 
tasks:

• Duplicate, export, backup and restore projects.

• View information about projects in the workspace.

• Import files to the workspace using FTP or WebDAV.

• Delete file versions and remove file locks.

• Create project users and define their project privileges.

• Restrict access to a specific project.

To view the complete Adobe Version Cue documentation, see Adobe Version Cue Help. 
You can also view the Adobe Version Cue documentation as a PDF or print it by opening 
the VersionCueHelp.pdf file located on the Adobe Creative Suite CD and the Adobe 
Photoshop CS CD.

Assigning scratch disks
When your system does not have enough RAM to perform an operation, Photoshop and 
ImageReady use a proprietary virtual memory technology, also called scratch disks. A 
scratch disk is any drive or a partition of a drive with free memory. By default, Photoshop 
and ImageReady use the hard drive that the operating system is installed on as its primary 
scratch disk. 

You can change the primary scratch disk and, in Photoshop, designate a second, third, or 
fourth scratch disk to be used when the primary disk is full. Your primary scratch disk 
should be your fastest hard disk, and should have plenty of defragmented space available. 

The following guidelines can help you assign scratch disks:

• For best performance, scratch disks should be on a different drive than any large files 
you are editing.

• Scratch disks should be on a different drive than the one used for virtual memory.
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• Scratch disks should be on a local drive. That is, they should not be accessed over a 
network.

• Scratch disks should be conventional (non-removable) media.

• Raid disks/disk arrays are good choices for dedicated scratch disk volumes.

• Drives with scratch disks should be defragmented regularly.

To change the scratch disk assignment:

1 Choose Edit > Preferences > Plug-Ins & Scratch Disks.

2 Do one of the following:

• (Photoshop) Choose the desired disks from the menus. You can assign up to four 
scratch disks of any size your file system supports. Photoshop lets you create up to 
200 GB of scratch disk space using those scratch disks.

• (ImageReady) Choose a primary scratch disk.

3 Click OK.

4 Restart Photoshop or ImageReady for the change to take effect.
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Getting Images into Photoshop 
and ImageReady

Working with bitmap images and vector graphics
Computer graphics fall into two main categories—bitmap and vector. You can work 
with both types of graphics in Photoshop and ImageReady; moreover, a Photoshop file 
can contain both bitmap and vector data. Understanding the difference between the two 
categories helps as you create, edit, and import artwork.

About bitmap images
Bitmap images—technically called raster images—are made up of a grid of dots known as 
pixels. When working with bitmap images, you edit pixels rather than objects or shapes. 
Bitmap images are the most common electronic medium for continuous-tone images, 
such as photographs or digital paintings, because they can represent subtle gradations of 
shades and color. 

Bitmap images can lose detail when scaled on-screen because they are resolution-
dependent, they contain a fixed number of pixels, and each pixel is assigned a specific 
location and color value. Bitmapped images can look jagged if they’re printed at too low a 
resolution because the size of each pixel is increased (see “Understanding image size and 
resolution” on page 62).

Example of a bitmap image at different levels of magnification

About vector graphics
Vector graphics are made up of mathematically defined lines and curves called vectors. 
This means that you can move, resize, or change the color of a line without losing the 
quality of the graphic. 

24:1

3:1
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Vector graphics are resolution-independent—that is, they can be scaled to any size and 
printed at any resolution without losing detail or clarity. As a result, vector graphics are the 
best choice for representing bold graphics that must retain crisp lines when scaled to 
various sizes (logos, for example).

Example of a vector graphic at different levels of magnification

Note: Because computer monitors can display images only on a grid, both vector graphics 
and bitmap images are displayed as pixels on-screen (see “Monitor resolution” on 
page 64).

Understanding image size and resolution
Understanding the relationship between the pixel dimension of an image and its print 
resolution is key to producing high-quality images.

The amount of detail in an image depends on its pixel dimensions, while the image 
resolution controls how much space the pixels are printed over. For example, you can 
modify an image’s resolution without changing the actual pixel data in the image—all you 
change is the printed size of the image. However, if you want to maintain the same output 
dimensions, changing the image’s resolution requires a change in the total number of 
pixels.

Pixel dimensions equal document (output) size times resolution 
A. Decreasing the resolution without changing pixel dimensions (no resampling) B. Original 
dimensions and resolution C. Decreasing the resolution at same document size decreases pixel 
dimensions (resampling)

24:1

3:1

BA C
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Pixel dimensions and image resolution
The number of pixels along the height and width of a bitmap image is called the pixel 
dimensions of an image. 

The resolution of an image is determined by the number of pixels per inch (ppi) printed on 
a page. In Photoshop, you can change the resolution of an image. In ImageReady, the 
resolution of images is always 72 ppi, to optimize the images for online media.

Example of an image at 72-ppi and 300-ppi

When printed, an image with a high resolution contains more, and therefore smaller, 
pixels than an image with a low resolution. Higher-resolution images can reproduce more 
detail and subtler color transitions than lower-resolution images because of the density of 
the pixels in the images. High-quality images often look good at any print size.

You can’t improve a lower-quality image by printing it at a high resolution. Changing the 
print resolution of an image simply makes each pixel larger, which results in pixelation—
output with large, coarse-looking pixels. Increasing the print resolution of an image 
doesn’t add any pixel information to the image. You can make a low-resolution image look 
its best by picking a print size that makes the most of the pixels it has. For more infor-
mation on print resolution, see “Printer resolution” on page 64.

It’s important to note that video files are displayed only at 72 ppi. Even if an image has 
a higher resolution than 72 ppi, when it’s displayed in a video editing application, the 

quality may not look very good.

Printing the same low-resolution image at different sizes 
A. Small print size B. Medium print size C. Large print size

A B C
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File size
The file size of an image is the digital size of the image file, measured in kilobytes (K), 
megabytes (MB), or gigabytes (GB). File size is proportional to the pixel dimensions of the 
image. Images with more pixels may produce more detail at a given printed size, but they 
require more disk space to store and may be slower to edit and print. Image resolution 
thus becomes a compromise between image quality (capturing all the data you need) and 
file size. 

Another factor that affects file size is file format. Due to varying compression methods 
used by GIF, JPEG, and PNG file formats, file sizes can vary considerably for the same pixel 
dimensions. Similarly, color bit-depth and the number of layers and channels in an image 
affect file size. 

Photoshop supports a maximum pixel dimensions of 300,000 by 300,000 pixels per image. 
This restriction places limits on the print size and resolution available to an image.

Monitor resolution
Image data are translated directly into monitor pixels. This means that when the image 
resolution is higher than the monitor resolution, the image appears larger on-screen than 
its specified print dimensions. 

Monitor resolution depends on the size of the monitor plus its pixel setting. For example, 
a large image (800-by-600-pixel dimension) shown on a 15-inch monitor would almost fill 
the screen, but on a larger monitor, the same image would take up less room on the 
screen, and each pixel would appear larger.

Example of an image displayed on monitors of various sizes and resolutions

Important: When you are preparing an image for online display, pixel dimensions 
become especially important. You should make sure that the size of an image allows room 
for the Web browser window controls on smaller monitors.

Printer resolution
Printer resolution is measured by the number of ink dots per inch (dpi) produced by all 
laser printers, including imagesetters. (See “Preparing images for press” on page 615).

Inkjet printers produce a microscopic spray of ink, not actual dots; however, most inkjet 
printers have an approximate resolution of 300 to 720 dpi (see “Printing images to a 
desktop printer” on page 608). Many inkjet printer drivers offer simplified print settings for 
choosing higher quality printing. To determine your printer’s optimal resolution, check 
your printer documentation.

15"

20"

1024 x 768 / 640 x 480832 x 624 / 640 x 480
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Screen frequency
Screen frequency is the number of printer dots or halftone cells per inch used to print 
grayscale images or color separations. Also known as screen ruling or line screen, screen 
frequency is measured in lines per inch (lpi)—or lines of cells per inch in a halftone screen. 
The higher an output device’s resolution, the finer (higher) a screen ruling you can use. 

The relationship between image resolution and screen frequency determines the quality 
of detail in the printed image. To produce a halftone image of the highest quality, you 
generally use an image resolution that is from 1.5 to at most 2 times the screen frequency. 
But with some images and output devices, a lower resolution can produce good results. 
To determine your printer’s screen frequency, check your printer documentation or 
consult your service provider. 

Note: Some imagesetters and 600-dpi laser printers use screening technologies other than 
halftoning. If you are printing an image on a nonhalftone printer, consult your service 
provider or your printer documentation for the recommended image resolutions.

Screen frequency examples 
A. 65 lpi: Coarse screen typically used to print newsletters and grocery coupons B. 85 lpi: Average 
screen typically used to print newspapers C. 133 lpi: High-quality screen typically used to print 
four-color magazines D. 177 lpi: Very fine screen typically used for annual reports and images in 
art books

Changing image size and resolution
Once you have scanned or imported an image, you may want to adjust its size. In 
Photoshop, the Image Size dialog box lets you adjust the pixel dimensions, print dimen-
sions, and resolution of an image; in ImageReady, you can adjust only the pixel dimen-
sions of an image.

For assistance with resizing and resampling images in Photoshop, choose Help > 
Resize Image. This interactive wizard helps you scale your images for print or online 

media.

Keep in mind that bitmap and vector data can produce different results when you resize 
an image. Bitmap data is resolution-dependent; therefore, changing the pixel dimensions 
of a bitmap image can cause a loss in image quality and sharpness. In contrast, vector data 
is resolution-independent; you can resize it without losing its crisp edges.

A B

C D
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Displaying image size information
You can display information about the current image size using the information box at the 
bottom of the application window (Windows) or the document window (Mac OS). 
(See “Displaying file and image information” on page 46.)

To display the current image size:

Do one of the following:

• (Photoshop) Press Alt (Windows) or Option (Mac OS), position the pointer over the file 
information box, and hold down the mouse button. The box displays the width and 
height of the image (both in pixels and in the unit of measurement currently selected 
for the rulers), the number of channels, and the image resolution.

• (ImageReady) Click an image information box, and select Image Dimensions from the 
pop-up menu. The box displays the width and height of the image in pixels.

About resampling
Resampling refers to changing the pixel dimensions (and therefore display size) of an 
image. When you downsample (decrease the number of pixels), information is deleted 
from the image. When you resample up (increase the number of pixels), new pixels are 
added. You specify an interpolation method to determine how pixels are added or deleted. 
(See “Choosing an interpolation method” on page 67.)

Resampling pixels 
A. Downsampled B. Original C. Resampled up (selected pixels displayed for each set of images)

A

B

C
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Keep in mind that resampling can result in poorer image quality. For example, when you 
resample an image to larger pixel dimensions, the image will lose some detail and 
sharpness. Applying the Unsharp Mask filter to a resampled image can help refocus the 
image’s details. (See “Sharpening images” on page 224.)

You can avoid the need for resampling by scanning or creating the image at a high 
enough resolution. If you want to preview the effects of changing pixel dimensions 
on-screen or print proofs at different resolutions, resample a duplicate of your file. 

Choosing an interpolation method 
When an image is resampled, an interpolation method is used to assign color values to any 
new pixels Photoshop creates, based on the color values of existing pixels in the image. 
Photoshop and ImageReady use sophisticated methods to preserve the quality and detail 
from the original image when you resample. 

The General Preferences dialog box lets you specify a default interpolation method to use 
whenever images are resampled with the Image Size or transformation commands. The 
Image Size command also lets you specify an interpolation method other than the default.

To specify the default interpolation method: 

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• (Photoshop) In Mac OS choose Photoshop > Preferences > General.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General.

2 For Interpolation, choose one of the following options:

• Nearest Neighbor for the fast but less precise method. This method is recommended for 
use with illustrations containing non-anti-aliased edges, to preserve hard edges and 
produce a smaller file. However, this method can result in jagged effects, which become 
apparent when distorting or scaling an image or performing multiple manipulations on 
a selection. 

• Bilinear for a medium-quality method.

• Bicubic for the slow but more precise method, resulting in the smoothest tonal grada-
tions.

• Bicubic Smoother when you’re enlarging images. 

• Bicubic Sharper for reducing the size of an image. This method maintains the detail in a 
resampled image. It may, however, over-sharpen some areas of an image. In this case, 
try using Bicubic.

Changing the pixel dimensions of an image
When preparing images for online distribution, it’s useful to specify image size in terms of 
the pixel dimensions. Keep in mind that changing pixel dimensions affects not only the 
size of an image on-screen but also its image quality and its printed characteristics—
either its printed dimensions or its image resolution. (See “Understanding image size and 
resolution” on page 62.) 

To change the pixel dimensions of an image (Photoshop):

1 Choose Image > Image Size.
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2 To maintain the current proportions of pixel width to pixel height, select Constrain 
Proportions. This option automatically updates the width as you change the height, and 
vice versa.

3 Under Pixel Dimensions, enter values for Width and Height. To enter values as 
percentages of the current dimensions, choose Percent as the unit of measurement. The 
new file size for the image appears at the top of the Image Size dialog box, with the old file 
size in parentheses.

4 Make sure that Resample Image is selected, and choose an interpolation method. 
(See “Choosing an interpolation method” on page 67.)

5 If your image has layers with styles applied to them, select Scale Styles to scale the 
effects in the resized image. This option is available only if you selected Constrain 
Proportions.

6 When you’re done setting options, click the OK button.

For best results in producing a smaller image, downsample and apply the Unsharp 
Mask filter. To produce a larger image, rescan the image at a higher resolution.

To change the pixel dimensions of an image (ImageReady):

1 Choose Image > Image Size.

2 To maintain the current proportions of pixel width to pixel height, select Constrain 
Proportions. 

3 Under New Size, enter values for Width, Height, or Percent. The New Size text field 
displays the new file size for the image.

4 Select a interpolation method from the Quality pop-up menu (see “Choosing an inter-
polation method” on page 67).

Changing the print dimensions and resolution of an image 
(Photoshop)
When creating an image for print media, it’s useful to specify image size in terms of the 
printed dimensions and the image resolution. These two measurements, referred to as the 
document size, determine the total pixel count and therefore the file size of the image; 
document size also determines the base size at which an image is placed into another 
application. You can further manipulate the scale of the printed image using the Print with 
Preview command; however, changes you make using the Print with Preview command 
affect only the printed image, not the document size of the image file. (See “Positioning 
and scaling images” on page 611.)

If you turn on resampling for the image, you can change print dimensions and resolution 
independently (and change the total number of pixels in the image). If you turn off resam-
pling, you can change either the dimensions or the resolution—Photoshop adjusts the 
other value automatically to preserve the total pixel count. For the highest print quality, 
it’s generally best to change the dimensions and resolution first without resampling. Then 
resample only as necessary.
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To change the print dimensions and resolution of an image:

1 Choose Image > Image Size.

2 Change the print dimensions, image resolution, or both:

• To change only the print dimensions or only the resolution and adjust the total number 
of pixels in the image proportionately, make sure that Resample Image is selected. Then 
choose an interpolation method. (See “Choosing an interpolation method” on 
page 67.)

• To change the print dimensions and resolution without changing the total number of 
pixels in the image, deselect Resample Image.

3 To maintain the current proportions of image width to image height, select Constrain 
Proportions. This option automatically updates the width as you change the height, and 
vice versa.

4 Under Document Size, enter new values for the height and width. If desired, choose a 
new unit of measurement. Note that for Width, the Columns option uses the width and 
gutter sizes specified in the Units & Rulers preferences. For more information, see “Using 
columns (Photoshop)” on page 41.

5 For Resolution, enter a new value. If desired, choose a new unit of measurement.

To return to the original values displayed in the Image Size dialog box, hold down Alt 
(Windows) or Option (Mac OS), and click Reset.

To view the print size on-screen:

Do one of the following:

• Choose View > Print Size.

• Select the Hand tool or Zoom tool, and click Print Size in the options bar.

The magnification of the image is adjusted to display its approximate printed size, as 
specified in the Document Size area of the Image Size dialog box. Keep in mind that the 
size and resolution of your monitor affect the on-screen print size.

Determining a recommended resolution for an image 
(Photoshop)
If you plan to print your image using a halftone screen, the range of suitable image 
resolutions depends on the screen frequency of your output device. You can have 
Photoshop determine a recommended resolution for your image based on your device’s 
screen frequency. (See “Understanding image size and resolution” on page 62.)

Note: If your image resolution is more than 2.5 times the screen ruling, an alert message 
appears when you try to print the image. This means that the image resolution is higher 
than necessary for the printer. Save a copy of the file, and then reduce the resolution. 

To determine a suggested resolution for an image:

1 Choose Image > Image Size.

2 Click Auto. 
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3 For Screen, enter the screen frequency for the output device. If desired, choose a new 
unit of measurement. Note that the screen value is used only to calculate the image 
resolution, not to set the screen for printing.

Important: To specify the halftone screen ruling for printing, you must use the Halftone 
Screens dialog box, accessible through the Print with Preview command. (See “Selecting 
halftone screen attributes” on page 618.)

4 For Quality, select an option:

• Draft to produce a resolution the same as the screen frequency (no lower than 72 pixels 
per inch).

• Good to produce a resolution 1.5 times the screen frequency.

• Best to produce a resolution 2 times the screen frequency.

Getting images from digital cameras
You can import images from your digital camera using TWAIN drivers, or using Windows 
Image Acquisition (WIA) if you’re using a PC. Once images are opened in Photoshop or 
ImageReady, you can edit them.

You can also get images using a memory or flash card reader.

Importing an image using the TWAIN interface 
TWAIN is a cross-platform interface for acquiring images captured by certain digital 
cameras.

You must install the TWAIN drivers that came with your camera before you can use it to 
import images into Photoshop and ImageReady. See the documentation provided by your 
device manufacturer for installation information.

To import images from a digital camera using the TWAIN interface (Photoshop):

Choose File > Import, and choose the device you want to use from the submenu.

To import images from a digital camera using the TWAIN interface (ImageReady):

1 If you’re using the TWAIN device for the first time with ImageReady, choose File > 
Import > TWAIN Select. Then select the device you want to use. You do not need to repeat 
this step for subsequent use of the TWAIN module.

If more than one TWAIN device is installed in your system and you want to switch 
devices, use the TWAIN Select command. 

2 To import the image, choose File > Import > TWAIN Acquire.

Importing images from digital cameras using Windows Image 
Acquisition (WIA)
Certain digital cameras import images using WIA support. When you use WIA, Photoshop 
works with Windows and your digital camera or scanner software to import images 
directly into Photoshop.

Note: WIA is only available if you are using Windows XP.
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To import images from a digital camera using WIA:

1 Choose File > Import > WIA Support.

2 Choose a destination on your computer for saving your image files. 

3 Make sure Open Acquired Images in Photoshop is checked. If you have a large number 
of images to import, or if you want to edit the images at a later time, deselect it. 

4 Select Unique Subfolder if you want to save the imported images directly into a folder 
named with the current date.

5 Click Start.

6 Select the digital camera that you want to import images from.

Note: If the name of your camera does not appear in the submenu, verify that the software 
and drivers were properly installed and that the camera is connected.

7 Choose the image or images you want to import:

• Click the image from the list of thumbnails to import the image.

• Hold down Shift and click on multiple images to import them at the same time.

• Click Select All to import all available images.

8 Click Get Picture to import the image.

Working with camera raw image files
The Photoshop Camera Raw plug-in lets you open a camera’s raw digital image files so 
that you can edit them in Photoshop or ImageReady. As you open the camera raw image 
files, you can quickly apply adjustments such as exposure compensation or tonal adjust-
ments without compressing the image or losing any of the original image data. 
The camera raw image file can then be brought into Photoshop and saved in a final format 
such as PSD, JPEG, Large Document Format (PSB), or TIFF. By default, Camera Raw settings 
are stored on a per-image basis in a Camera Raw database file. You can choose a 
preference to have the settings saved in sidecar XMP files (files that accompany the original 
camera raw image file in the same folder) instead of a Camera Raw database. For more 
information about Camera Raw settings, see “About Photoshop Camera Raw plug-in 
settings” on page 81.

About camera raw files
Camera raw image file formats are like digital negatives. They are created by a variety of 
digital cameras and contain all the information the camera has about the image. The 
image information is directly captured from the camera’s Charged Coupled Device (CCD) 
or Complementary Metal-Oxide Semiconductor (CMOS) without filters and adjustments 
applied by the camera. This lets photographers interpret the image data rather than 
letting the camera make the adjustments and conversions.

Similar to TIFF, a camera raw image file does not throw away any image information to 
generate a file—it’s lossless—but camera raw image files have the advantage of being 
smaller than uncompressed TIFFs. Only camera raw images contain the actual data 
captured by the sensor without any in-camera processing.



Using Help | Contents | Index Back 72  

Adobe Photoshop CS Help Getting Images into Photoshop and ImageReady 

Using Help | Contents | Index Back 72  

About the Camera Raw plug-in
Although each camera uses a unique format to save the camera raw image data, the 
Photoshop Camera Raw plug-in can open many camera raw file formats. Your workflow 
is improved because the camera raw image files are opened directly in Photoshop so 
you can edit them immediately. The adjustments available with the Photoshop Camera 
Raw Plug-in provide flexibility to produce the best image possible from a camera raw 
image file.

You can save the settings in the Camera Raw dialog box for a specific camera or a specific 
lighting condition and reuse the settings to open another camera raw image file or a 
batch of camera raw image files. 

Camera Raw dialog box 
A. Zoom, Hand, and White Balance tools B. Image preview C. Camera, file name, and some 
EXIF information D. Histogram E. Basic mode F. Advanced mode displays additional tabs
G. Photoshop Camera Raw plug-in menu H. Zoom level menu I. Image attributes
J. Rotate Preview buttons K. Adjustment sliders

Displaying the Camera Raw dialog box Opening a camera raw file in Photoshop or 
ImageReady generally opens the Camera Raw dialog box. It’s possible to suppress the 
dialog box from displaying for each file when opening a batch of camera raw files. The 
Camera Raw dialog box is automatically suppressed when using a batch of camera raw 
files for a Web Photo Gallery, Picture Package, or Contact Sheet. For more information 
about opening a batch of camera raw files, see “Creating an action to open camera raw 
image files” on page 84.

Basic and Advanced modes By default, the Camera Raw dialog box opens in Basic 
mode. Selecting the Advanced mode makes the following additional controls available:

B D FE G
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• The Camera Raw Preferences can be accessed from the Camera Raw plug-in menu. This 
is where you can specify the sharpening behavior of the Camera Raw plug-in and also 
choose where an image’s Camera Raw settings are stored. For more information on 
storing Photoshop Camera Raw plug-in settings, see “About Photoshop Camera Raw 
plug-in settings” on page 81, and for more information on sharpening with the Camera 
Raw plug-in, see “Using the Sharpness slider to reduce blur” on page 78.

• The Lens tab has controls to compensate for chromatic aberration and vignetting intro-
duced by a digital camera. For more information on using the controls in the Lens tab, 
see “Compensating for chromatic aberration” on page 79.

• The Calibrate tab has controls to correct a color cast in the shadows and adjust the 
Camera Raw built-in profile to alter the rendering of non-neutral colors. For more infor-
mation on using the controls in the Calibrate tab, see “Making advanced color adjust-
ments” on page 80.

Note: The Camera Raw Preferences, Lens tab, and Calibrate tab are not available when the 
Camera Raw dialog box is in Basic mode.

Using the histogram and RGB levels The Photoshop Camera Raw histogram shows all 
three channels (Red, Green, and Blue) of the image simultaneously. The histogram updates 
automatically as you adjust the settings in the Camera Raw dialog box. For more infor-
mation on using histograms, see “Reading a histogram” on page 176.

Moving the Zoom, Hand, or White Balance tool over the preview image displays the 
RGB values for the area being sampled.

RGB values appear whenever a tool pointer hovers over an area of the preview image.

Rotating the preview image Click the Rotate Preview buttons  . Rotation is applied 
to the preview in the Camera Raw dialog box. Photoshop automatically applies the 
rotation when the file is opened in a document window. Because Photoshop saves an 
image’s Camera Raw settings, the rotation will still be applied to the dialog box preview 
when you reopen the camera raw file.

Zooming in and out of the preview image Do one of the following:

• Choose a percentage from the zoom level menu.

• Select the Zoom tool , and either drag a selection or click in the preview image. 
To zoom out, hold down the Alt (Windows) or Option (Mac OS) key while using the 
Zoom tool.

If the preview image is larger than the viewing window, use the Hand tool  to move the 
image and view different areas. You can hold down the spacebar to access the hand tool 
while using another tool.
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Disabling the Preview option Deselect the Preview option to see the image unchanged, 
without the applied image setting adjustments.

Opening camera raw image files
The Photoshop Camera Raw plug-in lets you open a camera’s raw image file directly in 
Photoshop or ImageReady without using another program to convert the camera raw 
image into a readable format. As a result, all your work with camera raw image files can be 
completely done in Photoshop.

To open a camera raw image file for editing in Photoshop and ImageReady:

1 Open a camera raw image file by choosing File > Open or using the File Browser 
(see “Using the File Browser (Photoshop)” on page 90) in Photoshop. The Camera Raw 
dialog box automatically opens, displaying a preview of the image.

2 Adjust the settings such as the image attributes (target color space profile, bit depth, 
pixel size, and resolution), the white balance, exposure and tonal settings, sharpness, 
smoothness, and color noise reduction.

To restore all your adjustments to the original settings, hold down the Alt (Windows®) 
or Option (Mac OS) key. The Cancel button will change to a Reset button. While 

holding the key down, click the Reset button.

3 When you’ve finished your adjustments, click OK. A copy of the camera raw image file 
with the Photoshop Camera Raw plug-in settings applied opens in Photoshop. You can 
then edit the image and save it in a Photoshop-supported format. 

The original camera raw image file remains unaltered. The settings applied to the camera 
raw image are stored either in the Camera Raw database file or as a sidecar XMP file. For 
more information on storing Photoshop Camera Raw plug-in settings, see “About 
Photoshop Camera Raw plug-in settings” on page 81.

Note: Although Photoshop and ImageReady can open a camera raw image file, they 
cannot save an image as a camera raw image file. A Photoshop Raw format is available in 
Photoshop, but it is not the same format as a camera raw image file. A camera’s raw image 
file contains the unprocessed bits from the camera’s CCD or CMOS. This data needs signif-
icant processing, such as the processing done by the Photoshop Camera Raw plug-in. The 
Photoshop Raw format (.raw) is a flexible file format for transferring images between 
applications and computer platforms.

Adjusting the image attributes
The Camera Raw dialog box lets you change the image settings for the target color space 
profile, bit depth, pixel size for opening the image, and resolution using the following 
controls:

Space Specifies the target color space profile. Generally, this should be set to the same 
value as your Photoshop RGB working space. Keep in mind that the source profile for 
camera raw image files is usually the camera-native color space. (Higher-end cameras 
let you select a color space like Adobe RGB for the color profile when photographing.) 
The profiles listed in the Space menu are built into the Photoshop Camera Raw plug-in. 
If you want to use a color space that’s not listed in the Space menu, choose ProPhoto RGB, 
and then convert to the working space of your choice when the file opens in Photoshop.

Depth Specifies whether the image opens as 8 or 16 bits per channel in Photoshop. 
In ImageReady, 8 bits per channel is the only option.
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Size Specifies the pixel size at which to open the image. The default for this setting is the 
pixel size you used to photograph the image. Use the Size menu if you want to resample 
the image to a larger or smaller size.

• For square-pixel cameras, the Size menu is mostly a convenience for the user. However, 
choosing a smaller-than-native size is useful to speed processing when you are 
planning a smaller final image anyway. Picking a larger size is similar to upsampling in 
Photoshop.

• For non-square pixel cameras, the native size is the one that most closely preserves the 
total pixel count. This means the pixels in one dimension will be upsampled, while in 
the other dimension they will be downsampled. Choosing the next size larger than the 
native size keeps the pixel count along the high-resolution dimension constant, while 
upsampling the lower-resolution dimension to create square pixels. This larger size 
preserves maximum detail for non-square pixel cameras, since neither dimension is 
downsampled.

Note: You can always change the pixel size of the image after it opens in Photoshop.

Resolution Specifies the printing resolution the image will be printed at or the amount of 
data in the image. This setting does not affect the actual pixels (pixel size of the image). 
For example, a 2048 x 1536 pixel image prints at approximately 28 1/2 x 21 1/4 inches at 
72 dpi. When the resolution is changed to 300 dpi, the same image prints at approximately 
6 3/4 x 5 1/8 inches. Resolution can also be adjusted in Photoshop using the Image Size 
command.

Setting the white balance
A digital camera records the white balance at the time of exposure as a metadata entry. 
This is read by the Photoshop Camera Raw plug-in and set as the initial setting when 
opening an image in the Camera Raw dialog box. It usually comes close to being the 
correct color temperature. You can make adjustments if the white balance is not quite 
right. 

The Adjust tab in the Photoshop Camera Raw dialog box has three controls for making 
adjustments to remove a color cast in your image. The Photoshop Camera Raw plug-in 
also has a control in the Advanced mode for correcting a shadow color cast (a color cast 
that’s in the shadows even after the white balance has been adjusted). For more infor-
mation on correcting a shadow color cast, see “Correcting a shadow color cast” on 
page 80.

White Balance Sets the color balance of the image to reflect the lighting conditions 
under which the photo was taken. In many cases, choosing a white balance from the 
White Balance menu provides satisfactory results. In some cases, you may want to 
customize the white balance using the Temperature and Tint adjustments.

Note: The Photoshop Camera Raw plug-in can read the white balance settings of some 
cameras. Leaving the White Balance menu set to As Shot uses the camera’s white balance 
settings. For cameras whose white balance settings are not recognized by the Photoshop 
Camera Raw plug-in, leaving the White Balance menu set to As Shot is the same as 
choosing Auto: the Photoshop Camera Raw plug-in reads the image data and automati-
cally adjusts the white balance. 
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Temperature Lets you fine-tune the white balance to a custom color temperature. Set 
the color temperature using the Kelvin color temperature scale. Moving the slider to the 
left corrects for a photo taken with a lower color temperature of light; the plug-in makes 
the image colors bluer to compensate for the lower color temperature (yellowish) of the 
ambient light. Conversely, moving the slider to the right corrects for a photo taken with a 
higher color temperature of light; the plug-in makes the image colors warmer (yellowish) 
to compensate for the higher color temperature (bluish) of the ambient light.

Correcting the white balance 
A. Moving the Temperature slider to the right corrects a photo taken with a higher color 
temperature of light B. Moving the Temperature slider to the left corrects a photo taken with 
a lower color temperature of light C. Resulting photo with color temperature adjustment

Tint Lets you fine-tune the white balance to compensate for green or magenta tint in 
photos. Moving the slider to the left (negative values) adds green to the photo, while 
moving the slider to the right (positive values) adds magenta.

To adjust the white balance quickly, select the White Balance tool , and then click an 
area in the preview image that should be a neutral gray or white. The Temperature 

and Tint sliders automatically adjust to make the selected color exactly neutral (if 
possible). If you’re clicking whites, choose a highlight area that contains significant white 
detail rather than a specular highlight.

Using White Balance tool to click a neutral white area and result

A

C

B
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Making tonal adjustments
The Adjust tab in the Camera Raw dialog box has five sliders for making tonal adjustments 
to your image.

Exposure Adjusts the brightness or darkness of the image. Moving the slider to the left 
darkens the image, while moving the slider to the right brightens the image. The values 
are in increments equivalent to f-stops. A +1.50 adjustment is similar to increasing the 
aperture 1 1/2 stops wider. Likewise, a –1.50 adjustment is like reducing the aperture 
1 1/2 stops.

Holding down the Alt (Windows) or Option (Mac OS) key while moving the Exposure 
slider lets you preview where the highlights become completely white with no detail 

(clipped). One way to use this feature is to adjust the slider until the highlights (not 
specular highlights) are completely clipped, and then back off slightly on the adjustment. 
Black indicates areas that are not clipped, and color indicates areas that are being clipped 
in only one or two channels.

Holding the Alt (Windows) or Option (Mac OS) key down while moving the Exposure slider shows 
the highlights being clipped.

Note: Clipping is the shifting of pixel values to either the highest highlight value (255) or 
the lowest shadow value (0). Areas of a photo that are clipped are either completely white 
or completely black and have no image detail.

Shadows Controls what input levels will be mapped to black in the final image. Moving 
the slider to the right increases the areas that are mapped to black. This sometimes creates 
the impression of increased contrast in the image. Using the Shadows slider is similar to 
using the black point slider for the input levels in the Photoshop Levels command. For 
more information on levels, see “Using the Levels dialog box” on page 185.

Note: Holding down the Alt (Windows) or Option (Mac OS) key while moving the Shadow 
slider lets you preview where the shadows become completely black with no detail 
(clipped). One way to use this feature is to move the slider until the shadows begin to get 
clipped, and then back off slightly on the adjustment. Color indicates areas that are being 
clipped in one or two channels, and white indicates areas that aren’t clipped.

Brightness Adjusts the brightness or darkness of the image, similar to the Exposure 
slider. However, instead of clipping the image in the highlights (areas that are completely 
white, no detail) or shadows (areas that are completely black, no detail), Brightness 
compresses the shadows and expands the highlights when the slider is moved to the left. 
Generally, you use the Brightness slider to adjust the overall brightness or darkness after 
you set the white and black clipping points with the Exposure and Shadow sliders.
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Contrast Adjusts the midtones in an image. Higher values increase the midtone contrast, 
while lower values produce an image with less contrast. Generally, you use the Contrast 
slider to adjust the contrast of the midtones after setting the Exposure, Shadow, and 
Brightness values.

Saturation Adjusts the color saturation of the image from –100 (pure monochrome) to 
+100 (double the saturation).

Using the Sharpness slider to reduce blur
In the Detail tab of the Camera Raw dialog box, the Sharpness slider adjusts the image 
sharpening to provide the edge definition you wish. The Sharpness adjustment is a 
variation of the Photoshop Unsharp Mask filter, which locates pixels that differ from 
surrounding pixels based on the threshold you specify and increases the pixels’ contrast 
by the amount you specify. When opening a camera raw image file, the Photoshop 
Camera Raw plug-in calculates the threshold to use based on camera model, ISO, and 
exposure compensation. Users can choose whether sharpening is applied to all images or 
just previews.

To adjust the amount of sharpening:

1 Zoom the preview image to at least 100%.

2 Move the slider to the right to increase the amount of sharpening and to the left to 
decrease the amount of sharpening. A zero value turns off the Camera Raw sharpening. 
In general, the Sharpness slider should be set to a lower value for cleaner images. 

If you’re not planning to edit the image extensively in Photoshop, use the Photoshop 
Camera Raw plug-in’s Sharpness filter. However, if you plan to edit the image exten-

sively in Photoshop, turn off the Camera Raw sharpening, and later use the sharpening 
filters in Photoshop as the last step after all other editing and resizing is complete. 

To specify whether an image or preview is sharpened:

1 Do one of the following:

• (Windows and Mac OS) In the Advanced mode, choose Preferences from the Photoshop 
Camera Raw plug-in menu.

• (Mac OS) With the Camera Raw dialog box open, choose Photoshop > Preferences.

2 In the Camera Raw Preferences dialog box, choose one of the following:

All Images Applies sharpening to the camera raw image.

Preview Images only Applies sharpening only to the preview image and not the actual 
camera raw image. This option is for users who do not want to apply sharpening with the 
Photoshop Camera Raw plug-in.

Reducing noise
The Detail tab of the Camera Raw dialog box has controls to reduce image noise, the 
extraneous visible artifacts that degrade image quality. Image noise is made up of 
luminance (grayscale) noise, which makes an image look grainy, and chroma (color) noise, 
which is usually visible as colored artifacts in the image. Photographing with a higher ISO 
or less-sophisticated digital camera can result in images with objectionable noise. 
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Luminance Smoothing reduces grayscale noise, while Color Noise Reduction reduces 
chroma noise. Moving a slider to zero turns off its noise reduction.

When making Luminance Smoothing or Color Noise Reduction adjustments, first 
zoom in on the preview image for a better view.

Moving the Luminance Smoothing slider to the right reduces grayscale noise, and moving the Color 
Noise Reduction slider to the right reduces chroma noise.

Compensating for chromatic aberration
Chromatic Aberration is a common lens defect in which the lens focuses different 
frequencies (colors) of light differently. One type of chromatic aberration results in the 
different colors being in focus, but each color’s image is a slightly different size. This type 
of aberration results in complementary color fringing in areas away from the center of the 
image. For example, the fringing can appear as a red fringe on the side of an object toward 
the center of the image, and cyan fringe on the side of the object away from the center of 
the image. The controls in the Lens tab address this problem.

To compensate for chromatic aberration:

1 Make sure the Camera Raw dialog box is in Advanced mode.

2 Zoom into an area near the corner of the preview image. For the best results, the area 
should contain very dark or black detail against a very light or white background. The 
color fringing should be visible.

3 In the Lens tab, move one or more of the following sliders:

Chromatic Aberration R/C Adjusts the size of the red channel relative to the green 
channel. This compensates for red/cyan color fringing.

Chromatic Aberration B/Y Adjusts the size of the blue channel relative to the green 
channel. This compensates for blue/yellow color fringing.

Watch the preview image as you move the slider to the left or right. If you’re adjusting 
red/cyan color fringing, you can hold down the Alt (Windows) or Option (Mac OS) key to 
hide the blue/yellow color fringing. Similarly, holding down the Alt (Windows) or Option 
(Mac OS) key while adjusting the blue/yellow color fringing will hide the red/cyan color 
fringing. Your goal is to reduce the color fringing as much as possible.
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Compensating for lens vignetting
Vignetting is common lens defect where the edges, especially the corners, of an image are 
darker than the center.

To compensate for lens vignetting:

1 Make sure the Camera Raw dialog box is in Advanced mode.

2 In the Lens tab, move the Vignetting Amount slider to the right (positive values) to 
lighten the corners of the image or move the slider to the left (negative values) to darken 
the corners of the image. You can also enter values in the Vignetting Amount text box.

3 Move the Vignetting Midpoint slider to the left (lower value) to apply the Vignetting 
Amount adjustment to a larger area away from the corners, or move the slider to the right 
(higher value) to restrict the Vignetting Amount adjustment closer to the corners. You can 
also enter a value in the Vignetting Midpoint text box.

Correcting a shadow color cast
Sometimes there is a remaining color cast in the shadow areas, even after the highlight 
white balance is adjusted using the Temperature and Tint sliders. The Calibrate tab has a 
Shadow Tint slider to correct this remaining shadow color cast.

To remove a color cast in the shadows:

1 Make sure the Camera Raw dialog box is in Advanced Mode.

2 In the Calibrate tab, move the Shadow Tint slider to remove the color cast in the 
shadows. The colors that the Shadow Tint slider adjusts depends on your camera’s sensor 
and the white balance. Usually, moving the slider to the left (negative values) adds green 
to the shadow areas, and moving the slider to the right (positive values) adds magenta. 

Making advanced color adjustments
Sometimes colors rendered by the Photoshop Camera Raw plug-in do not look as 
expected. This could be due to the difference between a camera's profile and the 
Photoshop Camera Raw plug-in’s built in profile for the camera model. Other reasons 
might include photographs taken in nonstandard lighting conditions that extend outside 
the compensating range of the Photoshop Camera Raw plug-in. The Calibrate tab has Hue 
and Saturation sliders to adjust Photoshop Camera Raw plug-in’s built-in camera profile to 
render nonneutral colors differently.

To adjust the rendering of nonneutral colors:

1 Make sure the Camera Raw dialog box is in Advanced Mode.

2 In the Calibrate tab, use the Hue and Saturation sliders to adjust the red, green, and 
blue in the image. Watch the preview image as you make the adjustments until the image 
looks correct to you. In general, first adjust the hue first and then adjust its saturation. 
Moving the Hue slider to the left (negative value) is like a move counterclockwise on the 
color wheel and moving the slider to the right (positive value) is like a move clockwise on 
the color wheel. Moving the Saturation slider to the left (negative value) desaturates the 
color and moving the slider to the right (positive value) increases the saturation.
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About Photoshop Camera Raw plug-in settings
When a camera raw image file is opened with the Photoshop Camera Raw plug-in, the 
settings are stored in one of two places: the Camera Raw database file or a sidecar XMP 
file. The stored settings let Photoshop remember the setting for each individual camera 
raw image file. When you open a given camera raw image the next time, all the settings 
sliders default to the same values used the last time to open that specific camera raw 
image. Image attributes (target color space profile, bit depth, pixel size, and resolution) 
are not part of the stored settings.

You can determine where the settings are stored using the Camera Raw Preferences. 

To specify where a camera raw image file’s settings are stored:

1 Open the Camera Raw Preferences by doing one of the following:

• (Windows and Mac OS) In the Advanced mode, choose Preferences from the Photoshop 
Camera Raw plug-in menu.

• (Mac OS) With the Camera Raw dialog box open, choose Photoshop > Camera Raw 
Preferences.

2 In the Camera Raw Preference dialog box, choose one of the following from the Save 
Image Settings In menu:

Camera Raw database Stores the settings in a Camera Raw database file, generally 
located in the user’s Application Data folder as Document and Settings/user name/Appli-
cation Data/Adobe/CameraRaw (Windows) or the user’s Preferences folder as Users/user 
name/Library/Preferences (Mac OS). This database is indexed by file content, so settings 
stick to the image even if the camera raw image file is renamed or moved. 

Sidecar “.xmp” files Stores the settings in an XMP file in the same folder as the raw file 
with the same base name and an XMP extension. This option is useful for long-term 
archiving of raw files with their associated settings, and for the exchange of raw files with 
associated settings in multi-user workflows. These same sidecar XMP files can be used to 
store IPTC (International Press Telecommunications Council) data or other metadata 
associated with a camera raw image file. If you are opening camera raw files from a read-
only volume like a CD or DVD, be sure to copy the files to your hard drive before opening 
them. The Photoshop Camera Raw plug-in cannot write an XMP file to a read-only volume 
and will default to writing the settings to the Camera Raw database file.

These XMP files can be viewed in the File Browser by choosing View > Unreadable Files.

Saving, applying, and updating Photoshop Camera Raw settings
You can save Photoshop Camera Raw plug-in settings for a specific camera or a specific 
lighting condition and reapply them on other camera raw images. You can also save a 
settings file that contains only a subset of the Photoshop Camera Raw plug-in settings. 
When this subset file is then loaded, only those sliders are updated. This lets you create 
settings presets for custom white balances, specific lens settings, and so forth. Using the 
File Browser, you can also update all or a subset of the settings applied to camera raw 
images.
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To save Photoshop Camera Raw settings:

1 After making your adjustments in the Camera Raw dialog box, do one of the following:

• Choose Save Settings from the Photoshop Camera Raw plug-in menu  to save the 
current settings and add them to the Settings menu. The settings will then be available 
to apply to another image.

• Choose Set Camera Default from the Photoshop Camera Raw plug-in menu to set a 
default setting for other images that come from the same camera. You can have 
multiple defaults for different cameras.

Make sure that you save the setting to the Camera Raw preset folder so the setting is 
always present in the Settings menu. Settings saved elsewhere will disappear from the 
Settings menu once you’ve chosen another setting. If this happens, you must use the Load 
mechanism to get the setting.

Note: Choose Reset Camera Default from the Photoshop Camera Raw plug-in menu to 
return the default settings to the original Photoshop Camera Raw plug-in settings.

To save a settings subset:

1 In the Advanced mode, choose Save Settings Subset from the Photoshop Camera Raw 
plug-in menu.

2 Specify the settings to be saved by doing one of the following:

• Choose an option from the Subset menu.

• Select/deselect the settings from the Settings list.

3 Click Save.

4 In the Save Raw Conversion Settings dialog box, name and save the setting subset.

To apply saved Photoshop Camera Raw settings:

In the Camera Raw dialog box, do one of the following:

• From the Settings menu, choose:

Selected Image Uses the settings from the selected camera raw image. This setting 
becomes First Selected Image when a batch of camera raw images is selected. The settings 
for the first image in the selected batch will be applied to all the images in the batch.

Camera Default Uses the saved default settings for a specific camera.

Previous Conversion Uses the settings from the previous image of the same camera.

A camera raw image file Uses the setting from a previously opened camera raw file. Up 
to 100 files can appear in the Settings menu.
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• From the Photoshop Camera Raw plug-in menu, choose Load Settings and then select a 
saved setting.

Apply Camera Raw Settings dialog box in Advanced mode

To update settings applied to camera raw image files:

1 In the File Browser, select one or more camera raw image files to update.

2 Do one of the following to open the Apply Camera Raw Settings dialog box:

• From the File Browser menu, choose Automate > Apply Camera Raw Settings.

• Right-click (Windows) or Control-click (Mac OS) a selected image and choose Apply 
Camera Raw Settings from the context menu.

3 In the Apply Camera Raw Settings dialog box, select Advanced mode if you only want 
to update a subset of the settings in the selected camera raw files.

4 Choose a setting to apply:

• In Basic mode, choose from the Apply Settings From menu; in Advanced mode, choose 
from the Settings menu:

Selected Image Uses the settings from the selected camera raw image. This setting 
becomes First Selected Image when a batch of camera raw images is selected. The settings 
for the first image in the selected batch will be applied to all the images in the batch.

Camera Default Uses the saved default setting for a specific camera.

Previous Conversion Uses the settings from the previous image of the same camera.

Load Settings Uses a saved setting. In the Advanced mode, this option is available from 
the Apply Camera Raw Settings menu.

A camera raw image file Uses the setting from a previously opened camera raw file. Up 
to 100 files can appear in the Settings menu.
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• In Advanced mode, you have the following additional option in the Apply Camera Raw 
Settings menu:

Reset Camera Default returns the settings to the original Photoshop Camera Raw 
plug-in default settings.

5 To apply a settings subset, specify the settings to update by doing one of the following 
in the Update area:

• Choose an option from the Update menu.

• Select/deselect the settings from the Update list.

6 Click Update. The next time you open the camera raw image file, the updated settings 
are applied.

If you copy and paste one or more copies of a camera raw file to your desktop, all instances 
of the camera raw file will be updated if either the original or a copy have their settings 
updated.

To delete Photoshop Camera Raw settings:

Choose Delete Current Settings from the Photoshop Camera Raw plug-in menu.

Creating an action to open camera raw image files
You can automate opening camera raw image files, editing them, and saving the files in 
formats like TIFF, PSD, JPEG, Large Document Format (PSB), and PDF. In Photoshop, you 
can also use the Batch command or Create Droplet command to open one or more 
camera raw image files. 

To create an action to open camera raw image files:

1 In the Actions palette, click the New Action button , or choose New Action from the 
palette menu. Enter a name for the action.

2 Click Record. Then open a camera raw image file, and perform the operations you want 
to record. It’s recommended to record the action with Selected Image chosen in the 
Settings menu of the Camera Raw dialog box so that each image’s individual settings 
(from the Camera Raw database or XMP sidecar files) will be used when playing back the 
action. 

If you plan to use the action with the Batch command, you may want to include a Save 
As operation and choose the file format to which you would like the images 

converted.

3 To stop recording, click the Stop button.

The action you’ve created can be used every time you want to open one or more camera 
raw image files. For more information on creating actions, see “About actions” on 
page 627.

Important: When you use an action to open a camera raw image file, the Photoshop 
Camera Raw plug-in settings are based on the settings in the dialog box when the action 
was recorded. You may want to create different actions for opening camera raw image 
files with specific settings.
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To open camera raw image files using the Batch command (Photoshop):

1 From within Photoshop, choose File > Automate > Batch. 

2 In the Play area of the Batch dialog box, choose the action you created to open your 
camera raw image files from the Actions menu.

3 In the Source area, choose from the Source menu:

Folder Processes the images in a chosen folder. After choosing Folder from the Source 
menu, click Choose. In the Choose a Batch Folder dialog box, choose a folder of camera 
raw files. 

Import Imports camera raw image files from a digital camera connected to your 
computer and opens them. Choose a source in the From menu and then skip to step 8.

File Browser Opens the camera raw image files that are displayed in the File Browser.

4 Select Override Action “Open” Commands so the Open commands in the action to refer 
to the batched files rather than the filenames specified in the action. 

Deselect Override Action “Open” Commands only if the action is to operate on open files 
or if the action contains Open commands for specific files that are required by the action.

5 Select Include All Subfolders to process files in subfolders. 

6 Select Suppress File Open Options Dialogs. This prevents the Photoshop Camera Raw 
dialog box from opening for each camera raw image file being processed.

7 Select Suppress Color Profile Warnings to turn off the display of color policy messages.

8 Choose a destination for the opened files from the Destination menu. It’s best to 
choose either None to leave the files open, or Folder to save the opened files to a specific 
folder. This prevents accidently overwriting files.

Note: Select Override Action “Save As” Commands if you want to use the Save As instruc-
tions from the Batch command instead of the Save As instructions in the action. If you 
select this option, the action must contain a a Save As command because the Batch 
command will not automatically save the source files. Deselect Override Action “Save As” 
Commands will save the files processed by the Batch command in the location specified as 
the destination in the Batch dialog box.

Setting the other options in the Batch dialog box is up to your discretion. For more infor-
mation about using the Batch command including all the options in the Batch dialog box, 
see “Using the Batch command (Photoshop)” on page 641.

9 Click OK after you’ve specified all your settings. 

To create a droplet to open camera raw image files (Photoshop):

1 From within Photoshop, choose File > Automate > Create Droplet.

2 Click the Choose button in the Create Droplet dialog box and specify a location for the 
droplet.

3 In the Play area, select Suppress File Open Options Dialogs. This is useful for opening a 
batch of camera raw image files because it prevents the Camera Raw dialog box from 
opening for each camera raw image file being processed.

4 Choose a destination for the opened files from the Destination menu. It’s best to 
choose either None to leave the files open or Folder to save the opened files to a specific 
folder. This prevents accidently overwriting files.



Using Help | Contents | Index Back 86  

Adobe Photoshop CS Help Getting Images into Photoshop and ImageReady 

Using Help | Contents | Index Back 86  

Setting the other options in the Create Droplet dialog box is up to your discretion. 
For more information about using droplets and all the options in the Create Droplet 
dialog box, See “Using droplets” on page 644.)

5 Click OK after you’ve selected all your settings. Later, you can open single or multiple 
camera raw files by dragging them onto the droplet. 

Scanning images
Before you scan an image, make sure that the software necessary for your scanner has 
been installed. To ensure a high-quality scan, predetermine the scanning resolution and 
dynamic range your image requires. These preparatory steps can also prevent unwanted 
color casts from being introduced by your scanner.

Scanner drivers are provided and supported by the manufacturers of the scanners, not 
Adobe Systems Incorporated. If you have problems with scanning, make sure that you are 
using the latest version of the appropriate scanner driver.

When scanning images, try to scan similar images together. For example, it’s better to 
scan dark images with other dark images instead of images that are too light. You’ll 

have better scanned output, and correcting your images will be easier.

Importing scanned images
You can import scanned images directly from any scanner that has an Photoshop-
compatible plug-in module or that supports the TWAIN interface. To import the scan using 
a plug-in module, choose the scanner name from the File > Import submenu. See your 
scanner documentation for instructions on installing the scanner plug-in. For general 
plug-in information, see “Using plug-in modules” on page 57.

If your scanner does not have Photoshop-compatible scanner driver, import the scan 
using the TWAIN interface. (See “Importing scanned images using the TWAIN interface” on 
page 86.)

If you can’t import the scan using the TWAIN interface, use the scanner manufacturer’s 
software to scan your images, and save the images as TIFF, PICT, or BMP files. Then open 
the files in Photoshop or ImageReady.

Importing scanned images using the TWAIN interface 
TWAIN is a cross-platform interface for acquiring images captured by certain scanners, 
digital cameras, and frame grabbers. The manufacturer of the TWAIN device must provide 
a Source Manager and TWAIN Data source for your device to work with Photoshop and 
ImageReady. 

You must install the TWAIN device and its software, and restart your computer, before you 
can use it to import images into Photoshop and ImageReady. See the documentation 
provided by your device manufacturer for installation information.

To import an image using the TWAIN interface (Photoshop):

Choose File > Import, and choose the device you want to use from the submenu.
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To import an image using the TWAIN interface (ImageReady):

1 If you’re using the TWAIN device for the first time with ImageReady, choose File > 
Import > TWAIN Select. Then select the device you want to use. You do not need to repeat 
this step for subsequent use of the TWAIN module.

If more than one TWAIN device is installed in your system and you want to switch devices, 
use the TWAIN Select command. 

2 To import the image, choose File > Import > TWAIN Acquire.

Importing scanned images using WIA (Windows Image 
Acquisition) Support

To import images from a scanner using WIA Support:

1 Choose File > Import > WIA Support.

2 Choose a destination on your computer for saving your image files. 

3 Click Start.

4 Make sure Open Acquired Images in Photoshop is checked. If you have a large number 
of images to import, or if you want to edit the images at a later time, deselect it. 

5 Make sure Unique Subfolder is selected if you want to save the imported images 
directly into a folder named with the current date.

6 Select the scanner that you want to use.

Note: If the name of your scanner does not appear in the submenu, verify that the 
software and drivers were properly installed and that the scanner is connected.

7 Choose the kind of image you want to scan:

• Color picture to use the default settings for scanning color images

• Grayscale picture to use the default settings for scanning grayscale images

• Black and White picture or Text to use the default settings

• Click Adjust the Quality of the Scanned Picture to use custom settings

8 Click preview to view the scan. Crop the scan if needed by pulling the rectangle so it 
surrounds the image.

9 Click Scan.

10 The scanned image will be saved in the BMP file format.

Scanning using the resolution setting (Photoshop)
You can determine the resolution for your scan using the original and final image 
dimensions and the resolution of your output device. Scan resolution translates into 
image resolution when you open the scanned image in Photoshop. 

To estimate scan resolution:

1 Do one of the following:

• For laser printers and imagesetters, multiply the printer’s screen frequency by 2. 
To determine your printer’s screen frequency, check your printer documentation or 
consult your service provider.
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• For inkjet printers, check your printer documentation for the optimal resolution. Many 
dye sublimation printers and devices that print directly onto photographic paper have 
an optimal resolution of 300 to 400 dpi. 

2 Determine the ratio of the final image dimensions to the original image dimensions. 
For example, the ratio of a 6-by-9-inch final image to a 2-by-3-inch original image is 3.

3 Multiply the result of step 1 by the result of step 2.

For example, suppose you are printing to an imagesetter with a screen frequency of 85 lpi 
and the ratio of the final image to the original is 3. First multiply 85 (the screen frequency) 
by 2 to get 170. Then multiply 170 by 3 to get a scan resolution of 510 ppi. If you are 
printing to an inkjet printer with an optimal resolution of 300 dpi, multiply 300 by 3 to get 
a scan resolution of 900.

Note: Different color separation procedures might require different ratios of image 
resolution to screen frequency. It’s a good idea to check with your service provider or print 
shop before you scan the image.

Scanning using the file size setting (Photoshop)
You can create a dummy file to predict the file size needed for the final output of your 
scan. 

To calculate the file size before scanning an image:

1 In Photoshop, choose File > New. 

2 Enter the width, height, and resolution for your final printed image. The resolution 
should be 1.5 to 2 times the screen frequency you will use to print. Make sure that the 
mode you plan to scan in is selected. For more information, see “About the different color 
modes (Photoshop)” on page 150. The New dialog box displays the file size.

For example, suppose you want the final image to be 4 inches wide and 5 inches high. 
You plan to print it with a 150-line screen using a 2:1 ratio, so you set the resolution to 300. 
The resulting file size is 5.15 MB.

To produce the scan, enter the resulting file size in your scanner settings. Don’t worry 
about resolution or image dimensions. After you have scanned the image and imported it 
into Photoshop, use the Image Size command (with the Resample Image option 
deselected) to enter the correct width and height for the image.

Optimizing the dynamic range of the scan (Photoshop)
Keep in mind that the human eye can detect a wider tonal range than can be printed. 
If your scanner allows, set the black and white points before scanning a file to produce the 
best tonal range and capture the widest dynamic range. Then use Photoshop’s color 
adjustment tools to set the white and black points for the scanned image. (See “Using the 
color adjustment tools” on page 180.)

Eliminating unwanted color casts (Photoshop)
If your scanned image contains an unwanted color cast, you can perform a simple test to 
determine whether the cast was introduced by your scanner. If it was, you can use the 
same test file to create a color-cast correction for all images scanned with the scanner. 
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To identify and correct a color cast introduced by a scanner:

1 Make sure that your monitor has been calibrated. (See “Calibrating and creating 
profiles” on page 119.) 

2 Open a new Photoshop file, and use the Linear Gradient tool  to create a blend from 
pure black to pure white.

3 Choose Image > Adjustments > Posterize, and posterize the blend using 11 levels.

4 Print the 11-step gray wedge on a black-and-white printer, and then scan it into 
Photoshop.

Note: You can also perform this test using an 18-percent neutral gray card or an 11-step 
gray wedge from a photography store.

5 Open the Info palette, and read the RGB values on-screen for each of the gray levels. 
Uneven R, G, and B values indicate a color cast. 

6 Use Levels or Curves to correct the color cast, and then save the dialog box settings. 
(See “Using Levels to adjust color (Photoshop)” on page 188.)

7 Open the scanned image you want to correct, reopen the dialog box you used to 
correct the cast in step 6, and load the saved settings.

Creating new images 
The New command lets you create a blank image. If you’ve copied a selection to the 
Clipboard, the image dimensions and resolution are automatically based on that 
image data.

To create a new image:

1 Choose File > New.

2 If desired, type a name for the image, and set the width and height.

(Photoshop) To match the width and height of the new image to that of any open 
image, choose a filename from the bottom section of the Windows menu.

3 (Photoshop) Set the resolution and mode. For more information, see “Understanding 
image size and resolution” on page 62 and “About the different color modes (Photoshop)” 
on page 150.

4 Select an option for the contents of the background layer (Photoshop) or first layer 
(ImageReady) of the image:

• White to fill the background or first layer with white, the default background color.

• Background Color to fill the background or first layer with the current background color. 
(See “Choosing foreground and background colors” on page 351.)

• Transparent to make the first layer transparent, with no color values. The resulting 
document will have a single, transparent layer as its contents.

5 Under Advanced, choose a color profile, or choose Don’t Color Manage this Document. 
For Pixel Aspect Ratio, choose Square unless you’re using the image for video. In that case, 
choose another option to use non-square pixels. (See “Saving images for use in video” on 
page 604.)
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6 When you’re finished, you can save the settings as a preset by clicking the Save Preset 
button, or you can click the OK button to open the new file.

Using the File Browser (Photoshop)
File Browser lets you view, sort, and process image files. You can use the File Browser to 
perform tasks such as creating new folders; renaming, moving, and deleting files; and 
rotating images. You can also view individual file information and data imported from 
your digital camera.

The Photoshop File Browser 
A. Palette pop-up menu B. Palettes C. Toolbar D. Caption E. Location bar F. Main window
G. Flag icon H. Selected file I. Rank

About the File Browser window
The File Browser helps you to manage and organize your images. To open the File Browser, 
choose File > Browse or Window > File Browser, or click the File Browser button  in the 
options bar. The File Browser window is made up of several areas.

Palettes area The palettes area contains four palettes: Folders, Preview, Metadata, and 
Keywords. You can use the Folders palette to navigate through the folders on your 
computer (see “Working with files and folders” on page 92). Thumbnails of images appear 
in the Preview palette (see “Viewing images” on page 91.) The Keywords palette helps you 
organize your images by attaching keywords to them (see “Working with keywords” on 
page 93). The Metadata palette contains metadata information for images (see “Working 
with the metadata palette” on page 97).

Toolbar At the top of the File Browser, the File Browser toolbar contains menu options 
and shortcut buttons to help you efficiently work with your files. The location bar is 
directly below the shortcut buttons.

A
D

E

B
F

C

G H I



Using Help | Contents | Index Back 91  

Adobe Photoshop CS Help Getting Images into Photoshop and ImageReady 

Using Help | Contents | Index Back 91  

Customizing the File Browser window
The File Browser window can be customized by moving and resizing the palettes. 
For example, you can resize the Preview palette to make it bigger so you can view larger 
thumbnails. You cannot, however, move palettes to a new area in the File Browser window, 
or outside of the window.

Customizing the palette display Do any combination of the following:

• Drag one palette into another to dock the palettes together.

• Drag a palette’s horizontal divider bar up or down to make the palette larger or smaller.

• Drag a palette’s vertical divider bar right or left to make the palette larger or smaller.

• Double-click a palette’s tab to minimize it.

• Double-click a minimized palette’s tab to open it.

Though Photoshop remembers the arrangement of the File Browser when you close 
it, once you’ve set up the File Browser the way you want to use it, you may want to 

create a new workspace. You can save other workspaces with the File Browser set up 
differently any number of times so that you have several customized configurations 
(see “Saving workspaces” on page 22).

Viewing images
When you click a folder in the Folders palette, the contents of the folder are displayed. 
When you select an image file, a preview of the file is shown in the Preview palette. 

Viewing unreadable files To view files that Photoshop can’t open (spreadsheets, 
for example), Choose View > Unreadable Files.

Showing and hiding folders Choose View > Folders. When this option is selected, both 
images and folder display.

Displaying the location of files Choose View > Reveal Location in Explorer (Windows) 
or View > Reveal Location in Finder (Mac OS). When you choose this command, Explorer 
(Windows) or Finder (Mac OS) opens the folder containing the image file on your 
computer.

Refreshing the view Choose View > Refresh. When you choose this command, the 
contents of the selected folder in the Folder palette are updated. Closing and reopening 
the File Browser also refreshes the view.

Choosing a view option Choose an option from the View menu.

Selecting and opening images
Before you can work with a file, you need to select it. You can select more than one file at a 
time. You can open files in Photoshop or in ImageReady.

Selecting files Do any of the following:

• Click the thumbnail of a file. 

• Shift-click to select contiguous images.

• Ctrl-click (Windows) or Command-click (Mac OS) to select noncontinuous images

• Choose Edit > Select All from the File Browser menu bar to select all the files in the 
current folder.
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Opening files in Photoshop Select the file or files you want to open, and do one of the 
following: 

• Select a file and press Enter (Windows) or Return (Mac OS).

• Double-click a selected file.

• Choose Open from the palette menu. 

Opening files in ImageReady Select the file or files you want to open in ImageReady, 
and then choose File > Edit in ImageReady.

Working with files and folders
In the File Browser, you can manage your image files by adding, deleting, and moving 
them. You can also add folders to the Favorite Folders list for quick access to your most 
frequently used folders.

The Folder palette is where you can see the folder hierarchy of the files displayed in the 
File Browser. 

Creating new folders Choose File > New Folder. Type a name, and press Enter (Windows) 
or Return (Mac OS).

Adding a folder to Favorites Select a folder, and then choose File > Add Folder to 
Favorites. To remove a folder from Favorites, choose File > Remove Folder from Favorites.

Dragging files into the File Browser Select a file on your desktop, or in another appli-
cation. Drag and drop the file into the File Browser window.

Dragging and dropping a file onto the Preview palette or the main window moves or 
copies the file. To view the contents of a folder, drag and drop a file or a folder on to 

the Preview, Metadata, or Keywords palette.

Deleting files Select the file or files you want to delete, and do one of the following

• Click the Trash button.

• Drag the files to the Trash button .

• Press the Delete key.

• Choose File > Delete.

You can also delete empty folders using the above procedure.

Moving files Select the file, and then drag it to a different folder.

Moving a file from the File Browser to the Desktop

To quickly attach an image to an e-mail message, drag the image from the File 
Browser and drop it into the e-mail message.
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Copying files Select the file, and then Alt-drag (Windows) or Option-drag (Mac OS) it to a 
different folder.

Rotating files Select one or more files. To rotate the images clockwise by 90°, click the 
Rotate Clock Wise button  or choose Edit > Rotate 90 degrees CW. To rotate the images 
counter-clockwise, click the Rotate Counter-Clock Wise button  or choose Edit > Rotate 
90 degrees CCW. To rotate the image 180°, choose Edit > Rotate 180. To complete the 
rotation, choose Edit > Apply Rotation. 

If you don’t apply the rotation, the image is rotated only in the File Browser. Be sure to 
choose Edit > Apply Rotation so you can open the properly rotated image in other 

applications.

Working with keywords
The Keyword palette lets you create and apply keywords to files. Using keywords, you can 
group files together by their content. You can then view groups of files using the 
keywords. Keywords are organized in sets called categories.

File Browser Keywords palette 
A. Keyword group B. Keyword C. Selected keyword D. Click to show/hide content of keyword 
group E. Group with one or more keywords applied F. Keyword applied

Adding keyword to files Select one or more files. In the Keywords palette, click the box 
next to the name of the keyword you want to add, or double-click the keyword. A check 
mark appears in the box next to the keyword when it’s added to a file.

Adding a set of keywords to files Select one or more files. In the Keywords palette, 
click the box next to the name of the keyword group, or double-click the keyword group. 
A check mark appears in the box next to the keyword group when it’s added to a file.

You may want to create a group of keywords you frequently use so you can apply 
them as a group.

Removing keywords from a file Select the file, and then click the box next to the name 
of the keyword you want to remove, or double-click the keyword.

Creating a new keyword Click the New Keyword button . Name your keyword, and 
then click OK. 

Creating a new keyword set Click the New Keyword Set button . Name the keyword 
group, and then click OK.
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Renaming a keyword or category Select the keyword or category and then click the 
inverted triangle  to display the palette menu. Choose Rename from the menu, and then 
enter a new name for the keyword or category.

When you rename a keyword, the keyword’s name isn’t changed in files that currently 
contain it. The original name stays in the file.

Recategorizing a keyword Click and drag the keyword into another category.

Deleting a keyword Select the keyword by clicking its name, and then click the Delete 
Keyword button .

Keywords that you get from other users appear in the Other Keywords category until 
you recategorize them.

Sorting and ranking files
The File Browser allows you to sort files using several sort options. You can also sort by 
ascending or descending order.

Ranking lets you manually control the sort order of files. You can edit the ranking of an 
image.

Sorting files Choose an option from the Sort menu.

Sorting by ascending or descending order Choose Sort > Ascending Order. A check 
mark indicates that files are sorted in ascending order. No check mark indicates 
descending order.

Ranking files: Select one or more files. Choose View > Show Rank from the File Browser 
menu bar, and then do one of the following:

• If you’re ranking one file, click the Rank text box below the image thumbnail, type a 
rank (containing letters or numbers), and press Enter (Windows) or Return (Mac OS). 

• If you have one or more files selected, choose Edit > Rank, type a letter, and press Enter 
(Windows) or Return (Mac OS). 

Flagging files
Flagging files is a flexible way for you to quickly reduce a large number of files into a 
smaller, more manageable group. You can choose to view only flagged files, or unflagged 
files.

For example, if you’ve just imported a large number of images, you can then view the files 
in the File Browser. You can review each new image you have, and then flag the images 
you want to keep. After this initial pass, you can view only files you’ve flagged, then drag 
images around to group or rank them, or apply metadata.

When you view different folders, the File Browser always shows you both Flagged and 
Unflagged files until you choose another option.

Flagging files Select one or more files you want to flag. Click the Flag File button . 
The flag icon appears at the bottom right of the thumbnail.
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Unflagging files Select the flagged file, and then click the Flag File button.

Viewing only flagged files Select Flagged Files from the Show menu next to the 
Location bar. You can also choose View > Flagged Files. 

Viewing only unflagged files Select Unflagged Files from the Show menu, or choose 
View > Unflagged Files.

Viewing all files Select Flagged and Unflagged Files from the Show menu, or choose 
View > Flagged and Unflagged Files.

Searching for files
You can perform searches in the File Browser. You can run very specific searches, by adding 
up to 12 search criteria to narrow your search. Criteria limiters let you precisely target your 
search. 

Search criteria, and results from the search

To search files:

1 Choose File > Search.

2 In the Search dialog box, choose a source folder from the Look In menu. By default, 
the menu displays the currently active folder. Click the Browse button to navigate to 
another folder. 

Choose Include all Subfolders to expand the search into any subfolders located in the 
source folder.

3 Choose a criteria for your search by selecting an option from the leftmost menu.

4 Select a limiter from the center menu. 

5 Enter text in the text box at the right, if needed.
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6 To add another search criteria, click the plus sign button  . To remove an empty 
search criteria, click the minus sign button  .

7 Click the Search button.

8 The results of your search displays in the Folders palette so you can navigate through 
the files.

Running automated tasks from the File Browser
Commands in the Automate menu in the File Browser help you quickly produce things like 
picture packages and Photomerge compositions using photos you select in the File 
Browser. Running these tasks from the File Browser saves you a lot of time, because you 
don’t have to open each individual file.

To run an automated task:

1 Select the files you want to use. (See “Selecting and opening images” on page 91.)

2 Choose a command from the Automate menu:

Batch Loads the Photoshop Batch dialog box so you can play an action on the folders 
you’re viewing in the File Browser. (See “Using the Batch command (Photoshop)” on 
page 641.)

PDF Presentation Loads the PDF Presentation dialog box so you can use the images 
selected in the File Browser to create a slide show, presentation, or document in one multi-
paged PDF document (see “Creating a PDF presentation” on page 598).

Contact Sheet II Starts the Contact Sheet dialog box so you can print a series of 
thumbnail previews on a single page (see “Creating contact sheets” on page 594).

Online Services Order prints of your images from online service providers (see “Using 
online services” on page 626).

Photomerge Combines the files selected in the File Browser into one continuous image. 
(See “Creating panoramic images using Photomerge (Photoshop)” on page 284.)

Picture Package Prints out multiple copies of the source image selected in the File 
Browser on a single page, similar to the photo packages traditionally sold by portrait 
studios (see “Creating picture packages” on page 595).

Web Photo Gallery Automatically generate a Web photo gallery from the images you’ve 
selected in the File Browser. A Web photo gallery is a Web site that features a home page 
with thumbnail images and gallery pages with full-size images (see “Creating Web photo 
galleries (Photoshop)” on page 500).
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Renaming files and folders
You can rename files and folders in the File Browser individually or in a group, or batch. 
When you batch rename files, you can choose the same settings for all the selected files. 
Batch renaming files in the File Browser can save you a lot of time.

Batch renaming files using a combination of file naming elements and text

Renaming a file or folder Select a file or folder, and then click the filename, or right-click 
(Windows) or Control-click (Mac OS) the file or folder to display the context menu, then 
choose Rename from the context menu. Type a new name, and press Enter (Windows) or 
Return (Mac OS). 

Note: To move to the next filename, press Tab. To move to the previous filename, press 
Shift+Tab.

Batch renaming files Select the files you want to rename, or select a folder in the Folders 
palette. Then choose Automate > Batch Rename, and set the following options:

• For Destination Folder, select where you want to place the renamed files: in the same 
folder or in a different folder. If you select Move to New Folder, click Browse (Windows) 
or Choose (Mac OS) to select a different folder.

• For File Naming, choose elements from the menus or enter text into the fields. The 
specified elements and text will be combined to create the new filename. 

• For Compatibility, select the operating systems with which you want renamed files to 
be compatible. The current operating system is selected by default, and you cannot 
deselect it.

Working with the metadata palette
The Metadata palette is where you can view and edit the metadata for selected files. 
Metadata preserves information about the contents, copyright status, origin, and history 
of documents, and can be used to search for files.

Metadata is increasingly important in all types of publishing. You can create metadata 
templates to apply to files in order to add a copyright statement, for example (see “Adding 
metadata to files” on page 99).
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You can choose the types of metadata displayed in the Metadata in the Metadata display 
options dialog box.

If you have applied metadata to an Adobe Acrobat PDF file, some keywords may not 
appear, however, these keywords are still attached to the PDF file.

The following types of metadata appear in the File Browser’s Metadata palette:

File Properties Describes the characteristics of the file, including the size, creation, and 
modification dates.

IPTC The only category of editable metadata, IPTC Info lets you add a caption for your 
files, as well as copyright information.

Camera Data (EXIF) Assigned by digital cameras, EXIF information includes the camera 
settings that were used when the image was taken.

GPS Displays navigational information from a Global Positioning System (GPS). Some 
digital cameras have GPS technology. Photos without GPS information won’t have any 
GPS metadata.

Camera Raw Displays metadata for files in the Camera Raw format. For more information 
on Camera Raw, see “Working with camera raw image files” on page 71.

Edit History Keeps a log of changes made to images (see “Working with the Edit History 
Log” on page 38).

To view metadata:

Select a file. The metadata for the file appears in the Metadata palette. Use the scroll bars 
to view hidden categories.

If you have more than one file selected, metadata that is common to the files displays 
in the Metadata palette.

To edit IPTC metadata:

1 Click the pencil icon  to the left of the metadata field you want to edit (fields without 
the pencil icon can’t be edited). 

2 Type in the text box to edit or add metadata.

3 Press Tab to move through metadata fields.

4 When you’re done editing the metadata, click the Apply button . To cancel any 
changes you’ve made, click the Cancel button .

Editing metadata 

To customize the view of metadata:

1 Do one of the following:

• Choose Metadata Display Options from the Metadata palette menu.
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• Choose Edit > Metadata Display Options.

2 In the Metadata Display Options dialog box, select or deselect metadata fields you’d 
like to view or hide.

3 Select the Hide Empty Fields option if you don’t want to view fields with no information 
in them.

4 When you’re done, click the OK button.

Adding metadata to files
You can add metadata to files saved in Photoshop (PSD), PDF, EPS, PNG, GIF, JPEG, and TIFF 
formats. The information you add is embedded in the file using XMP (eXtensible Metadata 
Platform). XMP facilitates the exchange of metadata between Adobe applications and 
across publishing workflows. For example, you can save metadata from one file as a 
template, and then import the metadata into other files.

The XMP Software Development Kit can be used to customize the creation, 
processing, and interchange of metadata. For example, the XMP SDK can be used to 

add fields to the File Info dialog box. More information on XMP and the XMP SDK is 
available from the Adobe Solutions Network. 

To add metadata to a document:

1 Choose File > File Info.

2 Select a category from the list on the left side of the dialog box, enter the desired infor-
mation, and click OK. 

• Description to specify information about the document, such as document title, author, 
description, and keywords that can be used to search for the document. To specify 
copyright information, select Copyrighted from the Copyright Status pop-up menu. 
Then enter the copyright notice string and the URL of the person or company who 
owns the copyright. 

• Origin to provide information on the history of the artwork. To enter the current date in 
a short text format, click Today. For Credit, enter the information needed in the credit 
line for a copyrighted image. Transmission Reference provides the Associated Press 
with information on the original transmission location of the artwork. For Urgency, 
specify the editorial urgency of the artwork—not its handling priority.

• Advanced to view the XMP data for the file in a structured format. 

The information displayed for the following metadata categories are not editable: 
Camera Data 1, Camera Data 2, AP Categories, History, and Raw Data. 

To save metadata as a template:

1 Click the triangle icon at the top of the File Info dialog box, and choose Save Metadata 
Template.

2 Enter a template name, and click Save.

To save metadata to an XMP file:

1 In the Advanced area of the File Info dialog box, click Save.

2 Type a filename, choose a location for the file, and click Save.
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To import metadata into a document:

Choose File > File Info, and then do any of the following:

• Click the triangle icon at the top of the File Info dialog box, and choose a template name 
from the top section of the pop-up menu. The metadata from the template will replace 
the current metadata. To append the current metadata instead, hold down Ctrl 
(Windows) or Command (Mac OS) when you choose the template name.

Note: You must save a metadata template before you can import metadata from a 
template.

• In the Advanced area of the File Info dialog box, click Replace to replace the current 
information with information stored in an XMP file. Locate the XMP file containing the 
metadata you want to import, and click Open.

• In the Advanced area of the File Info dialog box, click Append to add information stored 
in an XMP file to the current file information. For each File Info field, if the field does not 
contain information, it will be updated with contents from the file. Keywords will always 
be appended with the information from the file.

To delete a metadata template:

1 Click the triangle icon at the top of the File Info dialog box, and choose Delete Metadata 
Template.

2 Select the name of the template you want to delete, and click Delete.

To show the location of metadata templates:

Click the triangle icon at the top of the File Info dialog box, and choose Show Templates.

Working with the cache 
The cache stores thumbnail and file information to make loading times quicker when you 
return to a previously viewed folder. However, storing cache takes up disk space. You can 
purge the cache to free up room on your hard disk drive. 

You can also export the cache. Exporting the cache allows you to burn a CD with the cache 
already generated.

Note: Purging the cache deletes ranking, flag, and thumbnail information.

Purging the cache for a folder Choose File > Purge Cache.

Purging the entire cache Choose File > Purge Entire Cache.

Exporting the cache Choose File > Export Cache. The entire cache is exported to the 
current folder in the File Browser. 

Building the cache in subfolders Choose File > Build Cache for Subfolders. The cache for 
just the active folder is exported to the current folder in the File Browser.

Setting File Browser preferences
You can set the following File Browser preferences:

Do Not Process Files Larger Than Specify the maximum file seize that the File Browser 
processes. Large files can slow down the File Browser. 

Display Most Recently Used Folders Enter a number of most recently viewed folders 
that appear in the location bar.
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Custom Thumbnail Size Specify the pixel width of the thumbnails that appear in the 
Preview palette.

Allow Background Processing Select to use extra processing power to pre-generate 
cache information like previews and metadata.

High-Quality Previews Select to view better quality previews of images. Generating 
these larger previews requires more disk space for the cache.

Render Vector Files Select this option if you want the File Browser to display thumbnails 
of vector files, such as Illustrator files.

Parse XMP Metadata from Non-image Files Allows you to view and edit the metadata 
of nonimage files, such as text files.

Keep Sidecar Files with Master Files Allows you to move, copy, delete, or rename XMP 
and THM sidecar files along with the master file. Sidecar files help other applications 
process the metadata associated with a file.

Opening and importing images
You can open and import images in various file formats. The available formats appear in 
the File Browser, the Open dialog box, the Open As dialog box (Windows), or the Import 
submenu. (See “About file formats” on page 582.)

Note: Photoshop and ImageReady use plug-in modules to open and import many file 
formats. If a file format does not appear in the Open dialog box or in the File > Import 
submenu, you may need to install the format’s plug-in module. (See “Using plug-in 
modules” on page 57.)

Opening files
You can open files using the Open command and Open Recent command. In Photoshop, 
you can also open files using the File Browser. For more information, see “Using the File 
Browser (Photoshop)” on page 90.

There may be instances when Photoshop cannot determine the correct format for a file. 
For example, transferring a file between Mac OS and Windows can cause the format to be 
mislabeled. In such cases, you must specify the correct format in which to open the file.

To open a file using the Open command:

1 Choose File > Open.

2 Select the name of the file you want to open. If the file does not appear, select the 
option for showing all files from the Files of Type (Windows) or Show (Mac OS) pop-up 
menu.

3 (Mac OS) Click Show Preview to preview the selected file. This option requires the Apple 
QuickTime extension.

Note: Previews display faster if they are saved with the file. In Photoshop, select Always 
Save for Image Previews in the File Handling preferences to always save a preview; select 
Ask When Saving to save previews on a file-per-file basis.
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4 Click Open. In some cases, a dialog box appears, letting you set format-specific options. 
(See “Opening and importing PDF files” on page 102 and “Opening PostScript artwork” on 
page 104.)

Note: If a color profile warning message appears, specify whether to convert the pixels 
based on the file’s color profile. (See “Calibrating and creating a profile of your monitor” on 
page 119.)

To open a recently used file:

Choose File > Open Recent, and select a file from the submenu.

To specify the number of files that are available in the Open Recent submenu:

1 Do one of the following:

• (Photoshop) In Windows, choose Edit > Preferences > File Handling.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > File Handling.

• (ImageReady) In Windows, choose Edit > Preferences > General.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General.

2 Do one of the following:

• (Photoshop) Enter a number in the Recent File List Contains text box.

• (ImageReady) Enter a number in the Recent Files text box.

To specify the file format in which to open a file (Photoshop):

Do one of the following:

• (Windows) Choose File > Open As, and select the file you want to open. Then choose 
the desired format from the Open As pop-up menu, and click Open.

• (Mac OS) Choose File > Open, and choose All Documents from the Show pop-up menu. 
Then select the file you want to open, choose the desired file format from the Format 
pop-up menu, and click Open.

Important: If the file does not open, then the chosen format may not match the file’s true 
format, or the file may be damaged.

Opening and importing PDF files
Portable Document Format (PDF) is a versatile file format that can represent both vector 
and bitmap data and can contain electronic document search and navigation features. 
PDF is the primary format for Adobe Illustrator and Adobe Acrobat. For more information 
on the PDF format, see “PDF” on page 586.

Some PDF files contain a single image. Other PDF files (called Generic PDF files) may 
contain multiple pages and images. When you open a Generic PDF file, you can choose 
which page to open and specify rasterization options. If you want to open an image 
(versus a page) from a PDF file, you can use the File > Import > PDF Image command.

You can also bring PDF data into Photoshop or ImageReady using the Place command, the 
Paste command, and the drag-and-drop feature. (See “Placing files” on page 105, “Using 
drag and drop to copy between applications” on page 245, and “Using the Clipboard to 
copy between applications” on page 245.)
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To open a PDF file:

1 Choose File > Open.

2 Select the name of the file, and click Open. You can change which types of files show by 
selecting an option from the Files of Type (Windows) or Show (Mac OS) pop-up menu.

3 If you are opening a Generic PDF file, do the following:

• If the file contains multiple pages, select the page you want to open.

• Indicate the desired dimensions, resolution, and mode. If the file has an embedded ICC 
profile and Preserve Embedded Profiles is selected for Color Management Policies in 
the Color Settings dialog box, you can choose the profile from the mode pop-up menu.

• Select Constrain Proportions to maintain the same height-to-width ratio.

• Select Anti-aliased to minimize the jagged appearance of the artwork’s edges as it is 
rasterized.

To import images from a PDF file:

1 Choose File > Import > PDF Image, select the file you want to import images from, 
and click Open.

2 In the PDF Image Import dialog box, select the images you want to open:

• To open one image, select it and click OK. You can scroll through the images.

• To open multiple images, Shift-click to select contiguous images, or Ctrl-click 
(Windows) or Command-click (Mac OS) to select non-contiguous images.

• To select all images, hold down Ctrl (Windows) or Command+A (Mac OS).

Press Esc to cancel the import operation before all images are imported.

To create a new Photoshop file for each page of a multiple-page PDF file 
(Photoshop):

1 Choose File > Automate > Multi-Page PDF to PSD.

2 Under Source PDF, click the Choose button, and select the file you want to import 
images from.

3 Under Page Range, specify a range of pages to import.

4 Under Output Options, specify a resolution, choose a color mode, and set the Anti-alias 
option for rasterizing each page of the PDF file. (To blend edge pixels during rasterization, 
select the Anti-alias option. To produce a hard-edged transition between edge pixels 
during rasterization, deselect the Anti-alias option.)

5 Under Destination, enter a base name for the generated files. (When Photoshop creates 
the new files, the base name is appended with a number that corresponds to the page 
number of the PDF file.) Then click the Choose button, and select the location where you 
want to save the generated files.
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Opening PostScript artwork
Encapsulated PostScript® (EPS) can represent both vector and bitmap data and is 
supported by virtually all graphic, illustration, and page-layout programs. Adobe applica-
tions that produce PostScript artwork include Adobe Illustrator, Adobe Dimensions™, and 
Adobe Streamline™. When you open an EPS file containing vector art, it is rasterized—the 
mathematically defined lines and curves of the vector artwork are converted into the 
pixels or bits of a bitmap image.

You can also bring PostScript artwork into Photoshop or ImageReady using the Place 
command, the Paste command, and the drag-and-drop feature. (See “Placing files” on 
page 105, “Using drag and drop to copy between applications” on page 245, and “Using 
the Clipboard to copy between applications” on page 245.)

To open an EPS file:

1 Choose File > Open. 

2 Select the file you want to open, and click Open. 

3 Indicate the desired dimensions, resolution, and mode. To maintain the same height-to-
width ratio, select Constrain Proportions.

4 Select Anti-aliased to minimize the jagged appearance of the artwork’s edges as it is 
rasterized. 

Turning off anti-aliasing for PDF and EPS files (ImageReady)
The Anti-alias PostScript option removes jagged edges from a pasted or placed selection 
by making a subtle transition between the edges of the selection and its surrounding 
pixels. Turning off this option produces a hard-edged transition between pixels—and 
therefore the appearance of jagged edges—when vector artwork is rasterized. 

Note: In Photoshop, you can deselect the Anti-alias option when you open or place a PDF 
or EPS file.

To turn off the Anti-alias PostScript option:

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• In Mac OS, choose ImageReady > Preferences > General.

2 Deselect Anti-alias PostScript. Clearing this option can decrease the time it takes to 
import the file.

Opening Photo CD files 
You can open Kodak® Photo CD™ (PCD) files, including high-resolution files from Pro Photo 
CD discs. 

Note: You cannot save files in PCD format from Photoshop or ImageReady.

To open a Photo CD file:

1 Choose File > Open.

2 Select the PCD file you want to open, and click Open. If the file does not appear, select 
the option for showing all files from the Files of Type (Windows) or Show (Mac OS) menu.



Using Help | Contents | Index Back 105  

Adobe Photoshop CS Help Getting Images into Photoshop and ImageReady 

Using Help | Contents | Index Back 105  

3 Select options for the source image:

• Pixel Size to specify the pixel dimensions of the image. Keep in mind that the on-screen 
size of the opened image depends on both the pixel size and resolution you choose. 
(See “Understanding image size and resolution” on page 62.)

• Profile to specify a device profile for color management. (See “Calibrating and creating 
a profile of your monitor” on page 119.)

4 Select options for the destination image:

• Resolution to specify the resolution of the opened image. 

• Color Space to specify a color profile for the opened image.

• Landscape or Portrait to specify the orientation of the opened image.

Importing anti-aliased PICT files (Mac OS)
Choose File > Import > Anti-aliased PICT to import object-oriented PICT files (such as 
those created with MacDraw and Canvas) as smooth-edged, or anti-aliased, images. 
Because the entire PICT file must be held in memory for this module to operate, you may 
not be able to use the module with large PICT files. 

The Anti-aliased PICT dialog box indicates the current file size and dimensions. To change 
the image dimensions, enter new values for Width and Height. The file size is then 
updated. To maintain image proportions, select Constrain Proportions. 

You can choose Grayscale or RGB color mode for an anti-aliased PICT file.

Importing PICT resources (Mac OS)
The PICT Resource module lets you read PICT resources from a file—for example, from 
another application. To open a PICT resource, choose File > Import > PICT Resource.

To preview a resource, click Preview. Click the arrow buttons to step forward and backward 
through the resources. Note that the number displayed for Resource refers to the 
resource’s position in ascending order in the resource fork and not to the resource’s identi-
fication number.

Note: In Photoshop, you can also open a file in the PICT Resource file format by choosing 
File > Open, choosing All Documents from the Show pop-up menu, selecting the file you 
want to open, choosing PICT Resource from the Format pop-up menu, and clicking Open. 
However, the Open command automatically opens the first resource in the file and does 
not display any other PICT resources in the file.

Placing files
You can use the File > Place command to place artwork into a new layer in an image. In 
Photoshop, you can place PDF, Adobe Illustrator, and EPS files; in ImageReady, you can 
place files in any supported format, with the exception of Photoshop (PSD) files containing 
CMYK images.

When you place a PDF, Adobe Illustrator, or EPS file, it is rasterized; you cannot edit text or 
vector data in placed artwork. Keep in mind that artwork is rasterized at the resolution of 
the file into which it is placed. 

To place a PDF, Adobe Illustrator, or EPS file (Photoshop):

1 Open the Photoshop image into which you want to place the artwork.
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2 Choose File > Place, select the file you want to place, and click Place.

3 If you are placing a PDF file that contains multiple pages, select the page you want to 
place in the provided dialog box, and click OK. 

The placed artwork appears inside a bounding box at the center of the Photoshop image. 
The artwork maintains its original aspect ratio; however, if the artwork is larger than the 
Photoshop image, it is resized to fit. 

4 If desired, reposition the placed artwork by doing one or more of the following:

• Position the pointer inside the bounding box of the placed artwork, and drag.

• In the options bar, enter a value for X to specify the distance between the center point 
of the placed artwork and the left edge of the image. Enter a value for Y to specify the 
distance between the center point of the placed artwork and the top edge of the 
image. 

• To adjust the center point of the placed artwork, drag the center point to a new 
location, or click a handle on the center point icon  in the options bar.

5 If desired, scale the placed artwork by doing one or more of the following:

• Drag one of the handles at the corners or sides of the bounding box. Hold down Shift as 
you drag a corner handle to constrain the proportions.

• In the options bar, enter values for W and H to specify the width and height of the 
artwork. By default, these options represent scale as a percentage; however, you can 
enter another unit of measurement. To constrain the proportions of the artwork, click 
the Constrain Proportions icon ; the option is on when the icon has a white 
background.

6 If desired, rotate the placed artwork by doing one or more of the following:

• Position the pointer outside the bounding box of the placed artwork (the pointer turns 
into a curved arrow), and drag. 

• In the options bar, enter a value (in degrees) for the Rotation option . 

The artwork rotates around the center point of the placed artwork. To adjust the center 
point, drag it to a new location, or click a handle on the Center Point icon  in the 
options bar.

7 If desired, skew the placed artwork by holding down Ctrl (Windows) or Command 
(Mac OS), and dragging a side handle of the bounding box.

8 Set the Anti-alias option in the options bar as desired. To blend edge pixels during 
rasterization, select the Anti-alias option. To produce a hard-edged transition between 
edge pixels during rasterization, deselect the Anti-alias option.

9 To commit the placed artwork to a new layer, do one of the following:

• Click the Commit button  in the options bar.

• Press Enter (Windows) or Return (Mac OS).

To cancel the placement, click the Cancel button  in the options bar, or press Esc.

To place a file (ImageReady):

1 Open the ImageReady image into which you want to place the file.

2 Choose File > Place, select the file you want to place, and click Open.
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3 Select offset options:

• From the Horizontal pop-up menu, choose an option for placing the file horizontally 
with respect to the image. In the Pixels text box, enter the number of pixels to offset the 
placed image horizontally.

• From the Vertical pop-up menu, choose an option for placing the file vertically with 
respect to the image. In the Pixels text box, enter the number of pixels to offset the 
placed image vertically.

Note: To enter a negative number (and offset the placed file to the left or below the 
image), type a hyphen (-) before the number.

4 Click OK.

5 If you are placing a PDF file that contains multiple pages, select the page you want to 
place, and click OK. 

6 If you are placing a PDF or EPS file, select Rasterize options, and click OK:

• Enter Width and Height values for Image Size.

• Select Anti-aliased to minimize the jagged appearance of the artwork’s edges as it is 
rasterized.

• Select Constrain Proportions to maintain the same height-to-width ratio.
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Producing Consistent Color 
(Photoshop)

An introduction to color management
Colors in an image will sometime look different when viewed on different monitors. They 
may also look very different when printed on your desktop printer or printed in a publi-
cation. If you need to produce consistent color across different devices, managing color 
should be an essential part of your workflow.

Why colors change
We use color models to describe the colors we see and work with. Each color model, such 
as RGB, CMYK, or Lab, represents a different method for describing and classifying color. 
Color models use numeric values to represent the visible spectrum of color. A color space is 
a variant of a color model and has a specific gamut (range) of colors. For example, within 
the RGB color model are a number of color spaces: Adobe RGB, sRGB, and Apple RGB. 
While each of these color spaces defines color using the same three axes (R, G, and B), their 
gamuts are different.

All devices operate within their own color space, the range of color they’re capable of 
reproducing. No device can reproduce the full range of colors viewable to the human eye, 
and no two devices have the same color space.

When you work with image colors in Adobe Photoshop, you are actually adjusting 
numerical values in the file. It’s easy to think of a number as a color, but these numerical 
values are not absolute colors in themselves—they only have a color meaning within the 
color space of the device that is producing the color.

Because each device has its own color space, it can reproduce colors only in its gamut. 
When an image moves from one device to another, image colors may change because 
each device interprets the RGB or CMYK values according to its own color space.

Every device has a different color space.
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It is impossible for all the colors viewed on a monitor to be identically matched in a print 
from a desktop printer. A printer operates in a CMYK color space, and a monitor operates 
in an RGB color space. Their gamuts are different. Some colors produced by inks cannot be 
displayed on a monitor, and some colors that can be displayed on a monitor cannot be 
reproduced using inks on paper. 

The same RGB values interpreted differently by each device’s color space

Even though it is impossible to perfectly match all colors on different devices, you can use 
color management to ensure that most colors are the same or similar enough so they 
appear consistent.

Solving color inconsistency with color management
Color management lets you produce consistent colors with a system that reconciles 
differences between the color spaces of each device.

For the color management system to successfully convert color values between the 
different color spaces so colors remain the same or very similar, three things must happen: 

• The color management system must know the color space of the image so it can 
decipher the meaning of the color values in the image. When assigning a profile to an 
image, the image will be in the color space described by the particular profile. A 
document’s profile can be assigned by a source device, like a digital camera or a 
scanner, or assigned in Photoshop.

• Then, the color management system uses a color reference to identify the absolute 
colors represented by the color values in the image. Currently, color management 
systems use either CIE L*a*b* (Lab) or CIE XYZ for color reference. Both color spaces 
describe all the colors that a person can see; the color values referred to in this space 
are not limited to or tied to the colors produced by any device.

• And finally, the color management system must know the color space of the desti-
nation device so it can send properly translated RGB or CMYK color values to the device. 
The color management system uses profiles to understand what RGB and CMYK values 
mean to each device. Device profiles can be supplied by the manufacturer or created 
using third-party software and hardware.
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Color management 
A. Source devices create documents containing raw color values. B. Source profiles describe 
the devices’ color spaces and document profiles describe the documents’ color spaces.
C. Taking the raw color values with the profile data, the color management system identifies the 
actual colors in the document using a color reference (Lab). D. Device profiles describe the color 
spaces of each device. E. The color management system converts the raw color values to the color 
space of each device.

Basic steps for producing consistent color
A color management system is built into Photoshop. To use Photoshop’s color 
management system successfully, you will need to follow some basic steps. 

To start managing the color in your workflow:

1 Calibrate your monitor. Use a visual calibration method, like Adobe Gamma (Windows) 
or Monitor Calibrator (Mac OS), or use third-party software and hardware for more 
accurate calibration.

2 Specify the color settings when you first launch Photoshop. The color settings in the 
Photoshop Color Settings dialog box control how the color management system works 
with RGB, CMYK, and grayscale images. 

When first launching Photoshop, an alert will tell you that the color settings will be 
configured using default settings (Web Graphics Defaults) and ask if you wish to 
customize the color settings. Do one of the following:

• Click No to accept the default settings. Keep in mind that the default settings might be 
appropriate for keeping colors consistent when images are viewed on a computer 
monitor, but may not be optimum for printing images. 

Note: Although you don’t have to customize the color settings when first launching 
Photoshop, it’s recommended that you do. The choices you make in the Color Settings 
dialog box influence how the colors in images are displayed.

• For better control of the Photoshop color management system, click Yes to customize 
the color settings in Photoshop when first launching the program. This opens the Color 
Settings dialog box. In the Color Settings dialog box, choose a preset option from the 
Settings menu. If your image is to be printed on a desktop printer or a printing press, 
choose one of the prepress defaults that’s relevant to your geographic location. For 
example, if you’re in the United States, you would choose U.S. Prepress Defaults. 

A B C D E
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• For the maximum control of the Photoshop color management system, click Yes to 
customize the color settings in Photoshop when first launching the program. This 
opens the Color Settings dialog box. In the Color Settings dialog box, select the 
Advanced Mode option and specify the individual settings.

Note: The Color Settings dialog box is not just accessible the first time you launch 
Photoshop. You can access the Color Settings dialog box at any time by choosing 
(Windows) Edit > Color Settings or (Mac OS) Photoshop > Color Settings.

It is important to use the same color settings in other color-managed applications such as 
Adobe Illustrator, Adobe InDesign, and Adobe Acrobat® in order to make your color 
consistent between the applications. Keep in mind that colors will probably not match 
between color-managed applications and non-color-managed applications. For more 
information about synchronizing color settings between color-managed Adobe applica-
tions, see “Keeping color consistent between Photoshop and other Adobe applications” 
on page 144.

3 Create or acquire profiles of devices in your workflow, such as your desktop printer. The 
Photoshop color management system needs to know the behavior of the devices in your 
workflow in order to properly convert the color values in a document so the devices 
produce consistent color. Common ways to obtain a profile include:

• Installing the driver for your desktop printer. When you install the printer driver, a profile 
is usually installed in your computer system. The color management system can access 
this profile so it will appear as a color management option when you print from 
Photoshop. 

• Creating a profile using a third-party measuring instrument and software. This method 
can create a more accurate descriptions of the behavior of specific devices. 

Note: You should also make separate profiles for every type of paper used with your 
desktop printer. A glossy paper is capable of displaying a different range of colors than a 
matte paper. Use a third-party measuring instrument and software to generate custom 
paper profiles.

4 Incorporate color management into your various workflows. Having a calibrated 
monitor and profiles is useless unless you know how to utilize them:

• For keeping colors consistent when printing to an inkjet printer, dye sublimation 
printer, laser printer or any desktop printer, see “Producing consistent color with a 
desktop printer” on page 146.

• For keeping colors consistent when placed in a layout application like InDesign and 
sent out to be printed on a printing press, see “Producing consistent color when 
sending images to press” on page 147.

• For keeping colors consistent when creating images for viewing on the Web or multi-
media presentations, see “Producing consistent color when creating images for the 
Web” on page 149.
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Understanding color
Color is how you perceive light. The light may be reflected, transmitted, diffracted, or 
emitted.

Using color models to describe color
We see only a small part of the electromagnetic spectrum. This small part is often called 
the visible spectrum. We see all light because light is defined as being that part of the 
electromagnetic spectrum that we can see. Color models attempt to describe the colors we 
see and work with. Each color model represents a different method for describing and 
classifying color. All color models use numeric values to represent the visible spectrum of 
color. 

People see only a small part of the energy spectrum.

The range of colors that can be produced using a particular color model, such as RGB or 
CMYK, is a color space. Other color models are HSL, HSB, Lab, and XYZ. 

A color model determines the relationship between values, and the color space defines 
the absolute meaning of those values as colors. Some color models have a fixed color 
space (such as Lab and XYZ) because they relate directly to the way humans perceive 
color. These models are described as being device independent. Other color models (RGB, 
HSL, HSB, CMYK, and so forth) can have many different color spaces. Because these models 
vary with each associated color space or device, they are described as being device 
dependent.

For example, the RGB color model has many RGB color spaces, such as ColorMatch, Adobe 
RGB, sRGB, and ProPhoto RGB. You can take the same RGB values (R=220, B=230, and G=5) 
and assign profiles that describe different RGB color spaces. The color will look different in 
each color space, but the numeric values and model will still be the same.

Photoshop uses color modes (similar to a color model) that let you work with an image in a 
specific color space. Photoshop keeps track of an image’s color space and will indicate in 
the title bar if the working space and the document’s color space don’t match.

Photoshop accommodates the color models that are most suitable for photographic 
images or graphics. Color models used in Photoshop are CMYK, HSB, RGB, and Lab. 

HSB model
HSB is a color model that is somewhat analogous to Munsell’s system of hue, value, and 
chroma in that it uses three similar axes to define a color. HSB is derived from RGB color 
spaces and is a device dependent color space. In HSB, the three fundamental character-
istics of color are:

• Hue is the color reflected from or transmitted through an object. It is measured as a 
location on the standard color wheel, expressed as a degree between 0° and 360°. 
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In common use, hue is identified by the name of the color such as red, orange, or green. 
To view the color wheel, see “Using the color wheel” on page 172.

• Saturation, sometimes called chroma, is the strength or purity of the color. Saturation 
represents the amount of gray in proportion to the hue, measured as a percentage 
from 0% (gray) to 100% (fully saturated). On the standard color wheel, saturation 
increases from the center to the edge.

• Brightness is the relative lightness or darkness of the color, usually measured as a 
percentage from 0% (black) to 100% (white).

You can use the HSB model in Photoshop to define a color in the Color palette or Color 
Picker dialog box, but there is no HSB mode available for creating and editing images.

HSB model 
H. Hue S. Saturation B. Brightness

RGB model
A large percentage of the visible spectrum can be represented by mixing red, green, and 
blue colored light in various proportions and intensities. Where the colors overlap, they 
create secondary colors—cyan, magenta, yellow—and white.

RGB colors are also called additive colors. Additive colors are created by mixing spectral 
light in varying combinations. Adding all colors together creates white—that is, all visible 
wavelengths are transmitted back to the eye. Additive colors are used for lighting, video, 
and monitors. Your monitor, for example, creates color by emitting light through red, 
green, and blue phosphors.

 
Additive colors (the RGB model)
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CMYK model
The CMYK model is based on the light-absorbing quality of ink printed on paper. As white 
light strikes translucent inks, certain visible wavelengths are absorbed (subtracted), while 
others are reflected back to your eyes. For this reason, these colors are called subtractive 
colors.

In theory, pure cyan (C), magenta (M), and yellow (Y) pigments should combine to absorb 
all light and produce black. Because all printing inks contain some impurities, however, 
these three inks actually produce a muddy brown. For this reason, black ink (K) is used in 
addition to the cyan, magenta, and yellow inks in four-color printing. (K is used for black 
instead of B to avoid confusion with blue.)

 
Subtractive colors (the CMYK model)

Lab model
The CIE L*a*b* color model (Lab) is based on the human perception of color. It is one of 
several color models produced by the Commission Internationale d’Eclairage (CIE), an 
organization dedicated to creating standards for all aspects of light. 

The numeric values in Lab describe all the colors that a person with normal vision sees. 
Because Lab describes how a color looks rather than how much of a particular colorant is 
needed for a device (such as a monitor, desktop printer, or digital camera) to produce 
colors, Lab is considered to be a device-independent color model. Color management 
systems use Lab as a color reference to predictably transform a color from one color space 
to another color space. 

Lab describes color in terms of luminance or its lightness component (L) and two 
chromatic components: the a component (green and red) and the b component (blue 
and yellow). 

C M Y K
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L*a*b* (Lab) model 
A. Luminance=100 (white) B. Green to red component C. Blue to yellow component
D. Luminance=0 (black) 

Photoshop uses Lab as a color reference in color management and lets you work in Lab 
Color mode.

In the Adobe Color Picker, select a color in RGB, HSB, or CMYK mode to see the related 
numeric values in Lab. (See “Using the Adobe Color Picker” on page 164.)

Why colors sometimes don’t match
The colors in an image change as you bring the image in from a scanner or digital camera 
and view it on your computer monitor. The colors change again when you send the image 
out to be printed on your desktop printer or printing press. This is because every device—
a digital camera, scanner, computer monitor, desktop printer, printing press—operates 
within a different color space. Incorrect color transformation or lack of color transfor-
mation from one color space to another causes color inconsistency. Correctly trans-
forming the color values creates color consistency. For more information on correctly 
transforming the color values, see “Using color management to produce consistent color” 
on page 117.

Understanding color space and gamut
A color space is a range of colors in the visible spectrum. A color space can also be a 
variant of a color model. Adobe RGB, Apple RGB, and sRGB are examples of different color 
spaces based on the same color model. 

The gamuts of different color spaces 
A. Lab color space encompasses all visible colors B. RGB color space C. CMYK color space

B

C

A

D
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B
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The range of color encompassed by a color space is called a gamut. The different devices 
(computer monitor, scanner, desktop printer, printing press, digital camera) throughout 
your workflow operate within different color spaces and each with different gamuts. Some 
colors within the gamut of your computer monitor are not within the gamut of your inkjet 
printer, and vice versa. When a color cannot be produced on a device, it’s considered to be 
outside the color space of that particular device. In other words, the color is out of gamut. 
When you edit an image in a specific workspace, Photoshop alerts you when it encounters 
out of gamut colors. (See “Identifying out-of-gamut colors (Photoshop)” on page 184.)

The color gamuts of various devices and documents 
A. Lab color space (entire visible spectrum) B. Documents (working space) C. Devices

Why each device has a different color space
The devices throughout your workflow use different methods to produce color. These 
methods are often based on different color models and as a result, the devices operate in 
different color spaces. Your computer monitor produces color with light and operates in 
an RGB color space. Your desktop printer produces colors with inks or dyes that work in a 
CMYK color space. Some colors can be viewed on a computer monitor that cannot be 
printed on desktop printer or printing press. Likewise, some colors can be produced with 
inks that cannot be displayed on a monitor.

Even when two devices use the same color model to produce color, they will have 
different color spaces. For example, a CRT monitor and an LCD monitor both use RGB to 
produce colors. However, because both use different means to display color, the range of 
color (color space) of both monitors would be different. The CRT monitor would display a 
specific red value differently than the LCD monitor.

Even two monitors of the same brand and model frequently display the same color differ-
ently. It’s nearly impossible for two devices to be completely identical, given the limita-
tions of manufacturing and materials. Go to an electronics store and look at a wall of 
television monitors. Each monitor displays colors differently. 

Device-dependent color models
RGB and CMYK are device-dependent color models. This is because the colors produced 
using these models depend on the device that is producing the color. For example, the 
RGB value of 255,0,0 is a formula for red. However, the red displayed using this formula on 
one computer monitor will be different than the red displayed on another monitor. Each 
monitor interprets the formula for red according to its own color space.

CMYK
RGB 

A B
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Device-independent color models
Device-independent color models describe absolute colors instead of formulas whose 
resulting colors depend on a device’s interpretation of its numeric values. Lab is a device-
independent color model and is used by many color management systems as a color 
reference. It enables the color management system to translate colors from the color 
space of one device to another with the best possible accuracy.

Using color management to produce consistent color
Photoshop’s color management system helps you maintain the appearance of colors as 
you bring an image in from a source device, edit the image on your computer, and then 
output your image. Photoshop follows a color management workflow based on conven-
tions developed by the International Color Consortium (ICC), a group responsible for 
standardized profile formats and procedures so consistent color can result from software 
and devices working together.

How color management works
A color management system reconciles the differences between the color spaces of 
different devices. It translates the RGB or CMYK values in a document so that the colors will 
be represented as consistently as possible on different devices.

Managing color with profiles 
A. Profiles describe the color spaces of the input device and the document. B. Using the 
profiles’ descriptions, the color management system identifies the document’s actual colors.
C. The monitor’s profile tells the color management system how to translate the numeric 
values to the monitor’s color space. D. Using the output device’s profile, the color management 
system translates the document’s numeric values to the color space of the output device so the 
actual colors are printed.

A

B

C

D
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For a color management system to perform this translation process, it needs three 
elements: 

Profiles Describe the color spaces of the different devices and also the color space of a 
document. A color management system needs separate profiles for each device and a 
profile embedded in a document. A device profile does not change the color values in a 
document, it tells the color management system how a device interprets the color values 
in a document. A document’s embedded profile defines the documents’ working space if 
you preserve the profile when opening it in Photoshop. Photoshop also lets you convert or 
discard the embedded profile, which uses the working space specified in the color 
settings. The working space tells the color management system what the RGB or CMYK 
values mean as you work on the document in Photoshop. For more information on 
working spaces, see “About working spaces” on page 125 and for more information on 
using profiles, see “Calibrating and creating profiles” on page 119.

Color reference Enables the color management system to identify the colors in one color 
space. These absolute colors can then be mapped to the same or closest matching colors 
in another color space. Photoshop’s color management system uses Lab for its color 
reference. 

Color Management Module (CMM) Does the actual conversion of color values in one 
color space to the same or similar color values in another color space. There are many 
different CMMs. The default CMM for Photoshop is Adobe (ACE), which is also used by 
Adobe Illustrator, Adobe InDesign, and Adobe Acrobat. 

When Photoshop opens an image, the Photoshop color management system reads the 
profile if one is embedded in the image. The profile describes the color space of the 
document so the color management system can interpret the color values in the 
document. If the image came from a camera or scanner, the device may embed the profile 
in the image, which explains to the color management system how that device created 
the image's colors. Images from other sources might have profiles embedded in them that 
describe their colors according to a previous version of Photoshop or another person’s 
working space. If no profile is embedded, you have the opportunity to assign a profile to 
that image. Most likely you'll want to assign your current working profile. 

After reading the profile, the color management system then identifies all the colors in the 
document using a color reference. Using the monitor’s profile, the color management 
system translates the document’s actual colors into the color space of the monitor so the 
colors are properly displayed. 

When it comes time to print the document, the color management system references the 
output device’s profile so the color values in the document are successfully converted to 
the output device’s color space. Inevitably, there will be colors that are not within the 
gamut of the output device. In Photoshop, you can determine how the color management 
system handles the color conversion and out-of-gamut colors by specifying a rendering 
intent. For more information on rendering intents, see “Handling colors with a rendering 
intent” on page 135.
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Calibrating and creating profiles
The color management system uses profiles to know how a device produces color and 
what the actual colors in a document are. Device profiles are often installed when a device 
is added to your system. The accuracy of these profiles (often called generic profiles or 
canned profiles) varies from manufacturer to manufacturer. Third-party software and 
hardware can also create device profiles (often called custom profiles). 

Color management system using profiles to correctly transform color from one color 
space to another 
A. Profile describing the meaning of the RGB values in the document B. Color management system 
using a color reference (Lab) to identify the actual colors C. Output profile (destination profile) 
describing the device’s color space so the RGB values are translated to maintain consistent colors 
when printed in CMYK

Calibrating and creating a profile of your monitor
A monitor profile is the first profile you should create. It is absolutely essential for 
managing color. If what you see on your monitor is not representative of the actual colors 
in your document, you will not be able to maintain color consistency.

When you calibrate your monitor, you are adjusting it so it conforms to a known specifi-
cation. Once your monitor is calibrated, a profile is created. The profile describes the color 
behavior of the monitor—what colors can or cannot be displayed on the monitor and how 
the numeric color values in an image must be converted so that colors are displayed 
accurately. 

Most profiles only describe the behavior of a device. In addition to describing the monitor’s 
behavior, a monitor profile also contains calibration information, which changes the 
behavior of the monitor. 

To calibrate and profile your monitor, you can use visual calibrators like Adobe Gamma 
(Windows), Monitor Calibrator (Mac OS), or use third-party software and measuring 
devices. In general, using a measuring device such as a spectrophotometer along with 
software can create more accurate profiles. An instrument can measure the colors 
displayed on a monitor far more accurately than the human eye.

Creating profiles of your input devices
A profile of an input device (sometimes called a source profile) describes what colors a 
device is capable of capturing or scanning. For example, the profile might tell the color 
management system that a specific camera tends to render the colors in a particular scene 
with a slightly warm cast. This information is not so the color management system will 
correct the warm cast, but so the color management system will faithfully represent the 
warm cast when sending color values to the computer monitor. 

A B C
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Digital camera profiles Generally describe the camera’s behavior when used with a 
specific lighting source in a specific environment. For example, different profiles are 
needed for the different light sources you use. Different profiles are also needed for the 
different qualities of daylight, such as sunny, overcast, shade, early morning, and sunset.

Scanner profiles Describe how a scanner captures the colors in a print or transparency. 
For critical color work, some photographers create separate profiles for each type or brand 
of film scanned on a scanner.

Creating an input profile involves photographing or scanning a color target. For the 
camera profile, the target must be photographed under the lighting conditions that the 
profile needs to describe. Third-party software and hardware read the RGB colors in the 
captured or scanned image. These values are compared with the actual color values that 
should be in the targets (referencing a device-independent color space like Lab), and the 
input profile is created.

There are different opinions on whether an input device profile is absolutely essential for 
producing consistent color. Some users feel that consistent color is difficult to achieve 
without a source profile. Others feel that regardless of an input device’s behavior, a well-
calibrated and profiled monitor will accurately display an image’s colors for successful 
color correction.

Creating profiles of your output devices
Profiles of your output devices (sometimes called destination profiles or output profiles) 
describe the color space of devices like desktop printers and a printing press. The 
Photoshop color management system uses these profiles in two ways:

• To properly map the colors in an image to the colors within the gamut of an output 
device’s color space so the resulting colors are the same or similar enough to retain the 
overall appearance of the original image.

• To generate a preview of how the colors in an image will probably look when produced 
by the output device. For more information about using profiles for previewing 
(proofing) the colors in an image, see “Soft-proofing colors” on page 140.

As with any profile, the more accurately a destination profile describes the behavior of an 
output device, the more accurately the Photoshop color management system can 
translate the numeric values of the actual colors in a document or generate a preview of 
how an image will look in the color space of the output device.

Embedding a profile in a document
Documents can be tagged with profiles that describe specific RGB or CMYK color spaces. 
By associating, or tagging, a document with a color profile, you provide a definition of 
actual color appearances in the document. Changing the associated profile changes the 
color appearances. (For information on displaying the current profile name in the status 
bar, see “Displaying status information (Photoshop)” on page 45.) Documents without 
associated profiles are known as untagged and contain only raw color numbers. When 
working with untagged documents, Photoshop uses the current working space profile 
that is specified in the color settings to display and edit colors. For more information on 
working spaces and profiles, see “About working spaces” on page 125.

By default, a tagged document will have its profile information embedded upon saving in 
a file format that supports embedded ICC profiles. Untagged documents are saved by 
default without embedded profiles. 
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You can specify whether or not to embed a profile as you save a document; you can also 
specify to convert colors to the proof profile space and embed the proof profile instead. 
However, changing the profile-embedding behavior is recommended only for advanced 
users who are familiar with color management.

To change the embedding behavior of a profile in a document:

1 Choose File > Save As. 

2 Do one of the following:

• To toggle the embedding of the document’s current color profile, select or deselect ICC 
Profile (Windows) or Embed Color Profile (Mac OS). This option is available only for the 
native Photoshop format (.psd) and PDF, JPEG, TIFF, EPS, DCS, and PICT formats. 

• To toggle the embedding of the document’s current proof profile, select or deselect Use 
Proof Setup (available for PDF, EPS, DCS 1.0, and DCS 2.0 formats only). Selecting this 
option converts the document’s colors to the proof profile space and is useful for 
creating an output file for print. For information on setting up a proof profile, see “Soft-
proofing colors” on page 140.

3 Name the document, choose other save options, and click Save.

Changing the color profile of a document
In some cases you may want to convert a document’s colors to a different color profile, tag 
a document with a different color profile without making color conversions, or remove the 
profile from a document altogether. For example, you may want to prepare the document 
for a different output destination, or you may want to correct a policy behavior that you 
no longer want implemented on the document. Photoshop has the Assign Profile and the 
Convert to Profile commands, which let you remove, reassign, or change profiles in a 
document. The Assign Profile and Convert to Profile commands are recommended for 
advanced users only.

When using the Assign Profile command, you may see a shift in color appearance as color 
numbers are mapped directly to the new profile space. Convert to Profile, however, shifts 
color numbers before mapping them to the new profile space, in an effort to preserve the 
original color appearances.

To reassign or discard the profile of a document:

1 Choose Image > Mode > Assign Profile.

2 Select one of the following:

• Don’t Color Manage This Document to remove the profile from a tagged document. 
Select this option only if you are sure that you want the document to become 
untagged.

• Working color mode: working space to tag the document with the current working space 
profile. For more information about working spaces, see “About working spaces” on 
page 125.

• Profile to reassign a different profile to a tagged document. Choose the desired profile 
from the menu. Photoshop tags the document with the new profile without converting 
colors to the profile space. This may dramatically change the appearance of the colors 
as displayed on your monitor.

3 To preview the effects of the new profile assignment in the document, select Preview.
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To convert colors in a document to another profile:

1 Choose Image > Mode > Convert to Profile.

2 Under Destination Space, choose the color profile to which you want to convert the 
document’s colors. The document will be converted to and tagged with this new profile.

3 Under Conversion Options, specify a color management engine, a rendering intent, and 
black point and dither options. For more information on conversion options, see “Custom-
izing advanced color management settings” on page 134.

4 To flatten all layers of the document onto a single layer upon conversion, select Flatten 
Image. 

5 To preview the effects of the conversion in the document, select Preview. This preview 
becomes more accurate if you select Flatten Image.

Using the Photoshop Color Settings
A color management system does not guarantee predictable color unless it’s properly set 
up. Your monitor can be calibrated, you can have profiles for all your devices, and still end 
up with colors that shift unpredictably. Photoshop simplifies the task of setting up a 
color-managed workflow by gathering most color management controls in one conve-
nient location, the Color Settings dialog box. 

Specifying color management settings
In the Color Settings dialog box, you can choose from a list of predefined color 
management settings or adjust the controls manually to create your own custom settings. 
You can even save customized settings to share them with other users and other Adobe 
applications that support color management.

To specify color management settings:

1 Do one of the following:

• In Windows, choose Edit > Color Settings.

• In Mac OS, choose Photoshop > Color Settings.

To display helpful descriptions of the options that appear in the dialog box, position 
the pointer over a section heading or menu item. These descriptions appear in the 

lower area of the dialog box. 

2 Do one of the following:

• To set up a predefined color management workflow, see “Using predefined color 
management settings” on page 122.

• To customize your own color management settings, see “Customizing color 
management settings” on page 124.

Using predefined color management settings
Photoshop offers a collection of predefined color management settings designed to 
produce consistent color for a common publishing workflow, such as preparation for 
offset or Web press output. In most cases, the predefined settings will provide sufficient 
color management for your needs. These settings can also serve as starting points for 
customizing your own workflow-specific settings.
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To choose a predefined color management setting:

Choose one of the following options from the Settings menu in the Color Settings 
dialog box.

Color Management Off Does not turn the Photoshop color management system off (the 
color management system cannot be turned off entirely). Instead, this option tells the 
color management system to use passive color management techniques to emulate the 
behavior of applications that do not support color management. Although working space 
profiles are considered when converting colors between color spaces, Color Management 
Off does not tag documents with profiles. You can use this option for content that will be 
output on video or as on-screen presentations. Do not use this option if you work mostly 
with documents that are tagged with color profiles.

ColorSync Workflow (Mac OS only) Manages color using the ColorSync color 
management system with the profiles chosen in the ColorSync control panel. Use this 
option if you want to use color management with a mix of Adobe and non-Adobe applica-
tions. This color management configuration is not recognized by Windows systems or by 
versions of ColorSync earlier than 3.0.

Emulate Acrobat 4 Uses a configuration that emulates Adobe Acrobat 4.0 color handling 
behavior. This option is available only if Acrobat is installed on your computer.

Emulate Photoshop 4 Emulates the color workflow used by Adobe Photoshop 4.0 and 
earlier.

Europe General Purpose Defaults Uses general purpose color settings for consistent 
color handling across Adobe software products in Europe.

Europe Prepress Defaults Manages color for content that will be output under common 
press conditions in Europe.

Japan Color Prepress Uses settings that support the preparation of content for common 
press conditions in Japan.

Japan General Purpose Defaults Uses general purpose color settings for consistent 
color handling across Adobe software products in Japan.

Japan Prepress Defaults Manages color for content that will be output under common 
press conditions in Japan.

North American General Purpose Defaults Uses general purpose color settings for 
consistent color handling across Adobe software products in North America.

Photoshop 5 Default Spaces Prepares content using the default working spaces from 
Photoshop 5.

U.S. Prepress Defaults Manages color for content that will be output under common 
press conditions in the U.S.

Web Graphics Defaults Manages color for content that will be published on the World 
Wide Web.

When you choose a predefined configuration, settings are chosen for the working spaces 
and the color management policies. The Color Settings dialog box updates to display the 
specific color management settings associated with the configuration. For more infor-
mation about work spaces and color management policies, see “About working spaces” 
on page 125 and “About color management policies” on page 132.
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Customizing color management settings
Although the predefined settings should provide sufficient color management for many 
workflows, you may want to customize individual options in a configuration. For example, 
you might want to change the CMYK working space to a profile that matches the proofing 
system used by your desktop printer or your prepress service.

It’s important to save your custom configurations so that you can reuse and share them 
with other users and Adobe applications that use the same color management workflows. 
The color management settings that you customize in the Color Settings dialog box are 
contained in an associated preferences file called Color Settings. 

Note: The default location of the Color Settings file varies by operating system. In 
Windows XP, it is Documents and Settings/username/Application Data/Adobe/
Photoshop/8.0/Adobe Photoshop CS Settings/Color Settings.csf. In Mac OS, it is Users/user 
profile/Library/Preferences/Adobe Photoshop CS Settings/Color Settings.csf.

To customize color management settings:

1 Do one of the following:

• In Windows, choose Edit > Color Settings.

• In Mac OS, choose Photoshop > Color Settings.

2 To use a preset color management configuration as the starting point for your customi-
zation, choose that configuration from the Settings menu.

3 Specify the desired color settings (working spaces and policies). As you make adjust-
ments, the Settings menu option changes to Custom by default. 

For detailed customization instructions, see “About working spaces” on page 125 and 
“Specifying color management policies” on page 133.

4 (Optional) Select Advanced Mode for more options in the Color Settings dialog box.

5 If necessary, under Conversion Options, choose a CMM, a rendering intent, and whether 
color management converts the color values in an image using black point compensation 
and dither. For more information on these options, see “About the Color Management 
Module (CMM)” on page 135, “Handling colors with a rendering intent” on page 135, 
“Using black point compensation” on page 136, and “Using dither” on page 136.

6 If necessary, under Advanced Controls, specify how much to desaturate the colors on a 
monitor and what gamma to use for the RGB blend. For more information on these 
options, see “Desaturating monitor colors” on page 136 and “Blending RGB colors” on 
page 136.

7 Save your custom configuration so that it can be reused. (See “Saving and loading color 
management settings” on page 125.)

Note: Saving your custom configuration is important to synchronize the color 
management settings in Photoshop with Adobe Illustrator, Adobe InDesign, and Adobe 
Acrobat. (See “Keeping color consistent between Photoshop and other Adobe applica-
tions” on page 144.)
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Saving and loading color management settings
When you create a custom color management configuration, you should name and save 
the configuration to ensure that it can be shared with other users and applications that 
support color management, such as Adobe Illustrator, Adobe InDesign, and Adobe 
Acrobat. You can also load previously saved color management configurations into the 
Color Settings dialog box.

To save a custom color management configuration:

1 In the Color Settings dialog box, click Save.

2 Name your color settings file, and click Save. 

To ensure that the saved configuration appears in the Settings menu of the Color Settings 
dialog box, save the file in one of the following recommended locations:

• (Windows) Program Files/Common Files/Adobe/Color/Settings.

• (Mac OS) Users/user profile/Library/Application Support/Adobe/Color/Settings. 
To ensure that all color-managed Adobe applications can take advantage of saved 
color setting files, you may want to save them to the system application support folder. 
Library/Application Support/Adobe/Color/Settings.

3 Enter any comments that you want to associate with the configuration, and click OK.

The comments that you enter will appear in the Description area of the Color Settings 
dialog box when the pointer is positioned over the configuration in the Settings menu.

To load a color management configuration:

1 In the Color Settings dialog box, click Load.

2 Locate and select the desired color settings file, and click Load.

When you load a custom color settings file, it appears as the active choice in the Settings 
menu of the Color Settings dialog box. If you load a settings file that has been saved 
outside the recommended location, it temporarily replaces the Other option in the 
Settings menu until another settings file is loaded.

About working spaces
A working space is the default profile for an image while you’re editing it in Photoshop. 
It defines the color space in which you are editing an image. 

Lab Cannot be selected as a working space in the Color Settings dialog box. If you choose 
to edit a document in Lab mode, the document is converted to your monitor’s color space 
prior to viewing and you will have limited editing capabilities. Because Lab encompasses 
the complete range of visible colors, for practical reasons it is better to work in color 
spaces (such as RGB and CMYK) that are smaller and more in line with the color spaces of 
devices that capture, display, or output images.

RGB working spaces Are based on the RGB color model. Some RGB working space 
options are device-dependent (such as a monitor-profile-based working space) and some 
are device-independent (such as Adobe RGB, Apple RGB, and sRGB). It’s probably best to 
use a device-independent working space for most image editing.
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CMYK working spaces Are device-dependent. While an RGB working space can be 
device-independent, CMYK working spaces are based on actual combinations of ink and 
paper. It’s often best to use an RGB working space for editing your image in Photoshop 
and then use the appropriate CMYK profile to convert your RGB image to CMYK in prepa-
ration for printing. The data in the CMYK working space is the data that will be used to 
convert the image to CMYK. For more information on RGB and CMYK working spaces, see 
“Choosing an RGB working space” on page 126 and “Choosing a CMYK working space” on 
page 127. 

Photoshop gives you the option of embedding the profile of your working space when 
you save an image. Embedding a profile is recommended because it tells Photoshop and 
other color-management-savvy applications the color meaning of the numeric values in 
the document.

Adobe RGB and sRGB are smaller color spaces than Lab and provide a practical working 
space to edit and output images. 
A. Adobe RGB (1998) B. sRGB

Choosing an RGB working space
Choosing an RGB working space is a balancing act. On one hand, you want a working 
space whose gamut is large enough to encompass the color spaces of all the devices in 
your workflow. But, on the other hand, it’s possible to choose a working space that’s too 
large. When you work in RGB, you have 255 levels of intensity for each color. The larger 
the RGB working space, the father apart each color value would be from its nearest 
neighbor. As a result, the jump from one level of color intensity to the next could be 
visually significant.

To choose an RGB working space:

1 Do one of the following:

• In Windows, choose Edit > Color Settings.

• In Mac OS, choose Photoshop > Color Settings.

2 Under Working Spaces, choose an option from the RGB menu:

Adobe RGB (1998) Is the largest recommended RGB working space and suited for print 
production with a broad range of colors.

Apple RGB Reflects the characteristics of the older 13-inch Mac OS monitor. This space is 
suitable for working with older desktop publishing files or for emulating Photoshop 4.0 
and earlier.

A

B
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ColorMatch RGB Matches the native color space of the old Radius Pressview monitors. 
This space is a smaller gamut alternative to Adobe RGB (1998) for print production work.

sRGB Is designed to reflect the characteristics of the average PC monitor. sRGB is suitable 
for RGB images destined for the Web, but not recommended for print production work.

Monitor RGB Sets the RGB working space to your current monitor color space. This 
setting is suitable when you’re trying to match the RGB color in non-color-managed 
applications like Adobe GoLive.

ColorSync RGB (Mac OS) Matches the RGB color space specified in the Apple ColorSync 
control panel.

Note: When the Advanced Mode option is selected in the Color Settings dialog box, every 
RGB profile on your computer is displayed in the RGB working space menu. You can even 
choose Custom RGB to define your own RGB working space. This is recommended only for 
users who have a good understanding of color.

Choosing a CMYK working space
CMYK working spaces are generally based on actual ink and paper combinations. When 
the Advanced Mode option is not selected in the Color Settings dialog box, you can 
choose from seven ICC press profiles and Custom CMYK. Mac OS users can also choose the 
ColorSync profile that is specified in the Color Sync preferences. This setting matches the 
CMYK space specified in the Apple ColorSync control panel.

Specifying a CMYK working space
Choosing Custom CMYK lets you specify the ink colors, dot gain, separation type, and 
black generation of your output device. If you have saved Printing Inks and Separation 
Setup files from Photoshop 4.x or earlier, you can load them for use as a working space 
profile in the Color Settings dialog box. (See “Saving and loading custom working space 
profiles” on page 136.)

Custom CMYK working space profiles are mainly useful for providing color management 
compatibility with documents created in versions of Photoshop prior to 6.0. In general, the 
CMYK working space profiles included with the current version of Photoshop produce 
more accurate results.

To choose a CMYK working space:

1 Do one of the following:

• In Windows, choose Edit > Color Settings.

• In Mac OS, choose Photoshop > Color Settings.

2 Under Working Spaces, choose an option from the CMYK menu.

To create a custom CMYK profile:

1 Do one of the following:

• In Windows, choose Edit > Color Settings.

• In Mac OS, choose Photoshop > Color Settings.

2 Under Working Spaces, choose Custom CMYK from the CMYK menu.
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3 For Name, enter a new name for the custom profile if desired. However, because the 
default name automatically reflects changes that you make to the Custom CMYK settings, 
it is recommended that you accept the default name.

4 For Ink Colors, choose an ink type. (See “Specifying ink colors” on page 128.)

5 For Dot Gain, specify a value. (See “Specifying dot gain” on page 129.)

6 Specify separation options. (See “Adjusting the separation type and black generation” 
on page 130.)

7 Click OK.

8 Save the custom profile. (See “Saving and loading custom working space profiles” on 
page 136.)

Specifying ink colors
The Ink Colors menu lets you choose from the following options:

• The preset ink options are designed to produce quality separations using standard 
inks and printing specifications. These ink standards differ slightly from one another. 
Similarly, the color and ink absorption qualities of the paper stock affect the final 
printed result. You can think of this information as telling Photoshop what printed cyan, 
magenta, yellow, and black look like given a certain set of inks and paper stock under 
your lighting conditions.

• The Custom option lets you customize the on-screen display of ink colors to match 
printed output by entering values obtained from a color proof. (See “Printing a hard 
proof” on page 143.) For example, you may want to use the Custom option to specify 
an ink set not listed as a preset option. When you change these settings, you change 
the profile that Photoshop uses to display the ink colors on-screen. See the following 
procedure for instructions on entering custom ink values.

• If you have loaded a CMYK profile or color settings file that has been saved outside the 
recommended location, the ink setting for that profile or settings file temporarily 
replaces the Other option in the Ink Colors menu.

Note: In most cases, printing ink characteristics do not vary greatly from printer to printer 
within the same printer type. For example, one Tektronix Phaser II printer prints ink hues 
very similar to another one. But the amount of dot gain can vary significantly. Thus, for a 
different printer of the same type, you may have to change the dot gain setting in the 
CMYK Setup dialog box but not the printing ink colors.

To enter custom ink color values:

1 In the Custom CMYK dialog box, for Ink Colors, choose Custom.

By default, the Ink Colors dialog box defines colors using the CIE coordinates of Y 
(lightness), x, and y values. The default ink sets are calibrated for viewing conditions of 
5000 K (when viewed under D50 lighting), 2° field of view. CIE coordinates are an interna-
tional color definition standard supported by PostScript Level 2 and higher.

Note: Colors appear slightly different based on how much of the eye’s field of view they 
cover. The CIE has defined two standard ways of measuring color coordinates, one based 
on colors filling 10° of the eye’s field of view, and one based on colors filling 2° of the field of 
view. Photoshop uses the 2° field of view standard.
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2 If desired, select L*a*b Coordinates to enter the color box coordinates as Lab values 
rather than Yxy values. Use this option if your spectrophotometer has only Lab readouts.

3 Using your printed CMYK proof, take a reading of the color values using a spectropho-
tometer, and then enter those values in the appropriate text boxes. 

Alternately, you can click the color box of the ink color you want to adjust and then adjust 
the color on-screen until it matches the patch on the color proof. Make sure that you are 
viewing the proof under the proper lighting conditions.

4 If desired, select Estimate Overprints to automatically estimate the overprint colors 
(MY, CY, CM, and CMY) using the CMYK and white values you entered. This is useful if you 
don’t have a spectrophotometer.

Specifying dot gain
Dot gain or loss can occur when the specified printer’s halftone dots change as the ink 
spreads and is absorbed by paper. As a general rule, you should not adjust the dot gain 
value until you have run a hard proof (which includes a calibration bar) and have 
measured the density values on the proof with a reflective densitometer. Adjust this value 
if your print shop has provided a different value for estimated dot gain.

Proof (no dot gain), and printed image (with dot gain)

The Custom CMYK dialog box gives you the following ways to specify a printer’s dot gain: 

• You can define a single dot gain value at the 50% level. This means that all four inks gain 
the same amount at 50%.

• You can set up to 13 values along the grayscale range to create a customized dot gain 
curve for one or more CMYK plates. Use this method if your proof has a significant color 
cast in its neutral gray values.

To specify the dot gain at the standard 50% mark:

1 Print a hard proof with calibration bars included. (See “Setting output options” on 
page 616.)

2 Using a reflective densitometer, take a reading at the 50% mark of the printed 
calibration bar.

3 In the Custom CMYK dialog box, for Dot Gain, choose Standard. Then enter the total 
amount of dot gain measured by the densitometer. For example, if the densitometer 
reading is 54%, enter 4 in the text box to specify a dot gain of 4%.

Note: If you don’t have a densitometer, adjust the Dot Gain value until the image on-
screen looks like the proof, and then add that value to your printer’s estimate of the 
expected dot gain between proof and final output.
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To specify the dot gain using curves:

1 Print a hard proof with calibration bars included. (See “Setting output options” on 
page 616.)

2 Using a reflective densitometer, take a reading at one or more marks of the printed 
calibration bar.

3 In the Custom CMYK dialog box, for Dot Gain, choose Curves.

4 In the lower right of the Dot Gain Curves dialog box, select the ink plate for which you 
want to set dot gain curves. To set the same curves for all the plates, select All Same.

5 Do one of the following:

• Enter the values of your densitometer readings in the text boxes.

For example, if you have specified a 30% dot, and the densitometer reading is 36%, you 
have a 6% dot gain in your midtones. To compensate for this gain, enter 36% in the 30% 
text box.

• Click to add an adjustment point in the dot gain curve, and drag the point to change its 
value. The value then appears in the appropriate text box.

Adjusting the separation type and black generation
To make color separations, the three additive colors (red, green, and blue) are translated 
into their subtractive counterparts (cyan, magenta, and yellow). In theory, equal parts of 
cyan, magenta, and yellow combine to subtract all light reflected from the paper and 
create black. Due to impurities present in all printing inks, however, a mix of these colors 
instead yields a muddy brown. To compensate for this deficiency in the color separation 
process, printers remove some cyan, magenta, and yellow in areas where the three colors 
exist in equal amounts, and they add black ink. 

A given color can be translated from RGB mode to CMYK mode in an endless number of 
ways. But prepress operators typically use one of the following ways to generate black in 
print:

• In undercolor removal (UCR), black ink is used to replace cyan, magenta, and yellow ink 
in neutral areas only (that is, areas with equal amounts of cyan, magenta, and yellow). 
This results in less ink and greater depth in shadows. Because it uses less ink, UCR is 
used for newsprint and uncoated stock, which generally have greater dot gain than 
coated stock.

• In gray component replacement (GCR), black ink is used to replace portions of cyan, 
magenta, and yellow ink in colored areas as well as in neutral areas. GCR separations 
tend to reproduce dark, saturated colors somewhat better than UCR separations do 
and maintain gray balance better on press.

Choose the type of separation based on your paper stock and the requirements of your 
print shop.

To adjust the separation type and black generation:

1 In the Custom CMYK dialog box, select a separation type.
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The Separation Options area displays a graph based on current settings showing how 
neutral colors in the image will separate. In the graph, sometimes called a gray ramp, 
neutral colors have equal parts of cyan, magenta, and yellow. The horizontal axis repre-
sents the neutral color value, from 0% (white) to 100% (black). The vertical axis represents 
the amount of each ink that will be generated for the given value. In most cases, the cyan 
curve extends beyond the magenta and yellow curves, because a small extra amount of 
cyan is required to produce a true neutral. 

2 If you selected GCR as the separation type, choose an option for Black Generation:

• None generates the color separation using no black plate.

• The Light and Heavy settings decrease and increase the effect of the Medium setting 
(the default). In most cases, Medium produces the best results. 

• Maximum maps the gray value directly to the black plate. This option is useful for 
images with a large amount of solid black against a light background, such as screen 
shots from a computer.

• Custom lets you adjust the black generation curve manually. Before choosing Custom, 
first choose an option (Light, Medium, Heavy, or Maximum) that is closest to the type of 
black generation you want. This gives you a black generation curve to use as a starting 
point. Then choose Custom, position the pointer on the curve, and drag to adjust the 
black curve. The curves for cyan, magenta, and yellow are adjusted automatically 
relative to the new black curve and the total ink densities.

Black generation examples 
A. No black generation (Composite image, CMY, K) B. Medium black generation 
(Composite image, CMY, K) C. Maximum black generation (Composite image, CMY, K)

3 If needed, specify values for Black Ink Limit and Total Ink Limit (the maximum ink 
density your press can support). Check with your print shop to see if you should adjust 
these values. 

In the Gray Ramp graph, these limits determine the cutoff points for the CMYK curves.

4 If you selected GCR as the separation type, specify an amount for undercolor addition 
(UCA) to increase the amount of CMY added to shadow areas. Check with your print shop 
for the preferred value. If you are unsure of this value, leave it at 0%.

A

B

C



Using Help | Contents | Index Back 132  

Adobe Photoshop CS Help Producing Consistent Color (Photoshop) 

Using Help | Contents | Index Back 132  

UCA compensates for the loss of ink density in neutral shadow areas. This additional ink 
produces rich, dark shadows in areas that might appear flat if printed with only black ink. 
UCA can also prevent posterization in subtle detail in the shadows. 

To save a Custom CMYK setting:

1 Choose Save CMYK from the CMYK working space menu in the Color Settings 
dialog box. 

2 In the Save dialog box, give your setting a name and click Save. The profile will not be 
accessible by other Adobe applications that use color management. For information on 
color settings in other Adobe applications, see “Keeping color consistent between 
Photoshop and other Adobe applications” on page 144.

About color management policies
Color management policies determine how to handle color data that does not match your 
current color working space. Policies provide guidelines on what to do when you open a 
document or import color data into an active document. For information about working 
spaces, see “About working spaces” on page 125.

Using color management policies
When you specify a predefined color management setting, Photoshop sets up a color 
management workflow that will be used as the standard for all documents and color data 
that you open or import. For a newly created document, the color workflow usually 
operates seamlessly: unless specified otherwise, the document uses the working space 
profile associated with its color mode for creating and editing colors. 

However, it is common to encounter the following exceptions to your color-managed 
workflow:

• You might open a document or import color data (for example, by copying and pasting 
or dragging and dropping) from a document that is not tagged with a profile. This is 
often the case when you open a document created in an application that either does 
not support color management or has color management turned off.

• You might open a document or import color data from a document that is tagged with 
a profile different from the current working space. This may be the case when you open 
a document that has been created using different color management settings, or a 
document that has been scanned and tagged with a scanner profile.

In either case, Photoshop must decide how to handle the color data in the document. 
A color management policy looks for the color profile associated with an opened 
document or imported color data, and compares the profile (or lack of profile) with the 
current working space to make default color management decisions. If the profile is 
missing or does not match the working space, Photoshop displays a message that 
indicates the default action for the policy (if the alert option is selected in the color 
settings). In many cases you will also be provided with the opportunity to choose another 
action. For detailed information on the color management decisions associated with 
different policies, see “Specifying color management policies” on page 133.
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Working with policy warnings and messages
The predefined color management workflows are set to display warning or option 
messages when a default color management policy is about to be used. Although you can 
disable the repeated display of some warnings and messages by selecting the Don’t Show 
Again option, it is highly recommended that you continue to display all policy messages, 
to ensure the appropriate color management of documents on a case-by-case basis. (See 
“Resetting all warning dialogs” on page 56.) You should turn off message displays only if 
you are confident that you understand the default policy decision and are willing to 
accept it for all documents that you open. You cannot undo the results of a default policy 
decision once a document has been saved.

Specifying color management policies
Each predefined color management configuration sets up a color management policy for 
the RGB, CMYK, and Grayscale color modes and displays warning messages to let you 
override the default policy behavior on a case-by-case basis. If desired, you can change the 
default policy behavior to reflect a color management workflow that you use more often. 
For more information on policies, see “About color management policies” on page 132. 

To customize color management policies:

1 In the Color Settings dialog box, under Color Management Policies, choose one of the 
following to set the default color management policy for each color mode:

• Off if you do not want to color-manage new, imported, or opened color data.

• Preserve Embedded Profiles if you anticipate working with a mix of color-managed and 
non-color-managed documents, or with documents that use different profiles within 
the same color mode.

• Convert to Working Space if you want to force all documents to use the current working 
space.

For detailed descriptions of the default behaviors associated with each policy option, 
see the table following this procedure.

2 For Profile Mismatches, select either, both, or neither of the following:

• Ask When Opening to display a message whenever you open a document tagged with 
a profile other than the current working space. You will be given the option to override 
the policy’s default behavior.

• Ask When Pasting to display a message whenever color profile mismatches occur as 
colors are imported into a document (via pasting, drag-and-drop, placing, and so on). 
You will be given the option to override the policy’s default behavior.

The availability of options for Profile Mismatches depends on which policies have been 
specified.

3 For Missing Profiles, select Ask When Opening to display a message whenever you open 
an untagged document. You will be given the option to override the policy’s default 
behavior.

The availability of options for Missing Profiles depends on which policies have been 
specified.

It is strongly recommended that you keep the Ask When Opening and Ask When Pasting 
options selected.
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Customizing advanced color management settings
When the Advanced mode is selected, the Photoshop Color Setting dialog box lets you 
specify conversion options to handle the colors in a document as it moves from one color 
space to another. It also has advanced controls for desaturating monitor colors to visualize 
color spaces with gamuts greater than that of the monitor and for controlling the 
blending behavior of RGB colors. These options are not available if the Advanced Mode is 
turned off. 

Policy option Default color management behavior

Off • New documents and existing untagged documents remain 
untagged.

• Existing documents tagged with a profile other than the current 
working space open a warning alert before becoming untagged. 

• Existing documents tagged with the current working space profile 
remain tagged.

• For color data imported into a document using the same color 
mode, color numbers are preserved.

• For all other import cases, colors are converted to the document’s 
color space.

Preserve Embedded 
Profiles

• New documents are tagged with the current working space profile.

• Existing documents tagged with a profile other than the current 
working space remain tagged with the original embedded profile. 

• Existing untagged documents use the current working space for 
editing but remain untagged. 

• For color data imported within the same color mode between 
either a non-color-managed source or destination, or from a CMYK 
document into a CMYK document, color numbers are preserved.

• For all other import cases, colors are converted to the document’s 
color space.

Convert to Working Space • New documents are tagged with the current working space profile.

• Existing documents tagged with a profile other than the current 
working space are converted to and tagged with the working space 
profile.

• Existing untagged documents use the current working space for 
editing but remain untagged.

• For color data imported within the same color mode between 
either a non-color-managed source or destination, color numbers are 
preserved.

• For all other import cases, colors are converted to the document’s 
color space.
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About the Color Management Module (CMM)
The Color Management Module (CMM), sometimes called the color engine, is the part of 
the color management system that maps the gamut (range of colors) of one color space to 
the gamut of another.

When Advanced Mode is selected in the Color Settings dialog box, Photoshop lets you 
choose a CMM from the Engine menu in the Conversion Options area of the dialog box. 
For most users, the default Adobe (ACE) engine will fulfill all conversion needs. 

Typical engine choices include:

Adobe (ACE) Uses the Adobe color management system and color engine. This is the 
default CMM in Photoshop.

Microsoft ICM (Windows) Uses the Microsoft ICM color management system and its 
default color matching method.

Apple ColorSync (Mac OS) Uses the Apple ColorSync color management system and its 
default color matching method. 

Apple CMM (Mac OS) Uses the Apple ColorSync color management system and the 
rendering intent chosen in the Color Setting dialog box.

Other CMMs can be loaded on your computer and chosen in the Color Settings dialog box. 
These CMMS are generally specialized and are of use only to knowledgeable users.

Handling colors with a rendering intent
A rendering intent determines how a color management system handles color conversion 
from one color space to another. The rendering intent you choose depends on whether 
colors are critical in an image and on your preference of what the overall color appearance 
of an image should be.

When Advanced Mode is selected in the Color Settings dialog box, Photoshop lets you 
choose a rendering intent in the Conversion Options area of the dialog box.

Perceptual Aims to preserve the visual relationship between colors so it’s perceived as 
natural to the human eye, even though the color values themselves may change. This 
intent is suitable for photographic images with lots of out-of-gamut colors.

Saturation Tries to produce vivid colors in an image at the expense of color accuracy. 
This rendering intent is suitable for business graphics like graphs or charts, where bright 
saturated colors are more important than the exact relationship between colors (such as 
in a photographic image).

Relative Colorimetric Compares the extreme highlight of the source color space to that 
of the destination color space and shifts all colors accordingly. Out-of-gamut colors are 
shifted to the closest reproducible color in the destination color space. Relative colori-
metric preserves more of the original colors in an image than Perceptual.

Absolute Colorimetric Leaves colors that fall inside the destination gamut unchanged. 
Out of gamut colors are clipped. No scaling of colors to destination white point is 
performed. This intent aims to maintain color accuracy at the expense of preserving 
relationships between colors and is suitable for proofing to simulate the output of a 
particular device.
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Using black point compensation
When Advanced Mode is selected in the Color Settings dialog box, the Use Black Point 
Compensation option is available to control whether to adjust for differences in black 
points when converting colors between color spaces. When this option is selected, the full 
dynamic range of the source space is mapped into the full dynamic range of the desti-
nation space. When deselected, the dynamic range of the source space is simulated in the 
destination space; although this mode can result in blocked or gray shadows, it can be 
useful when the black point of the source space is darker than that of the destination 
space.

The Use Black Point Compensation option is selected for all predefined configurations in 
the Settings menu of the Color Settings dialog box. It is highly recommended that you 
keep this option selected. 

Using dither
The Use Dither (8-bit/channel images) option controls whether to dither colors when 
converting 8-bit-per-channel images between color spaces. This option is available only 
when the Color Settings dialog box is in Advanced Mode. When the Use Dither option is 
selected, Photoshop mixes colors in the destination color space to simulate a missing 
color that existed in the source space. Although dithering helps to reduce the blocky or 
banded appearance of an image, it may also result in larger file sizes when images are 
compressed for Web use.

Desaturating monitor colors
The Desaturate Monitor Colors By option determines whether to desaturate colors by the 
specified amount when displayed on the monitor. When selected, this option can aid in 
visualizing the full range of color spaces with gamuts larger than that of the monitor. 
However, this causes a mismatch between the monitor display and the output. When the 
option is deselected, distinct colors in the image may display as a single color. The Desat-
urate Monitor Colors By option is available only when Advanced Mode is selected in the 
Color Settings dialog box.

Blending RGB colors
The Blend RGB Colors Using Gamma option controls how RGB colors blend together to 
produce composite data (for example, when you blend or paint layers using Normal 
mode). When the option is selected, RGB colors are blended in the color space corre-
sponding to the specified gamma. A gamma of 1.00 is considered “colorimetrically 
correct” and should result in the fewest edge artifacts. When the option is deselected, 
RGB colors are blended directly in the document’s color space. The Blend RGB Colors Using 
Gamma option is available only when Advanced Mode is selected in the Color Settings 
dialog box.

Saving and loading custom working space profiles
If none of the working space options in the Color Settings dialog box accurately describe 
the color space of your particular output or display device, you can create a custom RGB, 
CMYK, Grayscale, or Spot working space profile. Saving your custom profile ensures that 
you can reuse it and share it with other users and other Adobe applications that use the 
Color Settings dialog box. 
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You can also load a profile that has not been saved in the recommended profile location, 
so that the profile appears in the Color Settings dialog box. 

To save a custom working space profiles:

1 Do one of the following:

• In Windows, choose Edit > Color Settings, and select Advanced Mode.

• In Mac OS, choose Photoshop > Color Settings, and select Advanced Mode.

2 Create a custom working space profile by doing one of the following in the Color 
Settings dialog box:

• Choose Custom RGB from the RGB menu. In the Custom RGB dialog box, give the 
custom profile a name, and then specify the gamma, white point, and primaries 
options. Click OK.

• Choose Custom CMYK from the CMYK menu. In the Custom CMYK dialog box, give the 
custom profile a name, and then specify the ink options and separation options. 
Click OK.

• Choose Custom Dot Gain from either the Gray menu or the Spot menu. In the Custom 
Dot Gain dialog box, give the custom profile a name, and then specify the dot gain 
curve.

• Choose Custom Gamma from the Gray menu. In the Custom Gamma dialog box, give 
the custom profile a name and then enter a value for the gamma.

3 Depending on the custom profile you created, in the Working Spaces area of the Color 
Settings dialog box, choose one of the following:

• Save RGB from the RGB menu.

• Save CMYK from the CMYK menu.

• Save Gray from the Gray menu.

• Save Spot from the Spot menu.

4 Name and save the profile. Profiles can be saved to the system profile location 
(depending on the operating system) or to (Windows) Program Files/CommonFiles/
Adobe/Color/Profiles or (Mac OS) Library/Application Support/Adobe/Color/Profiles. 
On Mac OS, the profiles can also be saved to the user-specific Application Support folder 
as well.

To access a saved profile, you may need to load it or restart Photoshop. If you do not save a 
custom profile, it will be stored only in the custom color settings file of which it is a part 
and will not be available as a profile option in the Color Settings dialog box.

To load a custom profile:

1 Do one of the following:

• In Windows, choose Edit > Color Settings, and select Advanced Mode.

• In Mac OS, choose Photoshop > Color Settings, and select Advanced Mode.

2 In the Working Spaces area of the Color Settings dialog box, choose:

• Load RGB from the RGB menu.

• Load CMYK from the CMYK menu.



Using Help | Contents | Index Back 138  

Adobe Photoshop CS Help Producing Consistent Color (Photoshop) 

Using Help | Contents | Index Back 138  

• Load Gray from the Gray menu.

• Load Spot from the Spot menu.

3 Locate and select the desired profile, and click Open.

If you load a profile that has been saved outside the recommended location, it temporarily 
replaces the Other option in the Working Spaces menu until another profile is loaded.

Creating custom grayscale and spot-color profiles
You can create a custom grayscale or spot-color profile based on the specific dot-gain or 
gamma characteristics of your output device. You can also load a CMYK profile into the 
Gray working space menu to generate a custom grayscale profile based on the CMYK 
space.

To create a grayscale or spot-color profile based on a custom dot gain:

1 Print a hard proof with calibration bars included. (See “Setting output options” on 
page 616.)

2 Using a reflective densitometer, take a reading at one or more marks of the printed 
calibration bar.

3 Do one of the following:

• In Windows, choose Edit > Color Settings, and select Advanced Mode.

• In Mac OS, choose Photoshop > Color Settings, and select Advanced Mode.

4 Under Working Spaces, for Gray or Spot, choose Custom Dot Gain.

5 For Name, enter the name for the custom profile.

6 Do one of the following:

• Using your densitometer readings, calculate the required adjustments, and enter the 
percentage values in the text boxes.

For example, if you have specified a 30% dot, and the densitometer reading is 36%, you 
have a 6% dot gain in your midtones. To compensate for this gain, enter 36% in the 30% 
text box.

• Click to add an adjustment point in the dot gain curve, and drag the point to change its 
value. The value then appears in the appropriate text box.

• Click OK.

7 Save the custom profile. (See “Saving and loading custom working space profiles” on 
page 136.)

To create a grayscale profile based on a custom gamma:

1 Do one of the following:

• In Windows, choose Edit > Color Settings, and select Advanced Mode.

• In Mac OS, choose Photoshop > Color Settings, and select Advanced Mode.

2 Select Advanced.

3 Under Working Spaces, for Gray, choose Custom Gamma.

4 For Name, enter the name for the custom profile.



Using Help | Contents | Index Back 139  

Adobe Photoshop CS Help Producing Consistent Color (Photoshop) 

Using Help | Contents | Index Back 139  

5 Specify the desired gamma value, and click OK.

6 Save the custom profile. (See “Saving and loading custom working space profiles” on 
page 136.)

Creating a viewing environment for color management
Your work environment influences how you see color on your monitor and on printed 
output. For best results, control the colors and light in your work environment by doing 
the following:

• View your documents in an environment that provides a consistent light level and color 
temperature. For example, the color characteristics of sunlight change throughout the 
day and alter the way colors appear on your screen, so keep shades closed or work in a 
windowless room. To eliminate the blue-green cast from fluorescent lighting, consider 
installing D50 (5000 degree Kelvin) lighting. Ideally, view printed documents using a 
D50 lightbox or using the ANSI PH2.30 viewing standard for graphic arts.

• View your document in a room with neutral-colored walls and ceiling. A room’s color 
can affect the perception of both monitor color and printed color. The best color for a 
viewing room is polychromatic gray. Also, the color of your clothing reflecting off the 
glass of your monitor may affect the appearance of colors on-screen.

• Match the light intensity in the room or variable lightbox to the light intensity of your 
monitor. View continuous-tone art, printed output, and images on-screen under the 
same intensity of light.

• Remove colorful background and user-interface patterns on your monitor desktop. 
Busy or bright patterns surrounding a document interfere with accurate color 
perception. Set your desktop to display neutral grays only.

• View document proofs in the real-world conditions under which your audience will see 
the final piece. For example, you might want to see how a housewares catalog looks 
under the incandescent light bulbs used in homes, or view an office furniture catalog 
under the fluorescent lighting used in offices. However, always make final color 
judgments under the lighting conditions specified by the legal requirements for 
contract proofs in your country.

Compensating for dot gain in film using transfer functions
When using CMYK color profiles, you cannot customize dot gain settings. However, you 
may be able to compensate for dot gain from a miscalibrated imagesetter by using 
transfer functions.

Transfer functions enable you to compensate for dot gain between the image and film. 
For example, the Transfer function makes 50% dots in the image print as 50% dots on film. 
Similar to dot gain curves, the transfer functions let you specify up to 13 values along the 
grayscale to create a customized transfer function. Unlike dot gain curves, transfer 
functions apply only to printing—they don’t affect the image color data.

Use the following guidelines to determine the best method of accounting for dot gain:

• If you are using a custom CMYK profile, use the dot gain settings in the custom CMYK 
dialog box to adjust dot gain so that it matches the printed results.
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• If you are using an ICC profile and the dot gain values do not match the printed results, 
try to obtain a new profile with values that do match.

• Use transfer functions only if neither of the previous methods is an option.

To adjust transfer function values: 

1 Use a transmissive densitometer to record the density values at the appropriate steps in 
your image on film.

2 Choose File > Print with Preview.

3 Select Show More Options, and choose Output from the pop-up menu.

4 Click the Transfer button.

5 Calculate the required adjustment, and enter the values (as percentages) in the Transfer 
Functions dialog box. 

For example, if you specified a 50% dot, and your imagesetter prints it at 58%, an 8% dot 
gain occurs in the midtones. To compensate for this gain, enter 42% (50% – 8%) in the 50% 
text box of the Transfer Functions dialog box. The imagesetter then prints the 50% dot you 
want.

When entering transfer function values, keep in mind the density range of your image-
setter. On a given imagesetter, a very small highlight dot may be too small to hold ink. 
Beyond a certain density level, the shadow dots may fill as solid black, removing all detail 
in shadow areas. 

Note: To preserve transfer functions in an exported EPS file, select Override Printer’s 
Default Functions in the Transfer Functions dialog box and then export the file with 
Include Transfer Functions selected in the EPS Format dialog box. (See “Saving files in 
Photoshop EPS format (Photoshop)” on page 570.)

To save the current transfer function settings as the default:

Hold down Alt (Windows) or Option (Mac OS) to change the Save button to —> Default, 
and click the button. 

To load the default transfer function settings:

Hold down Alt (Windows) or Option (Mac OS) to change the Load button to <— Default, 
and click the button.

Soft-proofing colors
In a traditional publishing workflow, a hard proof of your document (sometimes called a 
proof print or match print) is produced so you can preview how the document’s colors will 
look when reproduced on a specific output device. In a color-managed workflow, color 
profiles tell the color management system how to display a preview (soft proof ) of your 
document directly on the monitor. This provides an on-screen preview of the document’s 
colors as reproduced on a specified device. You can print the soft proof using your desktop 
printer to produce a hard proof. (See “Printing a hard proof” on page 143.)

Keep in mind that the reliability of the soft proof depends upon the quality of your 
monitor, the profiles of your monitor and output devices, and the ambient lighting 
conditions of your work environment.
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Previewing colors using a soft proof
If your monitor is properly calibrated and you have accurate profiles of your output 
devices, you can use Photoshop’s soft proof capabilities to preview how your image will 
look when printed on your desktop printer, sent to a printing press, viewed on a particular 
computer operating system, made into color separations, and produced on a specific 
output device.

Photoshop also lets you open a document in two windows so you can compare the colors 
in the original image and the colors in the soft proof. (See “Comparing the soft proof to the 
original image” on page 143.) 

Using a soft proof to preview the final output of a document on your monitor 
A. The document in the working space. B. The document’s color values are translated to the color 
space of the chosen proof profile (usually the output device’s profile). C. The monitor displays the 
proof profile’s interpretation of the document’s color values.

To display a soft proof:

1 Choose View > Proof Setup, and choose the profile of the color space that you want to 
simulate:

• Custom creates a soft proof of colors using the color profile of a specific output device 
or of specific papers used in a desktop printer. Follow the instructions after this 
procedure to set up the custom proof. This option is recommended for the most 
accurate preview of your final printed piece.

• Working CMYK creates a soft proof of colors using the current CMYK working space as 
defined in the Color Settings dialog box.

• Working Cyan Plate, Working Magenta Plate, Working Yellow Plate, Working Black Plate, 
or Working CMY Plates creates a soft proof of specific CMYK ink colors using the current 
CMYK working space.

• Macintosh RGB or Windows RGB creates a soft proof of colors in an image using either a 
standard Mac OS or Windows monitor as the proof profile space to simulate. Neither 
option is available for Lab or CMYK documents.

• Monitor RGB creates a soft proof of colors in an RGB document using your current 
monitor color space as the proof profile space. This option is unavailable for Lab and 
CMYK documents.

• Simulate Paper White previews the specific shade of white exhibited by the print 
medium defined by a document’s profile. This option is not available for all profiles and 
is available only for soft-proofing, not printing.

• Simulate Ink Black previews the actual dynamic range defined by a document’s profile. 
This option is not available for all profiles and is available only for soft-proofing, not 
printing.

A B C
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2 Choose View > Proof Colors to turn the soft-proof display on and off. When soft 
proofing is on, a check mark appears next to the Proof Colors command.

When soft proofing is on, the name of the current proof profile appears next to the bit 
depth in the document’s title bar.

Note: The bit depth always appears in the title bar next to the color mode.

To create a custom proof setup:

1 Choose View > Proof Setup > Custom.

If you want the custom proof setup to be the default proof setup for documents, close 
all document windows before choosing the View > Proof Setup > Custom command.

2 Select Preview to display a live preview of the proof settings in the document while the 
Proof Setup dialog box is open. 

3 To use a preset proof setup as a starting point, choose it from the Setup menu. If the 
desired setup does not appear in the menu, click Load to locate and load the setup.

4 For Profile, choose the color profile for the output device for which you want to create 
the proof. The usefulness of the chosen profile depends on how accurately it describes the 
device’s behavior. Often, custom profiles for specific paper and printer combinations 
create the most accurate soft proof.

5 If the proof profile you chose uses the same color mode as the document, do one of 
the following:

• Select Preserve Color Numbers to preview how the image would look when sending 
numeric values in the file to an output device with no color conversion to the proof 
profile space. This option could be useful if you have a CMYK file that was prepared for a 
specific printing process and you want to see how it would look when printed directly 
to a different output device such as your inkjet printer or a different press. The results 
would help you decide whether the image needs to be converted to a different color 
space, edited, or left as is.

• Deselect Preserve Color Numbers to simulate how the document will appear if colors 
are converted from the document space to their nearest equivalents in the proof profile 
space in an effort to preserve the colors’ visual appearances. Then specify a rendering 
intent for the conversion. (See “Handling colors with a rendering intent” on page 135.)

6 If needed, select any of the following:

• Simulate Paper White to preview the dingy white of real paper. Selecting this option 
automatically selects the Simulate Ink Black option.

• Simulate Ink Black to preview the dark gray you really get instead of a solid black on 
many printers.

The availability of these options depends on the proof profile chosen. Not all profiles 
support both options.

7 To save your custom proof setup as a preset proof setup, click Save. To ensure that the 
new preset appears in the View > Proof Setup menu, save the preset in the Program Files/
Common Files/Adobe/Color/Proofing folder (Windows), or Users/user profile/Library/
Application Support/Adobe/Color/Proofing folder (Mac OS).
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Comparing the soft proof to the original image
Photoshop lets you open an document in two windows simultaneously. The document 
can be viewed using the profiles of two different working spaces or color modes. This is 
useful for comparing the colors in your original image with the colors in the soft-proof 
version of your image.

In Photoshop, you can compare the colors in a soft proof with the original image by opening the 
image in two windows, each showing the image in a different working space.

To view an image and a soft proof of the same image simultaneously:

1 Open a document in Photoshop.

2 Choose Window > Arrange > New Window for name of document.

3 With one of the document windows active, do one of the following:

• Choose View > Proof Setup and choose the profile you want to preview. 

• Choose View > Proof Colors. The document window will display the image applying the 
profile previously chosen in the Proof Setup.

Printing a hard proof
A hard proof (sometimes called a proof print or match print) is a printed simulation of what 
your final output on a printing press will look like. A hard proof is produced on an output 
device that’s less expensive than a printing press. In recent years some inkjet printers have 
the resolution necessary to produce inexpensive prints that can be used as hard proofs. 

To print a hard proof:

1 Open the document in Photoshop.

2 Choose View > Proof Setup > Custom and choose the profile of your output device in 
the Profile menu. Choose a Rendering Intent from the Intent menu. Click Save to save the 
settings if you’re going to be doing more proofs on the specific output device.

3 Click OK to close the Proof Setup dialog box.
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4 Choose File > Print with Preview.

5 In the Print with Preview dialog box, make sure Show More Options is selected and 
Color Management is chosen.

6 In the Source Space area, select Proof. The Proof Setup should be the profile you 
specified.

7 In the Print Space area, do one of the following:

• Choose Printer Color Management from the Profile menu if you’re printing with the 
printer driver’s choices of factory profiles. This is useful when you don’t have custom 
profiles for the printer, and you want the printer driver to pick the best profile according 
to the paper type, resolution, and so forth. After clicking the Print button, the Print 
dialog box (for setting printer options) opens. On Windows, click the Properties button 
to access the printer driver options and set the color management options. On Mac OS, 
use the pop-up menu to access the printer driver options and set the color 
management options.

• If you’re printing with a custom profile, choose the custom profile from the Profile 
menu. Then click the Print button. The Print dialog box (for setting printer options) 
opens. On Windows, click the Properties button and set the printer driver options 
so color management is turned off (the options could be similar to No Color 
Management, Color Adjustments Off, or Color Management Off ). On Mac OS, use 
the pop-up menu to access the printer driver options for color management and 
turn color management off.

Keeping color consistent between Photoshop and other 
Adobe applications
It’s necessary to specify the same color management settings for the workspaces and 
conversion options to keep color consistent when moving documents between 
Photoshop and other Adobe applications that support color management. The Color 
Settings dialog box represents the common color management controls shared by 
Photoshop, Adobe Illustrator, and Adobe InDesign. In Adobe Acrobat, the color 
management controls are found in the Preferences. Synchronizing the color settings helps 
to ensure that color is reproduced consistently between Adobe applications that support 
color management. To share custom color settings between applications, be sure to save 
your settings (in a .csf file). You can load the settings file in the desired application instead 
of copying all the settings manually. (See “Saving and loading color management 
settings” on page 125.)

Note: If you modify and save over the current Color Settings.csf file in any application 
other than Photoshop, you may be prompted to synchronize the common color settings 
upon starting Photoshop or upon reopening the Color Settings dialog box in Photoshop. 
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You can go through the following procedure to re-synchronize the color settings between 
Photoshop and other Adobe applications.

Saved settings in Photoshop will appear in the Color Settings menu in Illustrator, InDesign and 
Acrobat 6.

To synchronize the color settings between Photoshop and other Adobe applications:

1 Do one of the following:

• (Windows) Choose Edit > Color Settings.

• (Mac OS) Choose Photoshop > Color Settings.

2 In the Color Settings dialog box, choose a preset setting from the Settings menu or 
specify the settings for the Workspaces, Color Management Policies, and Conversion 
Options. If necessary, specify the Advanced Controls. For more information, see “Using the 
Photoshop Color Settings” on page 122.

3 (Optional) If you customized the color settings, click the Save button, give your settings 
a name, and click the Save button in the Save dialog box. Saving your settings in a .csf file 
lets you conveniently share the settings between color-managed Adobe applications. 

4 Click OK in the Color Settings dialog box.

5 To specify the same color settings in the other Adobe applications, do one of the 
following:

• In Adobe Illustrator and Adobe InDesign, choose Edit > Color Settings.

• In Adobe Acrobat, choose Edit > Preferences (Windows) or Acrobat > Preferences 
(Mac OS).

6 (Acrobat and InDesign only) Do one of the following:

• In Acrobat, click Color Management in the left pane of the Preferences dialog box.

• In InDesign, select the Enable Color Management option in the Color Settings dialog 
box.

7 Use the Settings menu to choose the color settings from Photoshop.

8 Click OK.
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Producing consistent color with a desktop printer
Using a color-managed workflow, you can control the appearance of colors in your 
document so they remain the same or similar when the document is printed on a desktop 
printer.

Desktop printer workflow 
A. Photoshop handling the color management; usually a custom profile is chosen from 
the Profile menu B. Printer driver handling the color management

To color manage your document for output on a desktop printer:

Set up your devices for color management Calibrate your monitor and create a profile 
for it. Use Adobe Gamma (Windows), Monitor Calibrator (Mac OS) or, for more precise 
calibration, use third-party software and hardware. If profiles came with your printer, 
make sure they’re installed on your computer. For important color work, it’s highly 
recommended that you create custom profiles for each type of paper that you use with 
the printer.

Set up the Photoshop color management system Choose Edit > Color Settings 
(Windows) or Photoshop > Color Settings (Mac OS) to specify the color management 
settings. You can either choose a preset from the Settings menu in the Color Settings 
dialog box or customize the settings. At the very least, you should choose one of the 
Prepress Default settings, which specifies Adobe RGB (1998) as the RGB working space. 
Adobe RGB (1998) is a large enough color space to encompass the colors used in printing. 
In general, it’s not advised to use sRGB as the working space, since it’s smaller and may not 
contain important colors that can be printed. 

PREPARE YOUR DEVICES

EDIT IN
PHOTOSHOP

PRINT WITH
PREVIEW

PRINT PRINT

PRINT WITH
PREVIEW

PROOF
COLORS

(optional)

Calibrate your monitor/
install canned profiles/
make custom profiles

Turn off Color Management Turn on Color Management

Use the US Prepress Default,
Adobe RGB working space

SETUP COLOR SETTINGS
IN PHOTOSHOP

BA
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Edit your image in Photoshop Depending on the color management policy you choose, 
you will be editing the image in either the current RGB working space or in the working 
space profile embedded in the document. The choice of whether to convert a document 
to the RGB working space or preserve its embedded profile is a personal decision. For 
instance, if you feel that Adobe RGB is a suitable working space for all images that you 
print, you might consider choosing Adobe RGB as your RGB working space, and then 
choose the Convert to Working Space policy and always working in Adobe RGB.

(Optional) Soft proof your image If you want to see a simulation of your final printed 
image, use the Proof Setup command and choose the printer’s profile. Your monitor will 
display the image in the color space of your desktop printer. For the most accurate soft 
proof, choose a profile for the specific paper you’re printing on.

Use Print with Preview Choose File > Print with Preview. In the Print dialog box:

• Select Show More Options and choose Color Management from the pop-up menu.

• In the Source Space area, Choose Document (unless you’re printing a hard copy of the 
soft proof ).

• In the Print Space area, choose the profile of your printer or your custom profile of a 
specific printer/paper combination. Photoshop will handle the color management 
during printing. Choose Printer Color Management if your printer driver is handling the 
color management during printing. 

• Also in the Print Space area, choose a rendering intent. Generally, Relative Colorimetric 
or Perceptual are the most common intents used for photographic images because 
they preserve the overall appearance of a document’s colors when printed.

Set printer options Click the Print button in the Print dialog box (for the Print with 
Preview command) to open a second Print dialog box (for setting printer options). The 
options available in the printer options dialog box depend on the printer drivers installed 
on your computer. On Windows, click the Properties button to access the printer driver 
options. On Mac OS, use the pop-up menu to access the printer driver options. Set the 
print options for the quality you want. If Photoshop is handling the color adjustment or 
color management options during printing, turn off all printer driver color adjustment 
options. If not, specify the color management settings to let your printer driver handle the 
color management during printing. It’s important not to color manage in both Photoshop 
and the printer driver simultaneously during printing. This results in unpredictable color. 

Producing consistent color when sending images to press
Using a color-managed workflow, you can control the appearance of colors in your 
document so they remain the same or similar when the document is sent out to be 
printed on a printing press.

To color manage your document for output on a printing press:

Set up your devices for color management Calibrate your monitor and create a profile 
for it. Use Adobe Gamma (Windows), Monitor Calibrator (Mac OS) or, for more precise 
calibration, use third-party software and hardware. If profiles came with your printer, 
make sure they’re installed on your computer. For important color work, it’s highly 
recommended that you create custom profiles for each type of paper that you use with 
the printer.
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Set up the Photoshop color management system Choose Edit > Color Settings 
(Windows) or Photoshop > Color Settings (Mac OS) to specify the color management 
settings. You can either choose a preset from the Settings menu in the Color Settings 
dialog box or customize the settings. At the very least, you should choose one of the 
Prepress Default settings, which specifies Adobe RGB (1998) as the RGB working space. 
Adobe RGB (1998) is a large enough color space to encompass the colors used in printing. 
In general, it’s not advised to use sRGB as the working space since it’s smaller and may not 
contain important colors that can be printed. 

Synchronize the color settings between Photoshop and Illustrator or InDesign If you 
plan to place your Photoshop image in an Illustrator or InDesign document, make sure the 
color settings are synchronized using the Color Settings dialog box in each application. 
For more information on keeping colors consistent between Photoshop and other Adobe 
applications, see “Keeping color consistent between Photoshop and other Adobe applica-
tions” on page 144.

Edit your image in Photoshop Depending on the color management policy you choose, 
you will be editing the image in either the current RGB working space or in the working 
space profile embedded in the document. The choice of whether to convert a document 
to the RGB working space or preserve its embedded profile is a personal decision. For 
instance, if you feel that Adobe RGB is a suitable working space for all images that you 
print, you might consider choosing Adobe RGB as your RGB working space, and then 
choose the Convert to Working Space policy and always working in Adobe RGB.

(Optional) Place your RGB or CMYK image in Adobe InDesign or Adobe Illustrator
In general, most images printed on a commercial press are not printed directly from 
Photoshop but from a page-layout program like Adobe InDesign or a print-savvy program 
like Adobe Illustrator. For more information on importing Photoshop files into Adobe 
InDesign or Adobe Illustrator, see Adobe InDesign Help or Adobe Illustrator Help.

(Optional) Work entirely in RGB mode Make sure the image file is tagged with the RGB 
working space profile. If your printer or prepress vendor uses a color management system, 
he or she should be able to use your file’s profile to make an accurate conversion to CMYK 
for producing the film and printing plates.

(Optional) Convert to CMYK Work in RGB mode until you finish with your image editing. 
After editing, convert the image to CMYK mode and make any additional color and tonal 
adjustments. Be sure to check the highlight and shadow areas of the image. If necessary, 
use the Levels, Curves, or Hue/Saturation command to make tonal corrections. These 
image adjustments should be very minor. After making final adjustments, send the CMYK 
file to your print house or prepress.
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Producing consistent color when creating images 
for the Web
Keeping colors consistent in images for the Web is a challenge. You have control over how 
your images display on your monitor, but you have no control over how they will display 
on other monitors. Additionally, most browsers do not recognize a document’s embedded 
profile. They simply send the raw RGB values to your monitor. Without a profile, a 
computer’s color management system must guess what colors a document’s RGB values 
actually represent. Although it may seem impossible to produce consistent colors in an 
image for the Web, there are a few things you can do to keep the colors as consistent as 
possible.

To keep colors as consistent as possible in Web images:

Set up your monitor for a color-managed workflow Calibrate and profile your monitor. 
Use a visual calibrator like Adobe Gamma (Windows), Monitor Calibrator (Mac OS) or, 
for more precision, use third-party software and hardware. 

Set up color management in Photoshop Choose Edit > Color Settings (Windows) or 
Photoshop > Color Settings (Mac OS) and specify the color management settings. You can 
either choose Web Graphics Defaults from the Settings menu in the Color Settings dialog 
box or customize the settings. If you prefer not to use the preset option, it’s recommended 
that you at least use sRGB for your working space. sRGB is a smaller color space than 
Adobe RGB (1998) and supposedly represents the profile of the average monitor. Tagging 
your image with an sRGB profile increases the possibility that more monitors will correctly 
display the colors in your image.

(Optional) Convert the document to sRGB profile If you have an image that’s tagged 
with a profile other than sRGB, you can convert profile to sRGB so that the colors have a 
chance of maintaining a consistent appearance on a wide variety of monitors. Choose 
Image > Mode > Convert to Profile and choose sRGB for Profile under Destination Space. 

Save for Web Choose File > Save for Web. The Save for Web command gives you more 
control over the optimization of your image. You can specify the colors that are preserved 
when saving an image in GIF or PNG-8 format. In JPEG format, you have the option of 
embedding an ICC profile in the file. Currently, only Internet Explorer (Mac OS) and 
OmniWeb (Mac OS) can read embedded profiles in images if the user enables the 
ColorSync option in the preferences. If an image has no embedded profile, Internet 
Explorer (Mac OS) and OmniWeb (Mac OS) assume an sRGB profile for the image.
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Working with Color

About the different color modes (Photoshop)
Color models describe colors numerically. There are different methods of describing colors 
numerically, and a color mode determines which method or set of numbers to use to 
display and print an image. Photoshop bases its color modes on the color models that are 
useful for images used in publishing. You can choose from RGB (red, green, blue); CMYK 
(cyan, magenta, yellow, black); Lab Color (based on CIE L*a*b*), and Grayscale. Photoshop 
also includes modes for specialized color output such as Indexed Color and Duotone. 

Note: ImageReady only uses the RGB mode to work with images, since its documents are 
primarily intended for the Web. For more information about color models, see “Using color 
models to describe color” on page 112.

In addition to determining the number of colors that can be displayed in an image, color 
modes affect the number of channels and the file size of an image.

RGB Color mode
Photoshop’s RGB Color mode uses the RGB model, assigning an intensity value to each 
pixel ranging from 0 (black) to 255 (white) for each of the RGB (red, green, blue) compo-
nents in a color image. For example, a bright red color might have an R value of 246, 
a G value of 20, and a B value of 50. When the values of all three components are equal, 
the result is a shade of neutral gray. When the value of all components are 255, the result is 
pure white; when the values are 0, pure black.

RGB images use three colors, or channels, to reproduce colors on-screen. The three 
channels translate to 24 (8 bits x 3 channels) bits of color information per pixel. With 24-bit 
images, up to 16.7 million colors can be reproduced. With 48-bit images (16 bits per 
channel), even more colors can be reproduced. In addition to being the default mode for 
new Photoshop images, the RGB model is used by computer monitors to display colors. 
This means that when working in color modes other than RGB, such as CMYK, Photoshop 
interpolates the CMYK image to RGB for display on-screen.

Although RGB is a standard color model, the exact range of colors represented can vary, 
depending on the application or display device. Photoshop’s RGB Color mode varies 
according to the working space setting that you have specified in the Color Settings 
dialog box. (See “About working spaces” on page 125.)

CMYK Color mode
In Photoshop’s CMYK mode, each pixel is assigned a percentage value for each of the 
process inks. The lightest (highlight) colors are assigned small percentages of process ink 
colors, the darker (shadow) colors higher percentages. For example, a bright red might 
contain 2% cyan, 93% magenta, 90% yellow, and 0% black. In CMYK images, pure white is 
generated when all four components have values of 0%.
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Use the CMYK mode when preparing an image to be printed using process colors. 
Converting an RGB image into CMYK creates a color separation. If you start with an RGB 
image, it’s best to edit first in RGB and then convert to CMYK at the end of your process. 
In RGB mode, you can use the Proof Setup commands to simulate the effects of a CMYK 
conversion without changing the actual image data. (See “Soft-proofing colors” on 
page 140.) You can also use CMYK mode to work directly with CMYK images scanned or 
imported from high-end systems.

Although CMYK is a standard color model, the exact range of colors represented can vary, 
depending on the press and printing conditions. Photoshop’s CMYK Color mode varies 
according to the working space setting that you have specified in the Color Settings 
dialog box. (See “About working spaces” on page 125.)

Lab Color mode
In Photoshop, the Lab Color mode has a lightness component (L) that can range from 0 to 
100. In the Adobe Color Picker, the a component (green-red axis) and the b component 
(blue-yellow axis) can range from +127 to –128. In the Color palette, the a component and 
the b component can range from +120 to –120.

You can use Lab mode to work with Photo CD images, edit the luminance and the color 
values in an image independently, move images between systems, and print to PostScript 
Level 2 and Level 3 printers. To print Lab images to other color PostScript devices, convert 
to CMYK first.

Lab images can be saved in Photoshop, Photoshop EPS, Large Document Format (PSB), 
PDF, Photoshop Raw, TIFF, Photoshop DCS 1.0, or Photoshop DCS 2.0 formats. 48-bit (16 
bits per channel) Lab images can be saved in Photoshop, Large Document Format (PSB), 
Photoshop PDF, Photoshop Raw, or TIFF formats.

Note: The DCS 1.0 and DCS 2.0 formats convert the file to CMYK when opened.

Lab color is the intermediate color model Photoshop uses when converting from one 
color mode to another.

Bitmap mode
This mode uses one of two color values (black or white) to represent the pixels in an 
image. Images in Bitmap mode are called bitmapped 1-bit images because they have a bit 
depth of 1. (See “Specifying 8-bit color display (Photoshop)” on page 153.)

Grayscale mode
Grayscale mode uses up to 256 shades of gray. Every pixel of a grayscale image has a 
brightness value ranging from 0 (black) to 255 (white). Grayscale values can also be 
measured as percentages of black ink coverage (0% is equal to white, 100% to black). 
Images produced using black-and-white or grayscale scanners typically are displayed in 
Grayscale mode. 

Although Grayscale is a standard color model, the exact range of grays represented can 
vary, depending on the printing conditions. In Photoshop, Grayscale mode uses the range 
defined by the working space setting that you have specified in the Color Settings dialog 
box. (See “About working spaces” on page 125.)
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These guidelines apply to converting images to and from Grayscale mode:

• You can convert both Bitmap-mode and color images to grayscale. 

• To convert a color image to a high-quality grayscale image, Photoshop discards all color 
information in the original image. The gray levels (shades) of the converted pixels 
represent the luminosity of the original pixels.

You can mix information from the color channels to create a custom grayscale channel 
by using the Channel Mixer command.

• When converting from grayscale to RGB, the color values for a pixel are based on its 
previous gray value. A grayscale image can also be converted to a CMYK image (for 
creating process-color quadtones without converting to Duotone mode) or to a Lab 
color image.

Duotone mode
Duotone mode creates monotone, duotone (two-color), tritone (three-color), and 
quadtone (four-color) grayscale images using two to four custom inks. (See “Printing 
duotones” on page 622.)

Indexed Color mode
Indexed Color mode produces 8-bit image files with at most 256 colors. When converting 
to indexed color, Photoshop builds a color lookup table (CLUT), which stores and indexes 
the colors in the image. If a color in the original image does not appear in the table, 
the program chooses the closest one or uses dithering to simulate the color using available 
colors. 

By limiting the palette of colors, indexed color can reduce file size while maintaining 
enough visual quality for certain applications like a multimedia presentation or a Web 
page. Limited editing is available in this mode. For extensive editing, you should convert 
temporarily to RGB mode. Indexed Color files can be saved in Photoshop, BMP, GIF, 
Photoshop EPS, Large Document Format (PSB), PCX, Photoshop PDF, Photoshop Raw, 
Photoshop 2.0, PICT, PNG, Targa, or TIFF formats. (See “Converting to indexed color 
(Photoshop)” on page 160.)

Multichannel mode
Multichannel mode uses 256 levels of gray in each channel. Multichannel images are 
useful for specialized printing. Multichannel mode images can be saved in Photoshop, 
Photoshop 2.0, Photoshop Raw, or Photoshop DCS 2.0 format.

These guidelines apply to converting images to Multichannel mode:

• Color channels in the original image become spot color channels in the converted 
image.

• When you convert a color image to multichannel, the new grayscale information is 
based on the color values of the pixels in each channel. 

• Converting a CMYK image to multichannel creates cyan, magenta, yellow, and black 
spot channels.
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• Converting an RGB image to multichannel creates cyan, magenta, and yellow spot 
channels.

• Deleting a channel from an RGB, CMYK, or Lab image automatically converts the image 
to Multichannel mode. (See “About color channels” on page 155 for more information 
on channels.) 

• To export a multichannel image, save it in Photoshop DCS 2.0 format.

Adjusting the monitor display
Although the RGB color model used by computer monitors is capable of displaying much 
of the visible spectrum, the video system sending data to a given monitor often limits how 
many colors can be displayed at once. By understanding how color data is measured in 
digital files and on-screen, you can better adjust color display settings to offset the limita-
tions of your video system. For critical work, your monitor should be calibrated and 
characterized for use in a color management system. At the very least, your monitor 
should be calibrated to display colors as accurately as possible. For more information on 
calibrating your monitor and creating a display profile, see “Calibrating and creating a 
profile of your monitor” on page 119.

Specifying 8-bit color display (Photoshop)
Most monitors are capable of displaying 24-bit color (8 bits per channel), which is capable 
of displaying millions of colors. To achieve the best results, avoid using 8-bit display mode 
(256 colors) when editing color images.

When you work with a display system that supports only 8-bit color, Adobe Photoshop 
uses a technique called dithering to mix pixels of available colors and thus simulate colors 
not currently available.

By default, Adobe Photoshop uses pattern dithering, which can result in a distinctive 
pattern of darker or lighter areas in the image. In contrast, diffusion dithering eliminates 
this distinctive patterning by using the surrounding pixels in the mix of pixel color. But 
diffusion dithering can cause visual inconsistencies when only part of a screen is redrawn 
as you scroll, edit, or paint. Keep in mind that dithering effects only appear on-screen, not 
in print. 

To select a color display option:

1 Do one of the following:

• In Windows, choose Edit > Preferences > Display & Cursors.

• In Mac OS, choose Photoshop > Preferences > Display & Cursors.

2 Select Use Diffusion Dither to minimize dither patterns produced by dithering.

Making previews display more quickly (Photoshop)
The Use Pixel Doubling preference option speeds up the preview of a tool or command’s 
effects by temporarily doubling the size of the pixels (halving the resolution) in the 
preview. This option has no effect on the pixels in the file; it simply provides faster 
previews with the tools and commands.
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To speed up previews:

1 Do one of the following:

• In Windows, choose Edit > Preferences > Display & Cursors.

• In Mac OS, choose Photoshop > Preferences > Display & Cursors.

2 Select Use Pixel Doubling, and click OK.

Adjusting color display for cross-platform variations
RGB color display on a computer monitor varies with the operating system used by the 
computer. For example, an image appears darker on a Windows system than on a Mac OS 
computer (because the standard RGB color space is darker in Windows than in Mac OS). 
The Preview commands in ImageReady enable you to compensate for cross-platform 
differences in RGB color display during image preview. In Photoshop, you can simulate 
cross-platform differences by using the Macintosh RGB, Windows RGB, and Monitor RGB 
commands in the View > Proof Setup menu. (See “Soft-proofing colors” on page 140.)

RGB color display can also vary between Photoshop and ImageReady. In Photoshop, 
you can select from several RGB color spaces when editing images. As a result, images 
created in Photoshop may use an RGB color space that differs from the monitor RGB color 
space used by ImageReady. You can adjust the RGB color display during image preview to 
compensate for differences between Photoshop and ImageReady.

To adjust RGB color display for cross-platform variations (ImageReady):

Choose View > Preview and choose an option for adjusting the color display:

• Uncompensated Color to view the image with the monitor gamma uncorrected 

• Standard Macintosh Color to view the image with a gamma value of 1.8

• Standard Windows Color to view the image with a gamma value of 2.2

• Use Embedded Color Profile to view the image using the embedded profile

These options adjust color display only. No changes are made to pixels in the image. 

You can edit your image in one window and view the same image with a different 
gamma value in a second window. Choose Window > Arrange > New Window for 

[file name]. With the new window active, choose View > Preview and then choose a 
different gamma than the one used in the first window.

To adjust RGB color display to match Photoshop color display (ImageReady):

Choose View > Preview > Use Embedded Color Profile.

Note: In order to use the Use Embedded Color Profile command in ImageReady, you must 
save the original image, with the color profile embedded, in Photoshop. Keep in mind that 
ImageReady does not use profiles in PNG or TIFF files.
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Channels and bit depth (Photoshop)
A working knowledge of color channels and bit depth is key to understanding how 
Photoshop stores and displays color information in images.

About color channels
Every Photoshop image has one or more channels, each storing information about color 
elements in the image. The number of default color channels in an image depends on its 
color mode. For example, a CMYK image has at least four channels, one each for cyan, 
magenta, yellow, and black information. Think of a channel as analogous to a plate in the 
printing process, with a separate plate applying each layer of color. 

In addition to these default color channels, extra channels, called alpha channels, can be 
added to an image for storing and editing selections as masks, and spot color channels 
can be added to add spot color plates for printing. (See “Storing masks in alpha channels” 
on page 254 and “Adding spot colors (Photoshop)” on page 362.)

An image can have up to 56 channels. By default, Bitmap-mode, grayscale, duotone, and 
indexed-color images have one channel; RGB and Lab images have three; and CMYK 
images have four. You can add channels to all image types except Bitmap-mode images. 

About bit depth
Bit depth—also called pixel depth or color depth—measures how much color information 
is available to display or print each pixel in an image. Greater bit depth (more bits of infor-
mation per pixel) means more available colors and more accurate color representation in 
the digital image. For example, a pixel with a bit depth of 1 has two possible values: black 
and white. A pixel with a bit depth of 8 has 28, or 256, possible values. And a pixel with a bit 
depth of 24 has 224, or roughly 16 million, possible values. Common values for bit depth 
range from 1 to 64 bits per pixel.

Pixel depth 
A. 1-bit (Bitmap B. 8-bit (Grayscale) C. 8-bit (Indexed Color) D. 24-bit (RGB)

A B

C D
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In most cases, Lab, RGB, grayscale, and CMYK images contain 8 bits of data per color 
channel. This translates to a 24-bit Lab bit depth (8 bits x 3 channels), a 24-bit RGB bit 
depth (8 bits x 3 channels), an 8-bit grayscale bit depth (8 bits x 1 channel), and a 32-bit 
CMYK bit depth (8 bits x 4 channels). Photoshop can also work with Lab, RGB, CMYK, multi-
channel, and grayscale images that contain 16 bits of data per color channel.

Converting between bit depths
A 16-bit-per-channel image provides finer distinctions in color, but it can have twice the 
file size of an 8-bit-per-channel image. Photoshop CS provides more support for working 
with 16-bit-per-channel images: 

• All tools in the toolbox, except the Art History Brush tool, can be used with 16-bit-per-
channel images.

• All color and tonal adjustment commands, except Variations, are available, and a limited 
set of filters. (See “Using filters” on page 415.)

• You can work with layers, including adjustment layers, in 16-bit-per-channel images.

To take advantage of certain Photoshop features, such as Extract, Liquify, Pattern Maker, 
and some filters, you can convert a 16-bit-per-channel image to an 8-bit-per-channel 
image. It’s best if you do a Save As and convert a copy of the image file so the original file 
retains the full 16-bit-per-channel image data.

To convert between 8 bits per channel and 16 bits per channel:

Choose Image > Mode > 16 Bits/Channel or 8 Bits/Channel.

Converting between color modes (Photoshop)
Photoshop lets you change an image from its original mode (source mode) to a different 
mode (target mode). When you choose a different color mode for an image, you perma-
nently change the color values in the image. For example, when you convert an RGB 
image to CMYK mode, RGB color values outside the CMYK gamut (defined by the CMYK 
working space setting in the Color Settings dialog box) are adjusted to fall within gamut. 
As a result, some image data may be lost and will not be recovered if you were to convert 
the image from CMYK back to RGB.

Converting an image to another mode
Before converting images, it’s best to do the following:

• Do as much editing as possible in the image’s original mode (usually RGB from most 
scanners or digital cameras, or CMYK from traditional drum scanners or if imported 
from a Scitex system). 

• Save a backup copy before converting. Be sure to save a copy of your image that 
includes all layers in order to edit the original version of the image after the conversion.

• Flatten the file before converting it. The interaction of colors between layer blending 
modes will change when the mode changes.
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To convert an image to another mode:

Choose Image > Mode and the mode you want from the submenu. Modes not available 
for the active image appear dimmed in the menu.

Images are flattened when converted to Multichannel, Bitmap, or Indexed Color mode, 
because these modes do not support layers.

Making a conditional mode change
Photoshop lets you specify conditions for a mode change so the conversion can be 
successfully used in an action, which is a series of commands that you play back on a 
single file or a batch of files. When a mode change is part of an action, an error can occur if 
the file being opened is not in the same source mode specified in the action. For example, 
one step in an action can be to convert an image with a source mode of RGB to a target 
mode of CMYK. Applying this action to an image in Grayscale mode, or any other source 
mode besides RGB, will cause an error. 

While recording an action, the Conditional Mode Change command lets you specify one 
or more modes for the source mode and a mode for the target mode. For more infor-
mation on creating actions, see “Recording actions” on page 628.

To add a conditional mode change to an action:

1 Start recording an action.

2 Choose File > Automate > Conditional Mode Change.

3 In the Conditional Mode Change dialog box, select one or more modes for the source 
mode. You can also use the All or None buttons to select all possible modes or no mode.

4 Choose a target mode from the Mode pop-up menu.

5 Click OK. The conditional mode change will appear as a new step in the Actions palette.

Converting images to Bitmap mode (Photoshop)
Converting an image to Bitmap mode reduces the image to two colors, greatly simplifying 
the color information in the image and reducing its file size.

Converting a color or grayscale image to Bitmap mode
To convert a color image to Bitmap mode, first convert it to Grayscale mode. This removes 
the hue and saturation information from the pixels and leaves just the brightness values. 
However, because few editing options are available for Bitmap-mode images, it’s usually 
best to edit the image in Grayscale mode and then convert it to Bitmap mode. 

Note: Images in Bitmap mode are 1 bit per channel. A 16-bit-per-channel image must be 
converted to Grayscale 8 bits before converting to Bitmap mode.

To convert an image to Bitmap mode:

1 Do one of the following:

• If the image is in color, choose Image > Mode > Grayscale. Then choose Image > Mode > 
Bitmap.

• If the image is grayscale, choose Image > Mode > Bitmap.
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2 For Output, enter a value for the output resolution of the Bitmap-mode image, and 
choose a unit of measurement. By default, the current image resolution appears as both 
the input and the output resolutions.

3 Choose one of the following bitmap conversion methods from the Use pop-up menu:

• 50% Threshold converts pixels with gray values above the middle gray level (128) to 
white and below it to black. The result is a very high-contrast, black-and-white repre-
sentation of the image.

• Pattern Dither converts an image by organizing the gray levels into geometric configu-
rations of black and white dots.

• Diffusion Dither converts an image by using an error-diffusion process, starting at the 
pixel in the upper left corner of the image. If the pixel’s value is above middle gray (128), 
the pixel is changed to white—if below it, to black. Because the original pixel is rarely 
pure white or pure black, error is inevitably introduced. This error is transferred to 
surrounding pixels and diffused throughout the image, resulting in a grainy, filmlike 
texture. This option is useful for viewing images on a black-and-white screen.

• Halftone Screen simulates the appearance of halftone dots in the converted image. 
(See “Specifying halftone screens for Bitmap-mode images” on page 159.)

• Custom Pattern simulates the appearance of a custom halftone screen in the converted 
image. (See “Specifying custom halftone screens for Bitmap-mode images” on 
page 160.)

Original grayscale image, and 50% Threshold conversion method

Pattern Dither conversion method, and Diffusion Dither conversion method

Converting an image from Bitmap mode to Grayscale mode
You can convert a Bitmap-mode image to Grayscale mode so you can edit it. Keep in mind 
that a Bitmap-mode image edited in Grayscale mode may not look the same when 
converted back to Bitmap mode. For example, a pixel that is black in Bitmap mode and 
then edited to a shade of gray in Grayscale mode may have a gray value that is light 
enough that it will become white when converted back to Bitmap mode.



Using Help | Contents | Index Back 159  

Adobe Photoshop CS Help Working with Color 

Using Help | Contents | Index Back 159  

To convert a Bitmap-mode image to grayscale:

1 Choose Image > Mode > Grayscale.

2 Enter a value between 1 and 16 for the size ratio.

The size ratio is the factor for scaling down the image. For example, to reduce a grayscale 
image by 50%, enter 2 for the size ratio. If you enter a number greater than 1, the program 
averages multiple pixels in the Bitmap-mode image to produce a single pixel in the 
grayscale image. This process lets you generate multiple shades of gray from an image 
scanned on a 1-bit scanner. 

Specifying halftone screens for Bitmap-mode images
The Halftone Screen option in the Bitmap dialog box lets you convert a grayscale image to 
simulated halftone dots.

Important: The halftone screen becomes part of the image. If you print the image on a 
halftone printer, it will print with the halftone screen you choose here plus that of the 
printer. On some printers, the result probably will be a moiré pattern in the image.

To specify the halftone screen for a Bitmap-mode image: 

1 Choose Image > Mode > Bitmap.

2 Choose Halftone Screen from the Use menu; then click OK. The Halftone Screen dialog 
box opens.

3 For Frequency, enter a value for the screen frequency, and choose a unit of 
measurement. Values can range from 1 to 999 for lines per inch and from 0.400 to 400 for 
lines per centimeter. You can enter decimal values. 

The screen frequency specifies the ruling of the halftone screen in lines per inch (lpi). The 
frequency depends on the paper stock and type of press used for printing. Newspapers 
commonly use an 85-line screen. Magazines use higher resolution screens, such as 133 lpi 
and 150 lpi. Check with your print shop for correct screen frequencies.

4 Enter a value for the screen angle in degrees from –180 to +180. 

The screen angle refers to the orientation of the screen. Continuous-tone and black-and-
white halftone screens commonly use a 45° angle. 

5 For Shape, choose the dot shape you want.

Original grayscale image, and Halftone Screen conversion: 53 lpi, 45° angle, round dot

You can save and reuse halftone screen settings by using the Save and Load buttons in the 
Halftone Screen dialog box.
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Specifying custom halftone screens for Bitmap-mode images
The Custom Pattern option in the Bitmap dialog box simulates the effect of printing a 
grayscale image through a custom halftone screen. This method lets you apply a screen 
texture, such as a wood grain, to an image. To use this option, you must first define a 
pattern. (See “Filling and stroking selections and layers” on page 344.)

You can create a pattern representing the texture you want and then screen the grayscale 
image to apply the texture. To cover the entire image, the pattern must be as large as the 
image. Otherwise, the pattern will be tiled. For example, if you apply a 1-inch-by-1-inch 
pattern to a 4-inch-by-4-inch image, the pattern appears as 16 squares. Photoshop comes 
with several self-tiling patterns that can be used as halftone screen patterns. (See the 
procedure to use a pattern from the PostScript Patterns folder in “Filling and stroking 
selections and layers” on page 344.)

Because the Custom Pattern option simulates dark and light colors by making the halftone 
pattern thicker and thinner, it makes sense to choose a pattern that lends itself to 
thickness variations, typically one with a variety of gray shades. 

To prepare a black-and-white pattern for conversion, you can first convert the image 
to grayscale and then apply the Blur More filter several times. This blurring technique 

creates thick lines tapering from dark gray to white.

Converting to indexed color (Photoshop)
Converting to indexed color reduces the number of colors in the image to at most 256—
the standard number of colors supported by the GIF and PNG-8 formats and many multi-
media applications. This conversion reduces file size by deleting color information from 
the image.

To convert to indexed color, you must start with an image that is 8 bits per channel and 
either grayscale or RGB.

To convert a grayscale or RGB image to indexed color:

1 Choose Image > Mode > Indexed Color.

Note: All visible layers will be flattened; any hidden layers will be discarded.

For grayscale images, the conversion happens automatically. For RGB images, the Indexed 
Color dialog box appears.

2 Select Preview in the Indexed Color dialog box to display a preview of the changes.

3 Specify conversion options. (See “Conversion options for indexed-color images 
(Photoshop)” on page 160.)

Conversion options for indexed-color images (Photoshop)
When converting an RGB image to indexed color, you can specify a number of conversion 
options in the Indexed Color dialog box.

Palette type
A number of palette types are available for converting an image to indexed color. For the 
Perceptual, Selective, and Adaptive options, you can choose between using a local palette 
based on the current image’s colors or a master palette created in ImageReady. 
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Exact Creates a palette using the exact colors appearing in the RGB image—an option 
available only if the image uses 256 or fewer colors. Because the image’s palette contains 
all colors in the image, there is no dithering. 

System (Mac OS) Uses the Mac OS default 8-bit palette, which is based on a uniform 
sampling of RGB colors. 

System (Windows) Uses the Windows system’s default 8-bit palette, which is based on a 
uniform sampling of RGB colors. 

Web Uses the 216-color palette that Web browsers, regardless of platform, use to display 
images on a monitor limited to 256 colors. This palette is a subset of the Mac OS 8-bit 
palette. Use this option to avoid browser dither when viewing images on a monitor 
display limited to 256 colors.

Uniform Creates a palette by uniformly sampling colors from the RGB color cube. For 
example, if Photoshop takes 6 evenly spaced color levels each of red, green, and blue, the 
combination produces a uniform palette of 216 colors (6 cubed = 6 x 6 x 6 = 216). The total 
number of colors displayed in an image corresponds to the nearest perfect cube (8, 27, 64, 
125, or 216) that is less than the value in the Colors text box.

Local (Perceptual) Creates a custom palette by giving priority to colors for which the 
human eye has greater sensitivity.

Local (Selective) Creates a color table similar to the Perceptual color table, but favoring 
broad areas of color and the preservation of Web colors. This option usually produces 
images with the greatest color integrity.

Local (Adaptive) Creates a palette by sampling the colors from the spectrum appearing 
most commonly in the image. For example, an RGB image with only the colors green and 
blue produces a palette made primarily of greens and blues. Most images concentrate 
colors in particular areas of the spectrum. To control a palette more precisely, first select a 
part of the image containing the colors you want to emphasize. Photoshop weights the 
conversion toward these colors.

Custom Creates a custom palette using the Color Table dialog box. Either edit the color 
table and save it for later use or click Load to load a previously created color table. (See 
“Customizing indexed color tables (Photoshop)” on page 163.) This option also displays 
the current adaptive palette, which is useful for previewing the colors most often used in 
the image.

Previous Uses the custom palette from the previous conversion, making it easy to 
convert several images with the same custom palette.

Number of colors
For the Uniform, Perceptual, Selective, or Adaptive palette, you can specify the exact 
number of colors to be displayed (up to 256) by entering a value for Colors. The Colors text 
box controls only how the indexed color table is created. Adobe Photoshop still treats the 
image as an 8-bit, 256-color image.
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Color inclusion and transparency
To specify colors to be included in the indexed color table or to specify transparency in the 
image, choose from the following options:

Forced Provides options to force the inclusion of certain colors in the color table. Black 
and White adds a pure black and a pure white to the color table; Primaries adds red, green, 
blue, cyan, magenta, yellow, black, and white; Web adds the 216 Web-safe colors; and 
Custom lets you define custom colors to add.

Transparency Specifies whether to preserve transparent areas of the image during 
conversion. Selecting this option adds a special index entry in the color table for trans-
parent colors. Deselecting this option fills transparent areas with the matte color, or with 
white if no matte color is chosen.

Matte Specifies the background color used to fill anti-aliased edges that lie adjacent to 
transparent areas of the image. With Transparency selected, the matte is applied to edge 
areas to help blend the edges with a Web background of the same color. With Trans-
parency deselected, the matte is applied to transparent areas. Choosing None for the 
matte creates hard-edged transparency if Transparency is selected; otherwise, all trans-
parent areas are filled with 100% white. The image must have transparency for the Matte 
options to be available.

Dithering
Unless you’re using the Exact color table option, the color table may not contain all the 
colors used in the image. To simulate colors not in the color table, you can dither the 
colors. Dithering mixes the pixels of the available colors to simulate the missing colors. 

Choose a dither option from the menu, and enter a value for the dither amount. A higher 
amount dithers more colors but may increase file size. You can choose from the following 
dither options:

None Does not dither colors but instead uses the color closest to the missing color. 
This tends to result in sharp transitions between shades of color in the image, creating a 
posterized effect.

Diffusion Uses an error-diffusion method that produces a less structured dither than the 
Pattern option. To protect colors in the image that contain entries in the color table from 
being dithered, select Preserve Exact Colors. This is useful for preserving fine lines and text 
for Web images. 

Pattern Uses a halftone-like square pattern to simulate any colors not in the color table.

Noise Helps to reduce seam patterns along the edges of image slices. Choose this option 
if you plan to slice the image for placement in an HTML table.
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Customizing indexed color tables (Photoshop)
The Color Table command lets you make changes to the color table of an indexed-color 
image. These customization features are particularly useful with pseudocolor images—
images displaying variations in gray levels with color rather than shades of gray, often 
used in scientific and medical applications. However, customizing the color table can also 
produce special effects with indexed-color images that have a limited number of colors.

Note: To shift colors simply in a pseudocolor image, choose Image > Adjustments, and use 
the color adjustment commands in the submenu. For a summary description of these 
commands, see “Basic steps for correcting images” on page 174.

Using the color table to edit colors and assign transparency
You can edit colors in the color table to produce special effects, or assign transparency in 
the image to a single color in the table.

To edit colors in the color table:

1 Open the indexed-color image.

2 Choose Image > Mode > Indexed Color.

3 In the Indexed Color dialog box, choose Custom from the Palette menu. This opens the 
Color Table dialog box.

4 In the Color Table dialog box, click or drag in the table to choose the color or range of 
colors you want to change. 

5 Choose a color and click OK. For more information on choosing colors, see “Using the 
Adobe Color Picker” on page 164. 

If you are changing a range of colors, Photoshop creates a gradient in the color table 
between the starting and ending colors. The first color you choose in the Color Picker is 
the beginning color for the range. When you click OK, the Color Picker reappears so that 
you can choose the last color in the range.

The colors you selected in the Color Picker are placed in the range you selected in the 
Color Table dialog box.

6 Click OK in the Color Table dialog box to apply the new colors to the indexed-color 
image.

7 Click OK in the Indexed Color dialog box.

To assign transparency to a single color:

1 Open the indexed-color image.

2 Choose Image > Mode > Indexed Color.

3 In the Indexed Color dialog box, choose Custom from the Palette menu. This opens the 
Color Table dialog box.

4 In the Color Table dialog box, select the Eyedropper tool , and click the desired color 
in the table or in the image. The sampled color is replaced with transparency in the image.
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Using predefined color tables
Your indexed color table can be modeled after the following predefined color tables:

Custom Creates a palette you specify.

Black Body Displays a palette based on the different colors a black body radiator emits as 
it is heated—from black to red, orange, yellow, and white. 

Grayscale Displays a palette based on 256 levels of gray—from black to white. 

Spectrum Displays a palette based on the colors produced as white light passes through 
a prism—from violet, blue, and green to yellow, orange, and red. 

System (Mac OS) Displays the standard Mac OS 256-color system palette.

System (Windows) Displays the standard Windows 256-color system palette. 

To choose a predefined table:

1 Open the indexed-color image.

2 Do one of the following:

• Choose Image > Mode > Color Table.

• Choose Image > Mode > Indexed Color. In the Indexed Color dialog box, choose 
Custom from the Palette menu. This opens the Color Table dialog box.

3 In the Color Table dialog box, choose a predefined table from the Table menu.

Saving and loading color tables
You use the Save and Load buttons in the Color Table dialog box to save your indexed 
color tables for use with other Adobe Photoshop images. The color tables and swatch 
tables can also be loaded by ImageReady. Once you load a color table into an image, the 
colors in the image change to reflect the color positions they reference in the new color 
table. 

Note: You can also load saved color tables into the Swatches palette. (See the procedure to 
save and reuse custom swatch sets in “Using the Swatches palette” on page 354.)

Using the Adobe Color Picker 
The Adobe Color Picker lets you select a color by choosing from a color spectrum or by 
defining colors numerically. The Adobe Color Picker can be used for setting the 
foreground color, background color, and text color. In Photoshop, it is also used for setting 
target colors in some color and tonal adjustment commands, the stop colors in the 
Gradient Editor, the filter color in the Photo Filter command, and the color in a fill layer, 
certain layer styles, and shape layers.

When a color is selected in the Adobe Color Picker, the numeric values for HSB, RGB, 
Lab, CMYK, and hexadecimal numbers are simultaneously displayed. This is useful for 

viewing how a color is described by the different color modes.
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About the Adobe Color Picker
In the Adobe Color Picker, you can select colors based on the HSB (hue, saturation, 
brightness) or RGB (red, green, blue) color models, or specify a color based on its 
hexadecimal values. In Photoshop, you can also select colors based on the Lab color 
model, and on the CMYK (cyan, magenta, yellow, black) color model. The Adobe Color 
Picker can be set so you choose only from Web-safe colors or choose from several custom 
color systems. The color field in the Adobe Color Picker can display color components in 
HSB color mode, RGB color mode, and (Photoshop) Lab color mode. 

Note: Although Photoshop and ImageReady use the Adobe Color Picker by default, 
you can set a Preference so Photoshop and ImageReady use a different color picker. 
(See “Using other color pickers” on page 171.)

Adobe Color Picker 
A. Picked color B. Original color C. Adjusted color D. Out-of-gamut alert icon E. Not Web-safe 
alert icon F. Web Colors option G. Color field H. Color slider I. Color values

To display the Adobe Color Picker:

Do one of the following:

• In the toolbox, click the foreground or background color selection box.

• In the Color palette, click the Set Foreground Color or Set Background Color 
selection box. 

• In the text tool options bar, click the color swatch.

• (Photoshop) In the Layers palette, click the color swatch in a fill or shape layer. 

• (Photoshop) In the Gradient Editor, double-click a color stop.

• (Photoshop) In the options bar of a shape or pen too, click the color swatch l.

• (Photoshop) In the Layer Style dialog box for certain layer styles (such as Outer Glow 
and Inner Glow), click the Set Color box.

• (Photoshop) In the dialog box of certain color and tonal adjustment commands, 
double-click an eyedropper tool or click a color swatch. Not every eyedropper tool lets 
you set a target color. For instance, double-clicking the eyedropper tools in the Replace 
Color command does not open the Adobe Color Picker. For more information on each 
color and tonal adjustment tool, see “Making Color and Tonal Adjustments” on 
page 173.
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Specifying a color using the color field and color slider
With the HSB, RGB, and Lab color modes, you can use the color field and the color slider in 
the Color Picker dialog box to select a color.

To specify a color using the color field and color slider:

1 Click a component next to the HSB, RGB, or Lab values.

2 Select a color by doing one of the following:

• Drag the white triangles along the slider.

• Click in the color slider.

• Click in the color field.

When you select a color, a circular marker indicates the color’s position in the color field. 

As you adjust the color using the color field and color slider, the numerical values change 
to reflect the new color. The color rectangle to the right of the color slider displays the new 
color in the top section of the rectangle. The original color appears at the bottom of the 
rectangle. Alerts will appear if the color is not Web-safe  or is (Photoshop) out of gamut . 
For more information about the alerts in the Adobe Color Picker, see “Using Web-safe 
colors” on page 168 and “Warning alert for nonprintable colors (Photoshop)” on page 169.

A color can be selected outside the Adobe Color Picker. Moving the pointer over the 
document window changes it to the Eyedropper tool. You can then select a color by 

clicking in the image. The selected color will be displayed in the Adobe Color Picker. 
Clicking in the image and then holding down the mouse button lets you move the 
Eyedropper tool anywhere on your desktop. You can select a color by releasing the mouse 
button.

Specifying a color using numeric values
In the Adobe Color Picker, you can select a color in any of the four color models by speci-
fying numeric values for each color component. 

To specify a color using numeric values:

Do one of the following:

• (Photoshop) In CMYK color mode (the mode PostScript printers use), specify each 
component value as a percentage of cyan, magenta, yellow, and black. 

• In RGB color mode (the mode your monitor uses), specify component values from 0 to 
255 (0 is black, and 255 is the pure color). 

• In HSB color mode, specify saturation and brightness as percentages; specify hue as an 
angle from 0° to 360° that corresponds to a location on the color wheel. For more infor-
mation on the color wheel, see “Using the color wheel” on page 172.

• Enter a hexadecimal value in the # text box. For example, 000000 is black, ffffff is white, 
and ff0000 is red. For more information on describing a color using hexadecimal values, 
see “Working with hexadecimal values for color” on page 556.

• (Photoshop) In Lab mode, enter a lightness value (L) from 0 to 100 and A (green to 
magenta) and B (blue to yellow) values from –128 to +127. 
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Working with the Adobe Color Picker in HSB mode
The Adobe Color Picker lets you select a color based on the HSB (hue, saturation, 
brightness) color model. When you select a color in HSB mode, the RGB, Lab, CMYK, and 
hexadecimal values update accordingly. The HSB mode is the default mode for the Adobe 
Color Picker.

To work with the Adobe Color Picker in HSB mode:

1 Open the Adobe Color Picker.

2 In the HSB section of the dialog box, do one of the following:

• Click the H option to display all hues in the color slider. Selecting a hue in the color 
slider displays the saturation and brightness range of the selected hue in the color field, 
with the saturation increasing from left to right and brightness increasing from bottom 
to top.

• Click the S option to display all hues in the color field with their maximum brightness at 
the top of the color field, decreasing to their minimum at the bottom. The color slider 
displays the color that’s selected in the color field with its maximum saturation at the 
top of the slider and its minimum saturation at the bottom.

• Click the B option to display all hues in the color field with their maximum saturation at 
the top of the color field, decreasing to their minimum saturation at the bottom. The 
color slider displays the color that’s selected in the color field with its maximum 
brightness at the top of the slider and its minimum brightness at the bottom.

3 Select a color with a specific hue, saturation, and brightness by using a combination of 
the color slider and the color field or entering a numeric values in the H, S, and B text 
boxes.

Working with the Adobe Color Picker in RGB mode
In RGB (red, green, blue) mode, the color slider displays the range of color levels available 
for the selected color component (R, G, or B). The color field displays the range for the 
remaining two components—one on the horizontal axis, one on the vertical. For example, 
if you click the red component (R), the color slider displays the range of color for red (0 is at 
the bottom of the slider and 255 is at the top). The color field displays the values for blue 
on its horizontal axis and for green on its vertical axis. 

To work with the Adobe Color Picker in RGB mode:

1 Open the Adobe Color Picker.

2 In the RGB section of the dialog box, do one of the following:

• Click the R option to display the red color component in the color slider with its 
maximum brightness (255) at the top of the slider and its minimum brightness (0) at 
the bottom. When the color slider is set to minimum brightness, the color field displays 
colors created by the green and blue color components. Using the color slider to 
increase the red brightness mixes more red into the colors displayed in the color field.

• Click the G option to display the green color component in the color slider with its 
maximum brightness (255) at the top of the slider and its minimum brightness (0) at 
the bottom. When the color slider is set to minimum brightness, the color field displays 
colors created by the red and blue color components. Using the color slider to increase 
the green brightness mixes more green into the colors displayed in the color field.
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• Click the B option to display the blue color component in the color slider with its 
maximum brightness (255) at the top of the slider and its minimum brightness (0) at 
the bottom. When the color slider is set to minimum brightness, the color field displays 
colors created by the green and red color components. Using the color slider to 
increase the blue brightness mixes more blue into the colors displayed in the color 
field.

3 Select an RGB color using a combination of the color slider and the color field or 
entering numeric values in the R, G, and B text boxes.

Working with the Adobe Color Picker in Lab mode (Photoshop)
The Adobe Color Picker lets you select a color based on the Lab color model. The L value 
specifies the luminance of a color. The a value specifies how red or green a color is. The b 
value specifies how blue or yellow a color is.

To work with the Adobe Color Picker in Lab mode:

1 Open the Adobe Color Picker.

2 In the Lab section of the dialog box, do one of the following:

• Click the L option to display all hues in the color field. A hue is selected by either clicking 
in the color field or entering values in the A and B text boxes. The color slider displays 
the selected hue with its maximum luminance at the top and its minimum luminance 
at the bottom. 

• Click the A option and the color slider adjusts whether a hue is red or green. Moving the 
slider or clicking in the color slider changes the range of colors displayed in the color 
field. The color field also displays the colors’ luminance with maximum luminance at the 
top decreasing to minimum luminance at the bottom. The B (blue or yellow) color 
component is represented in the color field with blue on the left and yellow on the 
right.

• Click the B option and the color slider adjusts whether a hue is yellow or blue. Moving 
the slider or clicking in the color slider changes the range of colors displayed in the 
color field. The color field also displays the colors’ luminance on the vertical axis with 
maximum luminance at the top. The A (green or red) color component is represented in 
the color field with green on the left and red on the right. 

3 Select a color using a combination of the color slider and the color field or entering 
numeric values in the L, A, and B text boxes.

Using Web-safe colors
The Web-safe colors are the 216 colors used by browsers regardless of the platform. The 
browser will change all colors in the image to these colors when displaying the color on an 
8-bit screen. The 216 colors are a subset of the Mac OS 8-bit color palettes. By working only 
with these colors, you can be sure that art you prepare for the Web will not dither on a 
system set to display in 256 colors.

To identify Web-safe colors in the Adobe Color Picker:

Select the Only Web Colors option in the lower left corner of the color picker, and then 
choose any color in the color picker. Any color you pick with this option selected is 
Web-safe.
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To change a non-Web color to a Web-safe color:

If you select a non-Web color, an alert cube  appears next to the color rectangle in the 
Adobe Color Picker. Click the alert cube to select the closest Web color. (If no alert cube 
appears, the color you chose is Web-safe.)

To select a Web-safe color using the Color palette:

1 Click the Color palette tab, or choose Window > Color to view the Color palette.

2 Choose an option for selecting a Web-safe color:

• Choose Make Ramp Web Safe from the Color palette menu. With this option selected, 
any color you choose in the Color palette is Web-safe.

• Choose Web Color Sliders from the Color palette menu (Photoshop), or choose any 
Slider option from the Color palette menu (ImageReady). By default, Web Color Sliders 
snap to Web-safe colors (indicated by tick marks) when you drag them. (To override 
Web-safe color selection, Alt-drag (Windows) or Option-drag (Mac OS) the sliders.) 

If you choose a non-Web color, an alert cube  appears above the color ramp on the left 
side of the Color palette. Click the alert cube to select the closest Web color. 

In ImageReady, drag around the alert icon to select other close Web colors. (If no alert 
cube appears, the color you chose is Web-safe.)

Note: In Photoshop, you must choose Web Color Sliders from the Color palette menu to 
view the Web-safe alert cube. In ImageReady, you can view the alert cube with any color 
slider option.

Warning alert for nonprintable colors (Photoshop)
Some colors in the RGB, HSB, and Lab color models, such as neon colors, cannot be printed 
because they have no equivalents in the CMYK model. When you select a nonprintable 
color, an alert triangle appears in the Color Picker dialog box and in the Color palette. The 
closest CMYK equivalent is displayed below the triangle. (See “Identifying out-of-gamut 
colors (Photoshop)” on page 184.)

Note: The alert triangle is not available if you’ve chosen to use Web-safe sliders.

Printable colors are determined by your current CMYK working space as defined in the 
Color Settings dialog box.

To select the closest CMYK equivalent for a nonprintable color:

Click the alert triangle  that appears in the Color Picker dialog box or the Color palette.

Choosing custom colors (Photoshop)
The Adobe Color Picker lets you choose custom colors from the PANTONE® MATCHING 
SYSTEM®, the TRUMATCH® SWATCHING SYSTEM™, the FOCOLTONE® COLOUR SYSTEM, the 
TOYO Color Finder™ 1050 system, the ANPA-COLOR™ system, the HKS® color system, and the 
DIC Color Guide. 
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To ensure that the final printed output is the color you want, consult your printer or 
service bureau and choose your custom color based on a printed color swatch. Manufac-
turers recommend that you get a new swatch book each year to compensate for fading 
inks and other damage. 

Important: Photoshop prints custom colors to CMYK (process color) plates in every 
image mode except Duotone. To print true spot color plates, create spot color channels. 
(See “Adding spot colors (Photoshop)” on page 362.)

To choose a custom color:

1 Open the Adobe Color Picker, and click Custom.

The Custom Colors dialog box displays the color closest to the color currently selected in 
the Adobe Color Picker.

2 For Book, choose a color system. (See “Choosing a custom color system (Photoshop)” 
on page 170.)

3 Locate the color you want by entering the ink number or by dragging the triangles 
along the scroll bar.

4 Click the desired color patch in the list.

Choosing a custom color system (Photoshop)
The Adobe Color Picker supports various color systems:

ANPA-COLOR Commonly used for newspaper applications. The ANPA-COLOR ROP 
Newspaper Color Ink Book contains samples of the ANPA colors.

DIC Color Guide Commonly used for printing projects in Japan. For more information, 
contact Dainippon Ink & Chemicals, Inc. in Tokyo, Japan.

FOCOLTONE Consists of 763 CMYK colors. FOCOLTONE colors help avoid prepress 
trapping and registration problems by showing the overprints that make up the colors. 
A swatch book with specifications for process and spot colors, overprint charts, and a chip 
book for marking up layouts are available from FOCOLTONE. For more information, 
contact Focoltone International, Ltd., in Stafford, United Kingdom.

HKS swatches Used for printing projects in Europe. Each color has a specified CMYK 
equivalent. You can select from HKS E (for continuous stationery), HKS K (for gloss art 
paper), HKS N (for natural paper), and HKS Z (for newsprint). Color samplers for each scale 
are available. HKS Process books and swatches have been added to the color system 
menu.

PANTONE® Colors are the worldwide standards for spot color reproduction. In 2000, a 
major revision was made to the PANTONE MATCHING SYSTEM® Color guides. 147 new 
solid colors and seven additional metallic colors were added to the System to include a 
total of 1,114 colors. PANTONE® Color guides and chip books are now printed on coated, 
uncoated, and matte paper stocks to ensure accurate visualization of the printed result 
and better on-press control. You can print a solid PANTONE® Color in CMYK. To compare a 
solid PANTONE® Color to its closest process color match, use the PANTONE® solid to 
process guide. The CMYK screen tint percentages are printed under each color. The guide 
is now printed on a brighter coated stock and includes comparisons of the 147 new solid 
colors to CMYK. For more information, contact Pantone, Inc. in Carlstadt, NJ 
(www.pantone.com).

http://www.pantone.com
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TOYO Color Finder 1050 Consists of more than 1000 colors based on the most common 
printing inks used in Japan. The TOYO Process Color Finder book and swatches have been 
added to the color system menu. The TOYO Color Finder 1050 Book contains printed 
samples of Toyo colors and is available from printers and graphic arts supply stores. 
For more information, contact Toyo Ink Manufacturing Co., Ltd. in Tokyo, Japan.

TRUMATCH Provides predictable CMYK color matching with more than 2000 achievable, 
computer-generated colors. TRUMATCH colors cover the visible spectrum of the CMYK 
gamut in even steps. The TRUMATCH COLORFINDER displays up to 40 tints and shades of 
each hue, each originally created in four-color process and each reproducible in four 
colors on electronic imagesetters. In addition, four-color grays using different hues are 
included. For more information, contact Trumatch Inc., in New York City, New York, U.S.A.

Using other color pickers
In addition to the default Adobe Color Picker, you can use the built-in color pickers on your 
system or a plug-in color picker to select colors. Any plug-in color pickers you install 
appear under Color Picker in the General section of the Preferences dialog box. For infor-
mation on installing and using a plug-in color picker, see the documentation that came 
with the plug-in.

To use the Windows Color Picker (Windows): 

1 Choose Edit > Preferences > General. 

2 Choose Windows from the Color Picker menu, and click OK.

For more information, see your Windows documentation.

To use the Apple Color Picker (Mac OS): 

1 Do one of the following:

• (Photoshop) Choose Photoshop > Preferences > General.

• (ImageReady) Choose ImageReady > Preferences > General.

2 For Color Picker, do one of the following:

• (Photoshop) Choose Apple and click OK.

• (ImageReady) Choose System, and click OK.

For more information, see your Mac OS documentation.

To return to the Adobe Color Picker after using another color picker:

1 Do one of the following:

• In Windows, choose Edit > Preferences > General.

• (Photoshop) In Mac OS, choose Photoshop > Preferences > General.

• (ImageReady) In Mac OS, choose ImageReady > Preferences > General.

2 Choose Adobe from the Color Picker menu, and click OK.
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Using the color wheel
When working with color, there are numerous ways to achieve similar results in color 
balance. It’s useful to consider the type of image you have and the effect you want to 
produce. If you’re new to adjusting color components, it helps to keep a diagram of the 
standard color wheel on hand. You can use the color wheel to predict how a change in one 
color component affects other colors and also how changes translate between RGB and 
CMYK color models. 

Color wheel 
R. Red Y. Yellow G. Green C. Cyan B. Blue M. Magenta

For example, you can decrease the amount of any color in an image by increasing the 
amount of its opposite on the color wheel—and vice versa. Colors that lie opposite each 
other on the standard color wheel are known as complementary colors. Similarly, you can 
increase and decrease a color by adjusting the two adjacent colors on the wheel, or even 
by adjusting the two colors adjacent to its opposite.

In a CMYK image, you can decrease magenta either by decreasing the amount of magenta 
or by increasing its complement (by adding cyan and yellow). You can even combine these 
two corrections, minimizing their effect on overall lightness. In an RGB image, you can 
decrease magenta by removing red and blue or by adding green. All of these adjustments 
result in an overall color balance containing less magenta.
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Making Color and Tonal 
Adjustments

Before making color and tonal adjustments
The powerful tools in Photoshop and ImageReady can enhance, repair, and correct the 
color and tonality (lightness, darkness, and contrast) in an image. Here are some items to 
consider before making color and tonal adjustments.

• Work with a monitor that’s calibrated and profiled. For critical image editing, this is 
absolutely essential. Otherwise, the image you see on your monitor will look different 
when printed. For more information on keeping color consistent throughout your 
workflow, see “An introduction to color management” on page 108.

• Whenever you make a color or tonal adjustment to an image, some image information 
is discarded. It’s best to be judicious regarding the amount of correction you apply to 
an image.

• (Photoshop) For critical work and maximum preservation of image data, it’s best if the 
image you work with is 16 bits per channel (16-bit image) rather than 8 bits per channel 
(8-bit image). As you make tonal and color adjustments and image data is discarded, 
the loss of image information is more critical in an 8-bit image than a 16-bit image. 
Photoshop CS has improved support for 16-bit images. Generally, 16-bit images have a 
larger file size than 8-bit images.

Note: If you jump back and forth between Photoshop and ImageReady, be aware that 
ImageReady converts 16-bit images to 8-bit for editing. Once the files are saved in 
ImageReady, they are permanently converted to 8-bit, and the discarded data is unrecov-
erable. However, if you are editing a 16-bit image in ImageReady and haven't saved it yet, 
you can return to Photoshop and the image will open as 16-bit without data loss.

• Duplicate or make a copy of the image file. Working on a copy of your image preserves 
the original in the event you need to use the image in its original state. (See “Dupli-
cating images” on page 39.)

• Remove any flaws such as dust spots, blemishes, and scratches from the image before 
making color and tonal adjustments. For more information on retouching an image, 
see “Retouching and repairing images” on page 270.

• (Photoshop) Plan to use adjustment layers to adjust the tonal range and color balance 
of your image rather than applying an adjustment directly to the image layer itself. 
Adjustment layers let you go back and make successive tonal adjustments without 
discarding data from the image layer. Keep in mind that using adjustment layers adds 
to the file size of the image and demands more RAM from your computer. For more 
information on using adjustment layers, see “Using adjustment layers and fill layers 
(Photoshop)” on page 402.
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• (Photoshop) Open the Info or Histogram palette in Expanded view. As you evaluate 
and correct the image, both palettes display invaluable feedback on your adjustments. 
For more information on using the Info palette, see “Viewing the color values of pixels 
(Photoshop)” on page 181 and for more information on the Histogram palette, see 
“About the Histogram palette” on page 177.

• You can make a selection or use a mask to confine your color and tonal adjustments to 
part of an image. Another method to selectively apply color and tonal adjustments is to 
set up your document with image components on different layers. Color and tonal 
adjustments are applied to only one layer at a time and will affect only the image 
components on the targeted layer. 

Basic steps for correcting images
The following workflow overview is a starting point for correcting the tonality and color of 
an image. 

Note: For some images, the use of the quick adjustment commands in Photoshop and 
ImageReady might give satisfactory results. For more information on the various Auto 
commands, see “Making quick overall adjustments to an image” on page 215.

To make color and tonal adjustments:

1 (Photoshop) Use the histogram to check the quality and tonal range of the image. 
For information on using the histogram, see “Using a histogram to view the tonal range of 
an image (Photoshop)” on page 176.

2 Adjust the color balance to remove unwanted color casts or to correct oversaturated or 
undersaturated colors. 

You can choose from the following color adjustment methods:

(Photoshop) Auto Color command Quickly corrects the color balance in an image. 
Although its name implies an automatic adjustment, you can fine tune how the Auto 
Color command behaves. For more information, see “Using the Auto Color command 
(Photoshop)” on page 217.

(Photoshop) Match Color command Matches the color from one photo to another 
photo, from one layer to another layer, and from a selection in an image to another 
selection in the same image or different image. This command also adjusts the luminance 
and color range and neutralizes color casts in an image. For more information, see “Using 
the Match Color command (Photoshop)” on page 206.

(Photoshop) Color Balance command Changes the overall mixture of colors in an 
image. For more information, see “Using the Color Balance command (Photoshop)” on 
page 199.

Hue/Saturation command Adjusts the hue, saturation, and lightness values of the entire 
image or of individual color components. For more information on the Hue/Saturation 
command, see “Using the Hue/Saturation command” on page 200.
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(Photoshop) Replace Color command Replaces specified colors in an image with new 
color values. For more information on the Replace Color command, see “Using the Replace 
Color command (Photoshop)” on page 210.

(Photoshop) Selective Color command Adjusts the amount of process colors in 
individual color components. For more information on the Selective Color command, 
see “Using the Selective Color command (Photoshop)” on page 214.

(Photoshop) Channel Mixer command Modifies a color channel and makes color 
adjustments not easily done with other color adjustment tools. For more information on 
the Channel Mixer command, see “Mixing color channels (Photoshop)” on page 212.

Levels command Adjusts color balance by setting the pixel distribution for individual 
color channels. For more information on the Levels command, see “Using Levels to adjust 
color (Photoshop)” on page 188.

(Photoshop) Curves command Provides up to 14 controls points for highlight, midtone, 
and shadow adjustments for individual channels. For more information on the Curves 
command, see “Using the Curves dialog box (Photoshop)” on page 189.

Photo Filter command Makes color adjustments by simulating the effects of photo-
graphing with a Kodak Wratten filter in front of a camera lens. For more information on the 
Photo Filter command, see “Using the Photo Filter command (Photoshop)” on page 203.

3 Adjust the tonal range.

Begin tonal corrections by adjusting the values of the extreme highlight and shadow 
pixels in the image, setting an overall tonal range for the image. This process is known as 
setting the highlights and shadows or setting the white and black points.

Setting the highlights and shadows typically redistributes the midtone pixels appropri-
ately. However, you may need to adjust your midtones manually.

There are several different ways to set an image’s tonal range:

• You can drag sliders along the histogram in the Levels dialog box. For more information 
using the sliders in Levels, see “Using Levels to set highlights, shadows, and midtones” 
on page 186.

• (Photoshop) You can adjust the shape of the graph in the Curves dialog box. This 
method lets you adjust any point along a 0–255 tonal scale and provides the greatest 
control over an image’s tonal quality. For more information on using the Curves 
command, see “Using the Curves dialog box (Photoshop)” on page 189.

• (Photoshop) You can assign target values to the highlight and shadow pixels using 
either the Levels or Curves dialog box. This can help preserve important highlight and 
shadow details in images being sent to a printing press or laser printer. You might also 
need to tweak the target values after sharpening. For more information on setting 
target values, see “Setting highlight and shadow target values (Photoshop)” on 
page 194.
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• Adjust the tonality in the shadow and highlight areas using the Shadow/Highlight 
command. This adjustment is especially useful to correct photos, where the subject is 
silhouetted due to strong backlighting or where the subject is a bit light from being too 
close to the camera flash. For more information on the Shadow/Highlight command, 
see “Using the Shadow/Highlight command (Photoshop)” on page 204.

4 (Optional) Make other special color adjustments.

Once you have corrected the overall color balance of your image, you can make optional 
adjustments to enhance colors or produce special effects. For more information on special 
color effects, see “Applying special color effects to images” on page 221.

5 Sharpen the edges of the image.

As one of the final steps, use the Unsharp Mask filter to sharpen the clarity of edges in the 
image. The amount of sharpening required for an image varies due to differences in 
quality produced by different digital cameras and scanners. For more information on 
sharpening images, see “Sharpening images” on page 224.

6 (Photoshop) Use the Output sliders in the Levels dialog box or the Curves dialog box to 
bring important details in the highlights and shadows into the gamut of an output device, 
like a desktop printer. Do this if your image is being sent out to a printing press and you 
know the characteristics of the press.

Because sharpening increases the contrast of neighboring pixels, it’s possible that some 
pixels in critical areas might become unprintable on the press that you’re sending your 
images to. This is why it’s best to tweak the output settings after sharpening. For more 
information on adjusting the output settings, see “Setting highlight and shadow target 
values (Photoshop)” on page 194.

Using a histogram to view the tonal range of an image 
(Photoshop)
A histogram illustrates how pixels in an image are distributed by graphing the number of 
pixels at each color intensity level. This can show you whether the image contains enough 
detail in the shadows (shown in the left part of the histogram), midtones (shown in the 
middle), and highlights (shown in the right part) to make a good correction.

Reading a histogram
The histogram also gives a quick picture of the tonal range of the image, or the image key 
type. A low-key image has detail concentrated in the shadows; a high-key image has detail 
concentrated in the highlights; and an average-key image has detail concentrated in the 
midtones. An image with full tonal range has a number of pixels in all areas. Identifying 
the tonal range helps determine appropriate tonal corrections.
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How to read a histogram 
A. Overexposed photo B. Properly exposed Photo with full tonality C. Underexposed photo

About the Histogram palette
The Histogram palette offers many options for viewing tonal and color information about 
an image. By default, the histogram displays the tonal range of the entire image. To display 
histogram data for a portion of the image, first select that portion. 

Opening the Histogram palette Choose Window > Histogram or click the Histogram 
tab to open the Histogram palette. By default, the Histogram palette opens in Compact 
View with no controls or statistics. See the following section to learn how to show the 
Histogram palette in different views.

Histogram palette 
A. Channel menu B. Palette menu C. Uncached Refresh button D. Cached Data Warning icon
E. Statistics

Adjusting the view of the Histogram palette Choose one of the following views from 
the palette menu.

• Choose Expanded View to view the histogram with statistics, and access controls for 
choosing the channel represented by the histogram, viewing options in the Histogram 
palette, refreshing the histogram to display uncached data, and choosing a specific 
layer in a multi-layered document.

• Choose Compact View to display a histogram with no controls or statistics. The 
histogram represents the entire image.
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• Choose All Channels View to display individual histograms of the channels in addition 
to all the options of the Expanded View. The individual histograms do not include alpha 
channels, spot channels, or masks.

Histogram palette with all channels displayed and statistics hidden

Viewing a specific channel If you chose the Expanded View or All Channels View, you 
can choose a setting from the Channel menu. The setting you choose will be remembered 
and displayed if you switch from either Expanded View or All Channels View back to 
Compact View.

• Choose an individual channel to display a histogram of the document’s individual 
channels including color channels, alpha channels, and spot channels.

• Depending on the image’s color mode, choose RGB, CMYK, or Composite to view a 
composite histogram of all the channels. This is the default view when first choosing 
Expanded View or All Channels View.

• If the image is RGB or CMYK, choose Luminosity to display a histogram representing the 
luminance or intensity values of the composite channel.

• If the image is RGB or CMYK, choose Colors to display a composite histogram of the 
individual color channels in color.

In the All Channels View, choosing from the Channels menu only affects the topmost 
histogram in the palette.

Viewing channels in color To view channels in color, do one of the following:

• In the All Channels View, choose Show Channels in Color from the palette menu. 
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• In Expanded View or All Channels View, choose an individual channel from the Channel 
menu and choose Show Channels in Color from the palette menu. Switching to 
Compact View will continue to show the individual channel in color.

• In Expanded View or All Channels View, choose Colors from the Channel menu to show 
a composite histogram of the channels in color. Switching to Compact View will 
continue to show the composite histogram in color.

Showing and hiding statistics By default, statistics are displayed in the Expanded View 
and All Channels View. To hide the statistics, make sure Show Statistics is not chosen in the 
Histogram palette menu. For more information on statistics in the Histogram palette, see 
“Viewing statistical information about pixel values” on page 180.

Viewing specific statistics You can place the pointer in the histogram to view infor-
mation about a specific pixel value. To view information about a range of values, drag in 
the histogram to highlight the range. For more information on statistics in the Histogram 
palette, see “Viewing statistical information about pixel values” on page 180.

Viewing options for multilayered documents If your document is multilayered, you 
can choose a setting from the Source menu. The Source menu is not available for single-
layered documents.

• Choose Entire Image to display a histogram of the entire image including all layers in 
the multilayered document.

• Choose Selected Layer to display a histogram of the layer that’s selected in the Layers 
palette.

• Choose Adjustment Composite to display a histogram of an adjustment layer selected 
in the Layers palette, including all the layers below the adjustment layer.

Previewing adjustments If the Preview option is selected in the dialog boxes of 
adjustment commands, the Histogram palette displays a preview of how the adjustment 
affects the histogram.

Preview of histogram adjustment in the Histogram palette 
A. Original histogram B. Adjusted histogram C. Shadows D. Midtones E. Highlights

Refreshing the histogram display When a histogram is being read from a cache instead 
of the document’s current state, the Cached Data Warning icon  appears in the 
Histogram palette. Using the image cache, the histogram displays faster and is based on a 
representative sampling of pixels in the image. This option is enabled and the cache level 
(from 2 to 8) is specified in the Memory and Image Cache Preference. To refresh the 
histogram so it displays all of the pixels of the original image in its current state, do one of 
the following:

• Double-click anywhere in a histogram.

• Click the Cached Data Warning icon .

• Click the Uncached Refresh button .
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• Choose Uncached Refresh from the Histogram palette menu.

For information about cache level, see “Viewing statistical information about pixel values” 
on page 180.

Viewing statistical information about pixel values
Statistical information about the intensity values of the pixels appears below the 
histogram in the Histogram palette. The Histogram palette must be in either the Expanded 
View or All Channels View, and Show Statistics must be chosen from the palette menu.

The statistical information includes:

Mean Represents the average intensity value. 

Standard deviation (Std Dev) Represents how widely intensity values vary. 

Median Shows the middle value in the range of intensity values. 

Pixels Represents the total number of pixels used to calculate the histogram.

Level Displays the intensity level of the area underneath the pointer. 

Count Shows the total number of pixels corresponding to the intensity level underneath 
the pointer.

Percentile Displays the cumulative number of pixels at or below the level underneath the 
pointer. This value is expressed as a percentage of all the pixels in the image, from 0% at 
the far left to 100% at the far right.

Cache Level Shows the current image cache used to create the histogram. If the Use 
Cache for Histograms option is selected in the Memory and Image Cache preferences, the 
histogram displays faster and is based on a representative sampling of pixels in the image 
(based on the magnification), rather than on all of the pixels. The original image is cache 
level 1. Each level above that averages four adjacent pixels below to get a single pixel, so 
each level is half the dimensions (1/4 the number of pixels) of the one below. When 
Photoshop needs to do a quick approximation, it can just use one of the upper levels. If 
you want to check for posterization in the image, choose Edit > Preferences > Memory & 
Image Cache, and then deselect the Use Cache for Histograms option.

Using the color adjustment tools
All Photoshop and ImageReady color adjustment tools work essentially the same way: 
by mapping an existing range of pixel values to a new range of values. The difference 
between the tools is the amount of control they provide. For an overview summary of the 
color adjustment tools, see “Basic steps for correcting images” on page 174.

Making color adjustments
There are two ways to adjust the colors in an image. One method is to choose a command 
from the Image > Adjustments submenu. This method permanently alters the pixels in the 
active layer. 

A more flexible method is to use an adjustment layer. Adjustment layers let you exper-
iment with color and tonal adjustments without permanently modifying the pixels in the 
image. The color and tonal changes reside within the adjustment layer, which acts as a veil 
through which the underlying image layers appear. You must use Photoshop to create and 
edit adjustment layers; however, you can view existing adjustment layers in ImageReady. 
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To open a color adjustment dialog box:

1 If you want to make adjustments to just a portion of your image, select that portion. 
If you make no selection, the adjustment will be applied to the entire image.

2 Do one of the following:

• Choose Image > Adjustments, and choose a command from the submenu. 

• (Photoshop) Create an adjustment layer. (See “Using adjustment layers and fill layers 
(Photoshop)” on page 402.)

• (Photoshop) Double-click the thumbnail of an existing adjustment layer in the Layers 
palette.

3 To see your adjustments in the image before accepting them, select Preview in the 
color adjustment dialog box. 

To cancel changes without closing a color adjustment dialog box, hold down 
Alt (Windows) or Option (Mac OS) to change the Cancel button to Reset; then click 

Reset. This resets the dialog box to the values it had prior to your changes. 

Viewing the color values of pixels (Photoshop)
You can use the Info palette and the Color palette to see the color value of pixels as you 
make color corrections. This feedback is useful while you make color adjustments. For 
instance, referring to the color values can help when neutralizing a color cast or can alert 
you to whether a color is saturated.

When you work with a color adjustment dialog box, the Info palette displays two sets of 
color values for the pixels under the pointer. The value in the left column is the original 
color value. The value in the right column is the color value after the adjustment is made.

Using Levels and Info palette to neutralize the tone of an image
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You can view the color of a single location using the Eyedropper tool , or you can use up 
to four Color Samplers  to display color information for one or more locations in the 
image. These samplers are saved in the image, so you can refer to them repeatedly as you 
work, even if you close and reopen the image.

Color samplers and Info palette

To use the Info palette and the Eyedropper or Color Sampler tool to see color values:

1 Choose Window > Info to open the Info palette.

2 Select the Eyedropper tool  or Color Sampler tool , and if necessary, choose a 
sample size in the options bar:

• Point Sample to read the value of a single pixel.

• 3 by 3 Average to read the average value of a 3-by-3 pixel area.

• 5 by 5 Average to read the average value of a 5-by-5 pixel area.

3 If you selected the Color Sampler tool , place up to four color samplers on the image. 
Click where you want to place a sampler.

4 Open an adjustment dialog box. (See “Making color adjustments” on page 180.)

5 Make your adjustments in the dialog box and, before applying them, view the before 
and after color values in the Info palette:

• To view color values using the Eyedropper tool , move the pointer over the area of 
the image you want to examine. Opening an adjustment dialog box activates the 
Eyedropper tool outside the dialog box. You still have access to the scroll controls and 
to the Hand  and Zoom  tools using keyboard shortcuts.

• To view the color values under the color samplers, look at the lower half of the Info 
palette. To place additional color samplers in the image while the adjustment dialog 
box is open, Shift-click in the image.

To move a color sampler:

Select the Color Sampler tool , and drag the sampler to the new location.

To delete a color sampler:

1 Select the Color Sampler tool .

2 Do any of the following:

• Drag the sampler out of the document window.

• Hold down Alt (Windows) or Option (Mac OS) until the pointer becomes a scissors  
and click the sampler.
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• Right-click (Windows) or Control-click (Mac OS) a sampler, and then choose Delete from 
the contextual menu. 

• To delete all color samplers, click Clear in the options bar.

• To delete a color sampler while an adjustment dialog box is open, hold down Alt+Shift 
(Windows) or Option+Shift (Mac OS), and click the sampler.

To hide/show color samplers in an image:

Choose View > Extras. A check mark indicates that color samplers are showing.

To change the display of color sampler information in the Info palette:

Do any of the following:

• To display or hide color sampler information in the Info palette, choose Color Samplers 
from the palette menu. A check mark indicates that the color sampler information is 
showing.

• To change the color space in which a color sampler displays values, move the pointer 
onto the color sampler icon  in the Info palette, hold down the mouse button, and 
choose another color space from the menu.

To use the Eyedropper tool and Color palette to see color values: 

1 Choose Window > Color to open the Color palette.

2 Open a color adjustment dialog box. This activates the Eyedropper tool  outside the 
dialog box and over the image.

3 Click the pixel you want to check in the image.

4 Make the adjustments in the dialog box and, before applying them, view the adjusted 
color values in the Color palette.

Saving and reapplying settings
The Save and Load buttons in the Levels, Curves (Photoshop), Hue/Saturation, Match 
Color (Photoshop), Replace Color (Photoshop), Selective Color (Photoshop), Channel 
Mixer (Photoshop), Shadow/Highlight (Photoshop), and Variations dialog boxes let you 
save your settings and apply them to other images. The procedure for saving and loading 
a setting in the Match Color command is slightly different. For saving and loading settings 
in the Match Color command, see “Saving and reusing Match Color settings” on page 210.

To save a setting: 

1 Click Save in the adjustment dialog box you are using.

2 Name and save the settings.

To apply a saved setting:

In one of the adjustment dialog boxes mentioned above, click Load. Locate and load the 
saved adjustment file.

If you apply the same adjustment often, consider recording and running the 
adjustment as an action or creating a droplet.
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Comparing corrections in CMYK and RGB (Photoshop)
Even though you can perform all color and tonal corrections in RGB mode and nearly all 
adjustments in CMYK, you should choose a mode carefully. Whenever possible, avoid 
multiple conversions between modes, because color values are rounded and lost with 
each conversion. If an RGB image is to be used on-screen, you needn’t convert it to CMYK 
mode. Conversely, if a CMYK scan is to be separated and printed, you needn’t perform 
corrections in RGB mode.

If you must convert your image from one mode to another, it makes sense to perform 
most of your tonal and color corrections in RGB mode and use CMYK mode for fine-tuning. 
Advantages of working in RGB mode include the following:

• You can save memory and improve performance because you are working with fewer 
channels.

• The range of colors in RGB spaces is much larger than that of CMYK spaces, so more 
colors are likely to be preserved after adjustments. For more information, see “Under-
standing color space and gamut” on page 115.

Using the Proof Setup and Proof Color commands, you can preview composite CMYK 
colors and separation plates using the CMYK working space defined in the Color Settings 
dialog box. Or, you can preview colors using a custom CMYK color profile. (See “Soft-
proofing colors” on page 140.)

You can edit an image in RGB mode in one window and view the same image in CMYK 
colors in another window. Choose Window > Arrange > New Window for (file name) to 

open a second window with the image you’re working on. Make sure Working CMYK is 
chosen for Proof Setup and then use the Proof Color command to turn on the CMYK 
preview in one of the windows.

Identifying out-of-gamut colors (Photoshop)
A gamut is the range of colors that a color system can display or print. A color that can be 
displayed in RGB may be out of gamut, and therefore unprintable, for your CMYK setting. 
(See “Understanding color space and gamut” on page 115.)

Photoshop automatically brings all colors into gamut when you convert an RGB image to 
CMYK. But you might want to identify the out-of-gamut colors in an image or correct them 
manually before converting to CMYK. 

In RGB mode, you can identify out-of-gamut colors in the following ways:

• In the Info palette, an exclamation point appears next to the CMYK values whenever 
you move the pointer over an out-of-gamut color.

• In both the Color Picker and the Color palette, an alert triangle  appears and the 
closest CMYK equivalent is displayed whenever you select an out-of-gamut color. To 
select the CMYK equivalent, click the triangle or the color patch. 

• Use the Gamut Warning command.

To turn on or off the highlighting of out-of-gamut colors:

1 Choose View > Proof Setup, and choose the proof profile on which you want to base 
the gamut warning. (See “Soft-proofing colors” on page 140.)
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2 Choose View > Gamut Warning. All pixels outside the gamut of the current proof profile 
space are highlighted.

To change the gamut warning color:

1 Do one of the following:

• In Windows, choose Edit > Preferences > Transparency & Gamut.

• In Mac OS, choose Photoshop > Preferences > Transparency & Gamut.

2 Under Gamut Warning, click the color box to display the Color Picker. Then choose a 
new warning color, and click OK. For best results, use a color that is not already present in 
the image.

3 Enter a value in the Opacity text box. Values can range from 0 to 100%. Use this setting 
to reveal more or less of the underlying image through the warning color. Then click OK. 

Original image, and preview of out-of-gamut colors with green chosen for the gamut warning color

Using the Levels dialog box
The Levels dialog box lets you correct the tonal range and color balance of an image by 
adjusting intensity levels of the image’s shadows, midtones, and highlights. The Levels 
histogram serves as a visual guide for adjusting the image’s key tones. For more infor-
mation on how to read a histogram, see “Using a histogram to view the tonal range of an 
image (Photoshop)” on page 176.

Settings made in the Levels dialog box can be saved for use on another image. See “Saving 
and reapplying settings” on page 183.

Levels dialog box 
A. Apply Auto Color Correction B. Open Auto Color Correction Options dialog box C. Shadows
D. Midtones E. Highlights
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Using Levels to set highlights, shadows, and midtones
The outer two Input Levels sliders map the black point and white point to the settings of 
the Output sliders. By default, the Output sliders are at level 0, where the pixels are 
completely black, and level 255, where the pixels are completely white. So in the default 
position for the Output sliders, moving the black point slider maps the pixel value to level 
0 and moving the white point slider maps the pixel value to level 255. Clipping the pixels 
causes the remaining levels to redistribute themselves between levels 0 and 255. This 
redistribution increases the tonal range of the image, in effect increasing the overall 
contrast of the image.

Note: When shadows are clipped, the pixels are completely black—no detail. When 
highlights are clipped, the pixels are completely white—no detail.

The middle Input slider adjusts the gamma in the image. It moves the midtone (level 128) 
and changes the intensity values of the middle range of gray tones without dramatically 
altering the highlights and shadows. 

To adjust tonal range using Levels:

1 Do one of the following:

• Choose Image > Adjustments > Levels.

• (Photoshop) Layer > New Adjustment Layer > Levels. Click OK in the New Layer 
dialog box. 

2 To adjust tones for a specific color channel, choose an option from the Channel menu.

To edit a combination of color channels at the same time, Shift-select the channels in the 
Channels palette before choosing the Levels command. The Channel menu then displays 
the abbreviations for the target channels—for example, CM for cyan and magenta. The 
menu also contains the individual channels for the selected combination. You can only 
edit spot channels and alpha channels individually. Keep in mind that this method does 
not work in a Levels adjustment layer.

3 To adjust the shadows and highlights manually, do one of the following:

• Drag the black and white Input Levels sliders to the edge of the first group of pixels on 
either end of the histogram. For example, moving the black point slider to the right at 
level 5 tells Photoshop to map all the pixels at level 5 and lower to level 0. Similarly, 
moving the white point slider to the left at level 243 tells Photoshop to map all pixels at 
level 243 and higher to level 255. The mapping affects the darkest and lightest pixels in 
each channel. The corresponding pixels in the other channels are adjusted proportion-
ately to avoid altering the color balance.

Note: You can also enter values directly into the first and third Input Levels text boxes. 
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Before and after adjusting the black point and white point 

• Drag the black and white Output Levels sliders to define new shadow and highlight 
values. You can also enter values directly in the Output Levels text boxes. For more 
information, see “Using Levels to preserve highlight and shadow details for printing” on 
page 188 and “Setting highlight and shadow target values (Photoshop)” on page 194.

You can also set the white and black points by using the eyedropper tools. See “Using the 
eyedropper tools to set the black and white points” on page 193.

It’s also possible to adjust the shadows and highlights automatically by clicking Auto. 
In Photoshop, clicking Auto applies settings specified in the Auto Color Correction 
Options dialog box. For more information on adjusting the Auto Color Correction settings, 
see “Setting auto color correction options (Photoshop)” on page 218. In ImageReady, 
clicking Auto is the same as using the Auto Levels command. (See “Using the Auto Levels 
command” on page 216.)

If your image needs midtone corrections, use the middle Input slider to make a gamma 
adjustment. Move the middle Input slider to the left makes the overall image lighter. It 
maps a lower (darker) level up to the midpoint level between the Output sliders. If the 
Output sliders are in their default position (0 and 255), the midpoint would be level 128. 
In this example, the shadows expand to fill the tonal range from 0 to 128 and the 
highlights get compressed. Move the middle Input slider to the right has the opposite 
effect, making the image darker.

Note: You can also enter a gamma adjustment value directly in the middle Input Levels 
text box.

Moving the middle slider adjusts the image gamma
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4 Click OK.

The adjusted histogram can be viewed in the Histogram palette. 

Using Levels to preserve highlight and shadow details for 
printing
The Output Levels sliders let you set the shadow and highlight levels to compress the 
image into a range less than 0 to 255. Use this adjustment to preserve the shadow and 
highlight details when an image is being printed on a press whose characteristics you 
know. For example, suppose there’s important image details in the highlights with a value 
of 245, and the printing press that you’re sending your image to won’t hold a dot smaller 
than 5%. You can pull the highlight slider to level 242 (which is a 5% dot on the press) to 
shift the highlight detail from 245 to 242. Now, the highlight detail will safely print on that 
particular press. For more information on setting the Output to target an output desti-
nation, see “Setting highlight and shadow target values (Photoshop)” on page 194.

Before and after adjusting the Output Levels to set the shadow and highlight levels

Using Levels to adjust color (Photoshop)
In addition to setting the tonal range, you can use Levels to adjust the color balance of an 
image.

To use Levels to adjust color balance:

1 Place a color sampler on an area of neutral gray in the image.

2 Do one of the following to open the Levels dialog box:

• Choose Image > Adjustments > Levels.

• (Photoshop) Choose Layer > New Adjustment Layer > Levels. Click OK in the New Layer 
dialog box. 

3 Do one of the following to neutralize a color cast:

• Double-click the Set Gray Point Eyedropper tool  in the Levels dialog box to display 
the Adobe Color Picker. Enter the values you want to assign to the neutral gray, and 
click OK. Then click the color sampler in the image. For more information on using an 
eyedropper tool, see “Using the eyedropper tools to remove a color cast” on page 193.
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• Click Options in the Levels dialog box. Click the Midtones color swatch to display the 
Adobe Color Picker. Enter the values you want to assign to the neutral gray, and click 
OK. This method has the advantage of showing you a preview of the values you’re 
assigning.

In general, assign equal color component values to achieve a neutral gray. For example, 
assign equal red, green, and blue values to produce a neutral gray in an RGB image.

Using the Curves dialog box (Photoshop)
Like the Levels dialog box, the Curves dialog box lets you adjust the entire tonal range of 
an image. But instead of using only three adjustments (white point, black point, gamma), 
with Curves you can adjust up to 14 different points throughout an image’s tonal range 
(from shadows to highlights). You can also use Curves to make precise adjustments to 
individual color channels in an image. Settings made in the Curves dialog box can be 
saved for use on another image. See “Saving and reapplying settings” on page 183.

Curves dialog box 
A. Highlights B. Midtones C. Shadows D. Adjust curve by adding points E. Draw a curve 
with the pencil F. Set black point G. Set gray point H. Set white point

About the Curves dialog box
The Curves dialog box opens with the curve as a straight diagonal line. The horizontal axis 
of the graph represents the original intensity values of the pixels (Input levels); the vertical 
axis represents the new color values (Output levels). 
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By default, Curves displays the intensity values from 0 to 255 for RGB images with black (0) 
at the bottom left corner. By default, Curves displays percentages from 0 to 100 for CMYK 
images with highlights (0%) at the bottom left corner. To reverse the display of intensity 
values and percentages, click the double arrow  below the curve. For RGB images, 0 will 
now be at the bottom right corner and for CMYK images, 0% will be at the bottom right 
corner. 

Default curve dialog for CMYK and RGB images 
A. Default orientation of CMYK tonal output bar B. CMYK Input and Output values in 
percentages C. Default orientation of CMYK tonal input bar D. Default orientation of RGB tonal 
output bar E. RGB Input and Output values are in intensity levels F. Default orientation of RGB 
tonal input bar

To open the Curves dialog box:

1 Do one of the following:

• Choose Image > Adjustments > Curves.

• Choose Layer > New Adjustment Layer > Curves. Click OK in the New Layer dialog box. 

2 To make the Curves grid finer, hold down Alt (Windows) or Option (Mac OS), and click 
the grid. Alt/Option-click again to make the grid larger.

Adjusting color and tonality with Curves
Changing the shape of the curve in the Curves dialog box alters the tonality and color of 
an image. Bowing the curve upward lightens an image, and bowing the curve downward 
darkens it. The steeper sections of the curve represent portions of an image with more 
contrast. Conversely, flatter sections of the curve represent areas of lower contrast in an 
image. 

In the default state of the Curves dialog box, moving a point in the top portion of the 
curve primarily adjusts the highlights; moving a point in the center of the curve primarily 
adjusts the midtones, and moving a point in the bottom section of the curve primarily 
adjusts the shadows. Moving a point either down or to the right maps the Input value to a 
lower Output value, and the image darkens. Conversely, moving a point either up or to the 
left maps a lower Input value to a higher Output value, and the image lightens. So, if you 
want to lighten the shadows, move up a point near the bottom of the curve. And, if you 
want to darken highlights, move down a point near the top of the curve.

To adjust color and tonality with Curves:

1 Open the Curves dialog box.

2 (Optional) To adjust the color balance of the image, choose the channel (or channels) 
you want to adjust from the Channel menu.

A B C D E F
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To edit a combination of color channels at the same time, Shift-select the channels in the 
Channels palette before choosing Curves. The Channel menu then displays the abbrevia-
tions for the target channels—for example, CM for cyan and magenta. The menu also 
contains the individual channels for the selected combination. Keep in mind that this 
method does not work in a Curves adjustment layer.

3 Add a point along the curve by doing one of the following:

• Click directly on the curve.

• (RGB images only) Ctrl-click (Windows) or Command-click (Mac OS) a pixel in the image.

Ctrl/Command-clicking pixels in the image is the best way to add points when you want to 
preserve or adjust specific details in an image.

You can add up to 14 control points to the curve. To remove a control point, drag it off the 
graph, select it and press Delete, or Ctrl-click (Windows) or Command-click (Mac OS) it. 
You cannot delete the endpoints of the curve.

Ctrl-clicking (Windows) or Command-clicking (Mac OS) three areas of an image to add points to 
the curve. By default, moving a point to the left or up raises the tonal value, and moving a point to 
the right or down lowers the tonal value. Lightening the highlights and darkening the shadows is 
represented by an S-curve where the image’s contrast is increased.

To determine the lightest and darkest areas in an RGB image, drag over the image. 
The intensity values of the area under the pointer, along with the corresponding 

location on the curve, are displayed in the Curves dialog box. Dragging the pointer over a 
CMYK image shows the percentages in the Color palette if it’s displaying CMYK values.

4 Do one of the following to adjust the shape of the curve:

• Click a point and drag the curve until the image looks the way you want it. 

• Click a point on the curve, and enter values in the Input and Output text boxes. 

• Select the pencil at the bottom of the dialog box, and drag to draw a new curve. 
You can hold down Shift to constrain the curve to a straight line, and click to define 
endpoints. When you’re finished, click Smooth if you want to smooth the curve.

Points on the curve remain anchored until you move them. As a result, you can make an 
adjustment in one tonal area while other areas remain unaffected.

Note: In general, only small curve adjustments are necessary to make tonal and color 
corrections to most images. 
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Quick adjustments in the Curves dialog box
Clicking the Auto button applies either an Auto Color, Auto Contrast, or Auto Levels 
correction, depending on the settings in the Auto Color Correction Options dialog box. 
For more information on specifying the settings for Auto Color, Auto Contrast, or Auto 
Levels, see “Setting auto color correction options (Photoshop)” on page 218.

The Curves dialog box also has eyedropper tools to adjust color and tonality in an image. 
For more information about using the eyedropper tools, see “Using the eyedropper tools 
in the Levels or Curves dialog box” on page 192.

Keyboard shortcuts for Curves
The following shortcuts work with the Curves dialog box:

• Ctrl-click (Windows) or Command-click (Mac OS) in the image to set a point on the 
curve in the current channel specified in the Curves dialog box.

• Shift+Ctrl-click (Windows) or Shift+Command-click (Mac OS) in the image to set a point 
on the curve for the selected color in each color component channel (but not in the 
composite channel).

• Shift-click points on the curve to select multiple points. Selected points appear filled 
with black.

• Click in the grid, or press Ctrl-D (Windows) or Command-D (Mac OS) to deselect all 
points on the curve.

• Press arrow keys to move selected points on the curve.

• Press Ctrl+Tab (Windows) or Control+Tab (Mac OS) to move forward through control 
points on the curve.

• Press Shift+Ctrl+Tab (Windows) or Shift+Control+Tab (Mac OS) to move backward 
through control points on the curve.

Using the eyedropper tools in the Levels or Curves 
dialog box 
Both the Levels (both Photoshop and ImageReady) and Curves (Photoshop) dialog boxes 
have eyedropper tools for setting the black point, setting the white point, and adjusting 
the color balance of an image. Simultaneously, using an eyedropper tool also applies a 
tonal correction to all the pixels in an image.

Note: The Set Gray Point Eyedropper tool  is used primarily for color correction and is 
unavailable when working with grayscale images.

For the best results, don’t use the eyedropper tools in images that require a huge 
adjustment to map a pixel to the maximum highlight or minimum shadow values. 
Because the eyedropper tools shift the tonal value of all pixels in an image in equal 
amounts higher or lower, some pixels may get clipped. It’s best to make only small 
adjustments with the eyedropper tools.

Important: Using the eyedropper tools will undo any previous adjustment you’ve made in 
Levels or Curves (Photoshop). If you plan to use the eyedropper tools, it’s best to use them 
first, and then tweak your adjustments with the Levels sliders or Curves points 
(Photoshop). 
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Using the eyedropper tools to set the black and white points 
You can use the eyedropper tools to set the black or white points in an image. Keep in 
mind that when the eyedropper tools shift the tonal value of a pixel to the black point (0) 
or white point (255), the amount of shift in the pixel value is applied to every pixel in the 
image. So, all pixel values are shifted equally higher or lower, depending on whether 
you’re setting the black point or white point.

This behavior differs from the Input Levels sliders and the Curves (Photoshop) end points, 
which set the black point in an image while preserving most of the tonality in the 
highlights and set the white point while preserving most of the tonality in the shadows. 
Further, both Levels and Curves (Photoshop) make gamma adjustments without affecting 
either the black or white points. For more information, see “Using the Levels dialog box” 
on page 185 and “Using the Curves dialog box (Photoshop)” on page 189.

To set the black and white points using the eyedropper tools:

1 Open the Levels or Curves (Photoshop) dialog box. 

By default, the target value for the Set Black Point Eyedropper tool  is 0 and the target 
value for the Set White Point Eyedropper tool  is 255.

2 To specify the target value for the black point or white point, double-click the Set Black 
Point Eyedropper tool or the Set White Point Eyedropper tool. Use the Color Picker to 
specify the target value.

Depending on the output device for your image, you may want to set a higher black point 
value or a lower white point value.

3 Select either the Set Black Point Eyedropper tool or the Set White Point Eyedropper 
tool. Then click in the image where you want to set the black or white point.

4 If necessary, make any further adjustments in the Levels or Curves (Photoshop) 
dialog box.

5 Click OK.

Using the eyedropper tools to remove a color cast
You can use the eyedropper tools in the Levels or Curves (Photoshop) dialog boxes to 
correct a color cast. It’s easier to color balance an image by first identifying an area that 
should be neutral and then removing the color cast from that area. With such a correction, 
all other colors in the image should be color balanced, too. The eyedropper tools work 
best on an image with easily identified neutrals.

Before and after using the Set Gray Point Eyedropper tool on a color sampler placed on 
a neutral gray in the image



Using Help | Contents | Index Back 194  

Adobe Photoshop CS Help Making Color and Tonal Adjustments 

Using Help | Contents | Index Back 194  

To color correct using an eyedropper tool:

1 (Optional) Place a color sampler on a pixel in an area of the image that should be 
neutral gray. Choose a pixel in the shadows, midtone, or highlight, depending on the 
eyedropper tool that you plan to use. Use the Info palette to help you locate an appro-
priate pixel. For more information on placing a color sampler and using the Info palette, 
see “Viewing the color values of pixels (Photoshop)” on page 181.

If you plan to use more than one eyedropper tool, you might want to place more than one 
color sampler in the image.

2 Open the Levels or Curves (Photoshop) dialog box. For more information, see “Using 
the Levels dialog box” on page 185 and “Using the Curves dialog box (Photoshop)” on 
page 189.

3 Double-click the Set Black Point , the Set Gray Point , or the Set White Point 
Eyedropper tool . Use the Adobe Color Picker to specify a neutral target color. 

If you’re working in RGB, enter the same values for R, G, and B to specify a neutral color. 
The neutral color should be close as possible to the values of the color sampler.

If you want to preserve specific details in the shadow or highlight, be sure to specify a 
values for the Set Black Point and the Set White Point Eyedropper tools that are within the 
gamut of the output device (printing press, laser printer, and so forth).

4 With the targeted eyedropper tool, click the color sampler that you want mapped to 
the target color specified in step 3. If you didn’t place a color sampler in the image, then 
click a pixel that you want mapped to the target color.

5 Repeat steps 3 and 4 using a different eyedropper tool if necessary.

6 If necessary, make final adjustments in the Levels or Curves (Photoshop) dialog box.

7 Click OK. If you specified new target colors for the Set Black Point , the Set Gray 
Point , or the Set White Point Eyedropper tool , Photoshop will ask if you want to 
save the new target colors as defaults.

Setting highlight and shadow target values (Photoshop)
Assigning (targeting) an image’s highlight and shadow values is necessary because most 
output devices (usually printing presses) cannot print detail in the blackest shadow values 
(near level 0) nor the whitest highlight values (near level 255). Specifying the minimum 
shadow level and maximum highlight level helps to bring the important shadow and 
highlight details within the gamut of the output device. For more information about the 
gamut of a device, see “Why each device has a different color space” on page 116.

If you are printing an image on a desktop printer and your system is color managed, it’s 
unnecessary to set the highlight and target values. The Photoshop color management 
system automatically makes adjustments to the image you see on the screen so it prints 
properly on your profiled desktop printer. For more information on producing consistent 
color from image editing to printing, see “Producing consistent color with a desktop 
printer” on page 146.

Note: You can do the following procedure in the Levels dialog box in ImageReady.
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To use target values to set highlights and shadows:

1 Select the Eyedropper tool . You can choose 3 by 3 Average from the Sample Size 
menu in the Eyedropper tool options. This ensures a representative sample of an area 
rather than the value of a single screen pixel.

2 Open the Levels or Curves dialog box. (See “Using the Levels dialog box” on page 185 
or “Using the Curves dialog box (Photoshop)” on page 189.)

When you open Levels or Curves, the Eyedropper tool  is active outside the dialog box. 
You still have access to the scroll controls, the Hand tool , and the Zoom tool  using 
keyboard shortcuts.

3 Do one of the following to identify areas of highlights and shadows that you want to 
preserve in the image:

• Move the pointer around the image, and look at the Info palette to find the lightest 
and darkest areas that you want preserved (not clipped to pure black or white). 
(See “Viewing the color values of pixels (Photoshop)” on page 181.) 

• Drag the pointer in the image, and look at the Curves dialog box to find the lightest and 
darkest points you want to preserve. This method does not work if the Curves dialog 
box is set to the CMYK composite channel.

When identifying the lightest highlight details that you want targeted to a printable 
(lower) value, don’t include specular highlights. Specular highlights such as the highlight 
glint in jewelry or a spot of glare are meant to be the brightest points in an image. It’s 
usually desirable to let specular highlight pixels be clipped (pure white, no detail) so no ink 
is printed on the paper. 

You can also use the Threshold command to identify representative highlights and 
shadows before opening Levels or Curves. (See “Using the Threshold command 

(Photoshop)” on page 222.)

4 Do one of the following to assign highlight values to the lightest area of the image:

• In Levels, move the Output Levels highlight slider to set the highest highlight value. 
As you move the slider, the highlight value displays in the Output Levels text box and 
you can see a preview in the document window. The Output Levels slider lowers the 
values of the highlight pixels. Don’t use the Output Levels slider if your image has a 
specular highlight and you want it to be pure white (level 255). 

• Double-click the Set White Point Eyedropper tool  in the Levels or Curves dialog box 
to display the Color Picker. Enter the values you want to assign to the lightest area in 
the image, and click OK. Then click the highlight you identified in step 3. 

If you accidentally click the wrong highlight, hold down Alt (Windows) or Option 
(Mac OS), and click Reset in the Levels or Curves dialog box.

• Click Options in the Levels or Curves dialog box. In the Auto Color Correction Options 
dialog box, click the Highlights color swatch to display the Color Picker. Enter the values 
you want to assign to the lightest area in the image, and click OK.
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Depending on the output device, when you are printing on white paper, you can achieve a 
good highlight in an average-key image using CMYK values of 5, 3, 3, and 0, respectively. 
An approximate RGB equivalent is 244, 244, 244, and an approximate grayscale equivalent 
is a 4% dot. You can approximate these target values quickly by entering 96 in the 
Brightness (B) text box under the HSB area of the Color Picker.

With a low-key image, you might want to set the highlight to a lower value to avoid 
too much contrast. Experiment with Brightness values between 96 and 80.

Using the Eyedropper tool  or the Auto Color Correction Options, you can adjust the 
pixel values throughout the image proportionately to the new highlight values. Any pixels 
lighter than the area you clicked are clipped (adjusted to level 255, pure white). The Info 
palette shows the values both before and after the color adjustment.

Setting the target value for the Set White Point Eyedropper tool and then clicking a highlight to 
assign it the target value 

5 Do one of the following to assign shadow values to the darkest area of the image that 
you want preserved:

• In Levels, move the Output Levels shadow slider to set the lowest shadow value.

• Double-click the Set Black Point Eyedropper tool  in the Levels or Curves dialog box 
to display the Color Picker. Enter the values you want to assign to the darkest area in the 
image, and click OK. Then click the shadow you identified in step 3. 

• Click Options in the Levels or Curves dialog box. In the Auto Color Correction Options 
dialog box, click the Shadows color swatch to display the Color Picker. Enter the values 
you want to assign to the darkest area in the image, and click OK.
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In most situations when you’re printing on white paper, you can achieve a good shadow in 
an average-key image using CMYK values of 65, 53, 51, and 95. An approximate RGB equiv-
alent is 10, 10, 10, and an approximate grayscale equivalent is a 96% dot.You can approx-
imate these same values quickly by entering 4 in the Brightness (B) text box under the HSB 
area of the Color Picker.

With a high-key image, you might want to set the shadow to a higher value to 
maintain detail in the highlights. Experiment with Brightness values between 

4 and 20.

To use Threshold mode to identify the lightest and darkest areas in an image:

1 Open the Levels dialog box, and make sure the Preview option is selected.

Note: The Threshold mode in Levels is not available for CMYK images.

2 Hold down Alt (Windows) or Option (Mac OS), and drag the white or black Input Levels 
triangle.

The image changes to Threshold mode, and a high-contrast preview image appears. The 
visible areas of the image indicate the lightest parts of the image if you are dragging the 
white slider, and the darkest parts if you are dragging the black slider. If a color channel is 
selected in the Levels dialog box, the black area indicates where none of the given color 
component exists.

Image preview in Threshold mode

3 Slowly drag the slider to the center of the histogram to identify areas in the image that 
are being clipped (completely black or completely white). Use the pixels in these areas for 
targeting the black point and white point in your image.

Adjusting the gamma value of an image (ImageReady)
In very simplistic terms, gamma is the measure of the contrast—brightness of the midtone 
values—produced by a device (like a computer monitor) or in a photographic image. 
A higher gamma value yields an overall darker image. Windows systems use a higher 
gamma value (usually 2.2) than Mac OS systems (usually 1.8), with the result that the same 
image is noticeably darker on a Windows system than on a Mac OS system. 
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Designers, particularly those who use Mac OS systems to create images that will be 
viewed on Windows systems, must consider the issue of cross-platform gamma. You can 
modify the gamma value of an image to compensate for the differences between 
Windows and Mac OS monitors. 

The Gamma command modifies the pixel values in an image. By contrast, the Preview 
commands adjust the appearance of the image on your monitor but do not change the 
image’s pixel values.

To preview an image using different gamma values:

Choose View > Preview, and then choose one of the following:

• Uncompensated Color to view the image with the monitor gamma uncorrected

• Standard Macintosh Color to view the image with a gamma value of 1.8

• Standard Windows Color to the image with a gamma value of 2.2

• Use Embedded Color Profile to view the image using the embedded profile

You can edit your image in one window and view the same image with a different 
gamma value in a second window. Choose Window > Arrange > New Window for 

(file name). With the new window active, choose View > Preview, and then choose a 
different gamma than the one used in the first window.

To adjust the gamma value automatically:

1 Choose Image > Adjustments > Gamma.

2 Select Preview to preview the adjustment in the image.

3 Adjust the gamma:

• Select Windows to Macintosh to adjust gamma for display in Mac OS.

• Select Macintosh to Windows to adjust gamma for display in Windows.

Note: Images created in Photoshop 4.0 or earlier use the Mac OS gamma value (1.8) by 
default and should be adjusted for display in Windows (unless gamma was adjusted when 
the image was created). Images created in Photoshop 5.0 or later use the Windows 
gamma value (2.2) by default and will be at the correct gamma for display in Windows 
with no adjustment.

To adjust the gamma value manually:

1 Choose Image > Adjustments > Gamma.

2 Select Preview to preview the adjustment in the image.

3 Drag the Gamma slider, or enter a value in the text box between 0.1 and 9.99. The 
Gamma slider measures the amount of change from the current gamma value. (The slider 
does not indicate the actual gamma value.)
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Using the Color Balance command (Photoshop)
The Color Balance command changes the overall mixture of colors in an image for 
generalized color correction.

Original image with greenish cast, and magenta/green level adjusted in midtones

To use the Color Balance command: 

1 Make sure the composite channel is selected in the Channels palette. This command is 
available only when you’re viewing the composite channel.

2 Do one of the following:

• Choose Image > Adjustments > Color Balance.

• Choose Layer > New Adjustment Layer > Color Balance. Click OK in the New Layer 
dialog box. 

3 Select Shadows, Midtones, or Highlights to select the tonal range on which you want to 
focus the changes. 

4 Select Preserve Luminosity to prevent changing the luminosity values in the image 
while changing the color. This option maintains the tonal balance in the image.

5 Drag a slider toward a color you want to increase in the image; drag a slider away from a 
color you want to decrease in the image.

The values above the color bars show the color changes for the red, green, and blue 
channels. (For Lab images, the values are for the a and b channels.) Values can range from 
–100 to +100.
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Using the Hue/Saturation command
The Hue/Saturation command lets you adjust the hue, saturation, and brightness of a 
specific color component in an image or simultaneously adjust all the colors in an image. 
In Photoshop, this command is especially good for tweaking specific colors in a CMYK 
image so they are within the gamut of an output device. For more information about the 
hue, saturation, and brightness (HSB) color model, see “HSB model” on page 112.

Settings in the Hue/Saturation dialog box can be saved and loaded for reuse on other 
images. For more information, see “Saving and reapplying settings” on page 183.

To use the Hue/Saturation command: 

1 Do one of the following:

• Choose Image > Adjustments > Hue/Saturation.

• (Photoshop) Choose Layer > New Adjustment Layer > Hue/Saturation. Click OK in the 
New Layer dialog box. 

The two color bars in the dialog box represent the colors in their order on the color wheel. 
The upper color bar shows the color before the adjustment; the lower bar shows how the 
adjustment affects all of the hues at full saturation.

2 (Photoshop) Choose which colors to adjust using the Edit pop-up menu:

• Choose Master to adjust all colors at once. 

• Choose one of the other preset color ranges listed for the color you want to adjust.

3 For Hue, enter a value or drag the slider until the colors appear as you want. 

The values displayed in the text box reflect the number of degrees of rotation around the 
wheel from the pixel’s original color. A positive value indicates clockwise rotation, a 
negative value counterclockwise rotation. Values can range from –180 to +180.

Color wheel and radius of color wheel 
A. Saturation B. Hue

4 For Saturation, enter a value or drag the slider to the right to increase the saturation or 
to the left to decrease it. 

The color shifts away from or toward the center of the wheel, relative to the beginning 
color values of the selected pixels. Values can range from –100 (percentage of desatu-
ration, duller colors) to +100 (percentage of saturation increase). 

0°/360°

180°

90°270°
A

B
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5 For Lightness, enter a value or drag the slider to the right to increase the lightness 
(add white to a color) or to the left to decrease it (add black to a color). Values can range 
from –100 (percentage of black) to +100 (percentage of white).

Note: Click the Reset button to undo a setting in the Hue/Saturation dialog box. Press the 
Alt (Windows) or Option (Mac OS) key to change the Cancel button to Reset. 

To specify or modify the range of colors being adjusted in the Hue/Saturation 
command (Photoshop):

1 Do one of the following:

• Choose Image > Adjustments > Hue/Saturation.

• (Photoshop) Choose Layer > New Adjustment Layer > Hue/Saturation. Click OK in the 
New Layer dialog box. 

2 In the Hue/Saturation dialog box, choose an individual color from the Edit menu.

Four color wheel values (in degrees) display in the dialog box. They correspond to the 
adjustment sliders that appear between the color bars. The two inner vertical sliders 
define the color range. The two outer triangle sliders show where the adjustments on a 
color range “fall-off” (a feathering or tapering of the adjustments instead of a sharply 
defined on/off application of the adjustments).

3 Use either the eyedropper tools or the adjustment sliders to modify the range of colors.

Click or drag in the image with the Eyedropper tool  to select a color range. To expand 
the range of color, click or drag in the image with the Add to Sample Eyedropper tool . 
To reduce the range of color, click or drag in the image with the Subtract from Sample 
Eyedropper tool . While an eyedropper tool is selected, you can also press Shift to add to 
the range, or Alt (Windows) or Option (Mac OS) to subtract from it.

Hue/Saturation adjustment slider 
A. Hue slider values B. Adjusts fall-off without affecting range C. Adjusts range without 
affecting fall-off D. Moves entire slider E. Adjusts range of color component

BA C D E
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Or, do any of the following to the adjustment sliders:

• Drag one of the white triangle sliders to adjust the amount of color fall-off (feathering 
of adjustment) without affecting the range.

• Drag the area between the triangle and the vertical bar to adjust the range without 
affecting the amount of fall-off.

• Drag the center area to move the entire adjustment slider (which includes the triangles 
and vertical bars) to select a different color area.

• Drag one of the vertical white bars to adjust the range of the color component. Moving 
a vertical bar out from the center of the adjustment slider and closer to a triangle 
increases the color range and decreases the fall-off. Moving a vertical bar closer to the 
center of the adjustment slider and away from a triangle decreases the color range and 
increases the fall-off.

• Ctrl-drag (Windows) or Command-drag (Mac OS) the color bar so that a different color 
is in the center of the bar.

If you modify the adjustment slider so that it falls into a different color range, the name in 
the Edit menu changes to reflect this. For example, if you choose Yellow and alter its range 
so that it falls in the red part of the color bar, the name changes to Red 2. You can convert 
up to six of the individual color ranges to varieties of the same color range (for example, 
Red through Red 6).

Note: By default, the range of color selected when you choose a color component is 30° 
wide, with 30° of fall-off on either side. Setting the fall-off too low can produce banding in 
the image.

To colorize a grayscale image or create a monotone effect: 

1 (Photoshop) If you are colorizing a grayscale image, choose Image > Mode > RGB Color 
to convert the image to RGB.

2 Do one of the following to open the Hue/Saturation dialog box:

• Choose Image > Adjustments > Hue/Saturation.

• (Photoshop) Choose Layer > New Adjustment Layer > Hue/Saturation. Click OK in the 
New Layer dialog box. 

3 Select the Colorize option. If the foreground color is black or white, the image is 
converted to a red hue (0°). If the foreground color is not black or white, the image is 
converted to the hue of the current foreground color. The lightness value of each pixel 
does not change.

4 Use the Hue slider to select a new color if desired. Use the Saturation and Lightness 
sliders to adjust the saturation and lightness of the pixels.
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Using the Photo Filter command (Photoshop)
The Photo Filter command mimics the technique of putting a colored filter in front of the 
camera lens to adjust the color balance and color temperature of the light transmitted 
through the lens and exposing the film. The Photo Filter command also lets you choose a 
color preset to apply a hue adjustment to an image. If you want to apply a custom color 
adjustment, the Photo Filter command lets you specify a color using the Adobe Color 
Picker.

Original image, and Warming Filter (81) with 60% Density applied

To change the color balance using the Photo Filter command:

1 Do one of the following:

• Choose Image > Adjustments > Photo Filter.

• Choose Layer > New Adjustment Layer > Photo Filter. Click OK in the New Layer 
dialog box. 

2 To choose the filter color, do one of the following in the Photo Filter dialog box:

• Select the Filter option and choose one of the following presets from the Filter menu:

Warming Filter (85) and Cooling Filter (80) Are color conversion filters that tune the 
white balance in an image. If an image was photographed with a lower color temperature 
of light (yellowish), the Cooling Filter (80) makes the image colors bluer to compensate for 
the lower color temperature of the ambient light. Conversely, if the photo was taken with a 
higher color temperature of light (bluish), the Warming Filter (85) makes the image colors 
warmer to compensate for the higher color temperature of the ambient light.

Warming Filter (81) and Cooling Filter (82) Are light balancing filters for minor adjust-
ments in the color quality of an image. The Warming Filter (81) makes the image warmer 
(yellower), and the Cooling Filter (82) makes the image cooler (bluer). 

Individual Colors Apply a hue adjustment to the image depending on the color preset 
you choose. Your choice of color depends on how you’re using the Photo Filter command. 
If your photo has a color cast, you can choose a complement color to neutralize the color 
cast. You can also apply colors for special color effects or enhancements. For example, the 
Underwater color simulates the greenish-blue color cast caused when photographing 
underwater.
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• Select the Color option, click the color square, and use the Adobe Color Picker to specify 
a color for a custom color filter. You can click the New Swatch button  to save your 
custom color in the Swatches palette for future use.

Make sure Preview is selected to view the results of using a color filter.

If you don’t want the image darkened by adding the color filter, be sure that the Preserve 
Luminosity option is selected.

3 To adjust the amount of color applied to the image, use the Density slider or enter a 
percentage in the Density text box. A higher Density applies a stronger color adjustment.

4 Click OK.

Using the Shadow/Highlight command (Photoshop)
The Shadow/Highlight command is suitable for correcting photos with silhouetted 
images due to strong backlighting or correcting subjects that have been slightly washed 
out because they were too close to the camera flash. The adjustment is also useful for 
brightening up areas of shadow in an otherwise well-lit image. The Shadow/Highlight 
command does not just lighten or darken an image, it lightens or darkens based on the 
surrounding pixels (local neighborhood) in the shadows or highlights. This enables 
separate controls of the shadows and the highlights. The defaults are set to fix images 
suffering from backlighting problems. The Shadow/Highlight command also has a 
Midtone Contrast slider, Black Clip option, and White Clip option for adjusting the overall 
contrast of the image.

Original image, and Shadow/Highlight Correction applied

To adjust the shadows and highlights in an image:

1 Choose Image > Adjustments > Shadow/Highlight.

Make sure the Preview option is selected in the dialog box if you want the image to 
update as you make adjustments.

2 Adjust the amount of lighting correction by moving the Amount slider or entering a 
value in the percentage text box for Shadows or Highlights. Larger values provide either 
greater lightening of shadows or greater darkening of highlights. You can make adjust-
ments to both Shadows and Highlights in an image.
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3 For finer control, select Show More Options to make the additional shadow or highlight 
adjustments:

Tonal Width Controls the range of tones in the shadows or highlights that are modified. 
Move the slider to the left or right to decrease or increase the Tonal Width value. Smaller 
values restrict the adjustments to only the darker regions for Shadow correction and only 
the lighter regions for Highlight correction. Larger values include more tonal regions (such 
as adding the midtones) that are being adjusted. A value of 100% produces a linear effect; 
for Shadow correction, deep shadows get modified the most with no correction to bright 
highlights and half the shadow correction to midtones. The tonal width requirements will 
vary from image to image. Specifying a value that is too large for a given image might 
introduce halos around strong dark to light edges. The default settings attempt to reduce 
these artifacts. These halos may occur when the Shadow or Highlight Amount values are 
too large; they can also be reduced by decreasing these values.

The Tone Width default is set to 50%. If you find that you are trying to lighten a dark 
subject but the midtones or lighter regions are changing too much, try reducing the 

Shadow Tone Width towards zero. Then only the darkest regions will be lightened. On the 
other hand, if you need to brighten up the midtones as well as the shadows, increase the 
Shadows Tone Width toward 100%.

Radius Controls the size of the local neighborhood around each pixel that is used to 
determine whether a pixel is in the shadows or highlights. Moving the slider to the left 
specifies a smaller area, and moving it to the right specifies a larger area. The optimum 
local neighborhood size depends on the image. It’s best to experiment with the 
adjustment. If the Radius is too large, the adjustment tends to brighten (or darken) the 
whole image rather than brightening the subject only. It’s best to set the radius to be 
roughly the size of the subjects of interest in the image. Experiment with different Radius 
settings to obtain the best balance between subject contrast and differential brightening 
(or darkening) of the subject compared to the background. 

4 In the Adjustments area, do one of the following to apply an image adjustment:

Color Correction Allows fine tuning of the colors in regions of the image that have 
changed. This adjustment is only available in color images. For example, if you increase 
the Shadows Amount slider, you will bring out colors that were dark in the original image. 
You may want these colors to be more or less vivid. Adjust the Color Correction slider to 
give the best results. In general, increasing values tend to produce more saturated colors 
and decreasing values produce less saturated colors. 

Note: Since the Color Correction slider only affects changed portions of the image, the 
amount of color variation depends on how much or little Shadows or Highlights Amount 
is applied. The greater the correction made to the shadows and highlights, the greater the 
range of color correction available. The Color Correction slider applies subtle control over 
the darkened or lightened colors in the image. If you want to change the color hues or 
saturation over the whole image, use the Hue/Saturation command after applying the 
Shadow/Highlight command.
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Brightness Adjusts the brightness in a grayscale image. This adjustment is only available 
for grayscale images. Moving the Brightness slider to the left darkens a grayscale image, 
and moving the slider to the right lightens a grayscale image.

Midtone Contrast Adjusts the contrast in the midtones. Move the slider to the left to 
reduce the contrast and to the right to increase the contrast. You can also enter a value in 
the Midtone Contrast text box. A negative value reduces contrast, and a positive value 
increases contrast. An increase in Midtone Contrast adjustment produces greater contrast 
in the midtones while tending to darken the shadows and lighten the highlights.

Black Clip and White Clip Specifies how much of the shadows and highlights will be 
clipped to the new extreme shadow (level 0) and highlight (level 255) colors in the image. 
Larger values produce an image with greater contrast. Be careful of setting the clipping 
values too large, as this will lead to reduced detail in the shadows or highlights as the 
intensity values get clipped and sent to pure black or white. 

5 Click the Save As Defaults button to save and make your current settings the Shadow/
Highlights command defaults. To restore the original defaults, hold the Shift key down 
while clicking the Save As Defaults button.

Note: Different Shadow/Highlight settings can be reused by clicking the Save button to 
save the current settings to a file and later using the Load button to reload the settings. For 
more information on saving and loading settings, see “Saving and reapplying settings” on 
page 183.

6 Click OK.

Using the Match Color command (Photoshop)
The Match Color command matches colors between multiple images, between multiple 
layers, or between multiple color selections. It also lets you adjust the colors in an image 
by changing the luminance, the color range, and neutralize a color cast. The Match Color 
command only works in RGB mode.

When you’re using the Match Color command, the pointer becomes the Eyedropper 
tool . Use the Eyedropper tool on the image while making adjustments to view the 

color pixel values in the Info palette. This gives you feedback regarding the changes in 
color values as you use the Match Color command. For more information about using 
color samplers, see “Viewing the color values of pixels (Photoshop)” on page 181.

Matching colors
The Match Color command matches the colors from one image (the source image) to 
another image (the target image). This can be useful when you’re trying to make the colors 
in different photos look consistent, or when the colors of a specific element (like skin 
tones) in one image must match the colors of an element in another image. 
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In addition to matching the color between two images, the Match Color command can 
match the color between different layers in the same image.

Original images with different skin tones (above), and Match Color applied (below)

To match the color from one image to another image:

1 (Optional) Make a selection in the images you want to match. This is useful when 
matching a specific region (for example, facial skin tones) in one image with a specific 
region in another. 

If you don’t make a selection, then the Match Color command matches the overall 
image statistics between images.

2 Make the image that you want to target active, and then choose Image > 
Adjustments > Match Color. 

If you’re applying the Match Color command to a specific layer in the target image, 
make sure that layer is active when you choose the Match Color command.

3 From the Source menu in the Image Statistics area of the Match Color dialog box, 
choose the source image whose colors you’ll be matching in the target image. Choose 
None when you don’t want to reference a different image to calculate the color 
adjustment. With None chosen, the target image and the source image are the same.

If necessary, use the Layer menu to choose the layer from the source image whose colors 
you want to match. You can also choose Merged from the Layer menu to match the colors 
from all the layers in the source image.

4 If you made a selection in the image, do one or more of the following:

• In the Destination Image area, select the Ignore Selection When Applying Adjustment 
option if you’re applying the adjustment to the entire target image. This option ignores 
the selection in the target image and applies the adjustment to the entire target image.
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• In the Image Statistics area, select the Use Selection in Source to Calculate Colors option 
if you made a selection in the source image and want to use the colors in the selection 
to compute the adjustment. Deselect this option to ignore the selection in the source 
image, and use the colors from the entire source image to compute the adjustment.

• In the Image Statistics area, select the Use Selection in Target to Calculate Adjustment 
option if you made a selection in the target image and want to use the colors in the 
selection to calculate the adjustment. Deselect this options to ignore the selection in 
the target image and compute the adjustment by using the colors of entire target 
image.

5 Select the Neutralize option to automatically remove a color cast in the target image. 
Make sure the Preview option is selected so your image updates as you make adjustments.

6 Move the Luminance slider to increase or decrease the brightness in the target image. 
Or, enter a value in the Luminance text box. The maximum value is 200, the minimum is 1, 
and the default is 100.

7 Move the Color Intensity slider to adjust the color saturation in the target image. Or, 
enter a value in the Color Intensity text box. The maximum value is 200, the minimum is 1 
(which produces a grayscale image), and the default is 100.

8 Move the Fade slider to control the amount of adjustment applied to the image. 
Moving the slider to the right reduces the amount of adjustment.

9 Click OK.

To match the color from one layer in an image with the color in another layer of the 
same image:

1 (Optional) Make a selection in the layer you want to match. This is useful when 
matching a specific region (for example, facial skin tones) in one layer with a specific 
region in another. 

If you don’t make a selection, then the Match Color matches the colors of the entire source 
layer.

2 Make sure the layer you want to target (apply the color adjustment to) is active, and 
then choose Image > Adjustments > Match Color.

3 From the Source menu in the Image Statistics area of the Match Color dialog box, make 
sure the image in the Source menu is the same as the target image.

4 Use the Layer menu to choose the layer whose colors you want to match. You can also 
choose Merged from the Layer menu to match the colors from all the layers.

5 If you made a selection in the image, do one or more of the following:

• In the Destination Image area, select the Ignore Selection When Applying Adjustment 
option if you’re applying the adjustment to the entire target layer. This option ignores 
the selection in the target layer and applies the adjustment to the entire target layer.



Using Help | Contents | Index Back 209  

Adobe Photoshop CS Help Making Color and Tonal Adjustments 

Using Help | Contents | Index Back 209  

• In the Image Statistics area, select the Use Selection in Source to Calculate Colors option 
if you made a selection in the source image and want to use the color in the selection to 
compute the adjustment. Deselect the Use Selection option to ignore the selection in 
the source layer and use the colors in the entire source layer to compute the 
adjustment.

• In the Image Statistics area, select the Use Selection in Target to Calculate Adjustment 
option if you only want to use the colors in the selected area of the target layer to 
compute the adjustment. Deselect this option to ignore the selection and use the 
colors of the entire target layer to compute the adjustment.

6 Select the Neutralize option to automatically remove a color cast in the target layer. 
Make sure the Preview option is selected so your image updates as you make adjustments.

7 Move the Luminance slider to increase or decrease the brightness in the target layer. Or, 
enter a value in the Luminance text box. The maximum value is 200, the minimum is 1, and 
the default is 100.

8 Move the Color Intensity slider to adjust the range of color pixel values in the target 
layer. Or, enter a value in the Color Intensity text box. The maximum value is 200, the 
minimum is 1 (which produces a grayscale image), and the default is 100.

9 Move the Fade slider to control the amount of adjustment applied to the image. 
Moving the slider to the right reduces the amount of adjustment.

10 Click OK.

Adjusting color in an image using the Match Color command
The Match Color command can adjust the brightness, color saturation, and color balance 
in an image. The advanced algorithms in the Match Color command let you make color 
adjustments that have better control of luminance and the color components of the 
image. Since you are adjusting the color in a single image rather than matching the colors 
between two images, the image you’re correcting is both the source and the target image.

To remove a color cast using the Match Color command:

1 Choose Image > Adjustments > Match Color.

2 In the Image Statistics area, make sure None is chosen in the Source menu. The option 
specifies that the source and the target are the same image.

3 Select the Neutralize option to automatically remove a color cast. Make sure the 
Preview option is selected so your image updates as you make adjustments.

4 Move the Luminance slider to increase or decrease the brightness in the image. Moving 
the Luminance slider to the left darkens the image and moving the slider to the right 
brightens the image. The luminance control tries not to clip pixels (change them to pure 
black/no detail or pure white/no detail) in either the shadows or highlights. However, it 
may clip pixels because the pixel values in an image can only be either 8 or 16-bits.
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5 Move the Color Intensity slider to expand or reduce the color pixel values in the image. 
Moving the Color Intensity slider to the left reduces the color range and the image 
becomes monochrome. Moving the Color Intensity to the right increases the color range 
and intensifies the colors.

6 Move the Fade slider to control the amount of adjustment applied to the image. 
Moving the slider to the right reduces the amount of adjustment.

Note: You can use the Match Color controls separately to apply a single correction to the 
image. For example, only adjust the Luminance slider to brighten/darken an image 
without affecting the color. Or, you can use the controls in different combinations, 
depending on the color correction you’re making.

7 Click OK.

Color cast neutralized using the Match Color command

Saving and reusing Match Color settings
The Match Color command lets you save your settings and apply them to other images. 

To save a settings in the Match Color command:

1 In the Image Statistics area of the Match Color dialog box, click the Save Statistics 
button.

2 Name and save the settings.

To apply a saved setting:

In the Image Statistics area of the Match Color dialog box, click the Load Statistics button. 
Locate and load the saved settings file.

Using the Replace Color command (Photoshop)
The Replace Color command lets you create a mask to select specific colors in an image 
and then replace those colors. You can set the hue, saturation, and lightness of the 
selected areas. Or, you can use the Color Picker to select the replacement color. The mask 
created by the Replace Color command is temporary. 
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Making a selection and then transforming the color of the selection

To use the Replace Color command:

1 Choose Image > Adjustments > Replace Color.

2 Select a display option:

• Selection to display the mask in the preview box. Masked areas are black, and 
unmasked areas are white. Partially masked areas (areas covered with a semitrans-
parent mask) appear as varying levels of gray according to their opacity. For more 
information, see “Using channel calculations to blend layers and channels (Photoshop)” 
on page 366.

• Image to display the image in the preview box. This option is useful when you are 
working with a magnified image or have limited screen space.

3 To select the areas exposed by the mask, do one of the following:

• Use the Eyedropper tool  to click in the image or in the preview box to select the 
areas exposed by the mask. Shift-click or use the Add to Sample Eyedropper tool  to 
add areas; Alt-click (Windows), Option-click (Mac OS), or use the Subtract from Sample 
Eyedropper tool  to remove areas.

• Double-click the Selection swatch. Use the Color Picker to target a color to be replaced. 
As you select a color in the Color Picker, the mask in the preview box updates.

4 Adjust the tolerance of the mask by dragging the Fuzziness slider or entering a value. 
This controls the degree to which related colors are included in the selection.
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5 To change the color of the selected areas, do one of the following:

• Drag the Hue, Saturation, and Lightness sliders (or enter values in the text boxes).

• Double-click the Result swatch and use the Color Picker to select the replacement color.

You can also save the settings you make in the Replace Color dialog box for reuse on other 
images. For more information on saving and loading settings, see “Saving and reapplying 
settings” on page 183.

Mixing color channels (Photoshop)
The Channel Mixer command lets you create high-quality grayscale images by choosing 
the percentage contribution from each color channel. You can also create high-quality 
sepia-tone or other tinted images. Using the Channel Mixer, you can also make creative 
color adjustments not easily done with other color adjustment tools.

The Channel Mixer modifies a targeted (output) color channel using a mix of the existing 
(source) color channels in the image. Color channels are grayscale images representing 
the tonal values of the color components in an image (RGB or CMYK). With the Channel 
Mixer, you are adding or subtracting grayscale data from a source channel to the targeted 
channel. You are not adding or subtracting colors to a specific color component as you do 
with the Selective Color command. For more information about channels, see “Using 
Channels” on page 357, and for more information about the Selective Color command, 
see “Using the Selective Color command (Photoshop)” on page 214.

To create monochrome images from RGB or CMYK images:

1 In the Channels palette, select the composite color channel.

2 Do one of the following to open the Channel Mixer dialog box:

• Choose Image > Adjustments > Channel Mixer.

• Choose Layer > New Adjustment Layer > Channel Mixer. Click OK in the New Layer 
dialog box.

3 Select the Monochrome option to set Gray as the output channel. This creates a color 
image that contains only gray values. 

4 Use the Source Channels sliders to control the amount of detail and contrast in the 
images you plan to convert to grayscale. 

Before adjusting the percentages of the source channels, view how the each source 
channel affects the monochrome image. For example, in RGB, view the image with the 

Red channel set to +100% and the Green and Blue source channels set to 0%. Then, view 
the image with the Green source channel set to +100% and the other two channels set to 
0%. Finally, view the image with Blue source channel set to +100% and the other channels 
set to 0%. In adjusting the percentages of the source channels, the best results are often 
when the combined values of the source channels add up to 100%.
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5 (Optional) If you select and then deselect the Monochrome option, you can modify the 
blend of each channel separately, creating a handtinted appearance.

Handtinted effect by selecting (left)/deselecting (right) the Monochrome option

6 (Optional) Drag the slider or enter a value for the Constant option. This option adjusts 
the grayscale value of the output channel. Negative values add more black, and positive 
values add more white. A -200% value makes the output channel completely black, and a 
+200% value makes the output channel completely white. 

To mix color channels:

1 In the Channels palette, select the composite color channel.

2 Do one of the following to open the Channel Mixer dialog box:

• Choose Image > Adjustments > Channel Mixer.

• Choose Layer > New Adjustment Layer > Channel Mixer. Click OK in the New Layer 
dialog box. 

3 For Output Channel, choose the channel in which to blend one or more existing 
(source) channels. For more information, see “Using the Channels palette (Photoshop)” on 
page 357.

Choosing an output channel sets the source slider for that particular channel to 100% and 
all other channels to 0%. For example, choosing Red as the output channel sets the Source 
Channels sliders to 100% for Red, and 0% for Green and Blue (in an RGB image).

4 Drag any source channel’s slider to the left to decrease the channel’s contribution to the 
output channel or to the right to increase it, or enter a value between –200% and +200% 
in the text box. Using a negative value inverts the source channel before adding it to the 
output channel.

5 Drag the slider or enter a value for the Constant option. This option adjusts the 
grayscale value of the output channel. Negative values add more black, and positive 
values add more white. A -200% value makes the output channel completely black, 
and a +200% value makes the output channel completely white. 

You can also save the settings you make in the Channel Mixer dialog box for reuse on 
other images. For more information on saving and loading settings, see “Saving and 
reapplying settings” on page 183.
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Using the Selective Color command (Photoshop)
Selective color correction is a technique used by high-end scanners and separation 
programs to increase and decrease the amount of process colors in each of the additive 
and subtractive primary color components in an image. Even though Selective Color uses 
CMYK colors to correct an image, you can use it on RGB images as well as on images that 
will be printed.

Selective color correction is based on a table that shows the amount of each process ink 
used to create each primary color. By increasing and decreasing the amount of a process 
ink in relation to the other process inks, you can modify the amount of a process color in 
any primary color selectively—without affecting the other primary colors. For example, 
you can use selective color correction to dramatically decrease the cyan in the green 
component of an image while leaving the cyan in the blue component unaltered.

To use the Selective Color command:

1 Make sure the composite channel is selected in the Channels palette. The Selective 
Color command is available only when you’re viewing the composite channel.

2 Do one of the following:

• Choose Image > Adjustments > Selective Color.

• Choose Layer > New Adjustment Layer > Selective Color. Click OK in the New Layer 
dialog box. 

3 Choose the color you want to adjust from the Colors menu at the top of the dialog box. 
Color sets consist of the primary additive and subtractive colors plus whites, neutrals, and 
blacks.

4 For Method, select an option:

• Relative to change the existing amount of cyan, magenta, yellow, or black by its 
percentage of the total. For example, if you start with a pixel that is 50% magenta and 
add 10%, 5% is added to the magenta (10% of 50% = 5%) for a total of 55% magenta. 
(This option cannot adjust pure specular white, which contains no color components.) 

• Absolute to adjust the color in absolute values. For example, if you start with a pixel that 
is 50% magenta and add 10%, the magenta ink is set to a total of 60%. 

Note: The adjustment is based on how close a color is to one of the options in the Colors 
menu. For example, 50% magenta is midway between white and pure magenta and will 
receive a proportionate mix of corrections defined for the two colors. 

5 Drag the sliders to increase or decrease the components in the selected color.

You can also save the settings you make in the Selective Color dialog box for reuse on 
other images. For more information on saving and loading settings, see “Saving and 
reapplying settings” on page 183.
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Making quick overall adjustments to an image
The Brightness/Contrast, Auto Levels, Auto Contrast, Auto Color (Photoshop), Variations, 
and Equalize (Photoshop) commands provide a quick and simple way to make overall 
adjustments to the color and tonality in an image. Since some of these adjustments 
features are automatic, keep in mind that you can always undo a command if you don’t 
like the results.

Auto adjustments 
A. Original image B. Auto Levels applied C. Auto Contrast applied D. Auto Color applied

Using the Brightness/Contrast command
The Brightness/Contrast command lets you make simple adjustments to the tonal range 
of an image. Unlike Curves and Levels, which apply proportionate adjustments to the 
pixels in an image (nonlinear adjustment) based on whether you’re setting the black or 
white points or the gamma, this command makes the same adjustment to every pixel in 
the image (linear adjustment). The Brightness/Contrast command is not recommended for 
high-end output because it can result in a loss of image detail.

To use the Brightness/Contrast command: 

1 Do one of the following:

• Choose Image > Adjustments > Brightness/Contrast.

• Choose Layer > New Adjustment Layer > Brightness/Contrast. Click OK in the New Layer 
dialog box.

2 Drag the sliders to adjust the brightness and contrast.

A B

C D
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Dragging to the left decreases the level and to the right increases it. The number at the 
right of each slider value displays the brightness or contrast value. Values can range 
from –100 to +100. 

Using the Auto Levels command
The Auto Levels command automatically adjusts the black point and white point in an 
image. This clips a portion of the shadows and highlights in each channel and maps the 
lightest and darkest pixels in each color channel to pure white (level 255) and pure black 
(level 0). The intermediate pixel values are redistributed proportionately. As a result, using 
Auto Levels increases the contrast in an image because the pixel values are expanded 
(as opposed to being compressed, as in lower contrast images). Because Auto Levels 
adjusts each color channel individually, it may remove color or introduce color casts. 

Auto Levels gives good results in certain images with an average distribution of pixel 
values that need a simple increase in contrast. 

Note: By default, Auto Levels clips the white and black pixels by 0.5%—that is, it ignores 
the first 0.5% of either extreme when identifying the lightest and darkest pixels in the 
image. The default settings for Auto Levels can be changed in the Auto Color Correction 
Options dialog box. For more information, see “Setting auto color correction options 
(Photoshop)” on page 218.

To use the Auto Levels command:

1 Do one of the following:

• Choose Image > Adjustments > Auto Levels. The application of Auto Levels is automatic 
with this option. You cannot adjust any of the options in the following steps.

• (Photoshop) Choose Layer > New Adjustment Layer and choose either Levels or Curves. 
Click OK in the New Layer dialog box. Continue with the following steps. 

2 In the Levels or Curves dialog box, click the Option button. 

3 Select Enhance Per Channel Contrast under Algorithms in the Auto Color Correction 
Options dialog box. 

4 Adjust the amount of shadow and highlight values that are clipped, and adjust the 
target color for the midtones. 

5 Click OK in the two opened dialog boxes to apply Auto Levels. For more information on 
adjusting the settings in the Auto Color Correction Options, see “Setting auto color 
correction options (Photoshop)” on page 218.

To change the Auto Levels defaults for target colors and clipping in ImageReady:

(ImageReady) Hold down Alt (Windows) or Option (Mac OS), and click Options in the 
Levels dialog box. Enter the percentage of extreme highlight and shadow pixels to ignore, 
and click OK. A value between 0.5% and 1% is recommended.

Using the Auto Contrast command
The Auto Contrast command adjusts the overall contrast and mixture of colors in an RGB 
image automatically. Because it does not adjust channels individually, Auto Contrast does 
not introduce or remove color casts. It clips the shadow and highlight values in an image 
and then maps the remaining lightest and darkest pixels in the image to pure white (level 
255) and pure black (level 0). This makes the highlights appear lighter and shadows 
appear darker. 
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By default, when identifying the lightest and darkest pixels in an image, Auto Contrast 
clips the white and black pixels by 0.5%—that is, it ignores the first 0.5% of either extreme. 
You can change this default using the Auto Color Correction Options found in the Levels 
and the Curves dialog boxes. For information changing the defaults in Auto Contrast, 
see “Setting auto color correction options (Photoshop)” on page 218.

Auto Contrast can improve the appearance of many photographic or continuous-tone 
images. It does not improve flat-color images.

To use the Auto Contrast command:

1 Do one of the following:

• Choose Image > Adjustments > Auto Contrast. The application of Auto Contrast is 
automatic with this option. You cannot adjust any of the options in the following steps.

• (Photoshop) Choose Layer > New Adjustment Layer and choose either Levels or Curves. 
Click OK in the New Layer dialog box. Continue with the following steps.

2 In the Levels or Curves dialog box, click the Option button. 

3 Select the Enhance Monochromatic Contrast option under Algorithms in the Auto 
Color Correction Options dialog box. 

4 Adjust the amount of shadow and highlight values that are clipped, and adjust the 
target color for the midtones. 

5 Click OK in the two opened dialog boxes to apply Auto Contrast. For more information 
on adjusting the settings in the Auto Color Correction Options, see “Setting auto color 
correction options (Photoshop)” on page 218.

To change the Auto Contrast defaults for target colors and clipping in ImageReady:

(ImageReady) Hold down Alt (Windows) or Option (Mac OS), and click Options in the 
Levels dialog box. Enter the percentage of extreme highlight and shadow pixels to ignore, 
and click OK. A value between 0.5% and 1% is recommended.

Using the Auto Color command (Photoshop)
The Auto Color command adjusts the contrast and color of an image by searching the 
actual image to identify shadows, midtones, and highlights. By default, Auto Color 
neutralizes the midtones using a target color of RGB 128 gray, and clips the shadows and 
highlight pixels by 0.5%. You can change these defaults in the Auto Color Correction 
Options dialog box. For more information on adjusting the auto color correction settings, 
see “Setting auto color correction options (Photoshop)” on page 218.

To use the Auto Color command:

1 Do one of the following:

• Choose Image > Adjustments > Auto Color. The application of Auto Color is automatic 
with this option. You cannot adjust any of the options in the following steps.

• Choose Layer > New Adjustment Layer and choose either Levels or Curves. Click OK in 
the New Layer dialog box. Continue with the following steps.

2 In the Levels or Curves dialog box, click the Option button.

3 Select the Find Dark & Light option under Algorithms in the Auto Color Correction 
Options dialog box. 
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4 Select the Snap Neutral Midtones option. 

5 Adjust the amount of shadow and highlight values that are clipped, and adjust the 
target color for the midtones. 

6 Click OK in the two opened dialog boxes to apply Auto Color. For more information on 
adjusting the settings in the Auto Color Correction Options, see “Setting auto color 
correction options (Photoshop)” on page 218.

Setting auto color correction options (Photoshop)
The Auto Color Correction Options control tonal and color corrections applied by Auto 
Color, Auto Levels, Auto Contrast, and the Auto option in both Levels and Curves. The auto 
color correction options let you specify shadow and highlight clipping percentages, and 
assign color values to shadows, midtones, and highlights.

You can apply the settings during a single use of the Levels dialog box or Curves dialog 
box, or you can save the settings as defaults when applying Auto Levels, Auto Contrast, 
Auto Color, and the Auto option in Levels and Curves.

Auto Color Correction Options dialog box 
A. Auto Contrast option B. Auto Levels option C. Auto Color option D. Set target colors, 
black point, and white point

To set color correction settings:

1 Click the Options button in the Levels dialog box or Curves dialog box.

2 Specify the algorithm you want Photoshop to use to adjust the overall tonal range of an 
image:

• Enhance Monochromatic Contrast clips all channels identically. This preserves the 
overall color relationship while making highlights appear lighter and shadows appear 
darker. The Auto Contrast command uses this algorithm.

• Enhance Per Channel Contrast maximizes the tonal range in each channel to produce a 
more dramatic correction. Because each channel is adjusted individually, Enhance Per 
Channel Contrast may remove or introduce color casts. The Auto Levels command uses 
this algorithm.

• Find Dark & Light Colors finds the average lightest and darkest pixels in an image and 
uses them to maximize contrast while minimizing clipping. The Auto Color command 
uses this algorithm.

A
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3 Select Snap Neutral Midtones if you want Photoshop to find an average nearly neutral 
color in an image and then adjust the gamma values to make the color neutral. The Auto 
Color command uses this algorithm.

4 To specify how much to clip black and white pixels, enter percentages in the Clip text 
boxes. A value between 0.0% and 1% is recommended.

By default, Photoshop clips the black and white pixels by 0.1%—that is, it ignores the first 
0.1% of either extreme when identifying the lightest and darkest pixels in the image. Due 
to the better output quality of today’s scanners and digital cameras, these default clipping 
percentages may be too high. 

5 To assign (target) color values to the darkest, neutral, and lightest areas of an image, 
click a color swatch. For guidelines on setting color values, see “Setting highlight and 
shadow target values (Photoshop)” on page 194.

6 Do one of the following:

• To use the settings in the current Levels or Curves dialog box, click OK. If you subse-
quently click the Auto button, Photoshop will reapply the same settings to the image.

• To save the settings as the default, select Save as Defaults, and then click OK. The next 
time you open the Levels or Curves dialog box, you can apply the same setting by 
clicking the Auto button. The default clipping percentages are also used by the Auto 
Level, Auto Contrast, and Auto Color commands.

Note: When saving the Auto Color Correction Options as defaults for Auto Color, Auto 
Levels, and Auto Contrast, it does not matter what algorithm you select in step 2. The three 
auto-correction commands only use values you set for the target colors and clipping 
values. The only exception is that the Auto Color command also uses the Snap Neutral 
Midtones option.

Using the Variations command
The Variations command lets you adjust the color balance, contrast, and saturation of an 
image by showing you thumbnails of alternatives. 

This command is most useful for average-key images that don’t require precise color 
adjustments. It does not work on indexed-color images or 16-bit-per-channel images 
(Photoshop).

To use the Variations command:

1 Choose Image > Adjustments > Variations.

The two thumbnails at the top of the dialog box show the original selection (Original) and 
the selection with its currently selected adjustments (Current Pick). When you first open 
the dialog box, these two images are the same. As you make adjustments, the Current Pick 
image changes to reflect your choices.

2 Select the Show Clipping option if you want to display a neon preview of areas in the 
image that will be clipped—converted to pure white or pure black— by the adjustment. 
Clipping can result in undesirable color shifts, as distinct colors in the original image are 
mapped to the same color. Clipping does not occur when you adjust midtones. 

Note: Clipped colors are not the same as out-of-gamut colors.
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3 Select what to adjust in the image:

• Shadows, Midtones, or Highlights to indicate whether you want to adjust the dark, 
middle, or light areas.

• Saturation to change the degree of hue in the image. If you exceed the maximum 
saturation for a color, it may be clipped.

4 Drag the Fine/Coarse slider to determine the amount of each adjustment. Moving the 
slider one tick mark doubles the adjustment amount. 

5 Adjust the color and brightness:

• To add a color to the image, click the appropriate color thumbnail.

• To subtract a color, click the thumbnail for its opposite color. (See “Using the Color 
Balance command (Photoshop)” on page 199.) For example, to subtract cyan, click the 
More Red thumbnail.

• To adjust brightness, click a thumbnail on the right side of the dialog box.

The effects of clicking the thumbnails are cumulative. For example, clicking the More Red 
thumbnail twice will apply the adjustment twice. Each time you click a thumbnail, the 
other thumbnails change. The three Current Pick thumbnails always reflect the current 
choices.

You can also save the settings you make in the Variations dialog box for reuse on other 
images. For more information on saving and loading settings, see “Saving and reapplying 
settings” on page 183.

Using the Equalize command (Photoshop)
The Equalize command redistributes the brightness values of the pixels in an image so 
that they more evenly represent the entire range of brightness levels. When you apply this 
command, Photoshop finds the brightest and darkest values in the composite image and 
remaps them so that the brightest value represents white and the darkest value repre-
sents black. Photoshop then attempts to equalize the brightness—that is, to distribute the 
intermediate pixel values evenly throughout the grayscale. 

You might use the Equalize command when a scanned image appears darker than the 
original and you want to balance the values to produce a lighter image. Using Equalize 
together with the Histogram palette lets you see before-and-after brightness compar-
isons.

To use the Equalize command: 

1 (Optional) Select an area of the image to equalize. 

2 Choose Image > Adjustments > Equalize.

3 If you selected an area of the image, select what to equalize in the dialog box, and 
click OK:

• Equalize Selected Area Only to evenly distribute only the selection’s pixels.

• Equalize Entire Image Based on Selected Area to evenly distribute all image pixels 
based on those in the selection. 
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Applying special color effects to images
The Desaturate, Invert, Equalize (Photoshop), Threshold (Photoshop), and Posterize 
(Photoshop) commands change colors or brightness values in an image but are typically 
used for enhancing color and producing special effects, rather than for correcting color.

Special color effects 
A. Original B. Desaturate C. Invert D. Equalize E. Threshold F. Posterize G. Gradient Map

Note: You can also make color adjustments by blending colors from different channels. 
(See “Mixing color channels (Photoshop)” on page 212.)

Using the Desaturate command 
The Desaturate command converts a color image to a grayscale image in the same color 
mode. For example, it assigns equal red, green, and blue values to each pixel in an RGB 
image to make it appear grayscale. The lightness value of each pixel does not change.

This command has the same effect as setting Saturation to –100 in the Hue/Saturation 
dialog box.

Note: If you are working with a multilayer image, Desaturate converts the selected layer 
only.

To use the Desaturate command:

Choose Image > Adjustments > Desaturate.
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Using the Invert command 
The Invert command inverts the colors in an image. You might use this command as part 
of the process to make an edge mask for applying sharpening and other adjustments to 
selected areas of an image. 

Note: Because color print film contains an orange mask in its base, the Invert command 
cannot make accurate positive images from scanned color negatives. Be sure to use the 
proper settings for color negatives when scanning film on slide scanners.

When you invert an image, the brightness value of each pixel in the channels is converted 
to the inverse value on the 256-step color-values scale. For example, a pixel in a positive 
image with a value of 255 is changed to 0, and a pixel with a value of 5 to 250.

To use the Invert command:

Do one of the following:

• Choose Image > Adjustments > Invert.

• (Photoshop) Choose Layer > New Adjustment Layer > Invert. Click OK in the New Layer 
dialog box. 

Using the Threshold command (Photoshop)
The Threshold command converts grayscale or color images to high-contrast, black-and-
white images. You can specify a certain level as a threshold. All pixels lighter than the 
threshold are converted to white; all pixels darker are converted to black. The Threshold 
command is useful for determining the lightest and darkest areas of an image.

To use the Threshold command to convert images to black and white: 

1 Do one of the following:

• Choose Image > Adjustments > Threshold.

• Chose Layer > New Adjustment Layer > Threshold. Click OK in the New Layer dialog box. 

The Threshold dialog box displays a histogram of the luminance levels of the pixels in the 
current selection.

2 Drag the slider below the histogram until the threshold level you want appears at the 
top of the dialog box, and click OK. As you drag, the image changes to reflect the new 
threshold setting.

To use the Threshold command to identify representative highlights and shadows:

1 Open the Threshold dialog box. (See “Making color adjustments” on page 180.)

2 Select Preview.

3 To identify a representative highlight, drag the slider to the far right until the image 
becomes pure black. Drag the slider slowly toward the center until some solid white areas 
appear in the image, and place a color sampler on one of the areas. 

4 To identify a representative shadow, drag the slider to the far left until the image 
becomes pure white. Drag the slider slowly toward the center until some solid black areas 
appear in the image, and place a color sampler on one of the areas. 

5 Click Cancel to close the Threshold dialog box without applying changes to the image.

You can use the Info palette readouts of the two color samplers to determine your 
highlight and shadow values.
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Using the Posterize command (Photoshop)
The Posterize command lets you specify the number of tonal levels (or brightness values) 
for each channel in an image and then maps pixels to the closest matching level. For 
example, choosing two tonal levels in an RGB image gives six colors: two for red, two for 
green, and two for blue.

This command is useful for creating special effects, such as large, flat areas in a photo-
graph. Its effects are most evident when you reduce the number of gray levels in a 
grayscale image. But it also produces interesting effects in color images.

If you want a specific number of colors in your image, convert the image to grayscale 
and specify the number of levels you want. Then convert the image back to the 

previous color mode, and replace the various gray tones with the colors you want.

To use the Posterize command:

1 Choose Image > Adjustments > Posterize.

2 Enter the number of tonal levels you want, and click OK.

Using the Gradient Map command (Photoshop)
The Gradient Map command maps the equivalent grayscale range of an image to the 
colors of a specified gradient fill. If you specify a two-color gradient fill, for example, 
shadows in the image map to one of the endpoint colors of the gradient fill, highlights 
map to the other endpoint color, and midtones map to the gradations in between.

To use the Gradient Map command:

1 Do one of the following:

• Choose Image > Adjustments > Gradient Map.

• Choose Layer > New Adjustment Layer > Gradient Map. Click OK in the New Layer 
dialog box. 

2 Specify the gradient fill you want to use:

• To choose from a list of gradient fills, click the triangle to the right of the gradient fill 
displayed in the Gradient Map dialog box. Click to select the desired gradient fill, and 
then click in a blank area of the dialog box to dismiss the list. For information on 
customizing the gradient fill list, see  “Managing libraries with the Preset Manager 
(Photoshop)” on page 52.

• To edit the gradient fill currently displayed in the Gradient Map dialog box, click the 
gradient fill. Then modify the existing gradient fill or create a new gradient fill using the 
Gradient Editor. (See “Creating smooth gradient fills” on page 339.)

By default, the shadows, midtones, and highlights of the image are mapped respectively 
to the starting (left) color, midpoint, and ending (right) color of the gradient fill.

3 Select either, none, or both of the Gradient Options:

• Dither adds random noise to smooth the appearance of the gradient fill and reduce 
banding effects.

• Reverse switches the direction of the gradient fill, reversing the gradient map.
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Sharpening images
When we view images, not only does our vision respond to color and tonality but also to 
the edges that define the shape of objects. Sharpening enhances the edge definition in an 
image. Whether your images come from a digital camera or a scanner, most images can 
benefit from sharpening. The degree of sharpening needed varies depending on the 
quality of the digital camera or scanner. Keep in mind that sharpening will not correct the 
problems of a severely blurred image. 

About the Photoshop sharpening filters
Use the Unsharp Mask (USM) filter to sharpen your images. The controls provided by this 
filter make it the best choice for sharpening. Although Photoshop also has the Sharpen, 
Sharpen Edges, and Sharpen More filter options, these filters are automatic and do not 
provide controls and options. You might use these filters for producing creative effects in 
your image. For more information on the Sharpen filters, see “Sharpen filters” on page 428, 
and for more information on using the Unsharp Mask filter, see “Using the Unsharp Mask 
filter” on page 224.

Photoshop lets you sharpen your entire image or sharpen part of your image by using a 
selection or mask. Since the Unsharp Mask filter can only be applied to one layer at a time, 
you might need to merge layers or flatten your file to sharpen all image layers in a multi-
layered file. For more information on sharpening only part of your image, see “Selective 
sharpening” on page 226.

Note: The name, Unsharp Mask, makes the filter seem like an unintuitive choice for sharp-
ening an image. The term comes from a darkroom technique used in traditional film-
based photography. The effect of a sharpened edge can be produced by sandwiching a 
photographic negative and a slightly blurred and underexposed copy negative in the 
enlarger. Then the photographic paper is exposed through the sandwiched negatives. 

Using the Unsharp Mask filter
The Unsharp Mask does not detect edges in an image. Instead, it locates pixels that differ 
in value from surrounding pixels by the threshold you specify and increases the pixels’ 
contrast by the amount you specify. So, for neighboring pixels specified by the threshold, 
the lighter pixels get even lighter and the darker pixels get even darker based on the 
specified amount. 

In addition, you specify the radius of the region to which each pixel is compared. The 
greater the radius, the larger the edge effects.

Original image and Unsharp Mask applied
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The degree of sharpening applied to an image is often a matter of personal choice. 
However, over-sharpening an image produces an unattractive halo effect around the 
edges.

Over-sharpening an image produces a halo effect around the edges.

The effects of the Unsharp Mask filter are more pronounced on-screen than in high-
resolution output. If your final destination is print, experiment to determine what settings 
work best for your image.

For information on other filters for sharpening images, see “Sharpen filters” on page 428.

To use Unsharp Mask to sharpen an image: 

1 (Optional) If your image is multilayered, select the layer with the image you want 
sharpened. The Unsharp Mask can only be applied to one layer at a time, even if layers are 
linked or grouped. You can merge the layers before applying the Unsharp Mask filter. For 
more information on merging layers, see “Merging and stamping layers” on page 383.

2 Choose Filter > Sharpen > Unsharp Mask. Make sure the Preview option is selected.

Click the image in the preview window and hold down the mouse to see how the 
image looks without the sharpening. Drag in the preview window to see different 

parts of the image, and click + or – to zoom in or out.

Although there is a preview window in the Unsharp Mask dialog box, it’s best to move the 
dialog box so you can preview the effects of the filter in the document window.

3 Drag the Radius slider or enter a value to determine the number of pixels surrounding 
the edge pixels that affect the sharpening. The greater the radius value, the wider the 
edge effects. And the wider the edge effects, the more obvious the sharpening.

Adjusting the Radius value depends on the subject matter of the image, the size that the 
image will be reproduced at, and output method. For high-resolution images, a Radius 
between 1 and 2 is usually recommended. A lower value sharpens only the edge pixels, 
whereas a higher value sharpens a wider band of pixels. This effect is much less noticeable 
in print than on-screen, because a 2-pixel radius represents a smaller area in a high-
resolution printed image. 

4 Do one of the following:

• Drag the Amount slider or enter a value to determine how much to increase the 
contrast of pixels. For high-resolution printed images, an amount between 150% and 
200% is usually recommended. 
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• Drag the Threshold slider or enter a value to determine how different the sharpened 
pixels must be from the surrounding area before they are considered edge pixels and 
sharpened by the filter. For instance, a threshold of 4 will affect all pixels that have tonal 
values that are different (on a scale of 0 to 255) by 4 or greater. So, if adjacent pixels 
have tonal values of 128 and 129, they will not be affected. To avoid introducing noise 
or posterization (in images with fleshtones, for example), use an edge mask or try 
experimenting with Threshold values between 2 and 20. The default Threshold value (0) 
sharpens all pixels in the image. For more information on using an edge mask for 
selective sharpening, see “Selective sharpening” on page 226.

If applying Unsharp Mask makes already bright colors appear overly saturated, 
convert the image to Lab mode and apply the filter to the Lightness channel only. 

This sharpens the image without affecting the color components.

Selective sharpening
You can sharpen part of your image instead of the entire image by using a mask or a 
selection. This is useful when you want to prevent certain parts of your image from being 
sharpened. For example, you can use an edge mask with the Unsharp Mask filter on a 
portrait to keep the facial skin soft looking but sharpen features like the eyes, mouth, nose, 
and outline of the head.

Using an edge mask to apply the Unsharp Mask only to specific features in a portrait

To sharpen a selection:

1 With the image layer selected in the Layers palette, draw a selection.

2 Choose Filter > Sharpen > Unsharp Mask. Adjust the options and click OK. For infor-
mation on setting the Unsharp Mask options, see “Using the Unsharp Mask filter” on 
page 224.

The image area within the selection will be sharpened, leaving the rest of the image 
untouched.

To selectively sharpen an image using an edge mask:

1 Create an edge mask. 
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There are many ways to create an edge mask. For more information on creating masks, 
see “About masks (Photoshop)” on page 251 or experiment with the following method:

• Open the Channels palette and select the channel that displays the grayscale image 
with the greatest contrast in the document window. Often, the green or the red 
channel will be the one you select.

Showing a channel with the greatest contrast

• Duplicate the selected channel.

• With the duplicate channel selected, choose Filter > Stylize > Find Edges. 

• Choose Image > Adjustments > Invert to invert the image.

Find Edges filter applied and image inverted

• With the inverted image still selected, choose Filter > Other > Maximum. Set the radius 
to a low number and click OK to thicken the edges and randomize the pixels.

• Choose Filter > Noise > Median. Set the radius to a low number and click OK. This 
averages the neighboring pixels.

• Choose Filter > Blur > Gaussian Blur to feather the edges.

Note: The Maximum, the Median, and the Gaussian Blur filters soften the edge mask so 
the sharpening effects will blend better in the final image. Although this procedure recom-
mends using all three filters, you can experiment using only one or two.
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• Choose Image > Adjustment > Levels and set the black point high to get rid of random 
pixels. If necessary, you can also paint with black to retouch the final edge mask.

Set the black point high in Levels to eliminate random pixels in the edge mask

2 In the Channels palette, Ctrl-click (Windows) or Command-click (Mac OS) the duplicate 
channel to make the edge mask a selection.

3 In the Layers palette, select the image layer. Make sure the selection is visible on the 
image.

4 Choose Select > Inverse.

5 With the selection active on the image layer, choose Filter > Sharpen > Unsharp Mask. 
Set the desired options and click OK. For more information on setting the Unsharp Mask 
options, see “Using the Unsharp Mask filter” on page 224.

Note: You can create an action to conveniently apply all the steps in the procedure.
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Selecting

About selections
There are separate sets of tools to make selections of bitmap and vector data. For example, 
to select bitmap pixels, you can use the marquee tools or the lasso tools. 

To select vector data, you can use the pen or shape tools, which produce precise 
outlines called paths. You can convert paths to selections or convert selections to paths. 
(See  “Converting between paths and selection borders (Photoshop)” on page 310.)

Using the Select menu
You can use commands in the Select menu to select all pixels, to deselect, or to reselect. 

To select all pixels on a layer within the canvas boundaries:

1 Select the layer in the Layers palette.

2 Choose Select > All. 

To deselect selections:

Do one of the following:

• Choose Select > Deselect.

• If you are using the Rectangle Marquee tool, the Rounded Rectangle Marquee tool 
(ImageReady), the Elliptical Marquee tool, or the Lasso tool, click anywhere in the 
image outside the selected area.

To reselect the most recent selection:

Choose Select > Reselect.

Using the marquee tools
The marquee tools let you select rectangles, ellipses, rounded rectangles (ImageReady), 
and 1-pixel rows and columns. By default, a selection border is dragged from its corner.

To use the marquee tools:

1 Select a marquee tool:

• Rectangle Marquee  to make a rectangular selection. 

• (ImageReady) Rounded Rectangle Marquee  to select a rounded rectangle such as a 
Web page button.

• Elliptical Marquee  to make an elliptical selection.

• Single Row  or Single Column  Marquee to define the border as a 1-pixel-wide row or 
column. 

2  In the options bar, specify whether to add a new selection , add to a selection , 
subtract from a selection , or select an area intersected by other selections .
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3 Specify a feathering setting in the options bar. Turn anti-aliasing on or off for the 
Rounded Rectangle tool or the Elliptical Marquee tool. (See “Softening the edges of a 
selection” on page 239.)

4 For the Rectangle tool, the Rounded Rectangle tool, or the Elliptical Marquee tool, 
choose a style in the options bar:

• Normal to determine marquee proportions by dragging. 

• Fixed Aspect Ratio to set a height-to-width ratio. Enter values (decimal values are valid 
in Photoshop) for the aspect ratio. For example, to draw a marquee twice as wide as it is 
high, enter 2 for the width and 1 for the height. 

• Fixed Size to specify set values for the marquee’s height and width. Enter pixel values in 
whole numbers. Keep in mind that the number of pixels needed to create a 1-inch 
selection depends on the resolution of the image. (See “Understanding image size and 
resolution” on page 62.)

5 For aligning your selection to guides, a grid, slices, or document bounds, do one of the 
following to snap your selection:

• (Photoshop) Choose View > Snap, or choose View > Snap To and choose a command 
from the submenu. The marquee selection can snap to a document boundary and 
more than one Photoshop Extra. This is controlled in the Snap To submenu. (See “Using 
the Snap command” on page 246.)

• (ImageReady) Choose View > Snap To > Guides.

6 Do one of the following to make a selection:

• With the Rectangle tool, the Rounded Rectangle tool, or the Elliptical Marquee tool, 
drag over the area you want to select. Hold down Shift as you drag to constrain the 
marquee to a square or circle (release the mouse button before Shift to keep the shape 
contsrained). To drag a marquee from its center, hold down Alt (Windows) or Option 
(Mac OS) after you begin dragging.

Dragging a marquee from the corner of an image (left), and from the center of an image (right)

• With the single row or single column marquee, click near the area you want to select, 
and then drag the marquee to the exact location. If no marquee is visible, increase the 
magnification of your image view.

To reposition a rectangle, rounded rectangle, or Elliptical Marquee, first drag to create 
the border, keeping the mouse button depressed. Then hold down the spacebar and 

continue to drag. Release the spacebar, but keep the mouse button depressed, if you need 
to continue adjusting the selection border. 
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Using the Lasso, Polygonal Lasso, and Magnetic Lasso tools
The Lasso tool  and the Polygonal Lasso tool  let you draw both straight-edged and 
freehand segments of a selection border. With the Magnetic Lasso tool (Photoshop), the 
border snaps to the edges of defined areas in the image. 

The Magnetic Lasso tool is especially useful for quickly selecting objects with complex 
edges set against high-contrast backgrounds.

To use the Lasso tool:

1 Select the Lasso tool , and select options. (See “Setting options for the Lasso, 
Polygonal Lasso, and Magnetic Lasso tools” on page 232.)

2 Drag to draw a freehand selection border. 

3 To draw a straight-edged selection border, hold down Alt (Windows) or Option 
(Mac OS), and click where segments should begin and end. You can switch between 
drawing freehand and straight-edged segments. 

4 To erase recently drawn segments, hold down the Delete key until you’ve erased the 
fastening points for the desired segment.

5 To close the selection border, release the mouse without holding down Alt (Windows) 
or Option (Mac OS).

To use the Polygonal Lasso tool:

1 Select the Polygonal Lasso tool , and select options. (See “Setting options for the 
Lasso, Polygonal Lasso, and Magnetic Lasso tools” on page 232.)

2 Click in the image to set the starting point.

3 Do one or more of the following:

• To draw a straight segment, position the pointer where you want the first straight 
segment to end, and click. Continue clicking to set endpoints for subsequent segments.

• To draw a freehand segment, hold down Alt (Windows) or Option (Mac OS), and drag. 
When finished, release Alt or Option and the mouse button.

• To erase recently drawn straight segments, press the Delete key.

4 Close the selection border:

• Position the Polygonal Lasso tool pointer over the starting point (a closed circle appears 
next to the pointer), and click.

• If the pointer is not over the starting point, double-click the Polygonal Lasso tool 
pointer, or Ctrl-click (Windows) or Command-click (Mac OS).

To use the Magnetic Lasso tool (Photoshop):

1 Select the Magnetic Lasso tool , and select options. (See “Setting options for the 
Lasso, Polygonal Lasso, and Magnetic Lasso tools” on page 232.)

2 Click in the image to set the first fastening point. Fastening points anchor the selection 
border in place.
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3 To draw a freehand segment, move the pointer along the edge you want to trace. 
(You can also drag with the mouse button depressed.) 

The most recent segment of the selection border remains active. As you move the pointer, 
the active segment snaps to the strongest edge in the image, based on the detection 
Width set in the options bar. Periodically, the Magnetic Lasso tool adds fastening points to 
the selection border to anchor previous segments.

4 If the border doesn’t snap to the desired edge, click once to add a fastening point 
manually. Continue to trace the edge, and add fastening points as needed.

Fastening points anchor selection border to edges

5 To switch temporarily to the other lasso tools, do one of the following:

• To activate the Lasso tool, hold down Alt (Windows) or Option (Mac OS), and drag with 
the mouse button depressed.

• To activate the Polygonal Lasso tool, hold down Alt (Windows) or Option (Mac OS), and 
click.

6 To erase recently drawn segments and fastening points, press the Delete key until 
you’ve erased the fastening points for the desired segment. 

7 Close the selection border:

• To close the border with a freehand Magnetic segment, double-click, or press Enter or 
Return.

• To close the border with a straight segment, hold down Alt (Windows) or Option 
(Mac OS), and double-click.

• To close the border, drag back over the starting point and click.

Setting options for the Lasso, Polygonal Lasso, and Magnetic 
Lasso tools
The Lasso tool options let you customize how the different lasso tools detect and select 
edges.

To set options for the lasso tools:

1 If needed, select the tool.

2  In the options bar, specify whether you want to create a new selection , add to an 
existing selection , subtract from a selection , or select an area intersected by other 
selections .
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3 Specify feather and anti-aliasing options. (See “Softening the edges of a selection” on 
page 239.)

4 For the Magnetic Lasso tool (Photoshop), set any of these options:

• To specify a detection width, enter a pixel value for Width. The Magnetic Lasso tool 
detects edges only within the specified distance from the pointer.

• To specify the lasso’s sensitivity to edges in the image, enter a value between 1% and 
100% for Edge Contrast. A higher value detects only edges that contrast sharply with 
their surroundings; a lower value detects lower-contrast edges.

• To specify the rate at which the lasso sets fastening points, enter a value between 0 and 
100 for Frequency. A higher value anchors the selection border in place more quickly. 

On an image with well-defined edges, try a higher width and higher edge contrast, 
and trace the border roughly. On an image with softer edges, try a lower width and 

lower edge contrast, and trace the border more precisely.

• To change the lasso cursor to indicate the lasso width, press the Caps Lock key on the 
keyboard. Change the cursor while the tool is selected but not in use.

• If you are working with a stylus tablet, select or deselect the Stylus Pressure option. 
When the option is selected, an increase in stylus pressure will cause the edge width to 
decrease. 

While creating a selection, you can press ] to increase the Magnetic Lasso edge width 
by 1 pixel; press [ to decrease the width by 1 pixel. 

Using the Magic Wand tool
The Magic Wand tool  lets you select a consistently colored area (for example, a red 
flower) without having to trace its outline. You specify the color range, or tolerance, for the 
Magic Wand tool’s selection.

Note: You cannot use the Magic Wand tool on an image in Bitmap mode.

To use the Magic Wand tool:

1 Select the Magic Wand tool .

2 In the options bar, specify whether to add a new selection , add to an existing 
selection , subtract from a selection , or select an area intersected by other selections 

. The Magic Wand tool’s cursor changes depending on which option is selected.

3 For Tolerance, enter a value in pixels, ranging from 0 to 255. Enter a low value to select 
the few colors very similar to the pixel you click, or enter a higher value to select a broader 
range of colors. 

4 To define a smooth edge, select Anti-aliased. (See “Softening the edges of a selection” 
on page 239.)

5 To select only adjacent areas using the same colors, select Contiguous. Otherwise, all 
pixels using the same colors will be selected.
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6 To select colors using data from all the visible layers, select Use All Layers. Otherwise, 
the Magic Wand tool selects colors from the active layer only. 

7 In the image, click the color you want to select. If Contiguous is selected, all adjacent 
pixels within the tolerance range are selected. Otherwise, all pixels in the tolerance range 
are selected.

Using the Color Range command (Photoshop)
The Color Range command selects a specified color or color subset within an existing 
selection or an entire image. If you want to replace a selection, be sure to deselect every-
thing before applying this command. 

To refine an existing selection, use the Color Range command repeatedly to select a 
subset of colors. For example, to select the green areas in a cyan selection, select Cyans in 
the Color Range dialog box, and click OK. Then reopen the Color Range dialog box, and 
select Greens. (The results are subtle because the technique selects parts of colors within a 
color mix.) 

To select a color range using sampled colors:

1 Choose Select > Color Range. 

2 For Select, choose the Sampled Colors tool .

3 Select one of the display options:

• Selection to preview only the selection as you build it.

• Image to preview the entire image. For example, you might want to sample from a part 
of the image that isn’t on-screen.

To toggle between the Image and Selection previews in the Color Range dialog box, 
press Ctrl (Windows) or Command (Mac OS). 

4 Position the pointer over the image or preview area, and click to sample the colors you 
want included. 

Sampling color
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5 Adjust the range of colors using the Fuzziness slider or by entering a value. To decrease 
the range of colors selected, decrease the value. The Fuzziness option partially selects 
pixels by controlling the degree to which related colors are included in the selection 
(whereas the Tolerance option for the Magic Wand tool and the paint bucket options 
increases the range of colors that are fully selected). 

Increasing Fuzziness expands selection

6 Adjust the selection:

• To add colors, select the plus eyedropper, and click in the preview area or image.

• To remove colors, select the minus eyedropper, and click in the preview area or image.

To activate the plus eyedropper temporarily, hold down Shift. Hold down Alt 
(Windows) or Option (Mac OS) to activate the minus eyedropper. 

7 To preview the selection in the image window, choose an option for Selection Preview:

• None to display no preview in the image window.

• Grayscale to display the selection as it would appear in a grayscale channel. 

• Black Matte to display the selection in color against a black background. 

• White Matte to display the selection in color against a white background.

• Quick Mask to display the selection using the current quick mask settings. (See “Using 
Quick Mask mode to make selections (Photoshop)” on page 252.)

8 To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and 
click Reset.

To select a color range using preset colors:

1 Choose Select > Color Range. 

2 For Select, choose a color or tonal range. The Out-of-Gamut option works only on RGB 
and Lab images. (An out-of-gamut color is an RGB or Lab color that cannot be printed 
using process color printing.)

3 Click Selection to display the selected areas in the preview area. 

4 To preview the selection in the image window, choose an option for Selection Preview:

• None to display no preview in the image window.

• Grayscale to display the selection as it would appear in a grayscale channel. 

• Black Matte to display the selection in color against a black background. 

• White Matte to display the selection in color against a white background.

• Quick Mask to display the selection using the current quick mask settings. (See “Using 
Quick Mask mode to make selections (Photoshop)” on page 252.)
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5 To revert to the original selection, hold down Alt (Windows) or Option (Mac OS), and 
click Reset.

Note: If a message appears stating “No pixels are more than 50% selected,” the selection 
border will not be visible. You may have selected a color, such as red, when the image 
didn’t contain the fully saturated color.

To save and load color range settings: 

Use the Save and Load buttons in the Color Range dialog box to save and reuse the 
current settings.

Creating selections from slices (ImageReady)
If you create a slice in ImageReady, it can be converted into a selection.

To create a selection from a slice:

1 Select a slice. (See “Selecting slices” on page 478.)

2 Choose Select > Create Selection from Slice.

Adjusting pixel selections
You can adjust and refine your pixel selections using the selection tools and a variety of 
commands in the Select menu. 

In addition, you can apply geometric transformations to change the shape of a selection 
border. (See “Transforming objects” on page 265.)

Moving, hiding, or inverting a selection
You can move a selection border around an image, hide a selection border, and invert a 
selection so that the previously unselected part of the image is selected.

To move a selection border: 

1 Using any selection tool, select new selection  from the options bar, and position the 
pointer inside the selection border. The pointer changes to indicate that you can move the 
selection .

2 Drag the border to enclose a different area of the image. You can drag a selection 
border partly beyond the canvas boundaries. When you drag it back, the original border 
reappears intact. You can also drag the selection border to another image window.

Original selection border (left), and selection border moved (right)
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To control the movement of a selection: 

• To constrain the direction to multiples of 45°, begin dragging, and then hold down Shift 
as you continue to drag. 

• To move the selection in 1-pixel increments, use an arrow key. 

• To move the selection in 10-pixel increments, hold down Shift, and use an arrow key.

To hide or show selection edges:

Do one of the following:

• Choose View > Extras. This command also shows or hides (Photoshop) selection edges, 
grids, guides, target path, slices, and annotations, or (ImageReady) selection edges, 
layer edges, grids, guides, smart guides, slices, auto slices, image maps, and text selec-
tions. (See “Working with Extras” on page 45.)

• Choose View > Show > Selection Edges. This toggles the view of the selection edges 
and affects the current selection only. The selection edges reappear when you make a 
different selection.

To select the unselected parts of an image:

Choose Select > Inverse.

You can use this option to select an object placed against a solid-colored background. 
Select the background using the Magic Wand tool and then inverse the selection. 

Adjusting selections manually
You can use the selection tools to add to or subtract from existing pixel selections. 

Before manually adding to or subtracting from a selection, set the feather and 
anti-aliased values in the options bar to the same settings used for the original selection. 
(See “Softening the edges of a selection” on page 239.)

To add to a selection or select an additional area:

1 Make a selection.

2 Using any selection tool, do one of the following 

• Select the Add to Selection option  in the options bar, and drag.

• Hold down Shift, and drag to add another selection.

A plus sign appears next to the pointer when you’re adding to a selection.

To subtract from a selection:

1 Make a selection.

2 Using any selection tool, do one of the following:

• Select the Subtract from Selection option  in the options bar, and drag to intersect 
with other selections.

• Hold down Alt (Windows) or Option (Mac OS), and drag to subtract another selection.

A minus sign appears next to the pointer when you’re subtracting from a selection.
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To select only an area intersected by other selections:

1 Make a selection.

2 Using any selection tool, do one of the following:

• Select the Intersect with Selection option  in the options bar, and drag.

• Hold down Alt+Shift (Windows) or Option+Shift (Mac OS) and drag over the portion of 
the original selection that you want to select.

An “x” appears next to the pointer when you’re selecting an intersected area.

Intersected selections 

Adjusting selections numerically
You can use commands in the Select menu to increase or decrease the pixels in an existing 
selection and to clean up stray pixels left inside or outside a color-based selection.

To expand or contract a selection by a specific number of pixels:

1 Choose Select > Modify > Expand or Contract. 

2 For Expand By or Contract By, enter a pixel value between 1 and 100, and click OK.

The border is increased or decreased by the specified number of pixels. Any portion of the 
selection border running along the canvas’s edge is unaffected.

To frame an existing selection with a new selection:

1 Use a selection tool to make a selection.

2 Choose Select > Modify > Border. 

3 Enter a value between 1 and 200 pixels for the border width of the new selection, and 
click OK. 

The new selection frames the original selected area.

Original selection (left), and after Border command: 5 pixels (right)
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The Border command creates an anti-aliased selection. (See “Softening the edges of a 
selection” on page 239.) To paint a hard-edged border around a selection, use the Stroke 
command. (See “Filling and stroking selections and layers” on page 344.)

To expand a selection to include areas with similar color:

Do one of the following:

• (Photoshop) Choose Select > Grow to include all adjacent pixels falling within the 
tolerance range specified in the magic wand options. 

• Choose Select > Similar to include pixels throughout the image, not just adjacent ones, 
falling within the tolerance range. 

To increase the selection in increments, choose either command more than once.

Note: You cannot use the Grow and Similar commands on images in Bitmap mode.

To clean up stray pixels left inside or outside a color-based selection:

1 Choose Select > Modify > Smooth. 

2 For Sample Radius, enter a pixel value between 1 and 100, and click OK. 

Photoshop or ImageReady checks around each selected pixel to find any unselected pixels 
falling within the specified range. For example, if you enter 16 for the sample radius, the 
program uses each pixel as the center of a 33-by-33-pixel area (16 pixels in the horizontal 
and vertical directions). If most pixels in the range are selected, any unselected pixels are 
added to the selection. If most pixels are unselected, any selected pixels are removed from 
the selection.

Note: The relationship between physical distance and pixel distance depends on the 
resolution of the image. For example, 5 pixels is a longer distance in a 72-ppi image than in 
a 300-ppi image. (See “Understanding image size and resolution” on page 62.)

Softening the edges of a selection
You can smooth the hard edges of a selection by anti-aliasing and by feathering.

Anti-aliasing Smooths the jagged edges of a selection by softening the color transition 
between edge pixels and background pixels. Since only the edge pixels change, no detail 
is lost. Anti-aliasing is useful when cutting, copying, and pasting selections to create 
composite images.

Anti-aliasing is available for the Lasso tool, the Polygonal Lasso tool, the Magnetic Lasso 
tool, the Rounded Rectangle Marquee tool (ImageReady), the Elliptical Marquee tool, and 
the Magic Wand tool. (Select a tool to display its options bar.) You must specify this option 
before using these tools. Once a selection is made, you cannot add anti-aliasing. 

Feathering Blurs edges by building a transition boundary between the selection and its 
surrounding pixels. This blurring can cause some loss of detail at the edge of the selection.

You can define feathering for the Marquee tool, the Lasso tool, the Polygonal Lasso tool, or 
the Magnetic Lasso tool as you use the tool, or you can add feathering to an existing 
selection. Feathering effects become apparent when you move, cut, copy, or fill the 
selection.
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To use anti-aliasing:

1 Select the Lasso tool, the Polygonal Lasso tool, the Magnetic Lasso tool, the Rounded 
Rectangle Marquee tool (ImageReady), the Elliptical Marquee tool, or the Magic Wand 
tool.

2 Select Anti-aliased in the options bar.

To define a feathered edge for a selection tool:

1 Select any of the lasso or marquee tools.

2 Enter a Feather value in the options bar. This value defines the width of the feathered 
edge and can range from 0 to 250 pixels. 

To define a feathered edge for an existing selection:

1 Choose Select > Feather.

2 Enter a value for the Feather Radius, and click OK. 

Note: A small selection made with a large feather radius may be so faint that its edges are 
invisible and thus not selectable. If a message appears stating “No pixels are more than 
50% selected,” either decrease the feather radius or increase the selection’s size. Or click OK 
to accept the mask at its current setting and create a selection in which you cannot see the 
edges.

Selection without feathering and with feathering 
A. Selection with no feather, same selection filled with pattern B. Selection with feather, 
same selection filled with pattern

A

B
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Moving, copying, and pasting selections and layers
You can move or copy selections and layers within or between images—and also between 
images in other applications.

Moving selections and layers within an image
The Move tool lets you drag a selection or layer to a new location in the image. With the 
Info palette open, you can track the exact distance of the move. You can also use the Move 
tool to align selections and layers and distribute layers within an image. To move objects 
in ImageReady layers, see “Selecting layers” on page 374.

To specify Move tool options:

1 Select the Move tool .

2 Select any of the following in the options bar:

• Auto Select Layer to select the topmost layer that has pixels under the Move tool, 
rather than the selected layer. 

• Show Bounding Box to display the bounding box around the selected item.

To move a selection or layer:

1 Select the Move tool . 

To activate the Move tool when another tool is selected, hold down Ctrl (Windows) or 
Command (Mac OS). (This technique does not work with the Pen tool , the Freeform Pen 
tool , the Path Selection tool , the Direct Selection tool , the Hand tool , the Slice 
Select tool , or the anchor point tools   .) 

2 Do one of the following:

• Move the pointer inside the selection border, and drag the selection to a new position. 
If you have selected multiple areas, all move as you drag.

Original selection (left), and after the selection is moved with the Move tool (right)

• Select the layer you want to move. Then drag the layer to a new position.

To align selections and layers within an image:

1 Do one of the following:

• To align the content of a layer to a selection, make a selection in the image. Then select 
a layer in the Layers palette. 

• To align the contents of multiple layers to a selection border, make a selection in 
the image. Then link together the layers you want to align in the Layers palette. 
(See “Linking layers” on page 378.



Using Help | Contents | Index Back 242  

Adobe Photoshop CS Help Selecting 

Using Help | Contents | Index Back 242  

• To align the contents of layers with the content of the active layer, link the layers you 
want to align to the active layer. (See “Linking layers” on page 378.)

2 Select the Move tool .

3 Click one or more alignment buttons in the options bar: Align Top Edges , Align 
Vertical Centers , Align Bottom Edges , Align Left Edges , Align Horizontal Centers , 
or Align Right Edges .

To distribute layers within an image:

1 In the Layers palette, link three or more layers. (See “Linking layers” on page 378.)

2 Select the Move tool .

3 Click one or more Distribute buttons in the options bar: Distribute Top Edges , 
Distribute Vertical Centers , Distribute Bottom Edges , Distribute Left Edges , 
Distribute Horizontal Centers , or Distribute Right Edges .

Copying selections or layers
You can use the Move tool to copy selections as you drag them within or between images, 
or you can copy and move selections using the Copy, Copy Merged, Cut, and Paste 
commands. Dragging with the Move tool saves memory because the Clipboard is not 
used as it is with the Copy, Copy Merged, Cut, and Paste commands.

• The Copy command copies the selected area on the active layer.

• The Copy Merged command makes a merged copy of all the visible layers in the 
selected area.

• The Paste command pastes a cut or copied selection into another part of the image or 
into another image as a new layer. If you have a selection, the Paste command places 
the copied selection over the current selection. Without an active selection, Paste 
places the copied selection in the middle of the view area.

• (Photoshop) The Paste Into command pastes a cut or copied selection inside another 
selection in the same image or different image. The source selection is pasted onto 
a new layer, and the destination selection border is converted into a layer mask. 
(See “Masking layers” on page 408.)

Keep in mind that when a selection or layer is pasted between images with different 
resolutions, the pasted data retains its pixel dimensions. This can make the pasted portion 
appear out of proportion to the new image. Use the Image Size command to make the 
source and destination images the same resolution before copying and pasting (see 
“Determining a recommended resolution for an image (Photoshop)” on page 69), and 
then set the zoom of both images to the same magnification.

Depending on your color management settings and the color profile associated with the 
file (or imported data), you may be prompted to specify how to handle color information 
in the file (or imported data). For more information, see “Using the Photoshop Color 
Settings” on page 122.



Using Help | Contents | Index Back 243  

Adobe Photoshop CS Help Selecting 

Using Help | Contents | Index Back 243  

To copy a selection:

1 Select the area you want to copy.

2 Choose Edit > Copy or Edit > Copy Merged.

To copy a selection while dragging: 

1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to 
activate the Move tool. 

2 Hold down Alt (Windows) or Option (Mac OS), and drag the selection you want to copy 
and move. 

When copying between images, drag the selection from the active image window into the 
destination image window. If nothing is selected, the entire active layer is copied. As you 
drag the selection over another image window, a border highlights the window if you can 
drop the selection into it.

To create multiple copies of a selection within an image: 

1 Select the Move tool , or hold down Ctrl (Windows) or Command (Mac OS) to 
activate the Move tool.

2 Copy the selection:

• Hold down Alt (Windows) or Option (Mac OS), and drag the selection.

• To copy the selection and offset the duplicate by 1 pixel, hold down Alt or Option, and 
press an arrow key.

• To copy the selection and offset the duplicate by 10 pixels, press Alt+Shift (Windows) or 
Option+Shift (Mac OS), and press an arrow key.

As long as you hold down Alt or Option, each press of an arrow key creates a copy of the 
selection and offsets it by the specified distance from the last duplicate. In this case, the 
copy isn’t made on a new layer.

Dragging a selection into another image

To paste one selection into another (Photoshop): 

1 Cut or copy the part of the image you want to paste. 

2 Select the part of the image into which you want to paste the selection. The source 
selection and the destination selection can be in the same image or in two different 
Photoshop images.
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3 Choose Edit > Paste Into. The contents of the source selection appear masked by the 
destination selection. 

In the Layers palette, the layer thumbnail for the source selection appears next to the layer 
mask thumbnail for the destination selection. The layer and layer mask are unlinked—
that is, you can move each one independently.

Using the Paste Into command 
A. Window panes selected B. Copied image C. Paste Into command D. Layer thumbnails and layer 
mask in Layers palette E. Pasted image repositioned

For more information on editing layer masks, see “Applying and discarding layer masks” 
on page 412.

4 Select the Move tool , or hold down the Ctrl (Windows) or Command (Mac OS) key to 
activate the Move tool. Then drag the source contents until the part you want appears 
through the mask.

5 To reveal more or less of the image underlying the layer, click the layer mask thumbnail 
in the Layers palette, select a painting tool, and edit the mask:

• To hide more of the image underlying the layer, paint the mask with black.

• To reveal more of the image underlying the layer, paint the mask with white.

• To partially reveal the image underlying the layer, paint the mask with gray.

6 If you are satisfied with your results, you can choose Layer > Merge Down to merge the 
new layer and layer mask with the underlying layer and make the changes permanent.

A B

C E

D
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Using drag and drop to copy between applications
The drag-and-drop feature lets you copy and move images between Photoshop or 
ImageReady and other applications.

In Windows, the application must be OLE-compliant. To duplicate an entire image by 
dragging and dropping, use the Move tool to drag the image. To copy an OLE object that 
contains PSD data, use the OLE Clipboard. (See your Windows documentation.)

Dragging vector artwork from Adobe Illustrator or from other applications that use the 
Illustrator Clipboard rasterizes the artwork—the mathematically defined lines and curves 
of the vector art are converted into the pixels or bits of a bitmap image. To copy the vector 
artwork as a path in Photoshop, hold down Ctrl (Windows) or Command (Mac OS) as you 
drag from Adobe Illustrator. To copy type, you must first convert it to outlines.

Using the Clipboard to copy between applications
You can often use the Cut or Copy command to copy selections between Photoshop or 
ImageReady and other applications. The cut or copied selection remains on the Clipboard 
until you cut or copy another selection. 

In some cases, the contents of the Clipboard are converted to a raster image. Photoshop 
prompts you when vector artwork will be rasterized. 

Note: The image is rasterized at the resolution of the file into which you paste it.

To change the Export Clipboard preference (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > General. 

• In Mac OS, choose Photoshop > Preferences > General. 

2 Select Export Clipboard to save any Photoshop contents on the Clipboard when you 
exit from Photoshop. If you leave this deselected, the contents are deleted when you exit 
from the program.

To paste PostScript artwork from another application:

1 In the supporting application, select your artwork, and choose Edit > Copy. (See  “About 
file formats” on page 582.)

2 In Photoshop or ImageReady, select the image into which you’ll paste the selection.

3 Choose Edit > Paste.

4 (Photoshop) In the dialog box, select from the following options: 

• Paste as Pixels to have the artwork rasterized as it is pasted. Rasterizing converts mathe-
matically defined vector artwork to pixels. 

• Paste as Paths to paste the copy as a path in the Paths palette. When copying type from 
Illustrator, you must first convert it to outlines.

• Paste as Shape Layer to create a new shape layer that uses the path as a vector mask.

Important: When copying artwork from Adobe Illustrator, Illustrator’s default Clipboard 
preferences may prevent the Paste dialog box from appearing in Photoshop. Select AICB in 
the Files and Clipboard area of Illustrator’s Preferences dialog box if you want the Paste 
options to appear when you paste the artwork in Photoshop.
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5 If you chose Paste as Pixels in the previous step, you can choose Anti-alias in the options 
bar to make a smooth transition between the edges of the selection and the surrounding 
pixels. (See “Softening the edges of a selection” on page 239.)

Note: You can use the Matting commands if you have already merged data and are 
trying to reextract the rasterized data. (See “Removing fringe pixels from a selection 
(Photoshop)” on page 247.)

Using the Snap command
Snapping helps with precise placement of selection edges, cropping marquees, slices, 
shapes, and paths. However, sometimes snapping prevents you from correctly placing 
elements. You can enable or disable snapping using the Snap command. You can also 
specify different elements to which you want to snap when snapping is enabled.

To enable or disable snapping:

Choose View > Snap. A check mark indicates that snapping is enabled.

To specify what to snap to:

Choose View > Snap To, and choose one or more options from the submenu:

• Guides to snap to guides.

• Grid to snap to the grid. You cannot select this option when the grid is hidden.

See “Using guides and the grid” on page 43 for more information about guides and 
the grid.

• Slices to snap to slice boundaries. You cannot select this option when slices are hidden. 
(See “Viewing slices” on page 476.)

• Document Bounds to snap to the edges of the document.

• All to select all Snap To options.

• None to deselect all Snap To options.

A check mark indicates that the option is selected and snapping is enabled. A dot 
(Windows) or a dash (Mac OS) indicates that the option is selected but snapping is 
disabled.

To enable snapping for one Snap To option:

1 With the Snap command disabled, choose View > Snap To. 

2 Choose an option. This automatically enables snapping for the selected option, and 
deselects all other Snap To options.

Saving and loading selections
Selections can be saved and loaded for reuse. (See “Saving a mask selection” on page 256.)

To save a selection:

Choose Select > Save Selection.
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To load a saved selection (Photoshop):

1 Choose Select > Load Selection, and then enter the options in the Load Selection dialog 
window. 

2 Click OK to load selection. (See “Loading a selection into an image” on page 257.)

To load a saved selection (ImageReady):

Choose Select > Load Selection, and then choose an option from the submenu.

Deleting selections
To delete a selection, choose Edit > Clear, or press Backspace (Windows) or Delete 
(Mac OS). To cut a selection to the Clipboard, choose Edit > Cut.

Deleting a selection on a background or on a layer with the Lock Transparency option 
selected in the Layers palette replaces the original location with the background color. 
Deleting a selection on a layer without Lock Transparency selected replaces the original 
area with the layer transparency.

Removing fringe pixels from a selection (Photoshop)
When you move or paste an anti-aliased selection, some of the pixels surrounding the 
selection border are included with the selection. This can result in a fringe or halo around 
the edges of the pasted selection. These Matting commands let you edit unwanted edge 
pixels: 

• Defringe replaces the color of any fringe pixels with the colors of nearby pixels 
containing pure colors (those without background color). For example, if you select a 
yellow object on a blue background and then move the selection, some of the blue 
background is selected and moved with the object. Defringe replaces the blue pixels 
with yellow ones.

• Remove Black Matte and Remove White Matte are useful when you want to paste a 
selection anti-aliased against a white or black background onto a different background. 
For example, anti-aliased black text on a white background has gray pixels at the edges, 
which are visible against a colored background.

You can also remove fringe areas by using the Advanced Blending sliders in the Layer 
Styles dialog box to remove, or make transparent, areas from the layer. In this case, you 

would make the black or white areas transparent. Alt-click (Windows) or Option-click 
(Mac OS) the sliders to separate them; separating the sliders allows you to remove fringe 
pixels and retain a smooth edge.

To decrease a fringe on a selection: 

1 Choose Layer > Matting > Defringe.

2 Enter a value in the Width text box for the distance to search for replacement pixels. In 
most cases, a distance of 1 or 2 pixels is enough.

3 Click OK.

To remove a matte from a selection:

Choose Layer > Matting > Remove Black Matte or Layer > Matting > Remove White Matte.
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Using the Extract filter (Photoshop)
The Extract filter dialog box provides a sophisticated way to isolate a foreground object 
and erase its background on a layer. Even objects with wispy, intricate, or undefinable 
edges may be clipped from their backgrounds with a minimum of manual work. You use 
tools in the Extract dialog box to specify which part of the image to extract. You can resize 
the dialog box by dragging its lower right corner.

For simpler cases, try using the Background Eraser tool (see “Using the Background 
Eraser tool (Photoshop)” on page 336).

When you extract the object, Photoshop erases its background to transparency. Pixels on 
the edge of the object lose their color components derived from the background, so they 
can blend with a new background without producing a color halo.

Selected area highlighted and filled, and extracted object

You can add back opacity to the background and create other effects by using the 
Edit > Fade command after an extraction. (See “Blending filter effects (Photoshop)” on 

page 418.)

To extract an object from its background:

1 In the Layers palette, select the layer containing the object you want to extract. If you 
select a background layer, it becomes a normal layer after the extraction. If the layer 
contains a selection, the extraction erases the background only in the selected area.

To avoid losing the original image information, duplicate the layer or make a snapshot 
of the original image state. 

2 Choose Filter > Extract, and then specify options for tools on the right side of the 
dialog box:

• For Brush Size, enter a value, or drag the slider to specify the width of the edge 
highlighter, eraser, cleanup, and edge touchup tools. This setting affects the size of the 
Highlighter tool . 

• For Highlight, choose a preset color option for the highlight that appears around 
objects you choose with the Highlighter tool, or choose Other to specify a custom color 
for the highlight.

• For Fill, choose a preset color option, or choose Other to specify a custom color for the 
area covered by the Fill tool.
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• If you are highlighting a well-defined edge, select Smart Highlighting. This option helps 
you keep the highlight on the edge, and applies a highlight that is just wide enough to 
cover the edge, regardless of the current brush size.

If you use Smart Highlighting to mark an object edge that is near another edge, 
decrease the brush size if conflicting edges pull the highlight off the object edge. 

If the object edge has a uniform color on one side and high-contrast edges on the other 
side, keep the object edge within the brush area but center the brush on the uniform 
color.

3 Specify Extraction options:

• Select Textured Image if the foreground or background of your image contains a lot of 
texture.

• For Smooth, enter a value or drag the slider to increase or decrease the smoothness of 
the outline.

• To base the highlight on a selection saved in an alpha channel, choose the alpha 
channel from the Channel menu. The alpha channel should be based on a selection of 
the edge boundary. If you modify a highlight based on a channel, the channel name in 
the menu changes to Custom. (See “About channels” on page 357.)

• Select Force Foreground if the object is especially intricate or lacks a clear interior. 

4 Adjust the view as needed:

• To magnify an area, select the Zoom tool  in the dialog box, and click in the preview 
image. To zoom out, hold down Alt (Windows) or Option (Mac OS) as you click.

• To view a different area, select the Hand tool in the dialog box, and drag in the preview 
image.

5 Define the edge of the object you want to extract:

• To draw a highlight that marks the edge, select the Edge Highlighter tool  in the 
dialog box, and drag so that the highlight slightly overlaps both the foreground object 
and its background. Use Smart Highlighting to trace sharper edges. Use a large brush to 
cover wispy, intricate edges where the foreground blends into the background, such as 
hair or trees. 

• If the object has a well-defined interior, make sure that the highlight forms a complete 
enclosure. You do not need to highlight areas where the object touches the image 
boundaries. If the object lacks a clear interior, highlight the entire object.

• To erase the highlight, select the Eraser tool  in the dialog box, and drag over the 
highlight. To erase the entire highlight, press Alt+Backspace (Windows) or 
Option+Delete (Mac OS).

6 Define the foreground area:

• If the object has a well-defined interior, select the Fill tool  in the dialog box. Click 
inside the object to fill its interior. (Clicking a filled area with the Fill tool removes 
the fill.)

Note: You can’t highlight the entire object if you’ve selected Texture or Force Foreground.
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• If you’ve selected Force Foreground, select the Eyedropper tool  in the dialog box, 
and click inside the object to sample the foreground color, or click in the Color text box 
and use a color picker to select the foreground color. This technique works best with 
objects that contain tones of a single color. 

7 Click Preview to preview the extracted object, or skip to step 10 to extract the object 
without a preview.

Zoom in as needed, and set any preview options:

• Use Show menu options to switch between previews of the original and extracted 
images.

• Use Display menu options to preview the extracted object against a colored matte 
background or as a grayscale mask. To display a transparent background, choose None.

• Select Show Highlight or Show Fill to display the object’s highlight or fill. 

8 If necessary, repeat the extraction to improve the results (when you are finished, you 
can perform final touchups as described in step 9):

• To perform another extraction after adjusting the highlight and fill, repeat steps 5, 6, 
and 7.

• To perform another extraction with new extraction settings, change the Smooth, Force 
Foreground, or Color settings, and repeat step 7.

Note: To specify the amount of smoothing of the extracted object, drag the Smooth slider 
or enter a value. It is usually best to begin with a zero or small value to avoid unwanted 
blurring of details. If there are sharp artifacts in the extraction result, you can increase the 
Smooth value to help remove them in the next extraction.

9 Touch up the extraction results as needed:

• To erase background traces in the extracted area, use the Cleanup tool . The tool 
subtracts opacity and has a cumulative effect. You can also use the Cleanup tool to fill 
gaps in the extracted object. Hold down Alt (Windows) or Option (Mac OS) while 
dragging to add back opacity.

• To edit the edge of the extracted object, use the Edge Touchup tool . The tool 
sharpens edges and has a cumulative effect. If there is no clear edge, the Edge Touchup 
tool adds opacity to the object or subtracts opacity from the background.

10 Click OK to apply the final extraction. On the layer, all pixels outside the extracted 
object are erased to transparency.

Note: For best results in cleaning up stray edges, use the cleanup and Edge Touchup tools 
in the Extract dialog box. You can also clean up after an extraction by using the 
Background Eraser and History Brush tools in the toolbox.



Using Help | Contents | Index Back 251  

Adobe Photoshop CS Help Selecting 

Using Help | Contents | Index Back 251  

About masks (Photoshop)
Masks let you isolate and protect areas of an image as you apply color changes, filters, or 
other effects to the rest of the image. When you select part of an image, the area that is 
not selected is “masked” or protected from editing. You can also use masks for complex 
image editing such as gradually applying color or filter effects to an image.

Examples of masks 
A. Opaque mask used to protect the background and edit the butterfly B. Opaque mask 
used to protect the butterfly and color the background C. Semitransparent mask used 
to color the background and part of the butterfly

Masks and channels are grayscale images, so you can edit them like any other image. 
With masks and channels, areas painted black are protected, and areas painted white are 
editable. Masks let you save and reuse time-consuming selections as alpha channels. 
Alpha channels can store selections so you can use them again, or you can load a saved 
selection into another image.

Photoshop lets you create masks in the following ways:

Quick Mask mode Lets you edit any selection as a mask. The advantage of editing your 
selection as a mask is that you can use almost any Photoshop tool or filter to modify the 
mask. For example, if you create a rectangular selection with the Marquee tool, you can 
enter Quick Mask mode and use the paintbrush to extend or contract the selection, or you 
can use a filter to distort the edges of the selection. You can also use selection tools, 
because the quick mask is not a selection. (See “Using Quick Mask mode to make selec-
tions (Photoshop)” on page 252.) You can also save and load selections you make using 
Quick Mask mode in Alpha channels (see “Saving a mask selection” on page 256).

Alpha channels Lets you save and load selections. (See “Storing masks in alpha 
channels” on page 254.) You can edit Alpha channels using any of the editing tools. When 
a channel is selected in the Channels palette, foreground and background colors appear 
as grayscale values. (See “Using Quick Mask mode to make selections (Photoshop)” on 
page 252.)

Layer masks and vector masks let you produce a mix of soft and hard masking edges 
on the same layer. By making changes to the layer mask or the vector masks, you can 

apply a variety of special effects. (See “Masking layers” on page 408.)

A B C
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Using Quick Mask mode to make selections (Photoshop)
To use Quick Mask mode, start with a selection and then add to or subtract from it to make 
the mask. Alternately, create the mask entirely in Quick Mask mode. Color differentiates 
the protected and unprotected areas. When you leave Quick Mask mode, the unprotected 
areas become a selection.

A temporary Quick Mask channel appears in the Channels palette while you work in Quick 
Mask mode. However, you do all mask editing in the image window. 

To create a temporary mask:

1 Using any selection tool, select the part of the image you want to change.

2 Click the Quick Mask mode button  in the toolbox.

A color overlay (similar to a rubylith) covers and protects the area outside the selection. 
Selected areas are left unprotected by this mask. By default, Quick Mask mode colors the 
protected area using a red, 50% opaque overlay.

Selecting in Standard mode and Quick Mask mode 
A. Standard mode B. Quick Mask mode C. Selected pixels appear as white in channel thumbnail
D. Rubylith overlay protects area outside selection and unselected pixels appear as black in channel 
thumbnail

3 To edit the mask, select a painting tool from the toolbox. The swatches in the toolbox 
automatically become black and white. 

A

C

D

B
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4 Paint with white to select more of an image (the color overlay is removed from areas 
painted with white). To deselect areas, paint over them with black (the color overlay covers 
areas painted with black). Painting with gray or another color creates a semitransparent 
area, useful for feathering or anti-aliased effects (semitransparent areas may not appear 
selected when you exit Quick Mask Mode, but they are).

Painting in Quick Mask mode 
A. Original selection and Quick Mask mode with green chosen as mask color B. Painting with white 
in Quick Mask mode adds to the selection C. Painting with black in Quick Mask mode subtracts from 
the selection

5 Click the Standard Mode button  in the toolbox to turn off the quick mask and return 
to your original image. A selection border now surrounds the unprotected area of the 
quick mask.

If a feathered mask is converted to a selection, the boundary line runs halfway between 
the black pixels and the white pixels of the mask gradient. The selection boundary 
indicates the pixels’ transition from being less than 50% selected to more than 50% 
selected.

6 Apply the desired changes to the image. Changes affect only the selected area.

7 Choose Select > Deselect to deselect the selection, or save the selection. 

You can convert this temporary mask to a permanent alpha channel by switching to 
standard mode and choosing Select > Save Selection

A

B

C
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To change the Quick Mask options:

1 Double-click the Quick Mask Mode button  in the toolbox.

2 Choose from the following display options:

• Masked Areas to have masked areas appear black (opaque) and to have selected areas 
appear white (transparent). Painting with black increases the masked area; painting 
with white increases the selected area. With this option, the Quick Mask button in the 
toolbox appears as a white circle on a gray background .

• Selected Areas to have masked areas appear white (transparent) and to have selected 
areas appear black (opaque). Painting with white increases the masked area; painting 
with black increases the selected area. With this option, the Quick Mask button in the 
toolbox appears as a gray circle on a white background .

To toggle between the Masked Areas and Selected Areas options for quick masks, 
Alt-click (Windows) or Option-click (Mac OS) the Quick Mask Mode button.

3 To choose a new mask color, click the color box, and choose a new color. (See “Using the 
Swatches palette” on page 354.)

4 To change the opacity, enter a value between 0% and 100%. 

Both the color and opacity settings affect only the appearance of the mask and have no 
effect on how underlying areas are protected. Changing these settings may make the 
mask more easily visible against the colors in the image.

Storing masks in alpha channels
In addition to the temporary masks of Quick Mask mode, you can create more permanent 
masks by storing them in alpha channels. This allows you to use the masks again in the 
same image or in a different image.

You can create an alpha channel in Photoshop and then add a mask to it. You can also save 
an existing selection in a Photoshop or ImageReady image as an alpha channel that will 
appear in the Channels palette in Photoshop.

Selection saved as an alpha channel in Channels palette
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Tips for using alpha channels (Photoshop)
An alpha channel has these properties:

• Each image can contain up to 56 channels, including all color and alpha channels.

• You can specify a name, color, mask option, and opacity for each channel. (The opacity 
affects the preview of the channel, not the image.)

• All new channels have the same dimensions and number of pixels as the original image.

• You can edit the mask in an alpha channel using painting tools, editing tools, and filters.

Original mask (left), and after a filter was applied (right)

• You can convert alpha channels to spot color channels.

Creating alpha channels (Photoshop)
You can create a new alpha channel and then use painting tools, editing tools, and filters 
to add the mask to it.

To create an alpha channel using current options:

1 Click the New Channel button  at the bottom of the Channels palette. The new 
channel is named according to the sequence in which it was created.

2 Use a painting or editing tool to paint in the image. Paint with black to add to the 
channel; paint with white to remove from the channel; paint with a lower opacity or a 
color to add to the channel with lower opacities. 

To create an alpha channel and specify options:

1 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the New Channel button  at the bottom 
of the palette. 

• Choose New Channel from the Channels palette menu.

2 Type a name for the channel. 

3 Select display options for the channel, as described in steps 2 through 4 of the 
procedure for changing Quick Mask options in “Using Quick Mask mode to make selec-
tions (Photoshop)” on page 252. Alpha channel options are identical to Quick Mask 
options. 

4 Click OK. A new channel appears at the bottom of the Channels palette and is the only 
channel visible in the image window.
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5 Click the eye icon  next to a color channel or the composite color channel to display 
the image with a color overlay.

6 Use a painting or editing tool to paint in the image. Paint with black to add to the new 
channel, paint with white to remove from the new channel, or paint with a lower opacity 
or a color to add to the new channel with lower opacities. 

Saving a mask selection
You can save any selection as a mask in a new or existing alpha channel.

To save a selection to a new channel with default options (Photoshop):

1 Select the area or areas of the image that you want to isolate.

2 Click the Save Selection button  at the bottom of the Channels palette. A new 
channel appears, named according to the sequence in which it was created.

To save a selection to a new or existing channel:

1 Select the area or areas of the image that you want to isolate. 

2 Choose Select > Save Selection.

3 Do the following in the Save Selection dialog box, and click OK:

• (Photoshop) Choose a destination image for the selection in the Document menu. 
By default, the selection is placed in a channel in your active image. You can choose to 
save the selection to a channel in another open image with the same pixel dimensions 
or to a new image.

• Choose a destination channel for the selection from the Channel pop-up menu. 
By default, the selection is saved in a new channel. You can choose to save the selection 
to any existing channel in the selected image or to a layer mask if the image contains 
layers. 

• If you’re saving the selection as a new channel, enter a name for the channel in the 
Name text box. In ImageReady, you can change the default channel name if desired.

• If you’re saving the selection to an existing channel, select how to combine the selec-
tions: Replace Channel to replace the current selection in the channel, Add to Channel 
to add the selection to the current channel contents, Subtract from Channel to delete 
the selection from the channel contents, or Intersect with Channel to keep the areas of 
the new selection that intersect with the channel contents.

In Photoshop, you can select the channel in the Channels palette to see the saved 
selection displayed in grayscale. A selection saved in ImageReady will appear in a new or 
existing channel in the Photoshop Channels palette.

Modifying alpha channels (Photoshop)
You can edit an alpha channel to add or remove color in it, and you can specify settings for 
the masking colors and opacity. See “Managing channels (Photoshop)” on page 360 for 
information on rearranging, duplicating, or deleting alpha channels.

To edit an alpha channel:

Use a painting or editing tool to paint in the image. Paint with black to add to the channel, 
paint with white to remove from the channel, or paint with a lower opacity or a color to 
add to the channel with lower opacities. 
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To change an alpha channel’s options:

1 Do one of the following:

• Select the channel in the Channels palette, and choose Channel Options from the 
palette menu.

• Double-click the channel thumbnail in the Channels palette.

2 Enter a new name for the channel.

3 Choose display options, as described in steps 2 through 4 of the procedure on Quick 
Mask options in “Using Quick Mask mode to make selections (Photoshop)” on page 252.

See “Modifying spot channels” on page 364 for information on changing Spot Color 
channel options.

Loading a selection into an image
You can reuse a previously saved selection by loading it into an image. In Photoshop, 
you can also load the selection into an image when you have finished modifying an alpha 
channel.

You can drag a selection from one open Photoshop image into another.

To load a saved selection (Photoshop):

Do one of the following in the Channels palette:

• Select the alpha channel, click the Load Selection button  at the bottom of the palette, 
and then click the composite color channel near the top of the palette.

• Drag the channel containing the selection you want to load onto the Load Selection 
button.

• Ctrl-click (Windows) or Command-click (Mac OS) the channel containing the selection 
you want to load.

• To add the mask to an existing selection, press Ctrl+Shift (Windows) or Command+Shift 
(Mac OS), and click the channel.

• To subtract the mask from an existing selection, press Ctrl+Alt (Windows) or 
Command+Option (Mac OS), and click the channel.

• To load the intersection of the saved selection and an existing selection, press 
Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS), and select the channel.

To load a saved selection into an image (Photoshop):

1 Choose Select > Load Selection. For Document, the active filename is selected.

2 For Channel, choose the channel containing the selection you want to load.

3 Click Invert to make the nonselected areas selected and vice versa.

4 If the destination image already has a selection, indicate how to combine the selec-
tions. (For information on these options, see “Saving a mask selection” on page 256.)

To load a saved selection into an image (ImageReady):

Choose Select > Load Selection, and then choose an option from the submenu.
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To load a selection from another image (Photoshop):

1 Open the two images you want to use. 

2 Make the destination image active, and choose Select > Load Selection.

3 For Document, choose the source image.

4 For Channel, choose the channel containing the selection you want to use as a mask.

5 Click Invert if you want to make the nonselected areas selected and vice versa.

6 If the destination image already has a selection, indicate how to combine the selec-
tions. (For information on these options, see “Saving a mask selection” on page 256.)
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Transforming and Retouching

Changing the size of the work canvas
The Canvas Size command lets you add or remove work space around an existing image. 
You can also use the command to crop an image by decreasing the canvas area. In 
ImageReady, added canvas appears in the same color or transparency as the background. 
In Photoshop, there are several options for the background of the added canvas. If your 
image has a transparent background, the added canvas will be transparent.

To use the Canvas Size command: 

1 Choose Image > Canvas Size.

2 Do one of the following:

• Enter the dimensions you want the canvas to be in the Width and Height boxes. 
(Photoshop) Choose the units of measurement you want from the drop-down menus 
next to the Width and Height boxes.

• Select Relative, and enter the amount by which you want to increase or decrease the 
size of the canvas. (Enter a negative number to decrease the size of the canvas.)

3 For Anchor, click a square to indicate where to position the existing image on the new 
canvas. 

4 (Photoshop) Choose an option from the Canvas Extension Color menu:

• Foreground to fill the new canvas with the current foreground color

• Background to fill the new canvas with the current background color

• White, Black, or Gray to fill the new canvas with that color

• Other to select a new canvas color using the Color Picker

Note: The Canvas Extension Color menu isn’t available if an image doesn’t contain a 
Background layer.
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5 Click OK.

Original canvas, and canvas added to right side of image using the foreground color

Rotating and flipping entire images
The Rotate Canvas commands let you rotate or flip an entire image. The commands do not 
work on individual layers or parts of layers, paths, or selection borders.

Rotating images 
A. Flip Horizontal B. Original image C. Flip Vertical D. Rotate 90° CCW E. Rotate 180°
F. Rotate 90° CW

To rotate or flip an entire image:

Choose Image > Rotate Canvas, and choose one of the following commands from the 
submenu:

• 180° to rotate the image by a half-turn.

• 90° CW to rotate the image clockwise by a quarter-turn.

• 90° CCW to rotate the image counterclockwise by a quarter-turn.

• Arbitrary to rotate the image by the angle you specify. If you choose this option, enter 
an angle between –360 and 360 in the angle text box. (In Photoshop, you can select CW 
or CCW to rotate clockwise or counter-clockwise.) Then click OK.

A B C

D E F
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• Flip Canvas Horizontal (Photoshop) or Flip Horizontal (ImageReady) to flip the image 
horizontally, along the vertical axis.

• Flip Canvas Vertical (Photoshop) or Flip Vertical (ImageReady) to flip the image verti-
cally, along the horizontal axis.

Cropping images
Cropping is the process of removing portions of an image to create focus or strengthen 
the composition. You can crop an image using the Crop tool  and the Crop command. 
You can also trim pixels using the Trim command

Using the Crop tool
The Crop tool provides the most options for cropping images. 

Using the Crop tool

To crop an image using the Crop tool:

1 Select the Crop tool .

2 Drag over the part of the image you want to keep to create a marquee. The marquee 
doesn’t have to be precise—you can adjust it later.

3 If necessary, adjust the cropping marquee:

• To move the marquee to another position, place the pointer inside the bounding box 
and drag. 

• To scale the marquee, drag a handle. To constrain the proportions, hold down Shift as 
you drag a corner handle.

• To rotate the marquee, position the pointer outside the bounding box (the pointer 
turns into a curved arrow), and drag. To move the center point around which the 
marquee rotates, drag the circle at the center of the bounding box.

Note: In Photoshop, you can’t rotate the marquee for an image in Bitmap mode.

4 Do one of the following:

• To complete the crop, press Enter (Windows) or Return (Mac OS), click the Commit 
button in the options bar, or double-click inside the cropping marquee.

• To cancel the cropping operation, press Esc or click the Cancel button  in the 
options bar.



Using Help | Contents | Index Back 262  

Adobe Photoshop CS Help Transforming and Retouching 

Using Help | Contents | Index Back 262  

To set Crop tool options:

Choose from the following in the options bar to set the mode of the Crop tool:

• (Photoshop) To crop the image without resampling (default), make sure that the 
resolution text box in the options bar is empty. You can click the Clear button to quickly 
clear all text boxes. 

• (Photoshop) To resample the image during cropping, enter the height and width, and a 
resolution in the options bar. The Crop tool won’t resample the image unless the width 
and/or height, and resolution are provided. 

• (ImageReady) To crop the image without resampling, make sure that Fixed Size is 
deselected in the options bar. 

• (ImageReady) To resample the image during cropping, select Fixed Size, and enter a 
height and width in the options bar.

• To resample an image based on the dimensions and resolution of another image, open 
the other image, select the Crop tool, and click Front Image in the options bar. (In 
ImageReady, you must select the Fixed Size option to access the Front Image button.) 
Then make the image you want to crop active.

Resampling during cropping combines the function of the Image > Image Size 
command with that of the Crop tool. (See “About resampling” on page 66.)

• Specify whether you want to hide or delete the cropped area. Select Hide to preserve 
the cropped area in the image file. You can make the hidden area visible by moving the 
image with the Move tool. Select Delete to discard the cropped area. 

Note: In Photoshop, the Hide option is not available for images that contain only a 
background layer. If you want to crop a background by hiding, convert the background to 
a regular layer first. (See “About the background layer” on page 371.) In ImageReady, 
cropping a background by hiding automatically converts the background to a regular 
layer.

• Specify whether you want to use a cropping shield to shade the area of the image that 
will be deleted or hidden. When Shield is selected, you can specify a color and opacity 
for the cropping shield. When Shield is deselected, the area outside the cropping 
marquee is revealed.

Using the Crop and Trim commands
In addition to the Crop tool, you can use the crop and trim commands to crop an image.

To crop an image using the Crop command:

1 Select the part of the image you want to keep. (See “Using the marquee tools” on 
page 229.)

2 Choose Image > Crop.

To crop an image using the Trim command:

1 Choose Image > Trim.

2 In the Trim dialog box, select an option:

• Transparent Pixels to trim away transparency at the edges of the image, leaving the 
smallest image containing non-transparent pixels.
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• Top Left Pixel Color to remove an area the color of the upper left pixel from the image.

• Bottom Right Pixel Color to remove an area the color of the lower right pixel from the 
image.

3 Select one or more areas of the image to trim away: Top, Bottom, Left, or Right.

Transforming perspective while cropping (Photoshop)
The Crop tool in Photoshop has an additional option that allows you to transform the 
perspective in an image. This is very useful when working with images that contain 
keystone distortion. Keystone distortion occurs when an object is photographed from an 
angle rather than from a straight-on view. For example, if you take a picture of a a tall 
building from ground level, the edges of the building appear closer at the top than they 
do at the bottom. 

Steps to transform perspective 
A. Draw initial cropping marquee B. Adjust cropping marquee to match the object’s edges
C. Extend the cropping bounds D. Final image

To transform the perspective in an image:

1 Select the Crop tool  and set the crop mode. (See “Cropping images” on page 261.)

2 Drag the cropping marquee around an object that was rectangular in the original scene 
(although it doesn’t appear rectangular in the image). You’ll use the edges of this object to 
define the perspective in the image. The marquee doesn’t have to be precise—you’ll 
adjust it later.

Important: You must select an object that was rectangular in the original scene or 
Photoshop will not be able to transform the perspective in the image. 

A

C D

B
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3 Select Perspective in the options bar, and set the other options as desired. 
(See “Cropping images” on page 261.)

4 Move the corner handles of the cropping marquee to match the object’s edges. 
This defines the perspective in the image, so it is important to precisely match the object’s 
edges. 

5 Drag the side handles to extend the cropping bounds while preserving the perspective. 

Important: Do not move the center point of the cropping marquee. Photoshop needs to 
know the original center point of the image in order to perform perspective correction. 

6 Do one of the following:

• Press Enter (Windows) or Return (Mac OS), click the Commit button  in the options 
bar, or double-click inside the cropping marquee.

• To cancel the cropping operation, press Esc or click the Cancel button  in the 
options bar.

If Photoshop displays an error, it is probably due to improper placement of the corner 
handles or center point. Click Cancel to go back and adjust the cropping marquee; 

click Don’t Crop to cancel the cropping operation. An error may also occur if you’re 
working with a previously cropped image. 

Using the Crop and Straighten Photos command (Photoshop)
The Crop and Straighten Photos command helps you make separate image files from 
multiple images in a single scan. For best results, you should keep an eighth of an inch 
between the images in your scan, and the background (typically the scanner bed) should 
be a uniform color with little “noise”. Images with clearly delineated outlines work best 
with the Crop and Straighten Photos command. 

If the Crop and Straighten Photos command isn’t processing difficult images, use the 
Crop tool to crop out individual images (see “Using the Crop tool” on page 261).

To use the Crop and Straighten Photos command:

1 Open the scanned file that contains the images you want to separate.

2 Select the layer that contains the images. Alternately, draw a selection border around 
one or more images to generate just those images into separate files.

3 Choose File > Automate > Crop and Straighten Photos. The scanned images are 
processed, and then each image opens in its own window.

If the Crop and Straighten Photos command incorrectly splits one of your images, 
make a selection border around the image and some background, and then hold 

down Alt (Windows) or Option (Mac OS) when you choose the command. The modifier 
key indicates that there is just one image to separate from the background.
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Transforming objects 
You can scale, rotate, skew, distort, and apply perspective to entire layers, selected parts of 
layers, masks, paths, shapes, selection borders, and channels.

Specifying what to transform
You can apply transformations to a selection, an entire layer, multiple layers, or a layer 
mask. In Photoshop, you can also apply transformations to a path, a vector shape, a vector 
mask, a selection border, or an alpha channel.

Important: In Photoshop, you can apply transformations to 8-bit and 16-bit images. 
However, you’ll need to convert images to 8-bit RGB color mode before you can edit them 
in ImageReady.

Transforming an image 
A. Original image B. Layer flipped C. Selection border rotated D. Part of object scaled

To calculate the color values of pixels that are added or deleted during transformations, 
Photoshop and ImageReady use the interpolation method selected in the General area of 
the Preferences dialog box. This setting directly affects the speed and quality of the trans-
formation. Bicubic interpolation, the default, is slowest but yields the best results. 
(See “Choosing an interpolation method” on page 67.)

To specify what to transform:

Do one of the following:

• To transform an entire layer, make the layer active, and make sure nothing is selected. 

Important: You cannot transform the background layer. However, you can convert a 
background layer to a regular layer. (See “Creating new layers and layer sets” on 
page 372.)

• To transform part of a layer, select the layer, and then select part of the image on 
that layer. 

A B

C D
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• To transform multiple layers, link the layers together in the Layers palette. (See “Linking 
layers” on page 378.)

• To transform a layer mask or a vector mask, unlink the mask, and select the mask 
thumbnail in the Layers palette. (See “Masking layers” on page 408.)

• (Photoshop) To transform a path or vector shape, use the Path Selection tool  to select 
the entire path or the Direct Selection tool  to select part of the path. (See “Selecting 
paths (Photoshop)” on page 302.) If you select one or more points on a path, only those 
path segments connected to the points are transformed. 

• (Photoshop) To transform a selection border, make or load a selection. Then choose 
Select > Transform Selection.

• (Photoshop) To transform an alpha channel, select the channel in the Channels palette. 
(See “Storing masks in alpha channels” on page 254.)

Setting the reference point
All transformations are performed around a fixed point called the reference point. 
By default, this point is at the center of the item you are transforming. However, you can 
change the reference point or move the center point to a different location using the 
reference point locator in the options bar.

To set the reference point for a transformation:

1 Select a transformation command, as described in the following topics. A bounding box 
appears in the image.

2 In the options bar, click a square on the reference point locator  in the options bar. 
Each square represents a point on the bounding box. For example, to set the reference 
point to the top left corner of the bounding box, click the top left square on the reference 
point locator.

To move the center point for the transformation:

1 Select a transformation command, as described in the following topics. A bounding box 
appears in the image.

2 Drag the center point. The center point can be outside the item you want to transform.

Applying transformations
The commands under the Transform submenu let you apply the following transforma-
tions to an item:

• Scaling enlarges or reduces an item relative to its reference point. You can scale 
horizontally, vertically, or both horizontally and vertically.

• Rotating turns an item around a reference point. By default, this point is at the center of 
the object; however, you can move it to another location.

• Skewing lets you slant an item vertically and horizontally.

• Distorting lets you stretch an item in all directions.

• Applying perspective lets you apply one-point perspective to an item.
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In Photoshop, you can perform several commands in succession before applying the 
cumulative transformation. For example, you can choose Scale, drag a handle to scale, 
and then choose Distort, drag a handle to distort, and press Enter or Return to apply both 
transformations. In ImageReady, you can perform multiple types of transformations at the 
same time using the Transform > Numeric command.

To scale, rotate, skew, distort, or apply perspective:

1 Select what you want to transform. (See “Specifying what to transform” on page 265.)

2 Choose Edit > Transform > Scale, Rotate, Skew, Distort, or Perspective.

Note: (Photoshop) If you are transforming a shape or entire path, the Transform menu 
becomes the Transform Path menu. If you are transforming multiple path segments 
(but not the entire path), the Transform menu becomes the Transform Points menu.

3 In the options bar, click a square on the reference point locator . (See “Setting the 
reference point” on page 266.)

4 Do one or more of the following:

• If you chose Scale, drag a handle on the bounding box. Press Shift as you drag a corner 
handle to scale proportionately. When positioned over a handle, the pointer becomes 
a double arrow.

• If you chose Rotate, move the pointer outside of the bounding border (it becomes a 
curved, two-sided arrow), and then drag. Press Shift to constrain the rotation to 15° 
increments. 

• If you chose Skew, drag a side handle to slant the bounding box. 

• If you chose Distort, drag a corner handle to stretch the bounding box. 

• If you chose Perspective, drag a corner handle to apply perspective to the bounding 
box. 

• For all types of transformations, enter a value in the options bar. For example, to rotate 
an item, specify degrees in the rotation  text box.

5 If desired, switch to a different type of transformation by selecting a command from the 
Edit > Transform submenu.

When transforming a bitmap image (versus a shape or path), it becomes slightly less 
sharp each time you commit a transformation; therefore, performing multiple 

commands before applying the cumulative transformation is preferable to applying each 
transformation separately. 

6 When you’re satisfied with the results, do one of the following:

• Press Enter (Windows) or Return (Mac OS), click the Commit button  in the options 
bar, or double-click inside the transformation marquee.

• To cancel the transformation, press Esc or click the Cancel button  in the options bar.
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To flip or rotate precisely:

1 Select what you want to transform. (See “Specifying what to transform” on page 265.)

2 Choose Edit > Transform and choose one of the following commands from the 
submenu:

• Rotate 180° to rotate by a half-turn

• Rotate 90° CW to rotate clockwise by a quarter-turn

• Rotate 90° CCW to rotate counterclockwise by a quarter-turn

• Flip Horizontal to flip horizontally, along the vertical axis

• Flip Vertical to flip vertically, along the horizontal axis

Note: (Photoshop) If you are transforming a shape or entire path, the Transform 
command becomes the Transform Path command. If you are transforming multiple path 
segments (but not the entire path), the Transform command becomes the Transform 
Points command.

To repeat a transformation:

Choose Edit > Transform > Again, Edit > Transform Path > Again, or Edit > Transform 
Points > Again.

To duplicate an item when transforming it:

Hold down Alt (Windows) or Option (Mac OS) when selecting the Transform command.

To apply multiple types of transformations at the same time (ImageReady):

1 Select what you want to transform. (See “Specifying what to transform” on page 265.)

2 Choose Edit > Transform > Numeric.

3 Do one or more of the following, and click OK:

• Select Position and enter values for the new location in the X (horizontal position) and Y 
(vertical position) text boxes. Select Relative to specify the new position in relation to 
the current position.

• Select Scale. Enter the dimensions in the Width and Height text boxes, or enter a scaling 
percentage in the Scale text box. Select Constrain Proportions to maintain the aspect 
ratio. 

• Select Skew and enter degrees in the Horizontal skew and Vertical skew text boxes.

• Select Rotate. Enter degrees of rotation in the Angle text box, or drag the in the circle to 
the right of the text box.

Using the Free Transform command
The Free Transform command lets you apply transformations (rotate, scale, skew, distort, 
and perspective) in one continuous operation. Instead of choosing different commands, 
you simply hold down a key on your keyboard to switch between transformation types.

Note: (Photoshop) If you are transforming a shape or entire path, the Transform 
command becomes the Transform Path command. If you are transforming multiple path 
segments (but not the entire path), the Transform command becomes the Transform 
Points command.
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To freely transform:

1 Select what you want to transform. (See “Specifying what to transform” on page 265.)

2 Do one of the following:

• Choose Edit > Free Transform.

• If you are transforming a selection, pixel-based layer, or selection border, choose the 
Move tool . Then select Show Bounding Box (Photoshop) or Show Transform Box 
(ImageReady) in the options bar.

• If you are transforming a vector shape or path, select the Path Selection tool . Then 
select Show Bounding Box in the options bar.

3 Do one or more of the following:

• To scale by dragging, drag a handle. Press Shift as you drag a corner handle to scale 
proportionately. 

• To scale numerically, enter percentages in the Width and Height text boxes in the 
options bar. Click the Link button  to maintain the aspect ratio.

• To rotate by dragging, move the pointer outside of the bounding border (it becomes a 
curved, two-sided arrow , and then drag. Press Shift to constrain the rotation to 15° 
increments. 

• To rotate numerically, enter degrees in the rotation text box  in the options bar.

• To distort relative to the center point of the bounding border, press Alt (Windows) or 
Option (Mac OS), and drag a handle .

• To distort freely, press Ctrl (Windows) or Command (Mac OS), and drag a handle.

• To skew, press Ctrl+Shift (Windows) or Command+Shift (Mac OS), and drag a side 
handle. When positioned over a side handle, the pointer becomes a white arrowhead 
with a small double arrow .

• To skew numerically, enter degrees in the H (horizontal skew) and V (vertical skew) text 
boxes in the options bar.

• To apply perspective, press Ctrl+Alt+Shift (Windows) or Command+Option+Shift 
(Mac OS), and drag a corner handle. When positioned over a corner handle, the pointer 
becomes a gray arrowhead .

• To change the reference point, click a square on the Reference point locator  in the 
options bar. (See “Setting the reference point” on page 266.)

• To move an item, enter values for the new location of the reference in the X (horizontal 
position) and Y (vertical position) text boxes in the options bar. In Photoshop, click the 
Relative Positioning button  to specify the new position in relation to the current 
position.

To undo the last handle adjustment, choose Edit > Undo.



Using Help | Contents | Index Back 270  

Adobe Photoshop CS Help Transforming and Retouching 

Using Help | Contents | Index Back 270  

4 Do one of the following:

• Press Enter (Windows) or Return (Mac OS), click the Commit button  in the options 
bar, or double-click inside the transformation marquee.

• To cancel the transformation, press Esc or click the Cancel button  in the options bar.

When transforming a bitmap image (versus a shape or path), it becomes slightly less 
sharp each time you commit a transformation; therefore, performing multiple 

commands before applying the cumulative transformation is preferable to applying each 
transformation separately. 

Retouching and repairing images
You can use the Clone Stamp tool, Pattern Stamp tool, Healing Brush tool, and Patch tool 
to clone pixels and repair images.

Using the Clone Stamp tool
The Clone Stamp tool  takes a sample of an image, which you can then apply over 
another image or part of the same image. You can also clone part of one layer over 
another layer. Each stroke of the tool paints on more of the sample. 

When you use the Clone Stamp tool, you set a sampling point on the area you want to 
apply over another area. By selecting Aligned in the options bar, you can reuse the most 
current sampling point, no matter how many times you stop and resume painting. When 
Aligned is deselected, you’ll reuse the same sampled pixels each time you paint.

Because you can use any brush tip with the Clone Stamp tool, you have a lot of control 
over the size of the area you clone. You can also use opacity and flow settings in the 
options bar to finesse the way you apply the cloned area. You can also sample from one 
image and apply the clone in another image, as long as both images are in the same 
color mode.

Altering an image with the Clone Stamp tool

To use the Clone Stamp tool:

1 Select the Clone Stamp tool .

2 Choose a brush tip and set brush options for the blending mode, opacity, and flow in 
the options bar (see “Setting options for painting and editing tools” on page 331).
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3 Next, determine how you want to align the sampled pixels. Select Aligned in the 
options bar to sample pixels continuously, without losing the current sampling point, 
even if you release the mouse button. Deselect Aligned to continue to use the sampled 
pixels from the initial sampling point each time you stop and resume painting.

4 Select Use All Layers in the options bar to sample data from all visible layers; deselect 
Use All Layers to sample only from the active layer.

5 Set the sampling point by positioning the pointer in any open image and Alt-clicking 
(Windows) or Option-clicking (Mac OS). 

6 Drag over the area of the image you want to correct.

Using the Pattern Stamp tool
The Pattern Stamp tool lets you paint with a pattern. You can select a pattern from the 
pattern libraries or create your own patterns.

To use the Pattern Stamp tool:

1 Select the Pattern Stamp tool .

2 Choose a brush tip and set brush options (blending mode, opacity, and flow) in the 
options bar (see “Setting options for painting and editing tools” on page 331).

3 Select Aligned in the options bar to sample pixels continuously, without losing the 
current sampling point, even if you release the mouse button. Deselect Aligned to 
continue to use the sampled pixels from the initial sampling point each time you stop and 
resume painting.

4 Select a pattern from the Pattern pop-up palette in the options bar. (See “Creating and 
managing patterns” on page 346.)

5 If you’d like to apply the pattern with an impressionistic effect, select Impressionist.

6 Drag in the image to paint with the pattern. 

Using the Healing Brush tool (Photoshop)
The Healing Brush tool lets you correct imperfections, causing them to disappear into the 
surrounding image. Like the cloning tools, you use the Healing Brush tool to paint with 
sampled pixels from an image or pattern. However, the Healing Brush tool also matches 
the texture, lighting, transparency, and shading of the sampled pixels to the source pixels. 
As a result, the repaired pixels blend seamlessly into the rest of the image.

Sampled pixels and healed image
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To use the Healing Brush tool:

1 Select the Healing Brush tool .

2 Click the brush sample in the options bar and set brush options in the pop-up palette:

• For more information on the Diameter, Hardness, Spacing, Angle, and Roundness 
options, see “Customizing brush tips (Photoshop)” on page 319. 

• If you’re using a pressure-sensitive digitizing tablet, choose an option from the Size 
menu to vary the size of the healing brush over the course of a stroke. Choose Pen 
Pressure to base the variation on the pen pressure. Choose Stylus Wheel to base the 
variation on the position of the pen thumbwheel. Choose Off to not vary the size.

3 Choose a blending mode from the Mode pop-up menu in the options bar:

• Choose Replace to preserve noise, film grain, and texture at the edges of the brush 
stroke. 

• For more information on the Normal, Multiply, Screen, Darken, Lighten, Color, and 
Luminosity modes, see “Selecting a blending mode” on page 331. 

4 Choose a source to use for repairing pixels in the options bar: Sampled to use pixels 
from the current image, or Pattern to use pixels from a pattern. If you chose Pattern, select 
a pattern from the Pattern pop-up palette. (See “Creating and managing patterns” on 
page 346.)

5 Select Aligned in the options bar to sample pixels continuously, without losing the 
current sampling point, even if you release the mouse button. Deselect Aligned to 
continue to use the sampled pixels from the initial sampling point each time you stop and 
resume painting.

6 Select Use All Layers in the options bar to sample data from all visible layers. Deselect 
Use All Layers to sample only from the active layer.

7 For the Healing Brush tool in sampling mode, set the sampling point by positioning the 
pointer in any open image and Alt-clicking (Windows) or Option-clicking (Mac OS). 

Note: If you are sampling from one image and applying to another, both images must be 
in the same color mode unless one of the images is in Grayscale mode.

8 Drag in the image. 

The sampled pixels are melded with the existing pixels each time you release the mouse 
button. Look in the status bar to view the status of the melding process.

If there is a strong contrast at the edges of the area you want to heal, make a selection 
before you use the Healing Brush tool. The selection should be bigger than the area 

you want to heal but should precisely follow the boundary of contrasting pixels. When you 
paint with the Healing Brush tool, the selection will prevent colors from bleeding in from 
the outside.
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Using the Patch tool (Photoshop)
The Patch tool lets you repair a selected area with pixels from another area or a pattern. 
Like the Healing Brush tool, the Patch tool matches the texture, lighting, and shading of 
the sampled pixels to the source pixels. You can also use the Patch tool to clone isolated 
areas of an image.

When repairing with pixels from the image, select a small area to produce the best 
result.

Using the Patch tool to replace pixels

Patched image

To repair an area using sampled pixels:

1 Select the Patch tool .

2 Do one of the following:

• Drag in the image to select the area you want to repair, and select Source in the 
options bar. 

• Drag in the image to select the area from which you want to sample, and select 
Destination in the options bar.

Note: You can also make a selection prior to selecting the Patch tool. 

3 To adjust the selection, do one of the following:

• Shift-drag in the image to add to the existing selection.

• Alt-drag (Windows) or Option-drag (Mac OS) in the image to subtract from the existing 
selection.
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• Alt-Shift-drag (Windows) or Option-Shift-drag (Mac OS) in the image to select an area 
intersected by the existing selection.

4 Position the pointer inside the selection, and do one of the following:

• If Source is selected in the options bar, drag the selection border to the area from which 
you want to sample. When you release the mouse button, the originally selected area is 
patched with the sampled pixels.

• If Destination is selected in the options bar, drag the selection border to the area you 
want to patch. When you release the mouse button, the newly selected area is patched 
with the sampled pixels.

To repair an area using a pattern:

1 Select the Patch tool .

2 Drag in the image to select the area you want to repair. 

Note: You can also make a selection prior to selecting the Patch tool. 

3 To adjust the selection, do one of the following:

• Shift-drag in the image to add to the existing selection.

• Alt-drag (Windows) or Option-drag (Mac OS) in the image to subtract from the existing 
selection.

• Alt-Shift-drag (Windows) or Option-Shift-drag (Mac OS) in the image to select an area 
intersected by the existing selection.

4 Select a pattern from the Pattern pop-up palette in the options bar, and click Use 
Pattern.

Using the Color Replacement tool
The Color Replacement tool simplifies replacing specific colors in your image. You can 
paint over a targeted color—for example, a person’s red eyes in an image—with a 
corrective color.

Note: The Color Replacement tool doesn’t work in images in Bitmap, Indexed, or Multi-
channel color modes.

Red eyes repaired using the Color Replacement tool
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To use the Color Replacement tool:

1 Select the Color Replacement tool .

2 Choose a brush tip in the options bar. Generally, you’ll want to keep the blending mode 
set to Color (see “Setting options for painting and editing tools” on page 331).

3 For the Sampling option, choose one of the following:

• Continuous to sample colors continuously as you drag

• Once to replace the targeted color only in areas containing the color that you first click

• Background Swatch to erase only areas containing the current background color

4 For the Limits option, select one of the following:

• Discontiguous to replace the sampled color wherever it occurs under the pointer

• Contiguous to replace colors that are contiguous with the color immediately under the 
pointer

• Find Edges to replace connected areas containing the sampled color while better 
preserving the sharpness of shape edges

5 For tolerance, enter a percentage value (ranging from 0 to 255) or drag the slider. 
Choose a low percentage to replace colors very similar to the pixel you click, or raise the 
percentage to replace a broader range of colors.

6 To define a smooth edge to the areas you correct, select Anti-aliased.

7 Choose a foreground color to use to replace the unwanted color.

8 Click the color you want to replace in the image. 

9 Drag in the image to replace the targeted color.

Using the Smudge tool (Photoshop)
The Smudge tool simulates the actions of dragging a finger through wet paint. The tool 
picks up color where the stroke begins and pushes it in the direction you drag. 

To use the Smudge tool:

1 Select the Smudge tool .

2 Choose a brush tip and options for the blending mode in the options bar (see “Setting 
options for painting and editing tools” on page 331).

3 Select Use All Layers in the options bar to smudge using color data from all visible 
layers. If this is deselected, the Smudge tool uses colors from only the active layer.

4 Select Finger Painting in the options bar to smudge using the foreground color at the 
beginning of each stroke. If this is deselected, the Smudge tool uses the color under the 
pointer at the beginning of each stroke.

5 Drag in the image to smudge the pixels.

In Photoshop, press Alt (Windows) or Option (Mac OS) as you drag with the Smudge 
tool to use the Finger Painting option.
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Using the Blur tool (Photoshop)
The Blur tool softens hard edges or areas in an image to reduce detail. For information on 
other ways to adjust sharpness, see “Sharpening images” on page 224 and “Blur filters” on 
page 421.

To use the Blur tool:

1 Select the Blur tool .

2 Do the following in the options bar:

3 Choose a brush tip and set options for the blending mode and strength in the options 
bar (see “Setting options for painting and editing tools” on page 331).

4 Select Use All Layers in the options bar to blur using data from all visible layers. If this is 
deselected, the tool uses data from only the active layer.

5 Drag over the part of the image you want to blur.

Using the Sharpen tool (Photoshop)
The Sharpen tool focuses soft edges to increase clarity or focus. For information on other 
ways to adjust sharpness, see “Sharpening images” on page 224 and “Sharpen filters” on 
page 428.

To use the Sharpen tool:

1 Select the Sharpen tool . 

2 Do the following in the options bar:

3 Choose a brush tip and set options for the blending mode and strength in the options 
bar (see “Setting options for painting and editing tools” on page 331).

4 Select Use All Layers in the options bar to sharpen using data from all visible layers. 
If this is deselected, the tool uses data from only the active layer.

5 Drag over the part of the image you want to sharpen.

Using the Dodge tool and the Burn tool (Photoshop)
Used to lighten or darken areas of the image, the Dodge tool and the Burn tools are based 
on a traditional photographer’s technique for regulating exposure on specific areas of a 
print. Photographers hold back light to lighten an area on the print (dodging) or increase 
the exposure to darken areas on a print (burning). 

To use the Dodge tool or the Burn tool:

1 Select the Dodge tool  or the Burn tool .

2 Choose a brush tip and set brush options in the options bar (see “Working with 
brushes” on page 317).

3 In the options bar, select one of the following:

• Midtones to change the middle range of grays

• Shadows to change the dark areas

• Highlights to change the light areas
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4 Specify the exposure for the Dodge tool or the Burn tool. (See “Specifying opacity, flow, 
strength, or exposure” on page 334.)

5 (Photoshop) Click the airbrush button  to use the brush as an airbrush. Alternately, 
select the Airbrush option in the Brushes palette. (See “Creating airbrush effects 
(Photoshop)” on page 328.)

6 Drag over the part of the image you want to lighten or darken.

Using the Sponge tool (Photoshop)
The Sponge tool subtly changes the color saturation of an area. In Grayscale mode, the 
tool increases or decreases contrast by moving gray levels away from or toward the 
middle gray.

To use the Sponge tool:

1 Select the Sponge tool . 

2 Choose a brush tip and set brush options in the options bar (see “Working with 
brushes” on page 317).

3 In the options bar, select the way you want to change the color.

• Saturate to intensify the color’s saturation

• Desaturate to dilute the color’s saturation

4 Specify the flow for the Sponge tool. (See “Specifying opacity, flow, strength, or 
exposure” on page 334.)

5 Drag over the part of the image you want to modify.

Using the Liquify filter
The Liquify filter lets you push, pull, rotate, reflect, pucker, and bloat any area of an image. 
The distortions you create can be subtle or drastic, which makes the Liquify command a 
powerful tool for retouching images as well as creating artistic effects. 

Distorting an image using the Liquify filter
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Using the Liquify dialog box
The Liquify dialog box provides tools and options for distorting an image.

Liquify dialog box 
A. Toolbox B. Preview image C. Options

Displaying the Liquify dialog box Choose Filter > Liquify.

Magnifying and reducing the preview image Select the Zoom tool  in the Liquify 
dialog box, and click or drag in the preview image to zoom in; hold down Alt (Windows) or 
Option (Mac OS), and click or drag in the preview image to zoom out. Alternately, you can 
specify a magnification level in the Zoom text box at the bottom of the dialog box.

Navigating in the preview image Select the Hand tool  in the Liquify dialog box, and 
drag in the preview image. Alternately, hold down the spacebar with any tool selected, 
and drag in the preview image. 

Using the distort tools
Several tools in the Liquify dialog box distort the brush area when you hold down the 
mouse button or drag. The distortion is concentrated at the center of the brush area, and 
the effect intensifies as you hold down the mouse button or repeatedly drag over an area.

Forward Warp Tool Pushes pixels forward as you drag.

Shift-click with the Warp tool, the Push Left tool, or the Mirror tool to create the effect 
of dragging in a straight line from the previous point you clicked.

CBA
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Twirl Clockwise tool Rotates pixels clockwise as you hold down the mouse button 
or drag. To twirl pixels counter-clockwise, hold down the Alt key (Windows) or Option 
(Mac OS) as you hold down the mouse button or drag.

Pucker Tool Moves pixels toward the center of the brush area as you hold down the 
mouse button or drag. 

Bloat Tool Moves pixels away from the center of the brush area as you hold down the 
mouse button or drag.

Push Left tool Moves pixels to the left when you drag the tool straight up (pixels 
move to the right if you drag down). You can also drag clockwise around an object to 
increase its size, or drag counter-clockwise to decrease its size. To push pixels right when 
you drag straight up (or to move pixels left when you drag down), hold down the Alt key 
(Windows) or Option (Mac OS) as you drag.

Mirror tool Copies pixels to the brush area. Drag to reflect the area perpendicular to 
the direction of the stroke (to the left of the stroke). Alt-drag (Windows) or Option-drag 
(Mac OS) to reflect the area in the direction opposite to that of the stroke (for example, 
the area above a downward stroke). Usually, Alt-dragging or Option-dragging gives better 
results when you have frozen the area you want to reflect. Use overlapping strokes to 
create an effect similar to a reflection in water.

Turbulence tool Smoothly scrambles pixels. It is useful for creating fire, clouds, waves, 
and similar effects.

Setting liquify tool options
In the Tool Options area of the dialog box, set the following options:

Brush size Sets the width of the brush you’ll use to distort the image.

Brush Pressure Sets the speed at which distortions are made when you drag a tool in the 
preview image. Using a low brush pressure makes changes occur more slowly, so it’s easier 
to stop them at exactly the right moment.

Brush Rate Sets the speed at which distortions are applied when you keep a tool (such as 
the Twirl tool) stationary in the preview image. A high setting applies distortions quickly; 
a lower setting provides a slower change.

Brush Density Controls how a brush feathers at the edge. An effect is strongest in the 
center of the brush and lighter at the edge.

Turbulent Jitter Control how tightly the Turbulence tool scrambles pixels.

Reconstruct Mode Used for the Reconstruct tool, the mode you choose determines how 
the tool reconstructs an area of the preview image (see “Reconstructing distortions” on 
page 281).

(Photoshop) Select Stylus Pressure Select to use pressure readings from a stylus tablet. 
(This option is available only when you are working with a stylus tablet.) When selected, 
the brush pressure for the tools is the stylus pressure multiplied by the Brush Pressure 
value.
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Distorting images
Distorting an image is as easy as dragging a tool in the preview image.

Note: If a type layer or a shape layer is selected, you must rasterize the layer before 
proceeding, making the type or shape editable. To distort type without rasterizing the type 
layer, use the Warp options for the Type tool (see “Warping type layers” on page 444).

To distort an image:

1 Select the layer you want to distort. To change only part of the current layer, select that 
area. 

2 Choose Filter > Liquify. 

3 Freeze areas of the image that you don’t want to alter. (See “Freezing areas” on 
page 280.)

4 Choose any of the liquify tools to distort the preview image (see “Using the distort 
tools” on page 278). Drag in the preview image to distort the image.

5 After distorting the preview image, you can use the Reconstruct tool  or other 
controls to fully or partially reverse the changes or to change the image in new ways. 
(See “Reconstructing distortions” on page 281.)

6 Do one of the following:

• Click OK to close the Liquify dialog box and apply the changes to the active layer.

• Click Cancel to close the Liquify dialog box without applying changes to the layer.

• Click Restore All to revert all distortions to the preview image, leaving all options in their 
current settings.

• Hold down Alt (Windows) or Option (Mac OS) and click Reset to revert all distortions to 
the preview image and reset all options to their defaults.

You can use the Edit > Fade command to create additional effects. (See “Blending filter 
effects (Photoshop)” on page 418.)

Freezing areas
By freezing areas of the preview image, you protect those areas from changes. Frozen 
areas are covered by a mask that you paint using the Freeze tool . You can also use an 
existing mask, selection, or transparency to freeze areas. You can view the mask in the 
preview image to help you with your distortions.

You can use the icons’ pop-up menus in the Mask Options area of the Liquify dialog box to 
choose how the frozen, or masked, areas of the preview image work (see “Using mask 
options” on page 281). 

Using the Freeze tool Select the Freeze tool  and drag over the area you want to 
protect. Shift-click to freeze in a straight line between the current point and the previous 
point that you clicked or Shift-clicked. 
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Using a selection, mask, or transparency channel Choose Selection, Layer Mask, 
Transparency, or Quick Mask from the pop-up menu from one of the five options in the 
Mask Options area of the dialog box (see “Using mask options” on page 281). 

Freezing all thawed areas Click the Mask All button in the Mask Options area of the 
dialog box.

Inverting thawed and frozen areas Click Invert All in the Mask Options area of the 
dialog box. 

Showing or hiding frozen areas Select or deselect Show Mask in the View Options area 
of the dialog box.

Changing the color of frozen areas Choose a color from the Mask Color pop-up menu 
in the View Options area of the dialog box.

Using mask options
When you have an existing selection or mask in an image, that information is retained 
when the Liquify dialog box opens. You can choose one of the following mask options:

Replace selection Shows the selection, mask, or transparency in the original image. 

Add to selection Shows the mask in the original image, so you can then add to the 
selection using the Freeze tool. Adds selected pixels in channel to the current freeze.

Subtract from selection Subtracts pixels in channel from current freeze.

Intersect with selection Uses only pixels that are selected and currently frozen.

Invert selection Uses selected pixels to invert current freeze.

Thawing areas
To thaw areas, do any of the following:

Using the Thaw tool Select the Thaw tool , and drag over the area. Shift-click to thaw 
in a straight line between the current point and the previous point that you clicked or 
Shift-clicked.

Thawing all frozen areas Click the None button in the Mask Options area of the dialog 
box.

Inverting frozen and thawed areas Click Invert All in the Mask Options area of the 
dialog box. If you used a selection, transparency, or alpha channel to define the frozen 
area, the alpha channel name in the Channel pop-up menu changes to Custom.

Reconstructing distortions
After you distort the preview image, you can use a variety of controls and reconstruction 
modes to reverse changes or redo the changes in new ways. Reconstructions can be 
applied two ways. You can apply a reconstruction to the entire image, smoothing out the 
distortion in unfrozen areas, or you can use the reconstruction tool to reconstruct in 
specific areas. You can use the Freeze tool to protect distorted areas from being recon-
structed.
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Reconstruction based on distortions in frozen areas 
A. Original image B. Distorted with frozen areas C. Reconstructed in Rigid mode (using button)  
D. Thawed, edges reconstructed in Smooth mode (using tool)

To reconstruct an entire image:

1 Select a reconstruction mode from the Reconstruct Options area of the dialog box 
(see “About reconstruction modes” on page 283).

2 Press the Reconstruct button in the Reconstruction Options area to apply the effect 
once. You can apply the reconstruction more than once to return the image to a less 
distorted appearance.

To remove all distortions:

Click the Restore All button in the Reconstruct Option area of the dialog box. This removes 
distortions even in frozen areas.

To reconstruct part of a distorted image:

1 Freeze areas you want to keep distorted. 

2 Select the Reconstruct tool . Choose one of these Reconstruct tool modes from the 
Brush Options area of the dialog box (see “About Reconstruct tool modes” on page 283).

3 Hold down the mouse button or drag over the area. Pixels move more quickly at the 
brush center. Shift-click to reconstruct in a straight line between the current point and the 
previous point that you clicked or Shift-clicked.

To repeat distortions sampled from a starting point:

1 After distorting the preview image, choose one of these reconstruction modes from the 
Mode menu in the Tool Options area of the dialog box (see “About Reconstruct tool 
modes” on page 283).

2 Select the Reconstruct tool , and in the preview image, hold down the mouse button 
or drag from a starting point. 

A B

C D
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This creates a copy of the distortion sampled at the starting point, similar to the way you 
can paint a copy of an area using the Clone tool. If there is no distortion, the effect is the 
same as using Revert mode. You can set new starting points and use the Reconstruct tool 
repeatedly to create a variety of effects.

About reconstruction modes
You can choose one of the following reconstruct modes:

Rigid Maintains right angles in the pixel grid (as shown by the mesh) at the edges 
between frozen and unfrozen areas, sometimes producing near-discontinuities at the 
edges. This restores the unfrozen areas to something close to their original appearance. 
(To restore their original appearance, use Revert reconstruction mode.)

Stiff Acts like a weak magnetic field. At the edges between frozen and unfrozen areas, the 
unfrozen areas continue the distortions in the frozen areas. As the distance from frozen 
areas increases, the distortions lessen.

Smooth Propagates the distortions in frozen areas throughout unfrozen areas, with 
smoothly continuous distortions.

Loose Produces effects similar to Smooth, with even greater continuity between distor-
tions in frozen and unfrozen areas.

Revert Scales back distortions uniformly without any kind of smoothing.

About Reconstruct tool modes
The Reconstruct tool has three modes that use the distortion where the tool was first 
clicked (start point) to reconstruct the area the tool is brushed over. Every time the mouse 
is clicked it sets a new start point, so if you want to extend an effect from one start point, 
don’t release the mouse button until you’re done using the Reconstruct tool.

Displace Reconstructs unfrozen areas to match the displacement at the start point for 
the reconstruction. You can use Displace to move all or part of the preview image to a 
different location. If you click and gradually spiral out from the start point, you’ll displace 
or move a portion of the image to the area you’ve brushed over.

Amplitwist Reconstructs unfrozen areas to match the displacement, rotation, and overall 
scaling that exist at the start point. 

Affine Reconstructs unfrozen areas to match all distortions that exist at the start point, 
including displacement, rotation, horizontal and vertical scaling, and skew.

Working with meshes
Using a mesh helps you see and keep track of distortions. You can choose the size and 
color of a mesh. You can save the mesh from one image and apply it to other images. 

Using a mesh To add a mesh, select Show Mesh in the View Options area of the dialog 
box, and choose a mesh size, mesh color, and freeze color. 

Viewing a mesh To show a mesh, select Show Mesh. When Show Mesh is selected, you 
can show or hide the preview image. Select Show Image in the View Options area of the 
dialog box to show the preview image; deselect Show Image to view only the mesh.
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Saving a distortion mesh After distorting the preview image, click Save Mesh. Specify a 
name and location for the mesh file, and click Save.

Applying a distortion mesh Click Load Mesh, select the mesh file you want to apply, and 
click Open. If the image and distortion mesh aren’t the same size, the mesh is scaled to fit 
the image.

Working with backdrops
You can choose to show only the active layer in the preview image, or you can show 
additional layers in the preview image as a backdrop. Using the Mode options, you can 
position the backdrop in front of or behind the active layer to help you keep track of the 
changes you’re making, or to line up a distortion with another distortion made in a 
different layer.

Note: Only the active layer is distorted, even if other layers are displayed. 

Showing the backdrop Select Show Backdrop, and then choose an option from the Use 
pop-up menu. If you use All Layers, changes to the current target layer are not reflected in 
the backdrop layer. Specify an overlay opacity to change the blending between the target 
layer and the backdrop. The mode selects how the backdrop and the target layer are 
combined for the preview. Choose an option from the Mode pop-up menu.

Hiding the backdrop Deselect Show Backdrop in the View Options area of the 
dialog box.

Creating panoramic images using Photomerge 
(Photoshop)
The Photomerge™ command combines several photographs into one continuous image. 
For example, you can take five overlapping photographs of a city skyline, and then 
assemble them into a panorama. The Photomerge command is capable of assembling 
photos that are tiled horizontally as well as vertically. 

Source images (top), and completed Photomerge composition (bottom)

Opening Photomerge compositions Choose File > Automate > Photomerge, and then 
click the Open Composition button. Choose the composition you want to open.
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Taking pictures for use with Photomerge
Your source photographs play a large role in panoramic compositions. To avoid problems, 
follow these guidelines when taking pictures for use with Photomerge:

Overlap images sufficiently Images should have an overlap of approximately 15% to 
40% of the image area. If the overlap is less, Photomerge may not be able to automatically 
assemble the panorama. However, keep in mind that the images shouldn’t overlap too 
much. If images overlap by 70% or more, it can be difficult to work with them, and 
blending may not be as effective. Try to keep the individual photos at least somewhat 
distinct from each other.

Use a consistent focal length Avoid using the zoom feature of your camera while taking 
your pictures. 

Keep the camera level Although Photomerge can process slight rotations between 
pictures, a tilt of more than a few degrees can result in errors when automatically assem-
bling the panorama. Using a tripod with a rotating head helps maintain camera alignment 
and viewpoint.

When photographing a panoramic scene from a high place, the natural inclination is 
to keep the horizon level in the viewfinder. However, this actually produces a 

noticeable rotation between images. Try using a tripod to keep the camera level when 
taking photographs in this situation. 

Stay in the same position Try not to change your position as you take a series of photo-
graphs, so that the pictures are from the same viewpoint. If you walk to a new position 
while taking photographs, you’ll likely disrupt the continuity of your images. Using the 
optical viewfinder with the camera held close to the eye helps keep the viewpoint 
consistent. Or try using a tripod to keep the camera in the same place.

Avoid using distortion lenses Lenses, such as fish-eye lenses, that cause noticeable 
distortion to the image can interfere with Photomerge.

Maintain the same exposure Avoid using the flash in some pictures and not in others. 
The advanced blending feature in Photomerge helps smooth out different exposures, but 
extreme differences make alignment difficult. Some digital cameras change exposure 
settings automatically as you take pictures, so you may need to check your camera 
settings to be sure that all the images have the same exposure.

Using the Photomerge dialog box
The Photomerge dialog box contains tools for manipulating the composition, a lightbox 
for storing source images that are not in use, a work area for assembling the composition, 
and options for viewing and editing the composition. You can also zoom in and out to 
better see the alignment of each file.
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Photomerge dialog box 
A. Lightbox B. Navigator view box C. Toolbox D. Work area E. Status bar

Navigating in the Photomerge dialog box Do one or more of the following in the 
Photomerge dialog box:

• Select the Hand tool  and drag in the work area to move the view.

• Drag the view box or the scroll bars in the Navigator thumbnail. The view box repre-
sents the boundaries of the work area.

Zooming in the Photomerge dialog box Do one of the following:

• Click the zoom in icon  below the Navigator.

• Use the Zoom tool  to zoom in.

• Click the zoom out icon  below the Navigator.

Using the lightbox You can use the lightbox to rearrange images in the Photomerge 
composition. To use the lightbox, select the Select Image tool , and then do one or more 
of the following:

• Drag an image from the lightbox to the work area to add it to the composition. 

• Drag an image from the work area to the lightbox to remove it from the composition.

• Double-click an image in the lightbox to add it to the composition.

Make sure Snap to Image is selected to automatically snap overlapping images into 
place when a commonality is detected.

Rotating images Select the Select Image tool , and click the image you want to rotate. 
Select the Rotate tool , and then click near the edge of the image and drag in a circular 
motion around the center of the image.

D
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Creating a Photomerge composition
When you set up a Photomerge composition, you identify your source files, and then the 
assembly of the panorama is automatically done for you. Once the panorama is complete, 
you can still make changes to the placement of the individual photos, if necessary.

To set up a new Photomerge composition:

1 Do one of the following:

• Choose File > Automate > Photomerge.

• In the File Browser, select the images you want to use and then choose Automate > 
Photomerge from the File Browser menu bar (see “Running automated tasks from the 
File Browser” on page 96).

2 In the dialog box, choose an option from the Use pop-up menu:

• Files to generate the Photomerge composition using individual files.

• Folders to use all the images stored in a folder to create the Photomerge composition. 
The files in the folder appear in the dialog box.

• Open Files to use the image files you have open in Photoshop.

3 Click the Browse button to navigate to the source files or folder you want to use to 
create the Photomerge composition. Select Attempt to Automatically Arrange Source 
Images if you want Photoshop to try to line the images up in their proper order. Deselect 
this option if you want to arrange the images in the lightbox yourself.

You can add more files by clicking the Browse button again and navigating to the 
source files. You can always remove a file from the Source Files list by selecting the file 

and clicking the Remove button.

4 When you’ve added all the source files, click OK to create the Photomerge composition. 
The source files will open automatically and will be processed. 

If the composition can’t be automatically assembled, a message appears on-screen. 
You can assemble the composition manually in the Photomerge dialog box using the 

lightbox. (See “Using the Photomerge dialog box” on page 285.)

5 Once the new panorama image appears in the Photomerge dialog box, you can work 
with individual source files and change your view of the work area. If you need to 
rearrange the order of the images, drag an image in the work area to reposition it, or 
rearrange the images in the light box (see “Using the Photomerge dialog box” on 
page 285).

6 If necessary, adjust the vanishing point or blending settings of your composition (see 
“Changing Photomerge composition settings” on page 288.)

7 If you’d like to save each image in the composition as individual layers, which is useful if 
you need to correct the color of each image separately, select Keep as Layers.
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8 Do one of the following:

• Click the OK button to generate the panorama as a new Photoshop file. The compo-
sition then opens in Photoshop.

• Click the Save Composition As button to save the composition so you can open it again 
at a later time.

Changing Photomerge composition settings
How source images appear in the Photomerge dialog box depends on the settings you 
choose. Adobe Photoshop lets you adjust the perspective and blend exposure differences 
to produce the best possible effect.

The Vanishing Point tool selects the vanishing point image, which changes the 
perspective of the composition. The middle image is the default vanishing point image 
(it has a blue border around it when selected). There can only be one vanishing point 
image in a composition.

The Cylindrical Mapping and Advanced Blending options are used to process the final 
image. The results of applying these options are visible only in Preview mode or in the 
final, generated image.

To change the vanishing point of a composition:

1 Select Perspective in the Settings area of the Photomerge dialog box.

2 Select the Vanishing Point tool , and click on an image in the work area to make it the 
vanishing point image. 

3 If necessary, use the Select Image tool  to adjust the position of the non-vanishing 
point images. A non-vanishing point image has a red border around it when selected. 

When you apply perspective correction to a composition, the non-vanishing point images 
are linked to the vanishing point image. You can break this link by clicking the Normal 
button, by separating the images in the work area, or by dragging the vanishing point 
image back to the lightbox. Once the link is broken, images return to their original shapes.

The perspective correction only works up to an approximately 120° angle of view. For a 
wider angle of view, deselect the Perspective option.

To change the perspective of a composition, select the Vanishing Point tool, and click 
a non-vanishing point image in the work area. Notice how the perspective of the 

composition changes depending on which image is the vanishing point image.
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To apply Advanced Blending or Cylindrical Mapping:

1 Select Composition options as desired:

• Cylindrical Mapping to reduce the “bow tie” distortion that can occur when you apply 
perspective correction. You must select the Perspective option in order to apply 
cylindrical mapping.

Adding Cylindrical Mapping 
A. Original B. Cylindrical Mapping applied

• Advanced Blending to minimize color inconsistencies that result from blending images 
with exposure differences. When this option is selected, broad colors and tones are 
blended over a large area, while detailed colors and tones are blended over a smaller 
area.

2 Click Preview. To return to edit mode, click Exit Preview.
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Drawing

About shapes and paths
When you draw in Photoshop, you create vector shapes—mathematically defined lines and 
curves. You use the drawing tools to create shape layers and work paths. Shapes are 
resolution-independent—they maintain crisp edges when resized, printed to a PostScript 
printer, saved in a PDF file, or imported into a vector-based graphics application. You can 
use shapes to make selections and create libraries of custom shapes with the 
Preset Manager.

In Photoshop, paths are used for making selections and defining areas of an image. 
The outline of a shape is a path. Paths are made up of one or more straight or curved 
segments. Each segment is marked by anchor points, which work like pins holding wire in 
place. You can easily change the shape of a path by editing its anchor points. The Paths 
palette helps you manage paths. You can’t use paths in ImageReady.

Drawing options 
A. Shape layers B. Paths C. Fill pixels

Using the shape tools 
In Photoshop, you can quickly select, resize, and move a shape, and you can edit a shape’s 
attributes (such as stroke, fill color, and style). 

ImageReady shapes are object-oriented, meaning that you can resize and move the 
shapes (see “Using the Free Transform command” on page 268) but not the outline of the 
shape. In ImageReady, you can easily align shapes as you draw them using smart guides 
(see “Using guides and the grid” on page 43). 

Note: The Polygon tool , Custom Shape tool , Add Anchor Point tool , Delete Anchor 
Point tool , and Convert Point tool  are available only in Photoshop.

A B C
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Creating shapes
Shapes are drawn on shape layers. In Photoshop, you can draw more than one shape in a 
shape layer, and specify how overlapping shapes interact. In ImageReady, you can draw 
only one shape in a layer. 

Shapes are automatically filled with the current foreground color; however, you can easily 
change the fill to a different color, a gradient, or a pattern. The shape’s outline is stored in a 
vector mask that is linked to the layer.

Hold down Shift to constrain a rectangle or rounded rectangle to a square, 
to constrain an ellipse to a circle, or to constrain the line angle to a multiple of 45°.

Drawing multiple shapes in a layer 
A. Original shape plus additional shape B. Result with Add to Shape Area selected C. Result with 
Subtract from Shape Area selected D. Result with Intersect Shape Areas selected E. Result with 
Exclude Overlapping Shape Areas selected

To create a new shape:

1 Select a shape tool or a Pen tool. Make sure that the Shape Layers button  is selected 
in the options bar.

2 To choose the color of the shape, click the color swatch in the options bar, and then 
choose a color from the Color Picker.

3 If you want to apply a style to the shape, select a preset style from the Style pop-up 
menu. (See “Applying preset styles” on page 392.)

4 Set additional tool-specific options (see “Using the shape tools” on page 290).

5 Drag in your image to draw a shape. You can then resize or edit the shape (see “Editing 
shapes (Photoshop)” on page 294).

Hold down the spacebar while you’re dragging the mouse to move the shape without 
changing its size or proportions. 

To draw multiple shapes in a layer (Photoshop):

1 Select the layer to which you want to add shapes.

2 Select a drawing tool and set tool-specific options (see “Setting shape tool options” on 
page 293).

3 Choose one of the following in the options bar:

• Add to Shape Area  to add the new area to the existing shapes or path.

A B C
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• Subtract from Shape Area  to remove the overlapping area from the existing shapes 
or path. 

• Intersect Shape Areas  to restrict the area to the intersection of the new area and the 
existing shapes or path.

• Exclude Overlapping Shape Areas  to exclude the overlap area in the consolidated 
new and existing areas.

4 Draw in the image. You can easily switch between drawing tools by clicking a tool 
button in the options bar.

Using custom shapes (Photoshop)
When you’re using the Custom Shape tool, you can choose from a variety of preset shapes. 
You can also save shapes that you create as preset shapes.

To select a custom shape:

1 Select the Custom Shape tool .

2 Select a shape from the Shape pop-up palette. (See “Using pop-up palettes” on 
page 24.)

To save a shape or path as a custom shape:

1 In the Paths palette, select a path—either a vector mask for a shape layer, a work path, 
or a saved path.

2 Choose Edit > Define Custom Shape, and enter a name for the new custom shape in the 
Shape Name dialog box. The new shape appears in the Shape pop-up palette.

3 To save the new custom shape as part of a new library, select Save Shapes from the 
pop-up palette menu. You can also use the Preset Manager to manage libraries of custom 
shapes. For more information, see “Managing libraries with the Preset Manager 
(Photoshop)” on page 52.

Creating rasterized shapes
You can create a rasterized (or bitmap) shape by making a selection and filling it with the 
foreground color. You cannot edit a rasterized shape as a vector object. Raster shapes are 
created using the current foreground color.

To create a rasterized shape (Photoshop):

1 Select a layer. You cannot create a rasterized shape on a vector-based layer (for 
example, a type layer).

2 Select a shape tool, and click the Fill Pixels button  in the options bar.

3 Set the following options in the options bar:

• Mode to control how the shape will affect the existing pixels in the image. 
(See “Selecting a blending mode” on page 331.)

• Opacity to determine to what degree the shape will obscure or reveal the pixels 
beneath it. A shape with 1% opacity appears nearly transparent, while one with 100% 
opacity appears completely opaque.

• Anti-Aliased to blend the shape’s edge pixels with the surrounding pixels.
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4 Set additional tool-specific options, and draw a shape. For more information, see “Using 
the shape tools” on page 290 and “Using the pen tools (Photoshop)” on page 295.

Note: In Photoshop, you can easily switch between drawing tools by clicking a tool button 
in the options bar.

To create a rasterized shape (ImageReady):

1 Select a layer that contains the shape you want to rasterize.

2 Choose Layer > Rasterize > Shape.

Setting shape tool options
Each shape tool provides specific options; for example, you can set options that allow you 
to draw a rectangle with fixed dimensions or a line with arrowheads. The available options 
vary by tool. In Photoshop, options are shown in a pop-up menu. In ImageReady, available 
options are displayed in the options bar.

(Photoshop) Click the inverted arrow to display options for the selected shape.

To set tool-specific options:

1 Select the Rectangle tool , Rounded Rectangle tool , Ellipse tool , Polygon tool  
(Photoshop), Line tool , or Custom Shape tool  (Photoshop).

2 Set tool options in the options bar. In Photoshop, click the inverted arrow  next to the 
shape buttons to view the options:

Arrowheads Start and End Adds arrowheads to a line. Select the Line tool and then 
select Start to add an arrow to the beginning of the line; select End to add an arrow to the 
end of the line. Select both options to add arrows on both ends. In ImageReady, click 
Shape to define the shape of the arrowhead; in Photoshop, the shape options appear in 
the pop-up dialog box. Enter values for Width and Length to specify the proportions of the 
arrowhead as a percentage of the line width (10% to 1000% for Width, and 10% to 5000% 
for Length). Enter a value for the concavity of the arrowhead (from –50% to +50%). The 
concavity value defines the amount of curvature on the widest part of the arrowhead, 
where the arrowhead meets the line.

Note: In Photoshop, you can also edit an arrowhead directly using the vector selection 
and drawing tools.

Circle (Photoshop) Constrains an ellipse to a circle.

Corner Radius (ImageReady) Specifies the corner radius for rendering a rounded 
rectangle or tab rectangle. 

Defined Proportions (Photoshop) Renders a custom shape based on the proportions 
with which it was created.
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Defined Size (Photoshop) Renders a custom shape based on the size at which it was 
created.

Fixed Size Renders a rectangle, rounded rectangle, ellipse, or custom shape as a fixed 
shape based on the values you enter in the Width and Height text boxes.

From Center (Photoshop) Renders a rectangle, rounded rectangle, ellipse, or custom 
shape from the center.

Indent Sides By (Photoshop) Renders a polygon as a star. Enter a percentage in the text 
box to specify the portion of the star’s radius taken up by the points. A 50% setting creates 
points that are half the total radius of the star; a larger value creates sharper, thinner 
points; a smaller value creates fuller points.

Proportional (Photoshop) Renders a rectangle, rounded rectangle, or ellipse as a 
proportional shape based on the values you enter in the Width and Height text boxes.

Radius (Photoshop) For rounded rectangles, specifies the corner radius. For polygons, 
specifies the distance from the center of a polygon to the outer points.

Sides (Photoshop) Specifies the number of sides in a polygon.

Smooth Corners or Smooth Indents (Photoshop) Renders a polygon with smooth 
corners or indents.

Snap to Pixels (Photoshop) Snaps edges of a rectangle or rounded rectangle to the 
pixel boundaries.

Square (Photoshop) Constrains a rectangle or rounded rectangle to a square.

Unconstrained (Photoshop) Lets you set the width and height of a rectangle, rounded 
rectangle, ellipse, or custom shape by dragging.

Weight Determines the width of a line in pixels. 

Editing shapes (Photoshop)
A shape is a fill layer linked to a vector mask. You can easily change the fill to a different 
color, a gradient, or a pattern by editing the shape’s fill layer. You can also edit the shape’s 
vector mask to modify the shape outline, and apply a style to the layer. 

For information on transforming shapes in ImageReady, see “Using the Free Transform 
command” on page 268.

To change the color of a shape:

Double-click the shape layer’s thumbnail in the Layers palette, and choose a different color 
using the color picker.

To fill a shape with a pattern or gradient:

1 Select a shape layer in the Layers palette.

2 Do one of the following:

• Choose Layer > Change Layer Content > Gradient, and set gradient options.

• Choose Layer > Change Layer Content > Pattern, and set pattern options.

For more information, see “Using adjustment layers and fill layers (Photoshop)” on 
page 402.
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To modify the outline of a shape:

Click the shape layer’s vector mask thumbnail in the Layers palette or Paths palette. Then 
change the shape using the shape and pen tools.

For more information, see “Moving, reshaping, copying, and deleting path components” 
on page 305.

Using the pen tools (Photoshop)
You can create or edit straight lines, curves, or freeform lines and shapes using the pen 
tools. The pen tools can be used in conjunction with the shape tools to create complex 
shapes.

Drawing with the Pen tool
The Pen tool lets you create straight lines and smooth flowing curves with greater 
precision than is possible with the Freeform Pen tool. For most users, the Pen tool provides 
the best control and greatest accuracy for drawing.

To draw with the Pen tool: 

1 Select the Pen tool .

2 Set the following tool-specific options:

• To add an anchor point when you click a line segment and delete an anchor point when 
you click it, select Auto Add/Delete in the options bar. (See “Adding, deleting, and 
converting anchor points” on page 307.)

• To preview path segments as you draw, click the inverted arrow  next to the shape 
buttons in the options bar, and select Rubber Band. 

3 Position the pen pointer where you want to begin to draw, and click to define the first 
anchor point.

4 Click or drag to set anchor points for additional segments.

5 Complete the path:

• To end an open path, Ctrl-click (Windows) or Command-click (Mac OS) away from 
the path.

• To close a path, position the pen pointer over the first anchor point. A small loop 
appears next to the pen tip when it is positioned correctly. Click to close the path.

For more information on closed and open paths, see “About anchor points, direction lines, 
direction points, and components” on page 301.

Drawing straight segments with the pen tool
The simplest segment you can draw with the Pen tool is a straight segment, made by 
clicking to create anchor points. 

To draw straight segments: 

1 Position the pen pointer where you want the straight segment to begin, and click to 
define the first anchor point. 

2 Click again where you want the first segment of the straight line to end, or Shift-click to 
constrain the angle of the segment to a multiple of 45°.
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3 Continue clicking to set anchor points for additional segments. The last anchor point is 
always a solid square, indicating it is selected. Previously defined anchor points become 
hollow squares as you add further anchor points. 

If the Auto Add/Delete option is selected in the options bar, you can click an existing 
point to delete it.

Drawing curves with the Pen tool
You create curves by dragging the Pen tool in the direction you want the curve to go. Keep 
these guidelines in mind when drawing curves:

• Always drag the first direction point in the direction of the bump of the curve, and drag 
the second direction point in the opposite direction to create a single curve. Dragging 
both direction points in the same direction creates an “S” curve.

Drag in the opposite direction to create a smooth curve. Drag in the same direction 
to create an “S” curve. 

• When drawing a series of smooth curves, draw one curve at a time, placing anchor 
points at the beginning and end of each curve, not at the tip of the curve. 

• To decrease the file size and reduce the potential for printing errors, use as few anchor 
points as possible, and place them as far apart as possible.

For more information on how paths are constructed, see “About anchor points, direction 
lines, direction points, and components” on page 301.

To draw a curve: 

1 Position the pointer where you want the curve to begin, and hold down the mouse 
button. The first anchor point appears, and the pointer changes to an arrowhead.

2 Drag in the direction you want the curve segment to be drawn. As you drag, the pointer 
leads one of two direction points. Hold down the Shift key to constrain the tool to 
multiples of 45°, and release the mouse button once you have positioned the first 
direction point. 
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The length and slope of the direction line determine the shape of the curve segment. 
You can adjust one or both sides of the direction line later.

Drag in the direction of the curve to set the first anchor point. Drag in the opposite direction to 
complete the curve segment.

3 Position the pointer where you want the curve segment to end, and drag in the 
opposite direction to complete the segment. 

4 Do one of the following:

• To draw the next segment of a smooth curve, position the pointer where you want the 
next segment to end, and drag away from the curve.

Drag away from the curve to create the next segment.

• To change the direction of the curve sharply, release the mouse button, and then 
Alt-drag (Windows) or Option-drag (Mac OS) the direction point in the direction of the 
curve. Release Alt (Windows) or Option (Mac OS) and the mouse button, reposition the 
pointer where you want the segment to end, and drag in the opposite direction to 
complete the curve segment.

• To break out the direction lines of an anchor point, Alt-drag (Windows) or Option-drag 
(Mac OS) the lines.

Alt-drag or Option-drag the direction point toward the curve. Release the key, and drag in the 
opposite direction.
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Drawing with the Freeform Pen tool
The Freeform Pen tool lets you draw as if you were drawing with a pencil on paper. Anchor 
points are added automatically as you draw. You do not determine where the points are 
positioned, but you can adjust them once the path is complete. 

The Magnetic Pen is an option of the Freeform Pen tool that lets you draw a path that 
snaps to the edges of defined areas in your image. You can define the range and sensitivity 
of the snapping behavior, as well as the complexity of the resulting path. The Magnetic 
Pen and Magnetic Lasso tools share many of the same options.

To draw with the Freeform Pen tool:

1 Select the Freeform Pen tool .

2 To control how sensitive the final path is to the movement of your mouse or stylus, click 
the inverted arrow  next to the shape buttons in the options bar, and enter a value 
between 0.5 and 10.0 pixels for Curve Fit. A higher value creates a simpler path with fewer 
anchor points.

3 Drag the pointer in the image. As you drag, a path trails behind the pointer. When you 
release the mouse, a work path is created.

4 To continue the existing freehand path, position the pen pointer on an endpoint of the 
path, and drag.

5 To complete the path, release the mouse. To create a closed path, drag the line to the 
initial point of the path (a circle appears next to the pointer when it is aligned). For more 
information on closed and open paths, see  “About anchor points, direction lines, direction 
points, and components” on page 301.

To draw using the magnetic pen options:

1 To convert the Freeform Pen tool to the Magnetic Pen tool , select Magnetic in the 
options bar, or click the inverted arrow next to the shape buttons in the options bar, select 
Magnetic, and set the following:

• For Width, enter a pixel value between 1 and 256. The Magnetic Pen detects edges only 
within the specified distance from the pointer.

• For Contrast, enter a percentage value between 1 and 100 to specify the contrast 
between pixels required to be considered an edge. Use a higher value for low contrast 
images.

• For Frequency, enter a value between 0 and 100 to specify the rate at which the Pen sets 
anchor points. A higher value anchors the path in place more quickly.

• If you are working with a stylus tablet, select or deselect Pen Pressure. When this option 
is selected, an increase in pen pressure causes the width to decrease.

2 Click in the image to set the first fastening point.

3 To draw a freehand segment, move the pointer or drag along the edge you want to 
trace.
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The most recent segment of the border remains active. As you move the pointer, the 
active segment snaps to the strongest edge in the image, connecting the pointer to the 
last fastening point. Periodically, the Magnetic Pen adds fastening points to the border to 
anchor previous sections.

Click to add fastening points, and continue tracing.

4 If the border doesn’t snap to the desired edge, click once to add a fastening point 
manually and to keep the border from moving. Continue to trace the edge and add 
fastening points as needed. If needed, press Delete to remove the last fastening point.

5 To dynamically modify the properties of the Magnetic Pen, do one of the following:

• Alt-drag (Windows) or Option-drag (Mac OS) to draw a freehand path.

• Alt-click (Windows) or Option-click (Mac OS) to draw straight segments.

• Press the [ key to decrease the Magnetic Pen width by 1 pixel; press the ] key to increase 
the pen width by 1 pixel. 

6 Complete the path:

• Press Enter (Windows) or Return (Mac OS) to end an open path.

• Double-click to close the path with a magnetic segment.

• Hold down Alt (Windows) or Option (Mac OS), and double-click to close the path with a 
straight segment.

Working with paths (Photoshop)
A path is composed of one or more path components—collections of one or more anchor 
points joined by segments. Because they take up less disk space than pixel-based data, 
paths can be used for long-term storage of simple masks.

Paths can also be used to clip sections of your image for export to an illustration or page-
layout application. (See “Using image clipping paths to create transparency” on page 601.) 

Using the Paths palette (Photoshop)
The Paths palette lists the name and a thumbnail image of each saved path, the current 
work path, and the current vector mask. Decreasing the size of thumbnails or turning 
them off lets you list more paths in the palette, and turning thumbnails off can improve 
performance. To view a path, you must first select it in the Paths palette.
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To display the Paths palette:

Choose Window > Paths.

To select or deselect a path in the palette:

Do one of the following:

• To select a path, click the path name in the Paths palette. Only one path can be selected 
at a time.

• To deselect a path, click in the blank area of the Paths palette or press Esc.

To change the size of path thumbnails:

1 Choose Palette Options from the Paths palette menu.

2 Select a size, or select None to turn off the display of thumbnails. 

To change a path’s stacking order:

1 Select the path in the Paths palette.

2 Drag the path up or down in the Paths palette. When the heavy black line appears in the 
desired location, release the mouse button.

Note: You cannot change the order of vector masks or working paths in the Paths palette.

Creating a work path (Photoshop)
A work path is a temporary path that appears in the Paths palette and defines the outline 
of a shape. You can use paths in several ways:

• You can use a path as a vector mask to hide areas of a layer. (See “Masking layers” on 
page 408.)

• You can convert a path to a selection. For more information, see “Converting between 
paths and selection borders (Photoshop)” on page 310.

• You can edit a path to change its shape. For more information, see “Managing paths 
(Photoshop)” on page 308.

• You can designate a saved path as a clipping path to make part of an image transparent 
when exporting the image to a page-layout or vector-editing application.

Create a new path in the Paths palette before you begin drawing to automatically save 
the work path as a named path.

To create a new work path:

1 Select a shape tool or a pen tool, and click the Paths button  in the options bar.

2 Set tool-specific options, and draw the path. For more information, see “Using the 
shape tools” on page 290 and “Using the pen tools (Photoshop)” on page 295.

3 Draw additional path components if desired. You can easily switch between drawing 
tools by clicking a tool button in the options bar. Choose a path area option to determine 
how overlapping path components intersect:

• Add to Path Area  to add the new area to overlapping path areas. 

• Subtract from Path Area  to remove the new area from the overlapping path area. 
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• Intersect Path Areas  to restrict the path to the intersection of the new area and the 
existing area.

• Exclude Overlapping Path Areas  to exclude the overlap area in the consolidated 
path.

Use the following keyboard shortcuts while drawing with a shape tool: Hold down 
Shift to temporarily select the Add to Path Area option; hold down Alt (Windows) or 

Option (Mac OS) to temporarily select the Subtract from Path Area option.

About anchor points, direction lines, direction points, and 
components
A path consists of one or more straight or curved segments. Anchor points mark the 
endpoints of the path segments. On curved segments, each selected anchor point 
displays one or two direction lines, ending in direction points. The positions of direction 
lines and points determine the size and shape of a curved segment. Moving these 
elements reshapes the curves in a path.

A path 
A. Curved line segment B. Direction point C. Direction line D. Selected anchor point
E. Unselected anchor point

A path can be closed, with no beginning or end (for example, a circle), or open, with 
distinct endpoints (for example, a wavy line). 

Smooth curves are connected by anchor points called smooth points. Sharply curved paths 
are connected by corner points. 

Smooth point, and corner point

E

A B

C

D
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When you move a direction line on a smooth point, the curved segments on both sides of 
the point adjust simultaneously. By comparison, when you move a direction line on a 
corner point, only the curve on the same side of the point as the direction line is adjusted. 

Adjusting a smooth point, and a corner point

A path does not have to be all one connected series of segments. It can contain more than 
one distinct and separate path components. Each shape in a shape layer is a path 
component, as described by the layer’s clipping path.

Separate path components selected

Selecting paths (Photoshop)
Selecting a path component or path segment displays all of the anchor points on the 
selected portion, including any direction lines and direction points if the selected 
segment is curved. Direction points appear as filled circles, selected anchor points as filled 
squares, and unselected anchor points as hollow squares. 

To select a path:

1 Do one of the following:

• To select a path component (including a shape in a shape layer), select the Path 
Selection tool , and click anywhere inside the path component. If a path consists of 
several path components, only the path component under the pointer is selected.

To display the bounding box along with the selected path, select Show Bounding Box 
in the options bar.
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• To select a path segment, select the Direct Selection tool , and click one of the 
segment’s anchor points or drag a marquee over part of the segment.

Drag a marquee to select segments.

2 To select additional path components or segments, select the Path Selection tool or the 
Direct Selection tool, and then hold down Shift while selecting additional paths or 
segments.

When the Direct Selection tool is selected, you can select the entire path or path 
component by Alt-clicking (Windows) or Option-clicking (Mac OS) inside the path. 

To activate the Direct Selection tool when any other tool is selected, position the pointer 
over an anchor point, and press Ctrl (Windows) or Command (Mac OS).

To change the overlap mode for the selected path component:

Using the Path Selection tool , drag a marquee to select existing path areas, and then 
choose a shape area option in the options bar:

• Add to Shape Area  to add the path area to overlapping path areas

• Subtract from Shape Area  to remove the path area from overlapping path areas

• Intersect Shape Areas  to restrict the area to the intersection of the selected path area 
and overlapping path areas

• Exclude Overlapping Shape Areas  to exclude the overlap area

To show or hide the selected path component:

Do one of the following:

• Choose View > Show > Target Path.

• Choose View > Extras. This command also shows or hides a grid, guides, selection 
edges, annotations, and slices.

Moving, reshaping, and deleting path segments
You can move, reshape, or delete individual segments in a path, and you can add or delete 
anchor points to change the configuration of segments. 

Note: You can also apply a transformation, such as scaling, rotating, flipping, or 
distorting, to a segment or anchor point. See “Applying transformations” on page 266.

To move a straight segment:

1 Select the Direct Selection tool , and select the segment you want to adjust. To adjust 
the angle or length of the segment, select an anchor point.

2 Drag the selected segment to its new position.
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To move a curved segment:

1 Select the Direct Selection tool , and select the points or segments you want to move. 
Be sure to select both points anchoring the segment.

2 Drag the selected anchor points or segments to new positions. Hold down Shift as you 
drag to constrain the movement to multiples of 45°.

Select points anchoring a curve. Then drag to move the curve.

To reshape a curved segment:

1 Select the Direct Selection tool , and select the curved segment you want to adjust. 
Direction lines appear for that segment.

2 Adjust the curve:

• To adjust the position of the segment, drag the segment.

Click to select the curve segment. Then drag to adjust.

• To adjust the shape of the segment on either side of a selected anchor point, drag the 
anchor point or the direction point. Hold down Shift as you drag to constrain 
movement to multiples of 45°.

Drag the anchor point, or drag the direction point.
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To delete a segment:

1 Select the Direct Selection tool , and select the segment you want to delete.

2 Press Backspace (Windows) or Delete (Mac OS) to delete the selected segment. 
Pressing Backspace or Delete again erases the rest of the path component. 

Moving, reshaping, copying, and deleting path components
You can reposition a path component (including a shape in a shape layer) anywhere 
within an image. You can copy components within an image or between two Photoshop 
images. Using the Path Selection tool, you can merge overlapping components into a 
single component. All vector objects, whether they are described by a saved path, a work 
path, or a vector mask, can be moved, reshaped, copied, or deleted.

You can also use the Copy and Paste commands to duplicate vector objects between a 
Photoshop image and an image in another application, such as Adobe Illustrator.

To move a path or path component:

1 Select the path name in the Paths palette, and use the Path Selection tool  to select 
the path in the image. To select multiple path components, Shift-click each additional 
path component to add it to the selection.

2 Drag the path to its new location. If you move any part of a path beyond the canvas 
boundaries, the hidden part of the path is still available.

Dragging a path to a new location

Note: If you drag a path so that the move pointer is over another open image, the path will 
be copied to that image.

To reshape a path component:

1 Select the path name in the Paths palette, and use the Direct Selection tool  to select 
an anchor point in the path. 

2 Drag the point or its handles to a new location. (See “Adding, deleting, and converting 
anchor points” on page 307.)

To merge overlapping path components:

1 Select the path name in the Paths palette, and select the Path Selection tool .

2 Click Combine in the options bar to create a single component from all overlapping 
components.
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To copy a path component or path:

Do any of the following:

• To copy a path component as you move it, select the path name in the Paths palette, 
and click a path component with the Path Selection tool . Then Alt-drag (Windows) 
or Option-drag (Mac OS) the selected path. 

• To copy a path without renaming it, drag the path name in the Paths palette to the New 
Path button  at the bottom of the palette.

• To copy and rename a path, Alt-drag (Windows) or Option-drag (Mac OS) the path in 
the Paths palette to the New Path button at the bottom of the palette. Or select the 
path to copy, and choose Duplicate Path from the Paths palette menu. Enter a new 
name for the path in the Duplicate Path dialog box, and click OK.

• To copy a path or path component into another path, select the path or path 
component you want to copy, and choose Edit > Copy. Then select the destination 
path, and choose Edit > Paste.

To copy path components between two Adobe Photoshop files:

1 Open both images. 

2 Use the Path Selection tool  to select the entire path or the path components in the 
source image you want to copy. 

3 To copy the path component, do any of the following:

• Drag the path component from the source image to the destination image. The path 
component is copied to the active path in the Paths palette.

• In the source image, select the path’s name in the Paths palette and choose Edit > Copy 
to copy the path. In the destination image, choose Edit > Paste. You can also use this 
method to combine paths in the same image.

• To paste the path component into the destination image, select the path component 
in the source image, and choose Edit > Copy. In the destination image, choose Edit > 
Paste. 

To delete a path component:

1 Select the path name in the Paths palette, and click a path component with the Path 
Selection tool .

2 Press backspace (Windows) or Delete (Mac OS) to delete the selected path component. 

Aligning and distributing path components
You can both align and distribute path components that are described in a single path. 
For example, you can align the left edges of several shapes contained in a single layer or 
distribute several components in a work path along their horizontal centers. 

Note: To align shapes that are on separate layers, use the move tool. (See “Moving selec-
tions and layers within an image” on page 241.)
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To align components:

Use the Path Selection tool  to select the components you want to align, and select 
one of the alignment options from the options bar: Top , Vertical Center , Bottom , 
Left , Horizontal Center , or Right .

To distribute components:

Select at least three components you want to distribute, and then select one of the 
distribute options from the options bar: Top , Vertical Center , Bottom , Left , 
Horizontal Center , or Right .

Adding, deleting, and converting anchor points
The Add Anchor Point and Delete Anchor Point tools let you add and delete anchor points 
on a shape. The convert direction point tool lets you convert a smooth curve to a sharp 
curve or to a straight segment, and vice versa. If you have selected Auto Add/Delete in the 
options bar for the Pen tool or Freeform Pen tool, when you click a line segment, a point is 
added, and when you click an existing point, it is deleted.

To add an anchor point:

1 Select the Add Anchor Point tool , and position the pointer on the path where you 
want the anchor point added (a plus sign appears next to the pointer).

2 Do one of the following:

• To add an anchor point without changing the shape of the segment, click the path. 

• To add an anchor point and change the shape of the segment, drag to define direction 
lines for the anchor point.

To delete an anchor point:

1 Select the Delete Anchor Point tool , and position the pointer on the anchor point 
you want deleted (a minus sign appears next to the pointer).

2 Delete the anchor point:

• Click the anchor point to delete it and to reshape the path to fit the remaining anchor 
points.

• Drag the anchor point to delete it and to change the shape of the segment.

To convert between a smooth point and a corner point:

1 Select the Convert Point tool , and position the pointer over the anchor point you 
want changed. 

To activate the Convert Point tool while the Direct Selection tool is selected, position 
the pointer over an anchor point, and press Ctrl+Alt (Windows) or Command+Option 

(Mac OS). 

2 Convert the point:

• To convert a smooth point to a corner point without direction lines, click the smooth 
anchor point. 
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• To convert a smooth point to a corner point with direction lines, make sure the 
direction lines are visible. Then drag a direction point to break the pair of direction 
lines.

Drag direction point to break direction lines.

• To convert a corner point to a smooth point, drag away from the corner point to make 
direction lines appear.

Click to create a corner point. Drag to create a smooth point.

Managing paths (Photoshop)
When you use a pen or shape tool to create a work path, the new path appears as the Work 
Path in the Paths palette. The Work Path is temporary; you must save it to avoid losing its 
contents. If you deselect the Work Path without saving it and start drawing again, a new 
path will replace the existing one.

When you use a pen or shape tool to create a new shape layer, the new path appears as a 
vector mask in the Paths palette. Vector masks are linked to their parent layer; you must 
select the parent layer in the Layers palette in order to list the clipping path in the Paths 
palette. You can remove a clipping path from a layer and convert a clipping path to a 
rasterized mask. For more information, see “Creating and editing vector masks” on 
page 411.
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Paths saved with an image appear when you open it again. In Windows, the Photoshop, 
JPEG, JPEG 2000, DCS, EPS, PDF, and TIFF formats support paths. In Mac OS, all available file 
formats support paths. 

Paths palette 
A. Saved path B. Temporary Work Path C. Vector mask path (appears only when shape layer is 
selected)

Note: Paths in formats other than those listed here generally don’t survive a transition 
from Mac OS to Windows and back to Mac OS.

To create a new path in the Paths palette:

Do one of the following:

• To create a path without naming it, click the New Path button  at the bottom of the 
Paths palette. 

• To create and name a path, make sure no work path is selected. Choose New Path from 
the Paths palette menu, or Alt-click (Windows) or Option-click (Mac OS) the New Path 
button at the bottom of the palette. Enter a name for the path in the New Path dialog 
box, and click OK.

To save a work path:

Do one of the following:

• To save without renaming, drag the Work Path name to the New Path button  at the 
bottom of the Paths palette.

• To save and rename, choose Save Path from the Paths palette menu, enter a new path 
name in the Save Path dialog box, and click OK.

To rename a saved path:

Double-click the path’s name in the Paths palette, type a new name, and press Enter 
(Windows) or Return (Mac OS).

To delete a path:

1 Click the path name in the Paths palette.

2 Do one of the following:

• Drag the path to the Trash button  at the bottom of the Paths palette.

• Choose Delete Path from the Paths palette menu.

• Click the Trash button at the bottom of the Paths palette, and click Yes. 

To delete a path without being asked to confirm, Alt-click (Windows) or Option-click 
(Mac OS) the Trash button at the bottom of the Paths palette.

A

B

C
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Converting between paths and selection borders 
(Photoshop)
Because of their smooth outlines, you can convert paths into precise selection borders. 
You also can convert selection borders into paths, using the Direct Selection tool  for 
fine-tuning.

Converting paths to selection borders
You can define any closed path as a selection border. A closed path can be added to, 
subtracted from, or combined with the current selection. 

To convert a path to a selection border using the current Make Selection settings:

1 Select the path in the Paths palette.

2 To convert the path, do one of the following:

• Click the Load Path as a Selection button  at the bottom of the Paths palette.

• Ctrl-click (Windows) or Command-click (Mac OS) the path thumbnail in the Paths 
palette.

To convert a path to a selection border and specify settings:

1 Select the path in the Paths palette.

2 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the Load Path as a Selection button  at 
the bottom of the Paths palette.

• Alt-drag (Windows) or Option-drag (Mac OS) the path to the Load Path as a Selection 
button.

• Choose Make Selection from the Paths palette menu. 

3 In the Make Selection dialog box, select a Rendering option:

• Feather Radius to define how far inside and outside the selection border the feather 
edge extends. Enter a value in pixels. 

• Anti-aliased to create a finer transition between the pixels in the selection and the 
surrounding pixels. Make sure the Feather Radius is set to 0. 

For more information on these options, see “Softening the edges of a selection” on 
page 239.

4 Select an Operation option:

• New Selection to select only the area defined by the path.

• Add to Selection to add the area defined by the path to the original selection. 

• Subtract from Selection to remove the area defined by the path from the current 
selection. 

• Intersect with Selection to select the area common to both the path and the original 
selection. If the path and selection do not overlap, nothing is selected. 

5 Click OK.
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Converting selection borders to paths
Any selection made with a selection tool can be defined as a path. 

The Make Work Path command eliminates any feathering applied to the selection. It can 
also alter the shape of the selection, depending on the complexity of the path and the 
tolerance value you choose in the Make Work Path dialog box.

To convert a selection to a path using the Make Work Path settings:

Make the selection, and click the Make Work Path button  at the bottom of the Paths 
palette.

To convert a selection to a path and specify settings:

1 Make the selection, and do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the Make Work Path button  at the 
bottom of the Paths palette. 

• Choose Make Work Path from the Paths palette menu. 

2 Enter a Tolerance value or use the default value in the Make Work Path dialog box.

Tolerance values can range from 0.5 to 10 pixels and determine how sensitive the Make 
Work Path command is to slight changes in the selection shape. The higher the tolerance 
value, the fewer the anchor points used to draw the path and the smoother the path. If the 
path is used as a clipping path and you have problems printing the image, use a higher 
tolerance value. (See “Printing image clipping paths” on page 602.)

3 Click OK. The path appears at the bottom of the Paths palette.

Adding color to paths (Photoshop)
You can add color values to a path by filling or stroking it. Filling a path is the same as 
creating a rasterized shape using the shape tools. (See “Creating rasterized shapes” on 
page 292.) 

Filling paths with color
The Fill Path command lets you fill a path with pixels using a specified color, a state of the 
image, a pattern, or a fill layer.

Path selected (left), and filled (right)

Important: When you fill a path, the color values appear on the active layer. Make sure the 
layer you want is active before beginning. You cannot fill a path when a layer mask or text 
layer is active.
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To fill a path using the current Fill Path settings:

1 Select the path in the Paths palette.

2 Click the Fill Path button  at the bottom of the Paths palette. 

To fill a path and specify options:

1 Select the path in the Paths palette.

2 Fill the path:

• Alt-click (Windows) or Option-click (Mac OS) the Fill Path button at the bottom of the 
Paths palette.

• Alt-drag (Windows) or Option-drag (Mac OS) the path to the Fill Path button.

• Choose Fill Path from the Paths palette menu. If the selected path is a path component, 
this command changes to Fill Subpath.

3 For Use, choose the contents for the fill. (See “Filling and stroking selections and layers” 
on page 344.)

4 Specify an opacity for the fill. To make the fill more transparent, use a low percentage. 
A setting of 100% makes the fill opaque.

5 Choose a blending mode for the fill. (See “Selecting a blending mode” on page 331.)

The Mode list includes a Clear mode that lets you erase to transparency. You must be 
working in a layer other than the background to use this option.

6 Choose Preserve Transparency to limit the fill to layer areas that contain pixels. (See 
“Locking layers” on page 380.)

7 Select a Rendering option:

• Feather Radius to define how far inside and outside the selection border the feather 
edge extends. Enter a value in pixels.

• Anti-aliased to create a finer transition between the pixels in the selection and the 
surrounding pixels by partially filling the edge pixels of the selection. 

For more information on these options, see “Softening the edges of a selection” on 
page 239.

8 Click OK.

Stroking to paint path borders
The Stroke Path command lets you paint the border of a path. The Stroke Path command 
allows you to create a paint stroke (using the current settings for your painting tools) that 
follows any path. This is completely different than the Stroke layer effect, which doesn’t 
mimic the effect of any of the painting tools.
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Path selected (left), and stroked (right)

Important: When you stroke a path, the color values appear on the active layer. Make sure 
the layer you want is active before beginning. You cannot stroke a path when a layer 
clipping mask or text layer is active.

To stroke a path using the current Stroke Path settings:

1 Select the path in the Paths palette.

2 Click the Stroke Path button  at the bottom of the Paths palette. Each click of the 
Stroke Path button builds up the opacity of the stroke and in some cases makes it look 
thicker.

To stroke a path and specify options:

1 Select the path in the Paths palette. 

2 Select the painting or editing tool you want to use to stroke the path. Set the tool 
options, and specify a brush from the options bar. You must specify the tool’s settings 
before opening the Stroke Path dialog box.For information on specific tool settings, 
see “Using the Smudge tool (Photoshop)” on page 275 and “Using the painting tools 
(Photoshop)” on page 314. 

3 To stroke the path, do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the Stroke Path button  at the bottom of 
the Paths palette.

• Alt-drag (Windows) or Option-drag (Mac OS) the path to the Stroke Path button.

• Choose Stroke Path from the Paths palette menu. If the selected path is a path 
component, this command changes to Stroke Subpath.

4 If you did not select a tool in step 2, choose a tool from the Stroke Path dialog box. 

5 Click OK.
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Painting

Using the painting tools (Photoshop)
Painting involves changing the colors of pixels using a painting tool. You can apply colors 
gradually, with soft edges and transitions, and manipulate individual pixels using 
powerful filter effects. 

Photoshop provides the Brush tool and the Pencil tool to let you paint with the current 
foreground color. By default, the Brush tool creates soft strokes of color and the Pencil tool 
creates hard-edged, freehand lines. However, you can change these default characteristics 
by resetting the tool’s brush options. You can also use the Brush tool as an airbrush to 
apply sprays of color to an image.

To use the Brush tool or Pencil tool:

1 Specify a foreground color. (See “Choosing foreground and background colors” on 
page 351.)

2 Select the Brush tool  or Pencil tool . 

3 Do the following in the options bar:

• Choose a brush and set brush options. (See “Working with brushes” on page 317.) 

• Choose a bending mode from the Mode menu. (See “Selecting a blending mode” on 
page 331.)

• Specify an opacity by dragging the Opacity slider. (See “Specifying opacity, flow, 
strength, or exposure” on page 334.)

• For the Brush tool, specify a flow rate by dragging the Flow slider. (See “Specifying 
opacity, flow, strength, or exposure” on page 334.)

• (Photoshop) Click the Airbrush button  to use the brush as an airbrush. 
(See “Creating airbrush effects (Photoshop)” on page 328.)

• For the Pencil tool, select Auto Erase to paint the background color over areas 
containing the foreground color. (See “Using the Auto Erase option” on page 337.)

4 Do one or more of the following:

• Drag in the image to paint. 

• To draw a straight line, click a starting point in the image. Then hold down Shift, and 
click an ending point.

• When using the Brush tool as an airbrush, hold down the mouse button without 
dragging to build up color.
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Using the painting tools
The Paintbrush tool and the Pencil tool let you paint the current foreground color on an 
image. The tools create different effects:

• The Paintbrush tool creates soft strokes of color. 

• The Pencil tool creates hard-edged freehand lines.

To use the Paintbrush tool, Pencil tool:

1 Specify a foreground color. (See “Choosing foreground and background colors” on 
page 351.)

2 Select the Paintbrush tool  or Pencil tool .

3 Do the following in the options bar:

• Choose a preset brush. (See “Working with brushes” on page 317.) 

• Specify a blending mode. (See “Selecting a blending mode” on page 331.)

• Specify an opacity. (See “Specifying opacity, flow, strength, or exposure” on page 334.)

• For the Pencil tool, select Auto Erase to paint the background color over areas 
containing the foreground color. (See “Using the Auto Erase option” on page 337.)

4 Do one or more of the following:

• Drag in the image to paint. 

• To draw a straight line, click a starting point in the image. Then hold down Shift, and 
click an ending point.

Using the Art History Brush tool (Photoshop)
The Art History Brush tool lets you paint with stylized strokes, using the source data from a 
specified history state or snapshot. By experimenting with different paint style, size, and 
tolerance options, you can simulate the texture of painting with different colors and 
artistic styles.

Like the History Brush tool, the Art History Brush tool uses a specified history state or 
snapshot as the source data. The History Brush tool, however, paints by recreating the 
specified source data, while the Art History Brush tool uses that data along with the 
options you set to create different colors and artistic styles. 

For a variety of visual effects, experiment with applying filters or filling an image with a 
solid color before painting with the Art History Brush tool. Also try increasing the size 

of the image by a factor of 4 to soften the details.
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Example of using the Art History Brush tool 
A. Original B. Using a small brush C. Using a large brush

To use the Art History Brush tool:

1 In the History palette, click the left column of the state or snapshot to use as the source 
for the Art History Brush tool. A brush icon appears next to the source history state.

2 Select the Art History Brush tool .

3 Do the following in the options bar:

• Choose a brush and set brush options. (See “Working with brushes” on page 317.)

• Specify a blending mode and opacity for the paint. (See “Setting options for painting 
and editing tools” on page 331.)

• Choose an option from the Style menu to control the shape of the paint stroke.

• For Area, enter a value to specify the area covered by the paint strokes. The greater the 
size, the larger the covered area and the more numerous the strokes. 

• For Tolerance, enter a value or drag the slider to limit the regions where paint strokes 
can be applied. A low tolerance lets you paint unlimited strokes anywhere in the image. 
A high tolerance limits paint strokes to areas that differ considerably from the color in 
the source state or snapshot.

4 Drag in the image to paint.

A

B

C
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Working with brushes
Working with brushes is an important part of using the painting and editing tools. The 
brush you select determines many characteristics of the resulting stroke. Photoshop and 
ImageReady provide a variety of preset brushes to fill a wide range of uses. In Photoshop, 
you can also create custom brushes using the Brushes palette.

Using the Brushes palette (Photoshop)
The Brushes palette lets you select preset brushes and design custom brushes.

Brushes palette with Brush Tip Shape options displayed 
A. Locked B. Unlocked C. Selected brush tip D. Brush settings E. Brush stroke preview F. Pop-up 
menu G. Brush tip shapes (available when Brush Tip Shape option is selected) H. Brush options

Displaying the Brushes palette Choose Window > Brushes, or click the palette 
button  on the right side of the options bar if you have a painting tool, erasing tool, 
toning tool, or focus tool selected.

Displaying options in the Brushes palette Select an item name on the left side of the 
palette. The available options for the selected item appear on the right side of the palette.

Click the check box to the left of the item name to enable or disable the item without 
viewing its options.

Selecting preset brushes
The Brush pop-up palette in the options bar for the painting and editing tools lets you 
view, select, and load preset brushes. In Photoshop, you can also use the Brushes palette 
to view, select, and load preset brushes.

D

G
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To display the Brush pop-up palette:

1 Select a painting tool or editing tool.

2 Click the brush sample in the options bar.

To select a preset brush:

1 Click a brush in the Brush pop-up palette or Brushes palette. 

Note: If you are using the Brushes palette, be sure that Brush Presets on the left side of the 
palette is selected to view the loaded presets.

2 (Photoshop) Specify a diameter for the brush by dragging the slider or entering a value. 
If the brush has a dual tip, both the primary and dual brush tips are scaled. (See “Creating 
dual brushes (Photoshop)” on page 325.)

3 (Photoshop) Click Use Sample Size to use the original diameter of the brush tip. This 
option is available only if the brush tip shape is based on a sample.

To change how preset brushes are displayed (Photoshop):

Choose a display option from the Brush pop-up palette menu or Brushes palette menu: 

• Text Only to view the brushes as a list.

• Small or Large Thumbnail to view the brushes as thumbnails.

• Small or Large List to view the brushes as a list with thumbnails.

• Stroke Thumbnail to view a sample brush stroke with each brush thumbnail.

To dynamically preview brush strokes in the Brushes palette, make sure that Brush 
Preset is selected, and then position the pointer over a brush until the tool tip appears. 

Move the pointer over different brushes. The preview area at the bottom of the palette will 
display sample brush strokes.

To load a library of preset brushes:

Choose one of the following from the Brush pop-up palette menu or Brushes palette 
menu:

• Load Brushes to add a library to the current list. Select the library file you want to use, 
and click Load.

• Replace Brushes to replace the current list with a different library. Select the library file 
you want to use, and click Load.

• A library file (displayed at the bottom of the palette menu). Click OK to replace the 
current list, or click Append to append the current list.

Note: You can also use the Preset Manager to load and reset brush libraries. For more 
information, see “Managing libraries with the Preset Manager (Photoshop)” on page 52.

To return to the default library of preset brushes:

Choose Reset Brushes from the Brush pop-up palette menu or Brushes palette menu. 
You can either replace the current list or append the default library to the current list. 
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Customizing brush tips (Photoshop)
You can customize brush tips by editing their options and create new brush tip shapes by 
sampling pixels in an image. The brush tip you select determines the shape, diameter, and 
other characteristics of a brush mark.

Selection sampled to create a custom brush (left), and brush stroke using the custom brush (right)

To create a new brush tip shape: 

1 Use any selection tool to select a part of an image to use as a custom brush. Feather 
should be set to 0 pixels if you want to create a brush with a sharp edge. The brush shape 
can be up to 2500 pixels by 2500 pixels in size. 

If you want to define a brush with soft edges, select pixels with gray values. (Colored 
brush shapes appear as gray values.)

2 Choose Edit > Define Brush Preset. 

3 Name the brush, and click OK.

To lock brush tip shape attributes:

To lock a brush tip, click the unlock icon . To unlock the tip, click the lock icon .

Setting brush tip shape options:
You can customize the tip shape of a brush. After selecting a brush tool, select Brush Tip 
Shape on the left side of the Brushes palette, and then select the brush tip you want to 
customize using one or more of the following options:

Diameter Controls the size of the brush. Enter a value in pixels or drag the slider. 

Brush strokes with different diameter values

Use Sample Size Resets the brush to its original diameter. This option is available only if 
the brush tip shape was created by sampling pixels in an image.
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Flip X Changes the direction of a brush tip on its X-axis. 

Flipping a brush tip on its X axis 
A. Brush tip in its default position B. Flip X selected C. Flip X and Flip Y selected

Flip Y Changes the direction of a brush tip on its Y-axis. 

Flipping a brush tip on its Y axis 
A. Brush tip in its default position B. Flip Y selected C. Flip Y and Flip X selected

Angle Specifies the angle by which an elliptical or sampled brush’s long axis is rotated 
from horizontal. Type a value in degrees, or drag the horizontal axis in the preview box.

Angled brushes create a chiseled stroke

Roundness Specifies the ratio between the brush’s short and long axes. Enter a 
percentage value, or drag the points in the preview box. A value of 100% indicates a 
circular brush, a value of 0% indicates a linear brush, and intermediate values indicate 
elliptical brushes.

Adjusting roundness to compress a brush tip shape

A B C

A B C
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Hardness Controls the size of the brush’s hard center. Type a number, or use the slider to 
enter a value that is a percentage of the brush diameter. You can’t change the hardness of 
sampled brushes.

Brush strokes with different hardness values

Spacing Controls the distance between the brush marks in a stroke. To change the 
spacing, type a number, or use the slider to enter a value that is a percentage of the brush 
diameter. When this option is deselected, the speed of the cursor determines the spacing.

Increasing the spacing makes the brush skip

While using a preset brush, press the [ key to decrease the brush width; press the ] key 
to increase the width. For hard round, soft round, and calligraphic brushes, press 

Shift+ the [ key to decrease the brush hardness; press Shift+ the ] key to increase the brush 
hardness. 

About brush dynamics (Photoshop)
The Brushes palette provides many options for adding dynamic (or changing) elements to 
preset brush tips. For example, you can set options that vary the size, color, and opacity of 
brush marks over the course of a stroke.

You work with two components when adding dynamics elements to a brush: 

• Jitter percentages specify the randomness of dynamic elements. At 0%, an element 
does not change over the course of a stroke; at 100%, an element has the maximum 
amount of randomness.

• Options in the Control pop-up menus specify how you want to control the variance of 
dynamic elements. You can choose to not control the variance of an element, to fade an 
element over the specified number of steps, or to vary an element based of pen 
pressure, pen tilt, or position of the pen thumbwheel.

Note: Pen controls are available only when you’re using a pressure-sensitive digitizing 
tablet such as the Wacom® tablet. A warning icon appears if you select a pen control but 
have not installed a tablet.
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Specifying brush shape dynamics (Photoshop)
Shape dynamics determine the variance of brush marks in a stroke.

Brush stokes without shape dynamics and with shape dynamics

To edit shape dynamics for a brush:

1 In the Brushes palette, select Shape Dynamics on the left side of the palette. Be sure to 
click the name, rather than the check box, to select the item.

2 Set one or more of the following options:

Size Jitter and Control Specifies how the size of brush marks vary in a stroke. For more 
information, see “About brush dynamics (Photoshop)” on page 321. 

To specify the maximum percentage of jittering, type a number or use the slider to enter a 
value. To specify how you want to control the size variance of brush marks, choose an 
option from the Control pop-up menu:

• Off to not control the size variance of brush marks. 

• Fade to fade the size of brush marks between the initial diameter and the minimum 
diameter in the specified number of steps. Each step is equal to one mark of the brush 
tip. The value can range from 1 to 9999. For example, entering 10 steps produces a fade 
in 10 increments.

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the size of brush marks between the initial 
diameter and the minimum diameter based on the pen pressure, pen tilt, or position of 
the pen thumbwheel. 

Minimum Diameter Specifies the minimum percentage by which brush marks can scale 
when Size Jitter or Size Control is enabled. Type a number, or use the slider to enter a value 
that is a percentage of the brush tip diameter.

Tilt Scale Specifies the scale factor applied to the height of the brush prior to rotation 
when Size Control is set to Pen Tilt. Type a number, or use the slider to enter a value that is 
a percentage of the brush diameter.

Angle Jitter and Control Specifies how the angle of brush marks varies in a stroke. For 
more information, see “About brush dynamics (Photoshop)” on page 321. 

To specify the maximum percentage of jittering, type a number or use the slider to enter a 
value that is a percentage of 360 degrees. To specify how you want to control the angle 
variance of brush marks, choose an option from the Control pop-up menu:

• Off to not control the angle variance of brush marks. 

• Fade to fade the angle of brush marks between 0 and 360 degrees in the specified 
number of steps. 
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• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the angle of brush marks between 0 and 
360 degrees based on the pen pressure, pen tilt, or position of the pen thumbwheel. 

• Initial Direction to base the angle of brush marks on the initial direction of the brush 
stroke.

• Direction to base the angle of brush marks on the direction of the brush stroke.

Roundness Jitter and Control Specifies how the roundness of brush marks varies in a 
stroke. For more information, see “About brush dynamics (Photoshop)” on page 321.

To specify the maximum percentage of jittering, type a number or use the slider to enter a 
percentage indicating the ratio between the brush’s short and long axes. To specify how 
you want to control the roundness variance of brush marks, choose an option from the 
Control pop-up menu:

• Off to not control the roundness variance of brush marks. 

• Fade to fade the roundness of brush marks between 100% and the Minimum 
Roundness value in the specified number of steps.

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the roundness of brush marks between 
100% and the Minimum Roundness value based on the pen pressure, pen tilt, or 
position of the pen thumbwheel. 

Minimum Roundness Specifies the minimum roundness for brush marks when 
Roundness Jitter or Roundness Control is enabled. Type a number, or use the slider to 
enter a percentage indicating the ratio between the brush’s short and long axes.

Specifying brush scattering (Photoshop)
Brush scattering determines the number and placement of marks in a stroke.

Brush strokes without scattering (left) and with scattering (right)

To edit scattering options for a brush:

1 In the Brushes palette, select Scattering on the left side of the palette. Be sure to click 
the name, rather than the check box, to select the item.

2 Set one or more of the following options:

Scatter and Control Specifies how brush marks are distributed in a stroke. When Both 
Axes is selected, brush marks are distributed in a radial direction. When Both Axes is 
deselected, brush marks are distributed perpendicular to the stroke path.
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To specify the maximum percentage of scattering, type a number or use the slider to enter 
a value. To specify how you want to control the scattering variance of brush marks, choose 
an option from the Control pop-up menu:

• Off to not control the scattering variance of brush marks. 

• Fade to fade the scattering of brush marks from the maximum scattering to no 
scattering in the specified number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the scattering of brush marks based on 
the pen pressure, pen tilt, or position of the pen thumbwheel. 

Count Specifies the number of brush marks applied at each spacing interval. Type a 
number, or use the slider to enter a value.

Note: If you increase the count without increasing the spacing or scattering values, 
painting performance may decrease.

Count Jitter and Control Specifies how the number of brush marks varies for each 
spacing interval. For more information, see “About brush dynamics (Photoshop)” on 
page 321.

To specify the maximum percentage of brush marks applied at each spacing interval, type 
a number or use the slider to enter a value. To specify how you want to control the count 
variance of brush marks, choose an option from the Control pop-up menu:

• Off to not control the count variance of brush marks. 

• Fade to fade the number of brush marks from the Count value to 1 in the specified 
number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the number of brush marks based on the 
pen pressure, pen tilt, or position of the pen thumbwheel. 

Creating textured brushes (Photoshop)
A textured brush uses a pattern to make strokes look as if they are painted on textured 
canvas.

Brush strokes without texture (left) and with texture (right)

To edit texture options for a brush:

1 In the Brushes palette, select Texture on the left side of the palette. Be sure to click the 
name, rather than the check box, to select the item.

2 Click the pattern sample, and select a pattern from the pop-up palette. 
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3 Set one or more of the following options:

Invert Inverts the high and low points in the texture based on the tones in the pattern. 
When Invert is selected, the lightest areas in the pattern are the low points in the texture 
and therefore receive the least paint; the darkest areas in the pattern are the high points in 
the texture and therefore receive the most paint. When Invert is deselected, the lightest 
areas in the pattern receive the most paint; the darkest areas in the pattern receive the 
least paint.

Scale Specifies the scale of the pattern. Type a number, or use the slider to enter a value 
that is a percentage of the pattern size.

Texture Each Tip Specifies whether or not to render each tip individually as it is painted. 
When this option is not selected, the Depth variance options are not available.

Mode Specifies the blending mode used to combine the brush and the pattern. 
(See “Selecting a blending mode” on page 331.)

Depth Specifies how deep the paint penetrates into the texture. Type a number, or use 
the slider to enter a value. At 100%, the low points in the texture do not receive any paint. 
At 0%, all points in the texture receive the same amount of paint, therefore hiding the 
pattern.

Minimum Depth Specifies the minimum depth paint can penetrate when Depth Control 
is set to Fade, Pen Pressure, Pen Tilt, or Stylus Wheel and Texture Each Tip is selected.

Depth Jitter and Control Specifies how the depth varies when Texture Each Tip is 
selected. For more information, see “About brush dynamics (Photoshop)” on page 321.

To specify the maximum percentage of jitter, type a number or use the slider to enter a 
value. To specify how you want to control the depth variance of brush marks, choose an 
option from the Control pop-up menu:

• Off to not control the depth variance of brush marks. 

• Fade to fade from the Depth Jitter percentage to the Minimum Depth percentage in the 
specified number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the depth based on the pen pressure, pen 
tilt, or position of the pen thumbwheel. 

Creating dual brushes (Photoshop)
A dual brush uses two tips to create brush marks. You set options for the primary tip in the 
Brush Tip Shape section of the Brushes palette. You set options for the secondary tip in the 
Dual Brush section of the Brushes palette.

Brush strokes created with a single tip (left) and with dual tips (right)
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To edit dual tip options for a brush:

1 In the Brushes palette, select Dual Brush on the left side of the palette. Be sure to click 
the name, rather than the check box, to select the item.

2 Select a blending mode to use when combining brush marks from the primary tip and 
the dual tip. (See “Selecting a blending mode” on page 331.)

3 Select a tip for the dual brush from the list below the Mode pop-up menu.

4 Set one or more of the following options:

Diameter Controls the size of the dual tip. Enter a value in pixels, drag the slider, or click 
Use Sample Size to use the original diameter of the brush tip. (The Use Sample Size option 
is available only if the brush tip shape was created by sampling pixels in an image.)

Spacing Controls the distance between the dual tip brush marks in a stroke. To change 
the spacing, type a number or use the slider to enter a percentage of the tip diameter. 

Scatter Specifies how dual tip brush marks are distributed in a stroke. When Both Axes is 
selected, dual tip brush marks are distributed in a radial direction. When Both Axes is 
deselected, dual tip brush marks are distributed perpendicular to the stroke path. To 
specify the maximum percentage of scattering, type a number or use the slider to enter 
a value.

Count Specifies the number of dual tip brush marks applied at each spacing interval. 
Type a number, or use the slider to enter a value.

Specifying color dynamics (Photoshop)
Color dynamics determine how the color of paint changes over the course of a stroke.

Brush strokes without color dynamics (left) and with color dynamics (right)

To edit color dynamics for a brush:

1 In the Brushes palette, select Color Dynamics on the left side of the palette. Be sure to 
click the name, rather than the check box, to select the item.

2 Set one or more of the following options:

Foreground/Background Jitter and Control Specifies how paint varies between the 
foreground color and background color. For more information, see “About brush 
dynamics (Photoshop)” on page 321.
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To specify a percentage by which the color of the paint can vary, type a number or use the 
slider to enter a value. To specify how you want to control the color variance of brush 
marks, choose an option from the Control pop-up menu:

• Off to not control the color variance of brush marks. 

• Fade to vary the color of paint between the foreground color and the background color 
in the specified number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the color of paint between the foreground 
color and the background color based on the pen pressure, pen tilt, or position of the 
pen thumbwheel. 

Hue Jitter Specifies a percentage by which the hue of the paint can vary in a stroke. Type 
a number, or use the slider to enter a value. A lower value changes the hue while 
maintaining a close proximity to the hue of the foreground color. A higher value increases 
the difference between hues.

Saturation Jitter Specifies a percentage by which the saturation of the paint can vary in a 
stroke. Type a number, or use the slider to enter a value. A lower value changes the 
saturation while maintaining a close proximity to the saturation of the foreground color. 
A higher value increases the difference between saturation levels.

Brightness Jitter Specifies a percentage by which the brightness of the paint can vary in 
a stroke. Type a number, or use the slider to enter a value. A lower value changes the 
brightness while maintaining a close proximity to the brightness of the foreground color. 
A higher value increases the difference between brightness levels.

Purity Increases or decreases the saturation of the color. Type a number, or use the 
slider to enter a percentage between –100 and 100. At –100, the color is fully desaturated; 
at 100, the color is fully saturated. 

Specifying paint dynamics (Photoshop)
Paint dynamics determine how paint changes over the course of a stroke.

Brush strokes without paint dynamics (left) and with paint dynamics (right)

To edit paint dynamics for a brush:

1 In the Brushes palette, select Other Dynamics on the left side of the palette. Be sure to 
click the name, rather than the check box, to select the item.

2 Set one or more of the following options:

Opacity Jitter and Control Specifies how the opacity of paint varies in a brush stroke, 
up to (but not exceeding) the opacity value specified in the options bar. For more infor-
mation, see “About brush dynamics (Photoshop)” on page 321.
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To specify a percentage by which the opacity of the paint can vary, type a number or use 
the slider to enter a value. To specify how you want to control the opacity variance of 
brush marks, choose an option from the Control pop-up menu:

• Off to not control the opacity variance of brush marks. 

• Fade to fade the opacity of paint from the opacity value in the options bar to 0 in the 
specified number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the opacity of paint based on the pen 
pressure, pen tilt, or the position of the pen thumbwheel. 

Flow Jitter and Control Specifies how the flow of paint varies in a brush stroke, up to 
(but not exceeding) the flow value specified in the options bar. For more information, 
see “About brush dynamics (Photoshop)” on page 321.

To specify a percentage by which the flow of the paint can vary, type a number or use the 
slider to enter a value. To specify how you want to control the flow variance of brush 
marks, choose an option from the Control pop-up menu:

• Off to not control the flow variance of brush marks. 

• Fade to fade the flow of paint from the flow value in the options bar to 0 in the specified 
number of steps. 

• Pen Pressure, Pen Tilt, or Stylus Wheel to vary the flow of paint based on the pen 
pressure, pen tilt, or the position of the pen thumbwheel. 

Adding noise to brush strokes (Photoshop)
The Noise option adds additional randomness to individual brush tips. This option is most 
effective when applied to soft brush tips (brush tips that contain gray values).

To enable or disable noise in brush strokes:

In the Brushes palette, select Noise on the left side of the palette. A check mark indicates 
that the option is enabled.

Using wet brush edges (Photoshop)
The Wet Edges option causes paint to build up along the edges of the brush stroke, 
creating a watercolor effect.

To enable or disable wet brush edges:

In the Brushes palette, select Wet Edges on the left side of the palette. A check mark 
indicates that the option is enabled.

Creating airbrush effects (Photoshop)
The Airbrush option in the Brushes palette lets you apply gradual tones to an image, 
simulating traditional airbrush techniques. 

Note: The Airbrush option in the Brushes palette corresponds to the Airbrush option in the 
options bar.

To enable or disable the Airbrush option:

In the Brushes palette, select Airbrush on the left side of the palette. A check mark 
indicates that the option is enabled.
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Smoothing brush strokes (Photoshop)
The Smoothing option produces smoother curves in brush strokes. This option is most 
effective when you are painting quickly with a stylus; however, it may produce a slight lag 
time in stroke rendering.

To enable or disable smoothing in brush strokes:

In the Brushes palette, select Smoothing on the left side of the palette. A check mark 
indicates that the option is enabled.

Protecting texture in brush strokes (Photoshop)
The Protect Texture option applies the same pattern and scale to all brush presets that 
have a texture. Select this option to simulate a consistent canvas texture when painting 
with multiple, textured brush tips.

To enable or disable the Protect Texture option:

In the Brushes palette, select Protect Texture on the left side of the palette. A check mark 
indicates that the option is enabled.

Copying textures between tools (Photoshop)
When you specify a texture for the current tool, you can copy the texture’s pattern and 
scale to all tools that support textures. For example, you can copy the current texture 
pattern and scale for the Brush tool to the Pencil, Clone Stamp, Pattern Stamp, History 
Brush, Art History Brush, Eraser, Dodge, Burn, and Sponge tools.

To copy a texture pattern and scale to other painting and editing tools:

Choose Copy Texture to Other Tools from the Brushes palette menu.

Clearing brush options (Photoshop)
You can easily clear all brush options for a tool using the Clear Brush Controls command.

To clear brush options:

Choose Clear Brush Controls from the Brushes palette menu.

Creating and managing preset brushes (Photoshop)
After you customize a brush, you can save it as a preset brush. Preset brushes appear in the 
Brushes palette, Brush pop-up palette in the options bar, and Preset Manager. You can 
create libraries of preset brushes, rename preset brushes, and delete preset brushes.

Three preset brushes created from one custom brush
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Note: New preset brushes are saved in a Preferences file so that they persist between 
editing sessions. If this file is deleted or damaged, or if you reset brushes to the default 
library, the new presets will be lost. To permanently save new preset brushes, save them in 
a library. 

To create a new preset brush:

1 Customize a brush.

2 Do one of the following in the Brushes palette or Brush pop-up palette:

• Choose New Brush Preset from the palette menu, enter a name for the preset brush, 
and click OK.

• Click the Create New Brush button .

To rename a preset brush:

Do one of the following:

• Select a brush in the Brush pop-up palette or Brushes palette, and choose Rename 
Brush from the palette menu. Enter a new name for the brush, and click OK. 

• If the Brushes palette is set to display brushes as thumbnails, double-click a brush, enter 
a new name, and click OK.

• If the Brushes palette is set to display brushes as a list or text only, double-click a brush, 
enter a new name inline, and press Enter (Windows) or Return (Mac OS).

To delete a preset brush:

Do one of the following:

• In the Brush pop-up palette or Brushes palette, select a brush, and choose Delete Brush 
from the palette menu. 

• In the Brush pop-up palette or Brushes palette, Alt-click (Windows) or Option-click 
(Mac OS) the brush you want to delete.

• In the Brushes palette, select a brush and click the Trash button , or drag a brush to the 
Trash button.

To save a set of preset brushes as a library:

1 Choose Save Brushes from the Brush pop-up palette menu or Brushes palette menu.

2 Choose a location for the brush library, enter a filename, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/
Brushes folder inside the Photoshop program folder, the library name will appear at the 
bottom of the Brush pop-up palette menu and Brushes palette menu after you restart 
Photoshop.

Note: You can also use the Preset Manager to rename, delete, and save libraries of preset 
brushes. For more information, see “Managing libraries with the Preset Manager 
(Photoshop)” on page 52.
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Setting options for painting and editing tools
You set options for a painting or editing tool in the options bar.

Selecting a blending mode
The blending mode specified in the options bar controls how pixels in the image are 
affected by a painting or editing tool. It’s helpful to think in terms of the following colors 
when visualizing a blending mode’s effect: 

• The base color is the original color in the image. 

• The blend color is the color being applied with the painting or editing tool.

• The result color is the color resulting from the blend.

Original Image Normal, 100% 
opacity

Normal, 50% opacity Dissolve, 50% opacity

Behind Clear Darken Multiply

Color Burn Linear Burn Lighten Screen

Color Dodge Linear Dodge Overlay Soft Light
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To select a blending mode for a tool:

Choose from the Mode pop-up menu in the options bar.

Normal Edits or paints each pixel to make it the result color. This is the default mode. 
(Normal mode is called Threshold when you’re working with a bitmapped or indexed-color 
image.)

Dissolve Edits or paints each pixel to make it the result color. However, the result color is a 
random replacement of the pixels with the base color or the blend color, depending on 
the opacity at any pixel location. 

Behind Edits or paints only on the transparent part of a layer. This mode works only in 
layers with Lock Transparency deselected and is analogous to painting on the back of 
transparent areas in a sheet of acetate.

Clear Edits or paints each pixel and makes it transparent. This mode is available for the 
Line tool  (when fill region  is selected), the Paint Bucket tool , the Brush tool , 
the Pencil tool , the Fill command, and the Stroke command. You must be in a layer with 
Lock Transparency deselected to use this mode. 

Darken Looks at the color information in each channel and selects the base or blend 
color—whichever is darker—as the result color. Pixels lighter than the blend color are 
replaced, and pixels darker than the blend color do not change. 

Hard Light Vivid Light Linear Light Pin Light

Hard Mix Difference Exclusion Hue

Saturation Color Luminosity, 80% 
opacity
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Multiply Looks at the color information in each channel and multiplies the base color by 
the blend color. The result color is always a darker color. Multiplying any color with black 
produces black. Multiplying any color with white leaves the color unchanged. When you’re 
painting with a color other than black or white, successive strokes with a painting tool 
produce progressively darker colors. The effect is similar to drawing on the image with 
multiple magic markers. 

Color Burn Looks at the color information in each channel and darkens the base color to 
reflect the blend color by increasing the contrast. Blending with white produces no 
change.

Linear Burn Looks at the color information in each channel and darkens the base color to 
reflect the blend color by decreasing the brightness. Blending with white produces no 
change.

Lighten Looks at the color information in each channel and selects the base or blend 
color—whichever is lighter—as the result color. Pixels darker than the blend color are 
replaced, and pixels lighter than the blend color do not change. 

Screen Looks at each channel’s color information and multiplies the inverse of the blend 
and base colors. The result color is always a lighter color. Screening with black leaves the 
color unchanged. Screening with white produces white. The effect is similar to projecting 
multiple photographic slides on top of each other. 

Color Dodge Looks at the color information in each channel and brightens the base color 
to reflect the blend color by decreasing the contrast. Blending with black produces no 
change.

Linear Dodge Looks at the color information in each channel and brightens the base 
color to reflect the blend color by increasing the brightness. Blending with black produces 
no change.

Overlay Multiplies or screens the colors, depending on the base color. Patterns or colors 
overlay the existing pixels while preserving the highlights and shadows of the base color. 
The base color is not replaced but is mixed with the blend color to reflect the lightness or 
darkness of the original color. 

Soft Light Darkens or lightens the colors, depending on the blend color. The effect is 
similar to shining a diffused spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened as if it were 
dodged. If the blend color is darker than 50% gray, the image is darkened as if it were 
burned in. Painting with pure black or white produces a distinctly darker or lighter area 
but does not result in pure black or white. 

Hard Light Multiplies or screens the colors, depending on the blend color. The effect is 
similar to shining a harsh spotlight on the image. 

If the blend color (light source) is lighter than 50% gray, the image is lightened, as if it were 
screened. This is useful for adding highlights to an image. If the blend color is darker than 
50% gray, the image is darkened, as if it were multiplied. This is useful for adding shadows 
to an image. Painting with pure black or white results in pure black or white.

Vivid Light Burns or dodges the colors by increasing or decreasing the contrast, 
depending on the blend color. If the blend color (light source) is lighter than 50% gray, the 
image is lightened by decreasing the contrast. If the blend color is darker than 50% gray, 
the image is darkened by increasing the contrast. 
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Linear Light Burns or dodges the colors by decreasing or increasing the brightness, 
depending on the blend color. If the blend color (light source) is lighter than 50% gray, the 
image is lightened by increasing the brightness. If the blend color is darker than 50% gray, 
the image is darkened by decreasing the brightness. 

Pin Light Replaces the colors, depending on the blend color. If the blend color (light 
source) is lighter than 50% gray, pixels darker than the blend color are replaced, and pixels 
lighter than the blend color do not change. If the blend color is darker than 50% gray, 
pixels lighter than the blend color are replaced, and pixels darker than the blend color do 
not change. This is useful for adding special effects to an image.

Difference Looks at the color information in each channel and subtracts either the blend 
color from the base color or the base color from the blend color, depending on which has 
the greater brightness value. Blending with white inverts the base color values; blending 
with black produces no change.

Exclusion Creates an effect similar to but lower in contrast than the Difference mode. 
Blending with white inverts the base color values. Blending with black produces no 
change.

Hue Creates a result color with the luminance and saturation of the base color and the 
hue of the blend color. 

Saturation Creates a result color with the luminance and hue of the base color and the 
saturation of the blend color. Painting with this mode in an area with no (0) saturation 
(gray) causes no change. 

Color Creates a result color with the luminance of the base color and the hue and 
saturation of the blend color. This preserves the gray levels in the image and is useful for 
coloring monochrome images and for tinting color images.

Luminosity Creates a result color with the hue and saturation of the base color and the 
luminance of the blend color. This mode creates an inverse effect from that of the Color 
mode.

Specifying opacity, flow, strength, or exposure
You can specify opacity, flow, strength, or exposure for the following tools: 

• Opacity specifies the maximum amount of paint coverage applied by the Brush, Paint-
Brush, Pencil, Clone Stamp, Pattern Stamp, History Brush, Art History Brush, Gradient, 
and Paint Bucket tools.

• Flow specifies how quickly paint is applied by the Brush tool. A low setting produces a 
lighter stroke.

• Strength specifies the strength of strokes applied by the Smudge, Blur, Sharpen, and 
Sponge tools.

• Exposure specifies the amount of exposure used by the Dodge and Burn tools.

To specify opacity, flow, strength, or exposure:

Enter a value, or drag the slider for Opacity, Flow, Strength, or Exposure in the options bar.
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Opacity, flow, strength, or exposure can range from 1% to 100%. For transparent paint or a 
weak effect, specify a low percentage value; for more opaque paint or a strong effect, 
specify a high value. 

Press a number key to set a tool’s opacity, flow, strength, or exposure in multiples of 
10% (pressing 1 sets to 10%; pressing 0 sets to 100%). 

Erasing
The Eraser and Magic Eraser tools let you erase areas of an image to transparency or to the 
background color. The Background Eraser tool (Photoshop) lets you erase to transparency 
on a layer. You can also use the Auto Erase option with the Pencil tool to erase the 
foreground color to the background color as you paint.

If you want to erase the background of an object with intricate or wispy edges, use the 
Extract command. (See “Using the Extract filter (Photoshop)” on page 248.)

Using the Eraser tool
The Eraser tool changes pixels in the image as you drag through them. If you’re working in 
the background or in a layer with transparency locked, the pixels change to the 
background color; otherwise, the pixels are erased to transparency. You can also use the 
eraser to return the affected area to a state selected in the History palette.

To use the Eraser tool:

1 Select the Eraser tool .

2 Do the following in the options bar:

• Choose a brush and set brush options (Photoshop), or choose a preset brush 
(ImageReady). (See “Working with brushes” on page 317.) This option is not available 
for Block mode.

• Choose a mode for the eraser—Brush (Photoshop), Paintbrush (ImageReady), Airbrush 
(ImageReady), Pencil, or Block. 

• Specify an opacity to define the strength of the erasure. An opacity of 100% erases 
pixels completely. A lower opacity erases pixels partially. (This option is not available for 
Block mode in Photoshop.)

• (Photoshop) In Brush mode, specify a flow rate. (See “Specifying opacity, flow, strength, 
or exposure” on page 334.)

• (Photoshop) In Brush mode, click the airbrush button  to use the brush as an 
airbrush. Alternately, select the Airbrush option in the Brushes palette. (See “Creating 
airbrush effects (Photoshop)” on page 328.)

• (Photoshop) To erase to a saved state or snapshot of the image, click the left column of 
the state or snapshot in the History palette, and then select Erase to History in the 
options bar. (See “Painting with a state or snapshot of an image (Photoshop)” on 
page 38.)

(Photoshop) To temporarily use the Eraser tool in Erase to History mode, hold down 
Alt (Windows) or Option (Mac OS) as you drag in the image. 

3 Drag through the area you want to erase.
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Using the Magic Eraser tool
When you click in a layer with the Magic Eraser tool, the tool automatically changes all 
similar pixels. If you’re working in the background, or in a layer with locked transparency, 
the pixels change to the background color; otherwise, the pixels are erased to trans-
parency. You can choose to erase contiguous pixels only or all similar pixels on the current 
layer.

Example of erasing similar pixels

To use the Magic Eraser tool:

1 Select the Magic Eraser tool .

2 Do the following in the options bar:

• Enter a tolerance value to define the range of colors that can be erased. A low tolerance 
erases pixels within a range of color values very similar to the pixel you click. A high 
tolerance erases pixels within a broader range.

• Select Anti-aliased to smooth the edges of the area you erase.

• Select Contiguous to erase only pixels contiguous to the one you click, or deselect to 
erase all similar pixels in the image.

• Select Use All Layers to sample the erased color using combined data from all visible 
layers.

• Specify an opacity to define the strength of the erasure. An opacity of 100% erases 
pixels completely. A lower opacity erases pixels partially.

3 Click in the part of the layer you want to erase.

Using the Background Eraser tool (Photoshop)
The Background Eraser tool lets you erase pixels on a layer to transparency as you drag; 
this allows you to erase the background while maintaining the edges of an object in the 
foreground. By specifying different sampling and tolerance options, you can control the 
range of the transparency and the sharpness of the boundaries. 

The background eraser samples the color in the center of the brush, also called the hot 
spot, and deletes that color wherever it appears inside the brush. It also performs color 
extraction at the edges of any foreground objects, so that color halos are not visible if the 
foreground object is later pasted into another image.

Note: The background eraser overrides the lock transparency setting of a layer.
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To use the Background Eraser tool:

1 In the Layers palette, select the layer containing the areas you want to erase.

2 Select the Background Eraser tool .

3 Click the brush sample in the options bar and set brush options in the pop-up palette:

• Choose settings for the Diameter, Hardness, Spacing, Angle, and Roundness options 
(see “Customizing brush tips (Photoshop)” on page 319). 

• If you’re using a pressure-sensitive digitizing tablet, choose options from the Size and 
Tolerance menus to vary the size and tolerance of the background eraser over the 
course of a stroke. Choose Pen Pressure to base the variation on the pen pressure. 
Choose Stylus Wheel to base the variation on the position of the pen thumbwheel. 
Choose Off to not vary the size or tolerance.

4 Do the following in the options bar:

• Choose a Limits mode for erasing: Discontiguous to erase the sampled color wherever it 
occurs under the brush, Contiguous to erase areas that contain the sampled color and 
are connected to one another, and Find Edges to erase connected areas containing the 
sampled color while better preserving the sharpness of shape edges.

• For Tolerance, enter a value or drag the slider. A low tolerance limits erasure to areas 
that are very similar to the sampled color. A high tolerance erases a broader range of 
colors.

• Select Protect Foreground Color to prevent the erasure of areas that match the 
foreground color in the toolbox.

• Choose a Sampling option: Continuous to sample colors continuously as you drag, 
Once to erase only areas containing the color that you first click, and Background 
Swatch to erase only areas containing the current background color.

5 Drag through the area you want to erase. The Background Eraser tool pointer appears 
as a brush shape with a cross hair indicating the tool’s hot spot .

Using the Auto Erase option
The Auto Erase option for the Pencil tool lets you paint the background color over areas 
containing the foreground color.

To use the Auto Erase option:

1 Specify foreground and background colors. (See “Choosing foreground and 
background colors” on page 351.)

2 Select the Pencil tool .

3 Select Auto Erase in the options bar.

4 Drag over the image. 

If the center of the cursor is over the foreground color when you begin dragging, the area 
is erased to the background color. If the center of the cursor is over an area that doesn’t 
contain the foreground color when you begin dragging, the area is painted with the 
foreground color. 
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Using the Gradient tool (Photoshop)
The Gradient tool creates a gradual blend between multiple colors. You can choose from 
preset gradient fills or create your own. 

Note: The Gradient tool cannot be used with images in Bitmap, indexed-color, or 16-
bit-per-channel mode.

Applying a gradient fill
You fill an area with a gradient by dragging in the image. The starting point (where the 
mouse is pressed) and ending point (where the mouse is released) affect the gradient 
appearance, depending on the Gradient tool used.

To apply a gradient fill: 

1 To fill part of the image, select the desired area. Otherwise, the gradient fill is applied to 
the entire active layer. 

2 Select the Gradient tool .

3 Choose a gradient fill in the options bar:

• Click the triangle next to the gradient sample to pick a preset gradient fill.

• Click inside the gradient sample to view the Gradient Editor. Select a preset gradient fill, 
or create a new gradient fill. Then click OK. (See “Creating smooth gradient fills” on 
page 339.)

4 Select an option for applying the gradient fill in the options bar:

• Linear gradient  to shade from the starting point to the ending point in a straight 
line.

• Radial gradient  to shade from the starting point to the ending point in a circular 
pattern.

• Angle gradient  to shade in a counterclockwise sweep around the starting point. 

• Reflected gradient  to shade using symmetric linear gradients on either side of the 
starting point.

• Diamond gradient  to shade from the starting point outward in a diamond pattern. 
The ending point defines one corner of the diamond.

5 Do the following in the options bar:

• Specify a blending mode and opacity for the paint. (See “Setting options for painting 
and editing tools” on page 331.)

• To reverse the order of colors in the gradient fill, select Reverse.

• To create a smoother blend with less banding, select Dither.

• To use a transparency mask for the gradient fill, select Transparency. (See “Specifying 
the gradient transparency” on page 340.)

6 Position the pointer in the image where you want to set the starting point of the 
gradient, and drag to define the ending point. To constrain the line angle to a multiple of 
45°, hold down Shift as you drag.
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Creating smooth gradient fills
The Gradient Editor dialog box lets you define a new gradient by modifying a copy of an 
existing gradient. You can also add intermediate colors to a gradient, creating a blend 
between more than two colors.

Gradient Editor dialog box 
A. Palette menu B. Opacity stop C. Color stops D. Adjust values or delete the selected opacity or 
color stop E. Midpoint

To create a smooth gradient:

1 Select the Gradient tool .

2 Click inside the gradient sample in the options bar to display the Gradient Editor 
dialog box. 

3 To base the new gradient on an existing gradient, select a gradient in the Presets 
section of the dialog box.

4 Choose Solid from the Gradient Type pop-up menu.

5 To define the starting color of the gradient, click the left color stop  under the gradient 
bar. The triangle above the stop turns black , indicating that the starting color is being 
edited.

6 To choose a color, do one of the following:

• Double-click the color stop, or click the color swatch in the Stops section of the dialog 
box. Choose a color, and click OK. For information on choosing a color, see “Choosing 
foreground and background colors” on page 351.

• Choose an option from the Color pop-up menu in the Stops section of the dialog box.

• Position the pointer over the gradient bar (the pointer turns into the eyedropper), and 
click to sample a color, or click anywhere in the image to sample a color from the image.

7 To define the ending color, click the right color stop under the gradient bar. Then 
choose a color as described in step 5.
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8 To adjust the location of the starting point or ending point, do one of the following:

• Drag the corresponding color stop left or right to the location you want. 

• Click the corresponding color stop, and enter a value for Location in the Stops section 
of the dialog box. A value of 0% places the point at the far left end of the gradient bar, 
a value of 100% at the far right end.

9 To adjust the location of the midpoint (where the gradient displays an even mix of the 
starting and ending colors), drag the diamond  below the gradient bar to the left or right, 
or click the diamond and enter a value for Location.

10 To delete the color stop you are editing, click Delete.

11 To set the smoothness for the entire gradient, enter a value in the Smoothness text 
box, or drag the Smoothness pop-up slider.

12 If desired, set transparency values for the gradient. (See “Specifying the gradient trans-
parency” on page 340.)

13 Enter a name for the new gradient.

14 To save the gradient as a preset, click New after you have finished creating the 
gradient.

Note: New presets are saved in a Preferences file so that they persist between editing 
sessions. If this file is deleted or damaged, or if you reset presets to the default library, 
the new presets will be lost. To permanently save new presets, save them in a library. 
(See “Managing gradients” on page 342.)

To add intermediate colors to a gradient:

In the Gradient Editor dialog box, click below the gradient bar to define another color stop. 
Specify the color and adjust the location and midpoint for the intermediate point as you 
would for a starting or ending point. To remove an intermediate color, drag the color stop 
down and off the gradient bar, or select the color stop and click the Delete button.

Specifying the gradient transparency
Each gradient fill contains settings that control the opacity of the fill at different locations 
on the gradient. For example, you can set the starting color to 100% opacity and have the 
fill gradually blend into an ending color with 50% opacity. The checkerboard pattern 
indicates the amount of transparency in the gradient preview.

To specify the gradient transparency:

1 Create a gradient as described in steps 1 through 10 of “Creating smooth gradient fills” 
on page 339.

2 To adjust the starting opacity, click the left opacity stop above the gradient bar. The 
triangle below the stop turns black, indicating that the starting transparency is being 
edited.

3 In the Stops section of the dialog box, enter a value in the Opacity text box, or drag the 
Opacity pop-up slider. 

4 To adjust the opacity of the endpoint, click the right transparency stop above the 
gradient bar. Then set the opacity as described in step 3. 
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5 To adjust the location of the starting or ending opacity, do one of the following:

• Drag the corresponding opacity stop to the left or right.

• Select the corresponding opacity stop, and enter a value for Location. 

6 To adjust the location of the midpoint opacity (the point midway between the starting 
and ending opacities), do one of the following:

• Drag the diamond above the gradient bar to the left or right.

• Select the diamond and enter a value for Location.

7 To delete the opacity stop you are editing, click Delete.

8 To add an intermediate opacity to the mask, click above the gradient bar to define a 
new opacity stop. You can then adjust and move this opacity as you would for a starting or 
ending opacity. To remove an intermediate opacity, drag its transparency stop up and off 
the gradient bar.

9 To create a preset gradient, enter a name in the Name text box and click New. This 
creates a new gradient preset with the transparency setting you specified.

Creating noise gradient fills
In addition to creating smooth gradients, the Gradient Editor dialog box lets you define a 
new noise gradient. A noise gradient is a gradient that contains randomly distributed 
colors within the range of colors that you specify.

Gradient with different Noise values 
A. 10% noise B. 50% noise C. 90% noise

To create a noise gradient:

1 Select the Gradient tool . 

2 Click in the gradient sample in the options bar to display the Gradient Editor dialog box.

3 To base the new gradient on an existing gradient, select a gradient in the Presets 
section of the dialog box.

4 Choose Noise from the Gradient Type pop-up menu.

5 To set the roughness for the entire gradient, enter a value in the Roughness text box, or 
drag the Roughness pop-up slider.

6 To define the color model, choose a color model from the Color Model list.

7 To adjust the range of colors, drag the sliders. For each color component of the color 
model you’ve selected, you can drag the sliders to define the range of acceptable values. 
For example, if you choose the HSB model, you can restrict the gradient to blue-green 
hues, high saturation, and medium brightness.

8 Set the options to restrict colors or to add transparency.

A
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9 To randomize a gradient that conforms to the settings, click the Randomize button until 
you find a setting you like.

10 To create a preset gradient, enter a name in the Name text box and click New. This 
creates a new preset gradient with the settings you specified.

Managing gradients
By saving and loading libraries of gradients, you can customize the gradient list that 
appears in the options bar and the Gradient Editor dialog box. You can also rename 
presets, delete presets, and change the display of the gradient list.

Note: You can use the Preset Manager to manage gradient libraries. For more information, 
see “Managing libraries with the Preset Manager (Photoshop)” on page 52.

To save a set of preset gradients as a library:

1 Click Save in the Gradient Editor dialog box.

2 Choose a location for the gradient library, enter a filename, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/
Gradients folder inside the Photoshop program folder, the library name will appear at the 
bottom of the palette menu after you restart Photoshop.

To load a library of preset gradients:

Do one of the following:

• Click Load to add a library to the current list. Select the library file you want to use, and 
click Load.

• Choose Replace Gradients from the palette menu to replace the current list with a 
different library. Select the library file you want to use, and click Load.

• Choose a library file from the bottom of the palette menu. Click OK to replace the 
current list, or click Append to append the current list.

To return to the default library of preset gradients:

Choose Reset Gradients from the palette menu. You can either replace the current list or 
append the default library to the current list. 

To change how preset gradients are displayed:

Choose a display option from the palette menu: 

• Text Only to view the gradients as a list.

• Small or Large Thumbnail to view the gradients as thumbnails.

• Small or Large List to view the gradients as a list with thumbnails.

To rename a preset gradient:

Do one of the following:

• If the palette is set to display gradients as thumbnails, double-click a gradient, enter a 
new name, and click OK.

• If the palette is set to display gradients as a list or text only, double-click a gradient, 
enter a new name inline, and press Enter (Windows) or Return (Mac OS).
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Using the Paint Bucket tool
The Paint Bucket tool fills adjacent pixels that are similar in color value to the pixels you 
click. 

Note: The Paint Bucket tool cannot be used with images in Bitmap mode.

Using the Paint Bucket tool to fill pixels similar in color value with the foreground color

To use the Paint Bucket tool: 

1 Specify a foreground color. (See “Choosing foreground and background colors” on 
page 351.)

2 Select the Paint Bucket tool .

3 (Photoshop) Specify whether to fill the selection with the foreground color or with a 
pattern. (See “Filling and stroking selections and layers” on page 344.)

4 Specify a blending mode and opacity for the paint. (See “Setting options for painting 
and editing tools” on page 331.)

5 Enter the tolerance for the fill.

The tolerance defines how similar in color a pixel must be to be filled. Values can range 
from 0 to 255. A low tolerance fills pixels within a range of color values very similar to the 
pixel you click. A high tolerance fills pixels within a broader range.

6 To smooth the edges of the filled selection, select Anti-aliased. (See “Softening the 
edges of a selection” on page 239.)

7 To fill only pixels contiguous to the one you click, select Contiguous; leave unselected 
to fill all similar pixels in the image.

8 To fill pixels based on the merged color data from all visible layers, select All Layers. 
(See “Sampling from layers” on page 381.)

9 Click the part of the image you want to fill. All specified pixels within the specified 
tolerance are filled with the foreground color or pattern.

If you’re working on a layer and don’t want to fill transparent areas, make sure that the 
layer’s transparency is locked in the Layers palette. (See “Locking layers” on page 380.)
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Filling and stroking selections and layers
Photoshop and ImageReady provide a variety of ways to fill a selection or a layer with 
colors and patterns. You can also paint a border around a selection or a layer. Layer styles 
allow you to fill or stroke a selection or layer to create a live editable effect, while you can 
also paint a fill or border to create a softer effect. (See “Managing Layers” on page 382.)

To increase the contrast between your image and the surrounding work canvas, you can 
fill the canvas with a color. 

Filling a selection or layer with colors or patterns
You can fill a selection or layer with the foreground color, the background color, or a 
pattern. In Photoshop, you can use patterns from the pattern libraries provided or create 
your own patterns. You can also fill a shape using the Color, Gradient, or Pattern Overlay 
effects or the Solid Color, Gradient, or Pattern fill layers on the Layers palette. When you 
use fill layers to fill a selection, you can easily change the type of layer being used. For 
more information, see “Using adjustment layers and fill layers (Photoshop)” on page 402. 

To fill a selection or a layer with a foreground or background color: 

1 Specify a foreground or background color. (See “Choosing foreground and background 
colors” on page 351.)

2 Select the area you want to fill. To fill an entire layer, select the layer in the Layers 
palette.

3 Choose Edit > Fill to fill the selection or layer. Or to fill a path, select the path and choose 
Fill Path from the Paths palette menu. 

4 In the Fill dialog box, for Use, choose one of the following options or select a Custom 
Pattern:

• Foreground Color, Background Color, Black, 50% Gray, or White to fill the selection with 
the specified color.

• Color to fill with a color you select from the Color Picker.

• Pattern to fill the selection with a pattern. Click the inverted arrow  next to the pattern 
sample and select a pattern from the pop-up palette. You can load additional patterns 
using the pop-up palette menu. Select the name of a library of patterns or choose Load 
Patterns and navigate to the folder containing the patterns you want to use. 

• History to restore the selected area to a state or snapshot of the image. (See “Making a 
snapshot of an image (Photoshop)” on page 37.)

Note: If you fill a CMYK image using the Black option, Photoshop fills all the channels with 
100% black. This may result in more ink than is allowable by the printer. For best results 
when filling a CMYK image, use the Foreground option with the foreground color set to an 
appropriate black.

5 Specify the blending mode and opacity for the paint. (See “Selecting a blending mode” 
on page 331 and “Setting options for painting and editing tools” on page 331.)

6 If you’re working in a layer and want to fill only areas containing pixels, choose Preserve 
Transparency.
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7 Click the OK button to apply the fill.

To apply a foreground color fill only to the areas that contain pixels, press 
Alt+Shift+Backspace (Windows) or Option+Shift+Delete (Mac OS). This preserves the 

transparency of the layer. To apply a background color fill only to the areas that contain 
pixels, press Ctrl+Shift+Backspace (Windows) or Command+Shift+Delete (Mac OS).

To fill the work canvas:

1 Set the foreground color you want to use for the canvas.

2 Select the Paint Bucket tool .

3 In the options bar, set Fill to Foreground. 

4 Hold down Shift, and click in the work canvas.

Note: You need to be in full screen mode and viewing the menus to fill the work canvas.

To fill a selection with a pattern: 

1 Select the part of the image you want to fill.

2 Do one of the following:

• Choose Edit > Fill. In the Fill dialog box, for Use, choose Pattern, select a pattern from 
the pop-up palette, and click OK. 

If Pattern is dimmed, you need to load a pattern library before you can select this option. 
(See “Managing libraries with the Preset Manager (Photoshop)” on page 52.)

• Select the Paint Bucket tool . In the options bar, choose Pattern from the Fill pop-up 
menu and select a pattern from the Pattern pop-up palette. Then click to fill the 
selected area with the pattern.

Note: You can load additional pattern libraries into the pop-up palette prior to making a 
selection. (See “Creating and managing patterns” on page 346.)

Stroking a selection or layer with color
You can use the Stroke command to paint a colored border around a selection, layer, or 
path. This allows you to create a softer border than one created using the Stroke layer 
style. The Stroke layer style provides a resolution-independent method to stroke a shape. 
(See “Managing Layers” on page 382.) You can use the Stroke layer effect when you want 
to stroke the entire layer. If you want a quick way to create a stroke on the current layer—
without necessarily following the edge of the layer—use the Stroke command.

To stroke a selection or layer:

1 Specify a foreground color. (See “Choosing foreground and background colors” on 
page 351.)

2 Select the area or layer you want to stroke. 

3 Choose Edit > Stroke. 

4 In the Stroke dialog box, specify the width of the hard-edged border. 

5 For Location, specify whether to place the border inside, outside, or centered over the 
selection or layer boundaries.

6 Specify an opacity and a blending mode. (See “Setting options for painting and editing 
tools” on page 331.) 
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7 If you’re working in a layer and want to stroke only areas containing pixels, select the 
Preserve Transparency option. (See “Locking layers” on page 380.) 

To stroke a path:

1 Select the path in the Paths palette.

2 Choose Stroke Path from the palette menu.

3 In the Stroke Path dialog box, choose a tool to stroke the path.

Creating and managing patterns 
A pattern is an image that is repeated, or tiled, during application. Photoshop and 
ImageReady come with a variety of preset patterns. In Photoshop, you can create new 
patterns and save them in libraries for use with different tools and commands. In 
ImageReady, you can define a single pattern, called the User Defined Pattern, which you 
can use to fill selections and layers.

Defining patterns
You use the Edit > Define Pattern command to create new patterns based on a selection.

To define a preset pattern: 

1 Use the Rectangle Marquee tool  on any open image to select an area to use as a 
pattern. Feather must be set to 0 pixels. Note that large images may become unwieldy.

2 Choose Edit > Define Pattern.

3 (Photoshop) Enter a name for the pattern in the Pattern Name dialog box.

Note: If you are using a pattern from one image and applying it to another, Photoshop 
converts the color mode.

To use a preset pattern from the PostScript Patterns folder:

1 Choose File > Open. Each preset file in the PostScript Patterns folder (which comes with 
Photoshop) contains a single pattern in the Adobe Illustrator format. You can scale and 
render these patterns at any resolution.

2 Select the pattern file you want to use, and click Open. 

3 Select any rasterizing options. (See “Opening and importing images” on page 101.)

4 Make a rectangular selection around the pattern, or make no selection to use the whole 
image.

5 Choose Edit > Define Pattern. 

6 (Photoshop) Enter a name for the pattern in the Pattern Name dialog box.

Managing patterns (Photoshop)
Preset patterns are displayed in pop-up palettes in the options bar for the Paint Bucket, 
Pattern Stamp, Healing Brush, and Patch tools, as well as in the Layer Style dialog box. 
You can load, reset, and save libraries of preset patterns, and rename and delete individual 
preset patterns. 

Note: You can also use the Preset Manager to load, reset, and save libraries of preset 
patterns, and rename and delete individual preset patterns. For more information, 
see “Managing libraries with the Preset Manager (Photoshop)” on page 52.
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To change how patterns are displayed:

Choose a display option from a Pattern pop-up palette menu.

To load a library of patterns:

Choose one of the following from a Pattern pop-up palette menu:

• Load Patterns to add a library to the current list. Select the library file you want to use, 
and click Load.

• Replace Patterns to replace the current list with a different library. Select the library file 
you want to use, and click Load.

• A library file (displayed at the bottom of the palette menu). Click OK to replace the 
current list, or click Append to append the current list.

To rename a preset pattern:

1 Select the pattern you want to rename, and choose Rename Pattern from the palette 
menu. 

2 Enter a new name for the pattern, and click OK. 

To delete a preset pattern:

Do one of the following:

• Select the pattern you want to delete, and choose Delete Pattern from the palette 
menu. 

• Hold down Alt (Windows) or Option (Mac OS), position the pointer over a pattern 
(the pointer turns into scissors), and click.

To save a set of preset patterns as a library:

1 Choose Save Patterns from a Pattern pop-up palette menu.

2 Choose a location for the pattern library, enter a filename, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/
Patterns folder inside the Photoshop program folder, the library name will appear at the 
bottom of the Pattern pop-up palette menus after you restart Photoshop.

To return to the default library of patterns:

Choose Reset Patterns from a Pattern pop-up palette menu. You can either replace the 
current list or append the default library to the current list. 

If you receive a Pattern Stamp tool preset that uses an undefined pattern, or if you 
erase the preset you’re using by resetting or replacing the pattern library, choose New 

Pattern from the Pattern pop-up palette menu to redefine the pattern.
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Using the Pattern Maker
The Pattern Maker lets you create an infinite variety of patterns based on a selection or the 
contents of the Clipboard. Because the pattern is based on the pixels in a sample, it shares 
visual characteristics with the sample. For example, if you sample an image of grass, the 
Pattern Maker generates a tileable pattern that is different from the sample but still 
appears to be grass.You can generate multiple patterns from the same sample, and save 
pattern tiles as Photoshop, Illustrator, or GIF files for future use as presets in Photoshop.

Note: The Pattern Maker command is available only for 8-bit images in RGB Color, CMYK 
Color, Lab Color, and Grayscale image modes.

Generating patterns
The Pattern Maker generates patterns by rearranging the pixels in a sampled area to 
create a tile. The size of a tile can vary, from 1 pixel by 1 pixel to the dimensions of the 
active layer. If the tile is smaller than the active layer, the pattern is made up of multiple 
tiles that are laid out in a grid to fill the layer. If the tile is the same size as the active layer, 
it comprises the entire pattern.

Creating a pattern using the Pattern Maker 
A. Original image with pixels selected to create a tile B. Generated single pattern tile C. Image filled 
with tiled pattern

Note: If the transparency of the active layer is locked, the Pattern Maker does not change 
the transparency of the layer when it tiles with a generated pattern.

To generate a pattern:

1 Do one of the following:

• Select the layer that contains the area from which you want to generate the pattern. 
The layer you select will be replaced by the generated pattern, so it’s a good idea to 
make a copy of the layer first.

• To generate a pattern in a new layer or file, select the pixels from which you want to 
generate the pattern, and choose Edit > Copy. Then add a layer to the image, or create a 
new file with the dimensions you want the final image to have.

Note: You cannot generate a pattern from a nonrectangular sample. If you make a 
nonrectangular selection, Photoshop uses the bounding box of the selected area to create 
a rectangular sample.

2 Choose Filter > Pattern Maker.
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3 Do one of the following:

• If you are generating a pattern in the same layer that contains the sample, select the 
Rectangular Marquee tool  in the Pattern Maker dialog box, and select the area from 
which you want to generate the pattern. To move the selection marquee, drag it to a 
different location.

• If you are generating a pattern in a new layer or file, select Use Clipboard as Sample in 
the Pattern Maker dialog box.

4 Specify the dimensions of tiles in the generated pattern by doing one of the following:

• Enter pixel values in the Width and Height text boxes, or drag the pop-up sliders.

• Click Use Image Size to use the image size as the tile size. Selecting this option produces 
a pattern with a single tile.

5 To offset the tiles in the generated pattern, choose a direction from the Offset pop-up 
menu and specify an offset amount by entering a value in the Amount text box or 
dragging the Amount pop-up slider. The offset amount is a percentage of the tile 
dimension in the specified direction. 

6 Click Generate. The preview area is tiled with the generated pattern. (See “Previewing 
patterns” on page 349.)

You can view the status of the current generation in the Photoshop status bar. Press Esc to 
cancel the generation.

7 Click Generate Again to generate additional patterns using the same options, or adjust 
the options and then click Generate Again. 

You can navigate through the generated tiles using the Tile History panel. (See “Reviewing 
tiles and pattern previews” on page 350.) 

8 When you are satisfied with a pattern preview and you have saved the tiles that you 
might want to use in the future, click OK. (See “Reviewing tiles and pattern previews” on 
page 350.)

Previewing patterns
The Pattern Maker dialog box provides tools and options for previewing generated 
patterns. You can magnify and navigate in the preview image just as you do in the 
Photoshop document window. You can also show or hide tile boundaries and switch 
between previewing the original image and the generated pattern.

To magnify and reduce the preview image:

1 Select the Zoom tool  in the Pattern Maker dialog box.

2 Click in the preview image to zoom in, or hold down Alt (Windows) or Option (Mac OS), 
and click in the preview image to zoom out. 

The magnification level appears at the bottom of the dialog box.

To navigate in the preview image:

Select the Hand tool  in the Pattern Maker dialog box, and drag in the preview image. 
Alternately, hold down the spacebar, and drag in the preview image. 
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To display tile boundaries in the preview image:

Select Tile Boundaries in the Preview section of the Pattern Maker dialog box. To choose a 
different color for tile boundaries, click the color swatch.

To switch between the generated pattern and the original image:

Choose an option from the Show pop-up menu in the Preview section of the Pattern 
Maker dialog box.

When previewing the original image, you change the sample area using the 
Rectangular Marquee tool. The new sample will be used for the next generation.

Reviewing tiles and pattern previews
The Tile History section of the Pattern Maker dialog box lets you review all the pattern 
previews you have generated. You can navigate through pattern previews, delete pattern 
previews, and save tiles as preset patterns.

Important: When you save a tile as a preset pattern, only a single tile is saved, not the full, 
generated pattern.

To navigate through tiles and pattern previews:

Do one of the following:

• Click the First Tile button , Previous Tile button , Next Tile button , or Last Tile 
button .

• Type the number of the pattern preview you want to view, and press Enter (Windows) 
or Return (Mac OS).

If the Update Pattern Preview option is selected, the full pattern is regenerated in the 
preview area. If the Update Pattern Preview option is deselected, only the tile thumbnail 
changes. 

Deselect Update Pattern Preview to quickly review tiles. When you find the desired 
tile, select Update Pattern Preview to regenerate the preview.

To delete a tile and pattern preview:

Navigate to the tile you want to delete, and click the Trash button .

To save a tile as a preset pattern:

1 Navigate to the tile you want to save, and click the Preset Pattern button .

2 Enter a preset name, and click OK.

You can create and manage libraries of presets using the Preset Manager. (See “Managing 
libraries with the Preset Manager (Photoshop)” on page 52.)

Specifying pattern smoothness and detail
The Smoothness and Sample Detail options in the Pattern Maker dialog box let you 
control the parameters that Photoshop uses to generate a pattern. The default settings 
work well for most samples, so don’t change these settings unless you get a poor result. 
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Smoothness If the pixels in the sample lack contrast, the Pattern Maker may introduce 
unwanted edges into the generated pattern. Increasing the Smoothness value decreases 
the prominence of edges within a generated tile.

Generated pattern with Smoothness of 1 (left) and Smoothness of 3 (right)

Sample Detail If the sample contains details that are cut up in the generated pattern, 
increase the Sample Detail value.

Example of sampled image

Generated pattern with Sample Detail of 5 (left) and Sample Detail of 15 (right)

Note: Increasing the Smoothness and Sample Detail values results in slower pattern 
generation.

Choosing foreground and background colors
Photoshop uses the foreground color to paint, fill, and stroke selections and the 
background color to make gradient fills and fill in the erased areas of an image. The 
foreground and background colors are also used by some special effects filters.

You can designate a new foreground or background color using the Eyedropper tool, the 
Color palette, the Swatches palette, or the Adobe Color Picker (see “Using the Adobe Color 
Picker” on page 164).
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The default foreground color is black, and the default background color is white. (In an 
alpha channel, the default foreground is white, and the background is black.)

Foreground and background color boxes in toolbox 
A. Foreground color box B. Default colors icon C. Switch colors icon D. Background color box

Using color settings in the toolbox
The current foreground color appears in the upper color selection box in the toolbox; the 
current background color appears in the lower box.

The Info palette, the Color palette, and the Adobe Color Picker let you display color values 
using a number of color models. (See “About the different color modes (Photoshop)” on 
page 150.)

To change the foreground or background color:

1 Do one of the following:

• To change the foreground color, click the upper color selection box in the toolbox.

• To change the background color, click the lower color selection box in the toolbox.

2 Choose a color in the Adobe Color Picker. (See “Using the Adobe Color Picker” on 
page 164.)

To reverse the foreground and background colors:

Click the Switch Colors icon  in the toolbox. 

To restore the default foreground and background colors:

Click the Default Colors icon  in the toolbox.

Using the Eyedropper tool
The Eyedropper tool samples color to designate a new foreground or background color. 
You can sample from the active image or from anywhere else on the screen. 

You can also specify the area sampled by the Eyedropper tool. For example, you can set 
the eyedropper to sample the color values of a 3-by-3-pixel area under the pointer. 
Modifying the sample size of the eyedropper affects the color readouts displayed in the 
Info palette.

Selecting a foreground color with the Eyedropper tool 
A. Point Sample B. 5 x 5 average sample

A

B

C
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To select the foreground or background color:

1 Select the Eyedropper tool .

2 To change the sample size of the eyedropper, choose an option from the Sample Size 
menu:

• Point Sample to read the precise value of the pixel you click.

• 3 by 3 Average or 5 by 5 Average to read the average value of the specified number of 
pixels within the area you click.

3 Do one of the following:

• To select a new foreground color, click in the image. Alternately, position the pointer 
over the image, press the mouse button, and drag anywhere on the screen. The 
foreground color selection box changes dynamically as you drag. Release the mouse 
button to pick the new color.

•  To select a new background color, Alt-click (Windows) or Option-click (Mac OS) in the 
image. Alternately, position the pointer over the image, press Alt (Windows) or Options 
(Mac OS), press the mouse button, and drag anywhere on the screen. The background 
color selection box changes dynamically as you drag. Release the mouse button to pick 
the new color.

To use the Eyedropper tool temporarily while using any painting tool, hold down Alt 
(Windows) or Option (Mac OS). 

Using the Color palette 
The Color palette displays the color values for the current foreground and background 
colors. Using the sliders in the Color palette, you can edit the foreground and background 
colors according to several different color models. You can also choose a foreground or 
background color from the spectrum of colors displayed in the color ramp at the bottom 
of the palette. 

Color palette 
A. Foreground color B. Background color C. Slider D. Color bar

The Color palette may display the following alerts when you select a color:

• In Photoshop, an exclamation point inside a triangle  appears above the left side of 
the color ramp when you choose a color that cannot be printed using CMYK inks. For 
more information, see “Identifying out-of-gamut colors (Photoshop)” on page 184.

• A cube  appears above the left side of the color ramp when you choose a color that is 
not Web-safe. (See “Using Web-safe colors” on page 168.)

To display the Color palette:

Choose Window > Color, or click the Color palette tab.

A
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To change the color model of the color sliders:

Choose a Sliders option from the Color palette menu. For more information on the 
different color models, see “About the different color modes (Photoshop)” on page 150.

To change the spectrum displayed in the color ramp:

1 Choose an option from the Color palette menu:

• RGB Spectrum, CMYK Spectrum (Photoshop), or Grayscale Ramp to display the 
spectrum of the specified color model.

• Current Colors to display the spectrum of colors between the current foreground color 
and the current background color.

2 To display only Web-safe colors, choose Make Ramp Web Safe. (See “Using Web-safe 
colors” on page 168.)

To change the spectrum of the color ramp quickly, Shift-click in the color ramp until 
you see the spectrum you want. 

To select the foreground or background color: 

1 To edit the foreground or background color, make sure that its color selection box is 
active (outlined in black). To make the foreground or background color selection box 
active, click the box. 

2 Do one of the following:

• Drag the color sliders. By default, the slider colors change as you drag. In Photoshop, 
you can turn off this feature to improve performance by deselecting Dynamic Color 
Sliders in the General section of the Preferences dialog box.

• Enter values next to the color sliders. 

• Click the color selection box, choose a color using the color picker (see “Using the 
Adobe Color Picker” on page 164), and click OK.

• Position the pointer over the color ramp (the pointer becomes the eyedropper), 
and click to sample a color. Alt-click to apply the sample to the nonactive color 
selection box.

Using the Swatches palette
You can choose a foreground or background color from the Swatches palette, or you can 
add or delete colors to create a custom swatch library. Creating libraries of swatches can 
help you group related or special swatches and manage palette size. 

Note: You can also use the Preset Manager to manage libraries. For more information, 
see “Managing libraries with the Preset Manager (Photoshop)” on page 52.

To display the Swatches palette:

Choose Window > Swatches, or click the Swatches palette tab.

To change how swatches are displayed (Photoshop):

Choose a display option from the Swatches palette menu: 

• Small Thumbnail to display a thumbnail of each swatch. This is the default view.

• Small List to display the name and thumbnail of each swatch.
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To select a foreground or background color:

Do one of the following:

• To choose a foreground color, click a color in the Swatches palette. 

• To choose a background color, Ctrl-click (Windows) or Command-click (Mac OS) a color 
in the Swatches palette.

To load a library of swatches:

Choose one of the following from the Swatches palette menu:

• Load Swatches to add a library to the current list. Select the library file you want to use, 
and click Load.

• Replace Swatches to replace the current list with a different library. Select the library file 
you want to use, and click Load.

• A library file (displayed at the bottom of the palette menu). Click OK to replace the 
current list, or click Append to append the current list.

To add a color to the Swatches palette: 

Do one of the following:

• Make the color you want to add the foreground color, and click the New Swatch 
button  in the Swatches palette. Alternately, choose New Swatch from the Swatches 
palette menu.

• (Photoshop) Make the color you want to add the foreground color. Position the pointer 
over an empty space in the bottom row of the Swatches palette (the pointer turns into 
the Paint Bucket tool), and click to add the color. Enter a name for the new color and 
click OK.

Color selected from image (left), and added to Swatches palette (right)

• (ImageReady) Drag the foreground color selection box or the background color 
selection box from the toolbox to the Swatches palette.

• (ImageReady) Drag a swatch from the Color Table palette to the Swatches palette.

Note: New colors are saved in the Preferences file so that they persist between editing 
sessions. To permanently save a color, save it in a library. 

To duplicate a color in the Swatches palette (ImageReady):

Select the color you want to duplicate, and choose New Swatch from the Swatches 
palette menu.
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To delete a color from the Swatches palette:

Do one of the following:

• Drag a swatch to the Trash button .

• (Photoshop) Hold down Alt (Windows) or Option (Mac OS), position the pointer over a 
swatch (the pointer turns into scissors), and click.

• (ImageReady) Select a swatch, and choose Delete Swatch from the Swatches palette 
menu.

To save a set of swatches as a library:

1 Choose Save Swatches from the Swatches palette menu.

2 Choose a location for the swatch library, enter a filename, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/
Swatches folder inside the Photoshop program folder, the library name will appear at the 
bottom of the Swatches palette menu after you restart the application.

To return to the default library of swatches:

Choose Reset Swatches from the Swatches palette menu. You can either replace the 
current list or append the default library to the current list. 
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Using Channels

About channels
Channels are grayscale images that store different types of information:

• Color information channels are created automatically when you open a new image. 
The image’s color mode determines the number of color channels created. For 
example, an RGB image has four default channels: one for each of the red, green, 
and blue colors plus a composite channel used for editing the image.

• You can create alpha channels to store selections as grayscale images. You use alpha 
channels to create and store masks, which let you manipulate, isolate, and protect 
specific parts of an image. In addition to supporting alpha channels from Photoshop, 
you can save, load, and delete selections as alpha channels in ImageReady. 

• You can create spot color channels to specify additional plates for printing with spot 
color inks.

An image can have up to 56 channels. The file size required for a channel depends on the 
pixel information in the channel. Certain file formats, including TIFF and Photoshop 
formats, compress channel information and can save space. The uncompressed size of a 
file, including alpha channels and layers, appears as the rightmost value in the status bar 
at the bottom of the window when Document Sizes is chosen from the pop-up menu.

Note: As long as you save a file in a format supporting the image’s color mode, the color 
channels are preserved. Alpha channels are preserved only when you save a file in Adobe 
Photoshop, PDF, PICT, Pixar, TIFF, or Raw formats. DCS 2.0 format preserves only spot 
channels. Saving in other formats may cause channel information to be discarded. 
(See “About file formats” on page 582.)

Using the Channels palette (Photoshop)
The Channels palette lets you create and manage channels and monitor the effects of 
editing. The palette lists all channels in the image—composite channel first (for RGB, 
CMYK, and Lab images), then individual color channels, spot color channels, and finally 
alpha channels. A thumbnail of the channel’s contents appears to the left of the channel 
name; the thumbnail automatically updates as you edit the channel.
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Channels types 
A. Color channels B. Spot channels C. Alpha channels

Viewing channels
You can use the palette to view any combination of individual channels. For example, 
you can view an alpha channel and the composite channel together to see how changes 
made in the alpha channel relate to the entire image. By default, individual channels are 
displayed in grayscale.

To display the Channels palette:

1 Choose Windows > Channels, or click the Channels palette tab.

2 Use the scroll bars or resize the palette to see additional channels.

When a channel is visible in the image, an eye icon  appears to its left in the palette. 

To show or hide a channel: 

Click in the eye column next to the channel to show or hide that channel. (Click the 
composite channel to view all default color channels. The composite channel is displayed 
whenever all the color channels are visible.)

To show or hide multiple channels, drag through the eye column in the Channels 
palette.

These guidelines apply to channels you display:

• In RGB, CMYK, or Lab images, you can view the individual channels in color. (In Lab 
images, only the a and b channels appear in color.)

• If more than one channel is active, the channels always appear in color.

• In alpha channels, selected pixels appear as white; unselected pixels appear as black 
(partially transparent or selected pixels appear as gray). These are the channel default 
options.

• If you display an alpha channel at the same time as color channels, the alpha channel 
appears as a transparent color overlay, analogous to a printer’s rubylith or a sheet 
of acetate. To change the color of this overlay or set other alpha channel options, 
see “Creating alpha channels (Photoshop)” on page 255.
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Changing the display of the palette
You can show the individual color channels in color (rather than grayscale) in the Channels 
palette and specify the size of the thumbnails. Using thumbnails is the most convenient 
way of tracking channel contents; however, turning off the display of thumbnails can 
improve performance.

To show color channels in color:

1 Do one of the following:

• In Windows, choose Edit > Preferences > Display & Cursors.

• In Mac OS, choose Photoshop > Preferences > Display & Cursors.

2 Select Color Channels in Color, and click OK.

To resize or hide channel thumbnails:

1 Choose Palette Options from the Channels palette menu.

2 Select a display option:

• Click a thumbnail size. Smaller thumbnails reduce the space required by the palette—
helpful when you’re working on smaller monitors.

• Click None to turn off the display of thumbnails. 

Selecting and editing channels
You can select one or more channels in the Channels palette. The names of all selected, 
or active, channels are highlighted. Any editing changes you make apply to the active 
channels.

Selecting multiple channels 
A. Not visible or editable B. Visible but not selected for editing C. Selected for viewing and editing  
D. Selected for editing but not viewing

To select a channel:

Click the channel name. Shift-click to select (or deselect) multiple channels. 

To edit a channel:

Use a painting or editing tool to paint in the image. Paint with white to add the selected 
channel’s color at 100% intensity. Paint with a value of gray to add the channel’s color at a 
lower intensity. Paint with black to fully remove the channel’s color. (See “Modifying alpha 
channels (Photoshop)” on page 256.)
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Managing channels (Photoshop)
You can rearrange channels, duplicate a channel within or between images, split a channel 
into separate images, merge channels from separate images into one new image, and 
delete alpha and spot channels when you’re finished with them.

Rearranging and renaming channels
The default color channels normally appear at the top of the Channels palette, followed by 
the spot color channels, and then the alpha channels. You cannot move or rename the 
default channels, but you can rearrange and rename spot and alpha channels to suit the 
way you work. 

Spot colors are overprinted in the order they appear in the Channels palette.

To change the order of alpha or spot channels:

Drag the channel up or down. When a line appears in the position you want, release the 
mouse button.

Note: You can move alpha or spot channels above the default color channels only if the 
image is in Multichannel mode.

To rename an alpha or spot channel:

Double-click the channel’s name in the Channels palette, and enter a new name.

Duplicating channels
You might duplicate an image’s channel to make a backup before editing the channel. 
Or you might duplicate alpha channels to a new image to create a library of selections to 
load into the current image one by one—thus keeping the file smaller. 

If you are duplicating alpha channels between images, the channels must have identical 
pixel dimensions. (See “Creating new images” on page 89.)

Note: You cannot duplicate a channel to a Bitmap-mode image.

To duplicate a channel using the Duplicate command:

1 In the Channels palette, select the channel to duplicate.

2 Choose Duplicate Channel from the Channels palette menu.

3 Type a name for the duplicate channel.

4 For Document, do one of the following:

• Choose a destination. Only open images with pixel dimensions identical to the current 
image are available. To duplicate the channel in the same file, select the channel’s 
current file. 

• Choose New to copy the channel to a new image, creating a multichannel image 
containing a single channel. Type a name for the new image. 

5 To reverse the selected and masked areas in the duplicate channel, select Invert. 

To duplicate a channel within an image by dragging:

1 In the Channels palette, select the channel you want to duplicate.

2 Drag the channel onto the New Channel button  at the bottom of the palette.
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To duplicate a channel to another image by dragging or pasting:

1 In the Channels palette, select the channel you want to duplicate.

2 Make sure that the destination image is open.

Note: The destination image does not have to be the same pixel dimensions as the 
duplicated channel.

3 Do one of the following:

• Drag the channel from the Channels palette into the destination image window. The 
duplicated channel appears at the bottom of the Channels palette.

• Choose Select > All, and then choose Edit > Copy. Select the channel in the destination 
image and choose Edit > Paste. The pasted channel overwrites the existing channel.

Splitting channels into separate images
You can split the channels of a flattened image into separate images. The original file is 
closed, and the individual channels appear in separate grayscale image windows. The title 
bars in the new windows show the original filename plus the channel abbreviation 
(Windows) or full name (Mac OS). Any changes since the last save are retained in the 
new images and lost in the original.

Splitting channels is useful when you want to retain individual channel information in 
a file format that doesn’t preserve channels.

Note: Only flattened images can be split. (See “Flattening all layers” on page 385.)

To split channels into separate images:

Choose Split Channels from the Channels palette menu.

Merging channels
Multiple grayscale images can be combined into a single image. Some grayscale scanners 
let you scan a color image through a red filter, a green filter, and a blue filter to generate 
red, green, and blue images. Merging lets you combine the separate scans into a single, 
color image.

The images you want to merge must be in Grayscale mode, have the same pixel dimen-
sions, and be open. (See “Changing the pixel dimensions of an image” on page 67.) The 
number of grayscale images you have open determines the color modes available when 
merging channels. For example, you can’t merge the split channels from an RGB image 
into a CMYK image, because CMYK requires four channels and RGB requires only three. 

Note: If you are working with DCS files that have accidentally lost their links (and so 
cannot be opened, placed, or printed), open the channel files, and merge them into a 
CMYK image. Then resave the file as a DCS EPS file. 

To merge channels: 

1 Open the grayscale images containing the channels you want to merge, and make one 
of the images active.

You must have more than one image opened for the Merge Channels option to be 
available.

2 Choose Merge Channels from the Channels palette menu.
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3 For Mode, choose the color mode you want to create. If an image mode is unavailable, 
it is dimmed. The number of channels appropriate for the mode appears in the Channels 
text box. 

4 If necessary, enter a number in the Channels text box. 

If you enter a number that is incompatible with the selected mode, Multichannel mode is 
automatically selected. This creates a a multichannel image with two or more channels.

5 Click OK.

6 For each channel, make sure the image you want is open. If you change your mind 
about image type, click Mode to return to the Merge Channels dialog box. 

7 If merging into a multichannel image, click Next, and repeat step 6 to select the 
remaining channels. 

Note: All channels of a multichannel image are alpha channels or spot channels.

8 When you are finished selecting channels, click OK. 

The selected channels are merged into a new image of the specified type, and the original 
images are closed without any changes. The new image appears in an untitled window. 

Note: You cannot split and recombine (merge) an image with spot color channels. The 
spot color channel will be added as an alpha channel.

Deleting channels
You may want to delete spot or alpha channels you no longer need before saving an 
image. Complex alpha channels can substantially increase the disk space required for an 
image. 

To delete a channel (Photoshop):

1 Select the channel in the Channels palette.

2 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the Trash button .

• Drag the channel name in the palette to the Trash button.

• Choose Delete Channel from the Channels palette menu.

• Click the Trash button at the bottom of the palette, and then click Yes.

Note: (Photoshop) When you delete a color channel from a file with layers, visible layers 
are flattened and hidden layers are discarded. This is done because removing a color 
channel converts the image to Multichannel mode, which does not support layers. An 
image isn’t flattened when you delete an alpha channel, a spot channel, or a quick mask.

To delete a channel (ImageReady):

Choose Select > Delete Channel, and choose the channel from the submenu.

Adding spot colors (Photoshop)
Spot colors are special premixed inks used instead of, or in addition to, the process color 
(CMYK) inks. Each spot color requires its own plate on the press. (Because a varnish 
requires a separate plate, it is considered a spot color, too.) For information on printing 
spot color plates, see “Printing color separations” on page 620.
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If you are planning to print an image with spot colors, you need to create spot channels 
to store the colors. To export spot channels, save the file in DCS 2.0 format or PDF. 
(See “Saving files in Photoshop EPS format (Photoshop)” on page 570.) 

Note: ImageReady supports Photoshop spot color channels as alpha channels.

About spot colors
Note the following when working with spot colors:

• For spot color graphics that have crisp edges and knock out the underlying image, 
consider creating the additional artwork in a page-layout or illustration application.

• To apply spot color as a tint throughout an image, convert the image to Duotone mode 
and apply the spot color to one of the duotone plates. You can use up to four spot 
colors, one per plate. (See “Printing color separations” on page 620.)

• The names of the spot colors print on the separations.

• Spot colors are overprinted on top of the fully composited image. Each spot color is 
overprinted in the order it appears in the Channels palette.

• You cannot move spot colors above a default channel in the Channels palette except in 
Multi-channel mode.

• Spot colors cannot be applied to individual layers.

• Printing an image with a spot color channel to a composite color printer will print the 
spot color at an opacity indicated by the solidity setting.

• You can merge spot channels with color channels, splitting the spot color into its color 
channel components. 

Creating spot channels
You can create a new spot channel or convert an existing alpha channel to a spot channel.

To create a new spot channel:

1 Choose Window > Channels to display the Channels palette.

2 To fill a selected area with a spot color, make or load a selection.

3 Do one of the following to create a channel:

• Ctrl-click (Windows) or Command-click (Mac OS) the New Channel button  in the 
Channels palette.

• Choose New Spot Channel from the Channels palette menu.

If you made a selection, that area is filled with the currently specified spot color.

4 Click the color box, and choose a color. 

If you select a custom color, your print service provider can more easily provide the 
proper ink to reproduce the image. (See “Choosing custom colors (Photoshop)” on 

page 169.)

5 For Solidity, enter a value between 0% and 100%. 
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This option lets you simulate on-screen the solidity of the printed spot color. A value of 
100% simulates an ink that completely covers the inks beneath (such as a metallic ink); 
0% simulates a transparent ink that completely reveals the inks beneath (such as a clear 
varnish). You can also use this option to see where an otherwise transparent spot color 
(such as a varnish) will appear.

Solidity 100% and solidity 50%

Note: The Solidity and color choice options affect only the on-screen preview and the 
composite print. They have no effect on the printed separations.

6 To enter a name for the spot channel, choose a custom color in step 4, and the channel 
automatically takes the name of that color.

Be sure to name spot colors so they’ll be recognized by other applications reading your 
file. Otherwise the file might not print.

To convert an alpha channel to a spot channel:

1 Do one of the following:

• Double-click the alpha channel thumbnail in the Channels palette.

• Select the alpha channel in the Channels palette, and choose Channel Options from the 
palette menu.

2 If needed, rename the channel.

3 Select Spot Color.

4 Click the color box, choose a color in the Color Picker dialog box, and click OK.

5 Click OK. The areas of the channel containing grayscale values are converted to spot 
color.

6 Choose Image > Adjustments > Invert to apply the color to the selected area of the 
channel. 

Modifying spot channels
You can edit a spot channel to add or remove color in it, change a spot channel’s color or 
on-screen color solidity, and merge a spot channel with the image’s color channels.

For information on rearranging, duplicating, or deleting spot channels, see “Managing 
channels (Photoshop)” on page 360.

To edit a spot channel:

1 Select the spot channel in the Channels palette.
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2 Use a painting or editing tool to paint in the image. Paint with black to add more spot 
color at 100% opacity; paint with gray to add spot color with lower opacity.

Note: Unlike the Solidity option in the Spot Channel Options dialog box, the Opacity 
option in the painting or editing tool’s options determines the actual density of ink used in 
the printed output.

To change a spot channel’s options:

1 Do one of the following:

• Double-click the spot channel thumbnail in the Channels palette.

• Select the spot channel in the Channels palette, and choose Channel Options from the 
palette menu.

2 Click the color box, and choose a color.

By selecting a custom color, your print service can more easily provide the proper ink to 
reproduce the image. (See “Choosing custom colors (Photoshop)” on page 169.)

3 For Solidity, enter a value between 0% and 100%. 

This option lets you simulate on-screen the solidity of the printed spot color. A value of 
100% simulates an ink that completely covers the inks beneath (such as a metallic ink); 
0% simulates a transparent ink that completely reveals the inks beneath (such as a clear 
varnish). You can also use this option to see where an otherwise transparent spot color 
(such as a varnish) will appear.

Note: The Solidity and color choice options affect only the on-screen preview and the 
composite print. They have no effect on the printed separations.

To merge spot channels:

1 Select the spot channel in the Channels palette.

2 Choose Merge Spot Channel from the palette menu.

The spot color is converted to and merged with the color channels. The spot channel is 
deleted from the palette.

Merging spot channels flattens layered images. The merged composite reflects the 
preview spot color information, including the Solidity settings. For example, a spot 
channel with a solidity of 50% will produce different merged results than the same 
channel with a solidity of 100%.

In addition, the resulting merged spot channels usually don’t reproduce the same colors 
as the original spot channels, because CMYK inks can’t represent the range of colors 
available from spot color inks.

Adjusting overlapping spot colors 
To prevent overlapping spot colors from either printing over or knocking out the under-
lying spot color, remove one of the spot colors where they overlap. 

Use a printed sample of the overprinted inks to adjust your screen display to help you 
predict how colors will look when printed.

Note: In some cases, such as when you use varnish and bump plates, you may want colors 
to overprint.
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To adjust overlapping spot colors:

1 In the Channels palette, select the spot channel with the color you want to print.

2 Choose Select > Load Selection.

To quickly select an image in a channel, hold down Ctrl (Windows) or Command 
(Mac OS), and click the channel in the Channels palette.

3 For Channel, choose the spot channel from step 1, and click OK.

4 To create a trap when knocking out the underlying color, choose Select > Modify > 
Expand or Contract, depending on whether the overlapping spot color is darker or lighter 
than the spot color beneath it. For more information on trapping, see “Creating color 
traps” on page 621.

5 In the Channels palette, select the underlying spot channel that contains areas you 
want to knock out. Press Backspace (Windows) or Delete (Mac OS).

This method can be used to knock out areas from any channels under a spot color, 
such as the CMYK channels.

6 If a spot color in one channel overlaps more than one other spot color, repeat this 
process for each channel that contains areas you want removed. 

Using channel calculations to blend layers and channels 
(Photoshop)
You can use the blending effects associated with layers to combine channels within and 
between images into new images using the Apply Image command (on single and 
composite channels) and the Calculations command (on single channels). These 
commands offer two additional blending modes not available in the Layers palette—
Add and Subtract. Although it’s possible to create new combinations of channels by 
copying channels into layers in the Layers palette, you may find it quicker to use the 
calculation commands to blend channel information. 

The calculation commands perform mathematical operations on the corresponding pixels 
of two channels (the pixels with identical locations on the image) and then combine the 
results in a single channel. Two concepts are fundamental to understanding how the 
calculation commands work.

• Each pixel in a channel has a brightness value. The Calculations and Apply Image 
commands manipulate these values to produce the resulting composite pixels. 

• These commands overlay the pixels in two or more channels. Thus, the images used for 
calculations must have the same pixel dimensions. (See “Changing image size and 
resolution” on page 65 for information on adjusting an image’s pixel dimensions.)
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Using the Apply Image command
The Apply Image command lets you blend one image’s layer and channel (the source) with 
a layer and channel of the active image (the destination). 

To use the Apply Image command: 

1 Open the source and destination images, and select the desired layer and channel in 
the destination image. The pixel dimensions of the images must match for image names 
to appear in the Apply Image dialog box.

Note: If the color modes of the two images differ (for example, one image is RGB and the 
other is CMYK), you can copy a single channel to another channel between images, but 
you cannot copy a composite channel to a composite channel in another image. 

2 Choose Image > Apply Image.

3 Choose the source image, layer, and channel you want to combine with the destination. 
To use all layers in the source image, select Merged for Layer. 

4 Select Preview to preview the results in the image window.

5 Select Invert to use the negative of the channel contents in the calculation.

6 For Blending, choose a blending option.

For information on the Add and Subtract options, see “About the Add and Subtract 
blending modes” on page 368. For information on other blending options, see “Selecting 
a blending mode” on page 331.

7 Enter an opacity to specify the effect’s strength. 

8 Select Preserve Transparency to apply the results only to opaque areas in the result 
layer.

9 Select Mask if you want to apply the blending through a mask. Then choose the image 
and layer containing the mask. For Channel, you can choose any color or alpha channel to 
use as the mask. You can also use a mask based on the active selection or the boundaries 
of the chosen layer (Transparency). Select Invert to reverse the masked and unmasked 
areas of the channel. (See “Using channel calculations to blend layers and channels 
(Photoshop)” on page 366.)

Using the Calculations command
The Calculations command lets you blend two individual channels from one or more 
source images. You can then apply the results to a new image or to a new channel or 
selection in the active image. You cannot apply the Calculations command to composite 
channels.

To use the Calculations command:

1 Open the source image or images. 

Note: If you are using more than one source image, the images must have the same pixel 
dimensions.

2 Choose Image > Calculations. 

3 Select Preview to preview the results in the image window.

4 Choose the first source image, layer, and channel. To use all the layers in the source 
image, choose Merged for Layer. 
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5 Select Invert to use the negative of the channel contents in the calculation. For 
Channel, choose Gray to get the same effect as would be obtained by converting the 
image to a grayscale image.

6 Choose the second source image, layer, and channel, specifying further options as 
described in step 5. 

7 For Blending, choose a blending mode. 

For information on the Add and Subtract modes, see “About the Add and Subtract 
blending modes” on page 368. For information on other blending modes, see “Selecting a 
blending mode” on page 331.

8 Enter an opacity to specify the effect’s strength. 

9 Select Mask if you want to apply the blending through a mask. Then choose the image 
and layer containing the mask. For Channel, you can choose any color or alpha channel to 
use as the mask. You can also use a mask based on the active selection or the boundaries 
of the chosen layer (Transparency). Select Invert to reverse the masked and unmasked 
areas of the channel.

10 For Result, specify whether to place the blending results in a new document or in a 
new channel or selection in the active image. 

About the Add and Subtract blending modes
The Add and Subtract blending modes are available only for the Apply Image and 
Calculations commands.

Add Adds the pixel values in two channels. This is a good way to combine nonover-
lapping images in two channels.

Because higher pixel values represent lighter colors, adding channels with overlapping 
pixels lightens the image. Black areas in both channels remain black (0 + 0 = 0). White in 
either channel results in white (255 + any value = 255 or greater).

Add mode divides the sum of the pixel values by the Scale amount and then adds the 
Offset value to the sum. For example, if you wanted to find the average of the pixels in two 
channels, you would add them, divide by 2, and enter no Offset value.

The Scale factor may be any number between 1.000 and 2.000. Entering a higher Scale 
value darkens the image. 

The Offset value lets you lighten or darken the pixels in the destination channel by any 
brightness value between +255 and –255. Negative values darken the image; positive 
values lighten the image. 

Subtract Subtracts the pixel values in the source channel from the corresponding pixels 
in the target channel. As with Add mode, the result is then divided by the Scale factor and 
added to the Offset value.

The Scale factor may be any number between 1.000 and 2.000. The Offset value lets you 
lighten or darken the pixels in the destination channel by any brightness value between 
+255 and –255.
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Using Layers

About layers
Layers allow you to work on one element of an image without disturbing the others. Think 
of layers as sheets of acetate stacked one on top of the other. Where there is no image on a 
layer, you can see through to the layers below. You can change the composition of an 
image by changing the order and attributes of layers. In addition, special features such as 
adjustment layers, fill layers, and layer styles let you create sophisticated effects.

Illustration of how transparent areas on a layer let you see through to the layers below

You can put multiple layers together in different ways:

• Groups let you view and physically manipulate multiple layers as a single object. 
(See “Grouping layers (ImageReady)” on page 375.)

• Sets let you assign attributes to multiple layers as a single object. (See “Creating new 
layers and layer sets” on page 372.)

• Links let you link layers together to use them as a single object. (See “Linking layers” on 
page 378.) If you’re using new files, use layer groups instead of linking layers 
(ImageReady).

Working with layers (ImageReady)
ImageReady layers have additional features that simplify Web design. For example, you 
can select multiple layers, either in the layers palette or directly in the document. Selected 
layers do not have to be contiguous. (See “Selecting layers” on page 374.) Once selected, 
layers can be aligned, distributed, moved, transformed, and grouped.

Using the Move tool with layers
In ImageReady, you can use the Move tool to select, align, distribute, and move multiple 
layers. Selecting the Move tool in the toolbox enables three additional move tools in the 
options bar: 

• Layer Move tool to move the entire layer.
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• Layer Select tool  to move an ungrouped layer or a grouped layer as a single object. 

• Direct Select tool  to select a specific layer or layers in a group to move separately.

Manipulating layer content
In ImageReady, the content on a layer displays selection handles so that you can easily see 
in the document which layers are selected. You can set an option for layer content to 
invoke transform mode when selected—this way you can immediately resize or rotate a 
button after you draw.

Layer content with selection handles (left) and with transform mode selected (right)

Using the Layers palette
The Layers palette lists all layers, layer sets, and layer effects in an image. You can accom-
plish many tasks—such as creating, hiding, displaying, copying, and deleting layers—
using the buttons in the Layers palette. You can access additional commands and options 
in the Layers palette menu and the Layers menu.

Photoshop Layers palette 
A. Layers palette menu B. Layer set C. Layer D. Layer thumbnail E. Layer effect

Displaying the Layers palette Choose Window > Layers. Be sure to move the palette 
from the dock to enable the palette menu.

A

B

C

D

E
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Using the Layers palette menu Click the triangle  in the upper right corner of the 
palette to access commands for working with layers.

Changing the size of layer thumbnails Choose Palette Options from the Layers palette 
menu, and select a thumbnail size. 

Changing thumbnail contents (ImageReady) Choose Palette Options from the Layers 
palette menu, and select Entire Document to display the contents of the entire document. 
Select Layer Bounds to restrict the thumbnail to the object’s pixels on the layer. This makes 
it easier to see in the Layers palette. Check the Show Layer Group Thumbnails box to show 
a composite image of the group rather than the group icon. 

Turn off thumbnails to improve performance and save monitor space.

Expanding and collapsing layer sets Click the triangle to the left of a layer set folder. In 
Photoshop, press Alt (Windows) or Option (Mac OS) when clicking the triangle to expand 
or collapse all effects applied to layers contained within the set. Press Alt (Windows) or 
Option (Mac OS) when clicking the triangle to expand or collapse all sets, including nested 
layer sets. Press Ctrl (Windows) or Command (Mac OS) when clicking to see all sets at the 
same level as the selected one.

Creating layers and layer sets
A new image in Photoshop or ImageReady has a single layer. The number of additional 
layers, layer effects, and layer sets you can add to an image is limited only by your 
computer’s memory. 

Layer sets help you organize and manage layers. You can use layer sets to semantically 
arrange your layers to reduce clutter in the Layers palette. You can nest sets within 
other sets. You can also use layer sets to apply attributes and masks to multiple layers 
simultaneously.

In ImageReady, you may find that working with layer groups rather than layer sets is more 
efficient. See “Grouping layers (ImageReady)” on page 375.

About the background layer
When you create a new image with a white background or a colored background, the 
bottommost image in the Layers palette is Background. An image can have only one 
background. You cannot change the stacking order of a background, its blending mode, 
or its opacity. However, you can convert a background to a regular layer.

When you create a new image with transparent content, the image does not have a 
background layer. The bottommost layer is not constrained like the background layer; you 
can move it anywhere in the Layers palette, and change its opacity and blending mode.

To convert a background into a layer:

1 Double-click Background in the Layers palette, or choose Layer > New > Layer from 
Background.

2 Set layer options as desired. (See “Creating new layers and layer sets” on page 372.)

3 Click OK.
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To convert a layer into a background:

1 Select a layer in the Layers palette.

2 Choose Layer > New > Background from Layer.

Note: You cannot create a background by renaming a regular layer Background—you 
must use the Background from Layer command. 

Creating new layers and layer sets
You can create empty layers and add content to them, or you can create new layers from 
existing content. When you create a new layer, it appears either above the selected layer or 
within the selected layer set in the Layers palette.

To create a new layer or layer set using default options:

Click the New Layer button  or New Layer Set button  in the Layers palette. 

To create a new layer or layer set and specify options:

1 Do one of the following:

• Choose Layer > New > Layer or choose Layer > New > Layer Set.

• Choose New Layer or New Layer Set from the Layers palette menu.

• Alt-click (Windows) or Option-click (Mac OS) the New Layer button or New Layer Set 
button in the Layers palette.

• Ctrl-click (Windows) or Command-click (Mac OS) the New Layer button or New Layer 
Set button in the Layers palette to add a layer below the currently selected layer.

2 Set layer options, and click OK:

• Name to specify a name for the layer or layer set. (See “Renaming layers” on page 382.)

• Use Layer Below to Create Clipping Mask. This option is not available for layer sets. 
(See “Creating clipping masks” on page 413.)

• Color to assign a color to the layer or layer set. (See “Color coding layers” on page 382.)

• Mode to specify a blending mode for the layer or layer set. (See “Choosing a blending 
mode” on page 386.)

• Opacity to specify an opacity level for the layer or layer set. (See “Setting layer opacity” 
on page 386.)

• (Photoshop) Fill with Mode-neutral color to fill the layer with a preset, neutral color. 
(See “Filling new layers with a neutral color” on page 387.)

To create a new layer that uses the style of an existing layer, see “Applying preset 
styles” on page 392.

To create a new layer with the same effects as an existing layer (ImageReady):

1 Select the existing layer in the Layers palette. 

2 Drag the layer to the New Layer button at the bottom of the Layers palette. The newly 
created layer contains all the effects of the existing one.

To copy a layer set:

Drag an existing layer set to the New Layer button.



Using Help | Contents | Index Back 373  

Adobe Photoshop CS Help Using Layers 

Using Help | Contents | Index Back 373  

To convert a selection into a new layer: 

1 Make a selection. 

2 Do one of the following:

• Choose Layer > New > Layer Via Copy to copy the selection into a new layer.

• Choose Layer > New > Layer Via Cut to cut the selection and paste it into a new layer.

To create a new layer set from linked layers:

Choose Layer > New > Layer Set from Linked. (See “Linking layers” on page 378.)

To add new or existing layers to a layer set:

Do one of the following:

• Select the layer set in the Layers palette and click the New Layer button .

• Drag a layer to the layer set folder.

• Drag a layer set folder into another layer set folder. The layer set and all of its layers 
move.

To nest layer sets:

Drag an existing layer set to the New Layer Set button .

Working with layered images
There are many advantages to working with layered images. You can quickly select, hide, 
duplicate, lock, and change the appearance of images using layers. 

Viewing layers and layer sets
Using the Layers palette, you can arrange your layers and layer sets in a way that makes 
the most sense to you. You can open sets when you want to work on the layers within 
them, and close sets to keep your palette manageable.

To view individual layers and layer sets:

Select Window > Layers palette to open the Layers palette. Each of your layers and layer 
sets will appear, unless they are in sets that are closed.

To view layers within a layer set:

1 Click the layer set in the Layers palette. 

2 To open the set, do one of the following:

• Click the triangle to the left of the folder icon.

• Control-click (Windows) or Command-click (Mac OS) the triangle to the left of the folder 
icon and choose Open This Layer Set. 

To view nested layer sets:

1 Open the parent layer set.

2 Do one of the following:

• Ctrl-click (Windows) or Command-click (Mac OS) the triangle to the left of the folder 
icon to open or close a set and its layers.
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• Alt-click (Windows) or Option-click (Mac OS) the triangle to open or close a set and the 
sets nested within it.

• Ctrl + Alt-click (Windows) or Command + Option-click (Mac OS) to open or close all 
layers within the set, all sets nested within the set, and the set itself.

Selecting layers
If an image has multiple layers, you must select which layer you want to work on. Any 
changes you make to the image affect only the active layers. You select a layer to make it 
active. In Photoshop you can select only one layer. In ImageReady you can select multiple 
layers at a time. The name of the active layer appears in the title bar of the document 
window (Photoshop), and a paintbrush icon  appears next to the layer in the Layers 
palette. You can select layers with the Layers palette or using the Move Tool.

If you don’t see the desired results when using a tool or applying a command, you may 
not have the correct layer selected. Check the Layers palette to make sure that you’re 

working on the desired layer.

To select a layer in the Layers palette:

Do one of the following:

• Click a layer in the Layers palette.

• (ImageReady) To select multiple contiguous layers, shift-click. To select multiple 
separate layers, Ctrl-click (Windows) or Command-click (Mac OS) in the layers palette. 

• (ImageReady) To select linked layers, choose Select Linked Layers from the Layers 
palette menu.

To select layers directly in the document window:

1 Select the Move tool .

2 Do one of the following:

• (ImageReady) In the options bar, select the Layer Select tool . Click in the document 
on a single layer to select it, in a group to select the entire group, or in a layer in a layer 
set to select only that layer. Note that you can’t select locked layers with this tool.

• (ImageReady) In the options bar, select the Direct Select tool . Click in the document 
on a layer within a group to select the individual layer.

• (Photoshop) In the options bar, select Auto Select Layer and click in the document on 
the layer content you want to select. The topmost layer containing pixels under the 
cursor will be selected. (See “Moving selections and layers within an image” on 
page 241.)

• Right-click (Windows) or Control-click (Mac OS) in the image, and choose a layer from 
the context menu. The context menu lists all the layers that contain pixels under the 
current pointer location.

To select a layer from a set:

1 Click the layer set in the Layers palette. 

2 To open the set, do one of the following:

• Click the triangle  to the left of the folder icon . 
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• Ctrl-click (Windows) or Command-click (Mac OS) the triangle to the left of the folder 
icon and choose Open This Layer Set from the popup menu. (You can choose Open 
Other Layer Sets to open those other than what you’ve selected.)

3 Click the individual layer in the set.

Displaying the contents of layers
You can use the Layers palette to selectively hide and display the contents of layers, layer 
sets, and layer effects. You can also specify how transparent areas are displayed in the 
image.

To change the visibility of a layer, layer set, or layer effect:

Do one of the following:

• In the Layers palette, click the eye icon  next to a layer, layer set, or layer effect to hide 
its content in the document window. Click in the column again to redisplay the content. 

• Alt-click (Windows) or Option-click (Mac OS) an eye icon to display only the content for 
that layer or layer set. Doing this will enable Photoshop to remember the visibility 
states of all layers before hiding them. Alt-click (Windows) or Option-click (Mac OS) in 
the eye column again to restore the original visibility settings. 

• Drag through the eye column to change the visibility of multiple items in the Layers 
palette.

Note: Only visible layers are printed.

To change the way transparency is displayed:

1 Do one of the following:

• (Photoshop) In Windows, choose Edit > Preferences > Transparency & Gamut; in 
Mac OS, choose Photoshop > Preferences > Transparency & Gamut. 

• (ImageReady) In Windows, choose Edit > Preference > Transparency; in Mac OS, choose 
ImageReady > Preferences > Transparency.

2 Choose a size and color for the transparency checkerboard, or choose None for Grid 
Size to hide the transparency checkerboard. 

3 (Photoshop) Select Use Video Alpha to enable Photoshop to send transparency 
information to your computer’s video board. This option requires hardware support—
make sure that your computer’s video board allows images to be overlaid on top of a live 
video signal. 

4 Click OK.

Grouping layers (ImageReady)
Grouping layers in ImageReady simplifies working with and organizing multiple layers. 
Layer groups are similar to layer sets but allow for different kinds of quick manipulation. 
Layer groups let you move, drag, resize and physically manipulate multiple layers as one. 
This is very useful if you have, for example, a tab that consists of multiple layers. Rather 
than carefully selecting each layer associated with the tab every time you want to move it, 
you can group all the layers of your tab and move it as a single object.
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When you create a layer group, the layers included in the group appear in the Layer 
palette indented under a heading of Group #, where “#” is the number of the group. With 
the Layer Select tool, you can click any layer in the group to move the entire group.

Layers in an ImageReady layer group can be selected and manipulated as a single object.

To group layers:

1 Select multiple layers in the layers palette.

2 Do one of the following:

• Choose Layer > Group Layers (or use Ctrl + G (Windows) or Command + G (Mac OS) to 
group.

• Alt-drag (Windows) or Option-drag (Mac OS) layers to the folder icon at the bottom of 
the layers palette to group the layers.

3 To Ungroup the layers, choose Layer > Ungroup Layers (or use Ctrl + Shift + G 
(Windows) or Command + Shift + G (Mac OS) to Ungroup.

Duplicating layers
Duplicating layers is an easy way to copy content within an image or between images. 
When duplicating layers between images, keep in mind that the layer’s content will 
appear smaller or larger if it is copied to a file with different resolution. 
(See “Understanding image size and resolution” on page 62.)

To duplicate a layer or layer set within an image:

1 Select a layer or layer set in the Layers palette. 

2 Do one of the following:

• Drag the layer or layer set to the New Layer button .

• Choose Duplicate Layer or Duplicate Layer Set from the Layers menu or the Layers 
palette menu. In Photoshop, enter a name for the layer or layer set, and click OK.

• (Photoshop) Press Alt (Windows) or Option (Mac OS), and drag the layer or layer set to 
the New Layer button or the New Layer Set button. Enter a name for the layer or layer 
set, and click OK.
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To duplicate a layer or layer set between images:

1 Open the source and destination images.

2 In the Layers palette of the source image, select a layer or layer set.

3 Do one of the following:

• Drag the layer or layer set from the Layers palette into the destination image.

• Select the Move tool , and drag from the source image to the destination image. The 
duplicate layer or layer set appears above the active layer in the Layers palette of the 
destination image. Shift-drag to position the image content in the same location it 
occupied in the source image (if the source and destination images have the same pixel 
dimensions) or at the center of the document window (if the source and destination 
images have different pixel dimensions).

• (Photoshop) Choose Duplicate Layer or Duplicate Layer Set from the Layers menu or 
the Layers palette menu. Choose the destination document from the Document 
pop-up menu, and click OK. 

• Choose Select > All to select all of the pixels on the layer, and choose Edit > Copy. Then 
choose Edit > Paste in the destination image. 

To create a new document from a layer or layer set (Photoshop):

1 Select a layer or layer set in the Layers palette.

2 Choose Duplicate Layer or Duplicate Layer Set from the Layers menu or the Layers 
palette menu.

3 Choose New from the document pop-up menu, and click OK.

Changing the stacking order of layers
The stacking order in the Layers palette determines whether the content of a layer or layer 
set appears in front of or behind other elements in the image.

To change the order of layers and layer sets:

Do one of the following:

• Drag the layer or layer set up or down in the Layers palette. Release the mouse button 
when the highlighted line appears where you want to place the layer or layer set. 

• To move a layer into a layer set, drag a layer to the layer set folder . The layer is placed 
at the bottom of the layer set.

Note: If a layer set is expanded so that you can see all the layers within it, adding a layer 
beneath the expanded set automatically adds the layer to that set. To avoid this, collapse 
the layer set before adding the new layer.

• Select a layer or layer set, choose Layer > Arrange, and choose a command from the 
submenu. If the selected item is in a layer set, the command applies to the stacking 
order within the layer set. If the selected item is not in a layer set, the command applies 
to the stacking order within the Layers palette. 
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• (ImageReady) To reverse the order of selected layers, choose Layer > Reverse Layers or 
choose Reverse Layers from the Layers palette menu. Note that these options appear 
dimmed if you do not have at least two layers selected.

Note: By definition, the background layer is always at the bottom of the stacking order. 
Therefore, the Send to Back command places the selected item directly above the 
background layer. (See “About the background layer” on page 371.)

Linking layers
By linking two or more layers or layer sets, you can move their contents together. You can 
also copy, paste, align, merge, apply transformations to, and create clipping masks from 
linked layers. In ImageReady, working with multiple layer selections is more flexible and 
provides all the functionality of linking (see “Selecting layers” on page 374), but linking is 
still an option in order to provide backwards compatibility.

To link layers:

1 Select a layer or layer set in the Layers palette.

2 Click in the column immediately to the left of any layers you want to link to the selected 
layer. A link icon  appears in the column.

To link selected layers: (ImageReady)

Choose Link Layers from the Layers palette menu.

To unlink layers:

In the Layers palette, click the link icons to remove the links.

Aligning layers 
You can align either layers or the contents of layers and layer sets using the Move tool. 
(See “Moving selections and layers within an image” on page 241.) In ImageReady, you 
can align layer groups.

To align the contents of layers:

1 Do one of the following:

• To align the content of a layer to a selection border, make a selection in the image. Then 
select a layer in the Layers palette. 

• To align the contents of multiple layers to a selection border, make a selection in the 
image. Then link the layers you want to align in the Layers palette. (See “Linking layers” 
on page 378.)

• To align the contents of layers to the content of the active layer, link the layers you want 
to align to the active layer. (See “Linking layers” on page 378.)

• To align multiple layers (ImageReady), either select multiple layers with the Move tool 
or select a layer group.
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2 Choose Layer > Align Linked or Layer > Align To Selection (Photoshop) or choose Edit > 
Align Layers (ImageReady), and choose a command from the submenu. These same 
commands are available as Alignment buttons in the Move tool options bar:

• Top Edges   aligns the top pixel on the linked layers to the top pixel on the active layer 
or the top edge of the selection border.

• Vertical Centers   aligns the vertical center pixel on the linked layers to the vertical 
center pixel on the active layer or the vertical center of the selection border.

• Bottom Edges  aligns the bottom pixel on the linked layers to the bottom pixel on the 
active layer or the bottom edge of the selection border.

• Left Edges  aligns the left pixel on the linked layers to the left pixel on the active layer 
or the left edge of the selection border.

• Horizontal Centers  aligns the horizontal center pixel on the linked layers to the 
horizontal center pixel on the active layer or the horizontal center of the selection 
border.

• Right Edges  aligns the right pixel on the linked layers to the right pixel on the active 
layer or the right edge of the selection border.

Distributing layers
You can distribute your layers in your document in a number of different ways. Both 
Photoshop and ImageReady have tools that let you distribute the layers in commonly 
used formations, and you can can customize the distribution as well. For instance, you 
might have layers that you want to align by centers but that might cause some overlap. 
So you can distribute the space between the layers evenly to remedy the problem.

To evenly distribute layers and layer groups:

1 Link three or more layers (Photoshop) or select multiple layers or a layer group with the 
Move tool (ImageReady).

2 Choose Layers > Distribute Linked (Photoshop) or Edit > Distribute Linked Layers 
(ImageReady) from the main menu, or in the options bar, click a Distribution button. Each 
of these buttons works on linked layers in Photoshop, or multiple selected layers or layer 
groups in ImageReady:

• Top edges  spaces the layers evenly starting from the top pixel on each layer.

• Vertical Centers  spaces the layers evenly starting from the vertical center pixel of 
each layer.

• Bottom Edges  spaces the layers evenly starting from the bottom pixel of each layer.

• Left Edges  spaces the layers evenly starting from the left pixel of each layer.

• Horizontal Centers  spaces the layers evenly starting from the horizontal center of 
each layer.
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• Right Edges  spaces the layers evenly starting from the right pixel on each layer.

Layers spaced unevenly (top) and spaced evenly (bottom)

To distribute layers unevenly (ImageReady):

1 Select the Move tool.

2 Select the layers you wish to space.

3 Enter a number in the Distribute Spacing box to the right of the Distribution buttons 
in the options bar. This number equals the number of pixels that will separate the layers. 
You can choose different numbers for different combinations of layers or layer groups to 
create an uneven spacing pattern.

4 Choose one of the Distribute Vertically or Distribute Horizontally buttons to finish the 
distribution process.

Space Between Distributed Layers Box lets you input size of layer separation.

Locking layers
You can fully or partially lock layers to protect their contents. For instance, you might want 
to lock a layer fully when you finish with it. Another layer might have the correct trans-
parency and styles, but you are still deciding on positioning, so you want to leave that 
layer partially locked. When a layer is locked, a lock icon displays to the right of the layer 
name. The lock icon is solid when the layer is fully locked; it is hollow when the layer is 
partially locked. 

To lock all properties of a layer or layer set:

1 Select a layer or layer set.

2 Do one of the following:

• Click the Lock All  option in the Layers palette. 
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• (ImageReady) Choose Layer Options from the Layers palette menu, and select the Lock 
All option.

Note: When a layer in a locked layer set has individual lock options applied to it, the lock 
icon is dimmed .

To partially lock a layer:

1 Select a layer.

2 Click one or more lock options in the Layers palette. (In ImageReady, you can also 
choose Layer Options from the Layers palette menu.) Select one or more lock options:

• Lock Transparency  to confine editing to the opaque portions of the layer. This option 
is equivalent to the Preserve Transparency option in earlier versions of Photoshop.

• Lock Image  to prevent modification of the layer’s pixels using the painting tools.

• Lock Position  to prevent the layer’s pixels from being moved.

Note: For type layers, Lock Transparency and Lock Image are selected by default and 
cannot be deselected.

To apply lock options to all linked layers or all layers in a layer set:

1 Select a linked layer or a layer set.

2 Choose Lock All Linked Layers or Lock All Layers in Set from the Layers menu or the 
Layers palette menu.

3 Select lock options, and click OK.

Unifying layers (ImageReady)
The unify buttons in the Layers palette determine how the changes you make to a 
layer in the active rollover state or animation frame apply to the other states in a rollover 
or frames in an animation. When a unify button is selected, changes apply to all states and 
frames; when a button is deselected, changes apply to only the active state or frame. 
(See “Unifying and matching layer rollovers and animations” on page 509.)

Sampling from layers
The default behavior of the Magic Wand, Smudge, Blur, Sharpen, Paint Bucket, Clone 
Stamp, and Healing Brush tools is to sample color only from pixels on the active layer. 
This means you can smudge or sample in a single layer even when other layers are visible, 
and you can sample from one layer and paint in another one. 

Alternately, you can choose to paint using sampled data from all visible layers. For 
example, you can use the Clone Stamp tool to clone an area containing pixels from all the 
visible layers.

To sample from all visible layers:

1 Select the Magic Wand tool , the Smudge tool , the Blur tool , the Sharpen tool , 
the Paint Bucket tool , the Clone Stamp tool , or the Healing Brush tool .

2 In the options bar, select Use All Layers.

Note: When you are using tools that sample image data, painting or editing in a new layer 
where there are no pixels produces the best results when Use All Layers is selected.
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Managing Layers
After you add layers to an image, you can use the Layers palette to manage them, and in 
ImageReady you can use the File menu to export them. 

Renaming layers
As you add layers to an image, it’s helpful to rename layers based on their content. Using 
descriptive layer names allows you to easily identify layers in the Layers palette.

To rename a layer or layer set:

1 Do one of the following:

• Double-click the layer or layer set’s name in the Layers palette, and enter a new name.

• Press Alt (Windows) or Option (Mac OS), and double-click the layer set’s name in the 
Layers palette. Enter a new name in the Name text box, and click OK.

• (Photoshop) Select a layer or layer set, and choose Layer Properties or Layer Set 
Properties from the Layers menu or the Layers palette menu. Enter a new name in the 
Name text box, and click OK.

• (ImageReady) Select a layer or layer set, and choose Layer Options or Layer Set Options 
from the Layers menu or the Layers palette menu. Enter a new name in the Name text 
box, and click OK.

Color coding layers
Color coding layers and layer sets makes it easier to locate related layers in the Layers 
palette.

To assign a color to a layer or layer set:

1 Do one of the following:

• (Photoshop) Select a layer or layer set, and choose Layer Properties or Layer Set 
Properties from the Layers menu or the Layers palette menu.

• (ImageReady) Select a layer or layer set, and choose Layer Options or Layer Set Options 
from the Layers menu or the Layers palette menu.

• For layer sets, press Alt (Windows) or Option (Mac OS), and double-click the layer set’s 
name in the Layers palette.

2 Choose a color from the Color pop-up menu, and click OK. 

Rasterizing layers
You cannot use the painting tools or filters on layers that contain vector data (such as type 
layers, shape layers, and vector masks) and generated data (such as fill layers). However, 
you can rasterize these layers to convert their contents into a flat, raster image. 

To rasterize a single layer:

1 Select the layer you want to rasterize.

2 Choose Layer > Rasterize, and choose an option from the submenu.
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To rasterize multiple layers:

Do one of the following:

• Link the layers you want to rasterize, and choose Layer > Rasterize > Linked Layers. 
(See “Linking layers” on page 378.)

• To rasterize all layers that contain vector and generated data, choose Layer > Rasterize > 
All Layers.

Deleting layers
Deleting layers that you no longer need reduces the size of your image file.

To delete a layer or layer set:

1 Select a layer or layer set in the Layers palette. In ImageReady you can select multiple 
layers.

2 Do one of the following:

• To delete the layer or layer set with confirmation, click the Trash button. Alternately, 
choose Delete Layer or Delete Layer Set from the Layers menu or the Layers palette 
menu.

• To delete the layer or layer set without confirmation, drag it to the Trash button or 
Alt-click (Windows) or Option-click (Mac OS) the Trash button.

To delete linked layers (Photoshop):

Do one of the following:

• To delete the linked layers with confirmation, choose Delete Linked Layers from the 
Layers menu or the Layers palette menu. Alternately, Ctrl-click (Windows) or Command-
click (Mac OS) the Trash button.

• To delete the linked layers without confirmation, Ctrl-Alt-click (Windows) or Command-
Option-click (Mac OS) the Trash button.

To delete hidden layers (Photoshop):

Choose Delete Hidden Layers from the Layers menu or the Layers palette menu.

Merging and stamping layers
When you have finalized the content of layers, you can merge them to create partial 
versions of your composite image. This helps you manage the size of your image files. 
When you merge layers, the data on the top layers replaces the data it overlaps on the 
lower layers. The intersection of all transparent areas in the merged layers remains 
transparent.
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Before and after merging two layers

Note: You cannot use an adjustment layer or fill layer as the target layer for a merge. 
(See “Merging adjustment layers or fill layers” on page 405.)

In addition to merging layers, you can stamp layers. Stamping allows you to merge the 
contents of more than one layer into a target layer while leaving the other layers intact. 
Typically, the selected layer will stamp down to the layer below it.

Note: When you save a merged document, you cannot revert back to the unmerged state; 
the layers are permanently merged. 

To merge two layers or layer sets:

1 Position the layers or layer sets you want to merge next to each other in the Layers 
palette, and make sure that the visibility for both items is enabled.

2 Select the top item in the pair.

3 Do one of the following:

• If the top item is a layer, choose Merge Down from the Layers menu or the Layers 
palette menu.

• If the top item is a layer set, choose Merge Layer Set from the Layers menu or the Layers 
palette menu.

To merge layers in a clipping mask:

1 Hide any layers you do not want to merge. 

2 Select the base layer in the group.

3 Choose Merge Clipping Mask from the Layers menu or the Layers palette menu.

To merge all visible linked layers:

Choose Merge Linked from the Layers palette or the Layers palette menu.

To merge all the visible layers and layer sets in an image:

Choose Merge Visible from the Layers palette or the Layers palette menu.

To stamp layers:

1 Position the layer you want to stamp to above the layer you want to stamp from, and 
make sure that the visibility for both items is enabled.

2 Select the top item in the pair.
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3 Press Ctrl+Alt+E (Windows) or Command+Option+E (Mac OS). 

The selected layer is stamped with the contents of the other layer.

To stamp linked layers:

Select one of the linked layers, and press Ctrl+Alt+E (Windows) or Command+Option+E 
(Mac OS). The selected layer is stamped with the contents from the other linked layers.

To stamp all visible layers:

Select the layer or layer set that you want to contain the new contents, and press 
Shift+Ctrl+Alt+E (Windows) or Shift+Command+Option+E (Mac OS). 

alternately, you can hold down Alt (Windows) or Option (Mac OS), and choose Layer > 
Merge Visible. The modified Merge command merges all the visible data into the current 
target layer.

Flattening all layers
In a flattened image, all visible layers are merged into the background, which greatly 
reduces the file size. Flattening an image discards all hidden layers and fills the remaining 
transparent areas with white. In most cases, you won’t want to flatten a file until you have 
finished editing the individual layers. 

Note: Converting an image between some color modes flattens the file. Be sure to save a 
copy of your file that includes all layers if you want to edit the original image after the 
conversion.

To flatten an image:

1 Make sure that all the layers you want to keep are visible.

2 Choose Layer > Flatten Image, or choose Flatten Image from the Layers palette menu.

Tracking file size
File size depends on the pixel dimensions of an image and the number of layers contained 
in the image. Images with more pixels may produce more detail when printed, but they 
require more disk space to store and may be slower to edit and print. You should keep 
track of your file sizes to make sure the files are not becoming too large for your purposes. 
If the file is becoming too large, reduce the number of layers in the image or change the 
image size.

You can view file size information for an image at the bottom of the application window 
(Windows) or document window (Mac OS). For more information, see “Displaying file and 
image information” on page 46.

Exporting layers (ImageReady)
In ImageReady, you can export some or all layers of a document as files. You can export 
layers as Photoshop (PSD), GIF, JPEG, PNG 8, PNG 24, WBMP or SWF. See “Exporting layers 
as files (ImageReady)” on page 579.

Setting opacity and blending options
A layer’s opacity and blending options determine how its pixels interact with pixels on 
other layers.
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Setting layer opacity
A layer’s opacity determines to what degree it obscures or reveals the layer beneath it. 
A layer with 1% opacity appears nearly transparent, while one with 100% opacity appears 
completely opaque.

To specify opacity for a layer or layer set:

1 Select a layer or layer set in the Layers palette.

Note: You cannot change the opacity of a background layer or a locked layer. You can, 
however, convert a background layer to a regular layer that does support transparency. 
See “About the background layer” on page 371.

2 Do one of the following:

• In the Layers palette, enter a value in the Opacity text box or drag the Opacity pop-up 
slider. 

• Choose Layer > Layer Style > Blending Options. Enter a value in the Opacity text box or 
drag the Opacity pop-up slider.

• Select the Move tool and type a number on your keyboard for the percentage of 
opacity for the selected layer.

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Add a Layer Style button at the bottom of 
the Layers palette menu.

Choosing a blending mode
A layer’s blending mode determines how its pixels blend with underlying pixels in the 
image. You can create a variety of special effects using blending modes.

By default, the blending mode of a layer set is Pass Through, which means that the layer 
set has no blending properties of its own. When you choose a different blending mode for 
a layer set, you effectively change the order in which the entire image is composited. All of 
the layers in the layer set are composited first. The composited layer set is then treated as a 
single image and blended with the rest of the image using the selected blending mode. 
Thus, if you choose a blending mode other than Pass Through for the layer set, none of the 
adjustment layers or layer blending modes inside the layer set will apply to layers outside 
the set.

For a description of each blending mode, see “Selecting a blending mode” on page 331. 

Note: There is no Clear blending mode for layers. In addition, the Color Dodge, Color Burn, 
Darken, Lighten, Difference, and Exclusion modes are unavailable for Lab images.

To specify a blending mode for a layer or layer set:

1 Select a layer or layer set in the Layers palette.

2 Choose a blending mode:

• In the Layers palette, choose an option from the Blend Mode pop-up menu. 

• Choose Layer > Layer Style > Blending Options, and then choose an option from the 
Blend Mode pop-up menu.



Using Help | Contents | Index Back 387  

Adobe Photoshop CS Help Using Layers 

Using Help | Contents | Index Back 387  

Filling new layers with a neutral color
Some filters (such as the Lighting Effects filter) cannot be applied to layers with no pixels. 
Selecting Fill with Mode-neutral color in the New Layer dialog box resolves this problem 
by first filling the layer with a preset, neutral color. The neutral color is assigned based on 
the layer’s blending mode and is invisible. If no effect is applied, filling with a neutral color 
has no effect on the remaining layers. The Fill with Neutral Color option is not available for 
layers that use the Normal, Dissolve, Hue, Saturation, Color, or Luminosity modes. 

Specifying fill opacity
In addition to setting opacity for a layer, which affects any layer styles and blending modes 
applied to the layer, you can specify a fill opacity for layers. Fill opacity affects pixels 
painted in a layer or shapes drawn on a layer without affecting the opacity of any layer 
effects that have been applied to the layer.

To specify fill opacity for a layer:

Do one of the following:

• (Photoshop) In the Layers palette, enter a value in the Fill Opacity text box or drag the 
Fill Opacity pop-up slider.

• (Photoshop) Double-click a layer thumbnail, choose Layer > Layer Style > Blending 
Options, or choose Add a Layer Style > Blending Options from the Layers palette menu. 
Enter a value in the Fill Opacity text box.

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Add a Layer Style button at the bottom of 
the Layers palette menu. (ImageReady) Choose Layer > Layer Style > Blending Options 
and enter a value in the Fill Opacity text box.

Specifying knockout options
Knockout options let you specify which layers “punch through” to reveal content from 
other layers. For example, you can use a text layer to knock out a color adjustment layer 
and reveal a portion of the image using the original colors.

To create a knockout effect, you need to decide which layer will create the shape of the 
knockout, which layers will be punched through, and which layer will be revealed. If you 
want to reveal a layer other than the Background, you can place the layers you want to use 
in a layer set or clipping mask.

Farm logo with shallow knockout to Field layer
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To create a knockout:

1 Do one of the following in the Layers palette:

• Position the layer that will create the knockout above the layers that will be punched 
through, and make the layer you want to reveal the Background. (Choose Layer > 
New > Background from Layer to convert a regular layer to the Background.)

• Place the layers you want to use in a layer set. The top layer in the set will punch 
through to the bottom layer in the set or the Background. If you want to reveal the 
Background, make sure the blending mode of the layer set is set to Pass Through 
(the default).

• Place the layers you want to use in a clipping mask. The top layer in the group will 
punch through to the bottom layer in the group or the Background. (See “Creating 
clipping masks” on page 413.) If you want to reveal the bottom layer in the group, 
make sure the Blend Clipped Layers as Group option for the bottom layer is selected. 
(See “Grouping blend effects” on page 389.)

2 Select the top layer (the layer that will create the knockout). 

3 Double-click a layer thumbnail (Photoshop), choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Layers palette menu. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Add a Layer Style button at the bottom of 
the Layers palette menu.

4 Choose an option from the Knockout pop-up menu:

• Shallow to knock out to the first possible stopping point such as the bottom of the layer 
set or clipping mask containing the knockout option. 

• Deep to knock out to the Background. If there is no Background, Deep knocks out to 
transparency.

5 Lower the fill opacity or change the blending mode to create the knockout effect. 
(See “Specifying fill opacity” on page 387 and “Choosing a blending mode” on page 386.)

6 Click OK.

Restricting blending to channels (Photoshop)
You can restrict blending effects to a specified channel when blending a layer or layer set. 
By default, all channels are included when blending a layer or layer set. The channel selec-
tions vary based on the type of image you are editing. For example, if you are editing a 
RGB image, the channel choices are R, G, and B. If you are editing a CMYK image, the 
channel choices are C, M, Y, and K. (See “About color channels” on page 155.) When using 
an RGB image, for example, you can choose to exclude the Red channel from blending; 
in the composite image, only information contained in the Green and Blue channels are 
affected. 
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To exclude channels from blending:

1 Double-click a layer thumbnail, and do one of the following:

• Choose Layer > Layer Style > Blending Options, 

• Choose Blending Options from the Add a Layer Style button at the bottom of the Layers 
palette. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Add a Layer Style button at the bottom of 
the Layers palette menu.

2 In the Advanced Blending area of the Layer Style dialog box, deselect any channels you 
do not want to include when the layer is blended. 

Grouping blend effects
By default, layers in a clipping mask are blended with the underlying layers using the 
blending mode of the bottommost layer in the group. However, you can choose to have 
the blending mode of the bottommost layer apply only to that layer, allowing you to 
maintain the original blending appearance of the clipped layers. (See “Creating clipping 
masks” on page 413.)

You can also apply the blending mode of a layer to layer effects that modify opaque pixels, 
such as Inner Glow or Color Overlay, without changing layer effects that modify only trans-
parent pixels, such as Outer Glow or Drop Shadow.

To specify the scope of blending options:

1 Select the layer that you want to affect.

2 Do one of the following:

• Double-click a layer thumbnail, choose Blending Options from the Layers palette menu 
(Photoshop), or choose Layer > Layer Style > Blending Options. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Add a Layer Style button at the bottom of 
the Layers palette menu.

3 Specify the scope of blending options:

• Select Blend Interior Effects as Group to apply the blending mode of the layer to layer 
effects that modify opaque pixels, such as Inner Glow, Satin, Color Overlay, 
and Gradient Overlay.

• Select Blend Clipped Layers as Group to apply the blending mode of the base layer to 
all layers in the clipping mask. Deselecting this option, which is always selected by 
default, maintains the original blending mode and appearance of each layer in the 
group.
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Advanced blending options 
A. Farm Logo and Paint Stroke layers each with its own blending mode B. Blend Interior Effects as 
Group option selected C. Blend Clipped Layers as Group option selected

• Select Transparency Shapes Layers to restrict layer effects and knockouts to opaque 
areas of the layer. Deselecting this option, which is always selected by default, applies 
these effects throughout the layer.

• Select Layer Mask Hides Effects to restrict layer effects to the area defined by the 
layer mask.

• Select Vector Mask Hides Effects to restrict layer effects to the area defined by the 
vector mask.

4 Click OK.

Specifying a range for blending layers (Photoshop)
The sliders in the Blending Options dialog box let you control which pixels from the active 
layer and from the underlying visible layers appear in the final image. For example, you 
can drop dark pixels out of the active layer or force bright pixels from the underlying layers 
to show through. You can also define a range of partially blended pixels to produce a 
smooth transition between blended and unblended areas. 

To define a range for the blending operation: 

1 Double-click a layer thumbnail, choose Layer > Layer Style > Blending Options, or 
choose Add a Layer Style > Blending Options from the Layers palette menu. 

Note: To view blending options for a text layer, choose Layer > Layer Style > Blending 
Options, or choose Blending Options from the Add a Layer Style button at the bottom of 
the Layers palette menu.

A

B C
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2 In the Advanced Blending area of the Layer Style dialog box, choose an option from the 
Blend If pop-up menu. 

• Gray to specify a blending range for all channels. 

• An individual color channel (for example, red, green, or blue in an RGB image) to specify 
blending in that channel. (See “About color channels” on page 155.)

3 Use the This Layer and Underlying Layer sliders to set the brightness range of the 
blended pixels—measured on a scale from 0 (black) to 255 (white). Drag the white slider 
to set the high value of the range. Drag the black slider to set the low value of the range. 

To define a range of partially blended pixels, hold down Alt (Windows) or Option 
(Mac OS), and drag one half of a slider triangle. The two values that appear above the 

divided slider indicate the partial blending range. 

Keep the following guidelines in mind when specifying blending ranges:

• Use the This Layer sliders to specify the range of pixels on the active layer that will 
blend, and therefore appear, in the final image. For example, if you drag the white slider 
to 235, pixels with brightness values higher than 235 will remain unblended and will be 
excluded from the final image. 

• Use the Underlying Layer sliders to specify the range of pixels in the underlying visible 
layers that will blend in the final image. Blended pixels are combined with pixels in the 
active layer to produce composite pixels, while unblended pixels show through 
overlying areas of the active layer. For example, if you drag the black slider to 19, pixels 
with brightness values lower than 19 will remain unblended and will show through the 
active layer in the final image.

Using layer effects and styles
Layer styles let you quickly apply effects to a layer’s content. You can scan through a 
variety of predefined layer styles and apply a style with just a click of the mouse, or you 
can create a custom style by applying multiple effects to a layer.

About layer effects and styles
Photoshop and ImageReady provide a variety of effects—such as shadows, glows, bevels, 
overlays, and strokes—that let you quickly change the appearance of a layer’s contents. 
Layer effects are linked to the layer contents. When you move or edit the contents of the 
layer, the effects are modified correspondingly. For example, if you apply a drop shadow 
effect to a text layer, the shadow will change automatically when you edit the text. 

The effects that you apply to a layer become part of the layer’s custom style. When a layer 
has a style, an “f” icon  appears to the right of the layer’s name in the Layers palette. You 
can expand the style in the Layers palette to view all the effects that compose the style 
and edit the effects to change the style. 
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When you save a custom style, it becomes a preset style. Preset styles appear in the Styles 
palette and can be applied with just a click of the mouse. Photoshop and ImageReady 
provide a variety of preset styles to fill a wide range of uses.

Illustration of a layer without a style

Illustration of a layer with a style

Note: You cannot apply layer effects and styles to a background, a locked layer, or a 
layer set.

Applying preset styles
The Styles palette, Layer Styles dialog box, and Layer Styles pop-up palette in the options 
bar for the Pen and Shape tool let you view and select preset layer styles. By default, 
applying a preset style replaces the current layer style. However, you can add the 
attributes of a second style to those of the current style using a keyboard modifier.

The layer styles that come with Photoshop and ImageReady are grouped into libraries by 
function. For example, one library contains styles for creating Web buttons; another library 
contains styles adding effects to text. 

To display the Styles palette:

Choose Window > Styles.

To apply a preset style to a layer:

Do one of the following:

• Click a style in the Styles palette to apply it to the currently selected layer. 

• Drag a style from the Styles palette onto a layer in the Layers palette.
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• Drag a style from the Styles palette to the document window, and release the mouse 
button when the pointer is over the layer content to which you want to apply the style.

Note: Hold down Shift while clicking or dragging to add the style to (instead of replace) 
any existing effects on the destination layer.

• Choose Layer > Layer Style > Blending Options, and click the word Styles in the Layer 
Styles dialog box (top item in the list on the left side of the dialog box). Click the style 
you want to apply, and click OK.

• When using a Shape or Pen tool in shape layers mode, select a style from the pop-up 
palette in the options bar before drawing the shape. 

To apply a style from an existing layer to another layer:

In the Layers palette, drag the style from a layer’s effect list to another layer.

To create a new layer with the style of an existing layer (ImageReady):

In the Layers palette, drag the layer effects to the New Layer button.

To load a library of preset styles:

1 Click the triangle  in the Styles palette, Layer Style dialog box (Photoshop), or Layer 
Style pop-up palette in the options bar when you have the Pen or Shape tool selected 
(Photoshop). 

2 Do one of the following:

• Choose Load Styles (Photoshop) or Append Styles (ImageReady) to add a library to the 
current list. Then select the library file you want to use, and click Load.

• Choose Replace Styles to replace the current list with a different library. Then select the 
library file you want to use, and click Load.

• Choose a library file (displayed at the bottom of the palette menu). Then click OK to 
replace the current list, or click Append to append the current list.

Note: You can also use the Preset Manager to load and reset style libraries. For more 
information, see “Managing libraries with the Preset Manager (Photoshop)” on page 52.

To return to the default library of preset styles:

1 Click the triangle  in the Styles palette, Layer Styles dialog box, or Layer Styles pop-up 
palette in the options bar (Photoshop). 

2 Choose Reset Styles. You can either replace the current list or append the default library 
to the current list. 

To change how preset styles are displayed:

1 Click the triangle  in the Styles palette, Layer Styles dialog box, or Layer Styles pop-up 
palette in the options bar (Photoshop). 

2 Choose a display option from the palette menu: 

• (Photoshop) Text Only to view the layer styles as a list.

• Small or Large Thumbnail to view the layer styles as thumbnails.

• Small or (Photoshop) Large List to view the layer styles as a list, with a thumbnail of the 
selected layer style displayed.



Using Help | Contents | Index Back 394  

Adobe Photoshop CS Help Using Layers 

Using Help | Contents | Index Back 394  

Creating custom styles
You can create custom styles using one or more of the following effects:

Drop Shadow Adds a shadow that falls behind the contents on the layer. 

Inner Shadow Adds a shadow that falls just inside the edges of the layer’s content, giving 
the layer a recessed appearance.

Outer Glow and Inner Glow Add glows that emanate from the outside or inside edges 
of the layer’s content.

Bevel and Emboss Add various combinations of highlights and shadows to a layer.

Satin Applies shading to the interior of a layer that reacts to the shape of the layer, 
typically creating a satiny finish.

Color, Gradient, and Pattern Overlay Fill the layer’s content with a color, gradient, or 
pattern. 

Stroke Outlines the object on the current layer using color, a gradient, or a pattern. It is 
particularly useful on hard-edged shapes such as type.

To apply a custom style to a layer:

1 Do one of the following:

• Click the Layer Styles button  in the Layers palette and choose an effect from the list. 

• Choose an effect from the Layer > Layer Style submenu.

2 Set effect options in the Layer Style dialog box. (See “Editing styles” on page 395.)

3 To add additional effects to the style, do one of the following:

• Repeat steps 1 and 2.

• Select additional effects in the Layer Style dialog box. Click the check box to the left of 
the effect name to add the effect without selecting it.

Displaying layer styles
When a layer has a style, an “f” icon  appears to the right of the layer’s name in the Layers 
palette. You can show or hide the style’s effects in the image and in the Layers palette.

To hide or show all layer styles in an image:

Choose Layer > Layer Style > Hide All Layer Effects or Show All Layer Effects.

To expand or collapse layer styles in the Layers palette:

Do one of the following:

• Click the triangle  next to the layer styles icon  to expand the list of layer effects 
applied to that layer.

• Click the inverted triangle  to collapse the layer effects.

• To expand or collapse all of the layer styles applied within a layer set, hold down Alt 
(Windows) or Option (Mac OS) and click the triangle or inverted triangle for the set. The 
layer styles applied to all layers within the layer set expand or collapse correspondingly.
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Editing styles
You edit a layer’s style by adjusting its effect settings.

Layer Style dialog box. Click a check box to apply the default settings 
without displaying the effect’s options.

Click an effect name to display the effect’s options. 

To edit a layer style:

1 Do one of the following:

• In the Layers palette, double-click an effect displayed below the layer name. (Click the 
inverted triangle  next to the “f” icon  to display the effects contained in the style.)

• Choose Layer > Layer Style and the effect you want to edit.

2 Set one or more of the following options in the Layer Style dialog box. The available 
options depend on the selected effect:

You can edit multiple effects without closing the Layer Style dialog box. Select an 
effect on the left side of the dialog box to display an effect’s options.

Angle Determines the lighting angle at which the effect is applied to the layer. In 
Photoshop, you can drag in the document window to adjust the angle of a Drop Shadow, 
Inner Shadow, or Satin effect.

Anti-alias Blends the edge pixels of a contour or gloss contour. Most useful on shadows 
with a small size and complicated contour.

Blend Mode Determines how the layer style blends with the underlying layers, which 
may or may not include the active layer. For example, an inner shadow blends with the 
active layer because the effect is drawn on top of that layer, but a drop shadow blends 
only with the layers beneath the active layer. In most cases, the default mode for each 
effect produces the best results. (See “Choosing a blending mode” on page 386.)
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Choke Shrinks the boundaries of the matte of an Inner Shadow or Inner Glow prior to 
blurring.

Color Specifies the color of a shadow, glow, or highlight. You can click the color box and 
choose a color. (See “Using the Adobe Color Picker” on page 164.)

Contour With solid-color glows, Contour allows you to create rings of transparency. 
With gradient-filled glows, Contour allows you to create variations in the repetition of the 
gradient color and opacity. With bevel and emboss, Contour allows you to sculpt the 
ridges, valleys, and bumps that are shaded in the embossing process. With shadows, 
Contour allows you to specify the fade. For more information, see “Modifying layer effects 
with contours” on page 398.

Distance Specifies the offset distance for a shadow or satin effect. In Photoshop, you can 
drag in the document window to adjust the offset distance.

Depth Specifies the depth of a bevel and is a ratio of size. It also specifies the depth of a 
pattern.

Global Angle Turns on global lighting for the effect. Global lighting applies the same 
angle to all effects with the Global Angle option selected, giving the appearance of a 
consistent light source shining on the image. (See “Applying global lighting” on page 398.) 
Deselect Global Angle to assign a local angle to Drop Shadow, Inner Shadow, and Bevel 
effects. 

Gloss Contour Creates a glossy, metal-like appearance and is applied after shading a 
bevel or emboss.

Gradient Specifies the gradient of a layer effect. In Photoshop, click the gradient to 
display the Gradient Editor or click the inverted arrow  and choose a gradient from the 
pop-up palette. In Photoshop, you can edit a gradient or create a new gradient using the 
Gradient Editor. (See “Creating smooth gradient fills” on page 339.) In ImageReady, click 
the inverted arrow  next to the gradient sample and select a gradient from the list, or 
choose a gradient type from the pop-up list. You can edit the color or opacity in the 
Gradient Overlay panel the same way you do in the Gradient Editor. For some effects, you 
can specify additional gradient options. Reverse flips the orientation of the gradient, Align 
With Layer uses the bounding box of the layer to calculate the gradient fill, and Scale 
scales the application of the gradient. You can also use the mouse to move the center of 
the gradient by clicking and dragging in the image window. Style specifies the shape of 
the gradient.

Highlight or Shadow Mode Specifies the blending mode of a bevel or emboss highlight 
or shadow. 

Jitter Varies the application of a gradient’s color and opacity.

Layer Knocks Out Drop Shadow Controls the drop shadow’s visibility in a semitrans-
parent layer.

Noise Specifies the amount of random elements in the opacity of a glow or shadow as 
you enter a value or drag the slider.

Opacity Sets the opacity of the layer effect as you enter a value or drag the slider.
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Pattern Specifies the pattern of a layer effect. In ImageReady, click the inverted arrow  
next to the pattern sample and choose a pattern from the list. In Photoshop, click the 
pop-up palette and choose a pattern. Click the New preset button  to create a new 
preset pattern based on the current settings. Click Snap to Origin to position the origin of 
the pattern with that of the document if Link with Layer is selected, or to position the 
origin with the top left corner of the layer if it is deselected. Select Link with Layer to 
specify that the pattern moves with the layer as it is relocated, and drag the Scale slider or 
enter a value to specify the size of the pattern. You can drag a pattern in the layer to 
position it while in this panel. The position can be reset with the Snap to Origin button. 
There must be at least one pattern loaded for the pattern option to be available. You can 
also load patterns using the Preset Manager.

Position Specifies the position of a stroke effect as Outside, Inside, or Center.

Range Controls which portion or range of the glow is targeted for the contour.

Size Specifies the amount of blur or the size of the shadow. 

Soften Blurs the results of shading before compositing to reduce unwanted artifacts.

Source Specifies the glow source for an inner glow. Choose Center to apply a glow that 
emanates from the center of the layer’s content, or Edge to apply a glow that emanates 
from the inside edges of the layer’s content.

Spread Expands the boundaries of the matte prior to blurring. 

Style Specifies the style of a bevel: Inner Bevel to create a bevel on the inside edges of the 
layer contents, Outer Bevel to create a bevel on the outside edges of the layer contents, 
Emboss to create the effect of embossing the layer contents against the underlying layers, 
Pillow Emboss to create the effect of stamping the edges of the layer contents into the 
underlying layers, or Stroke Emboss to confine the emboss to the boundaries of a stroke 
effect applied to the layer. (Note that the Stroke Emboss effect will not be visible if no 
stroke is applied to the layer.)

Technique For bevel and emboss, Smooth blurs the edges of a matte slightly and is 
useful for all types of mattes, whether their edges are soft or hard. It does not preserve 
detailed features at larger sizes. Chisel Hard uses a distance measurement technique and 
is primarily useful on hard-edged mattes from anti-aliased shapes such as type. It 
preserves detailed features better than the Smooth technique. Chisel Soft uses a modified 
distance measurement technique and, while not as accurate as Chisel Hard, it is more 
useful on a larger range of mattes. It preserves features better than the Smooth technique. 
For glows, Softer applies a blur and is useful on all types of mattes, whether their edges are 
soft or hard. At larger sizes, it does not preserve detailed features. Precise uses a distance 
measurement technique to create a glow and is primarily useful on hard-edged mattes 
from anti-aliased shapes such as type. It preserves features better than the Softer 
technique.

Texture Allows you to specify a pattern used to texture the bevel effect. Scale allows you 
to scale the size of the texture. Link with Layer specifies that the texture moves with the 
layer as it is relocated. Invert inverts the texture. Depth varies the degree and direction 
(up/down) to which the texturing is applied. Snap to Origin controls the snap of the 
pattern’s origin with that of the document if Link with Layer is disabled and with the top 
left corner of the layer if it is selected. You can also drag the texture with the mouse to 
position it while in this panel. 
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Modifying layer effects with contours
You can use contours to shape the appearance of an effect over a given range in the Drop 
Shadow, Inner Shadow, Inner Glow, Outer Glow, Bevel and Emboss, and Satin effects when 
creating custom layer styles. For example, a Linear contour on a Drop Shadow causes the 
opacity to drop off in a linear transition, while a Custom contour can be used to create a 
unique shadow transition. Custom contours created in Photoshop can be used in 
ImageReady.

You can select, reset, delete, or change the preview of contours in the contour pop-up 
palette and Preset Manager. For more information, see “Using pop-up palettes” on 
page 24 and “Managing libraries with the Preset Manager (Photoshop)” on page 52.

Detail of Layer Style dialog box for Drop Shadow effect 
A. Click to display the Contour Editor dialog box. B. Click to display the pop-up palette.

To create a custom contour:

1 Select the Drop Shadow, Inner Shadow, Inner Glow, Outer Glow, Bevel and Emboss, 
Contour, or Satin effect in the Layer Style dialog box. (See “Editing styles” on page 395.)

2 Click the contour thumbnail in the Layer Style dialog box.

3 Click the contour to add points and drag to adjust the contour. Or enter values for Input 
and Output.

4 To create a sharp corner instead of a smooth curve, select a point and click Corner.

5 To save the contour to a file, click Save and name the contour.

6 To store a contour as a preset, choose New.

7 Click OK. New contours are added at the bottom of the pop-up palette. 

To load contours from the Contour Editor dialog box:

Click the contour in the Layer Style dialog box, and in the Contour Editor dialog box, 
choose Load. Go to the folder where the contour library you want to load is located and 
click Open.

To delete a contour in the Contour Editor dialog box:

Click the inverted arrow  next to the currently selected contour to view the pop-up 
palette. Press Alt (Windows) or Option (Mac OS), and click the contour you want to delete.

Applying global lighting
Using global light gives the appearance of a consistent light source shining on the image.

A B
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To set a global lighting angle:

To set a global lighting angle for all layers, do one of the following:

• Choose Layer > Layer Style > Global Light. In the Global Light dialog box, enter a value 
or drag the angle radius to set the Angle and Altitude, and click OK.

• In the Layer Style dialog box for Drop Shadow, Inner Shadow, or Bevel, select Use Global 
Light. For Angle, enter a value or drag the slider, and click OK.

The new lighting angle appears as the default for each layer effect that uses the global 
lighting angle.

Creating and managing preset styles
After you customize a layer style, you can save it as a preset style. Preset styles appear 
in the Styles palette, Layer Styles dialog box, Layer Styles pop-up palette in the options 
bar for the Pen and Shape tool, and Preset Manager. (See “Applying preset styles” on 
page 392.) You can also create libraries of preset styles, rename preset styles, and delete 
preset styles.

To create a new preset style:

1 In the Layers palette, select the layer that contains the style you want to save as a 
preset.

2 Do one of the following:

• Drag the selected layer into the Styles palette or onto the New Item button  in the 
Styles palette.

• Click an empty area of the Styles palette. 

• Press Alt (Windows) or Option (Mac OS) and click the New Item button at the bottom of 
the Styles palette.

• Choose New Style from the Styles palette menu.

• Choose Layer > Layer Style > Blending Options, and click New Style in the Layer Style 
dialog box.

3 Enter a name for the preset style, set style options, and click OK. 

To create a preset style from a single effect, drag the effect from the Layers palette to 
the Styles palette.

To rename a preset style:

Do one of the following:

• Double-click a style in the Styles palette. If the Styles palette is set to display styles as 
thumbnails, enter a new name in the dialog box, and click OK. Otherwise, type a new 
name directly in the Style palette, and press Enter (Windows) or Return (Mac OS).

• Select a style in the Styles area of the Layer Styles dialog box. (See “Applying preset 
styles” on page 392.) Then choose Rename Style from the pop-up menu, enter a new 
name, and click OK.

• (Photoshop) When using a shape or pen tool, select a style from the Layer Style pop-up 
palette in the options bar. Then choose Rename Style from the pop-up palette menu.
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To delete a preset style:

Do one of the following:

• Drag a style to the Trash button  at the bottom of the Styles palette.

• Press Alt (Windows) or Option (Mac OS) and click the layer style in the Styles palette.

• (Photoshop) Select a style in the Styles area of the Layer Styles dialog box. 
(See “Applying preset styles” on page 392.) Then choose Delete Style from the 
pop-up menu.

• (Photoshop) When using a shape or pen tool, select a style from the Layer Style pop-up 
palette in the options bar. Then choose Delete Style from the pop-up palette menu.

To save a set of preset styles as a library:

1 Do one of the following:

• Choose Save Styles from the Styles palette menu.

• Select Styles on the left side of the Layer Styles dialog box. (See “Applying preset styles” 
on page 392.) Then choose Save Styles from the pop-up menu.

• (Photoshop) When using a shape or pen tool, click the layer style thumbnail in the 
options bar. Then choose Save Styles from the pop-up palette menu.

2 Choose a location for the style library, enter a filename, and click Save. 

You can save the library anywhere. However, if you place the library file in the Presets/
Styles folder inside the Photoshop program folder, the library name will appear at the 
bottom of the Styles palette menu when you restart the application.

Note: You can also use the Preset Manager to rename, delete, and save libraries of preset 
styles. For more information, see “Managing libraries with the Preset Manager 
(Photoshop)” on page 52.

Copying and pasting styles 
Copying and pasting styles is an easy way to apply the same effects to multiple layers. 

To copy layer styles between layers:

1 In the Layers palette, select the layer containing the style you want to copy.

2 Choose Layer > Layer Style > Copy Layer Style.

3 Do one of the following:

• To paste into a single layer, select the destination layer in the palette, and choose 
Layer > Layer Style > Paste Layer Style.

• To paste into multiple layers, link the destination layers. (See “Linking layers” on 
page 378.) Then choose Layer > Layer Style > Paste Layer Style to Linked.

The pasted layer style will replace the existing layer style on the destination layer or layers.

To copy layer styles between layers by dragging:

Do one of the following:

• In the Layers palette, drag a single layer effect from one layer to another to duplicate 
the layer effect, or drag the Effects bar from one layer to another to duplicate the layer 
style.
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• Drag one or more layer effects from the Layers palette to the image to apply the 
resulting layer style to the highest layer in the Layers palette that contains pixels at the 
drop point.

Scaling layer effects
A layer style may have been tuned to look best on a target resolution with features of a 
given size. Using Scale Effects allows you to scale the effects contained in the layer style 
without scaling the object to which the layer style is applied.

To scale a layer effect:

1 Select the layer in the Layers palette.

2 Choose Layer > Layer Style > Scale Effects.

3 Enter a percentage or drag the slider.

4 Select Preview to preview the changes in the image.

5 Click OK.

Removing layer effects
You can remove individual effects from a layer style and remove a style from the layer. 

To remove an effect from a style:

1 In the Layers palette, expand the layer style so you can see its effects.

2 Do one of the following:

• Drag the effect to the Trash button.

• (ImageReady) Select the effect, and choose Delete Effect from the Layers palette menu.

To remove a style from a layer:

1 In the Layers palette, select the layer containing the style you want to remove.

2 Do one of the following:

• In the Layers palette, drag the Effects bar to the Trash button.

• Choose Layer > Layer Style > Clear Layer Style.

• Select the layer, and then click the Clear Style button  at the bottom of the Styles 
palette.

• (ImageReady) Select an effect in the Layers palette, and choose Delete All Effects from 
the Layers palette menu.

Converting layer styles to layers
To customize or fine-tune the appearance of layer styles, you can convert the layer styles 
to regular image layers. Once you have converted a layer style to image layers, you can 
enhance the result by painting or applying commands and filters. However, you can no 
longer edit the layer style on the original layer, and the layer style will no longer update as 
you change the original image layer.

Note: The layers produced by this process may not result in artwork that exactly matches 
the version using layer styles. In Photoshop, you may see an alert when you create the new 
layers.
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To convert a layer style to image layers:

1 In the Layers palette, select the layer containing the layer style you want to convert.

2 Choose Layer > Layer Style > Create Layers.

You can now modify and restack the new layers in the same way as regular layers. Some 
effects—for example, Inner Glow—convert to layers within a clipping mask. 

You can also drag a layer style to the New Layer button at the bottom of the Layers palette 
to generate a new layer from an existing style.

Using adjustment layers and fill layers (Photoshop)
Adjustment layers and fill layers add another level of flexibility to working with layers. 
Adjustment layers allow you to experiment with color and apply tonal adjustments to an 
image; fill layers allow you to quickly add color, patterns, and gradient elements to an 
image. If you change your mind about the results, you can go back and edit or remove the 
adjustment or fill at any time.

Original, adjustment layer applied to barn only (which brings out more detail in the barn), and 
adjustment layer applied to entire image (which lightens everything but pixelates the clouds)

About adjustment layers and fill layers
Adjustment layers let you experiment with color and tonal adjustments to an image 
without permanently modifying the pixels in the image. The color and tonal changes 
reside within the adjustment layer, which acts as a veil through which the underlying 
image layers appear. Keep in mind that an adjustment layer affects all the layers below it. 
This means that you can correct multiple layers by making a single adjustment, rather 
than making the adjustment to each layer separately. 

Note: Adjustment layers can be applied and edited only in Photoshop; however, they can 
be viewed in ImageReady. 

Fill layers let you fill a layer with a solid color, a gradient, or a pattern. Unlike adjustment 
layers, fill layers do not affect the layers underneath them. 

Creating adjustment layers or fill layers
Adjustment layers and fill layers have the same opacity and blending mode options as 
image layers and can be rearranged, deleted, hidden, and duplicated in the same manner 
as image layers. By default, adjustment layers and fill layers have layer masks, as indicated 
by the mask icon to the left of the layer thumbnail. If a path is active when you create the 
adjustment or fill layer, a vector mask is created instead of a layer mask. 

To confine the effects of an adjustment layer to a group of layers, create a clipping 
mask consisting of these layers. You can place the adjustment layers in or at the base 

of the clipping mask. The adjustment will be confined to the layers inside the group. 
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(See “Creating clipping masks” on page 413.) Alternately, you can create a layer set, and 
have the set use any blending mode other than Pass Through.

Adjustment and fill layers 
A. Adjustment layer confined to Log home layer only B. Layer thumbnail C. Fill layer affecting all 
layers below it D. Layer mask

To create an adjustment layer or fill layer:

1 Do one of the following:

• Click the New Adjustment Layer button  at the bottom of the Layers palette, and 
choose the layer type you want to create.

• Choose Layer > New Fill Layer, and choose an option from the submenu. Then name the 
layer, set other layer options, and click OK. (See “Setting opacity and blending options” 
on page 385 and “Creating clipping masks” on page 413.)

• Choose Layer > New Adjustment Layer, and choose an option from the submenu. Then 
name the layer, set other layer options, and click OK. (See “Setting opacity and blending 
options” on page 385 and “Creating clipping masks” on page 413.)

Note: To confine the effects of the adjustment layer or fill layer to a selected area, make a 
selection, create a closed path and select it, or select an existing closed path. When you 
use a selection, you create an adjustment layer or fill layer confined by a layer mask. When 
you use a path, you create an adjustment layer or fill layer confined by a vector mask.

2 Choose from the following layer properties, and then click OK. 

Solid Color Specify a color. (See “Using the Adobe Color Picker” on page 164.)

Gradient Click the gradient to display the Gradient Editor, or click the inverted arrow  
and choose a gradient from the pop-up palette. (See “Creating smooth gradient fills” on 
page 339.) Set additional options if desired. Style specifies the shape of the gradient. 
Angle specifies the angle at which the gradient is applied. Scale changes the size of the 
gradient. Reverse flips the orientation of the gradient. Dither reduces banding by applying 
dithering to the gradient. Align with Layer uses the bounding box of the layer to calculate 
the gradient fill. You can use the mouse to move the center of the gradient by clicking and 
dragging in the image window.

A

D
C

B
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Pattern Click the pattern, and choose a pattern from the pop-up palette. Click Scale and 
enter a value or drag the slider to scale the pattern. Click Snap to Origin to position the 
origin of the pattern with that of the document window. (See “Using rulers, columns, 
the Measure tool, guides, and the grid” on page 40.) Select Link with Layer to specify that 
the pattern moves with the fill layer as it is relocated. When Link With Layer is selected, you 
can drag in the image to position the pattern while the Pattern Fill dialog box is open. 

Levels Specify values for the highlights, shadows, and midtones. (See “Using the Levels 
dialog box” on page 185.)

Curves Adjust the intensity values of pixels along a 0–255 scale while keeping up to 15 
other values constant.For more information, see “Using the Curves dialog box 
(Photoshop)” on page 189.

Color Balance Drag a slider toward a color you want to increase in the image; drag a 
slider away from a color you want to decrease in the image. For more information, 
see “Using the Color Balance command (Photoshop)” on page 199.

Brightness/Contrast Specify values for Brightness and Contrast. (See “Using the 
Brightness/Contrast command” on page 215.)

Hue/Saturation Choose which colors to edit, and specify values for Hue, Saturation, 
and Lightness. (See “Using the Hue/Saturation command” on page 200.)

Selective Color Choose the color you want to adjust, and drag the sliders to increase or 
decrease the components in the selected color. For more information, see “Using the 
Selective Color command (Photoshop)” on page 214.

Channel Mixer Modify a color channel. For more information, see “Mixing color channels 
(Photoshop)” on page 212.

Gradient Map Choose a gradient and set gradient options. For more information, 
see “Using the Gradient Map command (Photoshop)” on page 223.

Photo Filter Make color adjustments by simulating the effect of a filter in front of a 
camera lens.

Invert Inverted adjustment layers don’t have options. (See “Using the Invert command” 
on page 222.)

Threshold Specify a threshold level. (See “Using the Threshold command (Photoshop)” 
on page 222.)

Posterize Specify the number of tonal levels for each color channel. (See “Using the 
Posterize command (Photoshop)” on page 223.)

Editing adjustment layers or fill layers
Once you create an adjustment or fill layer, you can easily edit the settings, or dynamically 
replace it with a different adjustment or fill type. You can also edit the mask of an 
adjustment layer or fill layer to control the effect that the layer has on the image. By 
default, all areas of an adjustment or fill layer are “unmasked” and, therefore, are showing. 
(See “Creating and editing layer masks” on page 409.)
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To edit an adjustment or fill layer:

1 Do one of the following:

• Double-click the adjustment or fill layer’s thumbnail in the Layers palette.

• Choose Layer > Layer Content Options.

2 Make the desired adjustments, and click OK.

Note: Inverted adjustment layers do not have editable settings.

To change the content of an adjustment or fill layer:

1 Select the adjustment layer or fill layer that you want to change.

2 Choose Layer > Change Layer Content and select a different fill or adjustment layer 
from the list.

Merging adjustment layers or fill layers
You can merge an adjustment or fill layer several ways: with the layer below it, with the 
layers in its own grouped layer, with the layers it is linked to, and with all other visible 
layers. You cannot, however, use an adjustment layer or fill layer as the target layer for a 
merge. When you merge an adjustment layer or fill layer with the layer below it, the 
adjustments are rasterized and become permanently applied within the merged layer. 
(See “Merging and stamping layers” on page 383.) You can also rasterize a fill layer without 
merging it. (See “Rasterizing layers” on page 382.)

Adjustment layers and fill layers whose masks contain only white values do not add 
significantly to the file size, so it is not necessary to merge these adjustment layers to 
conserve file space.

Working with layer comps
Designers often create multiple compositions or comps of a page layout to show clients. 
Using layer comps, you can create, manage and view multiple versions of a layout in a 
single Photoshop or ImageReady file. Layer comps are fully interchangeable between 
Photoshop and ImageReady.

Note: ImageReady reads only RGB files, so pay special attention to RGBs you get from 
color conversions (from CMYK, Lab, and so on) in Photoshop. This is important in testing 
your layer comps.

About layer comps and the Layer Comps palette
A layer comp is a snapshot of a state of the Layers palette. Layer comps record three types 
of layer options:

• Layer visibility—whether a layer in the Layers palette is showing or hidden

• Layer position in the document

• Layer appearance—whether a layer style is applied to the layer
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You create a comp by making changes to the layers in your document and updating the 
comp in the Layer Comps palette. You view comps by applying them in the document. 
Choose Window > Layer Comps to show the palette.

Layer Comps palette 
A. Apply Layer Comp icon B. Last Document State C. Selected comps
D. Layer Comp Cannot Be Fully Restored icon

Creating a layer comp
To create a layer comp, you work with the Layers palette and the Layer Comp palette.

To create a layer comp:

1 Do one of the following:

• Choose Window > Layer Comps to bring up the Layer Comp palette. Click the Create 
New Layer Comp button  at the bottom of the Layer Comps palette. The new comp 
will be based on the current state of layers in the Layers palette.

• To duplicate a comp, select a comp in the Layer Comps palette and choose Duplicate 
Comp from the Layer Comps palette menu , or drag the comp to the New comps 
button.

2 In the New Layer Comp dialog box, name the comp, add descriptive comments, and 
choose options to apply to layers: Visibility (defaults to On), Position, and Appearance. 
Then click OK. Note that any new comp preserves the options you chose for the previous 
one, so you won’t have to go through all these choices again if you want them to be 
identical.

3 To change your comp options, select Layer Comp Options from the palette menu, or 
double click the layer comp you want to change (Don’t double click the name of the layer 
comp, as that will let you change only the name.) As you make changes, periodically click 
the Update Layer Comp button  at the bottom of the Comps palette (make sure that the 
comp you want to update is selected). 

B
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Viewing layer comps
To view a layer comp, you first need to apply it in the document. In the Layer Comp palette, 
click the Apply Layer Comp icon  next to a selected comp.

To cycle through a view of all the layer comps, use the Previous  and Next  buttons at 
the bottom of the palette.

To cycle through a view of specific selected comps, select the comps in the Layer Comps 
palette and then click the Next and Previous buttons at the bottom of the palette. This will 
cycle only through the comps you have selected.

Applying layer comps
To apply a layer comp, do one of the following:

• In the Layer Comp palette, click the Apply Layer Comp icon  next to a selected comp. 
You can apply the previous and next layer comp by clicking on the backward and 
forward buttons at the bottom of the Layer Comps palette.

• Choose Apply Layer Comp from the Layer Comps palette menu.

Updating layer comps
You can save changes to a layer comp by selecting it in the Layer Comps palette and then 
clicking the Update Layer Comp button  on the bottom of the palette. This rewrites an 
existing layer comp, bringing it up to date. For example, if your current comp has captured 
a certain document configuration (that is, certain layers visible, certain styles applied to 
some of your layers, and certain positions of the layers pixels on the canvas), and later you 
modify some of the parameters, making the original comp layer obsolete, you can simply 
update the existing layer comp to preserve the new configuration.

Restoring layer comps
When you apply any number of layer comps to view how they change your document, 
you have the option of restoring the document to its original state. Do one of the 
following to restore your document:

• Click on the Apply This Layer Comp icon next to the Last Document State.

• With any layer comp selected, choose Restore Last Document State from the palette 
menu.

Validating layer comps
There may be times when one or all of your layer comps get into a state where they can no 
longer be fully restored. This can happen if you delete a layer, merge a layer, convert a layer 
to a background, or use color conversion. In such instances, a caution icon  appears on 
the comp slots that meet one of these conditions. This will happen when the condition 
first occurs, not necessarily when you try to restore the layer comp. You can do one of the 
following:

• Ignore the warning, which may result in the loss of one or more layers. Other saved 
parameters may be preserved.

• Update the comp, which will result in the loss of the previously captured parameters, 
but will bring the comp up to date.
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Click the caution icon to see a message that explains that the layer comp cannot be 
restored properly. Choose Clear to remove the alert icon and leave the remaining layers 
unchanged.

Right-click (Windows) or Control-click (Mac OS) the caution icon to see the popup menu 
that lets you choose either the Clear Layer Comp Warning or the Clear All Layer Comp 
Warnings command.

Deleting layer comps
To delete a layer comp, select the layer comp in the Layer Comps palette and do one of the 
following:

• Click the Trash button in the palette.

• Drag it to the Trash button in the palette

• Choose Delete Layer Comp from the palette menu.

Masking layers
You can use masks to protect sections of layers from being edited and to show or hide 
sections of an image. 

About masking layers
Masks control how different areas within a layer or layer set are hidden and revealed. By 
making changes to the mask, you can apply a variety of special effects to the layer without 
actually affecting the pixels on that layer. You can then apply the mask and make the 
changes permanent or remove the mask without applying the changes. 

There are two types of masks:

• Layer masks are resolution-dependent bitmap images that are created with the 
painting or selection tools.

• (Photoshop) Vector masks are resolution independent and are created with the Pen or 
Shape tools.

In the Layers palette, both the layer and vector masks appear as an additional thumbnail 
to the right of the layer thumbnail. For the layer mask, this thumbnail represents the 
grayscale channel that is created when you add the layer mask. (See “Storing masks in 
alpha channels” on page 254.) The vector mask thumbnail represents a path that clips out 
the contents of the layer.
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Masking layers 
A. Layer mask selected B. Layer mask link icon C. Layer mask thumbnail D. Vector mask 
thumbnail E. Vector mask link icon F. New Layer Mask

Creating and editing layer masks
You can obscure an entire layer or layer set, or just a selected part of it, using a layer mask. 
You can also edit a layer mask to add or subtract from the masked region. A layer mask is a 
grayscale image, so what you paint in black will be hidden, what you paint in white will 
show, and what you paint in gray shades will show in various levels of transparency. 

Background painted with black, description card painted with gray, basket painted with white

To add a mask that shows or hides the entire layer:

1 Choose Select > Deselect to clear any selection borders in the image.

2 In the Layers palette, select the layer or layer set to which to add a mask.

3 Do one of the following:

• To create a mask that reveals the entire layer, click the New Layer Mask  button in the 
Layers palette, or choose Layer > Add Layer Mask > Reveal All.

• To create a mask that hides the entire layer, Alt click (Windows) or Option-click (Mac OS) 
the New Layer Mask button, or choose Layer > Add Layer Mask > Hide All.
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To add a mask that shows or hides a selection:

1 In the Layers palette, select the layer or layer set to which to add a mask.

2 Select the area in the image, and do one of the following:

• Click the New Layer Mask button  in the Layers palette to create a mask that reveals 
the selection.

• Choose Layer > Add Layer Mask > Reveal Selection or Hide Selection.

To duplicate a mask (ImageReady):

You can duplicate a layer mask and apply it to another layer by Alt-dragging (Windows) or 
Option-dragging (Mac OS) it to the target layer.

To edit a layer mask:

1 Click the layer mask thumbnail in the Layers palette to make it active.

2 Select any of the editing or painting tools.

Note: The foreground and background colors default to grayscale values when the mask is 
active. 

3 Do one of the following:

• To subtract from the mask and reveal the layer, paint the mask with white.

• To make the layer partially visible, paint the mask with gray.

• To add to the mask and hide the layer or layer set, paint the mask with black.

To edit the layer instead of the layer mask, select it by clicking its thumbnail in the Layers 
palette. The paintbrush icon  appears to the left of the thumbnail to indicate that you 
are editing the layer.

To paste a copied selection into a layer mask, Alt-click (Windows) or Option-click 
(Mac OS) the layer mask thumbnail in the Layers palette to select and display the mask 

channel. Choose Edit > Paste, drag the selection in the image to produce the desired 
masking effect, and choose Select > Deselect. Click the layer thumbnail in the Layers 
palette to deselect the mask channel.

To select and display the layer mask channel (Photoshop):

Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the layer mask thumbnail to view only the 
grayscale mask. The eye icons in the Layers palette are dimmed because all layers or 
layer sets are hidden. To redisplay the layers, Alt-click or Option-click the layer mask 
thumbnail, or click an eye icon.

• Hold down Alt+Shift (Windows) or Option+Shift (Mac OS), and click the layer mask 
thumbnail to view the mask on top of the layer in a rubylith masking color. Hold down 
Alt+Shift or Option+Shift, and click the thumbnail again to turn off the color display. 

To disable or enable a layer mask:

Do one of the following:

• Shift-click the layer mask thumbnail in the Layers palette.

• Select the layer with the layer mask you want to disable or enable, and choose Layer > 
Disable Layer Mask or Layer > Enable Layer Mask.
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A red X appears over the mask thumbnail in the Layers palette when the mask is disabled, 
and the layer’s content appears without masking effects.

To change the rubylith display for a layer mask (Photoshop):

1 Do one of the following:

• Alt-click (Windows) or Option-click (Mac OS) the layer mask thumbnail to select the 
layer mask channel; then double-click the layer mask thumbnail. 

• Double-click the layer mask channel in the Channels palette.

2 To choose a new mask color, in the Layer Mask Display Options dialog box, click the 
color swatch, and choose a new color.

3 To change the opacity, enter a value between 0% and 100%.

Both the color and opacity settings affect only the appearance of the mask and have no 
effect on how underlying areas are protected. For example, you might want to change 
these settings to make the mask more easily visible against the colors in the image.

4 Click OK.

Creating and editing vector masks 
A vector mask creates a sharp-edged shape on a layer and is useful any time you want to 
add a design element with clean, defined edges. Once you create a layer with a vector 
mask, you can apply one or more layer styles to it, edit them if needed, and instantly have 
a usable button, panel, or other Web design element. 

To add a vector mask that shows or hides the entire layer (Photoshop):

1 In the Layers palette, select the layer to which you want to add a vector mask.

2 Do one of the following:

• To create a vector mask that reveals the entire layer, choose Layer > Add Vector Mask > 
Reveal All.

• To create a vector mask that hides the entire layer, choose Layer > Add Vector Mask > 
Hide All.

To add a vector mask that shows the contents of a shape (Photoshop):

1 In the Layers palette, select the layer to which to add a vector mask.

2 Select a path or use one of the shape or pen tools to draw a work path. For more 
information, see “Creating a work path (Photoshop)” on page 300.

3 Choose Layer > Add Vector Mask > Current Path. 

To edit a vector mask (Photoshop):

Click the vector mask thumbnail in the Layers palette or the thumbnail in the Paths 
palette. Then change the shape using the shape and pen tools.

To remove a vector mask:

Do one of the following in the Layers palette:

• Drag the vector mask thumbnail to the Trash button .

• (Photoshop) Select the layer with the vector mask you want to delete, and choose 
Layer > Delete Vector Mask.



Using Help | Contents | Index Back 412  

Adobe Photoshop CS Help Using Layers 

Using Help | Contents | Index Back 412  

To disable or enable a vector mask:

Do one of the following:

• Shift-click the vector mask thumbnail in the Layers palette.

• (Photoshop) Select the layer with the vector mask you want to disable or enable, and 
choose Layer > Disable Vector Mask or Layer > Enable Vector Mask.

A red X appears over the mask thumbnail in the Layers palette when the mask is disabled, 
and the layer’s content appears without masking effects.

To convert a vector mask to a layer mask (Photoshop):

Select the layer with the vector mask you want to convert, and choose Layer > Rasterize > 
Vector Mask.

Important: Once you rasterize a vector mask, it cannot be changed back into a 
vector object. 

Unlinking layers and masks
By default, a layer or layer set is linked to its layer mask or vector mask, as indicated by the 
link icon between the thumbnails in the Layers palette. The layer and its mask move 
together in the image when you move either one with the Move tool. Unlinking them lets 
you move them independently and shift the mask’s boundaries separately from the layer. 

To unlink a layer from its mask:

Click the link icon in the Layers palette. 

To reestablish the link between a layer and its mask:

Click between the layer and mask path thumbnails in the Layers palette.

Applying and discarding layer masks
When you have finished creating a layer mask, you can either apply the mask and make 
the changes permanent or discard the mask without applying changes. Because layer 
masks are stored as alpha channels, applying and discarding layer masks can help reduce 
file size. (See “Storing masks in alpha channels” on page 254.)

To apply or discard a layer mask:

1 Click the layer mask thumbnail in the Layers palette.

2 To remove the layer mask and make changes permanent, click the Trash button  at the 
bottom of the Layers palette, and then click Apply (Photoshop) or Yes (ImageReady). 

3 To remove the layer mask without applying the changes, click the Trash button at the 
bottom of the Layers palette, and then click Discard (Photoshop) or No (ImageReady).

You can also apply or discard layer masks using the Layer menu.

Selecting opaque areas on a layer
By loading a layer mask, you can quickly select all the opaque areas on a layer—that is, the 
areas within the layer boundaries. This is useful when you want to exclude transparent 
areas from a selection. You can also load the boundaries of a layer mask as a selection. 
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To load a layer or layer mask’s boundaries as a selection:

Do one of the following:

• In the Layers palette, Ctrl-click (Windows) or Command-click (Mac OS) the layer or layer 
mask thumbnail.

• To add the pixels to an existing selection, press Ctrl+Shift (Windows) or 
Command+Shift (Mac OS), and click the layer or layer mask thumbnail in the Layers 
palette.

• To subtract the pixels from an existing selection, press Ctrl+Alt (Windows) or 
Command+Option (Mac OS), and click the layer or layer mask thumbnail in the Layers 
palette.

• To load the intersection of the pixels and an existing selection, press Ctrl+Alt+Shift 
(Windows) or Command+Option+Shift (Mac OS), and click the layer or layer mask 
thumbnail in the Layers palette.

If you want to move all the contents of a layer, use the Move tool without loading a 
transparency mask.

Creating clipping masks
You can use the content of a layer to mask the layers above it. The transparent pixels of the 
bottom or base layer mask out the content of layers above it that are part of a clipping 
mask. For example, you might have a shape on one layer, a texture on the overlying layer, 
and some text on the topmost layer. If you define all three layers as part of a clipping mask, 
the texture and the text appear only through the shape on the base layer, and take on the 
opacity of the base layer. 

Note that only successive layers can be included in a clipping mask. The name of the base 
layer in the mask is underlined, and the thumbnails for the overlying layers are indented. 
Additionally, the overlying layers display a clipping mask icon . The Blend Clipped Layers 
as Group option in the Layer Style dialog box determines whether the blending mode of 
the base affects the whole group or just the base. (See “Grouping blend effects” on 
page 389.)

Clipping mask with Potatoes and Logo layers
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To create a clipping mask:

Do one of the following:

• Hold down Alt (Windows) or Option (Mac OS), position the pointer over the line 
dividing two layers in the Layers palette (the pointer changes to two overlapping 
circles ), and click.

• Select a layer in the Layers palette, and choose Layer > Create Clipping Mask.

• Link the desired layers in the Layers palette. (See “Linking layers” on page 378.) 
Then choose Layer > Create Clipping Mask from Linked.

The clipping mask is assigned the opacity and mode attributes of the bottommost layer in 
the group. 

To duplicate a clipping mask to another layer

1 Select the clipping mask.

2 Alt-click (Windows) or Option-click (Mac OS) the mask and drag it to the destination 
layer. Make sure the destination layer highlights before letting go of the mouse button; 
otherwise, the layer won’t receive the mask properly.

To remove a layer from a clipping mask:

Do one of the following:

• Hold down Alt (Windows) or Option (Mac OS), position the pointer over the line 
separating two grouped layers in the Layers palette (the pointer changes to two 
overlapping circles ), and click.

• In the Layers palette, select a layer in the clipping mask, and choose Layer > Release 
Clipping Mask. This command removes the selected layer and any layers above it from 
the clipping mask.

To ungroup all layers in a clipping mask:

1 In the Layers palette, select the base layer in the clipping mask.

2 Choose Layer > Release Clipping Mask.
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Applying Filters for Special 
Effects

Using filters
To use a filter, choose the appropriate submenu command from the Filter menu. These 
guidelines can help you in choosing filters:

• Filters are applied to the active, visible layer or a selection.

• Most filters can be applied cumulatively using the Filter Gallery. All filters can be applied 
individually.

• Filters cannot be applied to Bitmap-mode or indexed-color images.

• Some filters work only on RGB images.

• All filters can be applied to 8-bit images. Only the following filters can be applied to 
16-bit images: Blur, Average Blur, Blur More, Gaussian Blur, Motion Blur, Noise, Add 
Noise, Despeckle, Dust & Scratches, Median, Sharpen, Sharpen Edges, Sharpen More, 
Unsharp Mask, Stylize, Emboss, Find Edges, and Solarize.

• Some filters are processed entirely in RAM. If all your available RAM is used to process a 
filter effect, you may get an error message (see “Improving filter performance” on 
page 436).

Using the Filter Gallery
Using the Filter Gallery, you can apply filters cumulatively, and apply individual filters more 
than once. You can also rearrange filters and change the settings of each filter you’ve 
applied to achieve the effect you want.

Note that not all available filters can be applied using the Filter Gallery. To learn how to 
apply these filters, see “Applying filters individually” on page 417.

Displaying the Filter Gallery Choose Filter > Filter Gallery.

Displaying filter thumbnails Click a filter category name to display previews of available 
filter effects.
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Changing the display of the filter preview You can do any of the following to change 
the display of the filter preview area:

• Use the + or – button under the preview area to zoom in or zoom out of the image.

• Click the zoom bar (where the zoom percentage appears) to choose a zoom 
percentage.

• Click the Show/Hide button   at the top of the dialog box to hide the filters 
thumbnails. Hiding the thumbnails expands the preview area.

• Drag in the preview area with the Hand tool to see a different area of the image.

Filter Gallery dialog box 
A. Preview B. Thumbnail of selected filter C. Show/Hide filter thumbnails D. Filters pop-up menu  
E. Options for selected filter F. List of filter effects to apply or arrange G. Filter effect selected but 
not applied H. Filter effects applied cumulatively but not selected I. Hidden filter effect

Applying and arranging filter effects Filter effects are applied in the order you select 
them. You can rearrange filters once you apply them by dragging a filter name to another 
position in the list of applied filters. Rearranging filter effects can dramatically change the 
way your image looks. Click the eye icon  next to a filter to hide the effect in the preview 
image. You can also delete applied filters by selecting the filter and clicking the Delete 
Effect Layer button .

Applying filters using the Filter Gallery dialog box
Because you can apply more than one filter to an image when you use the Filter Gallery 
dialog box, you have a lot of control over the way your image is affected by each filter.

To save time when trying various filters, experiment by selecting a small, represen-
tative part of your image. 
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Applying filters using the Filter Gallery 
A. Original image B. Images each with a single filter applied C. Three filters applied cumulatively

To apply filters:

1 Do one of the following:

• To apply a filter to an entire layer, make sure that the layer is active or selected.

• To apply a filter to an area of a layer, select that area. 

2 Choose Filter > Filter Gallery.

3 To apply a filter, click the filter’s name. You may need to click the inverted triangle next 
to the filter’s category to see a list of the filters.

4 Enter values or select options for the filter you’ve selected. 

5 Do any of the following:

• Choose additional filters to apply.

• Rearrange applied filters.

• Remove applied filters.

6 When you’re satisfied, click the OK button.

Applying filters individually
Applying filters—especially to large images—can be time-consuming. Some filters let you 
preview the effect before applying it. You can then choose to apply the filter or cancel the 
operation without wasting time.
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If the dialog box contains a preview window, use the following methods to preview the 
effect:

• If the dialog box contains sliders, hold down Alt (Windows) or Option (Mac OS) while 
dragging a slider to see a real-time preview (real-time rendering) of the effect.

• Drag in the preview window to center a specific area of the image in the window. 

• Use the + or – button under the preview window to zoom in or zoom out on the 
preview

• Click in the image window to center a specific area of the image in the preview window. 
(This may not work with all preview windows.)

Some individual filters use dialog boxes to help you customize the filter effect. These filter 
names are followed by ellipses (…) so you can identify them.

To apply a filter:

1 Do one of the following:

• To apply a filter to an entire layer, make sure that the layer is active or selected.

• To apply a filter to an area of a layer, select that area. 

2 Choose a filter from the submenus in the Filter menu. 

If no dialog box appears, the filter effect is applied. 

3 If a dialog box appears, enter values or select options, and then click the OK button.

Blending filter effects (Photoshop)
The Fade command changes the opacity and blending mode of any filter, painting tool, 
erasing tool, or color adjustment. The Fade command blending modes are a subset of 
those in the painting and editing tools options (excluding the Behind and Clear modes).

Applying the Fade command is similar to applying the filter effect on a separate layer and 
then using the layer opacity and blending mode controls. (See “Using adjustment layers 
and fill layers (Photoshop)” on page 402.)

Note: The Fade command can also modify the effects of using the Extract command, 
Liquify command, and Brush Strokes filters.

To fade the effect of a filter, painting tool, or color adjustment:

1 Apply a filter, painting tool, or color adjustment to an image or selection.

2 Choose Edit > Fade. Select the Preview option to preview the effect.

3 Drag the slider to adjust the opacity, from 0% (transparent) to 100%. (See “Specifying 
opacity, flow, strength, or exposure” on page 334.)

4 Choose a blending mode from the Mode menu (see “Selecting a blending mode” on 
page 331).

5 Click OK.

Note: The Color Dodge, Color Burn, Lighten, Darken, Difference, and Exclusion blending 
modes do not work on Lab images.
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Defining undistorted areas
The Displace, Shear, and Wave filters in the Distort submenu and the Offset filter in the 
Other submenu let you treat areas undefined (or unprotected) by the filter in the 
following ways:

• Wrap Around fills the undefined space with content from the opposite edge of the 
image.

• Repeat Edge Pixels extends the colors of pixels along the image’s edge in the direction 
specified. Banding may result if the edge pixels are different colors.

• Set to Background (Offset filter only) fills the selected area with the current background 
color.

Using texture and glass surface controls
The Conté Crayon, Glass, Rough Pastels, Texturizer, and Underpainting filters have textur-
izing options. These options make images appear as if they were painted onto textures 
such as canvas and brick or viewed through glass blocks.

To use texture and glass surface controls:

1 From the Filter menu, choose Artistic > Rough Pastels, Artistic > Underpainting, 
Distort > Glass, Sketch > Conté Crayon, or Texture > Texturizer.

2 For Texture, choose a texture type or choose Load Texture to specify a Photoshop file.

3 Drag the Scaling slider to enlarge or reduce the effect on the image surface. 

4 Drag the Relief slider (if available) to adjust the depth of the texture’s surface.

5 Select Invert to reverse the surface’s light and dark colors.

6 For Light Direction, indicate the direction of the light source on the image.

Tips for creating special effects
Try the following techniques to create special effects with filters.

Create edge effects You can use various techniques to treat the edges of an effect 
applied to only part of an image. To leave a distinct edge, simply apply the filter. For a soft 
edge, feather the edge, and then apply the filter. For a transparent effect, apply the filter, 
and then use the Fade command to adjust the selection’s blending mode and opacity. 
(See “Blending filter effects (Photoshop)” on page 418.)

Apply filters to layers You can apply filters to individual layers or to several layers in 
succession to build up an effect. For a filter to affect a layer, the layer must be visible and 
must contain pixels—for example, a neutral fill color. (See “Filling new layers with a neutral 
color” on page 387.)

Apply filters to individual channels You can apply a filter to an individual channel, 
apply a different effect to each color channel, or apply the same filter but with different 
settings.

Create backgrounds By applying effects to solid-color or grayscale shapes, you can 
generate a variety of backgrounds and textures. You might then blur these textures. 
Although some filters have little or no visible effect when applied to solid colors 
(for example, Glass), others produce interesting effects. 
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Combine multiple effects with masks or with duplicate images Using masks to create 
selection areas gives you more control over transitions from one effect to another. For 
example, you can filter the selection created with a mask. 

You can also use the History Brush tool to paint a filter effect onto part of the image. First, 
apply the filter to an entire image. Next, step back in the History palette to the image state 
before the filter was applied, and set the history brush source to the filtered state. Then, 
paint the image. (See “About the History palette” on page 34.)

Improve image quality and consistency You can disguise faults, alter or enhance 
images, or make a series of images look related by applying the same effect to each. Use 
the Actions palette to record the process of modifying one image, and then use this action 
on the other images. (See “Using the Actions palette” on page 627.)

Choosing a filter effect
The built-in filters are grouped into 14 submenus. In addition, any third-party filters 
installed appear at the bottom of the Filter menu. 

Artistic filters
Choose a filter from the Artistic submenu to achieve a painterly or special effect for a fine 
arts or commercial project. For example, use the Cutout filter for collages or type 
treatment. These filters replicate natural or traditional media effects. All of the Artistic 
filters can be applied using the Filter Gallery (see “Using the Filter Gallery” on page 415).

Colored Pencil Draws an image using colored pencils on a solid background. Important 
edges are retained and given a rough crosshatch appearance; the solid background color 
shows through the smoother areas.

For a parchment effect, change the background color just before applying the Colored 
Pencil filter to a selected area.

Cutout Portrays an image as though it were made from roughly cut-out pieces of colored 
paper. High-contrast images appear as if in silhouette, while colored images are built up 
from several layers of colored paper.

Dry Brush Paints the edges of the image using a dry brush technique (between oil and 
watercolor). The filter simplifies an image by reducing its range of colors to areas of 
common color.

Film Grain Applies an even pattern to the shadow tones and midtones of an image. 
A smoother, more saturated pattern is added to the image’s lighter areas. This filter is 
useful for eliminating banding in blends and visually unifying elements from various 
sources.

Fresco Paints an image in a coarse style using short, rounded, and hastily applied dabs.

Neon Glow Adds various types of glows to the objects in an image and is useful for 
colorizing an image while softening its look. To select a glow color, click the glow box and 
select a color from the color picker.

Paint Daubs Lets you choose from various brush sizes (from 1 to 50) and types for a 
painterly effect. Brush types include simple, light rough, light dark, wide sharp, wide 
blurry, and sparkle.
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Palette Knife Reduces detail in an image to give the effect of a thinly painted canvas that 
reveals the texture underneath.

Plastic Wrap Coats the image in shiny plastic, accentuating the surface detail.

Poster Edges Reduces the number of colors in an image (posterizes) according to the 
posterization option you set, and finds the edges of the image and draws black lines on 
them. Large broad areas of the image have simple shading, while fine dark detail is 
distributed throughout the image.

Rough Pastels Makes an image appear as if stroked with colored pastel chalk on a 
textured background. In areas of bright color, the chalk appears thick with little texture; 
in darker areas, the chalk appears scraped off to reveal the texture. For more on the filter 
options, see “Using texture and glass surface controls” on page 419.

Smudge Stick Softens an image using short diagonal strokes to smudge or smear the 
darker areas of the images. Lighter areas become brighter and lose detail.

Sponge Creates images with highly textured areas of contrasting color, appearing to 
have been painted with a sponge.

Underpainting Paints the image on a textured background, and then paints the final 
image over it. For more on the filter options, see “Using texture and glass surface controls” 
on page 419.

Watercolor Paints the image in a watercolor style, simplifying details in an image, using a 
medium brush loaded with water and color. Where significant tonal changes occur at 
edges, the filter saturates the color.

Blur filters
The blur filters soften a selection or an entire image, and are useful for retouching. They 
smooth transitions by averaging the pixels next to the hard edges of defined lines and 
shaded areas in an image.

Before (left) and after (right) using the Lens Blur filter; the background is blurred but 
foreground stays sharp

Note: To apply a Blur filter to the edges of a layer, be sure to deselect the Preserve 
Transparency option in the Layers palette.

Average Finds the average color of an image or selection, and then fills the image or 
selection with the color to create a smooth look. For example, if you select an area of grass, 
the filter will change the area into a smooth patch of green.
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Blur and Blur More Eliminate noise where significant color transitions occur in an image. 
Blur filters smooth transitions by averaging the pixels next to the hard edges of defined 
lines and shaded areas. The Blur More filter produces an effect three or four times stronger 
than that of the Blur filter.

Gaussian Blur Quickly blurs a selection by an adjustable amount. Gaussian refers to the 
bell-shaped curve that is generated when Photoshop applies a weighted average to the 
pixels. The Gaussian Blur filter adds low-frequency detail and can produce a hazy effect.

Lens Blur (Photoshop) Adds blur to an image to give the effect of a narrower depth of 
field so that some objects in the image stay in focus while others areas become blurred. 
A simple selection can be used to determine which areas become blurred, or you can 
provide a separate alpha channel depth map to describe exactly how you want the blur 
added. 

The Lens Blur filter uses a depth map to determine the position of pixels in an image. You 
can use alpha channels and layer masks to create depth maps; black areas in an alpha 
channel are treated as though they’re at the front of the photo, and white areas are treated 
as if they’re far in the distance.

To create a gradual blurring (none at the bottom to maximum at the top), create a new 
alpha channel and apply a gradient so the channel is white at the top of the image and 

black at the bottom. Then start the Lens Blur filter and choose the alpha channel from the 
Source pop-up menu. To change the direction of the gradient, check the Invert check box.

The way the blur appears depends on the Iris shape you choose. Iris shapes are deter-
mined by the number of blades they contain. You can change blades of an iris by curving 
(making them more circular) or rotating them. You can also magnify or reduce the view of 
the preview by clicking on the minus button  or the plus button .

To use the Lens Blur filter:

1 Choose Filter > Blur > Lens Blur.

2 For Preview, Choose Faster to generate quicker previews. Choose More Accurate to 
view the final version of the image. More Accurate previews take longer to update.

3 For Depth Map, choose a source (if you have one) from the Source pop-up menu. 
Drag the Blur Focal Distance slider to set the depth at which pixels are in focus. For 
example, if your focal distance is set at 100, pixels at 1 and at 255 are completely blurred, 
and pixels closer to 100 are blurred less. If you click the preview image, the Blur Focal 
Distance slider matches the location you clicked, setting that depth as in-focus.

4 Select Invert if you want to invert the selection or alpha channel you’re using as the 
depth map source.

5 Choose an Iris from the Shape pop-up menu. If you’d like, drag the Blade Curvature 
slider to smooth out the edges of the iris. Drag the Rotation slider to rotate the iris. To add 
more blur, drag the Radius slider.

6 For Specular Highlight, drag the Threshold slider to select a brightness cutoff so that all 
the pixels that are brighter than that value are treated as specular highlights. To increase 
the brightness of the highlights, drag the Brightness slider.
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7 To add noise to an image, choose Uniform or Gaussian. To add noise without affecting 
the color in your image, choose Monochromatic. Drag the Amount slider to add or remove 
noise.

Film grain and noise are removed from the original image when you blur it. To make 
the image look more realistic, you may want to add noise back to the image so the 

photo doesn’t look retouched.

8 Click the OK button to make the changes to your image.

Motion Blur Blurs in a particular direction (from –360º to +360º) and at a specific 
intensity (from 1 to 999). The filter’s effect is analogous to taking a picture of a moving 
object with a fixed exposure time.

Radial Blur Simulates the blur of a zooming or rotating camera to produce a soft blur. 
Choose Spin, to blur along concentric circular lines, and then specify a degree of rotation; 
or Zoom, to blur along radial lines, as if zooming in or out of the image, and specify an 
amount from 1 to 100. Blur quality ranges from Draft (for the fastest but grainy results) or 
Good and Best for smoother results, which are indistinguishable from each other except 
on a large selection. Specify the origin of the blur by dragging the pattern in the Blur 
Center box.

Smart Blur Precisely blurs an image. You can specify a radius, to determine how far the 
filter searches for dissimilar pixels to blur; a threshold, to determine how different the 
pixels’ values should be before they are eliminated; and a blur quality. You also can set a 
mode for the entire selection (Normal) or for the edges of color transitions (Edge Only and 
Overlay). Where significant contrast occurs, Edge Only applies black-and-white edges, and 
Overlay Edge applies white.

Brush Stroke filters
Like the Artistic filters, the Brush Stroke filters give a painterly or fine-arts look using 
different brush and ink stroke effects. Some of the filters add grain, paint, noise, edge 
detail, or texture to an image for a pointillist effect. All of the Brush Stroke filters can be 
applied using the Filter Gallery (see “Applying filters using the Filter Gallery dialog box” on 
page 416).

Accented Edges Accentuates the edges of an image. When the edge brightness control 
is set to a high value, the accents resemble white chalk; when set to a low value, the 
accents resemble black ink.

Angled Strokes Repaints an image using diagonal strokes. The lighter areas of the image 
are painted in strokes going in one direction, while the darker areas are painted in strokes 
going the opposite direction.

Crosshatch Preserves the details and features of the original image while adding texture 
and roughening the edges of the colored areas in the image with simulated pencil 
hatching. The Strength option controls the number of hatching passes, from 1 to 3.

Dark Strokes Paints dark areas of an image closer to black with short, tight strokes, and 
paints lighter areas of the image with long, white strokes.

Ink Outlines Redraws an image with fine narrow lines over the original details, in pen-
and-ink style.

Spatter Replicates the effect of a spatter airbrush. Increasing the options simplifies the 
overall effect.
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Sprayed Strokes Repaints an image, using its dominant colors with angled, sprayed 
strokes of color.

Sumi-e Paints an image in Japanese style, as if with a wet brush full of black ink on rice 
paper. The effect is soft blurry edges with rich blacks.

Distort filters
The Distort filters geometrically distort an image, creating 3D or other reshaping effects. 
Note that these filters can be very memory intensive. The Diffuse Glow, Glass, and Ocean 
Ripple filters can be applied using the Filter Gallery (see “Applying filters using the Filter 
Gallery dialog box” on page 416).

Diffuse Glow Renders an image as though it were viewed through a soft diffusion filter. 
The filter adds see-through white noise to an image, with the glow fading from the center 
of a selection.

Displace filter Uses an image, called a displacement map, to determine how to distort a 
selection. For example, using a parabola-shaped displacement map, you can create an 
image that appears to be printed on a cloth held at its corners.

This filter creates displacement maps, using a flattened file saved in Adobe Photoshop 
format (except Bitmap mode images). You can also use the files in the Plug-Ins/ 
Displacement Maps folder in the Photoshop program folder. 

To use the Displace filter:

1 Choose Filter > Distort > Displace.

2 Enter the scale for the magnitude of the displacement.

When the horizontal and vertical scale are set to 100%, the greatest displacement is 
128 pixels (because middle gray produces no displacement).

3 If the displacement map is not the same size as the selection, choose how the map will 
fit the image—Stretch to Fit to resize the map, or Tile to fill the selection by repeating the 
map in a pattern.

4 Choose Wrap Around or Repeat Edge Pixels to determine how undistorted areas of the 
image will be treated. (See “Defining undistorted areas” on page 419.)

5 Click OK.

6 Select and open the displacement map. The distortion is applied to the image.

The Displace filter shifts a selection using a color value from the displacement map—
0 is the maximum negative shift, 255 the maximum positive shift, and a gray value of 128 
produces no displacement. If a map has one channel, the image shifts along a diagonal 
defined by the horizontal and vertical scale ratios. If the map has more than one channel, 
the first channel controls the horizontal displacement and the second channel controls 
the vertical displacement.

Glass Makes an image appear as if it is being viewed through different types of glass.You 
can choose a glass effect or create your own glass surface as a Photoshop file and apply it. 
You can adjust scaling, distortion, and smoothness settings. When using surface controls 
with a file, follow the instructions for the Displace filter. For more information about Glass 
filter controls, see “Using texture and glass surface controls” on page 419.

Ocean Ripple Adds randomly spaced ripples to the image’s surface, making the image 
look as if it were under water.
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Pinch Squeezes a selection. A positive value up to 100% shifts a selection toward its 
center; a negative value up to –100% shifts a selection outward.

Polar Coordinates Converts a selection from its rectangular to polar coordinates, and 
vice versa, according to a selected option. You can use this filter to create a cylinder 
anamorphosis—art popular in the 18th century—in which the distorted image appears 
normal when viewed in a mirrored cylinder.

Ripple Creates an undulating pattern on a selection, like ripples on the surface of a pond. 
For greater control, use the Wave filter. Options include the amount and size of ripples.

Shear Distorts an image along a curve. Specify the curve by dragging the line in the box 
to form a curve for the distortion. You can adjust any point along the curve. Click Default 
to return the curve to a straight line. In addition, you choose how to treat undistorted 
areas. (See “Defining undistorted areas” on page 419.)

Spherize Gives objects a 3D effect by wrapping a selection around a spherical shape, 
distorting the image, and stretching it to fit the selected curve.

Twirl Rotates a selection more sharply in the center than at the edges. Specifying an 
angle produces a twirl pattern.

Wave Works in a similar way to the Ripple filter, but with greater control. Options include 
the number of wave generators, the wavelength (distance from one wave crest to the 
next), the height of the wave, and the wave type: Sine (rolling), Triangle, or Square. The 
Randomize option applies random values. You can also define undistorted areas. (See 
“Defining undistorted areas” on page 419.)

To replicate wave results on other selections, click Randomize, set the Number of 
Generators to 1, and set the minimum and maximum Wavelength and Amplitude 

parameters to the same value.

ZigZag Distorts a selection radially, depending on the radius of the pixels in your 
selection. The Ridges option sets the number of direction reversals of the zigzag from the 
center of the selection to its edge. You also choose how to displace the pixels: Pond 
Ripples displaces pixels to the upper left or lower right, Out From Center displaces pixels 
toward or away from the center of the selection, and Around Center rotates pixels around 
the center.

Noise filters (Photoshop)
The Noise filters add or remove noise, or pixels with randomly distributed color levels. This 
helps to blend a selection into the surrounding pixels. Noise filters can create unusual 
textures or remove problem areas, such as dust and scratches, from an image. 

Add Noise Applies random pixels to an image, simulating the effect of shooting pictures 
on high-speed film. The Add Noise filter can also be used to reduce banding in feathered 
selections or graduated fills or to give a more realistic look to heavily retouched areas. 
Options include noise distribution: Uniform distributes color values of noise using random 
numbers between 0 and plus or minus the specified value for a subtle effect and Gaussian 
distributes color values of noise along a bell-shaped curve for a speckled effect. The 
Monochromatic option applies the filter to only the tonal elements in the image without 
changing the colors.
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Despeckle Detects the edges in an image (areas where significant color changes occur) 
and blurs all of the selection except those edges. This blurring removes noise while 
preserving detail.

Dust & Scratches Reduces noise by changing dissimilar pixels. To achieve a balance 
between sharpening the image and hiding defects, try various combinations of radius and 
threshold settings. Or apply the filter on selected areas in the image.

To use the Dust & Scratches filter:

1 Choose Filter > Noise > Dust & Scratches.

2 If necessary, adjust the preview zoom ratio until the area containing noise is visible. 

3 Drag the Threshold slider left to 0 to turn off the value, so that all pixels in the selection 
or image can be examined. 

The Threshold determines how different the pixels’ values should be before they are 
eliminated. 

Note: The Threshold slider gives greater control for values between 0 and 128—the most 
common range for images—than for values between 128 and 255.

4 Drag the Radius slider left or right, or enter a value in the text box from 1 to 16 pixels. 
The radius determines how far the filter searches for differences among pixels. 

Adjusting the radius makes the image blurry. Stop at the smallest value that eliminates the 
defects.

5 Increase the threshold gradually by entering a value or by dragging the slider to the 
highest value possible that eliminates defects.

Median Reduces noise in an image by blending the brightness of pixels within a 
selection. The filter searches the radius of a pixel selection for pixels of similar brightness, 
discarding pixels that differ too much from adjacent pixels, and replaces the center pixel 
with the median brightness value of the searched pixels. This filter is useful for eliminating 
or reducing the effect of motion on an image.

Pixelate filters
The filters in the Pixelate submenu sharply define a selection by clumping pixels of similar 
color values in cells.

Color Halftone Simulates the effect of using an enlarged halftone screen on each 
channel of the image. For each channel, the filter divides the image into rectangles and 
replaces each rectangle with a circle. The circle size is proportional to the brightness of the 
rectangle. 

To use the Color Halftone filter:

1 Choose Filter > Pixelate > Color Halftone.

2 Enter a value in pixels for the maximum radius of a halftone dot, from 4 to 127.

3 Enter a screen-angle value (the angle of the dot from the true horizontal) for one or 
more channels:

• For Grayscale images, use only channel 1. 

• For RGB images, use channels 1, 2, and 3, which correspond to the red, green, and blue 
channels. 
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• For CMYK images, use all four channels, which correspond to the cyan, magenta, yellow, 
and black channels. 

• Click Defaults to return all the screen angles to their default values. 

4 Click OK.

Crystallize Clumps pixels into a solid color in a polygon shape.

Facet Clumps pixels of solid or similar colors into blocks of like-colored pixels. You can use 
this filter to make a scanned image look hand-painted or to make a realistic image 
resemble an abstract painting.

Fragment Creates four copies of the pixels in the selection, averages them, and offsets 
them from each other.

Mezzotint Converts an image to a random pattern of black-and-white areas or of fully 
saturated colors in a color image. To use the filter, choose a dot pattern from the Type 
menu in the Mezzotint dialog box.

Mosaic Clumps pixels into square blocks. The pixels in a given block are the same color, 
and the colors of the blocks represent the colors in the selection.

Pointillize Breaks up the color in an image into randomly placed dots, as in a pointillist 
painting, and uses the background color as a canvas area between the dots.

Render filters
The Render filters create 3D shapes, cloud patterns, refraction patterns, and simulated 
light reflections in an image. You can also manipulate objects in 3D space, create 3D 
objects (cubes, spheres, and cylinders), and create texture fills from grayscale files to 
produce 3D-like effects for lighting.

Clouds Generates a soft cloud pattern using random values that vary between the 
foreground and the background colors. To generate a more stark cloud pattern, hold 
down Alt (Windows) or Option (Mac OS) as you choose Filter > Render > Clouds. When you 
apply the Clouds filter, the image data on the active layer is replaced.

Difference Clouds Uses randomly generated values that vary between the foreground 
and back-ground color to produce a cloud pattern. The filter blends the cloud data with 
the existing pixels in the same way that the Difference mode blends colors. The first time 
you choose this filter, portions of the image are inverted in a cloud pattern. Applying the 
filter several times creates rib and vein patterns that resemble a marble texture. When you 
apply the Difference Clouds filter, the image data on the active layer is replaced.

Fibers Creates the look of woven fibers using the foreground and background colors. 
You can control how the colors vary by sliding the Variance slider (a low value creates 
longer streaks of color, while a high value makes very short fibers with more varied distri-
bution of color). The Strength slider controls how each fiber looks. A low setting creates 
spread out fibers, while a high setting produces short, stringy fibers. Click the Randomize 
button to change how the pattern looks; you can click the button a number of times until 
you find a pattern you like. When you apply the Fibers filter, the image data on the active 
layer is replaced with fibers.

Try adding a gradient map adjustment layer to colorize the fibers (see “Using the 
Gradient Map command (Photoshop)” on page 223).
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Lens Flare Simulates the refraction caused by shining a bright light into the camera lens. 
Specify a location for the center of the flare by clicking anywhere inside the image 
thumbnail or by dragging its cross hair. 

Lighting Effects Lets you produce myriad lighting effects on RGB images by varying 
17 light styles, three light types, and four sets of light properties. You can also use textures 
from grayscale files (called bump maps) to produce 3D-like effects and save your own 
styles for use in other images. (See “The Lighting Effects filter” on page 432.)

Sharpen filters
The Sharpen filters focus blurry images by increasing the contrast of adjacent pixels.

Sharpen and Sharpen More Focus a selection and improve its clarity. The Sharpen More 
filter applies a stronger sharpening effect than does the Sharpen filter.

Sharpen Edges and Unsharp Mask Find the areas in the image where significant color 
changes occur and sharpen them. The Sharpen Edges filter sharpens only edges while 
preserving the overall smoothness of the image. Use this filter to sharpen edges without 
specifying an amount. For professional color correction, use the Unsharp Mask filter to 
adjust the contrast of edge detail and produce a lighter and darker line on each side of the 
edge. This process will emphasize the edge and create the illusion of a sharper image. 
(See “Sharpening images” on page 224.)

Sketch filters
Filters in the Sketch submenu add texture to images, often for a 3D effect. The filters also 
are useful for creating a fine-arts or hand-drawn look. Many of the Sketch filters use the 
foreground and background color as they redraw the image. All of the Sketch filters can be 
applied using the Filter Gallery (see “Applying filters using the Filter Gallery dialog box” on 
page 416).

Bas Relief Transforms an image to appear carved in low relief and lit to accent the surface 
variations. Dark areas of the image take on the foreground color, and light colors use the 
background color.

Chalk & Charcoal Redraws an image’s highlights and midtones with a solid midtone gray 
back-ground drawn in coarse chalk. Shadow areas are replaced with black diagonal 
charcoal lines. The charcoal is drawn in the foreground color, the chalk in background 
color.

Charcoal Redraws an image to create a posterized, smudged effect. Major edges are 
boldly drawn, while midtones are sketched using a diagonal stroke. Charcoal is the 
foreground color, and the paper is the background color.

Chrome Treats the image as if it were a polished chrome surface. Highlights are high 
points, and shadows are low points in the reflecting surface. After applying the filter, use 
the Levels dialog box to add more contrast to the image.

Conté Crayon Replicates the texture of dense dark and pure white Conté crayons on an 
image. The Conté Crayon filter uses the foreground color for dark areas and the 
background color for light areas. For a truer effect, change the foreground color to one of 
the common Conté Crayon colors (black, sepia, sanguine) before applying the filter. For a 
muted effect, change the background color to white with some foreground color added 
to it before applying the filter. (See “Using texture and glass surface controls” on 
page 419.)



Using Help | Contents | Index Back 429  

Adobe Photoshop CS Help Applying Filters for Special Effects 

Using Help | Contents | Index Back 429  

Graphic Pen Uses fine, linear ink strokes to capture the details in the original image and 
is especially striking with scanned images. The filter replaces color in the original image, 
using the foreground color for ink and background color for paper.

Halftone Pattern Simulates the effect of a halftone screen while maintaining the 
continuous range of tones. 

Note Paper Creates an image that appears to be constructed of handmade paper. The 
filter simplifies an image and combines the effects of the Stylize > Emboss and Texture > 
Grain filters. Dark areas of the image appear as holes in the top layer of paper, revealing 
the background color.

Photocopy Simulates the effect of photocopying an image. Large areas of darkness tend 
to copy only around their edges, and midtones fall away to either solid black or white.

Plaster Molds an image from 3D plaster, and then colorizes the result using the 
foreground and background color. Dark areas are raised, and light areas are sunken.

Reticulation Simulates the controlled shrinking and distorting of film emulsion to create 
an image that appears clumped in the shadow areas and lightly grained in the highlights.

Stamp Is best used with black-and-white images. The filter simplifies the image to appear 
stamped with a rubber or wood stamp.

Torn Edges Is particularly useful for images consisting of text or high-contrast objects. 
The filter reconstructs the image as ragged, torn pieces of paper, and then colorizes the 
image using the foreground and background colors.

Water Paper Uses blotchy daubs that appear painted onto fibrous, damp paper, causing 
the colors to flow and blend.

Stylize filters
The Stylize filters produce a painted or impressionistic effect on a selection by displacing 
pixels and by finding and heightening contrast in an image. After using filters like Find 
Edges and Trace Contour that highlight edges, you can apply the Invert command to 
outline the edges of a color image with colored lines or to outline the edges of a grayscale 
image with white lines. (See “Using the Invert command” on page 222.)

Diffuse Shuffles pixels in a selection to make the selection look less focused according to 
the selected option: Normal moves pixels randomly, (ignoring color values), Darken Only 
replaces light pixels with darker pixels, and Lighten Only replaces dark pixels with lighter 
pixels. Anisotropic shuffles pixels in the direction of the least change in color.

Emboss Makes a selection appear raised or stamped by converting its fill color to gray 
and tracing the edges with the original fill color. Options include an embossing angle 
(from –360˚ to lower [stamp] the surface, to +360˚ to raise the surface), height, and a 
percentage (1% to 500%) for the amount of color within the selection. To retain color and 
detail when embossing, use the Fade command after applying the Emboss filter.

Extrude Gives a 3D texture to a selection or layer.
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To use the Extrude filter:

1 Choose Filter > Stylize > Extrude. 

2 Choose a 3D type:

• Blocks creates objects with a square front face and four side faces. To fill the front face of 
each block with the average color of the block, select Solid Front Faces. To fill the front 
face with the image, deselect Solid Front Faces. 

• Pyramids creates objects with four triangular sides that meet at a point.

3 Enter a value in the Size text box to determine the length of any side of the object’s 
base, from 2 to 255 pixels.

4 Enter a value in the Depth text box to indicate how far the tallest object appears to 
protrude from the screen, from 1 to 255.

5 Choose a depth option: 

• Random to give each block or pyramid an arbitrary depth.

• Level-based to make each object’s depth correspond to its brightness—bright 
protrudes more than dark.

6 Select Mask Incomplete Blocks to hide any object extending beyond the selection.

Find Edges Identifies the areas of the image with significant transitions and emphasizes 
the edges. Like the Trace Counter filter, Find Edges outlines the edges of an image with 
dark lines against a white background and is useful for creating a border around an image. 

Glowing Edges Identifies the edges of color and adds a neon-like glow to them. This filter 
can be applied cumulatively with other filters using the Filter Gallery (see “Using the Filter 
Gallery” on page 415).

Solarize Blends a negative and a positive image—similar to exposing a photographic 
print briefly to light during development.

Tiles Breaks up an image into a series of tiles, off-setting the selection from its original 
position. You can choose one of the following to fill the area between the tiles: the 
background color, the foreground color, a reverse version of the image, or an unaltered 
version of the image, which puts the tiled version on top of the original and reveals part of 
the original image underneath the tiled edges.

Trace Contour Finds the transitions of major brightness areas and thinly outlines them 
for each color channel, for an effect similar to the lines in a contour map.

To use the Trace Contour filter:

1 Choose Filter > Stylize > Trace Contour.

2 Choose an Edge option to outline areas in the selection: Lower outlines where the color 
values of pixels fall below the specified level, and Upper outlines where the color values 
fall above. 

3 Enter a threshold (Level) for evaluating color values (tonal level), from 0 to 255. 
Experiment to see what values bring out the best detail in the image. 

Use the Info palette in Grayscale mode to identify a color value that you want traced. 
Then enter the value in the Level text box. (See “Using the Info palette” on page 25.)
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Wind Creates tiny horizontal lines in the image to simulate a wind effect. Methods 
include Wind; Blast, for a more dramatic wind effect; and Stagger, which offsets the wind 
lines in the image.

Texture filters
Use the Texture filters to give an image the appearance of depth or substance, or to add an 
organic look. 

Craquelure Paints an image onto a high-relief plaster surface, producing a fine network 
of cracks that follow the contours of the image. Use this filter to create an embossing 
effect with images that contain a broad range of color or grayscale values.

Grain Adds texture to an image by simulating different kinds of grain—regular, soft, 
sprinkles, clumped, contrasty, enlarged, stippled, horizontal, vertical, and speckle.

Mosaic Tiles Draws the image as if it were made up of small chips or tiles and adds grout 
between the tiles. (In contrast, the Pixelate > Mosaic filter breaks up an image into blocks 
of different-colored pixels.)

Patchwork Breaks up an image into squares filled with the predominant color in that area 
of the image. The filter randomly reduces or increases the tile depth to replicate the 
highlights and shadows.

Stained Glass Repaints an image as single-colored adjacent cells outlined in the 
foreground color. 

Texturizer Applies a texture you select or create to an image. (See “Using texture and 
glass surface controls” on page 419.)

Video filters
The Video submenu contains the De-Interlace and NTSC Colors filters. 

De-Interlace Smooths moving images captured on video by removing either the odd or 
even interlaced lines in a video image. You can choose to replace the discarded lines by 
duplication or interpolation.

NTSC Colors Restricts the gamut of colors to those acceptable for television repro-
duction, to prevent oversaturated colors from bleeding across television scan lines.

Other filters
Filters in the Other submenu let you create your own filters, use filters to modify masks, 
offset a selection within an image, and make quick color adjustments.

Custom Lets you design your own filter effect. With the Custom filter, you can change the 
brightness values of each pixel in the image according to a predefined mathematical 
operation known as convolution. Each pixel is reassigned a value based on the values of 
surrounding pixels. This operation is similar to the Add and Subtract calculations for 
channels. 

You can save the custom filters you create and use them with other Photoshop images. 

To create a Custom filter: 

1 Choose Filter > Other > Custom. 

2 Select the center text box, which represents the pixel being evaluated. Enter the value 
by which you want to multiply that pixel’s brightness value, from –999 to +999.
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3 Select a text box representing an adjacent pixel. Enter the value by which you want the 
pixel in this position multiplied. 

For example, to multiply the brightness value of the pixel to the immediate right of the 
current pixel by 2, enter 2 in the text box to the immediate right of the center text box. 

4 Repeat steps 2 and 3 for all pixels to include in the operation. You don’t have to enter 
values in all the text boxes.

5 For Scale, enter the value by which to divide the sum of the brightness values of the 
pixels included in the calculation. 

6 For Offset, enter the value to be added to the result of the scale calculation. 

7 Click OK. The custom filter is applied to each pixel in the image, one at a time. 

Use the Save and Load buttons to save and reuse custom filters. 

High Pass Retains edge details in the specified radius where sharp color transitions occur 
and suppresses the rest of the image. (A radius of 0.1 pixel keeps only edge pixels.) 
The filter removes low-frequency detail in an image and has an effect opposite to that of 
the Gaussian Blur filter. 

It is helpful to apply the High Pass filter to a continuous-tone image before using the 
Threshold command or converting the image to Bitmap mode. The filter is useful for 
extracting line art and large black-and-white areas from scanned images.

Minimum and Maximum Are useful for modifying masks. The Minimum filter has 
the effect of applying a spread—spreading out black areas and shrinking white areas. 
The Maximum filter has the effect of applying a choke—spreading out white areas and 
choking in black areas. Like the Median filter, the Maximum and Minimum filters look at 
individual pixels in a selection. Within a specified radius, the Maximum and Minimum 
filters replace the current pixel’s brightness value with the greatest or least brightness 
value of the surrounding pixels.

Offset Moves a selection a specified horizontal or vertical amount, leaving an empty 
space at the selection’s original location. You can fill the empty area with the current 
background color, with another part of the image, or with your choice of fill if the selection 
is near the edge of an image. (See “Defining undistorted areas” on page 419.)

Tile Maker (ImageReady) Enables you to prepare an image for use as a tiled 
background. You can blend the edges of an image to create a seamless background. 
You can also create a kaleidoscopic background in which an image is flipped horizontally 
and vertically to create an abstract design. 

Digimarc filters
The Digimarc filters embed a digital watermark into an image to store copyright infor-
mation. For more information, see “Adding digital copyright information” on page 590.

The Lighting Effects filter
The Lighting Effects filter lets you produce myriad lighting effects on RGB images. You can 
also use textures from grayscale files (called bump maps) to produce 3D-like effects and 
save your own styles for use in other images.

Note: The Lighting Effects filter works only on RGB images.
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Using the Lighting Effects filter
You can apply the Lighting Effects filter using the Lighting Effects dialog box. You’ll see a 
preview of your image to see how the settings you choose affect the image.

To use the Lighting Effects filter:

1 Choose Filter > Render > Lighting Effects. 

2 For Style, choose a style. (See “Choosing a Lighting Effects style” on page 434.)

3 For Light Type, choose a type. If you’re using multiple lights, select and deselect On to 
turn individual lights on and off. (See “Choosing a Lighting Effects type” on page 433.)

4 To change the color of the light, click the color box in the Light Type area of the 
dialog box. 

The color picker chosen in the General Preferences dialog box opens. For information on 
choosing a color picker, see “Using the Adobe Color Picker” on page 164, or “Using other 
color pickers” on page 171.

5 To set light properties, drag the corresponding slider for the following options:

• Gloss determines how much the surface reflects light (as on the surface of a piece of 
photographic paper) from Matte (low reflectance) to Glossy (high reflectance). 

• Material determines whether the light or the object on which the light is cast reflects 
more light. Plastic reflects the light’s color; Metallic reflects the object’s color.

• Exposure increases the light (positive values) or decreases the light (negative values). 
A value of 0 has no effect.

• Ambience diffuses the light as if it were combined with other light in a room, such as 
sunlight or fluorescent light. Choose a value of 100 to use only the light source, or a 
value of –100 to remove the light source. To change the color of the ambient light, click 
the color box and use the color picker that appears.

To duplicate a light, Alt-drag (Windows) or Option-drag (Mac OS) the light within the 
preview window.

6 To use a texture fill, choose a channel for Texture Channel. (See “Using a Lighting Effects 
texture” on page 436.)

Choosing a Lighting Effects type
You can choose from several light types:

• Omni shines light in all directions from directly above the image—like a light bulb over 
a piece of paper.

• Directional shines light from far away so that the light angle doesn’t change—like 
the sun.

• Spotlight casts an elliptical beam of light. The line in the preview window defines the 
light direction and angle, and the handles define the edges of the ellipse. 

To adjust an Omni light:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Omni.
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3 Adjust the light:

• To move the light, drag the center circle. 

• To increase or decrease the size of the light (like a light moving closer or farther away), 
drag one of the handles defining the edges of the effect.

To adjust the angle and height of the directional light using the preview window:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Directional.

3 Adjust the light:

• To move the light, drag the center circle. 

• To change the direction of the light, drag the handle at the end of the line to rotate the 
light’s angle. Ctrl-drag (Windows) or Command-drag (Mac OS) to keep the light’s height 
(line length) constant.

• To change the light’s height, drag the handle at the end of the line. Shorten the line for 
a bright light, and lengthen it for a less intense one. A very short line produces pure 
white light, a very long one no light. Shift-drag to keep the angle constant and change 
the light’s height (line length).

To adjust the angle and height of the spotlight using the preview window:

1 Choose Filter > Render > Lighting Effects. 

2 For Light Type, choose Spotlight.

3 Adjust the light:

• To move the light, drag the center circle. 

• To increase the light angle, drag the handle to shorten the line. To decrease the light 
angle, drag to lengthen the line.

• To stretch the ellipse or rotate the light, drag one of the handles. Shift-drag to keep the 
angle constant and change only the size of the ellipse. Ctrl-drag (Windows) or 
Command-drag (Mac OS) to keep the size constant and change the angle or direction 
of the spotlight.

• To set the light focus (or spotlight intensity) and control how much of an ellipse is filled 
with light, drag the Intensity slider: full intensity (a value of 100) is brightest, normal 
intensity is about 50, negative intensity takes away light, and –100 intensity produces 
no light. Use the Focus slider to control how much of the ellipse is filled with light.

Choosing a Lighting Effects style
Use the Style menu in the Lighting Effects dialog box to choose from 17 light styles. You 
can also create your own lighting style by adding lights to the Default setting. The Lighting 
Effects filter requires at least one light source. Only one light can be edited at a time, but all 
added lights will be used to create the effect.

2 o’clock Spotlight A yellow spotlight with medium (17) intensity and wide (91) focus.

Blue Omni A blue overhead omni light with full (85) intensity and no focus.

Circle of Light Four spotlights. White has full (100) intensity and a concentrated (8) focus. 
Yellow has strong intensity (88) and a concentrated focus (3). Red has medium (50) 
intensity and a concentrated (0) focus. Blue has full (100) intensity and medium (25) focus. 
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Crossing A white spotlight with medium (35) intensity and a wide (69) focus.

Crossing Down Two white spotlights with medium (35) intensity and wide (100) focus.

Default A white spotlight with a medium intensity and a wide focus. 

Five Lights Down/Five Lights Up Five white spotlights down or up with full (100) 
intensity and wide (60) focus.

Flashlight An omni yellow light with medium (46) intensity.

Flood Light A white spotlight with medium (35) intensity and wide (69) focus.

Parallel Directional A directional blue light with full (98) intensity and no focus.

RGB Lights Red, blue, and green lights that produce a light of medium (60) intensity and 
wide (96) focus.

Soft Direct Lights Two unfocused white and blue directional lights. White has a soft (20) 
intensity. Blue has a medium (67) intensity.

Soft Omni A soft omni light of medium (50) intensity.

Soft Spotlight A white spotlight with full (98) intensity and wide (100) focus.

Three Down Three white spotlights with soft (35) intensity and wide (96) focus.

Triple Spotlight Three spotlights with slight (35) intensity and wide (100) focus.

To add a light: 

In the Lighting Effects dialog box, drag the light icon at the bottom of the dialog box into 
the preview area. Repeat as desired for a maximum of 16 lights. 

To delete a light:

In the Lighting Effects dialog box, drag the light by its center circle to the Trash button at 
the bottom right of the preview window.

To create a new style:

1 In the Lighting Effects dialog box, choose Default for Style. 

2 Drag the light icon at the bottom of the dialog box into the preview area. Repeat as 
desired for a maximum of 16 lights. 

To save a style:

1 In the Lighting Effects dialog box, click Save. 

2 Name the style, and click OK.

Saved styles include all of the settings for each light and appear in the Style menu 
whenever you open the image. 

To delete a style:

In the Lighting Effects dialog box, choose a style, and then click Delete.
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Using a Lighting Effects texture
The Texture Channel in the Lighting Effects dialog box lets you use a grayscale texture 
such as paper or water to control how light reflects off an image. You can use any channel 
in your image (including a channel copied from a different image) as a texture, or you can 
create your own texture. For an embossed text effect, use a channel with white text on a 
black background, or vice versa.

To use the Texture Channel in the Lighting Effects dialog box:

1 If necessary, create an alpha channel in your image and add texture. To use a texture 
from another image, copy and paste the image into a new channel. (See “Creating alpha 
channels (Photoshop)” on page 255.)

2 In the Lighting Effects dialog box, choose a channel from the Texture Channel menu: 
the image’s Red, Green, or Blue channel or any channel added to the image.

3 Select White is High to raise the white parts of the channel from the surface. Deselect 
this option to raise the dark parts.

4 Drag the Height slider to vary the texture from Flat (0) to Mountainous (100). 

Loading images and textures
To produce their effects, some filters load and use other images, such as textures and 
displacement maps. These filters include the Conté Crayon, Displace, Glass, Lighting 
Effects, Rough Pastels, Texture Fill, Texturizer, Underpainting, and Custom filters.

Not all of these filters load images or textures in the same way. (See “The Lighting Effects 
filter” on page 432.)

To load images and textures:

1 Choose the filter you want from the appropriate submenu.

2 In the filter’s dialog box, choose Load Texture from the Texture pop-up menu, and 
locate and open a texture image. 

All textures must be in the Photoshop format. Most filters use only the grayscale 
information of a color file.

Improving filter performance
Some filter effects can be memory-intensive, especially when applied to a high-resolution 
image. You can use these techniques to improve performance:

• Try out filters and settings on a small portion of an image.

• Apply the effect to individual channels—for example, to each RGB channel—if the 
image is large and you’re having problems with insufficient memory. (With some filters, 
effects vary if applied to the individual channel rather than the composite channel, 
especially if the filter randomly modifies pixels.)

• Free up memory before running the filter by using the Purge command. (See 
“Correcting mistakes” on page 33.)

• Allocate more RAM to Photoshop. If necessary, exit other applications to make more 
memory available to Photoshop.
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• Try changing settings to improve the speed of memory-intensive filters, such as 
Lighting Effects, Cutout, Stained Glass, Chrome, Ripple, Spatter, Sprayed Strokes, and 
Glass filters. (For example, with the Stained Glass filter, increase cell size. With the 
Cutout filter, increase Edge Simplicity, decrease Edge Fidelity, or both.)

• If you plan to print to a grayscale printer, convert a copy of the image to grayscale 
before applying filters. However, applying a filter to a color image and then converting 
to grayscale may not have the same effect as applying the filter to a grayscale version of 
the image.

About plug-in filters
You can install plug-in filters developed by non-Adobe software developers. Once 
installed, the plug-in filters appear at the bottom of the Filter menu and work in the same 
way as built-in filters.

If you are interested in creating plug-in modules, contact Adobe Systems Developer 
Support. (See “Using plug-in modules” on page 57.)

Note: If you have problems or questions about a third-party plug-in, contact the plug-in’s 
manufacturer for support.
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Using Type

About type
Type in Photoshop consists of mathematically defined shapes that describe the letters, 
numbers, and symbols of a typeface. Many typefaces are available in more than one 
format, the most common formats being Type 1 (also called PostScript fonts), TrueType, 
Open Type, New CID, and CID nonprotected (Japanese only).

When you add type to an image, the characters are composed of pixels and have the same 
resolution as the image file—zooming in on characters shows jagged edges. However, 
Photoshop and ImageReady preserve the vector-based type outlines and use them when 
you scale or resize type, save a PDF or EPS file, or print the image to a PostScript printer. 
As a result, it’s possible to produce type with crisp, resolution-independent edges. 

Creating type
You can create horizontal or vertical type anywhere in an image. Depending on how you 
use the type tools, you can enter point type or paragraph type. Point type is useful for 
entering a single word or a line of characters; paragraph type is useful for entering and 
formatting the type as one or more paragraphs.

Type entered as point type (top) and in a bounding box (bottom)

When you create type, a new type layer is added to the Layers palette. In Photoshop, 
you can also create a selection border in the shape of the type. 

Note: In Photoshop, a type layer is not created for images in Multichannel, Bitmap, or 
Indexed Color mode, because these modes do not support layers. In these image modes, 
type appears on the background.
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About using the type tools (Photoshop)
Clicking in an image with a type tool puts the type tool in edit mode. When the tool is in 
edit mode, you can enter and edit characters as well as perform some other commands 
from the various menus; however, certain operations require that you first commit 
changes to the type layer. To determine if a type tool is in edit mode, look in the options 
bar—if you see the Commit button  and the Cancel button , the type tool is in 
edit mode.

To commit changes to a type layer:

Do one of the following:

• Click the Commit button  in the options bar.

• Press the Enter key on the numeric keypad.

• Press Ctrl+Enter on the main keyboard (Windows) or Command+Return (Mac OS).

• Select any tool in the toolbox, click in the Layers, Channels, Paths, Actions, History, 
or Styles palette, or select any available menu command.

Entering point type
When you enter point type, each line of type is independent—the length of a line grows 
or shrinks as you edit it, but it doesn’t wrap to the next line. The type you entered appears 
in a new type layer.

To enter point type:

1 Do one of the following:

• (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool .

• (ImageReady) Select the Type tool .

Note: To change between horizontal or vertical text in ImageReady, click the Change Text 
Orientation button in the tool options bar or choose Change Text Orientation from the 
Character palette menu.

2 Click in the image to set an insertion point for the type. The small line through the 
I-beam marks the position of the type baseline (the imaginary line on which type rests). 
For vertical type, the baseline marks the center axis of the type characters.

3 Select additional type options in the options bar, Character palette, or Paragraph 
palette. (See “Formatting characters” on page 448 and “Formatting paragraphs” on 
page 459.)

4 Enter the characters you want. To begin a new line, press Enter on the main keyboard 
(Windows) or Return (Mac OS).

Note: (Photoshop) You can also transform point type while in edit mode. Hold down the 
Ctrl (Windows) or Command (Mac OS) key. A bounding box will appear around the type. 
You can grab a handle to scale or skew the type. You can also rotate the bounding box. 
For more information on resizing or transforming type, see “Entering paragraph type” on 
page 440.

5 (Photoshop) When you’re finished entering or editing the type, do one of the following:

• Click the Commit button  in the options bar.

• Press the Enter key on the numeric keypad.
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• Press Ctrl+Enter on the main keyboard (Windows) or Command+Return (Mac OS).

• Select any tool in the toolbox, click in the Layers, Channels, Paths, Actions, History, 
or Styles palette, or select any available menu command.

Entering paragraph type
When you enter paragraph type, the lines of type wrap to fit the dimensions of the 
bounding box. You can enter multiple paragraphs and select a paragraph justification 
option.

You can resize the bounding box, causing the type to reflow within the adjusted rectangle. 
You can adjust the bounding box while you’re entering type or after you create the type 
layer. You can also rotate, scale, and skew type using the bounding box.

To enter paragraph type:

1 Do one of the following:

• (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool .

• (ImageReady) Select the Type tool .

Note: To change between horizontal or vertical text in ImageReady, click the Change Text 
Orientation button in the tool options bar or choose Change Text Orientation from the 
Character palette menu.

2 Do one of the following:

• Drag diagonally to define a bounding box for the type. 

• Hold down Alt (Windows) or Option (Mac OS) as you click or drag to display the 
Paragraph Text Size dialog box. Enter values for Width and Height, and click OK.

3 Select additional type options in the options bar, Character palette, Paragraph palette, 
or Layer > Type submenu. (See “Formatting characters” on page 448 and “Formatting 
paragraphs” on page 459.)

4 Enter the characters you want. To begin a new paragraph, press Enter on the main 
keyboard (Windows) or Return (Mac OS). If you enter more type than can fit in the 
bounding box, the overflow icon  appears on the bounding box.

5 (Photoshop) If desired, resize, rotate, or skew the bounding box. 

6 (Photoshop) Commit the type layer by doing one of the following:

• Click the Commit button  in the options bar.

• Press the Enter key on the numeric keypad.

• Press Ctrl+Enter on the main keyboard (Windows) or Command+Return (Mac OS).

• Select any tool in the toolbox, click in the Layers, Channels, Paths, Actions, History, 
or Styles palette, or select any available menu command.

The type you entered appears in a new type layer.
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To resize or transform a type bounding box:

1 Display the bounding box handles:

• (Photoshop) With the Type tool active, select the type layer in the Layers palette, and 
click in the text flow in the image.

• (ImageReady) With the Type tool active, select the type layer.

Note: You can transform point type while in edit mode. Hold down the Ctrl (Windows) or 
Command (Mac OS) key, and a bounding box will appear around the type.

2 Do one of the following:

• To resize the bounding box, position the pointer over a handle—the pointer turns 
into a double arrow —and drag. Shift-drag to maintain the proportion of the 
bounding box. 

• (Photoshop) To rotate the bounding box, position the pointer outside of the 
bounding border—the pointer turns into a curved, two-sided arrow —and drag. 
Shift-drag to constrain the rotation to 15° increments. To change the center of rotation, 
Ctrl-drag (Windows) or Command-drag (Mac OS) the center point to a new location. 
The center point can be outside the bounding box.

• (Photoshop) To skew the bounding box, hold down Ctrl+Shift (Windows) or 
Command+Shift (Mac OS) and drag a side handle. The pointer turns into an arrowhead 
with a small double arrow . 

Skewing type using the bounding box

• (Photoshop) To scale the type as you resize the bounding box, Ctrl-drag (Windows) or 
Command-drag (Mac OS) a corner handle. 

Note: You can also transform type layers using the transformation commands in the Edit 
menu, except for Perspective and Distort.

Creating a type selection border (Photoshop)
When you use the Horizontal Type Mask tool  or Vertical Type Mask tool , you create a 
selection in the shape of the type. Type selections appear on the active layer, and can be 
moved, copied, filled, or stroked just like any other selection. For more information about 
working with selections, see “About selections” on page 229.

To create a type selection border:

1 Select the layer on which you want the selection to appear. For best results, create the 
type selection border on a normal image layer, not a type layer.

2 Select the Horizontal Type Mask tool  or the Vertical Type Mask tool .
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3 Select additional type options, and enter type at a point or in a bounding box. 
(See “Entering point type” on page 439 and “Entering paragraph type” on page 440.)

A red mask appears over the active layer as you enter the type. Once the type is 
committed, the type selection border appears in the image on the active layer.

Working with type layers
Once you create a type layer, you can edit the type and apply layer commands to it. 
You can change the orientation of the type, apply anti-aliasing, convert between point 
type and paragraph type, create a work path from type, or convert type to shapes. You can 
move, restack, copy, and change the layer options of a type layer as you do for a normal 
layer. You can also make the following changes to a type layer and still edit the type:

• Apply transformation commands from the Edit menu, except for Perspective and 
Distort. 

Note: To apply the Perspective or Distort commands, or to transform part of the type layer, 
you must first rasterize the type layer, turning the type shapes into a pixel image. Keep in 
mind that rasterized type no longer has vector outlines and is uneditable as type. For more 
information, see “Rasterizing type layers” on page 442.

• Use layer styles.

• Use fill shortcuts. To fill with the foreground color, press Alt+Backspace (Windows) or 
Option+Delete (Mac OS); to fill with the background color, press Ctrl+Backspace 
(Windows) or Command+Delete (Mac OS).

• Warp type to conform to a variety of shapes.

Editing text in type layers
You can insert new text, change existing text, and delete text in type layers.

To edit text in a type layer:

1 Select the Horizontal Type tool  or the Vertical Type tool . 

2 Select the type layer in the Layers palette, or click in the text flow to automatically select 
a type layer. 

3 Position the insertion point in the text, and do one of the following:

• Click to set the insertion point.

• Select one or more characters you want to edit.

4 Enter text as desired.

5 Commit the changes to the type layer. (See “About using the type tools (Photoshop)” 
on page 439.)

Rasterizing type layers
Some commands and tools—such as filter effects and painting tools—are not available for 
type layers. You must rasterize the type prior to applying the command or using the tool. 
Rasterizing converts the type layer to a normal layer and makes its contents uneditable as 
text. A warning message appears if you choose a command or tool that requires a 
rasterized layer. Some warning messages provide an OK button that you can click to 
rasterize the layer. 
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To convert a type layer to a normal layer:

1 Select the type layer in the Layers palette.

2 Choose Layer > Rasterize > Type.

Changing type layer orientation
The orientation of a type layer determines the direction of type lines in relation to the 
document window (for point type) or the bounding box (for paragraph type). When a type 
layer is vertical, the type lines flow up and down; when a type layer is horizontal, the type 
lines flow from left to right. Don’t confuse the orientation of a type layer with the direction 
of characters in a type line. (See “Rotating vertical type” on page 456.)

To change the orientation of a type layer:

1 Select the type layer in the Layers palette.

2 Do one of the following:

• Select a type tool and click the Text Orientation button  in the options bar.

• Choose Layer > Type > Horizontal, or choose Layer > Type > Vertical.

• Choose Change Text Orientation from the Character palette menu.

Specifying anti-aliasing
Anti-aliasing lets you produce smooth-edged type by partially filling the edge pixels. 
As a result, the edges of the type blend into the background. 

Anti-aliasing None (left), and Strong (right)

When creating type for display on the Web, consider that anti-aliasing greatly increases 
the number of colors in the original image. This limits your ability to reduce the number of 
colors in the image and thus reduce the image file size. This may also cause stray colors to 
appear along the edges of the type. When file size and limiting the number of colors is 
most important, leaving type without anti-aliased edges may be preferable, despite the 
jagged edges. Also, consider using larger type than you would use for printed works. 
Larger type can be easier to view on the Web and gives you more freedom in deciding 
whether to apply anti-aliasing to type.

Note: When you use anti-aliasing, type may be rendered inconsistently at small sizes and 
low resolutions (such as the resolution used for Web graphics). To reduce this inconsis-
tency, deselect the Fractional Width option in the Character palette menu.
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Anti-aliasing options include:

• None to apply no anti-aliasing

• Sharp to make type appear the most sharp

• Crisp to make type appear somewhat sharp

• Strong to make type appear heavier

• Smooth to make type appear smoother

To apply anti-aliasing to a type layer:

1 Select the type layer in the Layers palette.

2 Do one of the following:

• Choose an option from the anti-aliasing menu  in the options bar or the Character 
palette.

• Choose Layer > Type, and choose an option from the submenu.

Converting between point type and paragraph type
You can convert point type to paragraph type to adjust the flow of characters within a 
bounding box. Or you can convert paragraph type to point type to make each text line 
flow independently from the others.

When you convert from paragraph type to point type, a carriage return is added at the end 
of each line of type (with the exception of the last line). 

Important: When you convert paragraph type to point type, all characters that overflow 
the bounding box are deleted. To avoid losing text, adjust the bounding box so that all 
type is visible prior to conversion.

To convert between point type and paragraph type:

1 Select the type layer in the Layers palette.

2 Choose Layer > Type > Convert to Point Text, or Layer > Type > Convert to Paragraph 
Text.

Warping type layers
Warping lets you distort type to conform to a variety of shapes; for example, you can warp 
type in the shape of an arc or a wave. The warp style you select is an attribute of the type 
layer—you can change a layer’s warp style at any time to change the overall shape of the 
warp. Warping options give you precise control over the orientation and perspective of 
the warp effect.

Note: You cannot warp type layers that include Faux Bold formatting or use fonts that do 
not include outline data (such as bitmap fonts).
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Example of type warped with Fish style

To warp type:

1 Select a type layer. 

2 Do one of the following:

• Select a type tool, and click the Warp button  in the options bar.

• Choose Layer > Type > Warp Text.

3 Choose a warp style from the Style pop-up menu.

4 Select the orientation of the warp effect—Horizontal or Vertical.

5 If desired, specify values for additional warping options:

• Bend to specify how much warp is applied to the layer

• Horizontal Distortion and Vertical Distortion to apply perspective to the warp

To unwarp type:

1 Select a type layer that has warping applied to it. 

2 Select a type tool and click the Warp button  in the options bar, or choose Layer > 
Type > Warp Text.

3 Choose None from the Style pop-up menu, and click OK.

Creating text on a path (Photoshop)
You can enter type that flows along the edge of a work path created by a pen or a shape 
tool. For information on how to create a work path, see “Creating a work path 
(Photoshop)” on page 300.

When you enter type along a path, it flows in the direction in which anchor points were 
added to the path. Entering horizontal type on a path results in letters that are perpen-
dicular to the baseline. Entering vertical type on a path results in text orientation parallel 
to the baseline.
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You can also move a path or change the shape of the path, and the type will conform to 
the new path location or shape.

Example of horizontal and vertical type on an open path

Example of horizontal and vertical type on a closed path created by a shape tool

To enter type along a path:

1 Do one of the following:

• Select the Horizontal Type tool  or the Vertical Type tool .

• Select the Horizontal Type Mask tool  or the Vertical Type Mask tool .

2 Position the pointer so the baseline indicator of the type tool  is on the path and click. 
After clicking, an insertion point appears on the path. 

The baseline indicator of the Type tool (left) and the Type tool with its 
baseline indicator on a path (right)

3 Enter the type you want. Horizontal type appears along the path, perpendicular to the 
baseline. Vertical type appears along the path, parallel to the baseline.

cac tus  |cac tus  |

e
c
h
i

n
o

c

a c
t

u
s

e c h i no

c a c t u s

Echniocactus
p

latyca
n

th
u

s
sp

ecieswithlongsharp

sp
in

e
s

a
n

d
u

p
to

50
ribs. B a r r

e

l

E
c
h

n
i

o

c
actus

p

l
a

t
y
c
a

n
t

h

u
s

C



Using Help | Contents | Index Back 447  

Adobe Photoshop CS Help Using Type 

Using Help | Contents | Index Back 447  

To move type along a path:

1 Select the Direct Selection tool  or Path Selection tool  and position it over the type. 
The pointer changes to an I-beam with arrow .

2 Click and drag the type along the path. Be careful not to drag across the path. 

To flip type to the other side of a path:

1 Select the Direct Selection tool  or Path Selection tool  and position it over the type. 
The pointer changes to an I-beam with arrow .

2 Click and drag the type across the path.

Using the Direct Selection tool or Path Selection tool to move or flip type on a path

To move a path with type:

Select the Path Selection tool  or the Move tool , and then click and drag the path to a 
new position. If you’re using the Path Selection tool, make sure the pointer does not 
change to an I-beam with an arrow  or you’ll move the type along the path.

To change the shape of a path with type:

1 Select the Direct Selection tool .

2 Click an anchor point on the path and use the handles to change the shape of the path.

Creating a work path from type (Photoshop)
Creating a work path from type lets you work with the characters as vector shapes. A work 
path is a temporary path that appears in the Paths palette and defines the outline of a 
shape. Once you create a work path from a type layer, you can save and manipulate it like 
any other path. You cannot edit characters in the path as text; however, the original type 
layer remains intact and editable. For more information on manipulating paths, see 
“Moving, reshaping, and deleting path segments” on page 303.

To create a work path from type:

Select a type layer, and choose Layer > Type > Create Work Path.

Note: You cannot create work paths from fonts that don't include outline data (such as 
bitmap fonts).

Converting type to shapes (Photoshop)
When you convert type to shapes, the type layer is replaced by a layer with a vector mask. 
You can edit the vector mask and apply styles to the layer; however, you cannot edit 
characters in the layer as text. For more information on working with vector masks, 
see “Creating and editing vector masks” on page 411.

Ca Ca
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To convert type to shapes:

Select a type layer, and choose Layer > Type > Convert to Shape.

Note: You cannot create shapes from fonts that don't include outline data (such as 
bitmap fonts).

Formatting characters
Photoshop and ImageReady give you precise control over individual characters in type 
layers, including font, size, color, leading, kerning, tracking, baseline shift, and alignment. 
You can set type attributes before you enter characters or reset them to change the 
appearance of selected characters in a type layer. 

Selecting characters
Before you can format individual characters, you must select them. You can select one 
character, a range of characters, or all characters in a type layer. 

To select characters:

1 Do one of the following:

• (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool .

• (ImageReady) Select the Type tool .

2 Select the type layer in the Layers palette, or click in the text flow to automatically select 
a type layer.

3 Position the insertion point in the text, and do one of the following:

• Drag to select one or more characters.

• Click in the text and then shift-click to select a range of characters.

• Choose Select > All to select all the characters in the layer.

• Double-click a word to select it. Triple-click a line to select it. Quadruple-click a 
paragraph to select it. Quintuple-click anywhere in the text flow to select all characters 
in a bounding box.

• To use the arrow keys to select characters, click in the text, and then hold down Shift 
and press the Right arrow or Left arrow key. To use the arrow keys to select words, hold 
down Shift+Ctrl (Windows) or Shift+Command (Mac OS) and press the Right Arrow or 
Left Arrow key.

4 To select all the characters in a layer without positioning the insertion point in the 
text flow, select the type layer in the Layers palette, and then double-click the layer’s 
type icon .

Note: In Photoshop, selecting and formatting characters in a type layer puts the Type tool 
into edit mode. See “About using the type tools (Photoshop)” on page 439.

To show or hide selection highlighting (ImageReady):

Do one of the following:

• Choose View > Show > Text Selection.

• Choose View > Extras. This command shows or hides all selected items in the View > 
Show submenu. (See “Working with Extras” on page 45.)
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Using the Character palette
The Character palette provides options for formatting characters. Some formatting 
options are also provided in the options bar.

To display the Character palette:

Do one of the following:

• Choose Window > Character, or click the Character palette tab if the palette is visible 
but not active.

• With a type tool selected, click the palette button  in the options bar.

Choosing a font
A font is a complete set of characters—letters, numbers, and symbols—that share a 
common weight, width, and style. When you select a font, you can select the font family 
and its type style independently. The font family is a collection of fonts sharing an overall 
typeface design: for example, Times. A type style is a variant version of an individual font in 
the font family: for example, Regular, Bold, or Italic. The range of available type styles varies 
with each font. If a font doesn’t include the style you want, you can apply faux styles—
simulated versions of bold, italic, superscript, subscript, all caps, and small caps styles. 

In addition to the fonts installed on your system, Photoshop uses font files in these local 
folders:

Windows Program Files/Common Files/Adobe/Fonts

Mac OS Library/Application Support/Adobe/Fonts 

If you install a Type 1, TrueType, Open Type, or CID font into the local Fonts folder, the font 
appears in Adobe applications only. 

To choose a font family and style:

1 Choose a font family from the Font Family pop-up menu in the Character palette or 
options bar. If more than one copy of a font is installed on your computer, an abbreviation 
follows the font name: (T1) for Type 1 fonts, (TT) for TrueType fonts, or (OT) for Open Type 
fonts.

You can choose a font family and style by typing the desired name in the text box. 
As you type, the name of the first font or style beginning with that letter appears. 

Continue typing until the correct font or style name appears. Be sure to deselect the font 
name before entering new type in the image.

2 To choose a font style, do one of the following:

• Choose a font style from the Font Style pop-up menu in the Character palette or 
options bar.

• If the font family you chose does not include a bold or italic style, click the Faux Bold 
button  or the Faux Italic button  in the Character palette to apply a simulated style. 
Alternately, choose Faux Bold or Faux Italic from the Character palette menu.
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• Use a dynamic shortcut. Dynamic shortcuts are keyboard shortcuts that are available 
(in edit mode only) for Faux Bold, Faux Italic, All Caps, Small Caps, Superscript, 
Subscript, Underline, and Strikethrough. For more information on dynamic shortcuts, 
see “Using Dynamic Shortcuts” on page 455.

Note: You cannot apply Faux Bold formatting to warped type. (See “Warping type layers” 
on page 444.)

Choosing a type size
The type size determines how large the type appears in the image:

• In Photoshop, the default unit of measurement for type is points. One PostScript point is 
equal to 1/72 of an inch in a 72-ppi image; however, you can switch between using the 
PostScript and traditional definitions of point size. You can change the default unit of 
measurement for type in the Units & Rulers area of the Preferences dialog box. 

• In ImageReady, pixels are the only unit of measurement for type. This is because the 
ImageReady application is tailored to creating images for online viewing, in which 
pixels are the standard unit of measurement.

To choose a type size:

In the Character palette or options bar, enter or select a new value for Size . In 
Photoshop, to use an alternate unit of measurement, enter the unit (in, cm, mm, pt, 
px, or pica) after the value in the Size text box. The value you enter is converted to the 
default unit of measurement.

To specify the default unit of measurement for type (Photoshop): 

1 Do one of the following:

• In Windows, choose Edit > Preferences > Units & Rulers.

• In Mac OS, choose Photoshop > Preferences > Units & Rulers.

2 Select a unit of measurement for Type.

To specify the point size definition (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Units & Rulers.

• In Mac OS, choose Photoshop > Preferences > Units & Rulers.

2 Select an option for Point/Pica Size. Traditional points are slightly smaller than 
PostScript points.

Changing the type color
The type you enter gets its color from the current foreground color; however, you can 
change the type color before or after you enter type. When editing existing type layers, 
you can change the color of individual, selected characters or all type in a layer.
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To change the type color:

Do one of the following:

• Click the Color selection box in the options bar or Character palette, and select a color 
using the color picker. In ImageReady, you can also select an option from the Color 
selection box pop-up menu: Foreground Color, Background Color, Other (to use the 
color picker), or a color from the pop-up palette.

• Use fill shortcuts. To fill with the foreground color, press Alt+Backspace (Windows) or 
Option+Delete (Mac OS); to fill with the background color, press Ctrl+Backspace 
(Windows) or Command+Delete (Mac OS).

• Apply an overlay layer style to the type layer to apply a color, gradient, or pattern on top 
of the existing color. Applying an overlay layer style affects all characters in the type 
layer; you cannot use this method to change the color of individual characters. For 
more information on applying an overlay layer style, see “Using layer effects and styles” 
on page 391.

• Click the foreground color selection box in the toolbox, and select a color using the 
color picker. Or click a color in the Color palette, the Swatches palette, or (ImageReady) 
the Color Table palette. To use this method to change the color of an existing type layer, 
you must first select characters on that layer.

• (ImageReady) You can drag a color from the toolbox color selection box, the Color 
palette, the Color Table palette, or the Swatches palette, and drop it onto a type layer to 
automatically apply a color overlay style.

Specifying leading
The amount of space between lines of type is called leading. For Roman type, leading is 
measured from the baseline of one line of type to the baseline of the next line. The 
baseline is the invisible line on which most type lies. You can apply more than one leading 
amount within the same paragraph; however, the largest leading value in a line of type 
determines the leading value for that line.

You can use other options to set leading for Chinese, Japanese, or Korean type. See “Speci-
fying how leading is measured” on page 465.

5-point type with 6-point leading (left), and with 12-point leading (right)
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To change the leading:

In the Character palette, do one of the following:

• Choose the desired leading from the Leading menu .

• Select the existing leading value, and enter a new value.

To change the default auto leading percentage:

1 Display the Paragraph palette.

2 Choose Justification from the palette menu.

3 For Auto Leading, enter a new default percentage.

Specifying kerning and tracking
Kerning is the process of adding or subtracting space between specific letter pairs. You can 
control kerning manually, or you can use automatic kerning to turn on the kerning built 
into the font by the font designer. Tracking is the process of creating an equal amount of 
spacing across a range of letters. 

Positive kerning or tracking values move characters apart (adding to the default spacing); 
negative values move characters closer together (reducing the default spacing). Kerning 
and tracking values are measured in units that are 1/1000 of an em space. The width of an 
em space is relative to the current type size. In a 1-point font, 1 em corresponds to 1 point; 
in a 10-point font, 1 em corresponds to 10 points. Kerning and tracking units are 1/1000 
em. So, for example, 100 units in a 10-point font are equivalent to 1 point. 

Default tracking (left), and tracking set to 350 (right)

To use a font’s built-in kerning information:

In the Character palette, choose Metrics or Optical (Photoshop) or Auto (ImageReady) 
from the Kerning menu .

To adjust kerning manually:

1 Click with a type tool to set an insertion point between two characters.

Note: If a range of type is selected, you can’t manually kern the characters. Instead, use 
tracking.

2 In the Character palette, enter or select a numeric value for Kerning .

3 Commit the changes to the type layer. (See “About using the type tools (Photoshop)” 
on page 439.)
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To specify tracking:

1 Select the type you want to adjust.

2 In the Character palette, enter a numeric value or choose a numeric value from the 
pop-up menu for Tracking .

Adjusting horizontal or vertical scale
Horizontal scale and vertical scale specify the proportion between the height and width of 
the type. Unscaled characters have a value of 100%. You can adjust scale to compress or 
expand selected characters in both width and height.

To adjust the horizontal or vertical scale of type:

In the Character palette, enter a new percentage for Horizontal Scale  or Vertical 
Scale .

Specifying baseline shift
Baseline shift controls the distance that type appears from its baseline, either raising or 
lowering the selected type to create superscripts or subscripts. 

Default baseline shift (left), and baseline shift of 10 points (right)

To specify baseline shift:

1 Select the type that you want raised or lowered.

2 In the Character palette, enter a value for Baseline Shift . A positive value moves 
horizontal type above and vertical type to the right of the baseline; a negative value 
moves type below or to the left of the baseline.

Changing case
You can enter or format type as uppercase characters, either all caps or small caps. When 
you format type as small caps, Photoshop and ImageReady use the small caps designed as 
part of the font (if available). If the font does not include small caps, Photoshop and 
ImageReady generate faux small caps.
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To change the case of type:

1 Select the type that you want to change.

2 Do one of the following:

• Click the All Caps button   or the Small Caps button  in the Character palette. 

• Choose All Caps or Small Caps from the Character palette menu. A check mark indicates 
that the option is selected.

Note: Selecting Small Caps will not change characters that were originally typed 
in uppercase.

Making characters superscript or subscript
You can enter or format type as superscript or subscript characters. Superscript characters 
are reduced in size and shifted above the type baseline; subscript characters are reduced 
in size and shifted below the type baseline. If the font does not include superscript or 
subscript characters, Photoshop generates faux superscript or subscript characters.

To specify superscript or subscript characters:

1 Select the type you want to specify.

2 Do one of the following:

• Click the Superscript button  or the Subscript button  in the Character palette. 

• Choose Superscript or Subscript from the Character palette menu. A check mark 
indicates that the option is selected.

Applying underline and strikethrough
You can apply a line under horizontal type, or to the left or right of vertical type. You can 
also apply a line through horizontal or vertical type. The line is always the same color as 
the type color.

To apply an underline or strikethrough:

1 Select the type you want to underline or strikethrough.

2 Choose an option:

• Click the Underline button  in the Character palette to apply an underline beneath 
horizontal type.

• Choose Underline Left or Underline Right from the Character palette menu to apply an 
underline to the left or right of vertical type. You can apply an underline to the left or 
right, but not to both sides. A check mark indicates that an option is selected.

Note: The Underline Left and Underline Right options appear in the Character palette 
menu only when a type layer containing vertical type is selected.

• Click the Strikethrough button  in the Character palette to apply a horizontal line 
through horizontal type or a vertical line through vertical type. Alternately, choose 
Strikethrough from the Character palette menu.
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Using Dynamic Shortcuts
Dynamic Shortcuts are keyboard shortcuts that are only accessible when you are entering 
point or paragraph type, when type is selected, or when the I-beam is in text. You can view 
Dynamic Shortcuts in the Character palette menu when they are accessible. Dynamic 
Shortcuts are available for type options such as Faux Bold, Faux Italic, All Caps, Small Caps, 
Superscript, Subscript, Underline, and Strikethrough. 

Dynamic shortcuts display in the Character palette menu only when you are entering point or 
paragraph type, when type is selected, or when the I-beam is in text.

Using fractional character widths
By default, type is displayed using fractional character widths. This means that the spacing 
between characters varies, with fractions of whole pixels between some characters. In 
most situations, fractional character widths provide the best spacing for type appearance 
and readability. However, for type in small sizes (less than 20 points) displayed online, 
fractional character widths can cause type to run together or have too much extra space, 
making it difficult to read.

You can turn off fractional character widths to fix type spacing in whole-pixel increments 
and prevent small type from running together. The fractional character width setting 
applies to all characters on a type layer—you cannot set the option for selected 
characters.

To turn fractional character widths on or off:

Choose Fractional Widths from the Character palette menu. A check mark indicates that 
the option is selected. 

Viewing text using the operating system layout
The System Layout command lets you preview text using the operating system’s default 
text handling. This is useful when designing user interface elements, such as dialog boxes 
and menus.

To turn system layout on or off:

Choose System Layout from the Character palette menu. A check mark indicates that the 
option is selected. 
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Rotating vertical type
When working with vertical type, you can rotate the direction of characters by 90°. 
Rotated characters appear upright; unrotated characters appear sideways (perpendicular 
to the type line). 

Original type (left), and type without vertical rotation (right)

To rotate characters in vertical type:

1 Select the vertical type you want to rotate or unrotate.

2 Choose Standard Vertical Roman Alignment from the Character palette menu. A check 
mark indicates that the option is selected. 

Note: You cannot rotate double-byte characters (full width characters only available in 
Chinese, Japanese, and Korean fonts). Any double-byte characters in the selected range 
will not be rotated.

Applying Open Type features to characters
When working with Open Type fonts, you can use old style figures, ordinals, swash, titling, 
connection forms, stylistic alternates, ornaments, ligatures, discretionary ligatures, and 
fractions if the font provides them. For Japanese Open Type fonts, you can use ligatures, 
discretionary ligatures, Fractions Japanese 78, Japanese Expert, Japanese Traditional, 
Proportional Metrics, Kana, and italics if the font provides them. For more information on 
Japanese Open Type fonts, see “Using Asian Open Type fonts” on page 466.

To apply Open Type features:

1 Make sure you have an Open Type font chosen when using the Type tool.

2 From the Character palette menu, choose one of the following:

Old Style Are numerals shorter than regular numerals, with some old style numerals 
descending below the type baseline.

Ordinals Automatically formats ordinal numbers (such as 1st and 2nd) with superscript 
characters. Characters such as the superscript in the Spanish words segunda and segundo 
(2a and 2o) are also typeset properly.

Swash Substitutes swash glyphs (stylized letterforms with extended strokes).

Titling Formats characters (usually all in capitals) designed for use in large-size settings, 
such as titles.

Connection Forms Are alternate forms that provide better joining behavior. 
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Stylistic Alternate Formats stylized characters that create a purely aesthetic effect. 

Ornaments Are devices that add a personal signature to the type family and can be used 
as title page decoration, paragraph markers, dividers for blocks of text, or as repeated 
bands and borders.

Ligatures Are typographic replacements for certain pairs of characters, such as fi, fl, ff, ffi, 
and ffl.

Type with Ligatures option unselected and selected

Discretionary Ligatures Are typographic replacement characters for letter pairs such as 
ct, st, and ft. 

Fractions Automatically formats fractions, numbers separated by a slash (such as 1/2) are 
converted to a fraction (such as 1/2).

Checking for spelling errors (Photoshop)
When you spell-check a document, Photoshop questions any words that aren’t in its 
dictionary. If a questioned word is spelled correctly, you can confirm its spelling by adding 
the word to the dictionary. If a questioned word is misspelled, you can correct it. 

To check and correct spelling:

1 In the Character palette, choose a language from the pop-up menu at the bottom of 
the palette. This sets the dictionary for spell-checking.

2 (Optional) Show or unlock type layers. The Check Spelling command does not check 
hidden or locked layers.

3 Do one of the following:

• Select a type layer. 

• To check specific text, select the text.

• To check a word, place an insertion point in the word.

4 Choose Edit > Check Spelling.

5 As Photoshop finds unfamiliar words and other possible errors, do one of the following:

• Click Ignore to continue checking spelling without changing text. Click Ignore All to 
ignore the questioned word for the rest of the spell-check.

• To correct a misspelling, make sure the correctly spelled word is in the Change To text 
box and click Change. If the suggested word is not the word you want, you can select a 
different word in the Suggestions text box or enter the word in the Change To text box.
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• To correct a repeated misspelling in a document, make sure the correctly spelled word 
is in the Change To text box and click Change All.

• Click Add to have Photoshop store the unrecognized word in the dictionary, so that 
subsequent occurrences are not flagged as misspellings.

• If you selected a type layer and want to spell-check only that layer, deselect Check All 
Layers.

Finding and replacing text (Photoshop)
You can search for a single character, a word, or group of words. Once you find what you’re 
looking for, you can change it to something else. 

To find and replace a word:

1 (Optional) Show or unlock type layers. The Find and Replace Text command does not 
check hidden or locked layers.

2 Do one of the following:

• Select the layer that contains the text you want to find and replace.

• Select a nontype layer if you have more than one text layer and you want to search 
through all layers in the document.

3 (Optional) If you selected a layer containing text, place an insertion point at the 
beginning of portion of text you want to search.

4 Choose Edit > Find and Replace Text.

5 In the Find What box, type or paste the text you want to find. To change the text, type 
the new text in the Change To text box.

6 Select one or more of the following options to refine your search:

Search All Layers Searches all layers in a document. This option is available when a non-
type layer is selected in the Layers palette.

Forward Searches forward from an insertion point in the text. Deselecting this option 
searches the entire text in a layer regardless of where an insertion point has been placed.

Case Sensitive Searches for a word or words that exactly match the case of the text in the 
Find What text box. For example, with the Case Sensitive option selected, a search for 
“PrePress” will not find “Prepress” or “PREPRESS.”

Whole Word Only Disregards the search text if it is embedded within a larger word. 
For example, if you are searching for “any” as a whole word, “many” will be disregarded.

7 Click Find Next to begin the search.

8 Click the button that reflects what you want to do next.

• Change replaces the found text with the revised text. To repeat the search, select 
Find Next.

• Change All searches for and replaces all occurrences of the found text. 

• Change/Find replaces the found text with the revised text and then searches for the 
next occurrence.
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Formatting paragraphs
A paragraph is any range of type with a carriage return at the end. You use the Paragraph 
palette to set options that apply to entire paragraphs, such as the alignment, indentation, 
and space between lines of type. For point type, each line is a separate paragraph. For 
paragraph type, each paragraph can have multiple lines, depending on the dimensions of 
the bounding box.

Selecting paragraphs and showing the Paragraph palette
You can use the Paragraph palette to set formatting options for a single paragraph, 
multiple paragraphs, or all paragraphs in a type layer. 

To select paragraphs for formatting:

1 Do one of the following:

• (Photoshop) Select the Horizontal Type tool  or the Vertical Type tool .

• (ImageReady) Select the Type tool .

2 Select paragraphs by doing one of the following:

• Click in a paragraph to apply formatting to a single paragraph.

• Make a selection within a range of paragraphs to apply formatting to multiple 
paragraphs.

• Select the type layer in the Layers palette to apply formatting to all paragraphs in the 
layer.

To show the Paragraph palette:

Do one of the following:

• Choose Window > Paragraph, or click the Paragraph palette tab if the palette is visible 
but not active.

• With a type tool selected, click the Palette button  in the options bar.

Aligning and justifying type
You can align type to one edge of a paragraph (left, center, or right for horizontal type; top, 
center, or bottom for vertical type) and justify type to both edges of a paragraph. 
Alignment options are available for both point type and paragraph type; justification 
options are only available for paragraph type.

To specify alignment:

1 Do one of the following:

• Select a type layer if you want all the paragraphs contained in that type layer to be 
affected.

• Select the paragraphs you want affected.

2 In the Paragraph palette or options bar, click an alignment option. The options for 
horizontal type are:

 Aligns type to the left, leaving the right edge of the paragraph ragged

 Aligns type to the center, leaving both edges of the paragraph ragged

 Aligns type to right, leaving the left edge of the paragraph ragged
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The options for vertical type are:

 Aligns type to the top, leaving the bottom edge of the paragraph ragged

 Aligns type to the center, leaving both the top and bottom edges of the paragraph 
ragged

 Aligns type to bottom, leaving the top edge of the paragraph ragged

To specify justification for paragraph type:

1 Do one of the following:

• Select a type layer if you want all the paragraphs contained in that type layer to be 
affected.

• Select the paragraphs you want affected.

2 In the Paragraph palette, click a justification option. The options for horizontal type are: 

 Justifies all lines except the last, which is left-aligned

 Justifies all lines except the last, which is center-aligned

 Justifies all lines except the last, which is right-aligned

 Justifies all lines including the last, which is force-justified

The options for vertical type are:

 Justifies all lines except the last, which is top-aligned

 Justifies all lines except the last, which is center-aligned

 Justifies all lines except the last, which is bottom-aligned

 Justifies all lines including the last, which is force-justified

Note: Justification (right, center, and left align, and justify all) for type on a path starts at 
the insertion point and ends at the end of path.

Indenting paragraphs
Indentation specifies the amount of space between type and the bounding box or line 
that contains the type. Indentation affects only the selected paragraph or paragraphs, 
so you can easily set different indentations for paragraphs.

To specify paragraph indentation:

1 Do one of the following:

• Select a type layer if you want all the paragraphs contained in that type layer to be 
affected.

• Select the paragraphs you want affected.

2 In the Paragraph palette, enter a value for an indentation option: 

• Indent Left Margin  to indent from the left edge of the paragraph. For vertical type, 
this option controls the indentation from the top of the paragraph.

• Indent Right Margin  to indent from the right edge of the paragraph. For vertical type, 
this option controls the indentation from the bottom of the paragraph.
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• Indent First Line  to indent the first line of type in the paragraph. For horizontal type, 
the first line indent is relative to the left indent; for vertical type, the first line indent is 
relative to the top indent. To create a first line hanging indentation, enter a negative 
value.

Changing space above or below paragraphs
You can control the space above and below paragraphs using the paragraph spacing 
options.

To specify paragraph spacing:

1 Do one of the following:

• Select a type layer if you want all the paragraphs contained in that type layer to be 
affected.

• Select the paragraphs you want affected.

2 In the Paragraph palette, enter a value for Space Before  and Space After .

Specifying hanging punctuation
Hanging punctuation controls whether punctuation marks fall inside or outside the 
margins. If hanging punctuation is turned on for Roman fonts, then periods, commas, 
single-quotation marks, double-quotation marks, apostrophes, hyphens, em dashes, 
en dashes, colons, and semicolons appear outside the margins.

To use hanging punctuation for Roman fonts:

1 Do one of the following:

• Select a type layer if you want all the paragraphs contained in that type layer to be 
affected.

• Select the paragraphs you want affected.

2 Choose Roman Hanging Punctuation from the Paragraph palette menu. A check mark 
indicates that the option is selected.

Note: When you use Roman Hanging Punctuation, any double-byte punctuation marks 
available in Chinese, Japanese, and Korean fonts in the selected range will not hang. 
See “Using burasagari” on page 470.

Controlling hyphenation and justification
The settings you choose for hyphenation and justification affect the horizontal spacing of 
lines and the aesthetic appeal of type on a page. Hyphenation options determine whether 
words can be hyphenated and, if they can, what breaks are allowable. Justification options 
determine word, letter, and glyph spacing.

Note: Hyphenation and justification settings apply only to Roman characters; double-byte 
characters available in Chinese, Japanese, and Korean fonts are not affected by these 
settings. See “Working with Japanese composition” on page 468.
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Adjusting hyphenation
You can hyphenate words manually or automatically. 

Note: You can apply hyphenation to specific paragraphs by first selecting only the 
paragraphs in a type layer that you want to affect.

To choose a hyphenation dictionary:

Choose a language from the pop-up menu at the bottom of the Character palette

To turn automatic hyphenation on or off:

In the Paragraph palette, select or deselect the Hyphenate option.

To set automatic hyphenation options:

1 Choose Hyphenation from the Paragraph palette menu.

2 Enter values for the following options: 

• Words Longer Than _ Letters to specify the minimum number of characters for 
hyphenated words. The default value is 5 letters.

• After First _ Letters and Before Last _ Letters to specify the minimum number of 
characters at the beginning or end of a word that can be broken by a hyphen. For 
example, by specifying 3 for these values, aromatic would be hyphenated as aro- matic 
instead of ar- omatic or aromat- ic.

• Hyphen Limit to specify the maximum number of hyphens that can appear on consec-
utive lines. Zero means unlimited hyphens.

• Hyphenation Zone to specify the distance at the end of a line that will cause a word to 
break in unjustified type. This option applies only when using the single-line composer. 
See “About composition methods” on page 463.

3 To prevent capitalized words from being hyphenated, deselect Hyphenate Capitalized 
Words. Then click OK.

Preventing unwanted word breaks
You can prevent words from breaking at the end of lines—for example, proper names or 
words whose break might have a misleading appearance. You also can keep multiple 
words from breaking—for example, clusters of initials and a last name.

To prevent characters from breaking:

1 Select the characters you want to prevent from breaking.

2 Choose No Break from the Character palette menu. 

Note: If many contiguous characters are entered with the No Break option selected, there 
won’t be a forced wrap. However, none of the type may be visible once the number of 
characters exceed the type boundaries.

Adjusting spacing
You can precisely control the way in which Photoshop and ImageReady space letters and 
words and scale characters. Adjusting spacing options is especially useful when working 
with justified type, although you can also adjust spacing for unjustified type.
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Word spacing refers to the space between words that is created by pressing the spacebar. 
Letter spacing refers to the distance between letters and includes kerning or tracking 
values. Glyph spacing refers to the width of characters (a glyph is any font character).

Spacing options are always applied to an entire paragraph. To adjust the spacing in a few 
characters but not an entire paragraph, use the Tracking option.

To set spacing options:

1 Do one of the following:

• Select a type layer if you want all the paragraphs contained in that type layer to be 
affected.

• Select the paragraphs you want affected.

2 Choose Justification from the Paragraph palette menu.

3 Enter values for Word Spacing, Letter Spacing, and Glyph Spacing:

• For justified type only, enter values for Minimum and Maximum to define a range of 
acceptable spacing. 

• Enter a value for Desired to set the spacing for both justified and unjustified 
paragraphs. 

Word Spacing values can range from 0% to 1000%; at 100%, no additional space is added 
between words. Letter Spacing values can range from –100% to 500%; at 0%, no space is 
added between letters. Glyph Spacing values can range from 50% to 200%; at 100%, the 
width of characters is not scaled.

Working with composition
The appearance of type on the page depends on a complex interaction of processes called 
composition. Using the word spacing, letter spacing, glyph spacing, and hyphenation 
options you’ve selected, Photoshop and ImageReady evaluate possible line breaks and 
choose the one that best supports the specified parameters.

About composition methods
Photoshop and ImageReady offer two composition methods: the Adobe Every-line 
Composer and the Adobe Single-line Composer. Both composition methods evaluate 
possible breaks and choose the one that best supports the hyphenation and justification 
options you’ve specified for a given paragraph.

The Adobe Every-line Composer Considers a network of break points for a range of 
lines and thus optimizes earlier lines in the paragraph in order to eliminate especially 
unattractive breaks later on. Working with multiple lines of type results in more even 
spacing and fewer hyphens.

The Adobe Every-line composer approaches composition by identifying possible break-
points, evaluating them, and assigning a weighted penalty based on these principles:

• The highest importance is given to evenness of letter and word spacing. Possible break-
points are evaluated and penalized according to how much they deviate from optimal 
spacing.

• Hyphenation is avoided when possible. Breakpoints that require hyphenation are 
penalized more than those that create uneven spacing. 
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• Good breakpoints are preferred over bad breakpoints. After breakpoint penalty values 
are identified for a range of lines, they are squared, magnifying the bad breakpoints. 
The composer then uses the good breakpoints.

The Adobe Single-line Composer Offers a traditional approach to composing type one 
line at a time. This option is useful if you prefer to have manual control over how lines 
break. The Adobe Single-line composer uses the following principles when considering a 
breakpoint:

• Compressed or expanded word spacing is preferable to hyphenation.

• Hyphenation is preferable to compressed or expanded letter spacing.

• If spacing must be adjusted, compression is better than expansion.

Choosing a composition method
You use the Paragraph palette to choose a composition method for selected paragraphs.

To choose a composition method for a paragraph:

Choose Adobe Every-line Composer or Adobe Single-line Composer from the Paragraph 
palette menu. A check mark indicates which option is selected.

Setting options for Asian type (Photoshop)
Photoshop provides several options for working with Chinese, Japanese, and Korean type. 
Characters in Asian fonts are often referred to as double-byte characters. 

Displaying Asian type options
In order to view and set options for working with Chinese, Japanese, and Korean type, you 
must select Show Asian Text Options in the Preferences dialog box. You can also control 
how font names are displayed—in English or in the native language.

To display Asian type options:

1 Do one of the following:

• In Windows, Choose Edit > Preferences > General.

• In Mac OS, Choose Photoshop > Preferences > General.

2 Select Show Asian Text Options.

To display CJK font names in English:

1 Do one of the following:

• In Windows, Choose Edit > Preferences > General.

• In Mac OS, Choose Photoshop > Preferences > General.

2 Select Show Font Names in English.
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Adjusting tsume
Tsume reduces the space around a character by a specified percentage value. As a result, 
the character itself is not stretched or squeezed. Instead, the space between the 
character’s bounding box and the em box is compressed. When tsume is added to a 
character, spacing around both sides of the character is reduced by an equal percentage.

To reduce spacing between characters:

1 Select the characters you want to adjust.

2 In the Character palette, enter or select a percentage for Tsume . The greater the 
percentage, the tighter the compression between characters. At 100% (the maximum 
value), there is no space between the character’s bounding box and its em box.

Specifying how leading is measured
Top-to-top leading measures the spacing between lines of type from the top of one line to 
the top of the next line. This is different from Bottom-to-bottom leading, which measures 
the space between lines from the type baseline. If you use Top-to-top leading, the first 
line of type in a paragraph is aligned flush with the top of the bounding box; if you use 
Bottom-to-bottom leading, space appears between the first line of type and the 
bounding box.

The leading option you choose does not affect the amount of leading between lines, only 
how the leading is measured. (See “Specifying leading” on page 451.)

Note: Top-to-top Leading and Bottom-to-bottom Leading are not available for vertical 
text.

To specify how leading is measured:

1 Select the paragraphs you want to adjust.

2 Choose Top-to-top Leading or Bottom-to-bottom Leading from the Paragraph palette 
menu. A check mark indicates which option is selected.

Using tate-chuu-yoko
Tate-chuu-yoko (also called kumimoji and renmoji) is a block of horizontal type laid out 
within a vertical type line.

Before (left) and after (right) tate-chuu-yoko applied
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To turn on or turn off tate-chuu-yoko:

1 Select the characters that you want to rotate.

2 Choose Tate-Chuu-Yoko from the Character palette menu. A check mark indicates that 
the option is turned on.

Note: Using tate-chuu-yoko does not prevent you from editing and formatting type; you 
can edit and apply formatting options to rotated characters as you do to other characters.

Specifying left and right underlining
When working with vertical type, you can add an underline on either side of the type line. 
For more information, see “Applying underline and strikethrough” on page 454.

Using Asian Open Type fonts
Asian Open Type fonts may include a number of features that aren’t available in current 
PostScript and TrueType fonts. It is recommended to use any weights of KozMinPro and 
KozGoPro Open Type fonts. These fonts have the largest collection of glyphs of the Asian fonts 
produced by Adobe.

To apply Asian Open Type font attributes:

1 In the Character palette, make sure that an Asian Open Type Pro font is selected.

2 From the Character palette menu, choose an Open Type option. 

Ligatures Creates the standard Roman character ligatures fi, fl, ff, ffl, and ffi.

Discretionary Ligatures Are typographic replacement characters for letter pairs 
such as ct, st, and ft. This includes Roman letter and Kanji that become symbols and 
multicharacter ligatures.

Fractions Substitutes the expression of “number(s)/number(s)” characters with the 
pre-made glyph that represents the fractional expression. This substitution covers propor-
tional, half-width, and full-width fractions. But the fractional expression must be using the 
consistent numbers for the whole expression.

Japanese 78 Substitutes the standard glyph with the jp78-variant glyph.

Japanese Expert Substitutes the standard glyph with the expert-variant glyphs. 

Japanese Traditional Substitutes the standard glyph with the traditional-variant glyph.

Proportional Matrix Substitutes the half-width and the full-width glyph with the 
proportional glyph.

Kana Substitutes the standard kana glyph with the horizontally optimized kana glyph for 
horizontal layout. However, the differences are often very subtle.

Italics Substitutes the standard proportional glyph with the italic glyph.

3 Turn on the MSIME (Windows) or Kotoeri (Mac OS) input method.

4 Do one of the following:

• (Windows) Choose OS Start Menu > Accessory > System Tools > Character Code Table.

• (Mac OS) Select Kotoeri input method by choosing Show Character Palette from the 
Kotoeri menu.
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5 Do one of the following:

• (Windows) In the Character Code Table, select the Show Details option, and then 
choose All for Group and choose Unicode for Character Set.

Character Code Table 
A. Font menu B. Show Details checkbox

• (Mac OS) In the Kotoeri Character palette, set the display to All and then click the Glyph 
Catalog tab.

Kotoeri Character palette 
A. View option B. Show More Options C. Font information

6 (Mac OS) Set the Kotoeri Character palette font to the Open Type font you are using.

7 Do one of the following:

• (Windows) Select the character you want to use, click the Choose button, and then 
copy and paste it.

• (Mac OS) Click the More Options button , select the character you want to use, and 
then either double-click the character or click the Input button.

A

B

A

C

B
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Working with Japanese composition
The Paragraph palette includes several options for composing Japanese characters.

Kinsoku Shori Determines line breaks in Japanese type. Characters that cannot begin a 
line or end a line are known as kinsoku characters. Photoshop includes weak and 
maximum kinsoku sets based on the Japanese Industrial Standard (JIS) X 4051-1995. 

Mojikumi Determines spacing between punctuation, symbols, numbers, and other 
character classes in Japanese type. Photoshop includes several predefined mojikumi sets 
based on the Japanese Industrial Standard (JIS) X 4051-1995. 

Oidashi and Oikomi When kinsoku shori or mojikumi is on, you can choose different 
methods for processing line breaks. Oidashi—push-out line breaking—is a method of 
moving characters down to the next line in order to prevent prohibited characters from 
ending or beginning a line. Oikomi—push-in line breaking—is a method of moving 
characters up to the previous line in order to prevent prohibited characters from ending or 
beginning a line.

To select a mojikumi set for a paragraph:

In the Paragraph palette, choose an option from the Mojikumi pop-up menu:

• None to turn off the use of mojikumi

• Mojikumi Set 1 to use half-width spacing for punctuation

• Mojikumi Set 2 to use full-width spacing for most characters except the last character in 
the line

Mojikumi Set 1, and Mojikumi Set 2

• Mojikumi Set 3 to use full-width spacing for most characters and the last character in 
the line
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• Mojikumi Set 4 to use full-width spacing for all characters

Mojikumi Set 3, and Mojikumi Set 4

To select a kinsoku shori set for a paragraph:

In the Paragraph palette, choose an option from the Kinsoku Shori pop-up menu:

• None to turn off the use of kinsoku shori

• JIS Weak or JIS Maximum to prevent the following characters from beginning or ending 
a line: 

To select a kinsoku line breaking option:

Choose Oidashi or Oikomi from the Paragraph palette menu. A check mark indicates 
which option is selected.

JIS Weak Set

Characters that can’t begin a line

Characters that can’t end a line

JIS Maximum Set

Characters that can’t begin a line

Characters that can’t end a line
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Using burasagari
Burasagari allows single-byte periods, double-byte periods, single-byte commas, and 
double-byte commas to fall outside the paragraph bounding box. 

To turn on or turn off burasagari:

Choose one of the following options from the Paragraph palette menu:

None Disables Japanese hanging punctuations when a Kinsoku set is in effect. Kinsoku 
Shori can still cause push-in or push-out behavior but does not hang Burasagari characters 
on or immediately outside the text frame.

Burasagari Standard Is the default Burasagari option. The Standard option enables 
Japanese hanging punctuations but allows Burasagari characters to hang as little as 
possible. With the Standard option, the behavior varies whether the line is justified or 
nonjustified.

Burasagari Strong Enables Japanese hanging punctuation but forces the punctuation 
outside of the text frame when it needs to hang, regardless of the justification or 
alignment setting. A hanging punctuation will never be placed on the text frame as in 
Burasagari Standard. Also, the position of the hanging punctuation can cause a slight 
expansion, even for nonjustified text.
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Designing Web Pages

About designing Web pages with Photoshop and 
ImageReady
When designing Web pages using Photoshop and ImageReady, keep in mind the tools 
and features that are available in each application. 

• Photoshop provides tools for creating and manipulating static images for use on the 
Web. You can divide an image into slices, add links and HTML text, optimize the slices, 
and save the image as a Web page. 

• ImageReady is designed for professional Web page layout. You can more easily work 
with layers as if they were independent objects: selecting, grouping, aligning, and 
arranging them. In addition, ImageReady includes tools and palettes for advanced Web 
processing and creating dynamic Web images like animations and rollovers. 

The graphics tools and features in Photoshop and ImageReady simplify most Web 
design tasks:

Page design In ImageReady, preset document sizes for pages and banners, grids, 
guidelines, and smart guides simplify page layout. Both Photoshop and ImageReady let 
you add content to layouts using the text, drawing, and painting tools. In ImageReady, you 
can arrange and align content using layers, layer sets, and grouped layers. To experiment 
with different page compositions or to export variations of a page, use the Layer Comps 
palette. See “About layer comps and the Layer Comps palette” on page 405.

Slices When your page composition is ready for output to the Web, both Photoshop and 
ImageReady provide the Slice tool to let you divide page layouts or complex graphics into 
areas and specify independent compression settings (and smaller file sizes). (See “Creating 
and viewing slices” on page 472.)

Rollovers The Web Content palette in ImageReady enables you to track slices and their 
rollover states. For example, you can create a button for a Web page that glows whenever 
the user moves the pointer over it, and you can manage the button states and activities in 
those states. (See “About slices” on page 472.)

Animations For creating simple Web animations, ImageReady provides the Animation 
palette, giving you the ability to determine, frame by frame, the appearance of an 
animation that can be exported as an animated GIF or SWF file. You can create animation 
in conjunction with sets of slices, nested tables, percentage width tables, and remote 
rollovers, where you mouse over one image and a different image changes. 



Using Help | Contents | Index Back 472  

Adobe Photoshop CS Help Designing Web Pages 

Using Help | Contents | Index Back 472  

Export and image optimization When your page or graphic is ready for final export, the 
Save For Web dialog in Photoshop and the Optimization palette in ImageReady enables 
you to precisely determine how the page or graphic should be exported. Additionally, you 
can export an HTML file with the actual images. This text file instructs a browser how to 
properly display exported images and rollover effects. (See “Setting HTML output options” 
on page 489.)

Note: You can preview most Web effects directly in Photoshop or ImageReady. However, 
the appearance of an image on the Web depends on the operating system, color display 
system, and browser used to display the image. Be sure to preview images and pages in 
different browsers, on different operating systems, and with different color bit depths. 
(See “Previewing an image in a browser” on page 51.) Remote rollovers are best previewed 
in a browser.

Preparation in Adobe GoLive Additionally, Photoshop and ImageReady files can be 
opened directly in Adobe GoLive. Slices, URLs, and other Web features in Photoshop files 
are accessible in GoLive for management and editing. For more information on using 
GoLive, see the Adobe GoLive User Guide.

Automating the workflow Photoshop and ImageReady have a robust system that 
enables you to automate repetitive tasks. For example, ImageReady droplets allow 
designers to quickly convert a batch of images into a Web-ready format. (See “Automating 
Tasks” on page 627.)

Creating and viewing slices
A slice is a rectangular area of an image that you can use to create links, rollovers, and 
animations in the resulting Web page. Dividing an image into slices allows you both finer 
functional control and better file size optimization of your image.

About slices
You use slices to divide a source image into functional areas. When you save both the 
image and an HTML file, each slice is saved as an independent file with its own settings 
and color palette, and the proper links, rollover effects, and animation effects are 
preserved. 

Slices are also advantageous when working with images that contain different types of 
data. For example, if one area of an image needs to be optimized in GIF format to support 
an animation, but the rest of the image is better optimized in JPEG format, you can isolate 
the animation using a slice.
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Web page divided into slices with a highlighted rollover slice

To work with slices:

• Create a slice. (See “Creating and viewing slices” on page 472 and “Creating layer-based 
slices” on page 475.) After you create a slice, you can select it using the Slice Select 
tool  and then move or resize it.

• Set options for each slice—such as content type, name, and URL—in the Slice Options 
dialog box (Photoshop) or the Slice palette (ImageReady). (See “Setting HTML output 
options” on page 489).

• Align slices in ImageReady. You can also set values in the Output Settings dialog box 
that will generate HTML code to align your slices. These values use tables or cascading 
style sheets. (See “Setting output options” on page 616.)

Types of slices
Slices are categorized by their content type (auto, image, no-image, table) and by the way 
they are created (user, layer-based). For information on slice content types, see “Choosing 
a content type” on page 490.

Slices you create using the Slice tool are called user slices; slices you create based on the 
content of a layer are called layer-based slices. When you create a new user slice or layer-
based slice, additional auto slices are generated to account for the remaining areas of the 
image. In other words, auto slices fill the space in the image that is not defined by user 
slices or layer-based slices. Auto slices are regenerated every time you add or edit user 
slices or layer-based slices. You can convert auto slices to user slices. Table slices contain 
nested tables.

User slices, layer-based slices, and auto slices look different—user slices and layer-based 
slices are defined by a solid line, while auto slices are defined by a dotted line. In addition, 
each type of slice displays a distinct icon. You can choose to show or hide auto slices, 
which can make your work with user- and layer-based slices easier to view.

A subslice is a type of auto slice that is generated when you create overlapping slices. 
Subslices indicate how the image will be divided when you save the optimized file. 
Although subslices are numbered and display a slice symbol, you cannot select or edit 
them separately from the underlying slice. Subslices are regenerated every time you 
arrange the stacking order of slices.
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Slices are created using different methods:

• Auto slices are automatically generated by ImageReady.

• User slices are created with the Slice tool. (See “Creating user slices” on page 474.)

• Layer-based slices are created with the Layers palette. (See “Creating layer-based slices” 
on page 475.)

• Table slices are created with the Web Content palette. (See “Creating tables” on 
page 487.)

Creating user slices
You can create user slices with the Slice tool or from guides.

To create a slice with the Slice tool:

1 Select the Slice tool . Any existing slices automatically display in the document 
window. 

2 Choose a style setting in the options bar:

• Normal to determine slice proportions by dragging. 

• Fixed Aspect Ratio to set a height-to-width ratio. Enter whole numbers or decimals for 
the aspect ratio. For example, to create a slice twice as wide as it is high, enter 2 for the 
width and 1 for the height. 

• Fixed Size to specify the slice’s height and width. Enter pixel values in whole numbers. 

3 Drag over the area where you want to create a slice. Shift-drag to constrain the slice to a 
square. Alt-drag (Windows) or Option-drag (Mac OS) to draw from the center. Use  View > 
Snap To align a new slice to a guide or another slice in the image. (See “Moving and 
resizing user slices” on page 480.)

To create slices from guides:

1 Add guides to an image. (See “Using guides and the grid” on page 43.)

2 Do one of the following:

• (Photoshop) Select the Slice tool, and click Slices From Guides in the options bar.

• (ImageReady) Choose Slices > Create Slices from Guides. 

When you create slices from guides, any existing slices are deleted. 

To create a slice from a selection (ImageReady):

1 Select a portion of the image.

2 Choose Select > Create Slice from Selection.

ImageReady creates a user slice based on the selection marquee. If the selection is 
feathered, the slice covers the full selection (including the feathered edges). If the 
selection is nonrectangular, the slice covers a rectangular area large enough to enclose 
the full selection. 
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Creating layer-based slices
When you create a slice from a layer, the slice area encompasses all the pixel data in the 
layer. If you move the layer or edit the layer’s content, the slice area automatically adjusts 
to encompass the new pixels.

A layer-based slice is updated when the source layer is modified.

Layer-based slices are especially useful when working with rollovers. If you apply an effect 
to the layer—such as a drop shadow or glow—to create a rollover state, the slice automat-
ically adjusts to encompass the new pixels. However, do not use a layer-based slice when 
you plan to move the layer over a large area of the image during an animation, because 
the slice dimension may exceed a useful size. 

To create a slice from a layer:

1 Select a layer in the Layers palette. 

2 Choose Layer > New Layer Based Slice.

Converting auto slices to user slices
You can move, duplicate, combine, divide, resize, delete, arrange, align, and distribute user 
slices. You can also apply different optimization settings to user slices. In contrast, all auto 
slices in an image are linked and share the same optimization settings. This is because 
auto slices are regenerated every time you create or edit a user slice or layer-based slice. 

If you select an auto slice and link it to a user slice, the user slice will take on the optimi-
zation settings from the auto slice. If you select the user slice first, however, the auto slice is 
promoted to a user slice. Unlinking promotes auto slices to user slice status. (See “Linking 
slices (ImageReady)” on page 486.)

To convert an auto slice to a user slice:

1 Select an auto slice. In ImageReady, you can select multiple slices. (See “Selecting slices” 
on page 478.)

2 Do one of the following:

• (Photoshop) With the Slice Select tool selected, click Promote to User Slice in the 
options bar.

• (ImageReady) Choose Slices > Promote to User-slices.

Converting layer-based slices to user slices
Because a layer-based slice is tied to the pixel content of a layer, the only way to move, 
combine, divide, resize, and align it is to edit the layer. You can convert a layer-based slice 
to a user slice to unlink it from the layer.



Using Help | Contents | Index Back 476  

Adobe Photoshop CS Help Designing Web Pages 

Using Help | Contents | Index Back 476  

To convert a layer-based slice to a user slice:

1 Select a layer-based slice. In ImageReady, you can select multiple slices. (See “Selecting 
slices” on page 478.)

2 Do one of the following:

• (Photoshop) Click Promote to User Slice in the options bar.

• (ImageReady) Choose Slices > Promote to User-slices.

Viewing slices
You can view slices in Photoshop, the Photoshop Save for Web dialog box, and 
ImageReady. The following characteristics can help you identify and differentiate between 
slices:

Slice lines Define the boundary of the slice. Solid lines indicate that the slice is a user slice 
or layer-based slice; dotted lines indicate that the slice is an auto slice. 

Slice colors Differentiate user slices and layer-based slices from auto slices. By default, 
user slices and layer-based slices have blue symbols, while auto slices have gray symbols. 

In addition, ImageReady and the Photoshop Save for Web dialog box use color adjust-
ments to dim unselected slices. These adjustments are for display purposes only and do 
not affect the final image’s color. By default, the color adjustment for auto slices is twice 
the amount of that for user-slices.

Slice numbers Slices are numbered  from left to right and top to bottom, beginning in 
the upper left corner of the image. If you change the arrangement or total number of 
slices, slice numbers are updated to reflect the new order. 

Slice badges The Web Content palette uses a number of badges, or icons, to indicate 
certain conditions, and these icons also appear in the document itself:

•  User slice has Image content

•  User slice has No Image content

•  Slice is a layer-based slice 

•  Slice is linked 

•  Slice includes a rollover effect 

•  Slice contains the active rollover state

•  Slice is a nested table

•  Slice is a remote trigger 

•  Slice is a remote target

To show or hide slice badges (ImageReady):

1 In the Web Content palette, open the palette menu and choose palette options.

2 Check the Show Slice Badges box.
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To show or hide slice boundaries:

Do one of the following:

• Choose View > Show > Slices. To hide and show slices along with other items, use the 
Extras command. For more information, see “Working with Extras” on page 45.

• (ImageReady) Click the Visibility icon , located to the left of the slice in the Web 
Content palette.

Note: If you’ve turned off a slice’s visibility with the Slices Visibility icon, ImageReady 
doesn’t output that slice when you choose Save Optimized. This is similar to layer visibility 
functionality.

To show or hide auto slices:

Do one of the following:

• Select the Slice Select tool, and click Show Auto Slices or Hide Auto Slices in the 
options bar.

• Choose View > Show > Slices. Auto slices appear with the rest of your slices.

• (ImageReady) Choose View > Show > Auto Slices.

To show or hide slice numbers (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Guides, Grid, & Slices.

• In Mac OS, choose Photoshop > Preferences > Guides, Grid, & Slices.

2 Under Slices, click Show Slice Numbers.

To show or hide slice numbers and slice symbols (ImageReady):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Slices. 

• In Mac OS, choose ImageReady > Preferences > Slices.

2 Under Numbers and Symbols, select a size for display symbols:

• None to display no numbers or symbols

• The small icon to display small numbers and symbols

• The large icon to display large numbers and symbols

3 For Opacity, enter a value, or choose a value from the pop-up slider to change the 
opacity (transparency level) of the numbers and symbols display. 

To show slice lines only (ImageReady):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Slices.

• In Mac OS, choose ImageReady > Preferences > Slices.

2 Under Slice Lines, select Show Lines Only.
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To change the color of slice lines:

1 Do one of the following:

• (Photoshop) In Windows, choose Edit > Preferences > Guides, Grid, & Slices; in Mac OS, 
choose Photoshop > Preferences > Guides, Grid, & Slices.

• (ImageReady) In Windows, choose Edit > Preferences > Slices; in Mac OS, choose 
ImageReady > Preferences > Slices.

2 Under Slice Lines, choose a color from the Line Color pop-up menu.

Changing the color of slice lines automatically changes the color of selected slice lines to a 
contrasting color.

To change slice color adjustments (ImageReady):

1 Do one of the following:

• In Windows, choose Edit > Preferences > Slices.

• In Mac OS, choose ImageReady > Preferences > Slices.

2 Enter a value, or choose a value from the Color Adjustments pop-up slider for User 
slices, Auto slices, or both. (The User slices option controls color adjustments for both user 
slices and layer-based slices.)

The value determines by how much the brightness and contrast of unselected slices are 
dimmed. 

Selecting and modifying slices
You can move, duplicate, combine, divide, resize, delete, arrange, align, and distribute user 
slices. There are fewer options for modifying layer-based slices and auto slices; however, 
you can promote a layer-based slice or an auto slice to a user slice at any time. 

In Photoshop, you cannot combine, align, or distribute slices. Edit your document in 
ImageReady to access these slice-editing capabilities.

Selecting slices
You select a slice or multiple slices with the Slice Select tool. You can then modify the 
selected slices. 

In ImageReady, you can save, load, and delete slice selections. Using slice selections lets 
you reselect specific slices quickly and accurately. 

To select a slice:

Do one of the following:

• Select the Slice Select       tool  and click the slice in the image.When working with overlapping 
slices, click the visible section of an underlying slice to select it. 

• (Photoshop) Choose File > Save For Web. In the dialog box, use the Slice tool to select a 
slice.

When using either the Slice tool or the Slice Select tool, toggle between them by 
holding down Ctrl (Windows) or Command (Mac OS).

• (ImageReady) Select a slice in the Web Content palette.



Using Help | Contents | Index Back 479  

Adobe Photoshop CS Help Designing Web Pages 

Using Help | Contents | Index Back 479  

To select multiple slices (ImageReady):

With the Slice Select tool , do one of the following:

• Shift-click to add slices to the selection. 

• Click in an auto slice or outside the image area, and drag across the slices you want to 
select. (Clicking in a user slice and dragging moves the slice.)

• In the Web Content palette, shift-click multiple slices.

To select all the user slices in a document (ImageReady):

Choose Slices > Select All User Slices. This actually selects all nonauto slices, and includes 
layer-based slices in the selection.

To save a slice selection (ImageReady):

1 Select one or more slices.

2 Choose Slices > Save Slice Selection.

3 Enter a name in the Selection Name text box, and click OK.

To load a slice selection (ImageReady):

Choose Slices > Load Slice Selection, and select the name of the slice selection you want to 
load from the submenu. 

Note: You must save a slice selection before you can load it.

To delete a slice selection (ImageReady):

Choose Slices > Delete Slice Selection, and select the name of the slice selection you want 
to delete from the submenu. Deleting a slice selection does not delete the slices 
themselves.

Using slice sets (ImageReady)
In ImageReady, you can combine slices into sets, and toggle the visibility of those sets. 
This lets you create different configurations for your Web page, which is especially 
powerful when you combine this feature with layer comps. You can create unique slice 
sets to match your various layer comps. See “Working with layer comps” on page 405.

Note: You can only place a slice in one slice set at a time.

You work with slice sets in the Web Content palette.

To create a slice set:

1 Select one or more slices.

2 Do one of the following:

• Choose Slices > New Slice Set.
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• Click the New Slice Set button in the Web Content palette.

ImageReady Web Content palette with slice set

To toggle the visibility of a slice set:

In the Web Content palette, click the Visibility icon  to show or hide slice sets.

To delete a slice set:

1 In the Web Content palette, select the slice set you want to delete.

Note: If the slice set is not visible in the palette, expand the Slices section of the palette by 
clicking the arrow next to the Slices section header. 

2 Click the Delete Slice button  to remove the slice set. 

3 Choose one of the following:

• Set Only deletes just the set itself.

• Set and Contents deletes the set and all its slices.

Moving and resizing user slices
You can move and resize user slices in Photoshop and ImageReady, but not in the 
Photoshop Save for Web dialog box. You can also move and resize slices using numeric 
coordinates. (See “Resizing and moving slices using numeric coordinates” on page 481.)

To move or resize a user slice:

1 Select a user slice. In ImageReady, you can select and move multiple slices.

2 Do one of the following:

• To move a slice, move the pointer inside the slice selection border, and drag the slice 
to a new position. Press Shift to restrict movement to a vertical, horizontal, or 45° 
diagonal line.

• To resize a slice, grab a side or a corner handle of the slice, and drag to resize the slice. 
If you select and resize adjacent slices, common edges shared by the slices are resized 
together.
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To snap slices to a guide, user slice, or other object:

1 Select the options you want from the View > Snap To submenu, and choose to snap to 
grid, guides, layers, slices (ImageReady), image maps, document bounds (ImageReady), all, 
or none.

2 Choose View > Snap. (See “Using the Snap command” on page 246.) A check mark 
indicates that the option is turned on.

3 Move your selected slices as desired. The slices snap to any of your chosen objects 
within 4 pixels.

Note: For more information on moving objects with smart guides, see “Using guides and 
the grid” on page 43.

Resizing and moving slices using numeric coordinates
You can set the exact position and dimensions for a user slice using the Dimensions 
options of the Slice palette. In ImageReady, you can also set the exact position and dimen-
sions for a layer-based slice using the Layer Based Dimensions Pad options.

In ImageReady, if the Dimensions or Layer Based Dimensions Pad options aren’t showing, 
choose Show Options from the Slice palette menu, or click the Show Options button  on 
the palette tab to view them, and click the triangle to the left of the options you want 
displayed (such as the Layer Based Dimensions).

ImageReady Slice palette with Dimension options displayed

To resize or move a user slice using numeric coordinates (Photoshop):

1 Double-click the slice in the image with the Slice Select tool, and choose Slice Options 
from the menu bar.

2 In the Dimensions area of the Slice Options dialog box (Photoshop) or the Slice palette 
(ImageReady), change one or more of the following options:

• X to specify the distance in pixels between the left edge of the slice and the origin point 
of the ruler in the document window

• Y to specify the distance in pixels between the top edge of the slice and the origin point 
of the ruler in the document window

Note: The default origin point of the ruler is the upper left corner of the image. (See “Using 
guides and the grid” on page 43.)
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• W to specify the width of the slice

• H to specify the height of the slice

• Constrain Proportions to preserve the current proportions of the slice

To resize a layer-based slice using numeric dimensions (ImageReady):

1 Select a layer-based slice. 

2 In the Slice palette, in the Layer Based Dimensions options area, change one or more of 
the following Pad options:

• L to specify the distance in pixels between the left edge of the slice and the left edge of 
the layer’s content

• T to specify the distance in pixels between the top edge of the slice and the top edge of 
the layer’s content

• R to specify the distance in pixels between the right edge of the slice and the right edge 
of the layer’s content

• B to specify the distance in pixels between the bottom edge of the slice and the bottom 
edge of the layer’s content

Dividing user slices and auto slices 
The Divide Slice dialog box lets you divide slices horizontally, vertically, or both. In 
Photoshop, you can divide only one slice; in ImageReady, you can divide multiple slices at 
the same time. Divided slices are always user slices, regardless of whether the original is a 
user slice or an auto slice.

Note: You cannot divide layer-based or nested table slices.

To divide slices:

1 Select a slice. In ImageReady, you can select multiple slices.

2 Do one of the following:

• (Photoshop) With the Slice Select tool selected, click Divide Slice in the options bar.

• (ImageReady) Choose Slices > Divide Slice.

• (ImageReady) Choose Divide Slice from the Slice palette menu.

3 Select Preview in the Divide Slice dialog box to preview the changes.

4 In the Divide Slice dialog box, select one or both of the following options:

• Divide Horizontally Into to divide the slice lengthwise.

• Divide Vertically Into to divide the slice widthwise.

5 Define how you want to divide each selected slice:

• Select and enter a value for slices down or slices across to divide each slice evenly into 
the specified number of slices.

• Select and enter a value for pixels per slice to divide each slice based on the specified 
number of pixels. Any section of a slice that is left over is made into another slice. For 
example, if you divide a slice that is 100 pixels wide into three new slices each 30 pixels 
wide, the remaining 10-pixel-wide area becomes a new slice.

6 Click OK.



Using Help | Contents | Index Back 483  

Adobe Photoshop CS Help Designing Web Pages 

Using Help | Contents | Index Back 483  

Duplicating slices
You can create a duplicate slice with the same dimensions and optimization settings as 
the original. If the original slice is a linked user slice, the duplicate is linked to the same 
collection of linked slices. For more information, see “Linking slices (ImageReady)” on 
page 486. Duplicate slices are always user slices, regardless of whether the original is a 
user slice, a layer-based slice, or an auto slice.

In ImageReady, you can also copy and paste slices within or between documents.

To duplicate a slice:

1 Select a slice. (In ImageReady, you can select multiple slices.) 

2 Alt-drag (Windows) or Option-drag (Mac OS) from inside the selection.

To duplicate a slice using the Web Content palette (ImageReady)

1 Select a slice in the Web Content palette.

2 Choose Slices > Duplicate Slice or Duplicate Slice from the palette menu. (See “Using 
the Web Content palette” on page 510.) 

3 In the Duplicate Slice dialog box, select from the following options:

• Duplicate Rollover States to maintain any rollover states associated with the original 
slice 

• Duplicate Layers for Layer-Based Slices to duplicate a layer associated with a layer-
based slice

4 From the position menu, choose an option for the position of the duplicate slice. The 
duplicate slice will adjoin the original slice in the position indicated. If the duplicate slice 
extends beyond the edge of the document, it will be truncated.

5 Click OK.

To copy and paste a slice (ImageReady):

1 Select one or more slices with the Slice Select tool. 

2 Choose Copy Slice from the Edit menu.

3 If you want to paste into another image, open and display that image.

4 Choose Paste Slice from the Edit menu. If you paste the slice into the same image as you 
copied it from, the pasted slice appears on top of the original.

The Copy Slice and Paste Slice commands have the same keyboard shortcuts as the 
regular Copy and Paste commands.

Combining slices (ImageReady)
In ImageReady, you can combine two or more slices into a single slice. The resulting slice 
takes its dimensions and position from the rectangle created by joining the outer edges of 
the combined slices. If the combined slices are not adjacent or are of different proportions 
or alignments, the newly combined slice may overlap other slices. 

Optimization settings for the combined slice are those of the first slice selected before the 
Combine Slices operation. A combined slice is always a user slice, regardless of whether 
the original slices include auto slices.

Note: You cannot combine layer-based slices.
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To combine slices:

1 Select two or more slices.

2 Choose Slices > Combine Slices.

Arranging user slices and layer-based slices
When slices overlap, the last slice you create is the top slice in the stacking order. You can 
change the stacking order to gain access to underlying slices. You can specify which slice is 
on the top and bottom of the stack and move slices up or down in the stacking order.

Note: You cannot arrange the stacking order of auto slices.

To change the stacking order of slices:

1 Select a slice. In ImageReady, you can select multiple slices.

2 Do one of the following:

• With the Slice Select tool active, click a stacking order option in the options bar: Bring to 
Front , Bring Forward , Send Backward , or Send to Back .

• (ImageReady) Choose Edit > Arrange Slices and choose a stacking order command from 
the submenu.

• (ImageReady) Drag the slice up or down in the Web Content palette. See “Using the 
Web Content palette” on page 510.

Aligning user slices (ImageReady)
In ImageReady, you can align user slices with the top, bottom, left, right, or middle. 
Aligning user slices can eliminate unneeded auto slices and generate a smaller, more 
efficient HTML file.

Note: To align layer-based slices, align the contents of the layers. (See “Aligning layers” on 
page 378.)

To align user slices:

1 Select the user slices you want to align.

2 Do one of the following:

• With the Slice Select tool active, click an alignment option in the options bar: Align Top 
Edges , Align Vertical Centers , Align Bottom Edges , Align Left Edges , Align 
Horizontal Centers , or Align Right Edges .

• Choose Edit > Align Slices, and choose a command from the submenu.

Distributing user slices (ImageReady)
In ImageReady, you can distribute user slices evenly along the vertical or horizontal axis. 
Distributing user slices can eliminate unneeded auto slices and generate a smaller, more 
efficient HTML file.

Note: To distribute layer-based slices, distribute the contents of the layers. (See “Aligning 
layers” on page 378.)
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To distribute user slices: 

1 Select three or more user slices you want to distribute.

2 Do one of the following:

• With the Slice Select tool active, click a distribution option in the options bar: Distribute 
Top Edges , Distribute Vertical Centers , Distribute Bottom Edges , Distribute Left 
Edges , Distribute Horizontal Centers , or Distribute Right Edges .

• Choose Edit > Distribute Slices, and choose a command from the submenu.

Deleting user slices and layer-based slices
When you delete a user slice or layer-based slice, auto slices are regenerated to fill the 
document area. 

Deleting a layer-based slice does not delete the associated layer; however, deleting the 
layer associated with a layer-based slice does delete the layer-based slice.

Note: You cannot delete auto slices. If you delete all user slices and layer-based slices in an 
image, one auto slice layer will remain.

To delete a slice:

1 Select a slice. In ImageReady, you can select multiple slices.

2 Do one of the following:

• Choose the Slice or Slice Select tool and press the Backspace key or the Delete key.

• (ImageReady) Choose Slices > Delete Slices, or choose Delete Slices from the Slice 
palette menu.

• (ImageReady) Choose Delete Slice from the Web Content palette menu or click the 
Delete Slice button  in the Web Content palette.

To delete all user slices and layer-based slices:

Do one of the following:

• (Photoshop) Choose View > Clear Slices.

• (ImageReady) Choose Slices > Delete All.

Locking slices (Photoshop)
Locking slices prevents you from making changes accidentally, such as resizing or moving 
slices.

To lock all slices:

Choose View > Lock Slice.

Optimizing slices
You can optimize image slices using the Save for Web dialog box (Photoshop) or the 
Optimize palette (ImageReady). 

All image slices use the optimization settings of the entire image until you apply new 
settings. If you select multiple slices with different optimization settings, only the controls 
that are relevant to all of the selected slices are visible. If settings for a control differ among 
slices, the control is blank. Any settings you choose are applied to all selected slices. 
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In ImageReady, you can also copy optimization settings from one slice to another within a 
document, or from a slice in one view to a slice in another view in 2-Up or 4-Up view.

To optimize a slice:

Select one or more image slices. Do one of the following:

• Specify options in the Optimize palette. (See “Optimizing images” on page 531.)

• From the Optimize palette pop-up menu, choose Optimize to File Size. Enter a desired 
file size, and choose Slice to Start With (Current Settings or Auto Select GIF/JPEG), and 
Slice to Use (Current, Each, or Total of All).

To copy optimization settings between slices (ImageReady):

1 Select the slice that uses the optimization settings you want to copy.

2 Drag the Droplet icon  from the Optimize palette onto the slice to which you want to 
apply the optimization settings.

Linking slices (ImageReady)
Linking slices lets you share optimization settings between slices. When you apply optimi-
zation settings to a linked slice, all slices in the set are updated.

Linked slices in GIF and PNG-8 format share a color palette and dither pattern. The dither 
pattern is applied across adjacent slice boundaries to prevent the appearance of seams 
between the slices. (See “Optimizing colors in GIF and PNG-8 images” on page 548.)

Note: You can also link slices in the Photoshop Save for Web dialog box. (See “Working 
with slices in the Save for Web dialog box (Photoshop)” on page 534.)

To link slices:

1 Select two or more slices or slice sets you want to link. 

Note: If the first slice you select is a user slice, any auto slices you link to the first slice 
become user-slices. If the first slice you select is an auto slice, any user slices you select are 
linked to the auto slice group.

2 Choose Slices > Link Slices for Optimization. 

Each linked set of user slices is assigned a different color for the slice display graphics in 
the upper left corner of the slice. This helps to identify which slices are linked.

To unlink user slices:

Do one of the following:

• To unlink a user slice, select the slice, and then choose Slices > Unlink Slices.

• To unlink all of the slices linked to a particular slice, select one of the slices in the Web 
Content palette, and choose Slices > Unlink Shared Links.

• To unlink all user slices in an image, choose Slices > Unlink All.
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Working with tables (ImageReady)
When you convert a document containing slices to HTML, it is output as a single table; 
each individual slice is placed inside separate table cells. Slices are actually table cells. 

Optionally, you can choose to group slices into tables themselves, which are then nested 
inside the main table. You can only nest one level down, however; slices grouped into 
tables cannot be nested again inside other slice group tables. 

A slice of type Table Slice is a slice that contains a table you’ve created, or a nested table.

You can resize tables to fit layer-based elements. See “Resizing tables” on page 488.

Creating tables
You can select and group slices for output as separate, nested tables when converting a 
document to HTML.

To create a table:

Do one of the following:

• Select multiple slices (see “Selecting and modifying slices” on page 478) and then click 
the Group Slice Into Table button  in the Web Content palette.

• Select multiple slices (see “Selecting and modifying slices” on page 478) and then 
choose Slices > Group Slices Into Table.

• Select a slice, and change the slice type from “Image” to “Table” in the Slice palette. 
Switch to the Table palette to set its attributes. ImageReady automatically creates a user 
slice to fill the table.

Note: Certain slice layouts require ImageReady to generate spacer cells (spacer.gif 
images) to render the image properly in certain browsers. If this happens to your table, a 
yellow warning icon shows in the table’s header in the Web Content palette.

A table showing spacer cell warning
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Viewing tables
In the Web Content palette, slices grouped as nested tables are indicated with the table 
icon . This same icon appears in your document window, with the borders of the slice 
table outlined in color.

You can see tables in ImageReady’s Web Content palette or in the image in your document.

You can also see your table in the Table palette. It has option areas for the table’s 
Dimensions, Auto Slicing method, and Cell Options.

Note: In order to edit the table, you need to select the table or one of its slices.

Selecting tables
You can select tables via the document window or the Web Content palette.

To select a table:

Do one of the following:

• In a document, select the table icon  in a slice with the Slice Select tool.

• In the Web Content palette, select the table directly by clicking its name.

• In a document, select a slice with the Slice Select tool. (See “Selecting and modifying 
slices” on page 478.)

Note: To select the outermost table in a document, you must use the Slice Select tool.

Resizing tables
You can resize a table by grabbing the side or corner handles or by making adjustments to 
their dimensions (pixel or percentage).

To resize a table:

Select a table. Do one of the following:

• In the document window, grab a side or corner handle and drag to resize the table.
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• In the Table palette, in the Dimensions options area, enter the dimensions in pixels (the 
default method). Press Enter (Windows) or Return (Mac OS) to make the change. If you 
enter a width dimension, the height changes automatically, and vice-versa.

• In the Table palette, in the Dimensions options area, change the Pixels method to 
Percentage and add a value to any of the dimensions. Press Enter (Windows) or Return 
(Mac OS) to make the change.

• Choose Slices > Resize Table to Slices. If your table is larger than the slices, this 
command will shrink the table to fit the slices. If the slice area exceeds that of the table, 
it will expand the table to reveal all of the child slices.

Deleting nested tables slices
You can delete tables you’ve nested inside slices with or without deleting the slices that 
comprise them. In other words, you can ungroup the slices so they are no longer a table.

To delete a nested table:

1 In the Web Content palette, select the nested table slice.

2 Do one of the following:

• Choose Delete Slice from the palette menu 

• Choose Slices > Delete Slice.

3 Choose one of the following:

• Choose Table only to delete only the table and keep the slices intact.

• Choose Table and Contents to delete both the table and all its slices.

Setting HTML output options
Photoshop and ImageReady provide precise control over both preparation of images for 
the Web and the way in which the images are presented on a Web page. Slices and slice 
table structure can be specified within both applications to ensure proper functionality in 
an exported HTML or XHTML file. (See “Setting slice table export options (ImageReady)” 
on page 493.)

Setting and viewing slice options
Setting slice options lets you specify how the slice data will appear in a Web browser when 
exported with an HTML file. The available options vary according to the application and 
the slice type you select. You can only set options for one slice at a time.

Note: Setting options for an auto slice promotes the slice to a user slice.

You specify slice options in the Slice Options dialog box (Photoshop) and the Slice palette 
(ImageReady).

To display the Slice Options dialog box (Photoshop):

Do one of the following:

• Double-click a slice with the Slice Select tool.

• With the Slice Select tool active, click the Slice Options button in the options bar. This 
method is available only in the main Photoshop application, not in the Photoshop Save 
for Web dialog box.
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To display the Slice palette (ImageReady):

Choose Window > Slice, or select the Slice Select tool and click the palette button  in the 
options bar.

Choosing a content type
Formatting and display options for a slice vary according to its content type. There are 
three types of slice content:

• Image slices contain image data, including rollover states. This is the default content 
type.

• No Image slices let you create empty table cells that can be populated with text or a 
solid color. You can enter HTML text in a No Image slice, and if you have the “Text is 
HTML” flag set, it will be interpreted as HTML when viewed in a browser. No Image 
slices are not exported as images, and can be previewed in a browser. (See “Previewing 
an image in a browser” on page 51.)

• (ImageReady) Table slices act as containers for a subset of slices that, upon export, 
will be written into the HTML text file as a nested table.

To specify a content type:

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice 
Select tool to display the Slice Options dialog box.

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), select a 
slice type from the Type pop-up menu. 

Specifying slice names
As you add slices to an image, you may find it helpful to rename slices based on their 
content. By default, user slices are named according to the settings in the Output Options 
dialog box. (See “Setting slice output options” on page 560.) Layer-based slices are given 
the name of the layer from which they are derived.

To change the name of a slice:

Do one of the following:

• Select a slice. If you are working in Photoshop, double-click the slice with the Slice 
Select tool to display the Slice Options dialog box. In the Slice Options dialog box 
(Photoshop) or the Slice palette (ImageReady), type a new name in the Name text box. 

Note: The Name text box is not available for No Image slice content.

• Double-click the slice’s name in the Web Content palette (ImageReady), and enter a 
new name. See “Using the Web Content palette” on page 510.

Specifying slice background colors
The background color option lets you select a color to fill the transparent area (for Image 
slices) or entire area (for No Image slices) of the slice. 

Photoshop and ImageReady do not display the selected background color—you must 
preview the image in a browser to view the effect of selecting a background color. 
(See “Previewing an image in a browser” on page 51.)
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To choose a background color:

1 Select a slice. If you are working in the Photoshop Save for Web dialog box, double-click 
the slice with the Slice Select tool to display the Slice Options dialog box.

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), select a 
background color from the Background/BG pop-up menu:

•  (Photoshop) Select None, Matte, Eyedropper (to use the color in the eyedropper 
sample box), White, Black, or Other (using the color picker).

• (ImageReady) Select None, Matte, Foreground Color, Background Color, or Other (to use 
the color picker), or select a color from the pop-up palette.

Assigning a URL to an Image slice
Assigning a URL to a slice makes the entire slice area a link in the resulting Web page. 
When a user clicks in the link, the Web browser navigates to the specified URL and target 
frame. This option is only available for Image slices.

To assign link information to an Image slice:

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice 
Select tool to display the Slice Options dialog box.

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), enter a 
URL in the URL text box, or choose a previously created URL from the pop-up menu. You 
can enter a relative URL or a full URL. If you enter an absolute URL, be sure to include the 
proper protocol (for example, enter http://www.adobe.com, not www.adobe.com for an 
HTML link). For more information on using relative URLs and full URLs, see an HTML 
reference (either printed or on the Web). 

3 If desired, enter the name of a target frame in the Target text box, or choose an option 
from the pop-up menu. A frame name must match a frame previously defined in the HTML 
file for the document. When a user clicks the link, the specified file displays in the new 
frame:

• _blank to display the linked file in a new window, leaving the original browser window 
open. 

• _self to display the linked file in the same frame as the original file. 

• _parent to display the linked file in its own original parent frameset. Use this option if 
the HTML document contains frames and the current frame is a child. The linked file 
displays in the current parent frame.

• _top to replace the entire browser window with the linked file, removing all current 
frames. 

Note: For more information on frames, see an HTML reference (either printed or on 
the Web).

Specifying browser messages
You can specify what messages appear in the browser. In Photoshop, use the Message Text 
and Alt Tag areas of the Slice Options dialog box. (See “To display the Slice Options dialog 
box (Photoshop):” on page 489.) In ImageReady, use the Status Bar Message and Alt 
options of the Slice palette. (If the Message and Alt options aren’t showing in ImageReady, 
choose Show Options from the Slice palette menu, or click the Show Options button  on 
the palette tab.)

http://www.adobe.com
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These options are only available for Image slices, and only appear in exported HTML files.

Message Text/Status Bar Message Lets you change the default message in the 
browser’s status area for a selected slice or slices. By default, the slice’s link URL, if any, 
is displayed. 

Alt Tag/Alt Lets you specify an Alt tag for a selected slice or slices. The Alt text appears in 
place of the slice image in nongraphical browsers. It also appears in place of the image 
while the image is downloading and as a tool tip in some browsers. Specifying Alt tags is a 
critical aspect of ensuring the accessibility of your page for visitors whose browsers do not 
display images.

To specify a browser message:

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice 
Select tool to display the Slice Options dialog box.

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), type the 
desired text in the Message text box, Alt text box, or both.

Adding HTML text to a slice
Choosing the No Image type for a slice lets you enter text that will appear in the slice area 
of the resulting Web page. This text is HTML text—you can format it using standard HTML 
tags. You can also select vertical and horizontal alignment options. For more information 
on specific HTML tags, see an HTML reference (either printed or on the Web).

Photoshop and ImageReady do not display HTML text in the document window; you must 
use a Web browser to preview the text. (See “Setting and viewing slice options” on 
page 489.) Keep in mind that the appearance of text is affected by the browser settings 
and operating system it is viewed on. Be sure to preview HTML text in different browsers, 
with different browser settings, and on different operating systems to see how text will 
appear on the Web.

Note: The amount of text in a No Image slice can affect the layout of an exported page. 
Be sure to experiment with your design in several browsers to ensure consistency.

To add HTML text to a slice:

1 Select a slice. If you are working in Photoshop, double-click the slice with the Slice 
Select tool to display the Slice Options dialog box.

2 In the Slice Options dialog box (Photoshop) or the Slice palette (ImageReady), select No 
Image from the Type pop-up menu.

3 Type the desired text in the text box. 

4 (Photoshop Save for Web dialog box and ImageReady) If the text includes HTML 
formatting tags, select the Text is HTML option. When this option is deselected, all the text 
you enter (including formatting tags) will be displayed in the resulting Web page.

5 (Photoshop Save for Web dialog box and ImageReady) If desired, select options in the 
Cell Alignment section of the dialog box.

Horizontal alignment options:

• Default to use the browser’s default for horizontal alignment

• Left to align the text to the left side of the slice area
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• Center to align the text to the center of the slice area

• Right to align the text to the right side of the slice area

Vertical alignment options:

• Default to use the browser’s default for vertical alignment.

• Top to align the text to the top of the slice area.

• Baseline to set a common baseline for the first line of text in cells in the same row (of the 
resulting HTML table). Each cell in the row must use the Baseline option.

• Middle to center the text vertically in the slice area.

• Bottom to align the text to the bottom of the slice area.

Setting slice table export options (ImageReady)
When exporting slices for use on the Web, Photoshop and ImageReady can optionally 
export an HTML file providing instructions for a browser in how to display the slices in the 
proper layout. By default, this exported HTML uses tables to ensure consistent appearance 
with the original sliced composition. (See “Working with tables (ImageReady)” on 
page 487.) The Table palette in ImageReady provides an additional level of control over 
how this formatting table is exported.

Note: Changes you make to the structure of an exported HTML file don’t affect the 
appearance of the image in your work area; they only modify what it looks like in a 
browser.

To set table export options with the Table palette:

1 Choose Window > Table.

2 Select the table for which you want to set options. (See “Selecting tables” on page 488.) 
By default, the selected table is the top-level table encompassing the entire composition 
area.

3 Enter a name for the table in the ID input box of the Table palette. Specifying a name for 
an exported table allows for increased conformity with standards for Web accessibility. 

4 Choose a preferred formatting for table export from the Auto Slicing pop-up menu:

Note: Changing this preference may affect how auto slices are generated.

• Default maintains the default table formatting.

• As Columns (rowspan) favors the creation of vertical columns in an exported HTML 
table.

• As Rows (colspan) favors the creation of horizontal rows in an exported HTML table.

To set table dimensions:

1 Select the table for which you want to set options using the Slice Select tool. By default, 
the selected table is the top-level table encompassing the entire composition area.

2 If it is not visible, show the Dimensions options section of the Table palette by clicking 
the Dimensions arrow.
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3 Determine the width and height of the exported table by choosing Pixels or Percent 
from the appropriate pop-up menu. Specifying the width or height as a percent will allow 
the exported table to dynamically adjust in size, based on the size of a Web page visitor’s 
browser window. 

Note: The current X and Y coordinates of the table’s upper left corner are displayed in this 
section for reference. They cannot be changed.

To set table HTML attributes:

It’s best to set the table HTML attributes only for tables that contain No Image slices. 
Changing these settings with Image slices can break your tables up in undesirable ways.

1 Select the table for which you want to set options. (See “Selecting tables” on page 488.) 
By default, the selected table is the top-level table encompassing the entire composition 
area.

2 If it is not visible, show the Cell options section of the Table palette by clicking the Cell 
arrow.

3 Choose a value for each of the optional attributes:

• Border determines the width in pixels of the border around the table on export.

• Pad determines the amount of padding in pixels for each table cell. Padding is the 
amount of space between the edge of a table cell and its contents.

• Space determines the amount of spacing in pixels between each table cell. Spacing is 
the distance between the edges of any two table cells.

Working with image maps (ImageReady)
Image maps link an area of an image to a URL. You can set up multiple linked areas—called 
image map areas—in an image, with links to other Web pages or multimedia files. 

When choosing between using slices or image maps to create hyperlinks, consider the 
following.

• Using image maps keeps the exported image intact as a single file, while using slices 
causes the image to be exported as separate files (one per slice). 

• Image maps enable you to link circular, polygonal, or rectangular areas in an image, 
while slices enable you to link only rectangular areas. 

• Image maps do not allow as much flexibility in optimization as slices.

Note: To avoid unexpected results, do not create image map areas in slices that contain 
URL links—either the image map links or the slice links may be ignored in some browsers.

Creating image maps
You can create image map areas using an Image Map tool or a layer, and then set options 
for the image map sections in the Image Map palette.

Tool-based image map areas Create these using an Image Map tool; drag in the image 
to define the image map area. 
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Layer-based image map areas Create these from a layer; the layer’s content defines the 
shape of the image map area. If you edit the layer’s content, the image map area automat-
ically adjusts to encompass the new pixels.

Note: Adding a rollover effect to an image map area will cause the area to become a 
new slice.

Layer-based rectangle image map compared to polygonal image map

Important: If you overlap image map areas, the topmost area is active.

To create an image map area using an image map tool:

1 Select the Rectangle Image Map tool , the Circle Image Map tool , or the Polygon 
Image Map tool  in the toolbox.

2 If you create a layer-based image map, when using the Rectangle or Circle Image Map 
tool, select Fixed Size to specify set values for the image map area’s dimensions. Enter pixel 
values in whole numbers. For the Polygon tool, enter a value or choose a value from the 
Quality pop-up slider to set the number of segments in the polygon.

3 Do one of the following to define the image map area:

• With the Rectangle or Circle Image Map tool, drag over the area you want to define. 
Shift-drag to constrain the area to a square or circle. Alt-drag (Windows) or Option-drag 
(Mac OS) to drag an image map area from its center.

• With the Polygon Image Map tool, click in the image to set the starting point. Position 
the pointer where you want the first straight segment to end, and click. Continue 
clicking to set endpoints for subsequent segments. Hold down Shift to constrain the 
segment to 45° increments. Shift + Option-drag (Mac OS) to constrain and draw from 
the center. To close the border, double-click, or position the pointer over the starting 
point (a closed circle appears next to the pointer) and click.

To add points to a polygon image map area, select the Image Map Select tool, and 
Shift-click where you want to add a point. To remove points from a polygon image 

map area, select either the Image Map Select or the Polygon tool, and Alt-click (Windows) 
or Option-click (Mac OS) the points you want to remove.

To create an image map area from a layer:

1 In the Layers palette, choose a layer from which to create an image map area. (To use 
multiple layers in one image map area, first merge the layers.)

2 Choose Layer > New Layer Based Image Map Area or choose Promote Layer Based 
Image Map Area from the Image Map palette menu.
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To change the shape of a layer-based image map area:

1 Select a layer-based image map area by clicking it in the Web Content palette or by 
using the Image Map Select tool . (See “Selecting image maps” on page 498.)

2 In the Layer Based Settings section of the Image Map palette, choose an option from 
the shape pop-up list: Rectangle, Circle, or Polygon. If you choose Polygon, enter a value or 
choose a value from the Quality pop-up slider to set the number of segments in the 
polygon.

To convert a layer-based image map area to a tool-based image map area:

1 Select a layer-based image map area by clicking it in the Web Content palette or by 
using the Image Map Select tool . (See “Selecting image maps” on page 498.)

2 Choose Promote Layer Based Image Map Area from the Image Map palette menu. If the 
layer contains multiple, non-overlapping areas of pixel content, multiple tool-based image 
map areas are produced.

Viewing image maps
When you select the Image Map Select tool, image map areas show automatically. You can 
also show or hide image map areas using the Image Map Visibility button.

Image map preferences determine how image map areas appear in the document 
window. You can set preferences for image map lines, line color, and color adjustments.

To show or hide image map areas:

Do one of the following:

• Click the Image Map Visibility button  in the toolbox.

• Choose View > Show > Image Maps.

• Choose View > Extras. This command also shows or hides selection edges, slices, text 
bounds, text baseline, and text selections. (See “Working with Extras” on page 45.)

To set image map display preferences:

1 Do one of the following:

• In Window, choose Edit > Preferences > Image Maps.

• In Mac OS, choose ImageReady > Preferences > Image Maps.

2 To display image map lines only and deselect color adjustment display, select Show 
Lines Only.

3 To show a bounding box for circular image map areas, select Show Bounding Box.

4 To change the color of image map lines, choose a color from the Line Color pop-up 
menu. Changing the color of image map lines also changes the line color of selected 
image map areas to a contrasting color.

5 To change the strength of image map color adjustments, enter a value, or choose a 
value from the Image Map Overlay pop-up slider. The value determines the extent of color 
adjustments that dim the brightness and contrast of unselected image map areas. 
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Specifying image map options
You can specify a name, a URL, a target frame, and Alt text for an image map area in the 
Image Map palette.

To display the Image Map palette:

Choose Window > Image Map, or click the palette button  on the right side of the 
options bar for the Image Map Select tool .

To change the name of an image map area:

1 Select an image map area.

2 In the Image Map palette, enter a new name in the Name text box.

To specify link options for an image map area:

1 Select an image map area.

2 In the Image Map palette, enter a URL for the link, or choose a previously created 
URL from the URL pop-up menu. You can enter a relative URL or an absolute URL. 
If you enter a n absolute URL, be sure to include the proper protocol (for example, enter 
http://www.adobe.com, not www.adobe.com for an HTML link). For more information on 
using relative URLs and full URLs, see an HTML reference (either printed or on the Web). 

3 In the Image Map palette, enter the name of a target frame in the Target text box, or 
choose an option from the pop-up menu. A frame name must match a frame previously 
defined in the HTML file for the document. When a user clicks the link, the specified file 
displays in the new frame:

• _blank to display the linked file in a new window, leaving the original browser window 
open. 

• _self to display the linked file in the same frame as the original file. 

• _parent to display the linked file in its own original parent frameset. Use this option if 
the HTML document contains frames and the current frame is a child. The linked file 
displays in the current parent frame.

• _top to replace the entire browser window with the linked file, removing all current 
frames. 

Note: For more information on frames, see an HTML reference (either printed or on 
the Web).

4 In the Image Map palette, enter text for an Alt tag in the Alt text box. The Alt text 
appears in place of the image map area in nongraphical browsers. In many browsers, 
it also appears if the user positions the mouse over the image map area. 

http://www.adobe.com
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Selecting image maps
You select image map areas with the Image Map Select tool or by using the Web Content 
palette.

To select an image map area

Do one of the following:

• In the Web Content palette, click the image map name. Shift-click to select multiple 
images.

• With the Image Map Select tool , click an image map area in the image. Shift-click to 
add areas to the selection. You can also select multiple image map areas by clicking 
outside an image map area and dragging across the image map areas you want to 
select.

Moving and resizing tool-based image maps
You can move and resize tool-based image map areas by dragging. You can also move and 
resize rectangular and circular image map areas using numeric coordinates.

Note: To move or resize a layer-based image map area, move or edit the layer.

To move a tool-based image map area:

1 Select one or more image map areas you want to move 

2 Position the pointer inside the image map area, and drag it to a new position. Press 
Shift to restrict movement to a vertical, horizontal, or 45° diagonal line. 

To resize a tool-based image map area:

1 Select an image map with the Image Map Select tool  or in the Web Content palette.

Note: If you select a polygonal image map, the cursor changes to a white arrow  to show 
you where to point on the handle. The other tools use the standard resize cursor .

2 Grab a handle of the boundary box by holding the mouse button down over it.

3 Drag a handle on the image map border to resize the image map area.

To resize and move a tool-based image map area using numeric coordinates:

1 Select a rectangular or circular image map area.

2 In the Dimensions area of the Image Map palette, change one or more of the following 
options:

• X to specify the distance in pixels between the left edge of a rectangular image map 
area, or the center point of a circular image map area, and the origin point of the ruler 
in the document window. 

• Y to specify the distance in pixels between the top edge of a rectangular image map 
area, or the center point of a circular image map area, and the origin point of the ruler 
in the document window. 

Note: The default origin point of the ruler is the upper left corner of the image. (See “Using 
guides and the grid” on page 43.)

• W to specify the width of a rectangular image map area.

• H to specify the height of a rectangular image map area.

• R to specify the radius of a circular image map area. 
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Duplicating image maps
You can create a duplicate image map area with the same dimensions and settings as the 
original image map area. 

To duplicate an image map area:

Do one of the following:

• Select one or more image map areas, and choose Duplicate Image Map Areas from the 
Image Map palette menu.

• Select one or more image map areas, and Alt-drag (Windows) or Option-drag (Mac OS) 
from inside the image map area. 

• Select a image map in the Web Content palette, and choose Duplicate Image Map from 
the palette menu. (See “Using the Web Content palette” on page 510.)

• Select a number of image maps with the Image Map Select tool. Either right-click or 
Control-click with the cursor in one of the image maps. This brings up the context 
menu for image maps. Select Duplicate Image Map Areas.

The duplicate image map area appears on top of the original (offset 10 pixels down and to 
the right), and becomes the current selection. You can move, resize, or otherwise modify it. 

Arranging image maps
The Web Content palette displays the stacking order of image maps. The image map on 
the top of your stack takes precedence, so it’s helpful to be able to arrange them. You can 
specify which image map area is on the top and bottom of the stack and move image map 
areas up or down in the stacking order. To change the stacking order of image map areas:

Do one of the following:

• Select one or more image map areas you want to arrange. You can select a combination 
of tool-based image map areas and layer-based image map areas. Then, with the 
Image Map Select tool active, click a stacking order option in the options bar: Bring to 
Front , Bring Forward , Send Backward , Send to Back . Alternately, choose a 
stacking order command from the Image Map palette menu.

• Drag an image map up or down in the Web Content palette. (See “Using the Web 
Content palette” on page 510.)

• Select a number of image maps with the Image Map Select tool. Either right-click or 
Control-click with the cursor in one of the image maps. This brings up the context 
menu for image maps. Select from the Align choices: Top Edges, Vertical Centers, 
Bottom Edges, Left Edges, Horizontal Centers, Right Edges. See “Aligning and distrib-
uting tool-based image maps” on page 499.

Aligning and distributing tool-based image maps
You can align and distribute tool-based image map areas to the top, bottom, left, right, 
and middle. 

Note: To align layer-based image map areas, first select the layers, and then choose an 
alignment option from the Edit > Align Linked submenu. 
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To align tool-based image map areas:

1 Select the tool-based image map areas you want to align or distribute.

2 With the Image Map Select tool active, click an alignment option in the options bar: 
Align Image Map Top Edges , Align Image Map Vertical Centers , Align Image Map 
Bottom Edges , Align Image Map Left Edges , Align Image Map Horizontal Centers , 
or Align Image Map Right Edges . 

3 With the Image Map Select tool active, click a distribution option in the options bar: 
Distribute Image Map Top Edges , Distribute Image Map Vertical Centers , Distribute 
Image Map Bottom Edges , Distribute Image Map Left Edges , Distribute Image Map 
Horizontal Centers , Distribute Image Map Right Edges .

Deleting image maps
You can delete selected image map areas by doing one of the following:

• Pressing the Backspace key or the Delete key

• Choosing Delete Image Map Areas from the Image Map palette menu

• Selecting the image map in the Web Content palette and dragging it to the trash icon.

• Selecting a number of image maps with the Image Map Select tool. Either right-click or 
Control-click with the cursor in one of the image maps. This brings up the context 
menu for image maps. Select Delete Image Map Areas.

Selecting an image map type
ImageReady can create client-side and server-side image maps. In client-side image maps, 
the links are interpreted by the browser itself. In server-side image maps, the links are 
interpreted by the server. Because client-side image maps don’t need to contact the server 
to function, they are often significantly faster to navigate. By default, ImageReady saves 
image maps as client-side image maps.

Important: Server-side image maps do not work in images that have multiple slices.

You select an image map type in the Output Settings dialog box. (See “Setting HTML 
output options” on page 560.) If you select a server-side image map, ImageReady 
generates a separate map file based on the server option you select. However, you’ll need 
to update the path to the map file in your HTML file.

Creating Web photo galleries (Photoshop)
You use the Web Photo Gallery command to automatically generate a Web photo gallery 
from a set of images. A Web photo gallery is a Web site that features a home page with 
thumbnail images and gallery pages with full-size images. Each page contains links that 
allow visitors to navigate the site. For example, when a visitor clicks a thumbnail image on 
the home page, a gallery page with the associated full-size image loads.
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Web photo gallery home page and loaded gallery page

Photoshop provides a variety of styles for your gallery, which you can select using the Web 
Photo Gallery command. If you are an advanced user who has knowledge of HTML, you 
can also customize a style by editing a set of HTML template files or create a new style.

Each template for gallery styles comes with different options. If you’re using a preset style, 
some options may be dimmed, or unavailable in that particular style. (See “Customizing 
and creating Web photo gallery styles (Photoshop)” on page 503.)

To create a Web photo gallery:

When making a gallery from images in the file browser, your images will be presented 
in the order in which they’re displayed in the file browser. If you’d rather see a different 

order, change the order in the file browser, then select Web Photo Gallery.

1 Select the files or folder you want to use from the file browser.

2 Choose File > Automate > Web Photo Gallery.

3 Under Site, do the following:

• Choose a style for the gallery from the Styles pop-up menu. A preview of the home 
page for the chosen style appears in the dialog box.

• Enter the email address that you want to display as the contact for the gallery.

• Choose an extension for the generated files from the Extension pop-up menu.
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4 Under Source Images, do the following:

• In the Use pop-up menu, choose Folder or Selected Images From Web Browser.

• If you chose Folder, click Browse (Windows) or Choose (Mac OS). Then select the folder 
containing the images that you want to appear in the gallery, and click OK (Windows) 
or Choose (Mac OS). Your folder name appears in the dialog box next to the Browse/
Choose button. Then check Include All Subfolders to include images inside any 
subfolders of the selected folder.

• Click Destination, select the destination folder that you want to contain the images and 
HTML pages for the gallery, and click OK (Windows) or Choose (Mac OS).

5 To set general options for the gallery photos, choose General from the Options pop-up 
menu. Then do the following:

• Choose an extension for the files (.htm, .html).

• Check Use UTF 8 Encoding for URL if you want that encoding.

• Check Add Width and Height Attributes for images to increase download speed.

• Check Preserve All Metadata to maintain metadata info.

6 To set options for the banner that appears on each page in the gallery, choose Banner 
from the Options pop-up menu. Then do the following:

• For Site Name, enter the title of the gallery.

• For Photographer, enter the name of the person or organization that deserves credit for 
the photos in the gallery.

• For Contact Info, enter the contact information for the gallery, such as a telephone 
number or a business address.

• For Date, enter the date that you want to appear on each page of the gallery. By default, 
Photoshop uses the current date.

7 If available, for Font and Font Size, choose options for the banner text.

8 To set options for the gallery pages, choose Large Images from the Options pop-up 
menu. Then do the following:

• To have Photoshop resize the source images for placement on the gallery pages, select 
Resize Images. Then choose an option for the image size from the pop-up menu or 
enter a size in pixels. For Constrain, choose which dimensions of the image you want to 
constrain during resizing. For JPEG Quality, choose an option from the pop-up menu, 
enter a value between 0 and 12, or drag the slider. A higher value results in better 
image quality but larger file size.

• For Border Size, enter the width of the border around the image in pixels.

• For Titles Use, specify options to display caption information under each image. Select 
Filename to display the filename, or select Description, Credits, Title, and Copyright to 
display description text drawn from the File Info dialog box. For more information, see 
“Adding file information (Photoshop)” on page 590.

• For Font and Font Size, choose options for the caption text.
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9 To set options for the home page, choose Thumbnails from the Options pop-up menu. 
Then do the following:

• For Size, choose an option for the thumbnail size from the pop-up menu or enter a 
value in pixels for the width of each thumbnail.

• For Columns and Rows, enter the number of columns and rows that you want to be 
used to display the thumbnails on the home page. This option doesn’t apply to galleries 
that use the Horizontal Frame Style or Vertical Frame Style.

• For Border Size, enter the width of the border around each thumbnail in pixels.

• For Titles check either Filename, Description, Credits, Title or Copyright.

• For Font and Font Size, choose options for the caption text.

10 To set options for colors of elements in the gallery, choose Customize Colors from the 
Options pop-up menu. To change the color of a particular element, click its color swatch, 
and then select a new color using the Color Picker. The Background option lets you 
change the background color of each page. The Banner option lets you change the 
background color of the banner.

11 To set options to display text to appear over each image as an antitheft deterrent, 
choose Security from the Options pop-up menu. Then do the following:

• For Content, select Custom Text to enter customized text. Select Filename, Description, 
Credits, Title, or Copyright to display text drawn from the File Info dialog box. For more 
information, see “Adding file information (Photoshop)” on page 590.

• Specify font, color, and text alignment options. To place the text on the image at an 
angle, choose a rotation option.

Photoshop places the following HTML and JPEG files in your destination folder:

• A home page for your gallery named index.htm or index.html depending on the 
Extension options. Open this file in any Web browser to preview your gallery.

• JPEG images inside an images subfolder.

• HTML pages inside a pages subfolder.

• JPEG thumbnail images inside a thumbnails subfolder.

Customizing and creating Web photo gallery styles 
(Photoshop)
Photoshop provides a variety of styles for your Web photo gallery, which you can select 
using the Web Photo Gallery command. If you are an advanced user who has knowledge 
of HTML, you can also customize a style by editing a set of HTML template files or create a 
new style.

About Web photo gallery styles
The Web photo gallery styles provided by Photoshop are stored in individual folders in the 
following locations:

Windows Program Files/Adobe/Photoshop CS/Presets/Web Photo Gallery.

Mac OS Adobe Photoshop CS/Presets/Web Photo Gallery.
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The name of each folder in this location appears as an option in the Styles pop-up menu in 
the Web Photo Gallery dialog box. Each folder contains the following HTML template files, 
which Photoshop uses to generate the gallery:

Caption.htm Determines the layout of the caption that appears below each thumbnail 
on the home page.

FrameSet.htm Determines the layout of the frame set for displaying pages.

IndexPage.htm Determines the layout of the home page.

SubPage.htm Determines the layout of the gallery pages with full-size images.

Thumbnail.htm Determines the layout of the thumbnails that appear on the home page.

Each template file contains HTML code and tokens. A token is a text string that is replaced 
by Photoshop when you set its corresponding option in the Web Photo Gallery dialog box. 
For example, a template file may contain the following TITLE element that uses a token as 
its enclosed text:

<TITLE>%TITLE%</TITLE>

When Photoshop generates the gallery using this template file, it replaces the token 
%TITLE% with the text that you entered for Site Name in the Web Photo Gallery dialog 
box.

To better understand an existing style, you can open and study its HTML template files 
using an HTML editor. Because only standard ASCII characters are required to create HTML 
documents, you can open, edit, and create these documents using a plain-text editor such 
as Notepad (Windows) or TextEdit (Mac OS).

Customizing Web photo gallery styles
You can customize an existing Web photo gallery style by editing one or more of its HTML 
template files. When customizing a style, you need to follow these guidelines so that 
Photoshop can generate the gallery correctly:

• The style folder must contain these files: Caption.htm, IndexPage.htm, SubPage.htm, 
Thumbnail.htm, and FrameSet.htm.

• You can rename the style folder but not the HTML template files in the folder.

• You can have an empty Caption.htm file, and place the HTML code and tokens 
determining the layout of the caption in the Thumbnail.htm file.

• You can replace a token in a template file with the appropriate text or HTML code, 
so that an option is set through the template file rather than through the Web Photo 
Gallery dialog box. For example, a template file may contain a BODY element with the 
following bgcolor attribute that uses a token as its value:

bgcolor=%BGCOLOR%

To set the background color of the page to red, you can replace the token %BGCOLOR% 
with “FF0000.”

• You can add HTML code and tokens to the template files. All tokens must be in 
uppercase characters, and begin and end with the percent (%) symbol. For information 
on the tokens that you can use in the template files, see “Using tokens in Web photo 
gallery styles” on page 505.
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To customize an existing Web photo gallery style:

1 Locate the folder for the Web photo gallery style that you want to customize. For the 
location of style folders, see “About Web photo gallery styles” on page 503.

2 If you don’t want to overwrite an existing style, create a copy of the style folder, and 
store it in the same location on your hard drive as the existing style folders.

3 Using an HTML editor, open one of the HTML template files located inside the style 
folder.

4 Customize the HTML template file using the guidelines for customization outlined in 
this section, and save the file.

5 Repeat steps 2, 3, and 4 to customize other HTML template files in the style folder.

When you have finished, you can create a gallery using the customized style. The 
customized style appears as an option in the Styles pop-up menu in the Web Photo 
Gallery dialog box.

Creating new Web photo gallery styles
You can create a new Web photo gallery style by creating the necessary HTML template 
files that are used by Photoshop to generate a gallery. 

To create a new Web photo gallery style:

1 Locate the folder that stores the existing Web photo gallery styles. For the location of 
style folders, see “About Web photo gallery styles” on page 503.

2 Create a new folder for the new style, and store it in the same location on your hard 
drive as the existing style folders.

3 Using an HTML editor, create the necessary HTML template files and store them inside 
the style folder. When creating the template files, make sure that you follow the guidelines 
for customization outlined in “Customizing Web photo gallery styles” on page 504.

When you have finished, you can create a gallery using the new style. The new style 
appears as an option in the Styles pop-up menu in the Web Photo Gallery dialog box.

Using tokens in Web photo gallery styles
Photoshop uses tokens in the HTML template files that are used to define a default Web 
photo gallery style. The tokens enable Photoshop to generate a gallery based on user 
input in the Web Photo Gallery dialog box.

When customizing or creating a gallery style, you can add any token to any HTML 
template file, with the exception of %THUMBNAILS% and %THUMBNAILSROWS%, which 
can only appear in the IndexPage.htm file. When adding a token, keep in mind that you 
may also need to add HTML code to the file so that the token is used correctly. 

You can use the following tokens in the HTML template files:

%ALINK% Determines the color of active links.

%ALT% Determines the name of an image file.

%ANCHOR% Provides the ability to return to the thumnail of the image the user is 
viewing, rather than the beginning of the index. This takes effect when the user clicks the 
Home button.

%BANNERCOLOR% Determines the color of the banner.
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%BANNERFONT% Determines the font of the banner text.

%BANNERFONTSIZE% Determines the font size for the banner text.

%BGCOLOR% Determines the background color.

%CAPTIONFONT% Determines the font for the caption below each thumbnail on the 
home page.

%CAPTIONFONTSIZE% Determines the font size for the caption.

%CHARSET% Determines the character set used on each page.

%CONTENT_GENRATOR% Expands to “Adobe Photoshop CS Web Photo Gallery.”

%CURRENTINDEX% Determines the link for the current home page.

%CURRENTINDEXANCHOR% Resides in the subpage.htm and points to the first index 
page.

%DATE% Determines the date that appears on the banner.

%FILEINFO% Determines the image file information for a caption.

%FILENAME% Determines the filename of an image. Use this for metadata that appears 
as HTML text.

%FILENAME_URL% Determines the URL filename of an image. Use this for URL 
filenames only.

%FIRSTPAGE% Determines the link for the first gallery page that appears in the right 
frame of a frame set.

%FRAMEINDEX% Determines the link for the home page that appears in the left frame 
of a frame set.

%HEADER% Determines the title of the gallery.

%IMAGEBORDER% Determines the border size of the full-size image on a gallery page.

%IMAGE_HEIGHT% Enables “Add width and height attributes for images” check box. 
This allows the user to download the attributes, producing faster downloads.

%IMAGE_HEIGHT_NUMBER% This token is replaced by a numeral (only) representing 
the width of the image.

%IMAGEPAGE% Determines the link to a gallery page.

%IMAGE_SIZE% If the “Resize Images” box is checked, this token has the image pixel 
value in the “Large Images” panel. If the box is not checked, this token contains an empty 
string. This is useful for JavaScript in the templates, as it can show the maximum height 
and width values for all images for the generated site.

%IMAGESRC% Determines the URL for a full-size image on a gallery page.

%IMAGE_WIDTH% Enables “Add width and height attributes for images” check box. 
This allows the user to download the attributes, producing faster downloads.

%IMAGE_WIDTH_NUMBER% This token is replaced by a numeral (only) representing 
the width of the image.

%LINK% Determines the color of links.

%NEXTIMAGE% Determines the link for the next gallery page.

%NEXTIMAGE_CIRCULAR% Sets the link from large preview image to next large 
preview image.
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%NEXTINDEX% Determines the link for the next home page.

%NUMERICLINKS% Inserts numbered links on subpages to all large preview images.

%PAGE% Determines the current page location (for example, page 1 of 3).

%PHOTOGRAPHER% Determines the name of the person or organization that deserves 
credit for the photos in the gallery.

%PREVIMAGE% Determines the link for the previous gallery page.

%PREVINDEX% Determines the link for the previous home page.

%SUBPAGEHEADER% Determines the title of the gallery.

%SUBPAGETITLE% Determines the title of the gallery.

%TEXT% Determines the text color.

%THUMBBORDER% Determines the border size for the thumbnails.

%THUMBNAIL_HEIGHT% Enables “Add width and height attributes for images” check 
box. This allows the user to download the attributes, producing faster downloads.

%THUMBNAIL_HEIGHT_NUMBER% This token is replaced with a numeral (only) repre-
senting the height of the thumbnail.

%THUMBNAILS% This token is replaced with thumbnails using the Thumbnail.htm file 
for the frame styles. You must place this token alone in a single, nonbreaking line in the 
HTML file.

%THUMBNAIL_SIZE% Contains the thumbnail pixel value in the “Thumbnails” panel. 
This is useful for JavaScript in the templates, as it can show the maximum height and 
width values for all thumbnails for the generated site.

%THUMBNAILSRC% Determines the link to a thumbnail.

%THUMBNAILSROWS% This token is replaced with rows of thumbnails using the 
Thumbnail.htm file for the nonframe styles. You must place this token alone in a single, 
nonbreaking line in the HTML file.

%THUMBNAIL_WIDTH% Enables “Add width and height attributes for images” check 
box. This allows the user to download the attributes, producing faster downloads.

%THUMBNAIL_WIDTH_NUMBER% This token is replaced by a numeral (only) repre-
senting the width of the thumbnail.

%TITLE% Determines the title of the gallery.

%VLINK% Determines the color of visited links.

Important: When customizing or creating a template for a gallery style, you should place 
each of the following tokens on a separate line in the HTML file: %CURRENTINDEX%, 
%NEXTIMAGE%, %NEXTINDEX%, %PAGE%, %PREVIMAGE%, and %PREVINDEX%. When 
generating specific pages of a gallery, Photoshop skips lines in a template that contain 
tokens that don’t apply to those pages. For example, when Photoshop generates the first 
gallery page, it skips any line in the template that contains the %PREVIMAGE% token, 
which determines the link to the previous gallery page. By keeping the %PREVIMAGE% 
token on a separate line, you ensure that Photoshop doesn’t ignore other tokens in the 
template.
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Creating Complex Web Graphics 
(ImageReady)

About rollovers and states
A rollover is a Web effect in which different states of an image appear when a viewer 
performs a mouse action—such as rolling or clicking—over an area of the Web page. 
A state is defined by a specific configuration of the Layers palette, including layer location, 
styles, and other formatting options.

By default, every image has one state—the Normal state. The Normal state corresponds to 
the appearance of an image when it is first loaded into a Web browser and no rollover 
effects have occurred. You can add states to an image that will occur when a viewer 
performs a mouse action—such as rolling or clicking—over an area of the Web page.

About working with layers in rollovers and animations 
You work with layers in ImageReady to create rollover buttons and animations. Placing the 
image content for a rollover on its own layer allows you to make changes to the layer’s 
style, visibility, and position to create rollover effects. Likewise, placing each element of an 
animation on its own layer establishes it as an independent object and enables you to 
change the position and appearance of the object across a series of frames.

You can also work with rollover effects for layer slices other than the one you have 
selected. You can use these remote rollovers to create effects such as launching an appli-
cation or running an animation in the Over state. See “Creating remote rollovers” on 
page 514.

Illustration of a rollover. The button is on its own layer; effects are added to the layer to create a 
new appearance of the button for the Over state. The text for the word “EVENTS” is also on a 
separate layer.
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Illustration of an animation. The bicycle image is on its own layer; the position of the layer changes 
in each frame of the animation.

Editing layers in rollover states and animation frames
Some changes you make to layers affect only the active rollover state or animation frame, 
while others affect every state and frame in which the layers are included.

State and frame-specific changes Affect only the active animation frame or rollover 
state. By default, changes you make to layers using Layers palette commands and 
options—including layer opacity, blending mode, visibility, position, and style—are state 
and frame-specific. However, you can apply layer changes to all states in a rollover and all 
frames in an animation using the unify buttons in the Layers palette. (See “Unifying and 
matching layer rollovers and animations” on page 509.)

Important: Changes you make to layers in the Normal state or Frame 1—including layer 
opacity, blending mode, visibility, position, and style—affect all states or frames in which 
the layers are identical. For example, consider a slice that has a Normal state, an Over 
state, and a Down state. If the layers in the Normal and Over states are identical, and you 
apply a layer style in the Normal state, the layer style will also be applied in the Over state.

Inclusive changes Affect every state and frame in which the layers are included. Changes 
you make to layer pixel values, using painting and editing tools, color and tone 
adjustment commands, filters, type, and other image-editing commands, are inclusive. 

Unifying and matching layer rollovers and animations
By default, changes you make to layers using Layers palette commands and options—
including layer visibility, position, and style—apply only to the frame or state (unless you 
are working with the Normal state or Frame 1). However, you can use the unify buttons in 
the Layers palette and the Match command to apply changes to all states in a rollover and 
all frames in an animation:

• The unify buttons determine how the changes you make to a layer in the active state or 
frame apply to the other states in a rollover or frames in an animation. When a unify 
button is selected, changes apply to all states and frames; when a button is deselected, 
changes apply to only the active state or frame.

• The Layer > Match command lets you apply the layer attributes for an existing state or 
frame to other states in a rollover and frames in an animation. 
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To unify layers in rollover states and animation frames:

Select one or more unify buttons in the Layers palette:

• Unify Layer Position button  to apply changes you make to a layer’s position to all 
states in a rollover and all frames in an animation. 

Note: The Unify Layer Position button places the contents of the selected layer in the same 
place on every frame in your animation. If you’re trying to show the layer contents moving 
in the animation, do not use this button.

• Unify Layer Visibility button  to apply changes you make to a layer’s visibility to all 
states in a rollover and all frames in an animation. 

• Unify Layer Style button  to apply changes you make to a layer’s style to all states in a 
rollover and all frames in an animation. 

To match an existing layer across rollover states and animation frames:

1 In the Web Content palette, select the state or frame with the layer attributes you want 
to use.

2 Select the layer you want to match in the Layers palette.

3 Choose Layer > Match, or choose Match from the Layers palette menu.

4 Select one of the following from the Match Layer dialog:

• Current Animation to apply layer attributes for the selected frame to all frames in the 
animation.

• Current Slice/Image Map’s States to apply layer attributes for the selected state to all 
states in the rollover.

• All Rollovers to apply layer attributes for the selected state to all states in all rollovers (in 
the image) that include the layer.

5 Select the layer attributes you want to match, and click OK.

Note: The default setting Propagate Frame 1 Changes dynamically updates all rollover 
states and animation frames, based on a change in the first frame’s position, visibility, or 
layer style. If you want the changes in Frame 1 to remain only in Frame 1, turn off this 
option by toggling it in the Layers palette pop-up menu.

Using the Web Content palette
The Web Content palette lets you create, view, and set options for the rollover states in an 
image. In addition to rollover states, the Web Content palette can display slices, image 
maps, and animation frames. Displaying slices and image maps helps you keep track of 
the elements in an image that contain rollover effects. Displaying animation frames makes 
it easy to see which states of an image contain animations.
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The Web Content palette with slices, image maps, and animation frames 
A. Normal state B. Image map with Over state C. Slice visibility icon D. Indicates this slice has an 
active rollover state E. Drag the pickwhip to the image window to make the targeted slice remote 
for this rollover state F. Indicates that the down state has a remote slice associated with it
G. Indicates that this slice has a remote target associated with it H. Indicates that this state has 
animation associated with it I. Indicates that this slice is a nested table J. Nested Slice info: slice 
number, layer-based indicator, remote-trigger badge K. Individual slice info: slice number, layer-
based indicator L. Remote slice info: slice number, layer-based indicator, remote-target badge

Displaying the Web Content palette Choose Window > Web Content. A check mark 
indicates that the palette is showing.

Using the Web Content palette menu Click the triangle  in the upper right corner of 
the palette to access commands for working with rollovers.

Displaying slices and image maps in the Web Content palette In the Web Content 
palette, there are sections for Image Maps  and Slices . Click the disclose triangle to 
view or hide them. An option in the Palette Options area of the Web Content palette menu 
toggles the display of slice badges, which are small icons on each slice that display the 
slice’s current properties.

Displaying animation frames in the Web Content palette Choose Palette Options from 
the Web Content palette menu. Select or deselect Include Animation Frames, and click OK.
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Changing the size of rollover thumbnails Choose Palette Options from the Web 
Content palette menu, and select a thumbnail size. For sizes other than None, select 
Object Bounds or Entire Document to determine the contents of thumbnails.

Expanding and collapsing states, slices, and image maps Click the triangle to the left 
of an item in the Web Content palette. Alt-click (Windows) or Option-click (Mac OS) 
expands or contracts all options.

Creating and editing rollovers 
You use the Web Content palette, in conjunction with the Layers palette, to add rollover 
effects to an image. When you save the image as a Web page, ImageReady adds JavaScript 
code to the resulting HTML file to specify rollover states.

Creating rollovers
You use a slice or image map area to define the active area for a rollover. When you add a 
new state to the image, you capture a snapshot of the slice or image map area in the 
previous state. You can then use the Layers palette to make changes to the image in the 
new state. When you save an image with rollover states and an HTML file, each rollover 
state is saved as a separate image file. (See “Saving selected rollover states to Web pages” 
on page 518.)

An image with three rollover states 
A. Normal state B. Over state C. Down state

To create a rollover:

1 Create a layer-based slice for the rollover. (See “Creating slices for rollovers” on 
page 513.) You can also use a layer-based image map to contain the rollover.

2 Create rollover states. (See “Creating and changing rollover states” on page 513.)

3 Select a state in the Web content palette and then edit the layer content for the state to 
create the rollover effect. (See “State and frame-specific changes” on page 509.)

You can use layer styles to create instant rollover effects. When working with layer-
based slices, you can also save the series of states as a rollover style. (See “Applying 

and creating rollover styles” on page 516.)

4 If you are creating a remote rollover, target the remote slice to the selected state. See 
“Creating remote rollovers” on page 514.

5 Preview the rollover. (See “Previewing rollover states” on page 515.)
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Creating slices for rollovers
You can quickly create layer-based slices for rollovers using the Web Content palette. 
Layer-based slices are recommended when creating rollovers because the dimensions of a 
layer’s content may change in the course of creating a rollover, and layer-based slices 
automatically adjust to encompass the new pixels. For more information on the different 
types of slices, see “Creating and viewing slices” on page 472.

To create a layer-based slice for a rollover:

1 Select the layer in the Layers palette, or choose Layer > New Layer-Based Slice from the 
main menu. The content of the layer will define the active area for the rollover. 

2 Click the Create Layer-based Rollover button  in the Web Content palette. 

By default, ImageReady adds an Over state to the new slice.

Creating and changing rollover states
When you create a rollover state, ImageReady assigns the type of state by default; 
however, you can easily change the state. 

To add a rollover state to a slice or image map:

1 In the Web Content palette or the image, select the slice or image map you want to add 
the rollover state to. 

Note: If slices are not visible in the Web Content palette, select Include Slices and Image 
Maps in the Palette Options dialog box to display them. (See “Using the Web Content 
palette” on page 510.)

2 Do one of the following in the Web Content palette:

• Click the Create Rollover State button .

• Choose New Rollover State from the palette menu.

3 Use the default rollover state assigned by ImageReady, or select a different rollover 
state.

To select a different rollover state:

1 Do one of the following:

• Double-click a rollover state in the Web Content palette.

• Select a rollover state in the Web Content palette, and choose Rollover State Options 
from the palette menu.

2 Select a state, and click OK.

Over Activates the image when the user rolls over the slice or image map area with the 
mouse while the mouse button is not pressed. (Over is automatically selected for the 
second rollover state.)

Down Activates the image when the user presses the mouse button on the slice or image 
map area. The state appears as long as the viewer keeps the mouse button pressed down 
on the area.

Click Activates the image when the user clicks the mouse on the slice or image map area. 
The state appears until the viewer moves the mouse out of the rollover area.
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Note: Different Web browsers, or different versions of a browser, may process clicks and 
double-clicks differently. For example, some browsers leave the slice in the Click state after 
a click, and in the Up state after a double-click; other browsers use the Up state only as a 
transition into the Click state, regardless of single- or double-clicking. To ensure your Web 
page will function correctly, be sure to preview rollovers in various Web browsers.

Custom Activates the image of the specified name when the user performs the action 
defined in the corresponding JavaScript code. (You must create JavaScript code and add 
it to the HTML file for the Web page in order for the Custom rollover option to function. 
See a JavaScript manual for more information.)

Selected Activates the rollover state when the user clicks the mouse on the slice or image 
map area. The state appears until the viewer activates another selected rollover state, and 
other rollover effects can occur while the selected state is active. For example, a selected 
state for one button and an over state for another button can occur simultaneously. 
However, if a layer is used by both states, the layer attributes of the selected state override 
those of the over state.

Select Use as Default Selected State to activate the state initially when the document is 
previewed in ImageReady or loaded into a Web browser.

Out Activates the rollover state when the user rolls the mouse out of the slice or image 
map area. (The Normal state usually serves this purpose.)

Up Activates the rollover state when the user releases the mouse button over the slice or 
image map area. (The Normal state usually serves this purpose.)

None Preserves the current state of the image for later use, but does not output an image 
when the file is saved as a Web page. 

Creating remote rollovers
You can set up a rollover to show or hide the content of a slice on another part of your Web 
page. ImageReady gives you control over which slices change on a rollover state, elimi-
nating unwanted images and complexity.

Note: In Photoshop 7.0 and earlier, all changes made to a document would appear when 
in a rollover state. This sometimes caused users to create state changes they didn’t intend. 
In ImageReady CS, you have much more control over which slices change on a rollover 
state.

To create a remote rollover:

1 Set up a rollover as you normally do. This becomes the button the user will click to 
display the remote content. See “Creating rollovers” on page 512.

2 Add the remote content to the document and create one or more slices to contain it.

3 For each rollover state, set the desired visibility of the remote content layers in the 
Layers palette.
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4 Specify which remote slices you want to include when you optimize output files in one 
of these ways:

• To manually mark the remote slices for an individual button, go to the Slice column of 
the Web Content palette and select the rollover state that will trigger the remote 
rollover (for example, Down or Click). Drag the Pickwhip icon  from the rollover state 
to the remote content slice in the document window.

A rollover state targeted to a remote slice

• To let ImageReady automatically find and mark all remote slices in the document, go to 
the Web Content palette menu and choose Find All Remote Slices.

• To let ImageReady automatically find and mark remote slices for a selected state, go to 
the Web Content palette menu and choose Find Remote Slices For State.

5 Preview the remote rollover in a browser. See “Previewing rollover states” on page 515.

Previewing rollover states
You can preview rollover effects directly in the ImageReady document window by 
switching to Document Preview Mode. To preview the rollover effect in your computer’s 
default Web browser, click the Preview in Default Browser button in the toolbox. 
(See “Previewing an image in a browser” on page 51.)

All remote rollovers affect a previewed document. If a slice has a change that is ignored 
(not targeted), you can see it in an ImageReady preview, but not in a browser.

To use rollover preview mode:

1 Do one of the following:

• Click the Preview Document button  in the toolbox.

• Choose Image > Preview Document.
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2 In the document window, perform the action that activates the rollover state. For 
example, position the mouse over the rollover slice or image map area to preview the 
Over state. Then click the slice or image map area to preview the Click state.

Note: If a document contains a Selected state, synthetic states are generated for the other 
states in the Web Content palette. The synthetic state represents the appearance of the 
document when the Selected state is active. Synthetic states are generated automatically 
and cannot be edited.

To exit rollover preview mode:

Do one of the following:

• Select any tool in the toolbox.

• Click the Cancel Preview button  in the options bar, or press Esc (Windows).

• Deselect Preview Document in the Image menu.

• Click the Preview Document button again to toggle it out of preview mode.

Adding animation to rollover states
You can add a multiple-frame animation to a state in an image. Adding an animation to 
the Normal state will cause the animation to play when the image is loaded in a Web 
browser. Adding an animation to another type of state will cause the animation to play 
when a user activates the state.

To add animation frames to a rollover state:

1 In the Web Content palette, select the state in which you want to display an animation. 
If necessary, expand the slice or image map to view its states. (See “Using the Web Content 
palette” on page 510.)

2 Make sure you can see the Create Animation Frame button and the New Animation 
Frame command. If they aren’t visible, select Include Animation Frames in the Palette 
Options dialog box. (See “Using the Web Content palette” on page 510.)

3 Do one of the following to add frames to the animation:

• Click the Create Animation Frame button  in the Web Content palette or choose New 
Animation Frame from the palette menu.

• Create frames in the Animation palette. (See “Animations” on page 518.)

Applying and creating rollover styles
Rollover styles (indicated by a triangle in the upper left corner of the style thumbnail) 
simplify rollover creation by allowing you to turn a layer into a rollover effect with a single 
click. A rollover style includes all the attributes of a rollover, including its states and layer 
effects. When you apply a rollover style to a layer, the layer becomes a layer-based slice.

To apply a rollover style to a layer:

1 Select a layer in the Layers palette.

2 Choose Window > Styles, or click the Styles palette tab, to display the Styles palette. 

3 Click the thumbnail for the rollover style you want to apply. Rollover style thumbnails 
have a triangle in the upper left corner. 
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To create a rollover style:

1 In the Web Content palette, create the desired rollover states. (See “Creating and 
changing rollover states” on page 513.)

Note: You must use a layer-based slice in order to create a rollover style.

2 Apply the effects to each state using predefined styles in the Styles palette or by 
manually setting layer effects in the Layers palette. (See “Using layer effects and styles” on 
page 391.)

3 In the Styles palette, click the Create New Style button , or choose New Style from the 
palette menu.

4 Enter a name for the style, set style options, and click OK. The Include Rollover States 
option must be selected in order to create a rollover style.

The new rollover style appears in the Styles palette. The thumbnail preview displays the 
effects in the Normal state.

Copying and pasting rollover states
You can copy a rollover state and paste it into another state in the current rollover or into a 
state in another rollover. Layers in the source state replace layers in the destination state.

You can also copy frames from the Animation palette and paste them into the Web 
Content palette as states, or copy states from the Web Content palette and paste them 
into the Animation palette as frames. 

Note: Copy commands in the Animation palette and the Web Content palette use an 
internal clipboard available to these commands only. Copying frames or rollover states 
does not overwrite the primary ImageReady clipboard.

To copy and paste rollover states:

1 Select a rollover state, and choose Copy Rollover State from the Web Content 
palette menu.

2 Select a rollover state in which to paste the copied state:

• Select a state in the current rollover.

• Open or display another rollover, and select a state.

3 Choose Paste Rollover State from the Web Content palette menu.

Duplicating rollover states
Duplicating a state is an easy way to add existing animation frames to a new state.

To duplicate a rollover state:

Select a rollover state, and do one of the following:

• Choose Duplicate Rollover State from the Web Content palette menu.

• Drag the state to the Create Rollover State button .

The duplicate state and frames appear below the original state in the Web Content palette.
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Rearranging and deleting rollover states
You can move states between slices and image maps by dragging them to a new location 
in the Web Content palette. You can also delete individual states or all states in a rollover.

To move states between slices and image maps:

Drag the state up or down in the Web Content palette. When the highlighted line appears 
in the desired position, release the mouse button. 

To delete rollover states:

• To delete one state, select a rollover state, and either click the Trash button  on 
the Web Content palette or choose Delete Rollover State from the Web Content 
palette menu.

• To delete all states in a rollover, choose Delete Rollover from the Web Content 
palette menu.

Saving selected rollover states to Web pages
To choose which button is shown as the default selected button when you first view 
your page in a browser, double-click the selected state of that button in the Web Content 
palette, and check Use as Default Selected State. This removes the previously selected 
state and makes your new selection the default.

If you want to generate a unique HTML page for each selected state, choose Output 
Settings > Saving HTML and Output Multiple HTML Files.

Web page with Down state saved as Default Selected State. The button on the page gives 
a visual clue as to the location in the Website.

Animations
ImageReady supports animations in Web pages, and provides tools for creating, editing, 
and displaying animations.

About animation
An animation is a sequence of images, or frames, that is displayed over time. Each frame 
varies slightly from the preceding frame, creating the illusion of movement when the 
frames are viewed in quick succession.
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An image can have multiple animations that are associated with different rollover states. 
For example, adding an animation to the Normal rollover state causes the animation to 
play when the Web page is first loaded by a Web browser. Adding an animation to another 
rollover state causes the animation to play only when the Web user performs the specified 
action (such as placing the mouse over the rollover or clicking the rollover). 

Creating and editing animations
You use the Animation palette, in conjunction with the Layers palette and Web Content 
palette, to create animation frames from an original, multilayer image. Basically, you turn 
layers on and off per each animation frame to animate the data on those layers. You can 
assign a delay time to each frame, use the Tween command to generate new frames, and 
specify looping for the animation. The number of frames you can create is limited only by 
the amount of memory available to ImageReady on your system.

Slice with animation frames in the Over state

Using the Animation palette
The Animation palette lets you create, view, and set options for the frames in an 
animation. You can change the thumbnail view of frames in the Animation palette—using 
smaller thumbnails reduces the space required by the palette and displays more frames in 
a given palette width.

Displaying the Animation palette Choose Window > Animation. A check mark indicates 
that the palette is showing.

Using the Animation palette menu Click the triangle  in the upper right corner of the 
palette to access commands for working with animations.

Changing the size of animation thumbnails Choose Palette Options from the 
Animation palette menu, select a thumbnail size, and click OK.

Adding frames
Adding frames is the first step in creating an animation. If you have an image open in 
ImageReady, the Animation palette displays the image as the first frame in a new 
animation. Each frame you add starts as a duplicate of the preceding frame. You then 
make changes to the frame using the Layers palette. 

Note: Always create and edit frames in Original view. While you can view frames in an 
optimized view, the editing options are very limited.
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To add a frame to an animation: 

1 In the Web Content palette, select the state in which you want to display an animation. 
(See “Using the Web Content palette” on page 510.)

Adding an animation to the Normal state will cause the animation to play when the image 
is loaded in a Web browser. Adding an animation to another type of state will cause the 
animation to play when a user activates the state. 

2 Make sure you can see the Create Animation Frame button and the New Animation 
Frame command. If they aren’t visible, select Include Animation Frames in the Palette 
Options dialog box. (See “Using the Web Content palette” on page 510.)

3 Do one of the following to add frames to the animation:

• Click the Duplicates Current Frame button  in the Web Content palette or choose New 
Animation Frame from the palette menu.

4 Modify the image for the frame using the Layers palette. (See “Using the Layers palette” 
on page 370.)

Selecting frames
Before you can work with a frame, you must select it as the current frame. The contents of 
the current frame appear in the document window.

You can select multiple frames, either contiguous or discontiguous, to edit them or apply 
commands to them as a group. When multiple frames are selected, only the current frame 
appears in the document window.

In the Animation palette, the current frame is indicated by a narrow border (inside the 
shaded selection highlight) around the frame thumbnail. Selected frames are indicated by 
a shaded highlight around the frame thumbnails. 

To select the current frame:

Do one of the following:

• Click a frame in the Animation palette.

• Click a frame in the Web Content palette. If necessary, expand the state that contains 
the animation to view its frames. (See “Using the Web Content palette” on page 510.)

• In the Animation palette or the Layers palette, click the Selects Next Frame button  
to select the next frame in the series as the current frame.

• In the Animation palette or the Layers palette, click the Selects Previous Frame 
button  to select the previous frame in the series as the current frame.

• In the Animation palette, click the Selects First Frame button  to select the first frame 
in the series as the current frame.

To select multiple frames:

In the Animation palette, do one of the following:

• To select contiguous multiple frames, Shift-click a second frame. The second frame and 
all frames between the first and second are added to the selection.

• To select discontiguous multiple frames, Ctrl-click (Windows) or Command-click 
(Mac OS) additional frames to add those frames to the selection.

• To select all frames, choose Select All Frames from the Animation palette menu.
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To deselect a frame in a multiframe selection:

Ctrl-click (Windows) or Command-click (Mac OS) a frame to deselect it.

Editing frames
You can use the Animation palette or the Web Content palette to target the image content 
of a frame for editing.

To edit the image content of a frame:

1 Select a frame. (See “Selecting frames” on page 520.)

2 Modify the image for the frame using the Layers palette. (See “Using the Layers palette” 
on page 370.)

Rearranging and deleting frames
You can change the position of frames in an animation and reverse the order of selected 
contiguous frames. You can also delete selected frames or the entire animation.

To change the position of a frame:

1 Select the frame you want to move in the Animation palette or the Web Content 
palette. 

2 Drag the selection to the new position.

Note: In the Animation palette, you can select and change the position of multiple frames. 
(See “Selecting frames” on page 520.) However, if you drag multiple discontiguous frames, 
the frames are placed contiguously in the new position.

To reverse the order of frames:

1 Select the frames you want to reverse. They do not have to be contiguous; you can 
reverse any selected frames.

2 Choose Reverse Frames from the Animation palette menu.

To delete selected frames:

Do one of the following in the Animation palette or the Web Content palette:

• Select Delete Frame from the palette menu.

• Click the Trash button , and click Yes to confirm the deletion.

• Drag the selected frame onto the Trash button.

To delete an entire animation:

Select Delete Animation from the Animation palette menu or the Web Content 
palette menu.
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Copying and pasting frames
To understand what happens when you copy and paste a frame, think of a frame as a 
duplicate version of an image with a given layer configuration. When you copy a frame, 
you copy the configuration of layers (including each layer’s visibility setting, position, 
and other attributes). When you paste a frame, you apply that layer configuration to the 
destination frame. 

To copy and paste layers between frames:

1 Select the frame you want to copy in the Animation palette or the Web Content palette.

Note: In the Animation palette, you can select and copy multiple frames. (See “Selecting 
frames” on page 520.) 

2 Choose Copy Frame(s) from the Animation palette menu or the Web Content palette 
menu.

3 Select a destination frame or frames in the current animation or another animation. 

4 Choose Paste Frame(s) from the Animation palette menu or the Web Content palette 
menu.

5 Select a Paste method:

• Replace Frames to replace the selected frames with the copied frames. When you 
paste frames into the same image, no new layers are added to the image; rather, the 
attributes of each existing layer in the destination frames are replaced by those of each 
copied layer. When you paste frames between images, new layers are added to the 
image; however, only the pasted layers are visible in the destination frames (the 
existing layers are hidden).

• Paste Over Selection to add the contents of the pasted frames as new layers in the 
image. When you paste frames into the same image, using this option doubles the 
number of layers in the image. In the destination frames, the newly pasted layers are 
visible, and the original layers are hidden. In the nondestination frames, the newly 
pasted layers are hidden.

• Paste Before Selection or Paste After Selection to add the copied frames before or after 
the destination frame. When you paste frames between images, new layers are added 
to the image; however, only the pasted layers are visible in the new frames (the existing 
layers are hidden). 

6 Select Link Added Layers if you want to link pasted layers in the Layers palette. Use this 
option when you need to reposition the pasted layers as a unit.

7 Click OK.

Tweening frames
You use the Tween command to automatically add or modify a series of frames between 
two existing frames—varying the layer attributes (position, opacity, or effect parameters) 
evenly between the new frames to create the appearance of movement. For example, if 
you want to fade out a layer, set the opacity of the layer in the starting frame to 100%; then 
set the opacity of the same layer in the ending frame to 0%. When you tween between the 
two frames, the opacity of the layer is reduced evenly across the new frames.
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The term “tweening” is derived from “in betweening,” the traditional animation term used 
to describe this process. Tweening significantly reduces the time required to create 
animation effects such as fading in or fading out, or moving an element across a frame. 
You can edit tweened frames individually after you create them.

Using tweening to animate text position

To create frames using tweening:

1 To apply tweening to a specific layer, select it in the Layers palette.

2 Select a single frame or multiple contiguous frames.

If you select a single frame, you choose whether to tween the frame with the previous 
frame or the next frame. If you select two contiguous frames, new frames are added 
between the frames. If you select more than two frames, existing frames between the first 
and last selected frames are altered by the tweening operation. If you select the first and 
last frames in an animation, these frames are treated as contiguous, and tweened frames 
are added after the last frame. (This tweening method is useful when the animation is set 
to loop multiple times.)

Note: You cannot select discontiguous frames for tweening.

3 Do one of the following:

• Click the Tween button  in the Animation palette.

• Select Tween from the Animation palette menu.

4 Specify the layer or layers to be varied in the added frames:

• All Layers to vary all layers in the selected frame or frames. 

• Selected Layer to vary only the currently selected layer in the selected frame or frames. 

5 Specify layer attributes to be varied:

• Position to vary the position of the layer’s content in the new frames evenly between 
the beginning and ending frames.

• Opacity to vary the opacity of the new frames evenly between the beginning and 
ending frames.

• Effects to vary the parameter settings of layer effects evenly between the beginning 
and ending frames.

6 If you selected a single frame in step 2, choose where to add frames from the Tween 
With menu:

• Next Frame to add frames between the selected frame and the following frame. This 
option is not available when you select the last frame in the Animation palette.

• First Frame to add frames between the last frame and first frame. This option is only 
available if you select the last frame in the Animation palette.
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• Previous Frame to add frames between the selected frame and the preceding frame. 
This option is not available when you select the first frame in the Animation palette.

• Last Frame to add frames between the first frame and last frame. This option is only 
available if you select the first frame in the Animation palette.

7 Enter a value, or use the Up or Down Arrow key to choose the number of frames to add. 
(This option is not available if you selected more than two frames. In this case, the 
tweening operation alters the existing frames between the first and last frames in the 
selection.)

8 Click OK.

Specifying looping
You select a looping option to specify how many times the animation sequence repeats 
when played.

To specify looping:

1 Click the looping option selection box at the lower left corner of the Animation palette.

2 Select a looping option: Once, Forever, or Other.

3 If you selected Other, enter a value in the Set Loop Count dialog box, and click OK.

Specifying delay for frames
You can specify a delay—the time that a frame is displayed—for single frames or for 
multiple frames in an animation. Delay time is displayed in seconds. Fractions of a second 
are displayed as decimal values. For example, one-quarter second is specified as .25. If you 
set a delay on the current frame, every frame you create after that will remember and 
apply that delay value.

To specify a delay time:

1 Select one or more frames.

2 In the Animation palette, click the Delay value below the selected frame to view the 
Delay pop-up menu.

3 Specify the delay:

• Choose a value from the pop-up menu. (The last value used appears at the bottom of 
the menu.)

•  Choose Other, enter a value in the Set Frame Delay dialog box, and click OK. 

If you selected multiple frames, specifying a delay value for one frame applies the value to 
all frames.

Note: Delay time may not be exactly accurate. Animations play differently on almost 
every browser or operating system. This feature is to set an approximate delay, and not 
meant to be exact. Browsers, however, do tend to preview a bit closer to actual delay time 
than ImageReady’s previewing.

Adding layers to frames
When you create a new layer, it is visible in all frames of an animation. To hide a layer in a 
specific frame, select the frame in the Animation palette, and then hide the desired layer in 
the Layers palette.
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You can use the Create Layer for Each New Frame option to automatically add a new layer 
to the image every time you create a frame. The new layer is visible in the new frame but 
hidden in other frames. Using this options saves time when you are creating an animation 
that requires you to add a new visual element to each frame.

To add a new layer every time you create a frame:

Choose Create Layer for Each New Frame from the Animation palette menu. A check mark 
indicates that the option is turned on.

Setting the frame disposal method 
The frame disposal method specifies whether to discard the current frame before 
displaying the next frame. You select a disposal method when working with animations 
that include background transparency in order to specify whether the current frame will 
be visible through the transparent areas of the next frame. 

Frame disposal methods 
A. Frame with background transparency with Restore to Background option
B. Frame with background transparency with Do Not Dispose option

The Disposal Method icon indicates whether the frame is set to Do Not Dispose  or 
Restore to Background . (No icon appears when disposal method is set to Automatic.)

To choose a disposal method:

1 Select a frame or frames for which you want to choose a disposal method. 

2 Right-click (Windows) or Control-click (Mac OS) the frame thumbnail to view the 
Disposal Method context menu.

3 Choose a disposal method:

• Automatic to determine a disposal method for the current frame automatically, 
discarding the current frame if the next frame contains layer transparency. For most 
animations, the Automatic option yields the desired results and is, therefore, the 
default option. 

Note: Choose the Automatic disposal option when using the Redundant Pixel Removal 
optimization option, to enable ImageReady to preserve frames that include transparency. 

• Do Not Dispose to preserve the current frame as the next frame is added to the display. 
The current frame (and preceding frames) may show through transparent areas of the 
next frame. To accurately preview an animation using the Do Not Dispose option, 
preview the animation in a browser.

• Restore to Background to discard the current frame from the display before the next 
frame is displayed. Only a single frame is displayed at any time (and the current frame 
will not appear through the transparent areas of the next frame). 

A

B
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Flattening frames into layers
You can flatten animation frames into layers. A single, composite layer is created for each 
frame, containing all of the layers in the frame. The original layers in the frame are hidden 
but preserved (the original layers will be available if they are needed for another frame).

Note: If you save an animation as a GIF, the animation frames are flattened and the 
original layers are lost. You should save the original file in Photoshop file format to 
preserve layers for reediting.

To flatten frames into layers:

In the Animation palette, choose Flatten Frames into Layers from the palette menu.

Viewing animations
Viewing an animation lets you preview the frames in timed sequence. You can preview an 
animation in ImageReady or in a Web browser.

To view an animation in ImageReady:

1 Click the Play button  in the Animation palette. The animation is displayed in the 
document window. The animation repeats indefinitely unless you specified another 
repeat value in the Play Options dialog box. (See “Specifying looping” on page 524.)

2 To stop the animation, click the Stop button .

3 To rewind the animation, click the Selects First Frame button .

To preview an animation in a browser:

1 Click the Preview in Default Browser button  in the toolbox or choose File > Preview 
In and select a browser from the submenu:

• System Default Browser opens the browser you’ve set as your chosen one.

• Other Browser lets you choose an application from your system.

• Edit Browser List lets you add browsers to the Other Browser list.

Note: Once you select a browser, the Default Browser button changes to the browser icon.

2 Use the browser’s Stop and Reload commands to stop or replay the animation.

Optimizing animations
You can apply optimization settings to animated images just as you do to nonanimated 
images. You should always optimize an animation in GIF format because GIF is the only 
format in ImageReady that supports the display of animated images on the Web. 

Note: While you can optimize an image that includes animation in JPEG or PNG format, 
these formats do not support animation. The resulting Web page will display only the 
current frame of the animation.

In addition to the standard optimization options for GIF format, you can optimize frames 
to include only areas that change from frame to frame. (This greatly reduces the file size of 
the animated GIF.) ImageReady also applies a special dithering technique to animations to 
ensure that dither patterns are consistent across all frames and to prevent flickering 
during playback. Due to these additional optimization functions, ImageReady may require 
more time to optimize an animated GIF than to optimize a standard GIF.
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To optimize an animated image:

1 Choose Optimize Animation from the Animation palette menu.

2 Set the following options:

• Bounding Box to crop each frame to the area that has changed from the preceding 
frame. Animation files created using this option are smaller but are incompatible with 
GIF editors that do not support the option. (This option is selected by default and is 
recommended.)

• Redundant Pixel Removal to make transparent all pixels in a frame that are unchanged 
from the preceding frame. This option is selected by default and is recommended. The 
Transparency option in the Optimize palette must be selected for redundant pixel 
removal to work. (See “Optimization options for GIF and PNG-8 formats” on page 537.)

Important: Set the frame disposal method to Automatic when using the Redundant Pixel 
Removal option. (See “Setting the frame disposal method” on page 525.)

3 Click OK.

4 Apply optimization settings. (See “Optimizing images” on page 531.)

When optimizing the colors in an animation, use the Adaptive, Perceptual, or Selective 
palette. This ensures that the colors are consistent across frames. (See “Generating a 

color table” on page 549.)

Viewing animated images in Photoshop
When you open a file containing an animation in Photoshop, only the frame that was 
selected when you saved the file in ImageReady is displayed. You cannot edit the 
animation frames separately, play the animation, or save the animation as an 
animated GIF.

If you add a new layer to the file while in Photoshop, the layer is added to all frames of the 
animation. However, the new layer will only appear in the selected frame when you 
reopen the file in ImageReady. If you change the stacking order of layers while in 
Photoshop, the stacking order of layers will be changed when you reopen the file in 
ImageReady.

Saving animations
You can save an animation as an animated GIF file, a QuickTime® movie, or a SWF 
(Macromedia® Flash™) file. You can also save each frame in an animation as a separate file.

For information on saving animations and other ImageReady files in the SWF format, 
see “Saving files in SWF format (ImageReady)” on page 576. 

Saving animation frames as separate files
You can export individual animation frames as separate files. Each file appears on a 
separate layer when imported into another program. See “Exporting animation frames as 
files” on page 528.
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Saving animations as animated GIFs
Animations that you view in a Web browser are called animated GIFs. When you save an 
optimized document containing an animation, you can choose to generate an HTML file 
that contains code for displaying the animated GIF in a Web page. The resulting Web page 
can contain just the animated GIF or additional Web features, such as links and rollovers, 
depending on the source document.

To save an animation as an animated GIF:

1 Optimize the animation. (See “Optimizing animations” on page 526.)

2 Save the optimized image. (See “Saving optimized images” on page 558.)

Saving animations as QuickTime movies
You can save an animation as a QuickTime movie. The resulting file is viewable in the 
QuickTime player and can be opened in other applications that support QuickTime movie 
format.

To save an animation as a QuickTime movie:

1 Choose File > Export > Original Document.

2 Select QuickTime Movie from the format pop-up menu.

Note: On Windows, QuickTime Movie format is only available when QuickTime is installed 
on your computer.

3 Type a filename, and choose a location for the file.

4 Click Save.

5 If desired, adjust the compression settings, and click OK. 

Exporting animation frames as files
You can export individual animation frames as files. You can export frames as Photoshop 
(PSD), GIF, JPEG, PNG 8, PNG 24, WBMP, or SWF. 

ImageReady provides a number of preset formats for animation files. You can also develop 
your own formats and add them to the library of presets.

To export animation frames as files:

1 Choose File > Export > Animation Frames as Files. 

2 In the File Options area of the dialog box, do the following:

• Enter a Base Name for new files. You may choose your own naming scheme if you wish.

• Click the Set button to set the file naming convention for new files. You can choose from 
a number of different conventions and postfixes.

• Click the Choose button to determine the location for saved files.

3 In the Save Options area, select the following options:

• Selected Frames Only to choose specific frames for export.

• Preview to display the current layer settings in the document. Use the forward and 
backward triangles to cycle through your selections.

• Apply to set the formatting preference.
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4 In the Format Options area, select a format from the Preset menu. You can save sets of 
formats and place them in a directory that ImageReady can see; this lets you build a library 
of presets from which to choose. You can also use an “unnamed” Preset, and fill in the 
appropriate values.

5 Based on your chosen Preset, the Format item receives an automatic value, or you give 
it a value for “unnamed.” The other options in the Format Options area are then filled in 
automatically to reflect the Preset/Format settings, or you can fill them in for your own 
unnamed Preset.

Opening and importing files as animations
You can use the animation features in ImageReady to edit animated GIFs, multilayered 
Photoshop files, and QuickTime movies.

Opening animated GIFs
You can open an existing animated GIF in ImageReady using the File > Open command. 
The file is opened as a stack of layers. Each layer corresponds to one frame. In each frame, 
the layer for that frame is visible, and the layers for the other frames are hidden.

Opening existing animated GIF files in ImageReady is useful primarily for applying 
optimization settings to the files. The one-layer-per-frame structure of imported animated 
GIF files may make it impractical to edit animation frames in other ways.

Opening Photoshop files as animations
You can easily create animated GIFs from existing one-layer-per-frame images in Adobe 
Photoshop file format or from a group of single-layer images.

You can make each layer in a multilayer Photoshop file a separate frame in the Animation 
palette. The layers are placed in the Animation palette in their stacking order, with the 
bottom layer becoming the first frame. 

You can also import a folder of files and use each file as a frame in ImageReady. Files can 
be in any format that ImageReady supports. Each file becomes a frame in the Animation 
palette. The files are placed in the Animation palette in alphabetical order by image 
filename.

To open a multilayer Photoshop file as frames:

1 Choose File > Open, and select the Photoshop file to open.

2 Choose Make Frames From Layers from the Animation palette menu.

Each layer in the image appears as a frame in the Animation palette. The bottom layer in 
the Photoshop image is frame 1 in the Animation palette.

Choose Reverse Frames from the Animation palette menu to reverse the order of 
frames.

To import a folder of files as frames:

1 Place the files to be used as frames into a folder. Make sure that the folder contains only 
those images that are to be used as frames. The resulting animation will display more 
successfully if all files are the same pixel dimensions. 
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To have frames appear in the correct order in the animation, name the files in alphabetical 
or numeric order, with the file to be used as frame 1 the first in order. (You can also change 
the order of the frames in the Animation palette after you import the files.)

2 Choose File > Import > Folder As Frames, and choose the folder to be imported.

The files appear in the Animation palette as frames and in the Layers palette as layers, with 
each layer assigned to a separate frame. The image that is first alphabetically or numeri-
cally by filename is frame 1 in the Animation palette and the bottom layer in the Layers 
palette.

Opening QuickTime movies as animations
You can open movies in MOV, AVI, and FLIC formats to view and edit in ImageReady. 

To open QuickTime-compatible movies:

1 Choose File > Open, and select the movie to open.

2 Select the range of frames to import:

• From Beginning to End to open the full file.

• Selected Range Only to open selected frames. Drag the slider below the movie 
thumbnail to specify the starting point for the range, and then Shift-drag to specify the 
ending point. (A black bar on the slider indicates the range you select.)

3 Select Limit to Every number Frame to specify which frames to include from the 
selected range. (You can use this option with either Range option.)

4 Click Open.
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Preparing Graphics for the Web

About optimization
Optimization is the process of fine-tuning the display quality and file size of an image for 
use on the Web or other online media. Adobe Photoshop and Adobe ImageReady give 
you an effective range of controls for compressing the file size of an image while 
optimizing its online display quality.

There are two methods of optimizing images:

• For basic optimization, the Photoshop Save As command lets you save an image as a 
GIF, JPEG, PNG, or WBMP file. Depending on the file format, you can specify image 
quality, background transparency or matting, color display, and downloading method. 
However, any Web features—such as slices, links, animations, and rollovers—that 
you’ve added to a file are not preserved.

For complete information on using the Save As command to save an image as a GIF, JPEG, 
or PNG file, see “Saving images” on page 564. 

• For precise optimization, you can use the optimization features in Photoshop or 
ImageReady to preview optimized images in different file formats and with different file 
attributes. You can view multiple versions of an image simultaneously and modify 
optimization settings as you preview the image to select the best combination of 
settings for your needs. You can also specify transparency and matting, select options 
to control dithering, and resize the image to specified pixel dimensions or a specified 
percentage of the original size.

When you save an optimized file using the Save for Web (Photoshop) or Save Optimized 
(ImageReady) command, you can choose to generate an HTML file for the image. This file 
contains all the necessary information to display your image in a Web browser.

The Save for Web (Photoshop) or Save Optimized (ImageReady) commands are designed 
specifically to provide a more robust and intuitive set of options for saving an image file 
for use on the Web. This includes a refined sensitivity to file size and image color palette 
that is unavailable from the Save As command. When creating graphics for Web use, the 
Save for Web / Save Optimized commands are recommended.

Optimizing images
In Photoshop, you use the Save for Web dialog box to select optimization options and 
preview optimized artwork. In ImageReady, you can view and work with optimized 
images at any time in the document window.
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Using the Save for Web dialog box (Photoshop)
You use the Save for Web dialog box to select optimization options and preview optimized 
artwork. 

Save for Web dialog box 
A. Toolbox B. Preview pop-up menu C. Optimize pop-up menu D. Color Table pop-up menu  
E. Zoom text box F. Original image G. Optimized image

Displaying the Save for Web dialog box Choose File > Save for Web.

Previewing images Click a tab at the top of the image area to select a display option: 
Original to view the image with no optimization, Optimized to view the image with the 
current optimization settings applied, 2-Up to view two versions of the image side by side, 
or 4-Up to view four versions of the image side by side. 

If the entire artwork is not visible in the Save for Web dialog box, you can use the Hand 
tool to bring another area into view. Select the Hand tool  (or hold down the spacebar), 
and drag in the view area to pan over the image. You can also use the Zoom tool to 
magnify or reduce the view. Select the Zoom tool , and click in a view to zoom in; 
hold down Alt (Windows) or Option (Mac OS), and click in a view to zoom out. Alternately, 
you can specify a magnification level in the Zoom text box/pop-up menu at the bottom of 
the Save for Web dialog box. You can type in a percentage or choose from one of the 
preset Zoom options.

Selecting a new version You can try different optimization settings in the Optimized 
pane or, to compare different optimizations side by side, use the 2-up or 4-up pane. If 
you’re working in 2-Up or 4-Up view, you must select a version before you apply optimi-
zation settings. A black frame indicates which version is selected.
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Viewing annotations The annotation area below each image in the Save for Web dialog 
box provides valuable optimization information. The annotation for the original image 
shows the filename and file size. The annotation for the optimized image shows the 
current optimization options, the size of the optimized file, and the estimated download 
time using the selected modem speed. You can choose a modem speed in the Preview 
pop-up menu.

Editing images in ImageReady To quickly transition to ImageReady for refined Web 
graphics preparation, click the Edit in ImageReady button at the bottom right of the 
dialog box.

Predicting final display in the Save for Web dialog box 
(Photoshop)
You can set the Save for Web dialog box to approximate color dithering and gamma in the 
viewer’s Web browser and monitor.

Previewing browser dither If an image contains more colors than the monitor can 
display, the browser will dither, or approximate, the colors that it cannot display by 
blending colors that it can. 

To show or hide preview of browser dither, choose Browser Dither from the Preview 
pop-up menu . A check mark indicates that browser dithering is active. Activating 
Browser Dither will not affect final image output.

Previewing gamma shifts The default gamma, or the brightness of midtone values 
produced by a display device, varies between operating systems. A graphic that 
appears properly on a Mac OS system may appear much darker on a Windows OS 
system. (See “Adjusting color display for cross-platform variations” on page 154 and 
“Adjusting the gamma value of an image (ImageReady)” on page 197 for cross-platform 
color discussions.)

To preview the shifts in gamma within the Save For Web dialog box, choose one of the 
options below from the Preview pop-up menu. (A check mark indicates that option is 
active. Activating a preview option will not affect final image output.)

• Uncompensated Color preview makes no adjustments to image gamma. Uncompen-
sated Color is the default setting.

• Standard Windows Color displays an adjustment based on the default Windows 
gamma.

• Standard Macintosh Color displays an adjustment based on the default Macintosh 
gamma.

• Use Document Color Profile will adjust the gamma to match any attached document 
color profile in a color managed document. (For more information about document 
color profiles, see “Embedding a profile in a document” on page 120 and “Changing the 
color profile of a document” on page 121.)
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Working with slices in the Save for Web dialog box (Photoshop)
If your artwork contains multiple slices, you must specify the slices to be optimized. You 
can apply optimization settings to additional slices by linking the slices. Linked slices in 
GIF and PNG-8 format share a color palette and dither pattern to prevent the appearance 
of seams between the slices.

To show or hide all slices in the Save for Web dialog box:

Click the Toggle Slices Visibility button .

To show or hide auto slices in the Save for Web dialog box:

Choose Hide Auto Slices from the Preview pop-up menu. A check mark indicates that 
slices are hidden.

To select slices in the Save for Web dialog box:

1 Select the Slice Select tool .

2 Click a slice to select it. Shift-click or Shift-drag to select multiple slices. 

Note: In the Save for Web dialog box, unselected slices are dimmed. This does not affect 
the color of the final image.

To view slice options in the Save for Web dialog box:

Select the Slice Select tool, and double-click a slice. (See “Working with image maps 
(ImageReady)” on page 494.)

To link slices:

1 Select two or more slices that you want to link. 

2 Choose Link Slices from the Optimize pop-up menu . 

The link icon  appears on the linked slices. 

To unlink slices:

Do one of the following:

• To unlink a slice, select the slice, and then choose Unlink Slice from the Optimize 
pop-up menu.

• To unlink all slices in an image, choose Unlink All Slices from the Optimize 
pop-up menu.

Using the Optimize palette (ImageReady)
You use the Optimize palette to select optimization options. This palette corresponds to 
the Optimize panel in the Photoshop Save for Web dialog box.

Displaying the Optimize palette Choose Window > Optimize. To show all the optimi-
zation options, click the Show Options control  on the Optimize palette tab, or choose 
Show Options from the Optimize palette menu. To display one set of options, click the 
Show Options control  for that set of options.

Using the Optimize palette menu Click the triangle  in the upper right corner of the 
palette to display the menu.
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Viewing optimized images (ImageReady)
In ImageReady, you view and work with optimized images directly in the document 
window. You can view up to four versions of an optimized image simultaneously, and 
easily switch between the optimized and original (non-optimized) versions of an image.

Document window in 4-Up mode

To preview optimized images:

Click a tab at the top of the document window to select a display option: 

• Original to view the image with no optimization.

• Optimized to view the image with the current optimization settings applied.

• 2-Up to view two versions of the image side by side.

• 4-Up to view four versions of the image side by side. 

You can switch between views by pressing Ctrl + Y (Windows) or Command + Y (Mac OS).

To select a view:

Click the view you want to select. A black frame indicates which view is selected.

Note: If you’re working in 2-Up or 4-Up view, you must select a view before you apply 
optimization settings. 

In 2-Up and 4-Up view, the annotation area below each view provides valuable optimi-
zation information. The annotation for the original image shows the filename and file size. 
The annotation for the optimized image shows the current optimization options, the size 
of the optimized file, and the estimated download time using the selected modem speed. 
You can choose a modem speed in the image information box at the bottom of the 
document window. (See “Displaying file and image information” on page 46.)

To hide or show optimization annotations in 2-Up and 4-Up mode:

Choose View > Hide Optimization Info or View > Show Optimization Info.



Using Help | Contents | Index Back 536  

Adobe Photoshop CS Help Preparing Graphics for the Web 

Using Help | Contents | Index Back 536  

Applying optimization settings
You use the Optimize panel in the Save for Web dialog box (Photoshop) and the Optimize 
palette (ImageReady) to set optimization options. If you’re working in 2-Up or 4-Up mode, 
you can repopulate the views to automatically generate lower-quality versions of the 
image based on the selected settings.

To apply optimization settings:

1 Select a view to which you want to apply optimization settings. 

2 If your artwork contains multiple slices, select one or more slices to which you want to 
apply the optimization settings. (See “Working with slices in the Save for Web dialog box 
(Photoshop)” on page 534 and “Selecting slices” on page 478.)

3 Do one of the following:

• Choose a named optimization setting from the Preset menu. For information on 
creating custom named settings, see “Saving and resetting optimization settings” on 
page 542.

• Choose a file format from the File Format menu. 

4 Set additional optimization options. The file format you chose in Step 3 determines 
which options are available to you. 

For more information on specific optimization options, see “Optimization options for GIF 
and PNG-8 formats” on page 537, “Optimization options for JPEG format” on page 540, 
“Optimization options for PNG-24 format” on page 541, and “Optimization options for 
WBMP format” on page 542.

To apply optimization settings based on file size:

1 Choose Optimize to File Size from the Optimize pop-up menu (Photoshop) or the 
Optimize palette menu (ImageReady).

2 Choose a Start With option:

• Current Settings to use current optimization settings.

• Auto Select GIF/JPEG to automatically generate a GIF or JPEG file. (Photoshop or 
ImageReady selects GIF or JPEG format, depending on its analysis of colors in the 
image.)

3 Enter a value for file size.

4 In the Use area, choose which slices to affect: Current, Each, or Total of All Slices. 
Click OK.

To repopulate optimization settings:

1 Apply optimization settings to a view in 2-Up or 4-Up mode.

2 Choose Repopulate Views from the Optimize pop-up menu (Photoshop) or the 
Optimize palette menu (ImageReady). 

The optimization settings for the selected view and the original view are not altered 
during repopulation. 

To restore an optimized version of an image to the original version:

1 Select an optimized version of the image in 2-Up or 4-Up mode.

2 In the Optimize panel/palette, choose Original from the Settings pop-up menu.
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Determining ideal image format
To determine your ideal image format, consider how your image is going to be used 
(for example, in Web or Print form) and what type of image it is (flat color vs. continuous 
tone). It’s best to save images with large areas of flat color as GIF or PNG-8 images. Save 
other images, such as those with color gradients or other continuous tones, as JPEG or 
PNG-24 files.

Another consideration is where the image will be viewed. The WBMP format, for example, 
is specifically designed for display on mobile devices.

Optimization options for GIF and PNG-8 formats
GIF is the standard format for compressing images with flat color and crisp detail, such as 
line art, logos, or illustrations with type. You can lower the size of GIF images by reducing 
the number of colors in the file. Like the GIF format, the PNG-8 format efficiently 
compresses solid areas of color while preserving sharp detail; however, not all Web 
browsers can display PNG-8 files. PNG-8 settings are very similar to the GIF settings. 
(See “About file formats” on page 582.)

Photoshop Optimization panel for GIF format 
A. File format menu B. Color Reduction Algorithm menu C. Dither Algorithm menu
D. Transparency dithering menu E. Optimize menu 

In ImageReady, you can control which options show in the Optimize palette by clicking 
the Show Options control  on the Optimize palette tab. To show all options, choose 
Show Options from the Optimize palette menu.

Lossy (GIF only) Specify a Lossy value to allow for lossy compression. Lossy compression 
reduces file size by selectively discarding data—a higher Lossy setting results in more data 
being discarded. You can often apply a Lossy value of 5–10, and sometimes up to 50, 
without degrading the image. File size can often be reduced 5%–40% using the Lossy 
option. 

You can use masks from type layers, shape layers, and alpha channels to vary lossy 
compression across an image. This technique produces higher-quality results in critical 
image areas without sacrificing file size. (See “Using weighted optimization” on page 545.)

Note: You cannot use the Lossy option with the Interlaced option or with Noise or Pattern 
Dither algorithms.
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Color Reduction Algorithm and Colors Choose an algorithm for generating a color 
table from the Color Reduction Algorithm menu. (See “Generating a color table” on 
page 549.) Then specify the maximum number of colors in the Colors text box. If you 
choose Restrictive (Web) for the color reduction algorithm, the Auto option becomes 
active in the Colors pop-up menu. Use the Auto option if you want Photoshop or 
ImageReady to determine the number of colors in the color table based on the frequency 
of colors in the image. The Auto option is one of the presets available in ImageReady.

You can use masks from type layers, shape layers, and alpha channels to vary color 
reduction across an image. This technique produces higher-quality results in critical image 
areas without sacrificing file size. (See “Using weighted optimization” on page 545.)

Dithering Dithering refers to the method of simulating colors not available in the color 
display system of your computer. Images with primarily solid colors may work well with no 
dither. Images with continuous-tone color (especially color gradients) may require 
dithering to prevent color banding.

GIF image with 0% dither (left), and with 100% dither (right)

Choose a option from the Dither Algorithm menu: 

• No Dither applies no dither to the image.

• Diffusion applies a random pattern that is usually less noticeable than Pattern dither. 
The dither effects are extended across adjacent pixels. If you select this algorithm, 
specify a Dither percentage to control the amount of dithering that is applied to the 
image. A higher dithering percentage creates the appearance of more colors and more 
detail in an image, but can also increase the file size. You can use masks from type 
layers, shape layers, and alpha channels to vary the Dither percentage across an image. 
This technique produces higher-quality results in critical image areas without sacri-
ficing file size. (See “Using weighted optimization” on page 545.)

Note: Diffusion dither may cause detectable seams to appear across slice boundaries. 
Linking slices diffuses the dither pattern across all linked slices, and eliminates the seams.

• Pattern applies a halftone-like square pattern to simulate any colors not in the color 
table.

• Noise applies a random pattern similar to the Diffusion dither algorithm, but without 
diffusing the pattern across adjacent pixels. No seams appear with the Noise algorithm. 

Transparency and Matte Select a combination of Transparency and Matte options to 
specify how transparent pixels in the image are optimized:

• To make fully transparent pixels transparent and blend partially transparent pixels with 
a color, select Transparency and select a matte color. 
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• To make all pixels with greater than 50% transparency fully transparent and all pixels 
with 50% or less transparency fully opaque, select Transparency and choose None from 
the Matte menu. 

• To fill fully transparent pixels with the selected color and blend partially transparent 
pixels with the same color, select a matte color and deselect Transparency.

Examples of transparency and matting 
A. Original image B. Transparency selected with a matte color C. Transparency selected with no 
matting D. Transparency deselected with a matte color

To select a matte color, click the Matte color swatch and select a color in the color picker. 
Alternately, choose an option from the Matte menu. The matte color should match the 
background color of the Web page.

Transparency Dithering When the Transparency option is selected, you can choose a 
method for dithering partially transparent pixels:

• No Transparency Dither applies no dither to partially transparent pixels in the image.

• Diffusion Transparency Dither applies a random pattern that is usually less noticeable 
than Pattern dither. The dither effects are diffused across adjacent pixels. If you select 
this algorithm, specify a Dither percentage to control the amount of dithering that is 
applied to the image. 

• Pattern Transparency Dither applies a halftone-like square pattern to partially 
transparent pixels.

A B
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• Noise Transparency Dither applies a random pattern similar to the Diffusion algorithm, 
but without diffusing the pattern across adjacent pixels. No seams appear with the 
Noise algorithm.

Example of Pattern Transparency dithering (left) and applied to a Web page background (right)

Interlaced Select Interlaced to download the image every other line with each pass.

Web Snap Specify a tolerance level for shifting colors to the closest Web palette equiva-
lents (and prevent the colors from dithering in a browser). A higher value shifts more 
colors. 

Use Unified Color Table (ImageReady) Select to use the same color table for all rollover 
states.

Add Metadata (ImageReady) Select to include image metadata with the image:

• Select either Add Custom ImageReady Metadata (Backward Compatible), Add EXIF 
Metadata (JPEG Only) or Add XMP Metadata.

• If you choose XMP, then choose an XMP Option: Write Minimal Set of XMP, Include 
Reference to Source File, or Write XMP to Separate Files.

Optimization options for JPEG format
JPEG is the standard format for compressing continuous-tone images such as 
photographs. Optimizing an image as a JPEG format relies on lossy compression, 
which selectively discards data. (See “About file formats” on page 582.)

Optimization panel for JPEG format 
A. File format menu B. Quality Level menu C. Optimize menu

Note: In ImageReady, you can control which options show in the Optimize palette by 
clicking the Show Options control  on the Optimize palette tab. To show all options, 
choose Show Options from the Optimize palette menu.
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Quality Choose an option from the Quality Level menu, or specify a value in the Quality 
text box. The higher the Quality setting, the more detail the compression algorithm 
preserves. However, using a high Quality setting results in a larger file size than using a low 
Quality setting. View the optimized image at several quality settings to determine the best 
balance of quality and file size.

You can use masks from type layers, shape layers, and alpha channels to vary the quality 
level across an image. This technique produces higher-quality results in critical image 
areas without sacrificing file size. (See “Using weighted optimization” on page 545.)

Optimized Select Optimized to create an enhanced JPEG with a slightly smaller file size. 
The Optimized JPEG format is recommended for maximum file compression; however, 
some older browsers do not support this feature.

Progressive Select Progressive to create an image that displays progressively in a Web 
browser. The image will display as a series of overlays, enabling viewers to see a low-
resolution version of the image before it downloads completely. 

Note: Progressive JPEGs require more RAM for viewing, and are not supported by some 
browsers.

Blur Specify the amount of blur to apply to the image. This option applies an effect 
identical to that of the Gaussian Blur filter and allows the file to be compressed more, 
resulting in a smaller file size. A setting of 0.1 to 0.5 is recommended.

Preserve ICC Profile Select Preserve ICC Profile to preserve the ICC profile of the artwork 
with the file. ICC profiles are used by some browsers for color correction. (See “Using color 
management to produce consistent color” on page 117.)

Matte Specify a fill color for pixels that were transparent in the original image:

• Click the Matte color swatch and select a color in the color picker. 

• Choose an option from the Matte menu. 

Pixels that were fully transparent in the original image are filled with the selected color; 
pixels that were partially transparent in the original image are blended with the selected 
color.

Add Metadata (ImageReady) Select to include image metadata:

• Select either Add Custom ImageReady Metadata (Backward Compatible), Add EXIF 
Metadata (JPEG Only), or Add XMP Metadata.

• If you choose XMP, then choose an XMP Option: Write Minimal Set of XMP, Include 
Reference to Source File, or Write XMP to Separate Files.

Optimization options for PNG-24 format
PNG-24 is suitable for compressing continuous-tone images; however, it produces much 
larger files than JPEG format. (See “About file formats” on page 582.)

The advantage of using PNG-24 is that it can preserve up to 256 levels of transparency in 
an image. To save an image with multilevel transparency, select Transparency. For more 
information on the Interlaced, Transparency, and Matte options, see “Optimization options 
for GIF and PNG-8 formats” on page 537.
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Optimization options for WBMP format
WBMP format is the standard format for optimizing images for mobile devices, such as cell 
phones. WBMP supports 1-bit color, which means that WBMP images contain only black 
and white pixels. 

To set WBMP options:

1 In the Save For Web dialog box (Photoshop) or Optimize palette (ImageReady), choose 
WBMP from the Optimized File Format pop-up menu. Preset automatically turns to 
[Unnamed]. 

2 Specify the Dither Algorithm:

• No Dither applies no dithering at all and gives straight black and white pixels.

• Diffusion applies a random pattern that is usually less noticeable than Pattern dither. 
The dither effects are diffused across adjacent pixels. If you select this algorithm, specify 
a Dither percentage to control the amount of dithering that is applied to the image. 
You can use masks from type layers, shape layers, and alpha channels to vary the Dither 
percentage across an image. This technique produces higher-quality results in critical 
image areas without sacrificing file size. (See “Using weighted optimization” on 
page 545.)

Note: Diffusion dither may cause detectable seams to appear across slice boundaries. 
Linking slices diffuses the dither pattern across all linked slices, and eliminates the seams.

• Pattern applies a halftone-like square pattern to determine the value of pixels.

• Noise applies a random pattern similar to the Diffusion dithering, but without diffusing 
the pattern across adjacent pixels. No seams appear with the Noise algorithm. 

Optimizing and saving images as SWF files (ImageReady)
In ImageReady, you can save image and animation files in the Macromedia Flash (SWF) 
format. Choose Export > Macromedia Flash (SWF) and set output options. See “Saving files 
in SWF format (ImageReady)” on page 576 for complete information on SWF exporting.

Saving and resetting optimization settings
You can save optimization settings as a named set and apply the settings to other images. 
Settings that you save appear in the Preset pop-up menu, together with the predefined 
named settings. If you edit a named set or a predefined set, the Preset menu displays the 
term “Unnamed.” 

In Photoshop, after you optimize an image, you can return to it without losing your 
settings. When you choose the Save for Web command again, the optimization settings 
are just as you left them. 

To save a named set of optimization settings:

1 Set optimization options as desired, and choose Save Settings from the Optimize 
palette menu.

2 Name the settings, and save them in the Presets/Optimized Settings folder inside the 
Photoshop program folder.

Note: If you save the settings in a location other than the Presets/Optimized Settings 
folder, they will not be available from the Preset pop-up menu.
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To edit a named set of optimization settings:

1 Choose the named set from the Preset pop-up menu.

2 Edit the optimization settings as desired. The Preset menu will display the term 
“Unnamed,” since the settings no longer match a named set.

3 Choose Save Settings from the Optimize pop-up menu (Photoshop) or the Optimize 
palette menu (ImageReady), and save the settings with the name of the original set.

To delete optimization settings:

1 Choose a named set or predefined set of optimization settings from the Preset 
pop-up menu.

2 Choose Delete Settings from the Settings panel menu. 

Note: You cannot restore deleted settings, so use the Delete Settings command with care.

To save the current optimization setting (Photoshop):

Do one of the following:

• To save the settings and close the Save for Web dialog box, click Done.

• To save the settings without closing the Save for Web dialog box, press Alt (Windows) or 
Option (Mac OS), and click Remember.

To reset optimization settings to the last saved version (Photoshop):

Press Alt (Windows) or Option (Mac OS), and click Reset.

Resizing the image during optimization (Photoshop)
When optimizing an image in the Photoshop Save For Web dialog box, you can resize the 
image to specified pixel dimensions or to a percentage of the original size. 

To change the pixel dimensions of an image during optimization:

1 Click the Image Size tab in the Save For Web dialog box.

2 To maintain the current proportions of pixel width to pixel height, select Constrain 
Proportions. 

3 Enter values for Width, Height, or Percent. 

4 Choose an interpolation method from the Quality pop-up menu:

• Nearest Neighbor for the faster, but less precise, method. This method is recommended 
for use with illustrations containing non-anti-aliased edges, to preserve hard edges and 
produce a smaller file.

• Bilinear 

• Bicubic for the slower, but more precise, method, resulting in smoother tonal grada-
tions.

• Bicubic Smoother

• Bicubic Sharper

For more information on interpolation, see “About resampling” on page 66.

5 Click Apply. 
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Controlling optimization (ImageReady)
By default, Photoshop and ImageReady automatically regenerate the optimized image 
when you click the Optimized, 2-Up, or 4-Up tab at the top of the document (if you have 
modified the image since the last optimization), when you change optimization settings 
with the optimized image displayed, or when you edit the original image.

In ImageReady, you can turn off auto-regeneration so that the last version of the 
optimized image remains in the image window until you manually reoptimize the image 
or reactivate auto-regeneration. This feature is useful if you want to edit the image without 
pausing for reoptimization with each modification. You can also cancel optimization while 
it’s in progress, and preserve the previous image.

When auto-regeneration is turned off, the Regenerate button  appears in the lower-
right corner of each optimized image view. A regeneration alert symbol also appears in 
the Color Table palette if the optimized image is in GIF or PNG-8 format, indicating that the 
color table is out of date. 

To turn Auto Regenerate on or off:

In the Optimize palette, choose Auto Regenerate from the palette menu. A check mark 
indicates that the option is turned on.

To manually optimize an image:

Choose a method for optimizing:

• Click the Regenerate button  in the lower right corner of the optimized image (if it 
appears).

• Choose Regenerate from the Optimize palette menu.

Note: Manually optimizing an image does not turn auto-regeneration on.

To cancel optimization:

Click the Stop button next to the progress bar at the bottom of the image window. 

Setting optimization preferences (ImageReady)
You can set preferences in ImageReady to determine the default optimization settings and 
the default configuration of panels in 2-Up and 4-Up views.

To set optimization preferences:

1 Do one of the following:

• In Windows, choose Edit > Preferences > Optimization.

• In Mac OS, choose ImageReady > Preferences > Optimization.

2 Choose an option in the Default Optimization section:

• Previous Settings to automatically apply the last used optimization settings.

• Auto Selected GIF or JPEG to automatically optimize the image as a GIF or JPEG. 
ImageReady selects GIF or JPEG based on an analysis of the image.

• Named Setting and select an option from the Named Settings pop-up menu to apply 
that setting.



Using Help | Contents | Index Back 545  

Adobe Photoshop CS Help Preparing Graphics for the Web 

Using Help | Contents | Index Back 545  

3 Under 2-Up Settings or 4-Up Settings, specify settings for the 1st, 2nd, 3rd, and 4th 
panes (3rd and 4th panes apply to 4-Up view only):

• Original to display the original image in the specified pane. (This option is available for 
the first pane only.)

• Current to display the image with current Optimize palette settings in the specified 
pane. (This option is available for all panes.)

• Auto to display a smaller optimized version of the image generated automatically by 
ImageReady, based on the current Optimize palette settings. (This option is available 
for the second, third, and fourth panes.)

• Select one of the named settings to display the optimized image with those settings. 
(This option is available for the second, third, and fourth panes.)

4 Click OK.

Using weighted optimization
Weighted optimization lets you smoothly vary optimization settings across an image using 
masks from text layers, shape layers, and alpha channels. This technique produces higher-
quality results in critical image areas without sacrificing file size. With weighted optimi-
zation, you can produce gradual variations in GIF, PNG-8, and WBMP dithering, lossy GIF 
settings, and JPEG compression. Weighted optimization also lets you favor colors in 
selected image areas when you generate a color table.

Image without weighted optimization (left), and with weighted optimization on text layers 
and vector shapes (right)

About masks and weighted optimization
Photoshop and ImageReady automatically generate masks when you create a type layer 
or a shape layer. You can also manually create masks and store them in alpha channels. 
When you use a mask to apply optimization settings, the white areas of the mask describe 
the highest level of image quality, while the black areas for the mask describe the lowest 
level of image quality. (The level of optimization in gray areas of the mask decreases by a 
linear scale.) 

Weighted optimization is available for specific settings in the Optimize panel/palette, as 
indicated by the Mask button . To access the weighted optimization dialog box, simply 
click the mask button.

Note: For the Lossy setting, a higher number actually means greater compression, as 
opposed to greater quality (as in most other settings).
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To create masks for use during optimization:

Do one or more of the following:

• Create a type layer. (See “Creating type” on page 438.)

• Create a shape layer. (See “Creating shapes” on page 291.)

• (Photoshop) Save a selection as a mask, or create a new alpha channel and use the 
painting and editing tools to modify it. (See “Storing masks in alpha channels” on 
page 254.)

• (ImageReady) Use a selection tool to select an area of the image. (See “About selec-
tions” on page 229.) Either save the selection using the Select > Save Selection 
command, or choose the Save Selection command from the Channel pop-up menu in 
the weighted optimization dialog box. 

Using masks to modify JPEG quality
When you use masks to optimize the range of quality in a JPEG image, white areas of the 
masks yield the highest quality, and black areas of the masks yield the lowest quality. 
You can adjust the maximum and minimum level of quality in the Modify Quality Setting 
dialog box.

To use masks to modify JPEG quality:

1 In the Optimize panel/palette, choose a JPEG setting from the Preset menu, or choose 
JPEG from the file format menu.

2 Click the Mask button  to the right of the Quality text box. 

3 Choose which masks to use:

• All Text Layers to use the masks from all text layers in the image.

• All Vector Shape Layers to use the masks from all shape layers in the image.

• Channel to choose an alpha channel from the menu. In ImageReady, you can choose 
Save Selection to create a new alpha channel based on the current selection.

4 To preview the results of the weighted optimization, select the Preview option.

5 Define the quality range:

• To set the highest level of quality, drag the right (white) tab on the slider, enter a value 
in the Maximum text box, or use the arrows to change the current value. 

• To set the lowest level of quality, drag the left (black) tab on the slider, enter a value in 
the Minimum text box, or use the arrows to change the current value. 

6 Click OK.

Using masks to modify GIF lossiness
When you use masks to optimize the amount of lossiness (or quality reduction) in a GIF 
image, white areas of the masks yield the highest quality, and black areas of the masks 
yield the lowest quality. You can adjust the maximum and minimum level of quality 
reduction in the Modify Lossiness Setting dialog box.
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To use masks to modify GIF lossiness:

1 In the Optimize panel/palette, choose a GIF setting from the Preset menu, or choose GIF 
from the file format menu.

2 Click the Mask button  to the right of the Lossy text box. 

3 Choose which masks to use:

• All Text Layers to use the masks from all text layers in the image.

• All Vector Shape Layers to use the masks from all shape layers in the image.

• Channel to choose an alpha channel from the menu. In ImageReady, you can choose 
Save Selection to create a new alpha channel based on the current selection.

4 To preview the results of the weighted optimization, select the Preview option.

5 Define the quality range:

• To set the highest level of quality, drag the left (white) tab on the slider, enter a value in 
the Minimum text box, or use the arrows to change the current value. 

• To set the lowest level of quality, drag the right (black) tab on the slider, enter a value in 
the Maximum text box, or use the arrows to change the current value. 

Note: Lossiness is a reduction in quality; therefore, the highest level of image quality is 
defined by the Minimum value, and the lowest level of image quality is defined by the 
Maximum value. This is the opposite of the JPEG quality setting.

6 Click OK.

Using masks to modify dithering
When you use masks to optimize the amount of dithering in a GIF, PNG-8, or WBMP image, 
white areas of the masks yield the most dithering, and black areas of the masks yield the 
least dithering. You can adjust the maximum and minimum levels of dithering in the 
Modify Quality Setting dialog box.

To use masks to modify dithering:

1 In the Optimize panel/palette, choose a GIF or PNG-8 setting from the Preset menu, 
or choose GIF or PNG-8 from the file format menu.

2 Click the Mask button  to the right of the Dither text box. 

3 Choose which masks to use:

• All Text Layers to use the masks from all text layers in the image.

• All Vector Shape Layers to use the masks from all shape layers in the image.

• Channel to choose an alpha from the menu. In ImageReady, you can choose Save 
Selection to create a new alpha channel based on the current selection.

4 To preview the results of the weighted optimization, select the Preview option.

5 Define the dithering range:

• To set the highest percentage of dithering, drag the right (white) tab on the slider, enter 
a value in the Maximum text box, or use the arrows to change the current percentage. 

• To set the lowest percentage of dithering, drag the left (black) tab on the slider, enter a 
value in the Minimum text box, or use the arrows to change the current percentage. 

6 Click OK.
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Using masks to modify color reduction
When you use mask to optimize the colors in a GIF or PNG-8 image, the white areas of 
the masks indicate to the color reduction algorithm which pixels are highly important, 
whereas black areas of the masks indicate which pixels are less important.

To use masks to modify color reduction:

1 In the Optimize panel/palette, choose a GIF or PNG-8 setting from the Preset menu, 
or choose GIF or PNG-8 from the file format menu.

2 Choose a color reduction algorithm and specify the maximum number of colors.

3 Click the Mask button  to the right of the Color Reduction Algorithm pop-up menu. 

4 Choose which masks to use:

• All Text Layers to use the masks from all text layers in the image.

• All Vector Shape Layers to use the masks from all shape layers in the image.

• Channel to choose an alpha channel from the menu. In ImageReady, you can choose 
Save Selection to create a new alpha channel based on the current selection.

5 To preview the results of the weighted optimization, select the Preview option.

6 Click OK.

Optimizing colors in GIF and PNG-8 images
Decreasing the number of colors in an image is a key factor in optimizing GIF and 
PNG-8 images. A reduced range of colors will often preserve good image quality while 
dramatically reducing the file space required to store extra colors.

The color table gives you precise control over the colors in optimized GIF and PNG-8 
images (as well as original images in indexed color mode). With a maximum of 256 colors, 
you can add and delete colors in the color table, shift selected colors to other colors or to 
transparency, and lock selected colors to prevent them from being dropped from the 
palette.

Viewing a color table
The color table for a slice appears in the Color Table panel in the Save for Web dialog box 
(Photoshop) or the Color Table palette (ImageReady). 

Note: In ImageReady, be careful not to confuse the Color Table palette with the Color 
palette or Swatches palette. You use the Color Table palette to optimize colors; you use the 
Color palette and Swatches palette to select colors.

To view the color table for an optimized slice:

1 (ImageReady) Choose Window > Color Table.

2 Select a slice that is optimized in GIF or PNG-8 format. (See “Selecting slices” on 
page 478.) The color table for the selected slice appears in the Color Table palette.

Note: In ImageReady, the color table for the selected slice will not appear if Auto 
Regenerate is off. For more information, see “Controlling optimization (ImageReady)” on 
page 544.
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If an image has multiple slices, the colors in the color table may vary between slices 
(you can link the slices first to prevent this from happening). If you select multiple slices 
that use different color tables, the color table is empty and its status bar displays the 
message “Mixed.” 

Generating a color table
You can change the palette—or set of colors—in the color table by selecting a color 
reduction option in the Optimize palette. There are three categories of options:

• Dynamic options use a color reduction algorithm to build a palette based on the colors 
in the image and the number of colors specified in the optimization setting. The colors 
in the palette are regenerated every time you change or reoptimize the image. 
Perceptual, Selective, and Adaptive are dynamic options.

• Fixed options use a set palette of colors. In other words, the set of available colors is 
constant, but the actual colors in the palette will vary depending on the colors in the 
image. Web, Mac OS, Windows, Black & White, and Grayscale tables are fixed options.

• The Custom option uses a color palette that is created or modified by the user. If you 
open an existing GIF or PNG-8 file, it will have a custom color palette.

To select a color reduction algorithm:

Choose an option from the Color Reduction Algorithm pop-up menu (below the file 
format menu in the Optimize panel/palette):

Perceptual Creates a custom color table by giving priority to colors for which the human 
eye has greater sensitivity. 

Selective Creates a color table similar to the Perceptual color table, but favoring broad 
areas of color and the preservation of Web colors. This color table usually produces images 
with the greatest color integrity. Selective is the default option.

Adaptive Creates a custom color table by sampling colors from the spectrum appearing 
most commonly in the image. For example, an image with only the colors green and blue 
produces a color table made primarily of greens and blues. Most images concentrate 
colors in particular areas of the spectrum. 

Restrictive (Web) Uses the standard 216-color table common to the Windows and 
Mac OS 8-bit (256-color) palettes. This option ensures that no browser dither is applied 
to colors when the image is displayed using 8-bit color. (This palette is also called the 
Web-safe palette.) If your image has fewer colors than the total number specified in the 
color palette, unused colors are removed.

Using the Web palette can create larger files and is recommended only when avoiding 
browser dither is a high priority. 

Custom Preserves the current color table as a fixed palette that does not update with 
changes to the image.

Black and White Creates a color table with only black and white pixels.

Grayscale Creates a color table with only grayscale pixels.

Mac OS Uses the Mac OS system’s default 8-bit (256-color) color table, which is based on a 
uniform sampling of RGB colors. If your image has fewer colors than the total number 
specified in the color palette, unused colors are removed.
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Windows Uses the Windows system’s default 8-bit (256-color) color table, which is based 
on a uniform sampling of RGB colors. If your image has fewer colors than the total number 
specified in the color palette, unused colors are removed.

Other color tables appear in the menu if you have saved them previously. (See “Loading 
and saving color tables” on page 555.)

You can use an alpha channel to influence the generation of color tables. (See “Using 
masks to modify color reduction” on page 548.)

To regenerate a color table (ImageReady):

Choose Rebuild Color Table from the Color Table palette menu. Use this command to 
generate a new color table when the Auto Regenerate option is off. (See “Controlling 
optimization (ImageReady)” on page 544.)

Changing the display of the color table
You can sort colors in the color table by hue, luminance, or popularity, making it easier to 
see an image’s color range and locate particular colors. In ImageReady, you can also 
change the size of the color swatches in the color table.

To sort a color table:

Choose a sorting order from the Color Table palette menu:

• Unsorted restores the original sorting order.

• Sort By Hue or by the location of the color on the standard color wheel (expressed 
as a degree between 0 to 360). Neutral colors are assigned a hue of 0 and located with 
the reds.

• Sort By Luminance or by the lightness or brightness of a color.

• Sort By Popularity or by the colors’ frequency of occurrence in the image.

To change the size of the color swatches (ImageReady):

Choose Small Swatches or Large Swatches from the Color Table palette menu.

Adding new colors to the color table
You can add colors that were left out in building the color table. Adding a color to a 
dynamic table shifts the color in the palette closest to the new color. Adding a color to a 
fixed or Custom table adds an additional color to the palette. (See “Generating a color 
table” on page 549.)

To add a new color:

1 Deselect all colors in the color table (see “Selecting colors” on page 551).

2 Choose a color by doing one of the following:

• Click the color selection box in the Save for Web dialog box (Photoshop) or the toolbox 
(ImageReady), and choose a color from the color picker.

• Select the Eyedropper tool  in the Save for Web dialog box (Photoshop) or the 
toolbox (ImageReady) and click in the image.

• Select the Eyedropper tool , click in the image, hold the mouse down, and drag 
anywhere on the desktop. You can use this option to select a color displayed in another 
application, such as a color in a Web page displayed in a browser.
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• (ImageReady) Select a color from the Color palette or the Swatches palette.

3 Do one of the following:

• Click the New Color button  in the Color Table palette. 

• Select New Color from the Color Table palette menu. 

• (ImageReady) Drag the color from the color selection box, Color palette, or Swatches 
palette to the Color Table palette.

To switch the color table to a Custom palette, hold down Ctrl (Windows) or Command 
(Mac OS) when you add the new color. 

The new color appears in the color table with a small white square in the lower right 
corner, indicating that the color is locked. (See “Locking colors in the color table” on 
page 554.) If the color table is dynamic, the original color is displayed in the upper left and 
the new color is displayed in the lower right.

Including black and white in a color table
You can add black and white to the color table when the image does not include these 
colors. Including black and white is useful when preparing files for multimedia authoring 
applications, such as Adobe After Effects.

To add black or white to the color table for an image:

1 Choose black or white as the foreground color. (See “Choosing foreground and 
background colors” on page 351.)

2 Add the color to the color table. (See “Adding new colors to the color table” on 
page 550.)

Selecting colors
You select colors directly in the optimized image or in the color table. In ImageReady, you 
can select a color from another application, such as a Web page displayed in a browser.

To select a color from the optimized image:

1 Select the Eyedropper tool  in the Save for Web dialog box (Photoshop) or the 
toolbox (ImageReady).

2 Click a color in the image. A white border  appears around that color in the color 
table. Shift-click to select additional colors.

To select a color from another application (ImageReady):

(ImageReady) Select the Eyedropper tool, click in the image, hold the mouse down, and 
drag anywhere on the desktop. You can use this option to select a color displayed in 
another application, such as a color in a Web page displayed in a browser.

To select a color directly in the color table:

Click the color in the Color Table palette.

To select a contiguous group of colors, press Shift and click another color. All colors in the 
rows between the first and second selected colors are selected.

To select a discontiguous group of colors, press Ctrl (Windows) or Command (Mac OS) and 
click each color that you want to select.
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To select colors based on a selection in the image (ImageReady):

1 Make a selection in the image using the selection tools or the Select menu commands.

2 Choose Select All From Selection from the Color Table palette menu.

To select all colors:

Choose Select All Colors from the Color Table palette menu. 

To select all Web-safe colors:

Choose Select All Web Safe Colors from the Color Table palette menu.

To select all non-Web-safe colors:

Choose Select All Non-Web Safe Colors from the Color Table palette menu.

To view selected colors in an image (ImageReady):

Select the optimized image. Then click and hold a selected color in the Color Table palette 
to temporarily invert the color in the optimized image, enabling you to see which areas of 
the image contain the color. 

To view a contiguous group of colors, press Shift and click and hold another color. All 
colors in the rows between the first and second selected colors are inverted.

To view a discontiguous group of colors, press Ctrl (Windows) or Command (Mac OS) and 
click each color that you want to select, and hold the mouse button down on any color in 
the group.

To deselect all colors:

Choose Deselect All Colors from the Color Table palette menu.

Shifting colors
You can change a selected color in the color table to any other RGB color value. When you 
regenerate the optimized image, the selected color changes to the new color wherever it 
appears in the image. 

To shift a color:

1 Double-click the color in the color table to display the default color picker.

2 Select a color.

The original color appears at the upper left of the color swatch and the new color at the 
lower right. The small square at the lower right of the color swatch indicates that the color 
is locked. If you shift to a Web-safe color, a small white diamond appears at the center of 
the swatch.

To revert shifted colors to their original colors:

Do one of the following:

• Double-click the swatch for the shifted color. The original color is selected in the color 
picker. Click OK to restore the color.

• To revert all shifted colors in a color table (including Web-shifted colors), choose Unshift 
All Colors from the Color Table palette menu.
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Shifting to Web-safe colors
To protect colors from dithering in a browser, you can shift the colors to their closest 
equivalents in the Web palette. This ensures that the colors won’t dither when displayed in 
browsers on either Windows or Macintosh operating systems capable of displaying only 
256 colors. 

To shift colors to the closest Web palette equivalent:

1 Select one or more colors in the optimized image or color table. (See “Selecting colors” 
on page 551.)

2 Do one of the following:

• Click the Web Shift button  in the Color Table palette. 

• Choose Shift Selected Colors to Web Palette from the Color Table palette menu.

The original color appears at the upper left of the color swatch and the new color at the 
lower right. The small white diamond  in the center of the color swatch indicates that the 
color is Web-safe; the small square at the lower right of the color swatch indicates that the 
color is locked.

To revert Web-shifted colors to their original colors:

Do one of the following:

• Select a Web-shifted color in the color table and click the Web Shift button  in the 
Color Table palette.

• To revert all Web-shifted colors in the color table, choose Unshift All Web Shifted Colors 
from the Color Table palette menu.

To specify tolerance for shifting colors automatically to the closest Web palette 
equivalents:

In the Optimize panel/palette, enter a value for Web Snap or drag the pop-up slider. 
A higher value shifts more colors. 

(In ImageReady, click the Show Options control  on the Optimize palette tab or choose 
Show Options from the Preset pop-up menu in the Optimize palette to view the Web Snap 
option.)

Mapping colors to transparency
You can add transparency to an optimized image by mapping existing colors to trans-
parency.

To map colors to transparency:

1 Select one or more colors in the optimized image or color table. (See “Selecting colors” 
on page 551.)

2 Do one of the following:

• Click the Map Transparency button  in the Color Table palette. 

• Choose Map Selected Colors to Transparent from the Color Table palette menu.

The transparency grid  appears in half of each mapped color. The small square at the 
lower right of the color swatch indicates that the color is locked.
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To revert transparency to its original colors:

Do one of the following:

• Select the colors you want to revert and click the Map Transparency button  or choose 
Unmap Selected Colors from Transparent from the Color Table palette menu.

• To revert all transparency-mapped colors, choose Unmap All Transparent Colors.

Locking colors in the color table
You can lock selected colors in the color table to prevent them from being dropped when 
the number of colors is reduced and to prevent them from dithering in the application.

Note: Locking colors does not prevent them from dithering in a browser. 

To lock a color:

1 Select one or more colors in the color table. (See “Selecting colors” on page 551.)

2 Lock the color by doing one of the following:

• Click the Lock button . 

• Choose Lock/Unlock Selected Colors from the Color Table palette menu. 

A white square  appears in the lower right corner of each locked color. 

Note: If the selected colors include both locked and unlocked colors, all colors will be 
locked.

To unlock a color:

1 Click the locked color to select it.

2 Unlock the color by doing one of the following:

• Click the Lock button .

• Choose Lock/Unlock Selected Colors from the Color Table palette menu. 

The white square disappears from the color swatch.

Deleting colors from the color table 
You can delete selected colors from the color table to decrease the image file size. When 
you delete a color, areas of the optimized image that previously included that color are 
rerendered using the closest color remaining in the palette.

When you delete a color, the color table automatically changes to a Custom palette. This is 
because the Adaptive, Perceptual, and Selective palettes automatically add the deleted 
color back into the palette when you reoptimize the image—the Custom palette does not 
change when you reoptimize the image.

To delete selected colors:

1 Select one or more colors in the color table. (See “Selecting colors” on page 551.)

2 Delete the color by doing one of the following:

• Click on the Trash button .

• Choose Delete Color from the Color Table palette menu. 
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Loading and saving color tables
You can save color tables from optimized images to use with other images and to load 
color tables created in other applications. Once you load a new color table into an image, 
the colors in the optimized image are changed to reflect the colors in the new color table.

To save a color table:

1 Select Save Color Table from the Color Table palette menu. 

2 Name the color table and choose a location where it will be saved. By default, the color 
table file is given the extension .act (for Adobe Color Table).

If you want to access the color table when selecting Optimization options for a GIF or PNG 
image, save the color table in the Presets/Optimized Colors folder inside the Photoshop 
program folder.

3 Click Save.

Important: When you reload the table, all shifted colors will appear as full swatches and 
will be unlocked.

To load a color table:

1 Select Load Color Table from the Color Table palette menu.

2 Navigate to a file containing the color table you want to load—either an Adobe Color 
Table (.act) file, an Adobe Color Swatch (.aco) file, or a GIF file (to load the file’s embedded 
color table).

3 Click Open.

Using master palettes (ImageReady)
You can create a master palette to use with a group of GIF or PNG-8 images that will be 
placed on a CD-ROM or other multimedia storage medium. When you include the master 
palette with a batch of images, all images display using the same colors.

To build a master palette, add colors from a set of images and then build and save the 
master palette. To create a master palette for a batch of images, add colors to the palette 
from other optimized images. 

To create and apply a master palette:

1 With an image displayed, choose Image > Master Palette > Clear Master Palette 
(if available). Clearing the master palette ensures that colors from previous images are 
not included in the new palette.

2 Open an image whose colors you want to include in a master palette.

3 Choose Image > Master Palette > Add To Master Palette. All color information for the 
current image is added to the master palette.

4 Repeat steps 2 and 3 for all images whose colors you want to include in the master 
palette.

5 In the Optimize palette, select optimization settings for the master palette.

6 Choose Image > Master Palette > Build Master Palette to create a new color table from 
the color information of images used in steps 2, 3, and 4.

7 Choose Image > Master Palette > Save Master Palette. 
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8 Name the master palette and choose a location where it will be saved. By default, the 
master palette file is given the extension .act (for Adobe Color Table).

If you want to access the color table when selecting Optimization options for a GIF or PNG 
image, save the master palette in the Optimized Colors folder, inside the Presets folder in 
the Adobe Photoshop folder.

9 Click Save.

10 To apply the master palette to the image or images for which it was created, open the 
image or images and select the master palette:

• If the master palette appears in the Color Reduction Algorithm menu in the Optimize 
palette, select the master palette from this menu. (The Color Reduction Algorithm 
menu includes all palettes saved in the Optimized Colors folder, inside the Presets 
folder in the Adobe Photoshop folder.)

• Load the master palette. (See “Loading and saving color tables” on page 555.)

Working with hexadecimal values for color 
You can view colors as hexadecimal values in the Info palette. In addition, you can copy 
colors as hexadecimal values to the Clipboard and paste them into an HTML document.

Viewing hexadecimal values for colors in the Info palette
In Photoshop, hexadecimal values for colors are displayed in the Info palette when you 
select Web Color Mode for one or both color readouts. In ImageReady, hexadecimal values 
for colors are displayed automatically in the right side of the Info palette, next to RGB color 
values. The Photoshop and ImageReady Info palettes also display other information, 
depending on the tool being used. 

To view hexadecimal color values in the Info palette:

1 Choose Window > Info or click the Info palette tab to view the palette.

2 (Photoshop) Choose Palette Options from the palette menu. Under First Color Readout 
or Second Color Readout, choose Web Color from the Mode menu and click OK.

3 Position the pointer over the color you want to view hexadecimal values for.

Copying colors as hexadecimal values
You can copy colors as hexadecimal values from files in Photoshop or ImageReady, using 
the context menu with the Eyedropper tool, or using menu commands. In Photoshop, 
you copy a color as a hexadecimal value while in the main work area (not the Save for Web 
dialog box). 

To copy a color as a hexadecimal value using the Eyedropper tool:

1 Select the Eyedropper tool  in the toolbox.

2 Select a color to copy:

• Right-click (Windows) or Control-click (Mac OS) a color in the image to select the color 
and view the Eyedropper tool context menu. 

• (ImageReady) Click the color in the image that you want to copy. The color you click 
becomes the foreground color. With the Eyedropper tool still over the image, right-click 
(Windows) or Control-click (Mac OS) to view the Eyedropper tool context menu.
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3 Choose Copy Color as HTML (Photoshop) or Copy Foreground Color as HTML 
(ImageReady) from the Eyedropper tool context menu.

The selected color is copied to the Clipboard as the HTML COLOR attribute with the 
hexadecimal value (COLOR=#XXYYZZ). To paste the color into an HTML file, choose Edit > 
Paste with the HTML file displayed in your HTML editing application. 

To copy a color as a hexadecimal value using menu commands:

1 Select a color to copy.

2 Copy the color by doing one of the following:

• Choose Copy Color As HTML from the Color palette menu.

• (ImageReady) Choose Edit > Copy Foreground Color as HTML. 

The foreground color is copied to the Clipboard as the HTML COLOR attribute with the 
hexadecimal value (COLOR=#XXYYZZ). To paste the color into an HTML file, open a 
destination application and choose Copy > Paste with the HTML file displayed.

To copy a color as a hexadecimal value by dragging (ImageReady):

Drag the Foreground Color from the toolbox, or a selected color from the Color Table 
palette or the Swatches palette, into the HTML file in the destination application. 

Note: This feature is not supported by all text and HTML editing applications. 

Using a droplet to automate optimization settings 
(ImageReady)
You can save Optimize palette settings for use on individual images or batches of images 
by creating a droplet, a small application that applies the optimization settings to an 
image or batch of images that you drag over the droplet icon. You can drag a droplet to 
the desktop or save it to a location on disk. When you create the droplet, you can choose 
where the images will be saved. When you drag an image over it, the droplet launches 
ImageReady if the program is not currently running. 

Note: You can also drag a droplet onto the ImageReady Actions palette to create an 
action step. Or you can drag a droplet from the Optimize palette onto a slice to apply the 
optimization settings to the slice. You cannot, however, drag a droplet from the desktop 
onto a slice.

To create a droplet for automating Optimize palette settings:

1 With an image displayed in the image window, choose a compression format and 
compression options in the Optimize palette.

2 Create a droplet by doing one of the following:

• Drag the droplet icon  from the Optimize palette onto the desktop. 

The droplet is named with a brief description of the compression settings, including file 
format and color palette, or quality setting information. You can rename the droplet as you 
do other desktop icons.
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• Click the droplet icon on the Optimize palette. Name the droplet, choose a location 
where the droplet will be saved, and click Save.

• Choose Create Droplet from the Optimize palette menu. Name the droplet, choose a 
location where the droplet will be saved, and click Save.

To use a droplet:

1 Drag a single image or a folder of images onto the droplet icon.

As the images are processed, a progress bar appears.

2 Do any of the following to control the processing:

• To temporarily pause the processing, click Pause. You can then click Resume to continue 
the processing.

• To cancel the processing, click Stop.

• Let the process finish on its own.

For more information on working with droplets, see “Using droplets” on page 644.

Saving optimized images
When you’ve applied a combination of settings that achieve a balance between quality 
and file size, you’re ready to save the optimized image.

To save an optimized image:

1 Select the view with the desired optimization settings, and do one of the following:

• (Photoshop) Click Save in the Save For Web dialog box.

• (ImageReady) Choose File > Save Optimized to save the file in its current state. If you 
previously saved the optimized file using the File > Save Optimized command, applying 
the command again saves the file with the filename and Save options specified in the 
first save operation. The Save dialog box does not appear.

• (ImageReady) Choose File > Save Optimized As to save an alternate version of the file 
with a different filename.

2 Type a filename, and choose a location for the resulting file or files. 

3 Choose a Format option:

• HTML and Images to generate all files required to use your artwork as a Web page. 
This includes an HTML file and separate image files for the slices in the artwork. The 
HTML file includes code for any links, image maps, and other effects in the document. 

• Images Only to save your artwork with the specified optimization settings. If the 
artwork contains multiple slices, each slice is saved as a separate file.

• HTML Only to generate an HTML file but not save any image files. 

4 To set preferences for saving image files and HTML files, choose predefined output 
options from the Settings pop-up menu, or choose Other to set different options. 
(See “Setting output options” on page 559.)
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5 Choose an option for slices from the pop-up menu:

• All Slices to save all slices in the image. 

• Selected Slices to save only the selected slices. If you select this option in conjunction 
with the HTML and Images option, ImageReady or Photoshop generates the HTML 
code based on the outermost bounds of the selected slices, and generates auto-slices 
as needed to create a complete HTML table.

• All User Slices to save only the slices that are user slices.

Note: You must select the desired slices before starting this procedure. 

• (ImageReady) A slice selection to save only the slices in the selection. You must save a 
slice selection in order for this option to appear in the menu. (See “Selecting slices” on 
page 478.)

6 Click Save.

Setting output options
When you save an optimized image as a Web page, you can specify how HTML files are 
formatted, how slices are named, how files are named, and how background images are 
handled. You set these options in the Output Settings dialog box. 

Using the Output Settings dialog box
The Output Settings dialog box displays different sets of options. In ImageReady, you can 
save your output settings and apply them to other files.

Displaying the Output Settings dialog box Do one of the following:

• When you save an optimized image, choose Other from the Settings pop-up menu in 
the Save Optimized or Save Optimized As dialog box. The Save and Load options are 
not available when you use this method to access the Output Settings dialog box.

• (ImageReady) Choose the desired preferences set from the File > Output Settings 
submenu or from the document window menu. Use this method if you want to load 
and save settings.

• (Photoshop) Choose Edit Output Settings from the Optimize pop-up menu in the Save 
For Web dialog box. Use this method if you want to load and save settings.

Displaying predefined output options Choose an option from the Preset pop-up 
menu.

Switching to a different set of options Choose an options set from the pop-up menu 
below the Preset menu. Alternately, click Next to display the next set in the menu list; 
click Prev to display the previous set.

Saving output settings Set the options as desired, and click Save. Type a filename, 
choose a location for the saved file, and click Save. 

You can save the output settings anywhere. However, if you place the file in the Presets/
Optimized Output Settings folder inside the Photoshop program folder, the file will 
appear in the Settings pop-up menu in both Photoshop and ImageReady.

Loading output settings Click Load, select a file, and click Open.
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Setting HTML output options
You can set the following options in the HTML set:

Output XHTML Creates tags meeting the XHTML standard on export. Choosing Output 
XHTML will make other output options that might conflict with this standard unavailable. 
Selecting this option will automatically set the Tags Case and Attribute Case options.

Tags Case Specifies the capitalization for tags. 

Attribute Case Specifies the capitalization for attributes.

Indent Specifies a method for indenting lines of code: using the authoring application’s 
tab settings, using a specified number of spaces, or using no indentation.

Line Endings Specifies a platform for line ending compatibility.

Encoding Specifies a default character encoding for the Web page.

Include Comments Adds explanatory comments to the HTML code. In ImageReady, this 
option is required when you plan to update the resulting file using the File > Update HTML 
command.

Always Add Alt Attribute Adds the ALT attribute to IMG elements to comply with 
government Web accessibility standards.

Always Quote Attributes Places quotation marks around all tag attributes. Placing 
quotation marks around attributes is required for compatibility with certain early 
browsers and for strict HTML compliance.

Close All Tags Adds close tags for all HTML elements in the file for XHTML compliance.

Include Zero Margins on Body Tag Removes default internal margins within a browser 
window.

Saving HTML files (ImageReady)
Use Long Filename Extension (.html) Uses .html rather than .htm as the file extension 
for Web pages.

Output Multiple HTML files Generates a unique HTML page for each slice containing a 
selected state.

HTML File Naming Sets naming conventions when multiple HTML files are generated.

Setting slice output options
You can set the following options in the Slices set:

Generate Table Aligns slices using an HTML table, rather than a Cascading Style Sheet. 

Empty Cells Specifies how empty slices are converted to table cells. Select GIF, IMG W&H 
to use a 1-pixel GIF with width and height values specified on the IMG tag. Select GIF, TD 
W&H to use a 1-pixel GIF with width and height values specified on the TD tag. Select 
NoWrap, TD W&H to place a nonstandard NoWrap attribute on the table data and also 
place width and height values specified on the TD tags.

TD W&H Specifies when to include width and height attributes for table data: Always, 
Never, or Auto (the recommended setting).

Spacer Cells Specifies when to add one row and one column of empty spacer cells 
around the generated table: Auto (the recommended setting), Auto (Bottom), Always, 
Always (Bottom), or Never. For table layouts in which slice boundaries do not align, adding 
spacer cells can prevent the table from breaking apart in some browsers.
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Generate CSS Generates a Cascading Style Sheet, rather than an HTML table. 

Referenced Specifies how slice positions are referenced in the HTML file when using CSS:

• By ID to position each slice using styles that are referenced by a unique ID

• Inline to include style elements in the declaration of the block element <DIV> tag

• By Class to position each slice using classes that are referenced by a unique ID

Default Slice Naming Choose elements from the pop-up menus or enter text into the 
fields to create default names for slices. Elements include document name, the word slice, 
numbers or letters designating slices or rollover states, slice creation date, punctuation, 
or none.

Setting image map output options (ImageReady)
You can set the following options in the Image Maps set:

Image Map Type Specifies what type of image map is created:

• Client-Side to include all required code for the image map in the image’s HTML file

• NCSA Server-Side to create a separate .map file in addition to the HTML file, using NCSA 
specifications

• CERN Server-Side to create a separate .map file in addition to the HTML file, using CERN 
specifications

Important: Photoshop and ImageReady cannot generate server-side image maps for 
images that contain slices.

• Client-Side & NCSA Server-Side to create both a client-side and server-side compatible 
image map, using NCSA specifications

• Client-Side & CERN Server-Side to create both a client-side and server-side compatible 
image map, using CERN specifications

Note: Contact your Internet service provider to find out whether to use NCSA or CERN 
specification for server-side image maps. 

Image Map Placement Specifies the location of the image map declaration (the <MAP> 
tag) in the HTML file:

• Top to place the image map declaration at the top of the HTML body section

• Body to place the image map declaration above the <IMG SRC> tag for the associated 
slice

• Bottom to place the image map declaration at the bottom of the HTML body section

Setting background options
You can set the following options in the Background set:

View Document As Select Image if you want the Web page to display an image or a solid 
color as a background behind the current image. Select Background if you want the Web 
page to display the optimized image as a tiled background.

Background Image Enter the location of an image file, or click Choose and select an 
image. The file you specify will be tiled behind the optimized image on the Web page.

BG Color Click the Color box and choose a background color using the color picker, 
or choose an option from the pop-up menu.
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Setting file saving options
You set the following options in the Saving Files set:

File Naming Choose elements from the pop-up menus or enter text into the fields to be 
combined into the default names for all files. Elements include document name, slice 
name, rollover state, trigger name, trigger number, file creation date, slice number, 
punctuation, and file extension. Some options are relevant only if the file contains slices or 
rollover states.

The fields let you change the order and formatting of the filename parts (for example, 
letting you indicate rollover state by an abbreviation instead of the full word).

Filename Compatibility Select one or multiple options to make the filename compatible 
with Windows (permits longer filenames), Mac OS 9 (filenames may be truncated after 
31 characters), and UNIX operating systems.

Optimized Files Choose from the following:

• Put Images In Folder specifies a folder name where optimized images are saved 
(available only with documents containing multiple slices).

• Use Long Filename Extensions (ImageReady) saves files using four-letter extensions for 
JPEG and WBMP files, if desired.

• Copy Background Image When Saving copies the background image file specified in 
the Background set into the images folder for the Web page. 

• Include Copyright (Photoshop) includes copyright information with the image. 
(See “Adding file information (Photoshop)” on page 590.)

Adding title and copyright information to Web pages
You can add title and copyright information to a Web page by entering information in the 
File Info dialog box. Title information displays in the Web browser’s title bar when the 
image is exported with an HTML file. Copyright information is not displayed in a browser; 
however, it is added to the HTML file as a comment and to the image file as metadata.

To enter information about an image:

1 Choose File > File Info.

2 Enter a title that will appear in the Web browser’s title bar:

• (Photoshop) In the General section of the File Info dialog box, enter the desired text in 
the Description text box.

• (ImageReady) Enter the desired text in the Description text box.

3 Enter copyright information:

• (Photoshop) In the General section of the File Info dialog box, enter the desired text in 
the Copyright Notice text box.

• (ImageReady) Enter the desired text in the Copyright Notice text box.

4 Click OK.

Including image metadata (ImageReady)
ImageReady allows the quick and easy inclusion of metadata, or data describing an image, 
when the image is saved for Web use in the GIF, JPEG, or PNG formats.This data can be 
copyright information or information about the author, for example.
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To include metadata with a saved image:

1 In the Optimize palette, open the Options section by clicking the swing-down arrow.

2 Select the Add Metadata check box.

To specify metadata options:

1 Do one of the following:

• Choose File > Output Settings > Metadata.

• In the Optimize palette, open the Options section by clicking the swing-down arrow. 
Click the Settings button.

2 Specify the metadata that should be included by clicking the box next to any of the 
options listed.

• Add Custom ImageReady Metadata includes simple copyright and description 
information from the File Info dialog. (See “Adding file information (Photoshop)” on 
page 590.)

• Add EXIF Metadata includes information stored with digital photographs, including 
camera type, date and time of photo, and file size. 

Note: To view the complete EXIF information for a file, view the file in the File Browser 
(Photoshop).

• Add XMP Metadata adds an Adobe-specific set of information that both provides 
information about the file and facilitates the use of files between Adobe applications. 
XMP metadata can be included with a file in one of three ways:

Write minimal set of XMP Includes only a small subset of the complete XMP metadata 
set, including file modification and output times, file dimensions, and format.

Include Reference to Source File Adds to the XMP a block of information that points to 
the original document—in other words, a path to that file.

Write XMP to separate files XMP data for the file is written to a separate file, instead of 
being embedded in the image file.
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Saving and Exporting Images

Saving images
The saving options vary between Photoshop and ImageReady. The primary focus of 
ImageReady is producing images for the Web. If ImageReady doesn’t provide the file 
format or option you need, you can edit in Photoshop. For more information on saving an 
image for the Web, see “About optimization” on page 531 and “Optimizing images” on 
page 531.

To preserve all the Photoshop features in your edited image (layers, effects, masks, styles, 
and so forth), it’s best to save a copy of your image in Photoshop format (PSD). (See 
“Photoshop format (PSD)” on page 583.) Like most file formats, PSD can only support files 
up to 2 GB in size. In Photoshop, if you are working with documents larger than 2 GB in file 
size, you can save your image in the new Large Document Format (PSB), Photoshop Raw 
(flattened image only), and TIFF (up to 4 GB in size only). For more information on saving 
large documents, see “Saving large documents (Photoshop)” on page 567.

About the save commands
You can use the following commands to save images:

• Save to save changes you’ve made to the current file. In Photoshop, the file is saved in 
the current format; in ImageReady, the Save command always saves to PSD format.

• Save As to save an image with a different location or filename. In Photoshop, the Save 
As command lets you save an image in a different format and with different options. 
In ImageReady, the Save As command always saves to PSD format.

• Export Original Document (ImageReady) to flatten the layers in a copy of the original 
image and save the copy in a variety of file formats. Some information (such as slices 
and optimization settings) is not preserved when an original image is saved to file 
formats other than Photoshop.

• Save a Version (Photoshop). This command is available for an image that is managed by 
a Version Cue Workspace. Versioning lets you save different versions of a file and 
comment on each. For more information, see “Working with Adobe Version Cue 
managed projects” on page 59.

If you’re working with a file from an Adobe Version Cue project, the document title bar 
provides additional information about the status of the file. (See “Working with Adobe 

Version Cue managed projects” on page 59.)

• Save for Web (Photoshop), Save Optimized (ImageReady), and Save Optimized As 
(ImageReady) to save an optimized image for the Web. See “Optimizing images” on 
page 531 and “Saving optimized images” on page 558.
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Note: 16-bit-per-channel images can only be saved in the following formats using the 
Save As command: Photoshop, Photoshop PDF, Photoshop Raw, Large Document Format 
(PSB), Cineon, PNG, and TIFF. When using the Save for Web command with a 16-bit-per-
channel image, Photoshop automatically converts the image from 16-bits per channel 
to 8-bits per channel.

Saving files
You can save a file with its current filename, location, and format or with a different 
filename, location, format, and options. You can also save a copy of a file while leaving the 
current file open on your desktop.

To save changes to the current file:

Choose File > Save. 

To save a file with a different name and location:

1 Choose File > Save As.

2 Type a filename, and choose a location for the file.

3 Click Save.

To save a file in a different file format:

1 Do one of the following:

• (Photoshop) Choose File > Save As.

• (ImageReady) Choose File > Export > Original Document. 

2 Do one of the following:

• In Photoshop, choose a format from the Format menu. 

• In ImageReady, choose from the Save as Type (Windows) or Format (Mac OS) menu.

Note: In Photoshop, if you choose a format that does not support all features of the 
document, a warning appears at the bottom of the dialog box. If you see this warning, it is 
recommended that you save a copy of the file in Photoshop format or in another format 
that supports all of the image data. 

3 Specify a filename and location.

4 (Photoshop) In the Save As dialog box, select saving options. For more information, 
see “Setting the file saving options (Photoshop)” on page 566.

5 Click Save.

In both Photoshop and ImageReady, a dialog box appears when saving in some image 
formats. For more information, see one of the following:

• “Saving files in Photoshop EPS format (Photoshop)” on page 570.

• “Saving files in BMP format” on page 571.

• “Saving files in GIF format (Photoshop)” on page 572.

• “Saving files in JPEG format (Photoshop)” on page 572.

• “Saving files in JPEG 2000 format (Photoshop optional plug-in)” on page 573. (The JPEG 
2000 format is only available if the optional JPEG 2000 plug-in is installed.)

• “Saving files in Photoshop PDF format (Photoshop)” on page 567.
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• “Saving files in PNG format (Photoshop)” on page 575.

• “Saving files in the QuickTime Movie format (ImageReady)” on page 576. (The 
QuickTime Movie format is only available if QuickTime® is installed on the computer.)

• “Saving files in SWF format (ImageReady)” on page 576.

• “Saving files in Targa format” on page 578.

• “Saving files in TIFF format” on page 578.

To copy an image without saving it to your hard disk, use the Duplicate command. 
(See“Duplicating images” on page 39.) To store a temporary version of the image in 

memory, use the History palette to create a snapshot. For more information, see “Making a 
snapshot of an image (Photoshop)” on page 37.

Setting the file saving options (Photoshop)
You can set a variety of file saving options in the Save As dialog box. The availability of 
options depends on the image you are saving and the selected file format. For example, 
if an image doesn’t contain multiple layers, or if the selected file format doesn’t support 
layers, the Layers option is dimmed. For file saving options in ImageReady, see “Optimizing 
images” on page 531 and “Saving optimized images” on page 558.

As a Copy Saves a copy of the file while keeping the current file open on your desktop.

Alpha Channels Saves alpha channel information with the image. Disabling this option 
removes the alpha channels from the saved image.

Layers Preserves all layers in the image. If this option is disabled or unavailable, all visible 
layers are flattened or merged (depending on the selected format). 

Annotations Saves annotations with the image. 

Spot Colors Saves spot channel information with the image. Disabling an option 
removes spot colors from the saved image. 

Use Proof Setup, ICC Profile (Windows), or Embed Color Profile (Mac OS) Creates a 
color-managed document.For more information, see “Embedding a profile in a 
document” on page 120. 

Important: The following image preview and file extension options are only available if 
the Ask When Saving option is chosen for Image Previews and Append File Extension in the 
File Handling Preferences dialog box. For more information, see “Setting preferences for 
saving files (Photoshop)” on page 593. 

Thumbnail (Windows) Saves thumbnail data for the file. 

Image Previews options (Mac OS) Saves thumbnail data for the file. Thumbnails display 
in the Open dialog box. You can set these image preview options: Icon to use the preview 
as a file icon on the desktop, Full Size to save a 72-ppi version for use in applications that 
can only open low-resolution Photoshop images, Macintosh Thumbnail to display the 
preview in the Open dialog box, and Windows Thumbnail to save a preview that can 
display on Windows systems. 

Use Lower Case Makes the file extension lowercase.

File Extension options (Mac OS) Specifies the format for file extensions. Select Append 
to add the format’s extension to a filename and Use Lower Case to make the extension 
lowercase.
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Saving large documents (Photoshop)
Photoshop supports documents up to 300,000 pixels in either dimension and offers 
three file formats for saving documents with images greater than 30,000 pixels in either 
dimension. Keep in mind that most other applications, including older versions of 
Photoshop, can only support files up to 2 GB in size or images up to 30,000 pixels in either 
dimension.

To save a document with a file size larger than 2 GB:

Choose File > Save As and choose one of the following file formats:

Large Document Format (PSB) Supports documents of any pixel size and any file size. 
All Photoshop features are preserved in PSB files. Currently, PSB files are only supported by 
Photoshop CS. In Preferences under File Handling, the Enable Large Document Format 
option must be selected before you can save files in PSB format. For more information 
about the PSB format, see “Large Document Format (PSB)” on page 586.

Photoshop Raw Supports documents of any pixel dimension or file size, but does not 
support layers. Large documents saved in the Photoshop Raw format are flattened. For 
more information about the Photoshop Raw format, see “Photoshop Raw (Photoshop)” on 
page 588.

TIFF Supports files up to 4 GB in size. Documents larger than 4 GB cannot be saved in TIFF 
format. For more information about the TIFF format, see “TIFF” on page 589.

To enable the Large Document Format in Photoshop:

1 Do one of the following:

• (Windows) Choose Edit > Preferences > File Handling.

• (Mac OS) Choose Photoshop > Preferences > File Handling.

2 Select the Enable Large Document Format (.psb) option.

Saving files in Photoshop PDF format (Photoshop)
You can use the Save As command to save RGB, indexed-color, CMYK, grayscale, Bitmap-
mode, Lab color, and duotone images in Photoshop PDF format. You can also use the PDF 
format to save multiple images in a multipage document or slide show presentation. 
(See “Creating a PDF presentation” on page 598.) Saving in Photoshop PDF format lets you 
specify security options for restricting access to the PDF document. The new 128-bit RC4 
(Acrobat 6) encryption has an option for letting users view metadata and thumbnails in a 
secure PDF document using the File Browser. For more information about the PDF format 
including the differences between Photoshop PDF and generic PDF, see “PDF” on 
page 586.

To save a file in Photoshop PDF format:

1 Choose File > Save As and choose Photoshop PDF from the Format menu. You can 
select a Color option if you want to embed a color profile or use the profile specified with 
the Proof Setup command. Click Save.

2 In the PDF Options dialog box, select the options you want, and click OK.



Using Help | Contents | Index Back 568  

Adobe Photoshop CS Help Saving and Exporting Images 

Using Help | Contents | Index Back 568  

Encoding Determines the compression method (Zip or JPEG). For more information, 
see “About file compression” on page 582.

Note: Bitmap-mode images are automatically encoded using CCITT compression—
the PDF Options dialog box does not appear.

Save Transparency Preserves transparency when the file is opened in another appli-
cation. (Transparency is always preserved when the file is reopened in Photoshop or 
ImageReady.) This option is not available if the file contains a spot color channel or does 
not contain transparency.

Image Interpolation Anti-aliases the printed appearance of a low-resolution image.

Downgrade Color Profile If you selected ICC Profile (Windows) or Embed Color Profile 
(Mac OS) for a version 4 profile in the Save dialog box, this option downgrades the profile 
to version 2. Select this option if you plan to open the file in an application that does not 
support version 4 profiles. 

PDF Security Specifies security options such as password protection and restricted 
access to a file’s content. Select PDF Security and then click the Security Settings button to 
open the PDF Security dialog box. Specify the security options that you want and then 
click OK. 

Include Vector Data Preserves any vector graphics (such as shapes and type) as 
resolution-independent objects, ensuring smoother output. When it is selected, you can 
select the following options:

• Embed Fonts ensures that all fonts used in the file are displayed and printed, even on 
computers that do not have the fonts installed. Bitmap fonts, fonts that don’t allow PDF 
embedding, substitute fonts, type that uses the faux bold style, and warped type 
cannot be embedded. Selecting Embed Fonts increases the size of the saved file.

• Use Outlines for Text saves text as paths. Select this option if embedding fonts results in 
a file that is too large, if you plan to open the file in an application that cannot read PDF 
files with embedded fonts, or if a font fails to display or print correctly. Text saved as 
outlines is not searchable or selectable in a PDF viewer. You can, however, edit the text 
when you reopen the file in Photoshop.

Note: The PDF viewer may display a substitute font if both Embed Fonts and Use Outlines 
for Text are deselected.

To specify PDF Security options:

1 In the PDF Options dialog box, select PDF Security and then click the Security Settings 
button to open the PDF Security dialog box. 

2 In the PDF Security dialog box, select Password Required to Open Document and 
specify a Document Open Password to prevent users from opening the document unless 
they type the password you specify. Passwords are case-sensitive.

3 Select Password Required to Change Permission and Passwords and specify a Permis-
sions Password to restrict users from printing and editing the file. Users cannot change 
these security settings unless they type the passwords that you specify. You cannot use 
the same password used for the Document Open Password. Users are required to enter 
the Permissions Passwords when opening the PDF file in Photoshop.
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4 Use the Compatibility menu to choose the type of encryption for opening a password-
protected document:

40-bit RC4 (Acrobat 3.x,4.x) Specifies a low encryption level.

128-bit RC4 (Acrobat 5) Specifies a high encryption level, but users of Acrobat 3 and 
Acrobat 4 cannot open PDF documents set with high encryption.

128-bit RC4 (Acrobat 6) Specifies a high encryption level, but users of Acrobat 3, 
Acrobat 4, and Acrobat 5 cannot open PDF documents set with this encryption. This 
encryption lets you enable plaintext metadata and thumbnails, an option not available in 
versions earlier than Acrobat 6.

5 In the Compatibility area of the PDF Security dialog box, specify the following options:

For 40-bit RC4 (Acrobat 3.x,4.x) encryption:

No Printing Prevents users from printing the document.

No Changing the Document Prevents the user from making any changes to the 
document, including filling in signature and form fields.

No Content Copying or Extraction, Disable Accessibility Prevents users from selecting 
and copying contents of the PDF document.

No Adding or Changing Comments and Form Fields Prevents the user from adding or 
making changes to comments and form fields.

For 128-bit RC4 (Acrobat 5) or 128-bit RC4 (Acrobat 6) encryption:

Enable Content Access for the Visually Impaired Lets visually impaired users use 
screen readers to read the document’s contents.

Allow Content Copying and Extraction Lets users select and copy the contents of the 
PDF document. It also lets utilities that need access to the contents of a PDF file, such as 
Acrobat Catalog, get to those contents.

No Encryption for Metadata and Thumbnail (Acrobat 6 only) Lets metadata and 
thumbnails in a secure PDF document be viewed in the File Browser. Among the many 
uses of this feature, you can let clients read information (metadata) and preview images 
without the need to give them the password for full access to the secure PDF document.

Changes Allowed Define which editing actions are allowed in the PDF document:

• None prevents the user from making any changes to the document, including filling in 
signature and form fields.

• Only Document Assembly lets users insert, delete, and rotate pages, as well as create 
bookmarks and thumbnail pages.

• Only Form Field Fill-in or Signing lets users fill in forms and add digital signatures. This 
option doesn’t let users add comments or create form fields.

• Comment Authorizing, Form Field Fill-in or Signing lets users fill in forms and add digital 
signatures, and comments.

• General Editing, Comment and Form Field Authoring lets users change the document 
using any method listed in the Changes Allowed menu, except remove pages.
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Printing Specify the quality of printing for the PDF document:

• Not Allowed prevents users from printing the document.

• Low Resolution lets users print the document at no higher than 150-dpi resolution. 
Printing may be slower because each page is printed as a bitmapped image.

• Fully Allowed lets users print at any resolution, directing high-quality vector output to 
PostScript and other printers that support advanced high-quality printing features.

6 Click OK.

Saving files in Photoshop EPS format (Photoshop)
Virtually all page layout, word processing, and graphic applications accept imported or 
placed EPS (Encapsulated PostScript) files. To print EPS files, you should use a PostScript 
printer. Non-PostScript printers will only print the screen-resolution preview. For more 
information about the Photoshop EPS format, see “Photoshop EPS” on page 584.

To save a file in Photoshop EPS format:

1 Choose File > Save As and choose Photoshop EPS from the Format menu.

2 In the EPS Options dialog box, select the options you want, and click OK:

Preview Creates a low-resolution image to view in the destination application. Choose 
TIFF to share an EPS file between Windows and Mac OS systems. An 8-bit preview delivers 
better display quality but larger file size than a 1-bit preview.

Encoding Determines the way image data is delivered to a PostScript output device:

• Choose ASCII or ASCII85 if you’re printing from a Windows system, or if you experience 
printing errors or other difficulties. 

• Binary produces a smaller file and leaves the original data intact. However, some page-
layout applications and some commercial print spooling and network printing 
software may not support binary Photoshop EPS files.

• JPEG compresses the file by discarding some image data. You can choose the amount of 
JPEG compression from very little (JPEG Maximum Quality) to a lot (JPEG Low Quality). 
Files with JPEG encoding can be printed only on Level 2 (or later) PostScript printers 
and may not separate into individual plates.

Include Halftone Screen and Include Transfer Function Control print specifications for 
high-end commercial print jobs. Consult your printer before selecting these options.

Transparent Whites Displays white areas as transparent. This option is available only for 
images in Bitmap mode. 

PostScript Color Management Converts file data to the printer’s color space. Do not 
select this option if you plan to place the image into another color-managed document. 
Doing so may disrupt the color management.

Note: Only PostScript Level 3 printers support PostScript Color Management for CMYK 
images. To print a CMYK image using PostScript Color Management on a Level 2 printer, 
convert the image to Lab mode before saving in EPS format.

Include Vector Data Preserves any vector graphics (such as shapes and type) in the file. 
However, vector data in EPS and DCS files is only available to other applications; vector 
data is rasterized if you reopen the file in Photoshop.

Image Interpolation Anti-aliases the printed appearance of a low-resolution image.
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Saving files in Photoshop DCS format (Photoshop)
DCS (Desktop Color Separations) format is a version of EPS that lets you save color separa-
tions of CMYK or multichannel files. For more information about the Photoshop DCS 
format, see “Photoshop DCS 1.0 and 2.0 (Photoshop)” on page 584.

To save a file in Photoshop DCS format:

1 Choose File > Save As and choose Photoshop DCS 1.0 or Photoshop DCS 2.0 from the 
Format menu. 

2 In the DCS Format dialog box, select the options you want, and click OK.

The dialog box includes all the options available for Photoshop EPS files. For more infor-
mation, see “Saving files in Photoshop EPS format (Photoshop)” on page 570. Additionally, 
the DCS menu gives you the option of creating a 72-ppi composite file that can be placed 
in a page layout application or used to proof the image:

• DCS 1.0 format creates one file for each color channel in the CMYK image. You can also 
create a fifth file: a grayscale or color composite. To view the composite file, you must 
keep all five files in the same folder.

• DCS 2.0 format retains spot-color channels in the image. You can save the color 
channels as multiple files (as for DCS 1.0) or as a single file. The single-file option saves 
disk space. You can also include a grayscale or color composite. 

Saving files in Photoshop Raw format (Photoshop)
The Photoshop Raw format is a file format for transferring images between applications 
and computer platforms. For more information about the Photoshop Raw format, see 
“Photoshop Raw (Photoshop)” on page 588.

To save a file in Photoshop Raw format:

1 Choose File > Save As and choose Photoshop Raw from the Format menu.

2 In the Photoshop Raw Options dialog box, do the following:

• (Mac OS) Specify a File Type and File Creator, or accept the default values.

• Specify a Header parameter.

• Select whether to save the channels in an interleaved or noninterleaved order. 

Saving files in BMP format
The BMP format is an image format for the Windows operating system. The images can 
range from black and white (1 byte per pixel) up to 24-bit color (16.7 million colors). 
For more information about the BMP format, see “BMP” on page 584.

To save a file in BMP format:

1 Do one of the following:

2 In Photoshop, choose File > Save As and choose BMP from the Format menu.

• In ImageReady, choose File > Export > Original Document, and choose BMP from the 
Save as Type (Windows) or Format (Mac OS) menu.

3 Specify a filename and location, and click Save.
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4 In the BMP Options dialog box, select a file format, specify the bit depth and, if 
necessary, select Flip Row Order. For more options, click Advanced Modes and specify the 
BMP options.

5 Click OK.

Saving 16-bit-per-channel files in Cineon format (Photoshop)
RGB images that are 16 bits per channel can be saved in Cineon format for use in the 
Kodak Cineon Film System. For more information about the Cineon format, see “Cineon” 
on page 584.

To save a 16-bit-per-channel file in Cineon format:

Choose File > Save As and choose Cineon from the Format menu.

Saving files in GIF format (Photoshop)
You can use the Save As command to save RGB, indexed-color, grayscale, or Bitmap-mode 
images directly in Compuserve GIF (known as GIF) format. The image is automatically 
converted to indexed-color mode. For more information about the GIF format, see “GIF” 
on page 585.

Note: You can also save an image as one or more GIF files using the Save for Web 
command (Photoshop) or the Save Optimized command (ImageReady). For more 
information on optimizing images, see “Optimizing images” on page 531.

To save a file in GIF format:

1 Choose File > Save As and choose CompuServe GIF from the Format menu.

2 For RGB images, the Indexed Color dialog box appears. Specify conversion options and 
click OK. For more information, see “Conversion options for indexed-color images 
(Photoshop)” on page 160.

3 Select a row order for the GIF file, and click OK:

• Normal displays the image in a browser only when download is complete.

• Interlaced displays low-resolution versions of the image in a browser as the file 
downloads. Interlacing makes download time seem shorter, but it also increases 
file size.

Saving files in JPEG format (Photoshop)
You can use the Save As command to save CMYK, RGB, and grayscale images in JPEG 
format. JPEG compresses file size by selectively discarding data. For more information, 
see “About file compression” on page 582 and “JPEG” on page 585.

Note: You can also save an image as one or more JPEG files using the Save for Web 
command (Photoshop) or the Save Optimized command (ImageReady). For more 
information on optimizing images, see “Optimizing images” on page 531.

To save a file in JPEG format:

1 Choose File > Save As and choose JPEG from the Format menu.

2 In the JPEG Options dialog box, select the options you want, and click OK.
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Matte If the image contains transparency, choose a Matte color to simulate the 
appearance of background transparency. For more information on simulating trans-
parency using the Matte option, see “Optimization options for GIF and PNG-8 formats” on 
page 537.

Image Options To specify the image quality, choose an option from the Quality menu, 
drag the Quality pop-up slider, or enter a value between 0 and 12 in the Quality text box.

Format Options Select Baseline (“Standard”) to use a format recognized by most Web 
browsers, Baseline Optimized for optimized color and a slightly smaller file size, or 
Progressive to display a series of increasingly detailed scans (you specify how many) as the 
image downloads. Baseline Optimized and Progressive JPEG images are not supported by 
all Web browsers. 

Size To view the estimated download time, select a modem speed. (The Size preview is 
only available when Preview is selected.)

Note: Some applications may not be able to read a CMYK file saved in JPEG format. In 
addition, if you find that a Java application cannot read your JPEG file (in any color mode), 
try saving the file without a thumbnail preview.

Saving files in JPEG 2000 format (Photoshop optional plug-in)
To save files in the JPEG 2000 format, the optional JPEG 2000 plug-in must be installed in 
Adobe Photoshop CS/Plug-Ins/Adobe Photoshop Only/File Formats. The optional JPEG 
2000 plug-in can be found on the Photoshop CS installation CD in Goodies/Optional 
Plug-Ins/Photoshop Only/File Formats. You can save images in extended JPEG 2000 (JPF) 
format, which provides an expanded set of options compared to the standard JPEG 2000 
(JP2) format. However, you can make files JP2 compatible by selecting the appropriate 
option in the JPEG 2000 dialog box. For more information on the JPEG 2000 format, see 
“JPEG 2000 (Photoshop optional plug-in)” on page 585.

Note: You cannot save Duotone, Multichannel, or Bitmap mode images in JPEG 2000 
format. To save these files as JPEG 2000, first convert them to RGB color.

To save a file in JPEG 2000 format:

1 Choose File > Save As, and choose JPEG 2000 from the Format menu.

2 Specify a filename and location, select saving options, and click Save, which opens the 
JPEG 2000 dialog box.

Important: If you want to save a JP2-compatible file, you must select the ICC Profile 
option (Windows) or the Embed Color Profile option (Mac OS) in the Save As dialog box. 
Otherwise, the JP2 Compatible option will be unavailable in the JPEG 2000 dialog box. The 
JP2-compatible option slightly increases the JPF file size. Keep in mind that JP2 viewers are 
not required to support ICC profiles and metadata present in JPF files, so color fidelity and 
other features may not work as expected.

3 (Optional) Enter a value in the File Size text box to set a target size for the saved file. 
The value in the Quality text box will adjust to the best quality for the file size you enter.



Using Help | Contents | Index Back 574  

Adobe Photoshop CS Help Saving and Exporting Images 

Using Help | Contents | Index Back 574  

4 Do one of the following to specify the image quality:

• Select Lossless to compress the image without losing image quality. Selecting this 
option creates a larger file.

• Deselect Lossless to create a smaller file. Then drag the Quality pop-up slider or enter a 
value in the Quality text box to specify the image quality. A higher quality value results 
in better image quality and a larger file size.

If you specify an image quality that conflicts with a target file size you entered previously, 
Photoshop automatically changes the value in the File Size text box. 

5 Select Fast Mode for faster previewing or encoding of the image. File size control, 
progressive optimization, and lossy with integer wavelet filter are not supported in 
Fast Mode.

6 Select Include Metadata to include file information. If your image file contains paths 
and you wish to store the paths information in the JPEG 2000 file, the Metadata option 
must be selected.

 Deselect the Include Metadata and Include Color Settings options to make the image 
file size smaller.

7 Select Include Transparency to preserve transparency that exists in the original image. 
The Include Transparency option is dimmed if the image does not contain transparency.

8 Select JP2 Compatible to create a file that can be displayed in viewing software that 
supports standard JPEG 2000 (JP2) format but does not support extended JPEG 2000 (JPF) 
format.

9 Click the Advanced Options button to set the following options:

Compliance Chooses the types of devices with which the file is compliant. Currently, only 
general devices (such as Web browsers) are supported. 

Wavelet Filter Specifies the type of numbers (coefficients) used to encode the file. Float 
is more accurate but cannot be used for Lossless compression. Selecting the Lossless 
compression option automatically sets the Wavelet Filter option to Integer.

Choose Float or Integer depending on your image and the result you want. Integer is 
usually the best option for an overall consistent appearance in the image. Float may 

sharpen the image but could cause it to lose some quality around edges.

Tile Size Chooses the size of the tiles used in the image. When low quality values are used 
to optimize images smaller than 1024 x 1024 pixels, using the largest tile size will produce 
better results.

A tile size of 1024 is best for most images. When creating files with small dimensions 
(for cell phones, and so forth), a lower tile size should be used.

Metadata Format Select the metadata format(s) to include in the image file. JPEG2000 
XML is JPEG 2000-specific XML data; this option is only available if the image file contains 
this data. XMP is File Info data and EXIF is digital camera data.
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Color Settings Format Select the Color Settings Format to include in the image file. The 
ICC Profile option includes the full ICC profile specified in the Save As dialog box and is the 
default option. The Restricted ICC Profile option is intended for use in portable devices 
such as cell phones and PDAs. A Restricted ICC Profile must be in a JP2 file.

10 Choose an Optimization Order from the Order menu:

Growing Thumbnail Presents a sequence of small thumbnail images increasing in size 
until they reach the image’s full size.

Progressive Presents an image that displays increasingly detailed versions of the entire 
image as data becomes available (for example, streaming over the Web to a browser). 
Progressive JPEG images have a slightly larger file size, require more RAM for viewing, 
and are not supported by all applications and JPEG 2000 viewing software.

Color Makes the image appear first as a grayscale image, then as a color image.

Region of Interest If your Photoshop document contains one or more alpha channels, 
you can choose an alpha channel to define a Region of Interest.

Once the alpha channel is loaded as a Region of Interest, choose an Enhance value to 
increase or decrease the quality of the Region of Interest relative to the rest of the image. 
Note that Enhance does not change the file size of the image, so enhancing the area inside 
the alpha channel will decrease the quality of the area outside the alpha channel (and vice 
versa).

The Region of Interest and Enhance options are not available if your Photoshop document 
does not have an alpha channel.

Note: The channel (alpha, spot, or Quick Mask) used to define the Region of Interest will be 
discarded in the final saved JPEG 2000 file.

11 To preview how the image will appear in JPEG 2000 viewing software, make sure you 
chose an Optimization Order in step 10. The Preview option takes into consideration how 
the image is optimized and will open the image accordingly. In the Download Preview 
area of the JPEG 200 dialog box, choose a download rate from the pop-up menu to view 
the estimated download time of the image, then click the Preview button.

You can use the Set Preview Zoom pop-up menu to zoom in or out of the image for better 
viewing. You can also use the Zoom tool  and the Hand tool  to adjust the viewing 
area of your preview.

12 When you’re done setting options, click OK to generate the JPEG 2000 image file.

Saving files in PNG format (Photoshop)
You can use the Save As command to save RGB, indexed-color, grayscale, and Bitmap-
mode images in PNG format. For more information on the PNG format, see “PNG” on 
page 587.

Note: You can also save an image as one or more PNG files using the Save for Web 
command (Photoshop) or the Save Optimized command (ImageReady). For more 
information on optimizing images, see “Optimizing images” on page 531.
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To save a file in PNG format:

1 Choose File > Save As and choose PNG from the Format menu.

2 Select an Interlace option:

• None displays the image in a browser only when download is complete.

• Interlaced displays low-resolution versions of the image in a browser as the file 
downloads. Interlacing makes download time seem shorter, but it also increases 
file size.

3 Click OK.

Saving files in the QuickTime Movie format (ImageReady)
The QuickTime format is used to play back, create, and deliver multimedia. To save in the 
QuickTime Movie format, you need QuickTime installed on your computer. For more 
information about the QuickTime Movie format, see “QuickTime Movie (ImageReady)” on 
page 587.

To save files in QuickTime Movie format:

1 Choose File > Export > Original Document, and choose QuickTime Movie from the Save 
as Type (Windows) or Format (Mac OS) menu.

2 Specify a filename and location, and click Save.

3 In the Compression Settings dialog box, choose a compression from the pop-up menu, 
specify the compression options, and then click OK.

Saving files in SWF format (ImageReady)
In ImageReady, you can export a document as a SWF file, which can then go directly to the 
Web or be imported into the Macromedia® Flash™ application. In a multilayered PSD file, 
each layer of the PSD file can be exported as one SWF object, or each layer can be 
exported as separate SWF files using the Layers as Files command. When the entire PSD 
file is exported to one SWF file, animation frames are exported as SWF animation frames. 
URLs in slices and image maps will be preserved when exported. Rollovers are ignored. 
The exported images will not change when you rollover them. For more information 
about the SWF format, see “SWF (ImageReady)” on page 589.

Layers in a PSD file can be preserved when exported from ImageReady and then 
imported into Macromedia Flash. Use the Layers as Files command to export the 

individual layers as separate SWF files. When the SWF files are imported in a SWF 
document, they each appear on separate layers. You can also export individual animation 
frames as separate SWF files using the Animation as Files command. Again, each SWF file 
appears on a separate layer when imported into Macromedia Flash.

To export an ImageReady file in SWF format:

1 Do one of the following:

• Choose File > Export > Macromedia® Flash™ SWF.

• Choose File > Export > Original Document. In the Export Original dialog box, choose 
Macromedia® Flash™ SWF from the Save as Type (Windows) or Format (Mac OS) menu. 
Enter a name for the SWF file and choose a destination. Click Save.
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The Macromedia® Flash™ (SWF) Export dialog box opens, letting you select options for 
exporting to SWF format.

2 Under Export Options, select from the following options:

Preserve Appearance Retains the appearance of the PSD file and may rasterize a text or 
shape layer if it cannot be exported natively to SWF. If Preserve Appearance is not selected, 
all effects that cause flattening or rasterization of vectors are dropped, including ones on 
raster layers.

Generate HTML Generates HTML in addition to the SWF file.

3 Select the Enable Dynamic Text option to map text variables to SWF dynamic text. SWF 
dynamic text disappears on import into Macromedia Flash. Therefore, mapping text 
variables to SWF dynamic text would only be useful if the generated SWF file is going 
directly to the Web.

4 Under Bitmap Options, either leave the Format menu set at Auto Select or choose a file 
format used for bitmap images. If you choose JPEG, you can enter JPEG Quality to specify 
how much compression to use.

5 Under Text Options, specify which characters to embed by choosing either None, Full 
Set, or Partial Set from the Embed Fonts menu.

If you choose Partial Set, click any of the following buttons to specify the characters of the 
partial set:

 includes all uppercase characters.

 includes all lowercase characters.

 includes all numbers.

 includes all punctuations.

You can also enter specific characters to embed in the Extra text box.

Note: Whenever possible, PSD text and vector layers are converted into SWF text and 
vector objects. If layer effects or blending modes prohibit a native mapping of text and 
vectors, they can then be flattened into bitmap objects.

6 Click OK. If you chose File > Export > Macromedia® Flash™ SWF in step 1, the Export as 
Macromedia™ SWF dialog box opens. Enter a name for the SWF file and choose a desti-
nation. Click Save.

To export layers or animation frames as individual SWF files:

1 Do one of the following:

• Choose File > Export > Layers as Files. If you’re exporting only specific layers, select the 
layers in the Layers palette before you choose the Layers as Files command.

• Choose File > Export > Animation as Files. If you’re exporting only specific frames, select 
the frames in the Animation palette before you choose the Animation as Files 
command.

2 In the Export Layers as Files dialog box, under File Options, click Browse (Windows) or 
Choose (Mac OS) to select a destination for the exported files.

3 Enter a name in the Base Name text box to specify a common name for the files.

4 Set the Save Options.
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5 Choose SWF from the Format menu under Format Options and set the options for your 
SWF files.

6 Click OK.

For more information about the options in the Export Layers as Files dialog box or the 
Export Frames as Files dialog box, see “Exporting layers as files (ImageReady)” on page 579 
and “Exporting animation frames as files (ImageReady)” on page 580.

Saving files in Targa format
The Targa (TGA) format supports images of any dimensions with between 1 and 32 bits of 
color. It is designed for Truevision's hardware, but it is also used in other applications. For 
more information on the Targa format, see “Targa” on page 589.

To save a file in Targa format (ImageReady):

1 Do one of the following:

• In Photoshop, choose File > Save As and choose Targa from the Format menu.

• In ImageReady, choose File > Export > Original Document, and choose Targa from the 
Save as Type (Windows) or Format (Mac OS) menu.

2 Specify a filename and location, and click Save.

3 In the Targa Options dialog box, select a resolution, select the Compress (RLE) option if 
you want to compress the file, and then click OK.

Saving files in TIFF format
TIFF is a flexible raster (bitmap) image format supported by virtually all paint, image-
editing, and page-layout applications. For more information on the TIFF format, see “TIFF” 
on page 589.

To save a file in TIFF format (Photoshop):

1 Choose File > Save As, and choose TIFF from the Format menu.

2 In the TIFF Options dialog box, select the options you want, and click OK.

Image Compression Specifies a method for compressing the composite image data. 
(See “About file compression” on page 582.)

Byte Order Photoshop and most recent applications can read files using either IBM PC or 
Macintosh byte order. However, if you don’t know what kind of program the file may be 
opened in, select the platform on which the file will be read.

Save Image Pyramid Preserves multiresolution information. Photoshop does not 
provide options for opening multiresolution files; the image opens at the highest 
resolution within the file. However, Adobe InDesign and some image servers provide 
support for opening multiresolution formats.

Save Transparency Preserves transparency as an additional alpha channel when the file 
is opened in another application. Transparency is always preserved when the file is 
reopened in Photoshop or ImageReady.
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Layer Compression Specifies a method for compressing data for pixels in layers (as 
opposed to composite data). Many applications cannot read layer data and will skip over it 
when opening a TIFF file. Photoshop, however, can read layer data in TIFF files. Although 
files that include layer data are larger than those that don’t, saving layer data alleviates the 
need to save and manage a separate PSD file to hold the layer data. Choose Discard Layers 
and Save a Copy to flatten the image. For more information on RLE and ZIP compression, 
see “About file compression” on page 582.

Note: To have Photoshop prompt you before saving an image with multiple layers, 
select Ask Before Saving Layered TIFF Files in the File Handling area of the Preferences 
dialog box.

To save a file in TIFF format (ImageReady):

1 Choose File > Export > Original Document, and choose TIFF from the Save as Type 
(Windows) or Format (Mac OS) menu.

2 Specify a filename and location, and click Save.

3 Select a compression method, and click OK.

Exporting layers as files (ImageReady)
You can export and save layers as individual files using a variety of formats, including PSD, 
GIF, JPEG, PNG, WBMP, and SWF. Different format settings can be assigned to individual 
layers, or one format can apply to all exported layers. Layers are saved with automatic file 
naming. You can set options to control the generation of names.

All format settings are saved with your ImageReady document for convenience when you 
use this feature again.

To export layers as files:

1 Choose File > Export > Layers as Files. If you’re exporting only specific layers, select the 
layers in the Layers palette before you choose the Layers as Files command.

Note: Click a layer in the Layers palette to select it. Shift-click to select a series of layers. 
Ctrl-click (Windows) or Command-click (Mac OS) to select noncontiguous layers.

2 In the Export Layers as Files dialog box, under File Options, click Choose to select a 
destination for the exported files.

3 Enter a name in the Base Name text box to specify a common name for the files. 

Click the Set button to set up specific options for file naming. Choose elements from the 
pop-up menus or enter text into the fields to be combined into the default names for all 
files. Elements include layer name, document name, layer number, file creation date, 
punctuation, and file extension.

4 Specify how you want to save the files by choosing from the following options:

• For Export, select the layers to be exported by choosing either All Layers, Top Level 
Layers and Layer Sets, or Selected Layers. The Selected Layers option is only available if 
you select layers before choosing the Layers as Files command. If your multilayered 
document has a Background layer, you can select the Include Background option to 
include it in the export. 
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• For Layer, choose a layer from the Layer pop-up menu if you are using a separate format 
for each layer. You can also use the navigation buttons   to choose the layer.

• For Apply, choose either One Format for All Layers or Separate Format for Each Layer.

To preview the exported image for a specific layer, select the Preview option and then 
use the either the Layer pop-up menu or navigation buttons to choose the layer to 

preview.

5 Under Format Options, either choose a setting from the Preset pop-up menu or 
manually set the file format and compression. For more information about format options 
and compression, see “About file formats” on page 582 and “About file compression” on 
page 582.

If you’re using a separate format for each layer, choose another layer and then set the 
format options. Do this for all the subsequent layers you’re exporting.

A custom setting can be saved for reuse. Adjust the settings. The Unnamed option is 
automatically chosen in the Preset menu. Click the Save Current Layer Settings icon , 
name the new setting, and save it to the Optimized Settings folder. You can also delete a 
setting by choosing it from the Preset menu and then clicking the Delete Current Layer 
Setting icon .

6 Click OK.

Exporting animation frames as files (ImageReady)
You can export and save animation frames as individual files using a variety of formats, 
including GIF, JPEG, PNG, WBMP, and SWF. Different format settings can be assigned to 
individual frames, or one format can apply to all exported frames. Frames are saved with 
automatic file naming. You can set options to control the generation of names.

All format settings are saved with your ImageReady document for convenience when 
using the feature again.

To export animation frames as files:

1 Choose File > Export > Animation Frames as Files. If you’re exporting only specific 
frames, select the frames in the Animation palette before you choose the Animation 
Frames as Files command.

Click a frame in the Animation palette to select it. Shift-click to select a series of frames. 
Ctrl-click (Windows) or Command-click (Mac OS) to select noncontiguous frames.

2 In the Export Animation Frames as Files dialog box, under File Options, click Choose to 
select a destination for the exported files.

3 Enter a name in the Base Name text box to specify a common name for the files. 

Click the Set button to set up specific options for file naming. Elements include document 
name, frame number, file creation date, punctuation, and file extension.
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4 If you selected frames in the Animation palette before choosing the Animation Frames 
as Files command, you can enable the Selected Frames Only option to export only the 
frames you selected. Deselecting this option exports all the frames in your animation 
regardless of whether you selected them or not.

To preview the exported image for a specific frame, select the Preview option and 
then use either the Preview menu or navigation buttons   to choose the frame to 

preview.

5 Under Format Options, either choose a setting from the Preset pop-up menu or 
manually set the file format and compression. For more information about format options 
and compression, see “About file formats” on page 582 and “About file compression” on 
page 582.

A custom setting can be saved for reuse by clicking the Save Current Format Preset icon , 
naming the new setting, and saving it to the Optimized Settings folder. You can also delete 
a setting by choosing it from the Preset menu and then clicking the Delete Current Format 
Preset icon .

6 Click OK.

Exporting images in ZoomView format (Photoshop)
ZoomView is a format for delivering high-resolution images over the Web. With the 
Viewpoint Media Player, users can zoom into or out of an image and pan the image to see 
its various parts. 

When you export an image in ZoomView format, Photoshop creates the following files:

• An MTX file that defines the image to be displayed.

• An HTML file that loads the Viewpoint Media Player and points to the MTX file.

• A folder containing tiles that are used to display the image. 

• A folder containing VBS and JavaScript scripts that are used by the HTML file.

To export an image in ZoomView format:

1 Choose File > Export > ZoomView.

2 Set the following options, and click OK:

Template Specify a template for generating the MTX, HTML, and auxiliary files. Choose a 
template (Plain or With Instructions) from the pop-up menu, or click the Load button to 
choose a different ZoomView Template (ZVT) file. You can download additional templates 
from the Viewpoint Web site.

Output Location Click Folder to specify an output location. Enter a name in the Base 
Name text box to specify a common name for the files. 

Path to Broadcast License File Specify a URL for the broadcast license file. The 
Viewpoint Corporation requires that all publishers of ZoomView content acquire a 
broadcast license. To apply for a key, click Get License.

Image Tile Options ZoomView technology uses image tiling to load only the part of a 
high-resolution image that a user wants see. Select a Tile Size to control how many pixels 
are in each tile. A tile size of 128 is recommended for small images; a tile size of 256 is 
recommended for large images. 
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To specify an amount of compression for each tile image, choose an option from the 
Quality menu, drag the Quality pop-up slider, or enter a value between 0 and 13 in the 
Quality text box. Select Optimize Tables to create enhanced JPEGs with slightly smaller file 
sizes. This option is recommended for maximum file compression.

Browser Options Specify a width and height for the image in the Viewpoint Media 
Player. Select Preview in Browser to launch your default Web browser and load the 
generated HTML file after you click OK.

About file formats
Graphic file formats differ in the way they represent image data (as pixels or as vectors), in 
compression technique, and in which Photoshop and ImageReady features they support. 
With the exception of the Large Document Format (PSB), Photoshop Raw, and TIFF, all file 
formats can only support documents with a file size of 2 GB or less.

For more information on choosing file formats when opening or saving images, 
see “Opening and importing images” on page 101 and “Saving images” on page 564. For 
information on choosing a Web optimization format, see “Optimizing images” on 
page 531 and “Saving optimized images” on page 558.

Note: If a supported file format does not appear in the appropriate dialog box or 
submenu, you may need to install the format’s plug-in module. (See “Using plug-in 
modules” on page 57.)

About file compression
Many file formats use compression to reduce the file size of bitmap images. 
Lossless techniques compress the file without removing image detail or color information; 
lossy techniques remove detail. The following are commonly used compression 
techniques:

RLE (Run Length Encoding) Lossless compression; supported by some common 
Windows file formats.

LZW (Lemple-Zif-Welch) Lossless compression; supported by TIFF, PDF, GIF, and 
PostScript language file formats. Most useful for images with large areas of single color.

JPEG (Joint Photographic Experts Group) Lossy compression; supported by JPEG, TIFF, 
PDF, and PostScript language file formats. Recommended for continuous-tone images, 
such as photographs. JPEG uses lossy compression. To specify image quality, choose an 
option from the Quality menu, drag the Quality pop-up slider, or enter a value between 0 
and 12 (Photoshop) or 0 and 100 (ImageReady) in the Quality text box. For the best 
printed results, choose maximum-quality compression. JPEG files can be printed only on 
Level 2 (or later) PostScript printers and may not separate into individual plates.

CCITT A family of lossless compression techniques for black-and-white images; 
supported by the PDF and PostScript language file formats. (CCITT is an abbreviation for 
the French spelling of International Telegraph and Telekeyed Consultive Committee.)

ZIP Lossless compression; supported by PDF and TIFF file formats. Like LZW, ZIP 
compression is most effective for images that contain large areas of single color.

PackBits (ImageReady) Lossless compression that uses a run-length compression 
scheme; supported by the TIFF file format in ImageReady only.
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Photoshop format (PSD)
Photoshop format (PSD) is the default file format and the only format that supports 
most Photoshop features besides the Large Document Format (PSB). Due to the tight 
integration between Adobe products, other Adobe applications like Adobe Illustrator, 
Adobe InDesign, Adobe Premiere, Adobe After Effects, and Adobe GoLive can directly 
import PSD files and preserve many Photoshop features. For more information, see Help 
for the specific Adobe applications; also see “Saving images for use in video” on page 604 
and “Saving images for use in motion graphics” on page 607.

When saving a PSD file for use in a previous version of Photoshop or ImageReady, you can 
set a preference to maximize file compatibility.

To maximize compatibility with previous versions of Photoshop and with other 
applications (Photoshop):

1 Do one of the following:

• In Windows, choose Edit > Preferences > File Handling.

• In Mac OS, choose Photoshop > Preferences > File Handling.

2 Choose Always from the Maximize PSD File Compatibility menu. This saves a composite 
(flattened) image along with the layers of your document.

Note: If file size is an issue or if you’re only opening your files in Photoshop, turning off 
Maximize PSD File Compatibility reduces the file sizes significantly. In the Maximize PSD 
File Compatibility menu, choose either Ask to prompt you on whether to maximize 
compatibility when saving or Never to save your document without maximizing 
compatibility. 

If you edit or save an image using an earlier version of Photoshop, unsupported features 
are discarded. Keep in mind the following features when working with earlier versions of 
Photoshop:

• Photoshop CS introduces nested layers, Hard Mix blending mode, Photo Filter 
adjustment layers, 56 channel limit, text on a path, support for files greater than 2GB, 
support for files greater than 30,000 pixels in any dimension, non-square pixels 
support, 16-bit layers, 16-bit patterns, and 16-bit Brushes.

• Photoshop 7.0 introduced the Linear Burn, Linear Dodge, Vivid Light, Linear Light, and 
Pin Light blending modes and the Layer Mask Hides Effect and Vector Mask Hides Effect 
advanced blending options.

• Photoshop 6.0 introduced layer sets, layer color coding, layer clipping paths, fill layers, 
layer styles, editable type, and advanced type formatting. Photoshop 6.0 also added 
new layer effects.

• Photoshop 5.0 introduced layer effects; however, effects added in later versions of 
Photoshop are not supported. Photoshop 5.0 also introduced color samplers, spot 
channels, and embedded ICC profiles.

• Photoshop 4.0 introduced adjustment layers and guides.

Photoshop 2.0 (Photoshop)
(Mac OS) You can use this format to open an image in version 2.0 or to export an image to 
an application supporting only Photoshop 2.0 files. Saving in Photoshop 2.0 format 
flattens your image and discards layer information.
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QuickTime Movie (ImageReady)
QuickTime (.mov) is a file format for the playback and media authoring of audio and video 
on both Windows and Mac OS. The QuickTime Movie format is visible in the Export 
Original Document’s Save as Type (Windows) or Format (Mac OS) menu only if QuickTime 
is installed on the computer.

BMP 
BMP is a standard Windows image format on DOS and Windows-compatible computers. 
BMP format supports RGB, Indexed Color, Grayscale, and Bitmap color modes. You can 
specify either Windows or OS/2® format and a bit depth for the image. For 4-bit and 8-bit 
images using Windows format, you can also specify RLE compression. 

BMP images are normally written bottom to top; however, you can select the Flip Row 
Order option to write them from top to bottom. You can also select an alternate encoding 
method by clicking Advanced Modes. (Flip Row Order and Advanced Modes are most 
relevant to game programmers and others using DirectX.)

Photoshop EPS 
Encapsulated PostScript (EPS) language file format can contain both vector and bitmap 
graphics and is supported by virtually all graphic, illustration, and page-layout programs. 
EPS format is used to transfer PostScript-language artwork between applications. When 
you open an EPS file containing vector graphics, Photoshop rasterizes the image, 
converting the vector graphics to pixels.

EPS format supports Lab, CMYK, RGB, Indexed Color, Duotone, Grayscale, and Bitmap color 
modes, and does not support alpha channels. EPS does support clipping paths. Desktop 
Color Separations (DCS) format, a version of the standard EPS format, lets you save color 
separations of CMYK images. You use DCS 2.0 format to export images containing spot 
channels.To print EPS files, you must use a PostScript printer.

Photoshop uses the EPS TIFF and EPS PICT formats to let you open images saved in file 
formats that create previews but are not supported by Photoshop (such as QuarkXPress®). 
An opened preview image can be edited and used like any other low-resolution file. 
An EPS PICT preview is available only in Mac OS. 

Note: EPS TIFF format and EPS PICT format were more relevant for use in earlier versions of 
Photoshop. The current version of Photoshop includes rasterization features for opening 
files that include vector data.

Photoshop DCS 1.0 and 2.0 (Photoshop)
Desktop Color Separations (DCS) format is a version of the standard EPS format that lets 
you save color separations of CMYK images. You can use DCS 2.0 format to export images 
containing spot channels. To print DCS files, you must use a PostScript printer.

Cineon
Developed by Kodak, Cineon is a 10-bit-per-channel digital format suitable for electronic 
compositing, manipulation, and enhancement. Using the Cineon format, you can output 
back to film with no loss of image quality. The format is used in the Cineon Digital Film 
System, which transfers images originated on film to the Cineon format and back out 
to film.
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Filmstrip 
Filmstrip format is used for RGB animation or movie files created by Adobe Premiere®. 
If you resize, resample, remove alpha channels, or change the color mode or file format 
of a Filmstrip file in Photoshop, you won’t be able to save it back to Filmstrip format. 
For further guidelines, see Adobe Premiere Help.

GIF 
Graphics Interchange Format (GIF) is the file format commonly used to display indexed-
color graphics and images in hypertext markup language (HTML) documents over the 
World Wide Web and other online services. GIF is an LZW-compressed format designed to 
minimize file size and electronic transfer time. GIF format preserves transparency in 
indexed-color images; however, it does not support alpha channels. 

IFF
IFF (Interchange File Format) is available through an optional plug-in. It is a general 
purpose data storage format that can associate and store multiple types of data. IFF is 
portable and has extensions that support still-picture, sound, music, video, and textual 
data. The IFF format includes Maya IFF and IFF (formerly Amiga IFF).

JPEG 
Joint Photographic Experts Group (JPEG) format is commonly used to display photo-
graphs and other continuous-tone images in hypertext markup language (HTML) 
documents over the World Wide Web and other online services. JPEG format supports 
CMYK, RGB, and Grayscale color modes, and does not support alpha channels. Unlike GIF 
format, JPEG retains all color information in an RGB image but compresses file size by 
selectively discarding data. 

A JPEG image is automatically decompressed when opened. A higher level of compression 
results in lower image quality, and a lower level of compression results in better image 
quality. In most cases, the Maximum quality option produces a result indistinguishable 
from the original. 

JPEG 2000 (Photoshop optional plug-in)
JPEG 2000 is a file format that provides more options and greater flexibility than the 
standard JPEG (JPG) format. Using JPEG 2000, you can produce images with better 
compression and quality for both Web and print publishing. To save files in the JPEG 
2000 format, the optional JPEG 2000 plug-in must be installed in Adobe Photoshop CS/
Plug-Ins/Adobe Photoshop Only/File Formats. The optional JPEG 2000 format plug-in can 
be found on the Photoshop CS installation CD in Goodies/Optional Plug-Ins/Photoshop 
Only/File Formats.

Note: Currently, computers with the necessary plug-in can display your JPEG 2000 files on 
the Web.

Unlike traditional JPEG files, which are lossy, the JPEG 2000 format supports optional 
lossless compression. The JPEG 2000 format also supports 16-bit color or grayscale files, 
8-bit transparency, and it can retain alpha channels and spot channels. Grayscale, RGB, 
CMYK, and Lab are the only modes supported by the JPEG 2000 format.
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The JPEG 2000 format also supports using a Region of Interest (ROI) to minimize file size 
and preserve quality in critical regions of an image. By using an alpha channel, you can 
specify the area (ROI) where the most detail should be preserved, allowing greater 
compression and less detail in other regions. (See “Creating alpha channels (Photoshop)” 
on page 255.)

Large Document Format (PSB)
The Large Document Format (PSB) supports documents up to 300,000 pixels in any 
dimension. All Photoshop features, such as layers, effects, and filters, are supported by the 
PSB format. Currently, if you save a document in PSB format, it can only be opened in 
Photoshop CS. Other applications and older versions of Photoshop cannot open 
documents saved in PSB format.

Note: Most other applications and older versions of Photoshop cannot support 
documents with file sizes larger than 2 GB.

The Enable Large Document Format (.psb) option must be enabled in Preferences before 
you can save documents in PSB format. There is one exception: it is possible to open an 
existing PSB file and save it in PSB format even if the Enable Large Document Format (.psb) 
option is not selected in Preferences. For more information on saving a document in PSB 
format and selecting the Enable Large Document Format (.psb) option, see “Saving large 
documents (Photoshop)” on page 567.

PCX 
PCX format is commonly used by IBM PC-compatible computers. Most PC software 
supports version 5 of PCX format. A standard VGA color palette is used with version 3 files, 
which do not support custom color palettes. 

PCX format supports Bitmap, Grayscale, Indexed Color, and RGB color modes, and does 
not support alpha channels. PCX supports the RLE compression method. Images can have 
a bit depth of 1, 4, 8, or 24.

PDF 
Portable Document Format (PDF) is a flexible, cross-platform, cross-application file format. 
Based on the PostScript imaging model, PDF files accurately display and preserve fonts, 
page layouts, and both vector and bitmap graphics. In addition, PDF files can contain 
electronic document search and navigation features such as electronic links. PDF supports 
16-bit-per-channel images. Adobe Acrobat also has a Touch Up Object tool for minor 
editing of images in a PDF. For more information about working with images in PDFs, 
see Acrobat Help.

Note: The Touch Up Object tool is mainly for last-minute revisions to images and objects. 
It’s best to do image editing in Photoshop before saving as PDF.

Photoshop and ImageReady recognize two types of PDF files: Photoshop PDF files and 
Generic PDF files. You can open both types of PDF files; however, you can only save images 
to Photoshop PDF format.

Photoshop PDF files Are created using the Photoshop Save As command. Photoshop 
PDF files can contain only a single image. 
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Photoshop PDF format supports all of the color modes (except Multichannel mode) and 
features that are supported in standard Photoshop format. Photoshop PDF also supports 
JPEG and ZIP compression, except for Bitmap-mode images, which use CCITT Group 4 
compression. 

Generic PDF files Are created using applications other than Photoshop, such as Adobe 
Acrobat and Adobe Illustrator, and can contain multiple pages and images. When you 
open a Generic PDF file, Photoshop rasterizes the image. 

PICT File 
PICT format is used in Mac OS graphics and page-layout applications as an intermediary 
file format for transferring images between applications. PICT format supports RGB 
images with a single alpha channel, and indexed-color, grayscale, and Bitmap-mode 
images without alpha channels. PICT format is especially effective at compressing images 
with large areas of solid color. This compression can be dramatic for alpha channels with 
their large areas of white and black. 

When saving an RGB image in PICT format, you can choose either a 16-bit or 32-bit pixel 
resolution. For bitmap and grayscale images, you can choose from 2, 4, or 8 bits per pixel. 
In Mac OS with QuickTime installed, four JPEG compression options are available.

Note: In ImageReady, PICT format is supported in Mac OS only. 

PICT Resource 
(Mac OS) A PICT resource is a PICT file but takes a name and resource ID number. The PICT 
Resource format supports RGB images with a single alpha channel, and indexed-color, 
grayscale, and Bitmap-mode images without alpha channels.

You can use the Import command or the Open command to open a PICT resource. When 
saving a file as a PICT resource, you can specify the resource ID and resource name. As with 
other PICT files, you also specify bit depth and compression options. 

Pixar
The Pixar format is designed specifically for high-end graphics applications, such as those 
used for rendering three-dimensional images and animation. Pixar format supports RGB 
and grayscale images with a single alpha channel.

PNG
Developed as a patent-free alternative to GIF, Portable Network Graphics (PNG) format is 
used for lossless compression and for display of images on the Web. Unlike GIF, PNG 
supports 24-bit images and produces background transparency without jagged edges; 
however, some Web browsers do not support PNG images. PNG format supports RGB, 
indexed-color, grayscale, and Bitmap-mode images without alpha channels. PNG 
preserves transparency in grayscale and RGB images.

QuickTime Movie (ImageReady)
QuickTime Movie format is a cross-platform format used for time-based data, such as 
video and audio. In ImageReady, you can save animations as QuickTime movies and open 
existing QuickTime movies as animations in order to optimize them for the Web.

Note: In Windows, QuickTime Movie format is visible in the Files of Type pop-up menu only 
when QuickTime is installed on your computer.
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Photoshop Raw (Photoshop)
The Photoshop Raw format is a flexible file format for transferring images between 
applications and computer platforms. This format supports CMYK, RGB, and grayscale 
images with alpha channels, and multichannel and Lab images without alpha channels. 
Documents saved in the Photoshop Raw format can be any pixel or file size, but cannot 
contain layers. For more information on saving large documents in Photoshop Raw 
format, see “Saving large documents (Photoshop)” on page 567.

The Photoshop Raw format consists of a stream of bytes describing the color information 
in the image. Each pixel is described in binary format, with 0 representing black and 255 
white (for images with 16-bit channels, the white value is 65535). Photoshop designates 
the number of channels needed to describe the image, plus any additional channels in 
the image. You can specify the file extension (Windows), file type (Mac OS), file creator 
(Mac OS), and header information.

In Mac OS, the file type is generally a four-character ID that identifies the file—for example, 
TEXT identifies the file as an ASCII text file. The file creator is also generally a four-character 
ID. Most Mac OS applications have a unique file creator ID that is registered with the Apple 
Computer Developer Services group. 

The header parameter specifies how many bytes of information appear in the file before 
actual image information begins. This value determines the number of zeroes inserted at 
the beginning of the file as placeholders. By default, there is no header (header size = 0). 
You can enter a header when you open the file in Raw format. You can also save the file 
without a header and then use a file-editing program, such as HEdit (Windows) or Norton 
Utilities® (Mac OS), to replace the zeroes with header information.

You can save the image in an interleaved or noninterleaved format. If you choose inter-
leaved, the color values (red, green, and blue, for example) are stored sequentially. Your 
choice depends on requirements of the application that will open the file.

Note: Photoshop Raw is not the same file format as a raw image file from a digital camera. 
A digital camera’s raw image file is a camera-specific proprietary format that provides the 
photographer with a digital negative, an image free of any filtering, white balance adjust-
ments, and other in-camera processing. 

Scitex CT (Photoshop)
Scitex Continuous Tone (CT) format is used for high-end image processing on Scitex 
computers. Contact Creo to obtain utilities for transferring files saved in Scitex CT format 
to a Scitex system. Scitex CT format supports CMYK, RGB, and grayscale images and does 
not support alpha channels.

CMYK images saved in Scitex CT format often have extremely large file sizes. These files are 
generated for input using a Scitex scanner. Images saved in Scitex CT format are printed to 
film using a Scitex rasterizing unit, which produces separations using a patented Scitex 
halftoning system. This system produces very few moiré patterns and is often demanded 
in professional color work—for example, ads in magazines.



Using Help | Contents | Index Back 589  

Adobe Photoshop CS Help Saving and Exporting Images 

Using Help | Contents | Index Back 589  

SWF (ImageReady)
The Macromedia Flash (SWF) file format is used for playing animated compositions. The 
animated compositions can provide Web site interactivity and navigation. Any browsers 
with the Macromedia Flash Player plug-in can read the SWF format. Because the SWF 
format can save animations as vector images to maintain a small file size, it is a good 
choice for animations with solid areas of color and sharp object definitions. A SWF file can 
also contain raster (bitmap) images and QuickTime movies. However, raster images and 
QuickTime movies increase the size of a SWF file significantly.

Some features of the SWF format to keep in mind:

• You can also choose a compression format for any embedded bitmap, such as JPEG, 
Indexed, and Truecolor. The default format for the embedded bitmaps in an SWF file is 
JPEG. Note, however, that bitmap objects usually increase the composition’s file size.

• The SWF format supports solid-color backgrounds only. Gradients or textures applied to 
the background of a composition are exported as a backdrop object—a bitmap object 
that appears behind all the other objects in the composition.

• The SWF format is a streaming format, and plays as soon as a certain amount of the file 
has downloaded.

Targa 
TGA (Targa®) format is designed for systems using the Truevision® video board and is 
commonly supported by MS-DOS color applications. Targa format supports 16-bit RGB 
images (5 bits x 3 color channels, plus one unused bit), 24-bit RGB images (8 bits x 3 color 
channels), and 32-bit RGB images (8 bits x 3 color channels plus a single 8-bit alpha 
channel). Targa format also supports indexed-color and grayscale images without alpha 
channels. When saving an RGB image in this format, you can choose a pixel depth and 
select RLE encoding to compress the image. 

TIFF 
Tagged-Image File Format (TIFF) is used to exchange files between applications and 
computer platforms. TIFF is a flexible bitmap image format supported by virtually all paint, 
image-editing, and page-layout applications. Also, virtually all desktop scanners can 
produce TIFF images. TIFF documents can have a maximum file size of 4 GB. Photoshop CS 
supports large documents saved in TIFF format. However, most other applications and 
older versions of Photoshop do not support documents with file sizes greater than 2 GB. 
For more information on saving large documents in TIFF format, see “Saving large 
documents (Photoshop)” on page 567.

TIFF format supports CMYK, RGB, Lab, indexed-color, and grayscale images with alpha 
channels and Bitmap-mode images without alpha channels. Photoshop can save layers in 
a TIFF file; however, if you open the file in another application, only the flattened image is 
visible. Photoshop can also save annotations, transparency, and multiresolution pyramid 
data in TIFF format.
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Adding file information (Photoshop)
File information—also called metadata—is increasingly important in all types of 
publishing. Photoshop supports the information standard developed by the Newspaper 
Association of America (NAA) and the International Press Telecommunications Council 
(IPTC) to identify transmitted text and images. This standard includes entries for descrip-
tions, keywords, categories, credits, and origins. 

In Windows and Mac OS, you can add file information to files saved in Photoshop, Large 
Document Format (PSB), TIFF, JPEG, EPS, and PDF formats. In Mac OS, you can also add file 
information to files in other Photoshop-supported formats except GIF. The information 
you add is embedded in the file using XMP (eXtensible Metadata Platform). XMP provides 
Adobe applications and workflow partners with a common XML framework that 
standardizes the creation, processing, and interchange of document metadata across 
publishing workflows. When you save files from Photoshop that contain keywords, those 
keywords are not displayed in Adobe Acrobat’s File Info dialog when the file is opened in 
Acrobat. For information on adding metadata to a file, see “Working with the metadata 
palette” on page 97 and “Adding metadata to files” on page 99.

Note: It’s possible to add metadata in ImageReady using the options in the Optimize 
palette. For more information, see “Including image metadata (ImageReady)” on 
page 562.

Adding digital copyright information
You can add copyright information to Photoshop images and notify users that an image is 
copyright-protected via a digital watermark that uses Digimarc ImageBridge technology. 
The watermark—a digital code added as noise to the image—is virtually imperceptible to 
the human eye. The Digimarc watermark is durable in both digital and printed forms, 
surviving typical image edits and file format conversions.

Embedding a digital watermark in an image lets viewers obtain information about the 
creator of the image. This feature is particularly valuable to image creators who license 
their work to others. Copying an image with an embedded watermark also copies the 
watermark and any information associated with it.

For more detailed information on embedding Digimarc digital watermarks, refer to the 
Digimarc Web site at www.digimarc.com.

Before adding a digital watermark
Keep in mind the following considerations before embedding a digital watermark in your 
image.

Color variation The image must contain some degree of variation or randomness in 
color to embed the digital watermark effectively and imperceptibly. The image cannot 
consist mostly or entirely of a single flat color. 

Pixel dimensions The Digimarc technology requires a minimum number of pixels to 
work. Digimarc recommends the following minimum pixel dimensions for the image to be 
watermarked:

• 100 pixels by 100 pixels if you don’t expect the image to be modified or compressed 
prior to its actual use. 

http://www.digimarc.com
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• 256 pixels by 256 pixels if you expect the image to be cropped, rotated, compressed, or 
otherwise modified after watermarking. 

• 750 pixels by 750 pixels if you expect the image to appear ultimately in printed form at 
300 dpi or greater. 

There is no upper limit on pixel dimensions for watermarking.

File compression In general, a Digimarc watermark will survive lossy compression 
methods such as JPEG, though it is advisable to favor image quality over file size (a JPEG 
compression setting of 4 or higher works best). In addition, the higher the Watermark 
Durability setting you choose when embedding the watermark (see “Using the Watermark 
Durability setting” on page 592), the better the chances that the digital watermark will 
survive compression. 

Workflow Digital watermarking should be one of the very last tasks you perform on an 
image, except for file compression.

Use the following recommended workflow:

• Make all necessary modifications to your image until it has the desired final appearance 
(this includes resizing and color correction).

• Embed the Digimarc watermark.

• If needed, compress the image by saving it in JPEG or GIF format.

• If the image is intended for printed output, perform the color separation.

• Read the watermark and use the signal strength meter to verify that the image contains 
a watermark of sufficient strength for your purposes.

• Publish the digital watermarked image.

Embedding digital watermarks
To embed a digital watermark, you must first register with Digimarc Corporation—which 
maintains a database of artists, designers, and photographers and their contact infor-
mation—to get a unique Digimarc ID. You can then embed the Digimarc ID in your 
images, along with information such as the copyright year or a restricted-use identifier. 

To embed a watermark:

1 Open the image that you want to watermark. You can embed only one digital 
watermark per image. The Embed Watermark filter won’t work on an image that has been 
previously watermarked. 

If you’re working with a layered image, you should flatten the image before watermarking 
it; otherwise, the watermark will affect the active layer only.

Note: You can add a digital watermark to an indexed-color image by first converting the 
image to RGB mode, embedding the watermark, and then converting the image back to 
indexed-color mode. However, the results may be inconsistent. To make sure that the 
watermark was embedded, run the Read Watermark filter.

2 Choose Filter > Digimarc > Embed Watermark. 

3 If you are using the filter for the first time, click the Personalize button. Get a Digimarc 
ID by clicking Info to launch your Web browser and visit the Digimarc Web site at 
www.digimarc.com, or by contacting Digimarc at the telephone number listed in the 
dialog box. Enter your PIN and ID number in the Digimarc ID text box, and click OK.

http://www.digimarc.com
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Once you have entered a Digimarc ID, the Personalize button becomes a Change button, 
allowing you to enter a new Digimarc ID.

4 Enter a copyright year, Transaction ID, or Image ID for the image.

5 Select any of the following image attributes:

• Restricted Use to limit the use of the image.

• Do Not Copy to specify that the image should not be copied.

• Adult Content to label the image contents as suitable for adults only. (Within 
Photoshop, this option does not limit access to adult-only images, but future versions 
of other applications may limit their display.)

6 For Target Output, specify whether the image is intended for monitor, Web, or print 
display.

7 For Watermark Durability, drag the slider or enter a value, as described in the next 
section.

8 Select Verify to automatically assess the watermark’s durability after it is embedded. 
For more information, see “Using the signal strength meter” on page 592.

9 Click OK.

Using the Watermark Durability setting
The default Watermark Durability setting is designed to strike a balance between 
watermark durability and visibility in most images. However, you can adjust the 
Watermark Durability setting yourself to suit the needs of your images. Low values are less 
visible in an image but less durable, and may be damaged by applying filters or by 
performing some image-editing, printing, and scanning operations. High values are more 
durable but may display some visible noise in the image.

Your setting should depend on the intended use of the image and on the goals you’ve set 
for your watermarks. For example, it may be quite acceptable to use a higher Watermark 
Durability setting with JPEG images posted on a Web site. The higher durability helps to 
ensure the persistence of the watermark, and the increased visibility often is not 
noticeable with medium-resolution JPEG images. Digimarc recommends experimenting 
with various settings as part of your testing process to determine which setting works best 
for the majority of your images.

Using the signal strength meter
The signal strength meter helps you determine whether a watermark is durable enough to 
survive the intended use of the image. The signal strength meter is available only for 
images containing digital watermarks that you yourself have embedded.

Digimarc recommends that you check the signal strength meter before publishing your 
images. For example, if you often compress watermarked images for inclusion in a Web 
site, check the meter before posting the images. You can also use the signal strength 
meter to gauge the effectiveness of different Watermark Durability settings that you are 
experimenting with.
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To check the signal strength meter:

Choose Filter > Digimarc > Read Watermark. The signal strength meter appears at the 
bottom of the dialog box. 

You can also display the meter automatically by selecting Verify while embedding the 
watermark. See “Embedding digital watermarks” on page 591.

Setting preferences for saving files (Photoshop)
In Photoshop, you can set preferences for saving image previews, using file extensions, 
and maximizing file compatibility.

To set file saving preferences:

1 Do one of the following:

• In Windows, choose Edit > Preferences > File Handling.

• In Mac OS, choose Photoshop > Preferences > File Handling.

2 Set the following options:

Image Previews Choose an option for saving image previews: Never Save to save files 
without previews, Always Save to save files with specified previews, or Ask When Saving to 
assign previews on a file-by-file basis. 

In Mac OS, you can select one or more of the following preview types (to speed the saving 
of files and minimize file size, select only the previews you need):

• Icon to use the preview as a file icon on the desktop.

• Full Size to save a 72-ppi version of the file for use in applications that can only open 
low-resolution Photoshop images. For non-EPS files, this is a PICT preview. 

• Macintosh Thumbnail to display the preview in the Open dialog box.

• Windows Thumbnail to save a preview that can display on Windows systems.

File Extension (Windows) Choose an option for the three-character file extensions that 
indicate a file’s format: Use Upper Case to append file extensions using uppercase 
characters, or Use Lower Case to append file extensions using lowercase characters.

Append File Extension (Mac OS) File extensions are necessary for files that you want to 
use on or transfer to a Windows system. Choose an option for appending extensions to 
filenames: Never to save files without file extensions, Always to append file extensions to 
filenames, or Ask When Saving to append file extensions on a file-by-file basis. Select Use 
Lower Case to append file extensions using lowercase characters.

To toggle the Append File Extension option for a single file, hold down Option when 
you choose a file format in the Save As dialog box. 
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Creating multiple-image layouts (Photoshop)
You can export multiple images automatically as contact sheets and picture packages 
using Automate commands.

Creating contact sheets
Contact sheets let you easily preview and catalog groups of images by displaying a series 
of thumbnails on a single page. You can automatically create and place thumbnails on a 
page using the Contact Sheet II command.

Example of a contact sheet

To create a contact sheet:

1 Do one of the following:

• From the main menu, choose File > Automate > Contact Sheet II.

• In the File Browser, select a folder of images or specific image files, and then from the 
File Browser menu, choose Automate > Contact Sheet II. The Contact Sheet II command 
will use all the images displayed in the File Browser unless you select specific images 
before choosing the command. You can always choose a different folder of images or 
current open documents after the Contact Sheet II dialog box opens.

Note: Click to select an image in the File Browser. Shift-click to select a series of images. 
Ctrl-click (Windows) or Command-click (Mac OS) to select noncontiguous images.

2 In the Contact Sheet II dialog box, specify the images to use by choosing one of the 
following from the Use menu in the Source Images area:

• Current Open Documents to use any image that is currently open in Photoshop. 

• Folder, and then click Browse (Windows) or Choose (Mac OS) to specify the folder 
containing the images you want to use. Select Include All Subfolders to include images 
inside any subfolders.

• Selected Images from File Browser to use images displayed in the File Browser. All 
images in the File Browser will be used unless you select specific images before 
choosing the Contact Sheet II command.
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3 In the Document area, specify the dimensions, resolution, and color mode for the 
contact sheet. Select Flatten All Layers to create a contact sheet with all images and text 
on a single layer. Deselect Flatten All Layers to create a contact sheet in which each image 
is on a separate layer and each caption is on a separate text layer. 

4 In the Thumbnails area, specify layout options for the thumbnail previews.

• For Place, choose whether to arrange thumbnails across first (from left to right, then top 
to bottom) or down first (from top to bottom, then left to right).

• Enter the number of columns and rows that you want per contact sheet. The maximum 
dimensions for each thumbnail are displayed to the right, along with a visual preview of 
the specified layout.

• Select Use Auto-Spacing to let Photoshop automatically space the thumbnails in the 
contact sheet. Deselecting Use Auto-Spacing lets you specify the vertical and 
horizontal space around the thumbnails. The contact sheet preview in the dialog box 
updates as you specify the spacing.

• Select Rotate For Best Fit to rotate the images, regardless of their orientation, so they fit 
efficiently on a contact sheet.

The Rotate For Best Fit option off and on

5 Select Use Filename As Caption to label the thumbnails using their source image 
filenames. Use the menu to specify a caption font and font size.

6 Click OK.

Creating picture packages
With the Picture Package command, you can place multiple copies of a source image on a 
single page, similar to the photo packages traditionally sold by portrait studios. You also 
have the option of placing different images on the same page. You can choose from a 
variety of size and placement options to customize your package layout.
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Example of a picture package layout

To create a picture package:

1 Do one of the following:

• Choose File > Automate > Picture Package. If you have multiple documents open, 
Picture Package uses the frontmost document. 

• From the File Browser menu, choose Automate > Picture Package. The Picture Package 
command uses the first image listed in the File Browser unless you select a specific 
image before launching the Picture Package command. 

If you’re only using the frontmost document or a selected image from the File Browser for 
the Picture Package, you can skip to step 3.

2 Add one or more images to the layout by doing one of the following:

• In the Source Images area of the Picture Package dialog box, choose either File or Folder 
from the Use menu and click Browse (Windows) or Choose (Mac OS). When choosing 
Folder, you can select Include All Subfolders to include images inside any subfolders.

• Click a placeholder in the preview layout and browse to select an image.

Clicking a placeholder in the Picture Package preview layout lets you browse to select an image.
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• Drag an image from the desktop or a folder into a placeholder.

Dragging an image from the desktop into a placeholder to add an image in the Picture Package

You can change any image the layout by clicking a placeholder and browsing to select an 
image.

3 In the Document area of the Picture Package dialog box, select page size, layout, 
resolution, and color mode. A thumbnail of the chosen layout is displayed on the right 
side of the dialog box.

You can also create your own custom layouts. For more information, see “Customizing 
picture package layouts” on page 597.

4 Select Flatten All Layers to create a picture package with all images and label text on a 
single layer. Deselect Flatten All Layers to create a picture package where each image is on 
a separate layer and each label is on a separate text layer. Placing each image and label on 
a separate layer lets you update your picture package even after it’s been saved. Keep in 
mind that not flattening layers increases the file size of your picture package.

5 In the Label area, choose the source for label text from the Content menu or choose 
None. If you choose Custom Text, enter the text for the label in the Custom Text field.

6 Specify font, font size, color, opacity, position, and rotation for the labels. 

7 Click OK.

Customizing picture package layouts
You can modify existing layouts or create new layouts using the Picture Package Edit 
Layout feature. Your custom layouts are saved as text files that are stored in the Layouts 
folder inside the Presets folder. These saved layouts can be reused. The Picture Package 
Edit Layout feature uses a graphic interface that eliminates the need to write text files to 
create or modify layouts.

To customize a picture package layout:

1 Do one of the following:

• Choose File > Automate > Picture Package.

• From the File Browser menu, choose Automate > Picture Package.

2 In the Picture Package dialog box, choose a layout from the Layout menu if you’re 
creating a customizing an existing layout.

3 Click the Edit Layout button.
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4 In the Picture Package Edit Layout dialog box, enter a name for the custom layout in the 
Name text box.

5 (Optional) In the Layout area of the Picture Package Edit Layout dialog box, choose a 
size from the Page Size menu or enter values in the Width and Height text boxes. You can 
use the Units menu to specify inches, centimeters, pixels, or millimeters.

Dragging a placeholder to a new location in the Picture Package layout

6 In the Grid area of the Picture Package Edit Layout dialog box, select the Snap To option 
to display a grid to help you position the elements in the custom layout. Enter a value in 
the Size text box to change the appearance of the grid.

7 To add or delete a placeholder, do one of the following:

• Click Add Zone to add a placeholder to the layout.

• Select a placeholder and click Delete Zone to delete it from the layout. 

8 To modify a placeholder, select a placeholder and do one of the following:

• Enter values in the Width and Height text boxes to resize a placeholder.

• Click and drag a handle to resize a placeholder. If you resize a rectangle placeholder 
with an image in it, Picture Package will snap the image within the vertical or horizontal 
placeholder, depending on the way the zone is being resized.

• Enter values in the X and Y text boxes to move a placeholder.

• Enter values in the Position and Size text boxes for the positioning and sizing a 
placeholder.

• Click and drag a placeholder to the location you want in the layout. 

9 Click Save.

Creating a PDF presentation
The PDF Presentation command lets you use a variety of images to create a a multipage 
document or slide show presentation. You can set options to maintain image quality in the 
PDF, specify security settings, and set the document to open automatically as a slide show.
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PDF Presentation as a slide show 
A. First slide B. Wipe Left transition C. Second slide

To create a multipage PDF Presentation:

1 Do one of the following:

• From the main menu, choose File > Automate > PDF Presentation.

• From the File Browser menu, choose Automate > PDF Presentation. All the image files 
displayed in the File Browser will be added to the PDF Presentation. In the File Browser, 
you can select the image files you want for the PDF Presentation. Otherwise, the PDF 
Presentation command will select all the images currently displayed in the File Browser.

Note: Click a file to select it. Shift-click to select a series of files. Ctrl-click (Windows) or 
Command-click (Mac OS) to select noncontiguous files.

2 If you did not launch the PDF Presentation command from the File Browser, click 
Browse and navigate to select files for the PDF Presentation. Select the Add Open Files 
option to add files already open in Photoshop.

You can remove any unwanted file by selecting it in the Source Files window, and then 
clicking the Remove button.

The files in the Source Files window are used to generate the pages in the PDF Presen-
tation, starting with the topmost file for the first page and progressing down the list for 
subsequent pages. To reorder a file in the sequence, select the file and drag it to a new 
position in the list.

Dragging a file to a new position in the list

A 

B 

C 
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3 In the Output Options area of the PDF Presentation dialog box, select one of the 
following:

Multi-Page Document Creates a PDF document with the images on separate pages.

Presentation Creates a PDF slide show presentation.

4 Select the View PDF After Saving option if you want Adobe Acrobat or the Adobe 
Reader to open the PDF after it’s created.

5 If you selected Presentation as the Output Option, in the Presentation Options area, you 
can specify the following options:

Advance Every [5] Seconds Specifies how long each image is displayed before the 
presentation advances to the next image. The default duration is 5 seconds.

Loop After Last Page Specifies that the presentation will automatically start over after 
reaching the end. Deselecting this option specifies that the presentation will stop after the 
final image is displayed.

Transition Specifies the transition from one image to the next.

6 Click Save.

7 In the Save dialog box, enter a name for the PDF Presentation and select a destination 
for the saved file. Click Save.

8 In the PDF Options dialog box, select the options you want, and click OK.

Encoding Determines the compression method (Zip or JPEG). For more information, 
see “About file compression” on page 582.

Save Transparency Preserves transparency when the file is opened in another appli-
cation. (Transparency is always preserved when the file is reopened in Photoshop or 
ImageReady.) This option is not available if the file contains a spot color channel or does 
not contain transparency.

Image Interpolation Anti-aliases the printed appearance of a low-resolution image.

Downgrade Color Profile If you selected ICC Profile (Windows) or Embed Color Profile 
(Mac OS) for a version 4 profile in the Save dialog box, this option downgrades the profile 
to version 2. Select this option if you plan to open the file in an application that does not 
support version 4 profiles. 

PDF Security Specifies security options such as password protection and restricted 
access to a file’s content. Choose 40-bit or 128-bit RC4 encryption for a lower or higher 
level of security. For more information on PDF security, see “Saving files in Photoshop PDF 
format (Photoshop)” on page 567.

Include Vector Data Preserves any vector graphics (such as shapes and type) as 
resolution-independent objects, ensuring smoother output. When it is selected, you can 
select the following options:

• Embed Fonts ensures that all fonts used in the file are displayed and printed, even on 
computers that do not have the fonts installed. Bitmap fonts, fonts that don’t allow PDF 
embedding, substitute fonts, type that uses the faux bold style, and warped type 
cannot be embedded. Selecting Embed Fonts increases the size of the saved file.
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• Use Outlines for Text saves text as paths. Select this option if embedding fonts results in 
a file that is too large, if you plan to open the file in an application that cannot read PDF 
files with embedded fonts, or if a font fails to display or print correctly. Text saved as 
outlines is not searchable or selectable in a PDF viewer. You can, however, edit the text 
when you reopen the file in Photoshop.

Note: The PDF viewer may display a substitute font if both Embed Fonts and Use Outlines 
for Text are deselected.

9 Click OK. Photoshop closes the PDF options dialog box and creates the PDF Presen-
tation. A dialog appears telling you if the PDF Presentation was successfully created.

Placing Photoshop images in other applications 
(Photoshop)
Photoshop provides a number of features to help you use images in other applications. 
Due to the integration between Adobe products, many Adobe applications can directly 
import Photoshop (PSD) format files and use Photoshop features like layers, layer styles, 
masks, transparency, and effects. Additionally, programs like Adobe GoLive can use 
variables set in ImageReady and Photoshop (topmost text layer only) to use in creating 
multiple-iterations of an image. For more information on setting variables, see “Using 
variables” on page 650.

Using image clipping paths to create transparency
You can use image clipping paths to define transparent areas in images you place in 
page-layout applications. In addition, Mac OS users can embed Photoshop images in 
many word-processor files.

 For assistance with image clipping paths, choose Help > Export Transparent Image. 
This interactive wizard helps you prepare images with transparency for export to a 

page-layout application.

You may want to use only part of a Photoshop image when printing it or placing it in 
another application. For example, you may want to use a foreground object and exclude 
the background. An image clipping path lets you isolate the foreground object and make 
everything else transparent when the image is printed or placed in another application.

Image imported into Illustrator or InDesign without image clipping path (left), 
and with image clipping path (right)
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To save a path as an image clipping path:

1 Draw a work path that defines the area of the image you want to show. For more infor-
mation, see “Creating a work path (Photoshop)” on page 300 and “Converting selection 
borders to paths” on page 311.

Note: Paths are vector-based; therefore, they have hard edges. You cannot preserve the 
softness of a feathered edge, such as in a shadow, when creating an image clipping path.

2 In the Paths palette, save the work path as a path. For more information, see “Managing 
paths (Photoshop)” on page 308.

3 Choose Clipping Path from the Paths palette menu, set the following options, and 
click OK:

• For Path, choose the path you want to save.

• For Flatness, leave the flatness value blank to print the image using the printer’s default 
value. If you experience printing errors, enter a flatness value to determine how the 
PostScript interpreter approximates the curve. The lower the flatness value, the greater 
the number of straight lines used to draw the curve and the more accurate the curve. 

Values can range from 0.2 to 100. In general, a flatness setting from 8 to 10 is recom-
mended for high-resolution printing (1200 dpi to 2400 dpi), and a setting from 1 to 3 for 
low-resolution printing (300 dpi to 600 dpi).

4 If you plan to print the file using process colors, convert the file to CMYK mode. For 
more information, see “Converting between color modes (Photoshop)” on page 156.

5 Save the file by doing one of the following:

• To print the file using a PostScript printer, save in Photoshop EPS, DCS, or PDF format. 

• To print the file using a non-PostScript printer, save in TIFF format and export to Adobe 
InDesign, or to Adobe PageMaker® 5.0 or later. 

Note: If you import an EPS or DCS file with a TIFF preview into Adobe Illustrator, the image 
clipping path transparency may not display properly. This affects the on-screen preview 
only; it does not affect the printing behavior of the image clipping path on a PostScript 
printer.

Printing image clipping paths
Sometimes an imagesetter has difficulty interpreting image clipping paths, or a printer 
finds the image clipping path too complex to print, resulting in a Limitcheck error or a 
general PostScript error. Sometimes you can print a complex path on a low-resolution 
printer without difficulty but run into problems when printing the same path on a high-
resolution printer. This is because the lower-resolution printer simplifies the path, using 
fewer line segments to describe curves than does the high-resolution printer. 

You can simplify an image clipping path in the following ways:

• Manually reduce the number of anchor points on the path. (See “Adding, deleting, and 
converting anchor points” on page 307.) 

• Increase the tolerance setting used to create the path. To do this, load the existing path 
as a selection, choose Make Work Path from the Paths palette menu, and increase the 
tolerance setting (4 to 6 pixels is a good starting value). Then re-create the image 
clipping path. For more information, see “Converting paths to selection borders” on 
page 310 and “Using image clipping paths to create transparency” on page 601.
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Exporting paths to Adobe Illustrator
The Paths to Illustrator command lets you export Photoshop paths as Adobe Illustrator 
files. This makes it easier to work with combined Photoshop and Illustrator artwork or to 
use Photoshop features on Illustrator artwork. For example, you may want to export a pen 
tool path and stroke it to use as a trap with an Photoshop clipping path you are printing in 
Illustrator. You can also use this feature to align Illustrator text or objects with Photoshop 
paths.

To use the Paths to Illustrator command:

1 Draw and save a path or convert an existing selection into a path.

2 Choose File > Export > Paths to Illustrator. 

3 Choose a location for the exported path, and enter a filename. Make sure Work Path is 
chosen in the Write menu to export the path.

4 Click Save.

5 Open the file in Adobe Illustrator. You can manipulate the path or use the path to align 
Illustrator objects that you add to the file. 

Note that the crop marks in Adobe Illustrator reflect the dimensions of the Photoshop 
image. The position of the path within the Photoshop image is maintained, provided you 
don’t change the crop marks or move the path.

Object linking and embedding (OLE) (Windows only)
Photoshop is an OLE 2.0 server, which means it supports embedding or linking an image 
in an OLE container application (usually a word-processor or page-layout program). For 
example, you can insert Photoshop files and selections into other OLE applications such as 
Adobe PageMaker, Adobe FrameMaker, and Microsoft Word using copy and paste or 
other methods.

• Linking lets you place a link in the OLE container file that refers to the Photoshop file on 
the hard drive.

• Embedding lets you insert the Photoshop file into the OLE container file.

Once in the container application, an image can be double-clicked for editing in 
Photoshop. When closed in Photoshop, the image is updated in the container application.

To link or embed a selection or image in an OLE application:

Do one of the following:

• Copy a selection in Photoshop, and insert it in your OLE container application using the 
application’s Paste Special command. Refer to your word-processing or page-layout 
application documentation for more instructions. Pasted selections can only be 
embedded, not linked.

• Use your OLE container application’s Insert Object command to insert a new Photoshop 
image or existing Photoshop file as an OLE-embedded or OLE-linked object. Refer to 
your word-processing or page-layout application documentation for instructions.

To insert an unlinked screen-resolution bitmap into an OLE application:

With the Move tool , drag a selection to the OLE container application. When you drop 
the object, it appears as a 72-ppi bitmap, which cannot be automatically updated in 
Photoshop.
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To modify and update a linked or embedded image in an OLE application:

1 Double-click the linked or embedded image in your word-processor or page-layout 
application to launch Photoshop (if it is not already running), and open the image for 
editing.

2 Modify the image as desired.

3 Do one of the following:

• For embedded images, close the file, or choose File > Update or File > Close & Return to 
application name.

• For linked images, save and close the file.

Note: You can also modify linked files without first opening the container document. The 
linked image will be updated the next time you open the document in its OLE container 
application.

Saving images for use in video
The preset file sizes in the Preset menu of the New file dialog let you create images at a 
size and pixel aspect ratio to compensate for scaling when incorporated into video. The 
presets also create a document with nonprinting guides that delineate the action safe and 
title safe areas of the image. Using the preset file sizes, you can produce images for specific 
video systems—NTSC, PAL, or HDTV. 

An image on a computer monitor is made up of pixels that are essentially square. An 
image displayed on a video monitor is analog and does not involve pixel shape. 
Nonsquare pixels are the most commonly used by encoding devices for video. When 
importing an image created by a square-pixel graphics program into a video editing 
program like Adobe Premiere, the square pixels are scaled to the nonsquare pixels for 
video encoding. This scaling results in a distorted image.

Pixel aspect ratio scaling 
A. Square pixel image viewed on a computer monitor B. Square pixel image viewed on a 
video monitor C. Same image with the correct pixel aspect ratio viewed on a video monitor

Other issues to keep in mind when creating images for use in video are as follows: 

• Premiere does not support 16-bit-per-channel images. 

• Premiere can import an individual layer from a multilayer Photoshop (PSD) file. 

• If your Photoshop image file has transparency, Premiere preserves it.

• If your file uses a layer mask or multiple layers, you might not have to flatten the layers, 
but you might want to include a flattened copy of the PSD file in the PSD format to 
maximize backward compatibility. This should ensure that your Photoshop file will 
import successfully into Premiere.

A B C
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To save images for use in video:

1 Create a new document.

2 In the New dialog box, choose the appropriate preset from the Preset menu for the 
video system that the image will be shown on.

Video preset file size guides 
A. Action safe area (outer rectangle) B. Title safe area (inner rectangle)

For more options, click the Advanced button  to specify a color profile and specific pixel 
aspect ratio. For more information on using the New dialog box, see “Creating new 
images” on page 89.

By default, non-square pixel documents open with the Pixel Aspect Ratio Correction 
enabled. This scales the image so you can preview how the image will appear on the 
output device (usually a video monitor).

3 (Optional) Choose View > Pixel Aspect Ratio Correction to turn off the scaling 
correction and view the image as it looks on a computer (square pixel) monitor.

Viewing an image of a circle in a NTSC DV 720x480 document with the Pixel Aspect Ratio Correction 
turned on (top), and with the Pixel Aspect Ratio Correction turned off (bottom)

A

B
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You can simultaneously view an image with the Pixel Aspect Ratio Correction turned 
on and with the correction turned off. With the non-square pixel image open and the 

Pixel Aspect Ratio Correction enabled, choose Window > Arrange > New Window for 
[name of document]. With the new window active, choose View > Pixel Aspect Ratio 
Correction to turn the correction off.

To add images from another document to a non-square pixel document:

Do one of the following:

• Copy and paste an image.

• Drag an image from another document window. 

• Choose File > Place, choose the file you want to place, and click the Place button.

Photoshop automatically converts and scales the image to the pixel aspect ratio of the 
non-square pixel document. Images brought in from Adobe Illustrator will also be 
properly scaled.

To assign a pixel aspect ratio value to an existing document:

With the square pixel document open, choose Image > Pixel Aspect Ratio and select a 
pixel aspect ratio.

To create a custom pixel aspect ratio:

1 With a document open, choose Image > Pixel Aspect Ratio > Custom Pixel Aspect Ratio.

2 In the Save Pixel Aspect Ratio dialog box, enter a value in the Factor text box, name the 
custom pixel aspect ratio, and click OK.

The new custom pixel aspect ratio will appear in the both the Pixel Aspect Ratio menu in 
the New dialog box and in the Pixel Aspect Ratio submenu in the Image menu.

To delete a pixel aspect ratio:

1 With a document open, choose Image > Pixel Aspect Ratio > Delete Pixel Aspect Ratio.

2 In the Delete Pixel Aspect Ratio dialog box, choose the option you want to delete from 
the Pixel Aspect Ratio menu and click Delete.

To reset the pixel aspect ratios:

1 With a document open, choose Image > Pixel Aspect Ratio > Reset Pixel Aspect Ratios.

2 In the dialog box, choose one of the following:

Append Replaces the current pixel aspect ratios with the default values plus any custom 
pixel aspect ratios. This option is useful if you deleted a default value and want to restore it 
to the menu but also want to retain any custom values.

Cancel Cancels the command.

OK Replaces the current pixel aspect ratios with the default values. Custom pixel aspect 
ratios are discarded. 



Using Help | Contents | Index Back 607  

Adobe Photoshop CS Help Saving and Exporting Images 

Using Help | Contents | Index Back 607  

Saving images for use in motion graphics
You can save images in Photoshop for use in motion graphics software like Adobe After 
Effects. A Photoshop (PSD) file can be imported directly into an After Effects project with 
the option of preserving individual layers, layer styles, transparent areas and layer masks, 
and adjustment layers. Importing layers makes it easy to prepare still images for 
animation.

You can reduce the rendering times and problems in After Effects by doing the following:

• Organize and name layers. If you change a layer name or delete a layer in a Photoshop 
document after you have imported it into After Effects, After Effects will not be able to 
find the renamed or deleted layer. The After Effects Project window lists that layer as 
Missing.

• Make sure that each layer has a unique name, because After Effects manages layers by 
their names. Duplicate layer names can cause problems when you update footage.

• If you want to import a composited version of a layered Photoshop file along with a 
layered version, select the Include Composited Image With Layered Files option in the 
Photoshop Saving Files Preferences dialog box.

If you are creating a Photoshop file for export to After Effects for use in a video project, 
use one of the file size presets for video in the New file dialog box. For more information 
on why you must specify specific pixel aspect ratios for use in video, see “Saving images 
for use in video” on page 604.
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Printing (Photoshop)

About printing
Whether you are printing an image on your desktop printer or sending it to a prepress 
facility, knowing a few basics about printing will make the print job go more smoothly and 
help ensure that the finished image appears as intended. 

Types of printing For most users, printing a file means that the Adobe Photoshop appli-
cation sends the image to an inkjet printer to print a photograph. Photoshop can send 
your image to a variety of printing devices to be printed directly onto paper or to be 
converted to a positive or negative image on film. In the latter case, the film can be used to 
create a master plate for printing by a mechanical press.

Types of images The simplest types of images, such as line art, use only one color in one 
level of gray. A more complex image, such as a photograph, has color tones that vary 
within the image. This type of image is known as a continuous-tone image.

Halftoning To create the illusion of continuous tones when printed, images are broken 
down into a series of dots. When printing photos on a printing press, this process is called 
halftoning. Varying the sizes of the dots in a halftone screen creates the optical illusion of 
variations of gray or continuous color in the image. 

Note: Although inkjet printers also use dots to create the illusion of continuous tones, they 
use a different type of screen process that does not vary the size of the dots. Instead, inkjet 
printers use dots that have a uniform size and that are much tinier than the dots used by 
most printing presses.

Color separation Artwork that will be commercially reproduced and that contains more 
than a single color must be printed on separate master plates, one for each color. This 
process is called color separation and most commonly uses cyan, yellow, magenta, and 
black (CMYK) inks. In Photoshop, you can adjust how the various plates are generated. 

Quality of detail The detail in a printed image results from a combination of resolution 
and screen frequency. The higher an output device’s resolution, the finer (higher) a screen 
ruling you can use. Many inkjet printer drivers offer simplified print settings for choosing 
higher-quality printing.

Printing images to a desktop printer
Unless you work in a commercial printing company or service bureau, you’re probably 
printing images on a desktop printer—such as an inkjet, dye sublimation, or laser 
printer—and not to an image setter. Photoshop lets you control how your image will print.
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Desktop printing considerations
Because your monitor displays an image using light and a desktop printer reproduces an 
image using inks, dyes, or pigments, it is impossible for a desktop printer to reproduce all 
the colors that can be displayed on a monitor. However, by incorporating certain proce-
dures (such as a color management system) into your workflow, you can achieve 
predictable results when printing your images on a desktop printer. Here are some issues 
to consider when working with an image that you intend to print:

• If your image is in RGB mode, do not convert the document to CMYK mode when 
printing to a desktop printer. Work entirely in RGB mode. 

• If you want a preview of what your image might look like on any device for which you 
have a profile, use the Proof Colors command. For more information on proof setup and 
using the Proof Colors command, see “Soft-proofing colors” on page 140.

• For accurate color reproduction between the screen and the printed page, it’s 
absolutely necessary to incorporate color management into your workflow. You must 
work with a monitor that is calibrated and characterized. It’s also necessary that you 
have a custom profile for the combination of your printer and the paper you’re printing 
on. Using the profile supplied with your printer will only give average results (although 
the results are better than using no profiles at all). For more information on producing 
consistent color, see “Calibrating and creating profiles” on page 119 and “Using color 
management when printing” on page 612.

Printing images
Photoshop provides the following printing commands: 

• Page Setup and Print display options that are determined by your printer, print drivers, 
and operating system.

• Print with Preview displays Photoshop’s printing, output, and color management 
options.

• Print One Copy prints one copy of a file without displaying a dialog box. 

Note: You cannot print images directly from ImageReady. If you have an image open in 
ImageReady and need to print it, use the Edit in Photoshop command to open the image 
in Photoshop. Keep in mind that ImageReady images open at screen resolution (72 ppi); 
this resolution may not be high enough to produce a high-quality print.

To print an image with its current options:

Do one of the following:

• Choose File > Print, and click Print or OK.

• To print one copy of a file without displaying a dialog box, choose File > Print One Copy.

Note: By default, Photoshop prints a composite of all visible layers and channels. To print 
an individual layer or channel, make it the only visible layer or channel before choosing 
the Print command.

To set printer and page setup options:

1 Choose File > Page Setup or File > Print.

2 Select a printer from the pop-up list at the top of the dialog box. 
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3 Set additional options, such as paper size and layout, as desired. The available options 
depend on your printer, print drivers, and operating system.

If you plan to scale the printed image, choose the Print with Preview command and use 
the scaling options in the Print dialog box rather than the Page Setup dialog box. The Print 
dialog box is more helpful because it shows you a preview of the scaled image. Also, you 
don’t want to set the scaling options in both the Page Setup and Print dialog boxes. This 
applies scaling twice, and the resulting image may not print at the size you intended.

To set Photoshop print options:

1 Choose File > Print with Preview.

Print with Preview dialog box 
A. Preview print B. Position and scale image C. Specify options to prepare a file for prepress
D. Specify the document’s working space and choose a color management profile for printing 
on a desktop printer

2 Make sure Show More Options is selected. Then do one or more of the following:

• Adjust the position and scale of the image in relation to the selected paper size and 
orientation. (See “Positioning and scaling images” on page 611.)

• Set the Output options. For more information, see “Setting output options” on 
page 616.

• Choose Color Management from the pop-up menu and set color management options. 
(See “Using color management when printing” on page 612.)

3 Do one of the following:

• Click Print to print the image.

• Click Cancel to close the dialog box without saving the options.

• Click Done to preserve the options and close the dialog box.

• Hold down Alt (Windows) or Option (Mac OS) and click Print One to print one copy of 
the image.

C

D

A B



Using Help | Contents | Index Back 611  

Adobe Photoshop CS Help Printing (Photoshop) 

Using Help | Contents | Index Back 611  

• Hold down Alt (Windows) or Option (Mac OS) and click Reset to reset the print options.

• Hold down Alt (Windows) or Option (Mac OS) and click Remember to save the print 
options without closing the dialog box.

To preview the current image position and options:

Position the pointer over the file information box (at the bottom of the application 
window in Windows or the document window in Mac OS) and hold down the mouse 
button. 

Positioning and scaling images
You can adjust the position and scale of an image and preview how the image will be 
printed on the selected paper using the Print with Preview command. The shaded border 
at the edge of the paper represents the margins of the selected paper; the printable area is 
white.

The base output size of an image is determined by the document size settings in the 
Image Size dialog box. (See “Changing image size and resolution” on page 65.) Scaling an 
image in the Print with Preview dialog box changes the size and resolution of the printed 
image only. For example, if you scale a 72-ppi image to 50% in the Print with Preview 
dialog box, the image will print at 144 ppi; however, the document size settings in the 
Image Size dialog box will not change. 

Many printer drivers, such as AdobePS and LaserWriter, provide a scaling option in the 
Page Setup dialog box. This scaling affects everything on the page, including the size of all 
page marks such as crop marks and captions, whereas the scaling percentage provided by 
the Print with Preview command affects only the size of the printed image (and not the 
size of page marks).

Important: The Print with Preview command may not reflect accurate values for Scale, 
Height, and Width if you set a scaling percentage in the Page Setup dialog box. To avoid 
inaccurate scaling, specify scaling using the Print with Preview command rather than the 
Page Setup command; do not enter a scaling percentage in both dialog boxes.

To reposition an image on the paper:

Choose File > Print with Preview, and do one of the following:

• Select the Center Image option to center the image in the printable area.

• Deselect the Center Image option and then enter values for Top and Left to position the 
image numerically. 

• Deselect the Center Image option and then drag the image in the preview area. 

To scale the print size of an image:

Choose File > Print with Preview, and do one of the following:

• Click Scale to Fit Media to fit the image within the printable area of the selected paper.

• Enter values for Height and Width to rescale the image numerically. 

• Select Show Bounding Box, and drag a bounding box handle in the preview area to 
achieve the desired scale.
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Printing part of an image
You can use the Print Selected Area option to print a specific part of an image.

To print part of an image:

1 Use the Rectangle Marquee tool to select the part of an image you want to print. 

2 Choose File > Print with Preview, select Print Selected Area, and click Print. 

Printing vector graphics 
If an image includes vector graphics, such as shapes and type, Photoshop can send the 
vector data to a PostScript printer. When you choose to include vector data, Photoshop 
sends the printer a separate image for each type layer and each vector shape layer. These 
additional images are printed on top of the base image, and clipped using their vector 
outline. Consequently, the edges of vector graphics print at the printer’s full resolution, 
even though the content of each layer is limited to the resolution of your image file.

To print vector data:

1 Choose File > Print with Preview.

2 Select Show More Options, and choose Output from the pop-up menu.

3 Select the Include Vector Data option. If necessary, you can choose an encoding 
algorithm from the Encoding pop-up menu.

Using color management when printing
Even though it is impossible to perfectly match all colors between your monitor and your 
printer, you can use color management to ensure that most colors are the same or similar 
enough so they appear consistent. By calibrating and characterizing your monitor and 
creating profiles for your printer and papers, the color management system in Photoshop 
knows the color spaces that your devices operate in and can correctly transform the color 
from one color space to another. The color management options in the Print with Preview 
dialog box let you configure Photoshop to transform the outgoing image data so the 
printer will print colors consistent with what you see on your monitor. For more infor-
mation on color management, see “Using color management to produce consistent color” 
on page 117.

Note: Color management is also used to maintain consistent color when sending your 
image out to be printed on an offset press. For more information, see “Printing images to a 
commercial printing press” on page 615 and “Producing consistent color when sending 
images to press” on page 147.

Printing with the printer driver’s built-in profiles
Using the print driver’s factory profiles is useful when you don’t have custom profiles for 
the printer and every paper used with the printer. The print driver picks the best profile 
according to the paper type, resolution, and so forth.

To color manage a document using the print driver’s factory profiles:

1 Open the document in Photoshop.

2 Choose File > Print with Preview.
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3 Select Show More Options and choose Color Management from the menu.

4 In the Source Space area, select Document to reproduce document colors as inter-
preted by the profile currently assigned to the document.

5 In the Print Space area of the Print dialog box, choose Printer Color Management from 
the Profile menu.

6 For Intent, choose a rendering intent to use when converting colors to the destination 
color space. For more information on rendering intents, see “Handling colors with a 
rendering intent” on page 135.

7 Click the Print button. A second Print dialog box (for setting printer options) opens.

8 On Windows, click the Properties button to access the printer driver options. On 
Mac OS, use the pop-up menu to access the printer driver options. Set the print options 
for the quality you want. Specify the color management settings to let your printer driver 
handle the color management during printing.

9 Click the Print button.

Printing with custom profiles
Printing with a custom profile (for a specific paper and a specific printer) can potentially 
produce the best print results. Custom profiles are usually created using a third-party 
measuring instrument and software.

To color-manage a document while printing with custom profiles:

1 Open the document in Photoshop.

2 Choose File > Print with Preview.

3 Select Show More Options and choose Color Management from the menu.

4 In the Source Space area, select Document to reproduce document colors as inter-
preted by the profile currently assigned to the document.

5 In the Print Space area of the Print dialog box, choose the custom profile from the 
Profile menu.

6 For Intent, choose a rendering intent to use when converting colors to the destination 
color space. For more information on rendering intents, see “Handling colors with a 
rendering intent” on page 135.

7 Click the Print button. A second Print dialog box (for setting printer options) opens.

8 On Windows, click the Properties button to access the printer driver options. On 
Mac OS, use the pop-up menu to access the printer driver options. Set the print options 
for the quality you want. Since Photoshop is handling the color adjustment or color 
management options during printing, turn off all printer driver color adjustment options. 

9 Click the Print button.

Printing a hard proof
Printing a hard proof using the settings from the Proof Setup can simulate the final output 
of your document on a press. For more information on the Proof Setup command, soft 
proofs, and printing hard proofs, see “Soft-proofing colors” on page 140 and “Printing a 
hard proof” on page 143.
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To print a soft proof:

1 Open the document in Photoshop.

2 Choose View > Proof Setup > Custom and choose the profile of your output device in 
the Profile menu. Choose a Rendering Intent from the Intent menu. Click Save to save the 
settings if you’re going to be doing more proofs on the specific output device.

3 Click OK to close the Proof Setup dialog box.

4 Choose File > Print with Preview.

5 In the Print dialog box, make sure Show More Options is selected and Color 
Management is chosen from the menu.

6 In the Source Space area, select Proof. The Proof Setup should be the profile you 
specified.

7 In the Print Space area of the Print dialog box, do one of the following:

• Choose Printer Color Management from the Profile menu if you’re printing with the 
print driver’s choices of factory profiles. This is useful when you don’t have custom 
profiles for the printer, and you want the print driver to pick the best profile according 
to the paper type, resolution, and so forth. After clicking the Print button, a second Print 
dialog box opens to set printer options. On Windows, click the Properties button to 
access the printer driver options. On Mac OS, use the pop-up menu to access the 
printer driver options. Set the print options for the quality you want and specify the 
color management settings to let your printer driver handle the color management 
during printing.

• If you’re printing with a custom profile, choose the custom profile from the Profile 
menu, and then click the Print button. A second Print dialog box (to set printer options) 
opens. On Windows, click the Properties button to access the printer driver options. On 
Mac OS, use the pop-up menu to access the printer driver options. Set the print options 
for the quality you want and turn off all printer driver color adjustment options.

8 Click the Print button.

Printing targets for custom profiles
Printing a target is for creating a custom profile. Generally, a target document with 
swatches is supplied as part of a third-party color management software package. When 
printing a target, you want to turn off all color management in both Photoshop and the 
print driver. Once the target is printed, it is read/scanned by a third-party measuring 
instrument to create the custom profile.

To print a target:

1 Open the color target document in Photoshop.

2 Choose File > Print with Preview.

3 In the Print with Preview dialog box, make sure Show More Options is selected and 
Color Management is chosen from the menu.

4 In the Source Space area, select Document to reproduce document colors as inter-
preted by the profile currently assigned to the document.

5 In the Print Space area, choose Same As Source from the Profile menu.

6 Click the Print button.
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7 In the Print dialog box (for setting printer options), set the print driver for No Color 
Management, Color Adjustments Off, or Color Management Off.

8 Click the Print button.

Printing images to a commercial printing press
Photoshop lets you prepare image files for printing by different types of commercial 
printing press, such as offset lithography, digital printing, and gravure. 

Preparing images for press
Generally, your workflow depends on the capabilities of the prepress facility. Before you 
begin a workflow for commercial printing, you need to contact the people that will be 
outputting the file and find out what they want you to do. For example, they may not want 
you to convert to CMYK at any point because they have specific settings that they need to 
use. Here are some possible scenarios for preparing your image files to achieve 
predictable printing results:

• Work entirely in RGB mode and make sure the image file is embedded with the RGB 
working space profile. If your printer or prepress person uses a color management 
system, he or she should be able to use your file’s profile to make an accurate 
conversion to CMYK for producing the film and printing plates.

• Work in RGB mode until you finish with your image editing. Then convert the image to 
CMYK mode and make any additional color and tonal adjustments. Especially check the 
highlight and shadow areas of the image. Use the Levels, Curves, or Hue/Saturation 
command to make corrections. These adjustments should be very minor. Then send the 
CMYK file to the professional printer.

• Place your RGB or CMYK image in Adobe InDesign, Adobe Illustrator, or Adobe 
PageMaker. In general, most images printed on a commercial press are not printed 
directly from Photoshop but from a page-layout program like Adobe InDesign or a 
print-savvy program like Adobe Illustrator. For more information on importing 
Photoshop files into Adobe InDesign or Adobe Illustrator, see the Adobe InDesign Help 
or the Adobe Illustrator Help.

Here are a few issues to keep in mind when working on an image intended for commercial 
printing:

• If you know the characteristics of your printer’s press, you can specify the highlight and 
shadow output to preserve certain details. For more information on setting the tonal 
and color output of your image, see “Making Color and Tonal Adjustments” on 
page 173.

• If you print an image on a desktop printer in order to preview what the final printed 
piece will look like, keep in mind that there are differences between a desktop printer 
and a commercial printing press. You may find that the resulting images do not look 
alike. A professional color proof gives a more accurate preview of the final printed 
piece.

• If you have a profile from the print house, you could choose it with the Proof Setup 
command then view a soft proof using the Proof Colors command. This method gives 
you a preview on your monitor of the final printed piece. For more information on soft 
proofing, see “Soft-proofing colors” on page 140.
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Specifying prepress options
Photoshop has options in the Print with Preview command for preparing an image for 
output to an image setter or plate setter. The options include specifying page marks, half 
tone attributes, color channels as separate pages, and print encoding method. Generally, 
these output options should only specified by prepress professionals or people knowl-
edgeable about the commercial printing process.

Setting output options
If you are preparing your images for commercial printing directly from Photoshop, you can 
select and preview a variety of page marks and other output options using the Print with 
Preview command.

Page marks 
A. Gradient tint bar B. Label C. Registration marks D. Progressive color bar E. Corner crop mark  
F. Center crop mark G. Description H. Star target

To set output options:

1 Choose File > Print with Preview.

2 Select Show More Options, and choose Output from the pop-up menu.

Note: Options not supported by the designated printer are dimmed.

3 Set one or more of the following options:

Background Lets you select a background color to be printed on the page outside the 
image area. For example, a black or colored background may be desirable for slides 
printed to a film recorder. To use this option, click Background, and then select a color 
from the Color Picker dialog box. This is a printing option only; it does not affect the image 
itself.

Border Lets you print a black border around an image. Type in a number and choose a 
unit value to specify the width of the border.

Bleed Lets you print crop marks inside rather than outside the image. Use this option 
when you want to trim the image within the graphic. Type a number and choose a unit 
value to specify the width of the bleed.

Olé No Moire      177lpi   45o

cyan magenta yellow black

C DBA

HE GF

carnival series
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Screen Lets you set the screen frequency and dot shape for each screen used in the 
printing process. (See “Selecting halftone screen attributes” on page 618.)

Transfer Lets you adjust the transfer functions, traditionally used to compensate for 
dot gain or dot loss that may occur when an image is transferred to film. This option is 
recognized only when you print directly from Photoshop, or when you save the file in EPS 
format and print to a PostScript printer. Generally, it’s best to adjust for dot gain using the 
settings in the CMYK Setup dialog box. Transfer functions are useful, however, when 
compensating for a poorly calibrated output device. (See “Compensating for dot gain in 
film using transfer functions” on page 139.)

Interpolation Reduces the jagged appearance of a low-resolution image by automati-
cally resampling up while printing. However, resampling may reduce the sharpness of the 
image quality. (See “About resampling” on page 66.) Some PostScript Level 2 (or higher) 
printers have interpolation capability. If your printer doesn’t, this option has no effect.

Calibration Bars Prints an 11-step grayscale, a transition in density from 0 to 100% in 
10% increments. With a CMYK color separation, a gradient tint bar is printed to the left of 
each CMY plate, and a progressive color bar to the right.

Note: Calibration bars, registration marks, crop marks, and labels will print only if the 
paper size is larger than the printed image dimensions.

Registration Marks Prints registration marks on the image (including bull’s-eyes and star 
targets). These marks are used primarily for aligning color separations.

Corner Crop Marks Prints crop marks where the page is to be trimmed. You can print 
crop marks at the corners.

Center Crop Marks Prints crop marks where the page is to be trimmed. You can print 
crop marks at the center of each edge.

Description Prints any description text entered in the File Info dialog box up to about 
300 characters. (See “Adding file information (Photoshop)” on page 590.) Description text 
always prints as 9-point Helvetica plain type. 

Labels Prints the filename above the image.

Emulsion Down Makes type readable when the emulsion is down—that is, when the 
photosensitive layer on a piece of film or photographic paper is facing away from you. 
Normally, images printed on paper are printed with emulsion up, with type readable when 
the photosensitive layer faces you. Images printed on film are often printed with emulsion 
down.

Negative Prints an inverted version of the entire output, including all masks and any 
background color. Unlike the Invert command in the Image menu, the Negative option 
converts the output, not the on-screen image, to a negative. If you print separations 
directly to film, you probably want a negative, although in many countries film positives 
are common. Check with your print shop to determine which is required. 

To determine the emulsion side, examine the film under a bright light after it has been 
developed. The dull side is the emulsion; the shiny side is the base. Check whether your 
print shop requires film with positive emulsion up, negative emulsion up, positive 
emulsion down, or negative emulsion down.
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Selecting halftone screen attributes
Halftone screen attributes include the screen frequency and dot shape for each screen 
used in the printing process. For color separations, the prepress person must also specify 
an angle for each of the color screens. Setting the screens at different angles ensures that 
the dots placed by the four screens blend to look like continuous color and do not 
produce moiré patterns.

Halftone screens consist of dots that control how much ink is deposited at a specific 
location on-press. Varying their size and density creates the illusion of variations of gray 
or continuous color. For a process color image, four halftone screens are used: cyan, 
magenta, yellow, and black—one for each ink used in the printing process.

Halftone screen with black ink

Halftone screens with process ink at different screen angles; correctly registered dots form rosettes

In traditional print production, a halftone is produced by placing a halftone screen 
between a piece of film and the image and then exposing the film. In Photoshop, you 
specify the halftone screen attributes just before producing the film or paper output. For 
best results, your output device (a PostScript imagesetter, for example) should be set to 
the correct density limit, and your processor should be properly calibrated; otherwise, 
results can be unpredictable. 

Before creating your halftone screens, check with your print shop for preferred frequency, 
angle, and dot settings. (Use the default angle settings unless your print shop specifies 
changes.) 

To define the screen attributes: 

1 Choose File > Print with Preview.

2 Select Show More Options, choose Output from the pop-up menu, and click Screen. 

45°

0°

105° 90° 75°
45°
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3 In the Halftone Screens dialog box, choose whether to generate your own screen 
settings:

• Deselect Use Printer’s Default Screens to choose your own screen settings.

• Select Use Printer’s Default Screens to use the default halftone screen built into the 
printer. Photoshop then ignores the specifications in the Halftone Screens dialog box 
when it generates the halftone screens. 

4 For a grayscale halftone, enter a screen frequency from 1 to 999.999, and choose a unit 
of measurement. Enter a screen angle from –180 to +180 degrees.

5 For a color separation, choose from the following options:

• To manually enter the screen frequency and angle, choose a color of the screen for Ink, 
and enter the frequency and angle; repeat for each color separation. 

• To have Photoshop determine and enter the best frequencies and angles for each 
screen, click Auto. In the Auto Screens dialog box, enter the resolution of the output 
device and the screen frequency you intend to use, and click OK. Photoshop enters the 
values in the Halftone Screens dialog box. Changing these values may result in moiré 
patterns.

• If you are using a PostScript Level 2 (or higher) printer or an imagesetter equipped with 
an Emerald controller, make sure that the Use Accurate Screens option is selected in the 
Auto Screens dialog box (or in the Halftone Screens dialog box, if you’re entering the 
values manually). The Use Accurate Screens option lets the program access the correct 
angles and halftone screen frequencies for high-resolution output. If your output 
device is not a PostScript Level 2 (or higher) printer or is not equipped with an Emerald 
controller, this option has no effect.

6 For Shape, choose the dot shape you want. If you want all four screens to have the same 
dot shape, select Use Same Shape For All Inks. 

Choosing Custom from the Shape menu displays the Custom Spot Function dialog box. 
You can define your own dot shapes by entering PostScript commands—useful for 
printing with nonstandard halftone algorithms. For information about using PostScript 
language commands, see the PostScript Language Reference published by Addison-Wesley, 
or consult the imagesetter’s manufacturer.

For optimal output on a PostScript printer, the image resolution should be 1.5 to 2 times 
the halftone screen frequency. If the resolution is more than 2.5 times the screen 
frequency, an alert message appears. (See “Understanding image size and resolution” on 
page 62.) If you are printing line art or printing to a non-PostScript printer, see your printer 
documentation for the appropriate image resolutions to use.

7 Click OK.



Using Help | Contents | Index Back 620  

Adobe Photoshop CS Help Printing (Photoshop) 

Using Help | Contents | Index Back 620  

To save halftone screen settings:

In the Halftone Screens dialog box, click Save. Choose a location for the saved settings, 
enter a filename, and click Save.

To save the new settings as the default, hold down Alt (Windows) or Option (Mac OS), 
and click the —> Default button.

To load halftone screen settings:

In the Halftone Screens dialog box, click Load. Locate and select the settings, and click 
Load. 

To return to the original default settings, hold down Alt (Windows) or Option 
(Mac OS), and click <—Default.

Printing color separations
When preparing your image for prepress and working with CMYK images or images with 
spot colors, you can print each color channel as a separate page.

Each color channel printed as a separate page

Note: If you are printing an image from another application and want to print spot 
channels to spot color plates, you must first save the file in DCS 2.0 format. DCS 2.0 
preserves spot channels and is supported by applications such as Adobe InDesign, Adobe 
PageMaker, and QuarkXPress®. (See “Saving files in Photoshop EPS format (Photoshop)” on 
page 570.)

To print separations from Photoshop:

1 Make sure your document is in CMYK Color or Multichannel mode, and then choose 
File > Print with Preview.

2 Select Show More Options, and choose Color Management from the pop-up menu.

3 Choose Separations from the Profile pop-up menu. 

Note: Depending on the designated printer and print drivers on your computer, these 
options may also appear in the Print dialog box (for setting printer options). On Windows, 
click the Properties button to access the printer driver options. On Mac OS, use the pop-up 
menu to access the printer driver options. 

4 Click Print. Separations are printed for each of the colors in the image. 
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To prepare an image with spot channels for printing from another application:

1 If the image is a duotone, convert to Multichannel color mode.

2 Save the image in DCS 2.0 format. 

3 In the DCS 2.0 Format dialog box, be sure to deselect the Include Halftone Screen and 
the Include Transfer Function options. (See “Saving files in Photoshop EPS format 
(Photoshop)” on page 570.)

4 Open or import the image in the application you will be printing from, and set your 
screen angles. Make sure that you’ve communicated to the printer the spot color you want 
for each of the color plates.

Note: You can place a PSD file containing spot colors directly in InDesign CS without 
special preparation.

Choosing a print encoding method
By default, the printer driver transfers binary information to PostScript printers; however, 
you can choose to transfer image data using JPEG or ASCII85 encoding. These options are 
not available to non-PostScript printers such as many inkjet models. 

ASCII85 is a text encoding for binary data that is more compact than ASCII encoding.

JPEG-encoded files are smaller than binary files, and therefore require less time to print; 
however, using JPEG encoding decreases the image quality. Only PostScript Level 2 
(or higher) printers support JPEG encoding; sending a JPEG-encoded file to a PostScript 
Level 1 output device may result in PostScript language errors.

Some print spooler programs, computer networks, and third-party printer drivers don’t 
support files that are binary or JPEG-encoded, and some PostScript output devices accept 
binary and JPEG-encoded image data only through their AppleTalk and Ethernet ports, 
not their parallel or serial ports. In these situations, you can select the ASCII85 encoding 
method. However, ASCII85 files contain about twice as many characters and require about 
twice as much time to transfer as binary files.

To change the encoding method:

1 Choose File > Print with Preview.

2 Select Show More Options, and choose Output from the pop-up menu.

3 Select an option from the Encoding menu.

Creating color traps
A trap is an overlap that prevents tiny gaps from appearing in the printed image, due to a 
slight misregistration on press. It’s important that you first contact your service provider 
to see whether or not you should do any trapping. In most cases, your print shop will 
determine if trapping is needed and if so, they will tell you what values to enter in the 
Trap dialog box.
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Trapping to correct misalignment 
A. Misregistration with no trap B. Misregistration with trap

Trapping is intended to correct the misalignment of solid colors. In general, you don’t 
need traps for continuous-tone images such as photographs. Excessive trapping may 
produce an outline effect. These problems may not be visible on-screen and might show 
up only in print. Photoshop uses standard rules for trapping: 

• All colors spread under black. 

• Lighter colors spread under darker colors.

• Yellow spreads under cyan, magenta, and black.

• Pure cyan and pure magenta spread under each other equally.

To create a trap: 

1 Save a version of the file in RGB mode, in case you want to reconvert the image later. 
Then choose Image > Mode > CMYK Color to convert the image to CMYK mode. 

2 Choose Image > Trap.

3 For Width, enter the trapping value provided by your print shop. Then select a unit of 
measurement, and click OK. Consult your print shop to determine how much misregis-
tration to expect.

Printing duotones
Photoshop lets you create monotones, duotones, tritones, and quadtones. Monotones are 
grayscale images printed with a single, nonblack ink. Duotones, tritones, and quadtones 
are grayscale images printed with two, three, and four inks. In these types of images, 
colored inks are used to reproduce tinted grays rather than different colors. This section 
uses the term duotone to refer to duotones, monotones, tritones, and quadtones.

A B
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About duotones
Duotones are used to increase the tonal range of a grayscale image. Although a grayscale 
reproduction can display up to 256 levels of gray, a printing press can reproduce only 
about 50 levels of gray per ink. This means that a grayscale image printed with only black 
ink can look significantly coarser than the same image printed with two, three, or four inks, 
each individual ink reproducing up to 50 levels of gray. 

Sometimes duotones are printed using a black ink and a gray ink—the black for shadows 
and the gray for midtones and highlights. More frequently, duotones are printed using a 
colored ink for the highlight color. This technique produces an image with a slight tint to it 
and significantly increases the image’s dynamic range. Duotones are ideal for two-color 
print jobs with a spot color (such as a PANTONE Color) used for accent. 

Because duotones use different color inks to reproduce different gray levels, they are 
treated in Photoshop as single-channel, 8-bit, grayscale images. In Duotone mode, you do 
not have direct access to the individual image channels (as in RGB, CMYK, and Lab modes). 
Instead, you manipulate the channels through the curves in the Duotone Options 
dialog box.

To convert an image to duotone:

1 Convert the image to grayscale by choosing Image > Mode > Grayscale. Only 8-bit 
grayscale images can be converted to duotones. 

2 Choose Image > Mode > Duotone.

3 In the Duotone Options dialog box, select Preview to view the effects of the duotone 
settings on the image.

4 Select Monotone, Duotone, Tritone, or Quadtone for Type. 

5 To specify ink colors, click the color box (the solid square) for an ink. Then use the Color 
Picker or click the Custom button in Color Picker dialog box to open the Custom Colors 
dialog box to select an ink. For more information on the Adobe Color Picker, see  “Using 
the Adobe Color Picker” on page 164.

Note: To produce fully saturated colors, make sure that inks are specified in descending 
order—darkest at the top, lightest at the bottom. 

6 Click the curve box next to the color ink box and adjust the duotone curve for each ink 
color. (See “Modifying the duotone curve” on page 623.)

7 Set overprint colors, if necessary. (See “Specifying overprint colors” on page 624.)

8 Click OK.

To apply a duotone effect to only part of an image, convert the duotone image to 
Multichannel mode—this converts the duotone curves to spot channels. You can then 

erase part of the spot channel for areas that you want printed as standard grayscale. (See 
“Adding spot colors (Photoshop)” on page 362.)

Modifying the duotone curve
In a duotone image, each ink has a separate curve that specifies how the color is 
distributed across the shadows and highlights. This curve maps each grayscale value in 
the original image to a specific ink percentage. 



Using Help | Contents | Index Back 624  

Adobe Photoshop CS Help Printing (Photoshop) 

Using Help | Contents | Index Back 624  

To modify the duotone curve for a given ink:

1 To preview any adjustments, select the Preview option.

2 Click the curve box next to the ink color box.

The default duotone curve, a straight diagonal line, indicates that the grayscale values in 
the original image map to an equal percentage of ink. At this setting, a 50% midtone pixel 
prints with a 50% tint of the ink, a 100% shadow is printed in 100% color, and so on.

3 Adjust the duotone curve for each ink by dragging a point on the graph or by entering 
values for the different ink percentages. 

• In the curve graph, the horizontal axis moves from highlights (at the left) to shadows 
(at the right). Ink density increases as you move up the vertical axis. You can specify up 
to 13 points on the curve. When you specify two values along the curve, Photoshop 
calculates intermediate values. As you adjust the curve, values are automatically 
entered in the percentage text boxes.

• In the text box, the value you enter indicates the percentage of the ink color that will be 
used to represent the grayscale value in the original image. For example, if you enter 70 
in the 100% text box, a 70% tint of that ink color will be used to print the 100% shadow 
areas of the image. (See “Using the Curves dialog box (Photoshop)” on page 189.)

4 Click Save in the Duotone Curve dialog box to save curves created with this dialog box. 

5 Click Load to load these curves or curves created in the Curves dialog box, including 
curves created using the Arbitrary Map option. (See “Saving and loading duotone 
settings” on page 625.)

You can use the Info palette to display ink percentages when you’re working with duotone 
images. Set the readout mode to Actual Color to see the ink percentages that will be 
applied when the image is printed. These values reflect any changes you’ve entered in the 
Duotone Curve dialog box. 

Specifying overprint colors
Overprint colors are two unscreened inks printed on top of each other. For example, when 
a cyan ink prints over a yellow ink, the resulting overprint is a green color. The order in 
which inks are printed, as well as variations in the inks and paper, can significantly affect 
the final results. 

To help you predict how colors will look when printed, use a printed sample of the 
overprinted inks to adjust your screen display. Just remember that this adjustment affects 
only how the overprint colors appear on-screen, not when printed. Before adjusting these 
colors, make sure that you have calibrated your monitor following the instructions in 
“Calibrating and creating a profile of your monitor” on page 119.

To adjust the display of overprint colors:

1 Choose Image > Mode > Duotone.

2 Click Overprint Colors. The Overprint Colors dialog box displays the combinations that 
will result when the inks are printed.

3 Click the color swatch of the ink combination you want to adjust.

4 Select the color you want in the color picker, and click OK. 

5 Repeat steps 3 and 4 until the overprint inks appear as you want them. Then click OK.
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Saving and loading duotone settings
Use the Save button in the Duotone Options dialog box to save a set of duotone curves, 
ink settings, and overprint colors. Use the Load button to load a set of duotone curves, ink 
settings, and overprint colors. You can then apply these settings to other grayscale images.

The Photoshop application includes several sample sets of duotone, tritone, and 
quadtone curves. These sets include some of the more commonly used curves and colors 
and are useful as starting points for creating your own combinations. 

Viewing individual printing plates
Because duotones are single-channel images, your adjustments to individual printing inks 
are displayed as part of the final composite image. In some cases, you may want to view 
the individual “printing plates” to see how the individual colors will separate when printed 
(as you can with CMYK images). 

To view the individual colors of a duotone image:

1 After specifying your ink colors, choose Image > Mode > Multichannel.

The image is converted to a multichannel image, with each channel represented as a spot-
color channel. The contents of each spot channel accurately reflect the duotone settings, 
but the on-screen composite preview may not be as accurate as the preview in Duotone 
mode.

Important: If you make any changes to the image in Multichannel mode, you will be 
unable to revert to the original duotone state (unless you can access the duotone state in 
the History palette). To adjust the distribution of ink and view its effect on the individual 
printing plates, make the adjustments in the Duotone Curves dialog box before converting 
to Multichannel mode. 

2 Select the channel you want to examine in the Channels palette. 

3 Choose Edit > Undo Multichannel to revert to Duotone mode.

Printing duotones
When creating duotones, keep in mind that both the order in which the inks are printed 
and the screen angles you use dramatically affect the final output. 

Click the Auto button in the Halftone Screens dialog box to set the optimal screen angles 
and frequencies. (See “Selecting halftone screen attributes” on page 618.) Make sure that 
you select Use Accurate Screens in the Auto Screens dialog box if you’re printing to a 
PostScript Level 2 (or higher) printer or an imagesetter equipped with an Emerald 
controller. 

Note: The recommended screen angles and frequencies for quadtones are based on the 
assumption that channel 1 is the darkest ink and channel 4 is the lightest ink. 

You do not have to convert duotone images to CMYK to print separations—simply choose 
Separations from the Profile pop-up menu in the Color Management section of the Print 
dialog box (for setting printer options). (See “Printing color separations” on page 620.) 
Converting to CMYK mode converts any custom colors to their CMYK equivalents. 
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Exporting duotone images to other applications
To prepare a duotone image for exporting to a page-layout application, save the image in 
EPS or PDF format (unless the image contains spot channels, in which case you should 
convert it to Multichannel mode and save it in DCS 2.0 format). Keep in mind that it’s 
important to name custom colors so they’ll be recognized by the other application. 
Otherwise the image won’t print correctly—or might not print at all. 

Using online services
The Online Services feature allows you to send images from Photoshop to remote service 
providers, such as Photo Printing partners and Online Sharing companies. The service list 
may be updated each time you select the Online Services command, so check it 
occasionally for new services.

To select an online service:

1 Choose File > Online Services.

2 In the Online Services Assistant dialog box, choose a service from the list.
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Automating Tasks

About actions
An action is a series of commands that you play back on a single file or a batch of files. 
For example, you can create an action that applies an Image Size command to change an 
image to a specific size in pixels, followed by an Unsharp Mask filter that resharpens the 
detail, and a Save command that saves the file in the desired format.

Most commands and tool operations are recordable in actions. Actions can include stops 
that let you perform tasks that cannot be recorded (for example, using a painting tool). 
Actions can also include modal controls that let you enter values in a dialog box while 
playing an action. Actions form the basis for droplets, which are small applications that 
automatically process all files that are dragged onto their icon.

Both Photoshop and ImageReady include a number of predefined actions, although 
Photoshop has significantly more user-recordable functionality than ImageReady. You can 
use these actions as is, customize them to meet your needs, or create new actions.

Using the Actions palette
You use the Actions palette to record, play, edit, and delete individual actions. This palette 
also lets you save and load action files.

In Photoshop, actions are grouped into sets—you can create new sets to better organize 
your actions. (See “Organizing sets of actions (Photoshop)” on page 641.) In ImageReady, 
you cannot group actions into sets.

Photoshop Actions palette 
A. Action or set with excluded command B. Action or set with a modal control C. Included 
command (toggles command on or off ) D. Modal control (toggles modal control on or off )
E. Excluded command F. Set G. Action H. Recorded commands 

To display the Actions palette:

Choose Window > Actions and press Alt +F9 (Windows) or Window > Actions (Mac OS), 
or click the Actions palette tab if the palette is visible but not active.
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By default, the Actions palette displays actions in list mode—you can expand and collapse 
sets, actions, and commands. In Photoshop, you can also choose to display actions in 
button mode (as buttons in the Actions palette that play an action with a single mouse 
click). However, you cannot view individual commands or sets in button mode. 

To expand and collapse sets, actions, and commands:

Click the triangle  to the left of the set, action, or command in the Actions palette. 
Alt-click (Windows) or Option-click (Mac OS) the triangle to expand or collapse all actions 
in a set or all commands in an action.

To select actions:

Do one of the following:

• Click an action name to select a single action.

• (Photoshop) Shift-click action names to select multiple, contiguous actions.

• (Photoshop) Ctrl-click (Windows) or Command-click (Mac OS) action names to select 
multiple, discontiguous actions.

To display actions as buttons (Photoshop):

Choose Button Mode from the Actions palette menu. Choose Button Mode again to return 
to list mode.

To create a new set (Photoshop):

1 Do one of the following:

• In the Actions palette, click the Create New Set button .

• In the Actions palette menu, choose New Set.

2 Enter the name of the new set. 

Note: If you plan to create a new action and group it in a new set, make sure you create 
the set first. Then, the new set will appear in the set pop-up menu when you create your 
new action.

Recording actions
Keep in mind the following guidelines when recording actions:

• You can record most—but not all—commands in an action. 

• You can record operations that you perform with the Marquee, Move, Polygon, Lasso, 
Magic Wand, Crop, Slice, Magic Eraser, Gradient, Paint Bucket, Type, Shape, Notes, 
Eyedropper, and Color Sampler tools—as well as those that you perform in the History, 
Swatches, Color, Paths, Channels, Layers, Styles, and Actions palettes.

• Results depend on file and program setting variables, such as the active layer or the 
foreground color. For example, a 3-pixel Gaussian blur won’t create the same effect on a 
72-ppi file as on a 144-ppi file.  Nor will Color Balance work on a grayscale file.
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• When recording actions that include dialog boxes and palettes, the settings recorded 
will be the ones that are presently in the dialog box and palette at the time of the 
recording. If you change a setting in a dialog box or palette while recording an action, 
the resulting value will be the one recorded.

Note: Most dialog boxes retain the values of their previous settings; when they next 
appear they may already have values. Be sure to check carefully to see if the values are the 
ones you want to record.

• Modal operations and tools—as well as tools that record position—use the units 
currently specified for the ruler. A modal operation or tool is one that requires you 
to press Enter or Return to apply its effect, such as the transformation and crop 
commands. Tools that record position include the Marquee, Slice, Gradient, Magic 
Wand, Lasso, Shape, Path, Eyedropper, and Notes tools.

In Photoshop, when recording an action that will be played on files of different sizes, 
set the ruler units to percent. As a result, the action will always play back in the same 

relative position in the image.

• You can record the Play command listed on the Actions palette menu to cause one 
action to play another.

• In ImageReady, you can drag a command from the History palette to the action in the 
Actions palette in which you want the command recorded. Commands in italics are not 
recordable in an action. You cannot drag italicized commands from the History palette 
to the Actions palette. 

• Photoshop and ImageReady cannot share actions.

Creating a new action
When you create a new action, the commands and tools you use are added to the action 
until you stop recording.

To create a new action:

1 Open a file.

2 In the Actions palette, click the New Action button , or choose New Action from the 
Actions palette menu.

3 Enter a name for the action.

4 (Photoshop) Choose a set from the pop-up menu. 

5 If desired, set one or both of the following options:

• Assign a keyboard shortcut to the action. You can choose any combination of a 
Function key, the Ctrl key (Windows) or Command key (Mac OS), and the Shift key (for 
example, Ctrl+Shift+F3), with these exceptions: In Windows, you cannot use the F1 key, 
nor can you use F4 or F6 with the Ctrl key.

• (Photoshop) Assign a color for display in Button Mode.

6 Click Record. The Record button in the Actions palette turns red .

Important: When recording the Save As command, do not change the filename. If you 
enter a new filename, Photoshop records the filename and uses that filename each time 
you run the action. Before saving, if you navigate to a different folder, you can specify a 
different location without having to specify a filename.
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7 Choose the commands, and perform the operations you want to record.

8 To stop recording, either click the Stop button, choose Stop Recording from the Actions 
palette menu, or press the Escape key. To resume recording in the same action, choose 
Start Recording from the Actions palette menu. 

Recording paths (Photoshop)
The Insert Path command lets you include a complex path (a path created with a pen tool 
or pasted from Adobe Illustrator) as part of an action. When the action is played back, the 
work path is set to the recorded path. You can insert a path when recording an action or 
after it has been recorded.

Note: Playing actions that insert complex paths may require significant amounts of 
memory. If you encounter problems, increase the amount of memory available to 
Photoshop.

To record a path:

1 Do one of the following:

• Start recording an action.

• Select an action’s name to record a path at the end of the action.

• Select a command to record a path after the command. 

2 Select an existing path from the Paths palette.

3 Choose Insert Path from the Actions palette menu.

If you record multiple Insert Path commands in a single action, each path will replace the 
previous one in the target file. To add multiple paths, record a Save Path command using 
the Paths palette after recording each Insert Path command.

Inserting stops
You can include stops in your action that let you perform a task that cannot be recorded 
(for example, using a painting tool). Once you’ve completed the task, click the Play button 
in the Actions palette to complete the task. You can insert a stop when recording an action 
or after it has been recorded.

You can also display a short message when the action reaches the stop. For example, you 
can remind yourself what needs to be done before continuing with the action. Photoshop 
gives you the option of including a Continue button in the message box. This lets you 
check for a certain condition in the file (for example, a selection) and continue if nothing 
needs to be done. ImageReady automatically provides the Continue button.

To insert a stop:

1 Choose where to insert the stop by doing one of the following:

• Select an action’s name to insert a stop at the end of the action.

• Select a command to insert a stop after the command. 

2 Choose Insert Stop from the Actions palette  menu and choose Insert Stop. In 
ImageReady you can also click the Insert a Step button at the bottom of the palette.

3 Type the message you want to appear. 
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4 (Photoshop) If you want the option to continue the action without stopping, select 
Allow Continue.

5 Click OK.

Inserting Conditionals (ImageReady)
A conditional is a statement of a situation that must be met before the next step of an 
action can take place. You set both the condition situation and the steps to take if the 
condition is met. Conditionals are extremely useful in limiting the range of items an action 
will work on. For instance, say you have hundreds of images to import into a Web-based 
photo gallery, but you have to resize any that are too large for your specifications. You 
can add a conditional to your action that looks at all the files, checks the size, and changes 
only the ones that are too large, thus saving much time and space. Conditionals are also 
useful for nesting actions within actions, only playing the nested action under specified 
conditions.

To insert a conditional:

1 In the Actions palette, choose the step you want the conditional to appear after.

2 Choose Insert Conditional from the Actions palette menu, or click the Insert Step 
button  at the bottom of the palette and choose Insert Conditional.

Setting up a conditional for a recorded action

3 Choose when to execute the conditional action steps:

• Always executes the condition actions every time.

• Ask pops up a dialog during the condition to ask the user if the condition has been met.

• Never does not execute the condition actions.

Note: If you choose Always, Never, or Ask, you will not have the option of choosing one of 
the other conditions.
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In the If The Following Condition Is Met area of the dialog box, choose a condition. You can 
only choose one property to base your condition on. If you choose Image Width, for 
instance, you can’t also choose another image property, nor can you choose a layer or a 
document property.

Image Aspect Ratio Lets you choose between Landscape, Portrait and Square, and lets 
you ask if the aspect ratio is or is not one of those.

Image Width Sets the conditional to ask if the image width is equal to or not equal to, 
greater than, greater than or equal to, less than, or less than or equal to a width you can 
specify in the box.

Image Height Sets the conditional to ask if the image height is equal to or not equal to, 
greater than, greater than or equal to, less than, or less than or equal to a width you can 
specify in the box.

Layer count Sets the conditional to ask if the layer count is equal to or not equal to, 
greater than, greater than or equal to, less than, or less than or equal to a width you can 
specify in the box.

Layer type Lets you choose between Pixel, Text, Adjustment, Fill and Layer Set, and lets 
you ask if the layer type is or is not one of those.

Layer name Sets the conditional to ask if the name contains, does not contain, begins 
with, does not begin with, ends with, does not end with, or is equal to or not equal to a 
name you can specify in the box.

Document name Sets the conditional to ask if the document name contains, does not 
contain, begins with, does not begin with, ends with, does not end with, or is equal to or 
not equal to a name you can specify in the box.

4 In the Perform the Following Actions area of the dialog box, choose an action to 
perform if the condition has been met:

• Play Action launches the action you choose from the pop-up menu.

• Include lets you specify the number of steps the action will continue before ending. 
The steps will be performed only if the condition is met, and ignored otherwise.

• Skip lets you specify a number of subsequent steps the action should ignore if the 
condition is met. If the skip condition is not met, the steps will be executed.

• Skip Remaining Steps in the Action finishes the action without executing the remaining 
steps if the condition is met; otherwise, all steps are executed.

• Cancel Playing the Action terminates the action at this point if the condition is met.

• Repeat lets you specify the number of times the chosen number of previous steps are to 
be repeated.

• Beep notifies you with an alert sound when the condition you specify has been met.
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Editing conditionals
The conditionals you create appear in the Actions palette. Clicking the triangle to the 
left of the conditional action reveals its conditions and actions. You can edit the condi-
tional by double-clicking any of its conditions or actions, which will open the Conditional 
dialog box.

Actions palette showing a recorded action with a conditional

Setting modal controls
A modal control pauses an action so that you can specify values in a dialog box or use a 
modal tool. You can only set modal controls for actions that launch dialog boxes or 
activate modal tools. If you do not set a modal control, dialog boxes do not appear when 
you play the action, and you cannot change the recorded values.

A modal control is indicated by a dialog box icon  to the left of a command, action, or set 
in the Actions palette. Actions and sets in which some, but not all, available commands are 
modal display a red dialog box icon . In Photoshop, you must be in list mode—not 
button mode—to set a modal control.

To set a modal control:

Do one of the following:

• Click the box to the left of the command name to display the dialog box icon. Click 
again to remove the modal control.

• To turn on or disable modal controls for all commands in an action, click the box to the 
left of the action name.

• (Photoshop) To turn on or disable modal controls for all actions in a set, click the box to 
the left of the set name.
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Excluding commands
You can exclude commands that you don’t want to play as part of a recorded action. 
In Photoshop, you must be in list mode—not button mode—to exclude commands.

To exclude or include a command:

1 To expand the listing of commands in an action, click the triangle to the left of the 
action you want to work with.

2 Click the check mark to the left of the specific command you wish to exclude; click 
again to include the command. To exclude or include all commands in an action, click the 
check mark to the left of the action name. 

When you exclude a command, its check mark disappears. In addition, the check mark of 
the parent action turns red to indicate that some of the commands within the action are 
excluded.

Inserting nonrecordable commands (Photoshop)
You cannot record the painting and toning tools, tool options, view commands, and 
window commands. However, you can insert many nonrecordable commands into an 
action using the Insert Menu Item command. 

You can insert a command when recording an action, or after it has been recorded. 
An inserted command doesn’t execute until the action is played, so the file remains 
unchanged when the command is inserted. No values for the command are recorded in 
the action. If the command has a dialog box, the dialog box appears during playback, 
and the action pauses until you click OK or Cancel. 

Note: When you use the Insert Menu Item command to insert a command that opens a 
dialog box, you cannot disable the modal control in the Actions palette.

To insert a menu item in an action:

1 Choose where to insert the menu item:

• Select an action’s name to insert the item at the end of the action.

• Select a command to insert the item at the end of the command. 

2 Choose Insert Menu Item from the Actions palette menu.

3 With the Insert Menu Item dialog box open, choose a command from its menu.

4 Click OK.

Specifying an output folder (ImageReady)
If you include a Save Optimized step in your action or create a droplet from the action, 
you can specify the folder in which images are placed after the action is performed. 

Note: In Photoshop, you can set an output folder when using the Batch command to 
process files. (See “Using the Batch command (Photoshop)” on page 641.)



Using Help | Contents | Index Back 635  

Adobe Photoshop CS Help Automating Tasks 

Using Help | Contents | Index Back 635  

To specify an output folder:

1 Select the action for which you want to specify an output folder in the Actions palette.

2 Choose Insert Set Output Folder from the Actions palette menu, or click the Insert Step 
button  at the bottom of the palette and choose Insert Set Output Folder.

3 Select a folder, and click OK.

Recording image size options (ImageReady)
Resizing images is a typical step in preparing irregularly sized images for use on the Web. 
You can automate this task by creating an action that includes the Image Size command. 
ImageReady provides several options that give you control over how an action resizes 
images.

To record Image Size options:

1 Start recording an action.

2 Choose Image > Image Size, and enter the desired image dimensions. (See “Changing 
the pixel dimensions of an image” on page 67.)

3 Select Action Options.

4 Choose an option from the Fit Image By menu:

• Width to constrain proportions using the new width value.

• Height to constrain proportions using the new height value.

• Width & Height to constrain proportions using either the new width value or the new 
height value.

• Percent to constrain proportions using the new percent value.

5 Select Do Not Enlarge to prevent images that are smaller than the new dimensions 
from being sized up.

6 Click OK and continue recording the action.

Inserting optimization settings for selected slices (ImageReady)
When you record a Save Optimized action step, ImageReady includes optimization 
settings for the entire image. You can insert optimization settings for individual slices 
using the Insert Set Optimization Settings command.

To insert optimization settings in an action:

1 Select the slice or slices for which you want to record optimization settings. 
(See “Selecting slices” on page 478.)

2 Select the action in which you want to insert the optimization settings.

3 Do one of the following:

• Choose Insert Set Optimization Settings to current file format from the Actions palette 
menu. (The command indicates the optimization file format currently applied to the 
selected slice.)

• Drag the droplet icon  from the Optimize palette onto the Actions palette.

• Click the Insert Step button  at the bottom of the Actions palette. Choose Insert Set 
Optimization Settings To, and choose a format.
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Playing actions
Playing an action executes the series of commands you recorded in the active document. 
You can exclude specific commands from an action or play a single command. If the action 
includes a modal control, you can specify values in a dialog box or use a modal tool when 
the action pauses. 

Action applied to an image

Note: In button mode, clicking a button executes the entire action—though commands 
previously excluded are not executed. 

To play an action on a file:

1 Open the file.

2 Do one of the following:

• To play an entire action, select the action name, and click the Play button  in the 
Actions palette, or choose Play from the palette menu. 

• If you assigned a key combination to the action, press that combination to play the 
action automatically.

• To play part of an action, select the command from which you want to start playing, and 
click the Play button in the Actions palette, or choose Play from the palette menu.

To play a single command in an action:

1 Select the command you want to play.

2 Do one of the following:

• Ctrl-click (Windows) or Command-click (Mac OS) the Play button in the Actions palette.

• Press Ctrl (Windows) or Command (Mac OS), and double-click the command.
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To undo an entire action:

Do one of the following:

• (Photoshop) Take a snapshot in the History palette before you play an action, and then 
select the snapshot to undo the action.

• (ImageReady) Choose Edit > Undo Action Name.

Setting playback options (Photoshop)
Sometimes a long, complicated action does not play properly, but it is difficult to tell 
where the problem occurs. The Playback Options command gives you three speeds at 
which to play actions, so that you can watch each command as it is carried out.

When working with actions that contain audio annotations, you can specify whether or 
not the action will pause for audio annotations. This ensures that each audio annotation 
completes playing before the next step in the action is initiated.

To specify how fast actions should play:

1 Choose Playback Options from the Actions palette menu.

2 Specify a speed:

• Accelerated to play the action at normal speed (the default).

• Step by Step to complete each command and redraw the image before going on to the 
next command in the action.

• Pause For to enter the amount of time Photoshop should pause between carrying out 
each command in the action.

3 Select Pause For Audio Annotation to ensure that each audio annotation in an action 
completes playback before the next step in the action is initiated. Deselect this option if 
you want an action to continue while an audio annotation is playing.

4 Click OK.

Editing actions
After you record an action, you can edit it in a variety of ways. You can rearrange actions 
and commands in the Actions palette; record additional commands in an action; rerecord, 
duplicate, and delete commands and actions; and change action options. 

Rearranging actions and commands
You can rearrange actions in the Actions palette and rearrange commands within an 
action to change their order of execution. 

To rearrange actions:

In the Actions palette, drag the action to its new location before or after another action. 
When the highlighted line appears in the desired position, release the mouse button.

You can edit conditionals in actions. See “Editing conditionals” on page 633.
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To rearrange commands:

In the Actions palette, drag the command to its new location within the same or another 
action. When the highlighted line appears in the desired position, release the mouse 
button.

Recording additional commands
You can add commands to an action using the Record button or the Start Recording 
command in the Actions palette.

To record additional commands:

1 Do one of the following:

• Select the action name to insert a new command at the end of the action.

• Select a command in the action to insert a command after it.

2 Click the Record button, or choose Start Recording from the Actions palette menu.

3 Record the additional commands.

4 Click the Stop button to stop recording.

In ImageReady, you can drag any nonitalicized command from the History palette to 
the Actions palette without clicking the Record button or choosing Start Recording 

from the Actions palette menu.

Rerecording and duplicating actions and commands
Rerecording an action or command lets you set new values for it. Duplicating an action or 
command lets you make changes to it without losing the original version.

To record an action again (Photoshop):

1 Select an action, and choose Record Again from the Actions palette menu.

2 For a modal tool, do one of the following:

• Use the tool differently, and Press Enter (Windows) or Return (Mac OS) to change the 
tool’s effect.

• Press Cancel to retain the same settings.

3 For a dialog box, do one of the following:

• Change the values, and click OK to record them.

• Click Cancel to retain the same values. 

To record a single command again:

1 In the Actions palette, double-click the command. 

2 Enter the new values, and click OK.
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To duplicate an action or command:

Do one of the following:

• Alt-drag (Windows) or Option-drag (Mac OS) the action or command to a new location 
in the Actions palette. When the highlighted line appears in the desired location, 
release the mouse button.

• Select an action or command. Then choose Duplicate from the Actions palette menu. 
The copied action or command appears after the original.

• Drag an action or command to the New Action button at the bottom of the Actions 
palette. The copied action or command appears after the original.

In Photoshop, you can duplicate sets as well as actions and commands.

Deleting actions and commands
If you no longer need an action or command, you can delete it from the Actions palette.

To delete an action or command:

1 In the Actions palette, select the action or command you want to delete.

2 Delete the action or command:

• Click the Trash button  on the Actions palette. Click OK to delete the action or 
command. 

• Alt-click (Windows) or Option-click (Mac OS) the Trash button to delete the selected 
action or command without displaying a confirmation dialog box.

• Drag the action or command to the Trash button on the Actions palette to delete the 
selected action or command without displaying a confirmation dialog box.

• Choose Delete from the Actions palette menu. 

To delete all actions in the Actions palette (Photoshop):

Choose Clear All Actions from the Actions palette menu.

Even after clearing all actions, the Actions palette can be restored to its default set of 
actions. See “Saving and loading actions” on page 640.

Changing action options
You can change the name, keyboard shortcut, and button color (Photoshop) for an action 
in the Action Options dialog box.

To rename an action:

Double-click the action name in the Actions palette and enter a new name.

To change action options:

1 Do one of the following:

• Select the action, and choose Action Options from the Actions palette menu.

2 Type a new name for the action, or change other options. For more information about 
action options, see “Recording actions” on page 628.

3 Click OK.
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Managing actions in the Actions palette
By default, the Actions palette displays predefined actions (shipped with the application) 
and any actions you create. You can also load additional actions into the Actions palette.

Note: Photoshop actions are not compatible with ImageReady, and vice versa. 

Saving and loading actions
Actions are automatically saved to the Actions Palette folder in the Adobe Photoshop or 
Adobe ImageReady CS Settings folder. If this file is lost or removed, the actions you 
created are lost. You can save your actions to a separate actions file so that you can recover 
them if necessary. You can also load a variety of action sets that are shipped with 
Photoshop (Photoshop). 

Note: The default location of the Adobe Photoshop CS Settings folder varies by operating 
system. Use your operating system’s Find command to locate this folder.

To save a set of actions:

1 Select a set.

2 Choose Save Actions from the Actions palette menu.

3 Type a name for the set, choose a location, and click Save.

You can save the set anywhere. However, if you place the file in the Presets/Photoshop 
Actions folder inside the Photoshop program folder, the set will appear at the bottom of 
the Actions palette menu after you restart the application.

Press Ctrl+Alt (Windows) or Command+Option (Mac OS) when you choose the Save 
Actions command to save the actions in a text file. You can use this file to review or 

print the contents of an action. However, you can’t reload the text file back into 
Photoshop.

To load a set of actions:

Do one of the following:

• Choose Load Actions from the Actions palette menu. Locate and select the action 
set file, and then click Load. (In Windows, Photoshop action set files have the 
extension .atn.) 

• Select an action set from the bottom of the Actions palette menu.

To restore actions to the default set:

1 Choose Reset Actions from the Actions palette menu.

2 Click OK to replace the current actions in the Actions palette with the default set, or 
click Append to add the set of default actions to the current actions in the Actions palette.
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Organizing sets of actions (Photoshop)
To help you organize your actions, you can create sets of actions and save the sets to disk. 
You can organize sets of actions for different types of work—such as print publishing and 
online publishing—and transfer sets to other computers. 

Although ImageReady doesn’t allow you to create sets, you can manually organize 
actions in the ImageReady Actions folder. For example, if the Actions palette contains 

too many actions, create a new folder inside the ImageReady Actions folder and move 
less-used actions from the ImageReady Actions folder to this new folder. The relocated 
actions are removed from the palette until you return them to the ImageReady Actions 
folder.

To create a new set of actions:

1 In the Actions palette, click the New Set button , or choose New Set from the 
palette menu.

2 Enter the name of the set, and click OK.

To move an action to a different set:

In the Actions palette, drag the action to a different set. When the highlighted line appears 
in the desired position, release the mouse button.

To rename a set of actions:

1 In the Actions palette, choose Set Options from the pop-up menu.

2 Enter the name of the set, and click OK.

Using the Batch command (Photoshop)
The Batch command lets you play an action on a folder of files and subfolders. If you have 
a digital camera or a scanner with a document feeder, you can also import and process 
multiple images with a single action. Your scanner or digital camera may need an acquire 
plug-in module that supports actions. (If the third-party plug-in wasn’t written to import 
multiple documents at a time, it may not work during batch-processing or if used as part 
of an action. Contact the plug-in’s manufacturer for further information.) 

You can also import PDF images from Acrobat Capture or other software programs.

When batch-processing files, you can leave all the files open, close and save the changes 
to the original files, or save modified versions of the files to a new location (leaving the 
originals unchanged). If you are saving the processed files to a new location, you may 
want to create a new folder for the processed files before starting the batch.

For better batch performance, reduce the number of saved history states and deselect 
the Automatically Create First Snapshot option in the History palette.

To batch-process files using the Batch command:

1 Choose File > Automate > Batch.

2 For Play, choose the desired set and action from the Set and Action pop-up menus.
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3 For Source, choose a source from the pop-up menu:

• Folder to play the action on files already stored on your computer. Click Choose to 
locate and select the folder.

• Import to import and play the action on images from a digital camera, scanner, or PDF 
document.

• Opened Files to play the action on all open files.

• File Browser to play the action on the selected files in the File Browser.

4 Select Override Action “Open” Commands if you want Open commands in the action to 
refer to the batched files, rather than the filenames specified in the action. If you select this 
option, the action must contain an Open command because the Batch command will not 
automatically open the source files.

Deselect Override Action “Open” Commands if the action was recorded to operate on 
open files or if the action contains Open commands for specific files that are required by 
the action. 

5 Select Include All Subfolders to process files in subfolders. 

6 Select Suppress File Open Options Dialogs to hide File Open Options dialogs. This is 
useful when batching actions on camera raw files. The default or previously specified 
settings will be used. For more information on using the Batch command to open camera 
raw image files, see “Creating an action to open camera raw image files” on page 84.

7 Select Suppress Color Profile Warnings to turn off display of color policy messages. 

8 Choose a destination for the processed files from the Destination menu:

• None to leave the files open without saving changes (unless the action includes a 
Save command).

• Save and Close to save the files in their current location, overwriting the original files. 

Note: If you choose the Save and Close option, you can select the Override Action “Save 
As” Commands option. This option causes the Batch command to override any action Save 
As commands, and saves the file back to its original filename in its original folder.

• Folder to save the processed files to another location. Click Choose to specify the 
destination folder. 

9 Select Override Action “Save As” Commands if you want the Save As instructions from 
the Batch command instead of the Save As instructions in the action. If you select this 
option, the action must contain a a Save As command because the Batch command will 
not automatically save the source files. This is useful for saving documents with options 
not available in the Batch command (such as JPEG compression or TIFF options, etc.)

Note: No matter how you’ve recorded your action’s Save As steps (with or without 
filename specifications), if this option is selected, the file is saved to the folder and the 
filename in the Batch command.

Deselect Override Action “Save As” Commands will save the files processed by the Batch 
command in the location specified as the destination in the Batch dialog box.
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Note: You can record an action that saves with a specified filename and folder. If you’ve 
done this, and have Override Action “Save As” Commands off, the same file will be 
overwritten each time. If you’ve recorded your Save As step in the action without 
specifying a filename, the Batch command will save it to the same folder each time, 
but will use the filename of the document being saved.

10 If you chose Folder as the destination, specify a file-naming convention and select file 
compatibility options for the processed files:

• For File Naming, select elements from the pop-up menus or enter text into the fields to 
be combined into the default names for all files. The fields let you change the order and 
formatting of the filename parts. You must include at least one field that is unique for 
every file (for example, filename, serial number, or serial letter) to prevent files from 
overwriting each other. Starting serial number specifies the starting number for any 
serial number fields. Serial letter fields always start with the letter “A” for the first file.

• For File Name Compatibility, choose Windows, Mac OS, and UNIX to make filenames 
compatible with Windows, Mac OS, and UNIX operating systems.

Saving files using the Batch command options usually saves the files in the same 
format as the original files. To create a batch process that saves files in a new format, 

record the Save As command followed by the Close command as part of your original 
action. Then choose Override Action “Save In” Commands for the Destination when 
setting up the batch process. 

11 Select an option for error processing from the Errors pop-up menu:

• Stop for Errors to suspend the process until you confirm the error message.

• Log Errors to File to record each error in a file without stopping the process. If errors are 
logged to a file, a message appears after processing. To review the error file, open with 
a text editor after the batch command has run. 

To batch-process using multiple actions, create a new action that plays all the other 
actions, and then batch process that one (you can nest actions within actions). 

To batch-process multiple folders, create aliases within a folder to the other folders you 
want to process, and select the Include All Subfolders option.

To batch process files in nested folders into different formats:

1 Process your folders as you would normally, until the Destination step.

2 Choose “Save and Close” for the destination. You can select the Override Action “Save 
As” Commands options to do the following:

• If the “Save As” step in the action contains a filename, this overrides it with the name of 
the document being saved; all “Save As” steps are treated as if they were recorded 
without a filename.

• The folder you specified in the “Save As” action step is overridden with the document’s 
original folder.

Note: For this to work properly, you must have a “Save As” step in the action; the Batch 
command does not automatically save files.
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This procedure lets you, for instance, sharpen, resize and save the images as JPEGs back 
into their original folders. You create an action that has a sharpen step, a resize step, and 
then a “Save As JPEG” step. When you batch process this action, you set “Include All 
Subfolders,” make the destination “Save and Close,” and you set “Override Action “Save As” 
Commands” to on.

Using droplets
A droplet is a small application that applies an action to one or more images that you drag 
onto the droplet icon  in Photoshop or  in ImageReady. You can save a droplet on the 
desktop or to another location on disk.

Creating a droplet from an action
Actions are the basis for creating droplets—you must create the desired action in the 
Actions palette prior to creating a droplet. (See “Recording actions” on page 628.)

In ImageReady, you can also create droplets with the Optimize palette, so that you can 
apply Optimize palette settings to single images or batches of images.

To create a droplet from an action (Photoshop):

1 Choose File > Automate > Create Droplet.

2 Click Choose in the Save Droplet In section of the dialog box, and select a location to 
save the droplet. 

3 Select the desired set and action from the Set and Action menus.

4 Set Play options for the droplet:

• Select Override Action “Open” Commands if you want Open commands in the action to 
refer to the batched files, rather than the filenames specified in the action. Deselect 
Override Action “Open” Commands if the action was recorded to operate on open files 
or if the action contains Open commands for specific files that are required by the 
action.

• Select Include All Subfolders to process files in subdirectories.

• Select Suppress Color Profile Warnings to turn off display of color policy messages.

• Select Suppress File Open Options Dialogs to hide File Open Options dialogs. This is 
useful when batching actions on camera raw image files. The default or previously 
specified settings will be used. For information about using droplets to open camera 
raw image files, see “Creating an action to open camera raw image files” on page 84.

5 Select a destination for the processed files from the Destination menu:

• None to leave the files open without saving changes (unless the action included a 
Save command).

• Save and Close to save the files in their current location. 

Note: If you selected the Save and Close option, you can select the “Override Action 
“Save As” Commands option.” This option causes the droplet to override any action 
Save As commands and saves the file back to its original filename in its original folder. 
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6 Select Folder to save the process files to another location. Select Override Action 
“Save As” Commands if you want the Save As instructions from the droplet instead of the 
Save As instructions in the action. If you select this option, the action must contain a a 
Save As command, because the droplet will not automatically save the source files. This is 
useful for saving documents with options not available in the droplet (such as JPEG 
compression or TIFF options). 

Note: No matter how you’ve recorded your action’s Save As steps (with or without 
filename specifications), if this option is selected, the file is saved to the folder and the 
filename in the droplet.

Deselect Override Action “Save As” Commands will save the files processed by the droplet 
in the location specified as the destination in the Create Droplet dialog box.

Note: You can record an action that saves with a specified filename and folder. If you’ve 
done this, and have Override Action “Save As” Commands off, the same file will be 
overwritten each time. If you’ve recorded your Save As step in the action without 
specifying a filename, the droplet will save it to the same folder each time but will use 
the filename of the document being saved.

7 If you chose Folder as the destination, specify a file-naming convention and select file 
compatibility options for the processed files:

• For File Naming, select elements from the pop-up menus or enter text into the fields to 
be combined into the default names for all files. Elements include document name, 
serial number or letter, file creation date, and file extension. Starting serial number 
specifies the starting number for any serial number fields. Serial letter fields always start 
with the letter “A” for the first file.

• For Compatibility, choose Windows, Mac OS, and UNIX to make filenames compatible 
with Windows, Mac OS, and UNIX operating systems.

8 Select an option for error processing from the Errors pop-up menu:

• Stop for Errors to suspend the process until you confirm the error message.

• Log Errors to File to record each error in a file without stopping the process. If errors are 
logged to a file, a message appears after processing. To review the error file, open it in a 
text editor after the batch command has executed. 

To create a droplet from an action (ImageReady):

1 For best results, make sure that the action contains at least one Set Optimization 
command. To add a Set Optimization command, adjust the settings in the Optimize 
palette, and then drag the droplet icon  from the Optimize palette onto the part of the 
Actions palette where you want to add that command. Or click the Insert Step button  at 
the bottom of the Actions palette and choose Add Set Optimization Settings.

If you do not add a Set Optimization command to the droplet, ImageReady will process 
files using the optimization settings in place at the time the droplet was created.
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2 Create the droplet:

• Drag the name of the action from the Actions palette onto the desktop. The droplet has 
the same name as the action it was created from. You can rename the droplet as you do 
other desktop icons.

• Select an action, and choose Create Droplet from the Actions palette menu. Name the 
droplet, choose a location where the droplet will be saved, and click Save.

Creating droplets for use on different operating systems
When creating droplets that may be used in both Windows and Mac OS, keep the 
following compatibility issues in mind:

• After moving a Photoshop droplet created in Windows to Mac OS, drag the droplet 
onto the Photoshop icon. Photoshop will launch and update the droplet for use in 
Mac OS.

• After moving an ImageReady droplet from Windows to Mac OS, drag the droplet onto 
the ImageReady icon for use on the Mac OS.

• When creating a droplet in Mac OS, use the .exe extension to make droplets compatible 
with both Windows and Mac OS.

• References to filenames are not supported between operating systems. Any action step 
that references a file or folder name (such as an Open command, Save As command, or 
adjustment command that loads its settings from a file) will pause and prompt the user 
for a filename.

Using droplets to process files
To use a droplet, simply drag a file or folder onto the droplet icon  in Photoshop or  in 
ImageReady. If the application you used to create the droplet is not currently running, the 
droplet launches it. 

In ImageReady, you can control droplet processing in the following ways:

• To temporarily pause processing, click Pause. Click Resume to continue the processing.

• To cancel processing, click Stop.

Editing droplets (ImageReady)
In ImageReady, you can edit the commands in a droplet in the same ways you edit the 
commands in an action. You can also set batch options for a droplet before or after you 
create it. For example, you can set the droplet to operate in the background during 
execution, so that you can work in other applications while ImageReady processes images.

To edit a droplet:

1 Double-click the droplet or Choose File > Open and select the action to open the 
droplet window. The droplet window looks like a simplified version of the Actions palette.

2 Edit the droplet in the same ways you would edit an action:

• Change the order of commands by dragging them in the droplet list.

• Delete commands by dragging them to the Trash button .

• Add a command by dragging a state from the History palette to the area in which you 
want the command recorded in the droplet window.
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To adjust droplet batch options:

1 Do one of the following:

• Before you create the droplet, select an action and choose Batch Options from the 
Actions palette menu.

• After you create the droplet, double-click the droplet to open the droplet window, 
and double-click Batch Options at the top of the droplet list.

2 Select Original (same name and folder) to save the original file with the same name and 
in the same folder.

3 Select Optimized to save an optimized version of the file. Then do any of the following:

• For In, choose the location in which you want to save the optimized file.

• For If Duplicate File Name, choose how and whether to append numbers or letters to 
indicate the optimized file in cases of duplicate filenames.

• For Modify File Name For, choose whether ImageReady appends or rewrites the 
filename using Windows, Mac OS 9, or UNIX file-naming conventions.

4 Select playback options:

• Run In Background to hide ImageReady during droplet execution, so that you can work 
in other applications while processing takes place. When you select Run In Background, 
other playback options requiring user input during processing are turned off, unless 
you have specifically set the dialog to pop ImageReady back up. ImageReady appears 
when the droplet completes execution.

Note: ImageReady is not available for creating and modifying current images while 
background processing is taking place. 

• Display Image to show the images as they are being processed.

• Pause Before Save to stop the processing of each image before saving it.

5 Choose error options from the Errors menu:

• Stop to suspend the process until you confirm the error message.

• Skip Step to not process steps in which errors are encountered.

• Skip File to not process files in which errors are encountered.

Using droplets to automate optimization settings (ImageReady)
You can save Optimize palette settings for use on individual images or batches of images 
by creating a droplet for the settings. The droplet lets you apply the compression settings 
to an image or batch of images that you drag onto the droplet icon.

To create a droplet for automating Optimize palette settings:

1 With an image displayed in the image window, choose a compression format and 
desired compression options in the Optimize palette. (See “Optimizing images” on 
page 531.)

2 Create a droplet:

• Drag the droplet icon  from the Optimize palette onto the desktop. 
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The droplet is named with a brief description of the compression settings, including file 
format and color palette or quality setting information. You can rename the droplet as you 
do other desktop icons.

• Click the droplet icon on the Optimize palette. Name the droplet, choose a location 
where the droplet will be saved, and click Save.

• Choose Create Droplet from the Optimize palette menu. Name the droplet, choose a 
location where the droplet will be saved, and click Save.

You can add optimization settings to an action by dragging the droplet icon in the 
Optimize palette to the Actions palette. 

Using the Automate commands (Photoshop)
The Automate commands simplify complex tasks by combining them into one or more 
dialog boxes. You can send files directly from the file browser to any of the automation 
plug-ins that process multiple images.

To use an automated command:

Choose File > Automate, and then choose any of the commands:

• PDF slideshow creates a PDF slideshow from multiple documents.

• Conditional Mode Change changes the color mode of an image to the mode you 
specify, based on the original mode of the image. Record this command in an action to 
ensure that images use the correct color mode and avoid generating unwanted error 
messages.

• Contact Sheet II produces a series of thumbnail previews on a single sheet from the files 
in the selected folder. (See “Creating contact sheets” on page 594.)

• Crop and Straighten (Photoshop) finds, separates and straightens one or more photo-
graphs from a single scan. 

• Fit Image fits the current image to the width and height you specify, without changing 
its aspect ratio.

Note: This will resample the image, changing the amount of data in the image.

• Multi-Page PDF to PSD converts each page of a PDF document you select to a separate 
Photoshop file. (See “Opening and importing PDF files” on page 102.)

• Picture Package places multiple copies of a source image on a single page, similar to the 
photo packages traditionally sold by portrait studios. (See “Creating picture packages” 
on page 595.)

• Web Photo Gallery generates a Web site from a set of images—complete with a thumb-
nails index page, individual JPEG image pages, and navigable links. (See “Creating Web 
photo galleries (Photoshop)” on page 500.)

• Photomerge merges multiple overlapping images into panoramas.
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External automation
Photoshop supports some external automation using OLE Automation (Windows) or 
AppleScript (Mac OS). Using either of these methods lets you start Adobe Photoshop and 
execute actions externally.

Using external automation lets you perform such tasks as:

• Having another scriptable application generate a series of files, and having Photoshop 
batch-process them.

• Having Photoshop batch-process files and save them to your Web site.

• Writing a script that runs an action and then shuts down your computer late at night 
after you’ve gone home.

Supported Scripting Languages and Platform Issues
In Windows, you can use any scripting language that supports OLE automation, such as 
Visual Basic. In Mac OS, you can use Applescript. These languages are not cross-platform 
but can control multiple applications such as Adobe Photoshop, Adobe Illustrator, and 
Microsoft Office.

You can also use Javascript on either platform. Javascript support lets you write scripts 
that will run on either Windows or Mac OS but can only control Photoshop. Photoshop 
includes a script editor and debugger for Javascript, but for other scripting languages you 
must use external tools to edit and debug the scripts.

Note: Please refer to the scripting documentation included with your Photoshop appli-
cation installation: AppleScript Reference Guide.pdf, JavaScript Reference Guide.pdf, 
Photoshop Scripting Guide.pdf, and VisualBasic Reference Guide.pdf. These guides can be 
found in Photoshop CS/Scripting Guide.

If you have further questions about OLE, contact Microsoft Corporation. For questions 
about AppleScript, see your Mac OS documentation or contact Apple Computer.

Creating templates for data-driven graphics (ImageReady)
Templates for data-driven graphics streamline how designers and developers work 
together in high-volume publishing environments.

About data-driven graphics
Data-driven graphics make it possible to produce multiple versions of an image quickly 
and accurately. Let’s say, for example, that you need to produce 500 different Web banners 
based on the same template. In the past, you had to manually populate the template with 
data (images, text, and so on). With data-driven graphics, you can quickly generate Web 
banners using variables and data sets.

You can turn any image into a template for data-driven graphics by defining variables for 
layers in the image. In addition, you can create different sets of variable data to view what 
your template will look like when it is rendered.
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Creating different versions of an image using variables 
A. Source file template B. User defines layers as variables C. Different versions of the image 
can be created, each with a different variable data set

Using variables
You use variables to define which elements in a template are dynamic (changeable). 
A variable’s type corresponds to the type of data you want to change in a template. 
Visibility variables let you show or hide the content of a layer. Pixel Replacement 
variables let you replace the pixels in the layer with pixels from another image file. 
Text Replacement variables let you replace a string of text in a type layer.

Note: You can use Photoshop to designate text as a variable for Adobe GoLive, if you 
put your variable text in the topmost text layer. Otherwise, you can use ImageReady to 
explicitly denote variables. GoLive recognizes all ImageReady text and visibility variables, 
but not pixel replacement variables.

Two versions of a Web image based on the same template 
A. Visibility variable B. Pixel Replacement variable C. Text Replacement variable

C

B

A

Daisy RoseLily

Flower

A

B

C

A

B

C
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To define variables:

1 In the Layers palette, select a layer for which you want to define variables.

Note: You cannot define variables for the Background layer.

2 Choose Image > Variables > Define, or choose Variables from the Layers palette menu.

3 Select one or more types of variables:

• Visibility to show or hide the content of the layer.

• Pixel Replacement to replace the pixels in the layer with pixels from another image file.

Note: You specify the replacement image (as well as the replacement text and visibility 
states) when you define a data set. (See “Using data sets” on page 652.)

• Text Replacement to replace a string of text in a type layer.

4 If desired, enter names for the variables. Variable names must begin with a letter, 
underscore, or colon and cannot contain spaces or special characters (except for periods, 
hyphens, underscores, and colons).

5 For Pixel Replacement variables, click Pixel Replacement Options, and do the following:

• Choose a method for scaling the replacement image: Fit to scale the image to fit within 
the bounding box (which may leave parts of the bounding box empty), Fill to scale the 
image to entirely fill the bounding box (which may cause the image to extend beyond 
the bounding box), As Is to not scale the image, and Conform to scale the image non-
proportionally to fit within the bounding box.

• Click a handle on the alignment icon  to choose an alignment for placing the image 
inside the bounding box.

• Select Clip to Bounding Box to clip areas of the image that do not fit within the 
bounding box. This option is only available when the Fill replacement method or As Is 
replacement method is selected.

6 To define variables for an additional layer, choose a layer from the Layer pop-up menu. 
Repeat Steps 3 through 5.

7 Click OK.

To rename a variable:

1 Choose Image > Variables > Define, or choose Variables from the Layers palette menu.

2 Choose the layer that contains the variable from the Layer pop-up menu.

3 Enter a name in the Name text box. Variable names must begin with a letter, under-
score, or colon and cannot contain spaces or special characters (except for periods, 
hyphens, underscores, and colons).

Note: If you are using data sets and want to rename a variable globally (in all layers), 
change the name in the Data Sets section of the Variable dialog box. (See “Using data sets” 
on page 652.)
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To remove variables:

1 Choose Image > Variables > Define, or choose Variables from the Layers palette menu.

2 Choose a layer from the Layer pop-up menu.

3 Deselect one or more variables.

4 Repeat Steps 2 and 3 to remove variables from additional layers, and then click OK.

Using data sets
A data set is a collection of variables and associated data. You can switch between data 
sets to upload different data into your template. 

Assigning data values to variables to create two data sets

To edit the default data set:

1 Do one of the following:

• Choose Image > Variables > Data Sets.

• If the Variables dialog box is open, choose Data Sets from the pop-up menu at the top 
of the dialog box, or click Next.

• Choose Variables from the Layers palette menu. Then choose Data Sets from the 
pop-up menu at the top of the dialog box, or click Next.

Note: You must define at least one variable before you can edit the default data set.

2 Select a variable from the Name pop-up menu or the list at the bottom of the 
dialog box.

3 Edit the variable data:

• For Visibility variables , select Visible to show the layer’s content or Invisible to hide 
the layer’s content.

• For Pixel Replacement variables , click Browse (Windows) or Choose (Mac OS) and 
select a replacement image file.

• For Text Replacement variables , enter a text string in the Value text box.

4 Repeat Steps 2 and 3 for every variable in the template.

5 Click OK, or click Next. 

To create a new data set:

1 Click the New Data Set button .

2 Edit the variable data.

3 Click OK.
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To rename a data set:

Enter a name in the Data Set text box.

To select a data set:

Do one of the following:

• Choose a data set from the Data Set pop-up menu.

• Click the Previous Data Set button  to select the previous set in the list.

• Click the Next Data Set button  to select the next set in the list. 

To change the data in a data set:

1 Select the data set you want to modify.

2 Edit the variable data.

3 Click OK.

To delete a data set:

1 Select the data set you want to delete.

2 Click the Trash button .

Applying data sets
You can apply a data set's contents to the base document while leaving all the variables 
and data sets intact. This changes the look of the PSD document to contain the values of 
the data set.

Note: Applying a data set overwrites your original document.

To apply a data set: Do one of the following:

1 Choose Image > Variables > Data Sets. Select the data set to apply from the list of data 
sets you've created or imported and click the Apply or OK button.

2 Choose Image > Apply Data Set. Select the data set to apply from the list of data sets 
and click OK.

Previewing data-driven graphics
Preview Document mode lets you preview how a template will look when it is rendered 
using different sets of data. 

To enable or disable Preview Document mode:

Do one of the following:

• Choose Image > Preview Document. A check mark appears next to the command when 
Preview Document mode is enabled.

• Click the Preview Document button in the tool box. 

To preview data-driven graphics:

1 Enable Preview Document mode.

2 In the options bar, choose a data set from the Data Set pop-up menu, click the Previous 
Data Set button , or click the Next Data Set button .

The data changes in the document window.
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Saving templates for use with other Adobe products
You can save a template in PSD format for use with other Adobe products, such as Adobe 
Graphics Server (available only in English) and Adobe GoLive. For example, a GoLive user 
can place a PSD template in a page layout, bind its variables to a database using dynamic 
links, and then use Graphics Server to generate iterations of the artwork. Likewise, a 
developer working with Graphics Server can bind the variables in the PSD file directly to a 
database or another data source.

For more information on using PSD templates to create data-driven graphics, see the 
Adobe GoLive User Guide, GoLive online Help, and the Adobe Graphics Server Developer 
Guide.

Processing all data sets
Once you have variables and one or more data sets defined, you can output, in batch 
mode, images using the data set values. You can output images as PSD files, optimized 
images, or SWF images.

To process data sets:

1 Choose File > Export > Data Sets as Files.

2 Enter a base name for all files generated. You may create your own file-naming scheme 
if you want.

3 Click the Choose button to select a destination directory for your files.

4 Choose data sets to export.

5 In the Save As text box, choose an export format and set the format-dependent export 
parameters.

6 Click OK.

Note: When exporting to SWF format, you can see multiple images in one HTML file. This is 
useful for quick visual scans. For instance, you can check if text was truncated, or choose a 
version from multiple data sets you’ve exported all to one file.

Importing data sets from external files
You can quickly create a large number of data sets by creating an external text file that 
contains all the variable information and loading that file into a PSD document containing 
variables. One good way to accomplish this is to enter your data into a text file and then 
export it to a tab or comma-separated file.

The syntax of the external text file is as follows (where each line that starts with “Variable” 
or “Value” is an entire line by itself in your file):

VariableName1<sep>VariableName2<sep> <sep>VariableNameN <nl>

Value1-1<sep>Value2-1<sep> <sep>ValueN-1<nl>

Value1-2<sep>Value2-2<sep> <sep>ValueN-2<nl>

Value1-M<sep>Value2-M<sep> <sep>ValueN-M<nl>

All the variable names are listed on the first line, in the order that the values are given in 
subsequent lines. Each subsequent line represents one data set, with the values for each 
variable given. 
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If <sep> or <nl> is part of the variable value, then the entire value must be enclosed in 
double quotes.

All variables defined in the PSD document must be defined in the text file. An error will be 
displayed if the number of variables in the text file does not match the document.

Example data set:

Using a template for flowers that holds variables for tulip and sunflower, you can set up a 
text file that looks like this:

{contents of FlowerShow.txt}

Variable1, Variable2, Variable3

true, TULIP, c:\My Documents\tulip.jpg

false, SUNFLOWER, c:\MyDocuments\sunflower.jpg

false, CALLA LILY, c:\My Documents\calla.jpg

true, VIOLET, c:\My Documents\violet.jpg

To import a data set:

1 Do one of the following

• Choose File > Import > Variable Data Sets.

• Choose Image > Variables > Data Sets.

2 Click the Import button.

3 Enter the name of the text file to import.

4 Set up your import options. There is a check box to use the first column value as the 
data set name. This is useful if your first variable is an identifier like a name or product 
number and you want to name your data sets with that value. Otherwise, the data sets are 
named “Data Set 1, Data Set 2, etc..” There is also a check box to delete all current data sets 
before importing new data sets.

5 Set the encoding of the text file or leave as “Automatic.”

6 Click OK.

External Text File Syntax Elements

<sep> Either a comma-separated (CSV) or a tab (tab-delimited) file that 
separates each variable name or value.

<nl> A newline that ends each data set and can be a line feed, carriage 
return, or both.

“true” and “false” Allowed values for a visibility variable.

Spaces Around the delimiter are removed when parsing the file; between 
words in a value string (e.g., two of a kind) are maintained and 
leading and trailing spaces are maintained if enclosed in double 
quotes (e.g. , “one kind ”). 

Double quotes Can be part of a value if preceded by another double quote (e.g. , 
““B”” would be “B” in the data set).



Using Help | Contents | Index Back 656  

Adobe Photoshop CS Help Keyboard Shortcuts 

Using Help | Contents | Index Back 656  

Keyboard Shortcuts

Keys for selecting tools
* Not in ImageReady

§ ImageReady only

*In Photoshop, shortcuts are customizable by using the Keyboard Shortcuts command. Choose 
Edit > Keyboard Shortcuts. For more information, see “Customizing keyboard shortcuts” on page 54.

§Mac OS X users: In ImageReady, when the Use System Shortcuts preference is enabled, certain 
ImageReady keyboard shortcuts are usurped by OS X keyboard shortcuts. (For example, with 
the preference on, Command + H hides the application. With the preference off, Command + H 
shows/hides Extras.) To prevent this, press the Control key in addition to the shortcut or choose 
ImageReady > Preferences > General and deselect Use System Shortcuts.

Result Windows Mac OS 

Cycle through tools with the 
same shortcut key

Shift-press shortcut key 
(*when Use Shift Key for Tool 
Switch preference is disabled)

Shift-press shortcut key 
(*when Use Shift Key for Tool 
Switch preference is disabled)

Cycle through hidden tools Alt-click + tool (*except add 
anchor point, delete anchor 
point, and convert point tools)

Option-click + tool (*except 
add anchor point, delete 
anchor point, and convert 
point tools)

Rectangular Marquee tool†

Rounded Rectangle Marquee 
tool§

Elliptical Marquee tool

Single Row Marquee tool

Single Column Marquee tool

M

M§

M§

M

M§

M§

Move tool V V

Lasso tool

Polygonal Lasso tool

Magnetic Lasso tool*

L L

Magic Wand tool W W

Crop tool C C

Slice tool

Slice Select tool

K

K*, O§

K

K*, O§
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Healing Brush tool*

Patch tool*

Color Replacement tool*

J J

Brush tool

Pencil tool

B B

Clone Stamp tool

Pattern Stamp tool*

S*, B§

S

S*, B§

S

History Brush tool*

Art History Brush tool*

Y Y

Eraser tool†

Background Eraser tool*

Magic Eraser tool

E E

Gradient tool*

Paint Bucket tool

G G

Blur tool*

Sharpen tool*

Smudge tool*

R R

Dodge tool*

Burn tool*

Sponge tool*

O O

Path Selection tool*

Direct Selection tool*

A A

Horizontal Type tool

Vertical Type tool*

Horizontal Type mask tool*

Vertical Type mask tool*

T T

Pen tool*

Freeform Pen tool*

P P

Rectangle tool

Rounded Rectangle tool

Ellipse tool

Polygon tool*

Line tool

Custom Shape tool*

U

U*, S§

U

U*, S§

Result Windows Mac OS 
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†Use same shortcut keys for Extract*, Liquify, and Pattern Maker*

Keys for selecting tools in the Extract toolbox (Photoshop)

Keys for selecting tools in the Liquify toolbox

Notes tool*

Audio Annotation tool*

N N

Eyedropper tool†

Color Sampler tool*

Measure tool*

I I

Hand tool† H H

Zoom tool† Z Z

Rectangle Image Map tool§ 

Circle Image Map tool§ 

Polygon Image Map tool§ 

P P

Image map Select tool§ J J

Tab Rectangle tool§ 

Pill Rectangle tool§ 

R R

Result Windows Mac OS 

Edge Highlighter tool B B

Fill tool G G

Eyedropper tool I I

Cleanup tool C C

Edge Touchup tool T T

Result Windows Mac OS 

Forward Warp tool W W

Reconstruct tool R R

Twirl Clockwise tool C C

Pucker tool S S

Bloat tool B B

Push Left tool O O

Mirror tool M M

Result Windows Mac OS 
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Keys for working with Extract*, Liquify, 
and Pattern Maker*
* Not in ImageReady

Turbulence tool T T

Freeze Mask tool F F

Thaw Mask tool D D

Result (Extract*, Liquify, and 
Pattern Maker*)

Windows Mac OS 

Cycle through controls on 
right from top

Tab Tab

Cycle through controls on 
right from bottom

Shift + Tab Shift + Tab

Temporarily activate Hand 
tool

Spacebar Spacebar

Change Cancel to Reset Alt Option

Result (Extract* and Liquify) Windows Mac OS 

Decreases or increases brush 
size

[ or ] [ or ]

Result (Extract* and Pattern 
Maker*)

Windows Mac OS 

Fit in window Control + 0 Command + 0

Temporarily selects Zoom In 
tool

Control + Spacebar Command + Spacebar

Select Zoom Out tool Alt + Spacebar Option + Spacebar

Result (Extract* only) Windows Mac OS 

Toggle between Edge High-
lighter tool and Eraser tool 

Alt Option

Toggle Smart Highlighting Control with Edge Highlighter 
tool selected

Command with Edge 
Highlighter tool selected

Remove current highlight Alt + Delete Option + Delete

Highlight entire image Control + Delete Command + Delete

Fill foreground area and 
preview extraction 

Shift-click with Fill tool 
selected

Shift-click with Fill tool 
selected

Result Windows Mac OS 
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Result (Extract* only) Windows Mac OS 

Move mask when Edge 
Touchup tool is selected 

Control-drag Command-drag

Add opacity when Cleanup 
tool is selected

Alt-drag Option-drag

Toggle Show menu options in 
preview between Original and 
Extracted

X X

Enable Cleanup and Edge 
Touchup tools before preview

Shift + X Shift + X

Cycle through Display menu 
in preview from top to bottom

F F

Cycle through Display menu 
in preview from bottom to top

Shift + F Shift + F

Decrease/increase brush size 
by 1

Down Arrow/Up Arrow in 
Brush Size text box†

Down Arrow or Up Arrow in 
Brush Size text box†

Decrease/increase brush size 
by 1

Left Arrow/Right Arrow with 
Brush Size Slider showing†

Left Arrow/Right Arrow with 
Brush Size Slider showing†

Set strength of Cleanup or 
Edge Touch-up tool

0–9 0–9 

Result (Liquify only) Windows Mac OS 

Reverse direction for Bloat, 
Pucker, Push Left, and Mirror 
tools

Alt + tool Option + tool

Continually sample the 
distortion

Alt + drag in preview with 
reconstruct tool, Displace, 
Amplitwist or Affine mode 
selected

Option + drag in preview with 
reconstruct tool, Displace, 
Amplitwist or Affine mode 
selected

Decrease/increase brush size 
by 2, or density, pressure, rate, 
or turbulent jitter by 1

Down Arrow/Up Arrow in 
Brush Size, Density, Pressure, 
Rate, or Turbulent Jitter text 
box†

Down Arrow/Up Arrow in 
Brush Size, Density, Pressure, 
Rate, or Turbulent Jittertext 
box†

Decrease/increase brush size 
by 2, or density, pressure, rate, 
or turbulent jitter by 1

Left Arrow/Right Arrow with 
Brush Size, Density, Pressure, 
Rate, or Turbulent Jitter slider 
showing†

Left Arrow/Right Arrow with 
Brush Size, Density, Pressure, 
Rate, or Turbulent Jitter slider 
showing†

Redo last step Control + Z Command + Z
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†Hold down Shift to decrease/increase by 10

Keys for using the File Browser (Photoshop)

Result (Pattern Maker* only) Windows Mac OS 

Delete current selection Control + D Command + D

Undo a selection move Control + Z Command + Z

Generate or generate again Control + G Command + G

Intersect with current 
selection

Shift + Alt + select Shift + Option + select

Toggle view: original/gener-
ated pattern

X X

Go to first tile in Tile History Home Home

Go to last tile in Tile History End End

Go to previous tile in Tile 
History

Left Arrow, Page Up Left Arrow, Page Up

Go to next tile in Tile History Right Arrow, Page Down Right Arrow, Page Down

Delete current tile from Tile 
History

Delete Delete

Nudge selection when 
viewing the original

Right Arrow, Left Arrow, Up 
Arrow, or Down Arrow

Right Arrow, Left Arrow, Up 
Arrow, or Down Arrow

Increase selection nudging 
when viewing the original

Shift + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow

Shift + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow

Result Windows Mac OS 

Open file browser Control + Shift + O Command + Shift + O

Move up a folder (in folder 
view) or a row

Up Arrow Up Arrow

Move down a folder (in folder 
view) or a row

Down Arrow Down Arrow

Move up a level (in folder 
view)

Control + Up Arrow Command + Up Arrow

Move left one item Left Arrow Left Arrow

Move right one item Right Arrow Right Arrow

Move to the first item Home Home

Move to the last item End End
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Keys for using the Filter Gallery

Commit an inline renaming Enter Return

Add to selection 
(discontiguous)

Control-click Command-click

Refresh tree and thumbnail 
panes

F5 F5

Add an item to the selection Shift + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow

Shift + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow

Rotate clockwise Control + ] Command + ]

Rotate counter-clockwise Control + [ Command + [

Open a file and close the File 
Browser

Alt + Enter or Alt-double-click 
file

Option + Return or Option-
double-click file

Launch File Browser palette in 
maximized state and auto-
hide palettes

Control-click the Toggle File 
Browser icon in the options 
bar

Command-click the Toggle 
File Browser icon in the 
options bar

Open a file and suppress open 
option and color warning 
dialogs

Shift + Enter or Shift-double-
click File Browser thumbnail

Shift + Enter or Shift-double-
click File Browser thumbnail

Result Windows Mac OS 

Apply a new filter on top of 
selected

Alt-click on a filter Option-click on a filter

Open/close all disclosure 
triangles

Alt-click on a disclosure 
triangle

Option-click on a disclosure 
triangle

Change Cancel button to 
Default

Control Command

Change Cancel button to 
Reset

Alt Option

Undo/Redo Control + Z Command + Z

Step forward Control + Shift + Z Command + Shift + Z

Step backward Control + Alt + Z Command + Option + Z

Result Windows Mac OS 
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Keys for using the Camera Raw dialog box (Photoshop)

Keys for using Photomerge (Photoshop)

Keys for working with blending modes
* Not in ImageReady

Result Windows Mac OS 

Display highlights that will be 
clipped in Preview

Alt-drag Exposure or Shadows 
sliders

Option-drag Exposure or 
Shadows sliders

Skip file conversion when 
selecting multiple files (turn 
OK button to Skip)

Shift Shift

Update raw settings without 
opening file (turn OK button 
to Update)

Alt Option

Result Windows Mac OS 

Select Image tool A A

Rotate Image tool R R

Set Vanishing Point tool V V

Zoom tool Z Z

Hand tool H H

Switch to Hand tool Spacebar Spacebar 

Step backward Control + Z Command + Z

Step forward Control + Shift + Z Command + Shift + Z

Move selected image 1 pixel Right Arrow, Left Arrow, 
Up Arrow, or Down Arrow

Right Arrow, Left Arrow, 
Up Arrow, or Down Arrow

Change Cancel to Reset Alt Option

Show individual image border Alt-move pointer over image Option-move pointer over 
image

Result Windows Mac OS 

Cycle through blending 
modes

Shift + Alt + + (plus) or – 
(minus)

Shift + Option + + (plus) or – 
(minus)

Normal Shift + Alt + N Shift + Option + N

Dissolve Shift + Alt + I Shift + Option + I
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Behind Shift + Alt + Q Shift + Option + Q

Clear Shift + Alt + R Shift + Option + R

Darken Shift + Alt + K Shift + Option + K

Multiply Shift + Alt + M Shift + Option + M

Color Burn Shift + Alt + B Shift + Option + B

Linear Burn Shift + Alt + A Shift + Option + A

Lighten Shift + Alt + G Shift + Option + G

Screen Shift + Alt + S Shift + Option + S

Color Dodge Shift + Alt + D Shift + Option + D

Linear Dodge Shift + Alt + W Shift + Option + W

Overlay Shift + Alt + O Shift + Option + O

Soft Light Shift + Alt + F Shift + Option + F

Hard Light Shift + Alt + H Shift + Option + H

Vivid Light Shift + Alt + V Shift + Option + V

Linear Light Shift + Alt + J Shift + Option + J

Pin Light Shift + Alt + Z Shift + Option + Z

Hard Mix Shift + Alt + L Shift + Option + L

Difference Shift + Alt + E Shift + Option + E

Exclusion Shift + Alt + X Shift + Option + X

Hue Shift + Alt + U Shift + Option + U

Saturation Shift + Alt + T Shift + Option + T

Color Shift + Alt + C Shift + Option + C

Luminosity Shift + Alt + Y Shift + Option + Y

Desaturate* Sponge tool + Shift + Alt + D Sponge tool + Shift + 
Option + D

Saturate* Sponge tool + Shift + Alt + S Sponge tool + Shift + 
Option + S

Dodge/burn shadows* Dodge tool/Burn tool + Shift + 
Alt + S

Dodge tool/Burn tool + Shift + 
Option + S

Dodge/burn midtones* Dodge tool/Burn tool + Shift + 
Alt + M

Dodge tool/Burn tool + Shift + 
Option + M

Result Windows Mac OS 
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Keys for viewing images
* Not in ImageReady

§ ImageReady only

Dodge/burn highlights* Dodge tool/Burn tool + Shift + 
Alt + H

Dodge tool/Burn tool + Shift + 
Option + H

Set blending mode to 
Threshold for bitmap images, 
Normal for all other images*

Shift + Alt + N Shift + Option + N

Result Windows Mac OS 

Cycles through open 
documents

Control + Tab Control + Tab

Toggle between Standard 
mode and Quick mask mode*

Q Q

Toggle between Standard 
screen mode, Full screen 
mode and Full screen mode 
with menu bar

F F

Toggle image maps visibility§ A A

Toggle slices visibility§ Q Q

Preview document§ Y Y

Preview in default browser§ Control + Alt + P Command + Option + P

Edit in ImageReady*

Edit in Photoshop§

Control + Shift + M Command + Shift + M

Fit image in window Double-click Hand tool Double-click Hand tool

Magnify 100% Double-click zoom tool Double-click zoom tool

Switch to Hand tool (when not 
in text-edit mode)

Spacebar Spacebar 

Switch to Zoom In tool Control + Spacebar Command + Spacebar

Switch to Zoom Out tool Alt + Spacebar Option + Spacebar 

Move zoom marquee while 
dragging with the zoom tool*

Spacebar-drag Spacebar-drag

Apply zoom percentage, and 
keep zoom percentage box 
active*

 Shift + Enter in Navigator 
palette

Shift + Return in Navigator 
palette

Result Windows Mac OS 
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†Hold down Control (Win) or Command (Mac OS) to scroll left (Page Up) or right (Page Down)

Keys for selecting and moving objects
* Not in ImageReady

§ ImageReady only

Zoom in on specified area of 
an image*

Control-drag over preview in 
Navigator palette

Command-drag over preview 
in Navigator palette

Scroll image with Hand tool* Spacebar-drag, or drag view 
area box in Navigator palette

Spacebar-drag, or drag view 
area box in Navigator palette

Scroll up or down 1 screen Page Up or Page Down† Page Up or Page Down†

Scroll up or down 10 units Shift + Page Up or Page Down† Shift + Page Up or Page Down†

Move view to upper left 
corner or lower right corner

Home or End Home or End

Toggle layer mask on/off as 
rubylith*

\ (backslash) \ (backslash)

Result Windows Mac OS 

Reposition marquee while 
selecting‡

Any marquee tool (except 
single column and single row) 
+ spacebar-drag

Any marquee tool (except 
single column and single row) 
+ spacebar-drag

Add to, subtract from, or inter-
sect a selection

Any selection tool + Shift or 
Alt-drag 

Any selection tool + Shift or 
Option-drag

Constrain marquee to square 
or circle (if no other selections 
are active)‡

Shift-drag Shift-drag

Draw marquee from center (if 
no other selections are active)‡

Alt-drag Option-drag

Constrain shape and draw 
marquee from center‡

Shift + Alt-drag Shift + Option-drag

Switch to Move tool Command (except when 
Hand, Slice, Path*, Shape*, 
Rectangle Image map§, Circle 
Image Map§, Polygon Image 
Map§, or any Pen* tool is 
selected)

Command (except when 
Hand, Slice, Path*, Shape*, 
Rectangle Image map§, Circle 
Image Map§, Polygon Image 
Map§, or any Pen* tool is 
selected)

Switch from Magnetic Lasso 
tool to Lasso tool*

Alt-drag Option-drag

Switch from Magnetic Lasso 
tool to polygonal Lasso tool*

Alt-click Option-click

Result Windows Mac OS 
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†Hold down Shift to move 10 pixels

‡Applies to shape tools

Keys for editing paths (Photoshop)

Apply/cancel an operation of 
the Magnetic Lasso*

Enter/Esc Return/Esc or Command + 
period

Move copy of selection Move tool + Alt-drag 
selection‡

Move tool + Option-drag 
selection‡

Move selection area 1 pixel Any selection + Right Arrow, 
Left Arrow, Up Arrow, or Down 
Arrow†

Any selection + Right Arrow, 
Left Arrow, Up Arrow, or Down 
Arrow†

Move selection 1 pixel Move tool + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow†‡

Move tool + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow†‡

Move layer 1 pixel when 
nothing selected on layer

Control + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow†

Command + Right Arrow, Left 
Arrow, Up Arrow, or Down 
Arrow†

Increase/decrease detection 
width*

Magnetic Lasso tool + [ or ] Magnetic Lasso tool + [ or ] 

Accept cropping or exit 
cropping

Crop tool + Enter or Esc Crop tool + Return or Esc

Toggle crop shield off and on* / (forward slash) / (forward slash)

Make protractor* Measure tool + Alt-drag end 
point 

Measure tool + Option-drag 
end point 

Snap guide to ruler ticks 
(*except when View > Snap is 
unchecked)

Shift-drag guide Shift-drag guide

Convert between horizontal 
and vertical guide 

Alt-drag guide Option-drag guide

Result Windows Mac OS 

Select multiple anchor points Direction selection tool + 
Shift-click

Direction selection tool + 
Shift-click

Select entire path Direction selection tool + 
Alt-click

Direction selection tool + 
Option-click

Duplicate a path Pen (any pen tool), Path Selec-
tion or Direct Selection tool + 
Control + Alt-drag

Pen tool + Command + 
Option-drag

Result Windows Mac OS 
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Keys for painting objects
* Not in ImageReady

§ ImageReady only

Switch from Path Selection, 
Pen, Add Anchor Point, Delete 
Anchor Point, or Convert Point 
tools, to Direct Selection tool 

Control Command

Switch from Pen tool or Free-
form Pen tool to Convert Point 
tool when pointer is over 
anchor or direction point

Alt Option

Close path Magnetic Pen tool-double-
click

Magnetic Pen tool-double-
click

Close path with straight-line 
segment

Magnetic Pen tool + 
Alt-double-click

Magnetic Pen tool + Option-
double-click

Result Windows Mac OS 

Eyedropper tool Any painting tool + Alt or any 
shape tool + Alt (*except 
when Paths option is selected)

Any painting tool + Option or 
any shape tool + Option 
(*except when Paths option is 
selected)

Select background color Eyedropper tool + Alt-click Eyedropper tool + 
Option-click

Color sampler tool* Eyedropper tool + Shift Eyedropper tool + Shift 

Deletes color sampler* Color sampler tool + Alt-click Color sampler tool + 
Option-click 

Sets opacity, tolerance, 
strength, or exposure for 
painting mode

Any painting or editing tool + 
number keys (e.g., 0 = 100%, 
1 = 10%, 4 then 5 in quick 
succession = 45%) (*When 
airbrush option is enabled, 
use Shift + number keys)

Any painting or editing tool + 
number keys (e.g., 0 = 100%, 
1 = 10%, 4 then 5 in quick 
succession = 45%) (*When 
airbrush option is enabled, 
use Shift + number keys)

Sets flow for painting mode* Any painting or editing tool + 
Shift + number keys (e.g., 
0 = 100%, 1 = 10%, 4 then 5 in 
quick succession = 45%) 
(*When airbrush option is 
enabled, omit Shift)

Any painting or editing tool + 
Shift + number keys (e.g., 
0 = 100%, 1 = 10%, 4 then 5 in 
quick succession = 45%) 
(*When airbrush option is 
enabled, omit Shift)

Cycles through blending 
modes

Shift + + (plus) or – (minus) Shift + + (plus) or – (minus)

Result Windows Mac OS 
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†Hold down Shift to preserve transparency

Keys for transforming selections, selection borders, 
and paths

Keys for selecting, editing, and navigating through text
* Not in ImageReady

Fills selection/layer with fore-
ground or background color

Alt + Backspace, or Control + 
Backspace†

Option + Delete, or Command 
+ Delete†

Fills from history* Control + Alt + Backspace† Command + Option + Delete†

Displays Fill dialog box Shift + Backspace Shift + Delete

Lock transparent pixels on/off / (forward slash) / (forward slash)

Connects points with a 
straight line

Any painting tool + Shift-click Any painting tool + Shift-click

Result Windows Mac OS 

Transform from center or 
reflect

Alt Option

Constrain Shift Shift

Distort Control Command

Apply Enter Return

Cancel Control + . (period) or Esc Command + . (period) or Esc

Free transform with 
duplicate data

Control + Alt + T Command + Option + T

Transform again with 
duplicate data

Control + Shift + Alt + T Command + Shift + Option + T

Result Windows Mac OS 

Move type in image Control-drag type when Type 
layer is selected

Command-drag type when 
Type layer is selected

Select 1 character left/right or 
1 line down/up, or 1 word left/
right

Shift + Left Arrow/Right Arrow 
or Down Arrow/Up Arrow, or 
Control + Shift + Left Arrow/
Right Arrow

Shift + Left Arrow/Right Arrow 
or Down Arrow/Up Arrow, or 
Command + Shift + Left 
Arrow/Right Arrow

Select characters from
insertion point to mouse 
click point

Shift-click Shift-click

Result Windows Mac OS 
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Keys for formatting type
* Not in ImageReady

Move 1 character left/right, 
1 line down/up, or 1 word 
left/right

Left Arrow/Right Arrow, Down 
Arrow/Up Arrow, or Control + 
Left Arrow/Right Arrow

Left Arrow/Right Arrow, 
Down Arrow/Up Arrow, or 
Command + Left Arrow/Right 
Arrow

Create a new text layer, when 
editing text

Shift-click Shift-click

Select word, line, paragraph, 
or story

Double-click, triple-click, 
quadruple-click, or 
quintuple-click

Double-click, triple-click, 
quadruple-click, or 
quintuple-click

Show/Hide selection on 
selected type

Control + H Command + H

Display the bounding box 
for transforming text when 
editing text, or activate Move 
tool if cursor is inside the 
bounding box*

Control Command

Scale text within a bounding 
box when resizing the 
bounding box*

Control-drag a bounding box 
handle 

Command-drag a bounding 
box handle 

Move text box while creating 
text box

Spacebar-drag Spacebar-drag

Result Windows Mac OS 

Align left, center, or right* Horizontal type tool + Control 
+ Shift + L, C, or R

 Horizontal type tool + 
Command + Shift + L, C, or R

Align top, center, or bottom* Vertical type tool + Control + 
Shift + L, C, or R

Vertical type tool + Command 
+ Shift + L, C, or R

Return to default font style Control + Shift + Y Command + Shift + Y

Choose 100% horizontal 
scale*

Control + Shift + X Command + Shift + X

Choose 100% vertical scale* Control + Shift + Alt + X Command + Shift + 
Option + X

Choose Auto leading* Control + Shift + Alt + A Command + Shift + 
Option + A

Choose 0 for tracking* Control + Shift + Q Command + Control + 
Shift + Q

Result Windows Mac OS 
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†Hold down Alt (Win) or Option (Mac OS) to decrease/increase by 10

††Hold down Control (Win) or Command (Mac OS) to decrease/increase by 10

Keys for slicing and optimizing
§ ImageReady only

Justify paragraph, left aligns 
last line*

Control + Shift + J Command + Shift + J

Justify paragraph, forces last 
line*

Control + Shift + F Command + Shift + F

Toggle paragraph hyphen-
ation on/off*

Control + Shift + Alt + H Command + Control + Shift + 
Option + H

Toggle single/every-line 
composer on/off*

Control + Shift + Alt + T Command + Shift + Option + T

Decrease or increase type size 
of selected text 2 pts/px

Control + Shift + < or >† Command + Shift + < or >†

Decrease or increase leading 
2 pts/px

Alt + Down Arrow or Up 
Arrow††

Option + Down Arrow or Up 
Arrow††

Decrease or increase baseline 
shift 2 pts/px

Shift + Alt + Down Arrow or 
Up Arrow††

Shift + Option + Down Arrow 
or Up Arrow††

Decrease or increase kerning/
tracking 20/1000 ems

Alt + Left Arrow or Right 
Arrow††

Option + Left Arrow or Right 
Arrow††

Result Windows Mac OS 

Toggle browser dither for 
selected image pane in 
Optimized view§

Control + Shift + Y Command + Shift + Y

Toggle through gamma 
previews in selected image 
pane§

Control + Alt + Y Command + Option + Y

Toggle through Optimized/
2up/4up/Original window§

Control + Y Command + Y

Toggle between Slice tool and 
Slice Selection tool

Control Command

Draw square slice Shift-drag Shift-drag

Draw from center outward Alt-drag Option-drag

Result Windows Mac OS 
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Keys for using palettes
* Not in ImageReady

Draw square slice from center 
outward

Shift + Alt-drag Shift + Option-drag

Reposition slice while creating 
slice

Spacebar-drag Spacebar-drag

Open context-sensitive menu Right-click on slice Control-click on slice

Result Windows Mac OS 

Set options (except for 
Actions, Styles, Brushes*, Tool 
Presets*, and Layer Comps 
palettes)

Alt-click New button Option-click New button

Delete without confirmation 
(except for the Brushes* pal-
ette)

Alt-click Trash button Option-click Trash button

Apply value and keep text box 
active*

Shift + Enter Shift + Return

Load as a selection Control-click channel, layer, 
or path thumbnail. Control + 
Alt-click layer in ImageReady

Command-click channel, 
layer, or path thumbnail. 
Command + Option-click 
layer in ImageReady

Add to current selection Control + Shift-click channel, 
layer, or path thumbnail. 
Control + Shift + Alt-click layer 
in ImageReady

Command + Shift-click 
channel, layer, or path 
thumbnail. Command + 
Shift + Option-click layer 
in ImageReady

Subtract from current 
selection*

Control + Alt-click channel, 
layer, or path thumbnail

Command + Option-click 
channel, layer, or path 
thumbnail

Intersect with current 
selection*

Control + Shift + Alt-click 
channel, layer, or path 
thumbnail

Command + Shift + Option-
click channel, layer, or path 
thumbnail

Show/Hide all palettes Tab Tab

Show/Hide all palettes except 
the toolbox and options bar

Shift + Tab Shift + Tab

Result Windows Mac OS 
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Keys for using the Actions palette
* Not in ImageReady

Highlight options bar Select tool and press Enter Select tool and press Return

Increase/decrease units by 10 
in a pop-up menu

Shift + Up Arrow/Down Arrow Shift + Up Arrow/Down Arrow

Result Windows Mac OS 

Turn command on and all 
others off, or turns all 
commands on*

Alt-click the check mark next 
to a command

Option-click the check mark 
next to a command

Turn current modal control on 
and toggle all other modal 
controls*

Alt-click Option-click

Change action set options Alt + double-click action set Option + double-click 
action set

Display Options dialog box Double-click set or actions. 
Alt + double-click set or action 
in ImageReady

Double-click set or actions. 
Alt + double-click set or action 
in ImageReady

Play entire action Control + double-click an 
action

Command + double-click an 
action

Collapse/expand all 
components of an action

Alt-click the triangle Option-click the triangle

Play a command Control-click the Play button Command-click the Play 
button

Create new action and 
begin recording without 
confirmation

Alt-click the New Action 
button

Option-click the New Action 
button

Select contiguous items of the 
same kind*

Shift-click the action/
command

Shift-click the action/
command

Select non-contiguous items 
of the same kind*

Control-click the action/
command

Command-click the action/
command

Result Windows Mac OS 
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Keys for using the Animation palette (ImageReady)

Keys for using the Brushes palette
* Not in ImageReady

§ ImageReady only

Result Windows Mac OS 

Select/deselect multiple 
contiguous frames

Shift-click on second frame Shift-click on second frame

Select/deselect multiple 
discontiguous frames

Control-click on multiple 
frames

Command-click multiple 
frames

Replace destination frame 
with copied frames

Shift + Alt + Paste Frames 
command from the palette 
pop-up menu

Shift + Option + Paste Frames 
command from the palette 
pop-up menu

Paste using previous settings 
without displaying the dialog

Alt + Paste Frames command 
from the palette pop-up 
menu

Option + Paste Frames 
command from the palette 
pop-up menu

Result Windows Mac OS 

Delete brush* Alt-click brush Option-click brush

Rename brush* Double-click brush Double-click brush

Decrease/increase brush size* [ or ] [ or ] 

Decrease/increase brush 
softness/hardness in 25% 
increments*

Shift + [ or ] Shift + [ or ] 

Select previous/next brush 
size*

, (comma) or . (period) , (comma) or . (period)

Select previous/next brush 
size§

[ or ] [ or ] 

Select first/last brush* Shift + , (comma) or . (period) Shift + , (comma) or . (period)

Select first/last brush§ Shift + [ or ] Shift + [ or ]

Display precise cross hair for 
brushes

Caps Lock Caps Lock

Toggle airbrush option* Shift + Alt + P Shift + Option + P
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Keys for using the Channels palette (Photoshop)

Keys for using the Color palette

Keys for using the Color Table palette (ImageReady)

Result Windows Mac OS 

Set options for Save Selection 
as Channel button

Alt-click button Option-click button

Create a new spot channel Control-click Create New 
Channel button

Command-click Create New 
Channel button

Select/deselect multiple 
color-channel selection

Shift-click color channel Shift-click color channel

Select/deselect alpha channel 
and show/hide as a rubylith 
overlay

Shift-click alpha channel Shift-click alpha channel

Display channel options Double-click alpha or spot 
channel thumbnail

Double-click alpha or spot 
channel thumbnail 

Display composite ~ (tilde) ~ (tilde)

Result Windows Mac OS 

Select background color Alt-click color in color bar Option-click color in color bar 

Display Color Bar menu Right-click color bar Control-click color bar

Cycle through color choices Shift-click color bar Shift-click color bar

Result Windows Mac OS 

Select background color Alt-click swatch Option-click swatch

Select multiple contiguous 
colors; last color clicked 
becomes foreground color

Shift-click a second swatch Shift-click a second swatch

Select discontiguous colors; 
last color clicked becomes 
foreground color

Control-click multiple 
swatches

Command-click multiple 
swatches

Add current background color Alt-click New Color button or 
drag color proxy from Tools 
palette onto color table

Option-click New Color 
button or drag color proxy 
from Tools palette onto 
color table

Add current foreground color Click New Color button or 
drag color proxy from Tools 
palette to New Color button

Click New Color button or 
drag color proxy from Tools 
palette to New Color button
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Keys for using the History palette
* Not in ImageReady

Keys for using the Info palette
* Not in ImageReady

Keys for using the Layer Comps palette

Result Windows Mac OS 

Rename snapshot* Double-click snapshot name Double-click snapshot name

Step forward through image 
states

Control + Shift + Z Command + Shift + Z

Step backward through 
image states*

Alt + Shift + Z Option + Shift + Z

Duplicate any image state, 
except the current state*

Alt-click the image state Option-click the image state

Permanently clear history 
(no Undo)*

Alt + Clear History (in History 
palette pop-up menu)

Option + Clear History (in 
History palette pop-up menu)

Result Windows Mac OS 

Change color readout modes* Click eyedropper icon Click eyedropper icon

Change measurement units* Click cross-hair icon Click cross-hair icon

Result Windows Mac OS 

Create new layer comp with-
out dialog

Alt-click Create New Layer 
Comp button

Option-click Create New Layer 
Comp button

Opens Layer Comp Options 
dialog

Double-click layer comp Double-click layer comp

Rename inline Double-click layer comp name Double-click layer comp name

Select/deselect multiple 
contiguous layer comps

Shift-click Shift-click

Select/deselect multiple 
discontiguous layer comps

Control-click Command-click
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Keys for using the Layers palette
* Not in ImageReady

§ ImageReady only

Result Windows Mac OS 

Load layer transparency as a 
selection

Control-click layer thumbnail Command-click layer thumb-
nail

Merge visible layers Control + Shift + E Command + Shift + E

Create new empty layer with 
dialog

Alt-click New Layer button Option-click New Layer 
button

Create new layer below target 
layer

Control-click New Layer 
button

Command-click New Layer 
button

Activate bottom/top layer Shift + Alt + [ or ] Shift + Option + [ or ]

Select next layer down/up Alt + [ or ] Option + [ or ]

Move target layer down/up Control + [ or ] Command + [ or ]

Merge a copy of all visible 
layers into target layer

Control + Shift + Alt + E Command + Shift + Option + E

Merge down Control + E Command + E

Bring target layer to back/
front (or back/front) of set

Control + Shift + [ or ] Command + Shift + [ or ]

Pass through blending mode 
for layer set

Shift + Alt + P Shift + Option + P

Copy current layer to layer 
below

Alt + Merge Down command 
from the palette pop-up 
menu

Option + Merge Down 
command from the palette 
pop-up menu

Copy all visible layers to active 
layer

Alt + Merge Visible command 
from the palette pop-up 
menu

Option + Merge Visible 
command from the palette 
pop-up menu

Copy visible linked layers to 
active layer

Alt + Merge Linked command 
from the palette pop-up 
menu

Option + Merge Linked 
command from the palette 
pop-up menu

Show/hide this layer/layer set 
only or all layers/layer sets

Right-click the eye icon Control-click the eye icon

Show/hide all other currently 
visible layers

Alt-click the eye icon Option-click the eye icon

Toggle lock transparency for 
target layer, or last applied 
lock

/ (forward slash) / (forward slash)

Edit layer effect/style, options Double-click layer effect/style Double-click layer effect/style
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Hide layer effect/style Alt-double-click layer effect/
style

Option-double-click layer 
effect/style

Reveal/hide all layers and 
effects

Alt-click layer set expansion 
triangle

Option-click layer set 
expansion triangle

Edit layer style Double-click layer thumbnail Double-click layer thumbnail

Disable/enable vector mask Alt-click vector mask 
thumbnail

Option-click vector mask 
thumbnail

Toggle vector mask on/off Shift-click vector mask 
thumbnail

Shift-click vector mask 
thumbnail

Open Layer Mask Display 
Options dialog

Double-click layer mask 
thumbnail

Double-click layer mask 
thumbnail

Toggle layer mask on/off Shift-click layer mask 
thumbnail

Shift-click layer mask 
thumbnail

Toggle between layer mask/
composite image

Alt-click layer mask thumbnail Option-click layer mask 
thumbnail

Toggle rubylith mode for layer 
mask on/off*

\ (backslash), or Shift + 
Alt-click

\ (backslash), or Shift + 
Option-click

Select all type; temporarily 
select type tool

Double-click type layer 
thumbnail

Double-click type layer 
thumbnail

Create a clipping mask Alt-click the line dividing two 
layers

Option-click the line dividing 
two layers

Rename layer Double-click the layer name Double-click the layer name

Create new layer set below 
current layer/layer set

Control-click New Layer Set 
button

Command-click New Layer Set 
button

Create new layer set with 
dialog

Alt-click New Layer Set button Option-click New Layer Set 
button

Create layer mask that hides 
all/selection

Alt-click Add Layer Mask 
button

Option-click Add Layer Mask 
button

Create vector mask that 
reveals all/selection

Control-click Add Layer Mask 
button

Command-click Add Layer 
Mask button

Create vector mask that hides 
all/selection

Control + Alt-click Add Layer 
Mask button

Command + Option-click Add 
Layer Mask button

Display layer set properties Right-click on layer set Control-click the layer set

Display layer options§ Alt + double-click layer 
thumbnail

Option + double-click layer 
thumbnail

Result Windows Mac OS 
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Keys for using the Paths palette (Photoshop)

Keys for using the Swatches palette
* Not in ImageReady

§ ImageReady only

Select/deselect multiple 
contiguous layers§

Shift-click Shift-click

Select/deselect multiple 
discontiguous layers§

Control-click Command-click

Result Windows Mac OS 

Add path to selection Control + Shift-click path 
name

Command + Shift-click path 
name

Subtract the path from 
selection

Control + Alt-click path name Command + Option-click path 
name

Retain intersection of path as 
a selection

Control + Shift + Alt-click path 
name

Command + Shift + 
Option-click path name

Hide path Control + Shift + H Command + Shift + H

Set options for Fill Path with 
Foreground Color button, 
Stroke Path with Brush 
button, Load Path as a 
Selection button, Make Work 
Path from Selection button, 
and Create New Path button

Alt-click button Option-click button

Result Windows Mac OS 

Create new swatch from 
foreground color*

Click in empty area of palette Click in empty area of palette

Select background color Control-click swatch Command-click swatch

Delete color Alt-click swatch Option-click swatch

Select multiple contiguous 
colors§

Shift-click on a second color Shift-click on a second color

Select multiple discontiguous 
colors§

Control-click on multiple 
colors

Command-click on multiple 
colors

Result Windows Mac OS 
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Keys for using the Web Content palette (ImageReady)

Function keys
* Not in ImageReady

§ ImageReady only

Result Windows Mac OS 

Edit image map name and 
show Image Map palette

Double-click image map 
thumbnail

Double-click image map 
thumbnail

Edit mouse action for rollover 
state

Double-click rollover state 
thumbnail

Double-click rollover state 
thumbnail

Edit image slice name and 
show Slice palette

Double-click image slice 
thumbnail

Double-click image slice 
thumbnail

Toggle visibility of animation 
frames

Right-click state with an 
animated frame icon and 
select new state from 
context menu

Control-click state with an 
animated frame icon and 
select new state from 
context menu

Create an image map rollover Control-click Create Layer-
based Rollover button

Command-click Create Layer-
based Rollover button

Result Windows Mac OS 

Invoke Help F1

Undo/Redo* F1

Cut* F2 F2

Copy* F3 F3

Paste* F4 F4

Show/Hide Brushes palette*

Show/Hide Slice palette§

F5 F5

Show/Hide Color palette F6 F6

Show/Hide Layers palette F7 F7

Show/Hide Info palette F8 F8

Show/Hide Actions palette* F9 Option + F9*, Control + F9§

Show/Hide Optimize palette§ F10 Control + F10

Show/Hide Animation 
palette§

F11 Control + F11

Revert F12 F12
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Fill* Shift + F5 Shift + F5

Feather Selection* Shift + F6 Shift + F6

Inverse Selection* Shift + F7 Shift + F7

Result Windows Mac OS 
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Tutorials

Image correction made easy with the Levels command
Does your photo look dull, lacking contrast? Or, does it have a color cast? Is it reddish or 
greenish? Adobe Photoshop’s Levels command lets you correct the tonal range and color 
balance of an image by adjusting intensity levels of the image’s shadows, midtones, and 
highlights. In this tutorial, you’ll learn how to adjust the tonality and color in your images 
using the Levels command.

1. Open an Image in Photoshop.

Choose File > Open or double-click a thumbnail in the File Browser. Before you start 
making adjustments, evaluate the image tonality. Is it too light or dark? Does it have too 
much or too little contrast? Is there a color cast?
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2. Create a new Levels adjustment layer.

Choose Layer > New Adjustment Layer > Levels, and then click OK in the New Layer dialog 
box. You can also open the Levels command by choosing Image > Adjustments > Levels. 
However, with an adjustment layer, you are applying the tonal correction on a separate 
layer. The original image is untouched. If you decide you don’t like your changes, you can 
change them at any time or simply discard the adjustment layer and return to your 
original image.

A useful tool for evaluating an image’s tonality is the histogram displayed in the Levels 
dialog box. A histogram illustrates how pixels in an image are distributed by graphing the 
number of pixels at each color intensity level. This can show you whether the image 
contains enough detail in the shadows (shown in the left part of the histogram), midtones 
(shown in the middle), and highlights (shown in the right part) to create good overall 
contrast in the image.

3. Set the shadows and highlights.

Move the Black Point Input slider and the White Point Input slider (located directly 
beneath the histogram) inward from the edges of the histogram. Moving the Black Point 
Input slider maps all image values at its position or below to the Output Levels black point 
(set by default to 0, or pure black). Moving the White Point Input slider maps image values 
at its position or above to the Output Levels white point (set by default to 255, or pure 
white).
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For example, if your image is too dark, try moving the Input White Point slider to the left. 
This maps more values in the image to 255 (the Output Levels white point), making them 
lighter. 

4. Adjust the midtones.

Move the middle Input slider to the left to lighten the image or to the right to darken the 
image.

The middle Input slider adjusts the gamma in the image. It moves the midtone (level 128) 
and changes the intensity values of the middle range of gray tones without dramatically 
altering the highlights and shadows.
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5. Remove the color cast.

Select the Set Gray Point Eyedropper tool in the Levels dialog box. Click an area in the 
image that contains only a gray tone, or an area containing as few colors as possible. 
It’s easier to color balance an image by first identifying an area that should be neutral and 
then removing the color cast from that area. With such a correction, all other colors in the 
image should be color balanced, too. The eyedropper tools work best on an image with 
easily identified neutrals.

Advanced users often use the Levels command to adjust individual channels and remove 
a color cast. Choose a channel from the Channel menu of the Levels dialog box and then 
adjust the Input sliders.

6. Apply the Levels adjustment.

Click OK. 
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Remove red-eye in images
There’s nothing more frustrating than having a great picture ruined when a person’s eyes 
come out bright red. Adobe Photoshop gives you a simple way to fix red-eye using the 
Color Replacement tool. In this tutorial, you’ll learn how to use the tool to fix red-eye in just 
a few steps.

1. Open your image.

Open the image that you want to repair. Try zooming in so you can easily see the red eyes 
that need to be fixed. Then, select the Color Replacement tool (located in the toolbox with 
the Healing Brush and Patch tool).

2. Choose a brush tip.

Choose a brush tip from the options bar. The brush tip should be smaller than the red area 
of the eye to make correcting the red-eye easier.
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3. Set options for the Color Replacement tool.

In the options bar, you can choose settings that help you fix red-eye. For Mode, make 
sure that Color is selected. For the Sampling option, choose Once to erase only areas 
containing the color that you target. For the Limits option, select Discontiguous to replace 
the sampled color wherever it occurs under the brush. Drag the Tolerance slider to a low 
value (around 30 percent) to replace only the few colors very similar to the pixels you click.

4. Choose a color to replace the red.

Typically, black is a good choice, but you could try other colors to more closely resemble 
a person’s eye color. To choose a color, click the foreground color swatch in the toolbox. 
In the color picker, choose a color that looks good, and then click OK.

5. Repair your photo.

Click once on the color you want to replace in the image. Drag over the red with black to 
repair the image. If all the red isn’t removed, try increasing the Tolerance level in the 
options bar to correct more shades of red.

Once you’re happy with the correction, save your image. Red-eye will never present a 
problem again!
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Create an image using layers
When you build an image from different pieces—background color, text, shapes, and 
photographs—Adobe Photoshop layers give you complete creative control. In this tutorial 
you’ll create a multilayered image, apply a layer mask, and then add a text layer.

1. Open an Image in Photoshop.

Choose File > Open or double-click a thumbnail in the File Browser.

By default, the Layers palette should show. If not, choose Window > Layers. The Layers 
palette displays all the layers in your document with the layer name and a thumbnail of 
the layer’s image. 
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2. Convert the background layer.

In the Layers palette, double-click the background layer. Click OK in the New Layer dialog. 
Converting the background into a regular layer lets you use transparency in this layer. 
You can now view or hide the layer using the eye icon. Click the eye icon on a layer. Notice 
that the icon disappears and the layer is hidden. Click the empty icon box again. Both the 
eye icon and the layer’s content reappear.

3. Apply a layer mask.

A layer mask lets you select and display just the part of the image you want to use, without 
altering the image. Here we’ll mask out all of the image except a circular area of the flower. 
Click and hold the Rectangular Marquee tool, and then select the Elliptical Marquee tool 
from the pop-up menu. Hold down the Shift key to constrain the selection to a circle, and 
then drag an area on the image. In the Layers palette, click the Add Layer Mask icon.

Now only the area you selected is visible. You can change the visible area by moving the 
mask around the image. First click the link icon to unlink the mask from the layer. Select 
the Move tool, and then click inside the mask and drag to reposition it. Once you have 
your final position, click the link icon to relink the mask and the layer. Now you can move 
the layer and the mask will move with it.
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4. Add a stroke effect.

Click the Add a Layer Style button at the bottom of the Layers palette, and select Stroke 
from the menu. Choose stroke settings in the Layer Style dialog box, including color, size, 
and position of the stroke. 

5. Create a new layer.

Click the Create a New Layer button to add a new layer to the image. The new layer is 
added on top of existing layers and becomes the selected layer. Click the Foreground color 
swatch and select a color with the Color Picker. Select the Paint Bucket tool (located in the 
toolbox with the Gradient tool) and click anywhere in the image to create the fill. 

6. Reorder the layers.

Click the new layer and drag it beneath the lower layer. Changing the stacking order of 
your layers makes certain parts of the image appear in front of or behind other layers. 
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7. Add a text layer.

In the Layers palette, click the top layer. Select the Text tool, and then click on the image. 
The text cursor appears. In the options bar, change text size, font, style, or color to your 
liking.When you add text, Photoshop automatically places it on its own layer, where you 
can edit it separately from the rest of the image. 

To edit the text, select it with the Text tool, and then change any of the settings in the 
options bar. To move the text, select the Move tool and then drag the text.

8. Add an effect to the text.

Click the Add a Layer Style button and select Drop Shadow from the menu. You can 
change the color or angle of the shadow or make other adjustments in the Layer Style 
dialog box. 

In the Layers palette, the layer effect shows under the layer name. You can turn display of 
the layer effect on or off by clicking the eye icon next to the effect.
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Using Photoshop selection tools
Having trouble deciding how to select part of your image? Adobe Photoshop gives you 
several tools that help you target just the areas you need to select. In this tutorial, you’ll 
learn about the best way to use each of the selection tools.You can practice with the eagle 
image, located in the Photoshop CS/Samples folder.

1. Use the Magic Wand tool to select the background of the image.

Since the eagle in our image has a well-defined shape, and since the colors in the eagle are 
different than the green background, we can select it using the Magic Wand tool. Select 
the Magic Wand tool, and then click anywhere in the green background. The green area is 
surrounded by a marquee and is now editable. Try dragging a paintbrush over the whole 
image to see how the eagle is protected.
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2. Invert your selection.

Because our background was so easy to select, we’ll invert the selection so that just 
the eagle is selected. Choose Select > Inverse. You’ll see the selection border change 
so that the eagle is surrounded. This is an easy method to make a selection when you 
have an image like the eagle. You could now work with the eagle without disturbing 
the background of the image. For now, choose Select > Deselect so we can try out 
another tool.

3. Use the Elliptical Marquee tool to select the eagle’s eye.

Select the Elliptical Marquee tool, and then drag to draw a selection border around the 
eagle’s eye. To reposition the selection border while you’re drawing it, hold the spacebar 
and drag the selection border into a new position. To move the selection border after it’s 
created, click anywhere inside the border and drag.

4. Use the Magnetic Lasso to select the eagle’s beak.

Select the Magnetic Lasso tool (located in the toolbox with the Lasso tool), and then click 
and drag around the beak. The Magnetic Lasso tool makes free-form selections easier 
because it traces around an object. It works best when you have a clearly defined edge, 
like the eagle’s beak. The tool places anchors while you drag (you can remove anchors 
while you’re dragging by pressing the Delete key). To finish the selection border, click the 
starting anchor point (or double-click). Try moving the beak using the Move tool. Choose 
Edit > Undo to return the beak to its correct position. Then choose Select > Deselect to 
deselect the beak.
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5. Add to a selection.

Select the Marquee tool, and make a rough selection of the eagle’s body. Once you’ve 
made a selection, you can add to the selection border without having to start over. Select 
the Magnetic Lasso tool, and click the Add to Selection icon in the options bar. Refine your 
selection by dragging around the outside of the eagle (you’ll notice a small plus sign 
below the tool pointer). Release the mouse. The selection border now includes the area 
you selected with the Magnetic Lasso tool.

Produce great prints using Print with Preview
What’s a great way to produce color prints from your inkjet printer? Use the Print with 
Preview command in Adobe Photoshop. The Print with Preview command lets you 
preview how your photo will print so the results are more predictable. You’ll learn how to 
add a simple border around your photo and then transform it into a frame by adding a 
texture and layer style.

1. Open the photo you want to print.

Choose File > Open or double-click a thumbnail in the File Browser. 

You should do any retouching or tonal correction to your photo before printing it.
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2. Choose the Print with Preview command.

Choose File > Print with Preview.

The Print with Preview command lets you see a preview of how an image will print on a 
page and control how it will print. The preview updates as you specify the position and 
scale of the image.

3. Position the image.

Deselect the Center Image option so that you can enter Top and Left values to reposition 
the image. You can also drag the preview image to the desired position. If the page is 
not correctly oriented for the image, you can click the Page Setup button and select an 
orientation in the Page Setup dialog box.

Don’t specify a scaling percentage in the Page Setup dialog box. Instead, use the scale 
controls in the Print dialog box. Specifying the scaling in both the Page Setup dialog box 
and the Print dialog box will apply scaling twice, and your image will not print at the size 
you expect.
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4. Scale the image.

You can scale the image in several ways. Select the Scale to Fit Media option and 
Photoshop automatically fits the image to the page. You can also manually enter values for 
the Scale, Height and Width. Or, you can grab one of the handles in the preview image and 
scale the photo.

5. Set the color management options and click the Print button.

Select Show More Options. Choose Color Management from the menu in the More 
Options area. Select Document for the Source Space. If you want Photoshop to handle 
color management during printing, choose your printer’s profile from the Profile menu in 
the Print Space area. If you prefer to let your printer’s driver handle the color management, 
then choose Printer Color Management from the Profile menu. Click the Print button. The 
Print dialog box closes, and a second Print dialog box opens.

Color management is essential for producing consistent color when printing. Whether you 
let Photoshop or your printer driver control color management, you’ll get the best results 
using a custom profile for your printer and the specific type of paper you’re printing on. 
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6. Specify the printer settings.

In the second Print dialog box, choose your printing options. On Windows, click the 
Properties button, then the Advanced button, to access the printer driver options. 
On Mac OS, use the pop-up menu to access the printer driver options. If you chose Printer 
Color Management in the previous step, specify the color management settings. If you’re 
letting Photoshop control the color management, then make sure any color management 
options are turned off.

Do not apply color management twice to your image. Unpredictable print color will result 
if color management is done with both Photoshop and the printer driver simultaneously.

7. Print the image.

Once all the settings have been made in the printer options dialog box, click the Print 
button.

Using Photoshop shapes
Adobe Photoshop makes it easy to add shapes to an image: you can draw them using a 
variety of shape tools, or select from a large assortment of predrawn shapes. You can 
arrange vector shapes on separate layers for easy modification and overlay effects. In this 
tutorial, you’ll add both background and foreground shapes to an image and create some 
flair with gradient and layer effects.
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1. Open an Image in Photoshop.

Choose File > Open or double-click a thumbnail in the File browser. For this tutorial, you 
might want to start with an image that has at least two layers. First we’ll add shapes to 
build a more interesting background for the image.

2. Select the rectangle tool.

Select the Rectangle tool from the toolbox. By default, the Shape Layers button in the 
options bar is selected. Use this option to create a vector shape, which is automatically 
placed on a new layer. (Adjacent icons in the palette let you create a path or a rasterized 
shape on the current layer.)
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3. Create a rectangle shape.

In the Layers palette, select the bottom layer in your image. Click and drag to create a 
rectangle covering the right half of the image.The rectangle uses the foreground color by 
default. To change the color, double-click the layer thumbnail to bring up the color picker 
and select a new color.

4. Add gradients to a shape.

Now we’ll add two more rectangle shapes, this time with gradient effects. Using the 
Rectangle Shape tool, drag a new rectangle to cover the top left quarter of the image. 
Click the foreground color swatch and select a new color for this rectangle. Choose Layer > 
Change Layer Content > Gradient. Leave Gradient at the default selection, Foreground to 
Transparent. Set Style to Linear and the angle to –50. Repeat these steps to create a 
second rectangle, this time with an angle of 20.

5. Load custom shapes.

Select the Custom Shape tool in the toolbox. In the options bar, click the down arrow to 
open the Custom Shape Picker. Click the black triangle to open the palette menu and 
select All, and then click Append. This loads all of Photoshop’s predrawn shapes into the 
Custom Shapes palette. 
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6. Draw a custom shape.

Now we’ll add a custom shape to the foreground for an overlay effect. Select the top layer 
of the image, and use the foreground color swatch to select a color for the new shape. 
Select a custom shape from the Custom Shapes palette. (For our image, we chose the 
sunburst shape.) Holding down the Shift key to constrain proportions, click and drag in 
the image to draw the shape.

Since it’s a vector shape on its own level, the sunburst is easy to move or resize. Select the 
layer and then use the Move tool to move the shape, or choose Edit > Free Transform to 
resize, rotate, flip, or skew it.

7. Fill the custom shape with a pattern.

Next we’ll apply one of Photoshop’s pattern effects to make our shape more interesting. 
Select the new shape in the layers palette, and then choose Layer > Change Layer  
Content > Pattern. Click the pattern in the Pattern Fill dialog box to open the Patterns 
palette. Click the black triangle to open the palette menu.

The palette menu shows different sets of patterns—Artist Surfaces, Color Paper, Nature 
Patterns, and so on—that you can add to your basic patterns palette. Select a set, and then 
click Append. Click a pattern to apply it to the custom shape. To change your shape back 
to a solid color or to a gradient, choose the Layer > Change Layer Content command 
again.



Using Help | Contents | Index Back 701  

Adobe Photoshop CS Help Tutorials 

Using Help | Contents | Index Back 701  

8. Add a layer effect to the shape.

To enhance your shape further, you can add layer effects to it. With the shape layer 
selected, click the Add a Layer Style button. Choose Stroke from the menu. In the Layer 
Style dialog box, choose settings for the stroke color, width, and position, and then 
click OK.

Experiment with different blending modes for the layer, such as Hue, Darken, or Multiply, 
using the mode menu in the Layers palette. To remove a layer effect, select the effect in 
the Layers palette and drag it to the Delete Layer icon.
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Index

A
Absolute Colorimetric rendering intent 135

Accented Edges filter 423

actions 627

about 627

adjusting tonal range and color with 183

button mode 628

conditional mode change 157

creating droplets from 644

creating new 629

definition of term 627

deleting 639

editing 637

editing conditionals 633

editing droplets in ImageReady 646

excluding commands from recording 634

inserting conditionals 631

inserting nonrecordable commands 634

inserting paths 630

inserting stops 630

list Mode 628

loading in Photoshop 640

managing in the Actions palette 640

opening camera raw files 84

optimizing slices with 635

playing 636

processing files with droplets 646

recording 628, 630, 638

recording modal controls 627

recording tool operations 627

recording tools in 634

recording with conditional statements 631

renaming 639

resizing images with 635

saving in Photoshop 640

selecting 628

sets 641

setting modal controls 633

specifying output folders during recording 
634

using droplets 644

using droplets for optimization settings 647

using the Actions palette 627

using the Batch command 641

Actions palette 627

button mode 628

Button Mode command 628

keyboard shortcuts 673

list Mode 628

active layer 374

Actual Size command 33

Adaptive color palette 161

number of colors 161

Adaptive color table 549

Add Anchor Point tool 290

Add Noise filter 425

Add option 368

Add to Channel option 256

Add To Master Palette command 555

adding HTML text to slices 492

adding to a selection 229

Adjustment Composite option

in the Histogram palette 179

adjustment layers 402

about 180, 402

creating 402, 403

editing 404, 405

for color corrections 402

for filters 436

merging 405
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Adobe (ACE) 135

Adobe applications

integration between 601

Adobe Color Picker

about 165

alerts 166, 169

choosing a custom color 169

choosing a custom color system 170

color field 166

color slider 166

displaying 165

out-of-gamut alert 166

RGB Color mode 167

selecting a CMYK color 166

selecting a color 166

selecting a color in the document window 
166

selecting a color on the desktop 166

selecting colors in HSB mode 166, 167

specifying a color in Lab Color mode 168

specifying a hexadecimal color value 166

Web-safe colors 168

Adobe Every-line Composer 463

Adobe GoLive 654

Adobe Graphics Server 654

Adobe Illustrator

files, opening 102, 104

files, placing 105

Adobe Premiere 585

Adobe RGB (1998) 126, 146, 148

Adobe Single-line Composer 464

Adobe Version Cue 59

Advanced Blending for Photomerge 289

advanced blending options

grouping blend effects 389

range for blending layers 390

removing fringe areas 247

airbrush 328

Align Layers command 379

Align Slices command 484

Align To Selection command 379

aligning

image maps 499

linked layers 242

selections 230

shapes 306

slices 484

type 459

Alignment buttons 379

Bottom Edges 379

Horizontal Centers 379

Left Edges 379

Right Edges 379

Top Edges 379

Vertical Center 379

alignment. See Snap command

All Caps command 454

All Channels View

in the Histogram palette 177

Allow Non-Linear History option 37

alpha channels

about 357

adding textures 436

calculating 366

converting to spot channel 364

copying 360

creating 255

deleting 362

display of 358

file formats for saving 357

file size of 357

in JPEG 2000 files 575

naming 256

options 255, 257

saving 566

saving selection in 256

storing masks 254

storing selections in 360

Alt HTML element 491, 497

anchor points

adding and deleting 307

creating 307, 308
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angle

brush option 320

global lighting 399

layer style option 395

Angled Strokes filter 423

Angular Gradient tool 338

animated GIFs

about 528

in rollover state 516

opening 529

See also animations

Animation as Files command

exporting to SWF 577

Animation Frames as Files command 580

Animation palette 519

animations 518

about 518

adding frames 519

adding layers to frames 524

Animation palette 519

changes to Frame1 or Normal State 509

copying and pasting frames 522

creating 519, 529

creating and editing 519

delay time 524

deleting frames 521

designing pages with 471

disposal method for frames 525

editing frames 521

editing layers in 509

exporting as files 528

exporting frames as files 580

flattening frames into layers 526

frame delay 524

importing files as 529

looping 524

looping options 524

opening files as 529

opening QuickTime movies as 530

optimizing 526

previewing 526

rearranging frames 521

saving 527

selecting frames 520

tweening frames 522

unifying layers in 509

viewing in Photoshop 527

working with layers in 508

annotations 48

playing in actions 637

saving 566

viewing in Save for Web dialog box 533

ANPA colors 170

anti-aliasing

Adobe Illustrator files 104

EPS files 104

layer style option 395

PDF files 103

placed artwork 106

selections 239, 253

type 443

type layers 443

Apple CMM 135

Apple Color Picker 171

Apple ColorSync 135

Apple RGB 126

AppleScript 649

applications, jumping between 50

Apply Image command 367

blending modes 367

Calculations command 367

applying data sets 653

Arrange command 377

Arrange Slices command 484

arranging

image maps 499

arrowhead options 293

Art History Brush tool 315

Artistic filters 420

ASCII encoding, in EPS and DCS files 570

Asian type

composition options 468, 470

formatting exceptions 456, 461

leading 465
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tate-chuu-yoko 466

tsume 465

underlining 466

aspect ratio, constraining

when placing files 106

Assign Profile command 121

authorship information 46

Auto Color command 217

about 218

adjusting 217, 218

algorithm 218

Snap Neutral Midtones option 219

Auto Color Correction Options 218

Auto Contrast command 216

about 218

adjusting 218

algorithm 218

Auto Erase option 335, 337

Auto Levels command 216

about 218

adjusting 218

algorithm 218

clipping defaults 216

Auto Regenerate option 544

Auto Screens dialog box 619

auto slices. See slices

automatic frame disposal 525

Automatically Create First Snapshot option 37

automating

applying data sets 653

Automate commands 648

batches of data sets 654

commands for 648

contact sheets 594

data-driven graphics 649

droplets 644

external 649

multiple image layouts 594

optimization 557, 647

previewing data-driven graphics 653

processing data sets 654

saving templates for other Adobe 
applications 654

using actions 627

using Batch command 641

using data sets 652

using droplets 644

using scripts to externally automate 649

See also actions

average-key images 219

B
background color 162, 490

choosing 351, 355

editing with Color palette 354

filling selections with 344

printing 616

selecting with Eyedropper tool 352

setting in new images 89

Background Eraser tool 336

backgrounds

converting to layer 371

from filter effects 419

layer styles and 392

badges 476

Bas Relief filter 428

base color 331

base layer 413

base output size 611

baseline 451

Baseline options

for JPEG format 573

baseline shift 453

Batch command 641

to open multiple camera raw files 85

Batch Rename command 97

Behind mode 332

Bevel and Emboss effect 394

Bicubic interpolation 67

Bilinear interpolation 67

Binary encoding, in EPS and DCS files 570

bit depth

about 155

converting between 156
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bitmap images

about 61, 151

channels and 155

See also images

Bitmap mode 151, 155

about 151, 157

converting to 157

converting to Grayscale mode 158

Custom Pattern option 160

duplicating channels in 360

Paint Bucket tool 343

saving transparency in 570

using type 438

black and white color table 549

black and white points, scanning and 88

Black Body option 164

black point compensation 136

black-and-white images, creating 222

bleeds

printing 616

Blend Clipped Layers as Group option 389

blend color 331

Blend If option for layers 390

Blend Interior Effects as Group option 389

blending

grouping effects 389

restricting to channels 388

specifying range for 390

blending modes

choosing 386

described 331

for channel calculations 367

for layer sets 386

layer style 395

blending RGB colors 136

Blur and Blur More filters 422

Blur More filter 160

Blur tool 276

BMP format 584

about 584

saving in 571

Border command 239

borders

printing 616

Bottom Edges alignment button 379

Bottom Edges distribution button 379

bounding box

image maps 496

bounding boxes

type 441

brightness

adjusting 215

equalizing 220

Bring Forward command 377

Bring to Front command 377

Browse command 90

browsers

previewing in 51

Brush Stroke filters 423

Brush tool 314

brushes

about 317

airbrush option 328

clearing options 329

color dynamics 326

dual 325

dynamics, about 321

noise 328

other dynamics 327

preset 317

scattering 323

shape dynamics 322

size options 18

texture 324, 329

tips, customizing 319

wet edges 328

Brushes palette 317

keyboard shortcuts 674

Build Master Palette command 555

bump maps 436

Burasagari option 470

Burn tool 276

Button Mode command 628



Using Help | Contents | Index Back 708  

Adobe Photoshop CS Help Index 

Using Help | Contents | Index Back 708  

A  B  C  D  E  F  G  H   I   J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

C
cache and histograms preference 180

Calculations command 367

calibrating

monitors 110

calibration bars

printing 617

camera profiles 120

camera raw files

about 71

adjusting sharpness 78

bit depth 74

chromatic aberration correction 79

color profile 74

correcting a color cast 80

deleting settings 81

image vignetting 80

non-square pixel images 75

opening 74

opening multiple files 85

pixel size 75

printing resolution 75

reapplying settings 81

reducing noise 78

saving settings 81

sidecar XMP files 81

specifying image attributes 74

square-pixel images 75

tonal adjustments 77

using actions with 84

vignetting correction 80

white balance 75

canvas

filling 345

resizing 259

Canvas Size command 259

Cascade command 29

CCITT compression 582

Chalk & Charcoal filter 428

Change Layer Content command 405

changed files, in Version Cue projects 59

Channel Mixer command 152, 212

Constant option 213

creating monochrome images 212

Output Channel option 213

channels

alpha 357

bit depth 155

blending 367

calculating 366

color 357

color information and

creating 255

deleting 362

display 358

duplicating 360

duplicating between separate images 360, 
361

file size of 357

hiding and showing 358

inverting 213

layer mask 410

maximum number of 255

merging 361

mixing 212

moving 360

optimizing images with 545

options 255, 257

printing 609

Quick Mask 252

saving selections in 256

selecting 358

sequence of 256

source 213

splitting into separate images 361

thumbnails 357, 359

viewing 358

viewing in the Histogram palette 178

See also alpha channels, color channels, spot 
channels

Channels palette

about 357

changing display 359

selecting channels 359
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Character palette 449

type size 450

characters, special 456

characters. See type

Charcoal filter 428

Check Spelling command 457

chroma 113

chromatic aberration

in camera raw images 79

Chrome filter 428

CIE L*a*b*

See Lab color model

CIE viewing standard 128

Cineon format

about 584

saving in 572

Circle Image Map tool 495

CJK type. See Asian type

Clear command 247

Clear Layer Style command 401

Clear mode 332

Clear Slices command 485

client-side image maps 500

Clipboard

clearing 34

copying between applications 245

Export Clipboard option 245

preferences 245

rasterizing images from 245

clipping

about 186

in Auto Levels command 216

clipping groups

about 413

knockout 389

merging 384

clipping paths 601

printing 602

Clone Stamp tool 270

Close command 30, 57

with Version Cue project files 59

closed paths 301

closing files

in Version Cue projects 59

Clouds filter 427

CLUT 152

CMYK Color mode 150

out-of-gamut colors 184

selecting colors in 166

tonal and color adjustments in 184

CMYK color model 114

subtractive colors 114

CMYK color spaces 151

customizing 127

dot gain 129

previewing 184

CMYK images

channel display 358

converted from RGB 156

out-of-gamut colors 184

printing hard proofs of 143

CMYK inks. See process color inks

CMYK working spaces 126

black generation 130

choosing 127

dot gain 129

ink colors 128

saving custom settings 132

separation type 130

collaborating, using Version Cue 59

color

adjustment layers 402

color reduction algorithm in Optimize 
palette 538

conversions from Photoshop 405

copying hexadecimal values as 556

fill layers 403

hexidecimal values 556

color adjustments

image map 496

slices 476

color adjustments. See tonal and color 
adjustments
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color balance

adjusting automatically 216

adjusting with Curves 190

generalized adjustments 219

Hue/Saturation command 200

Replace Color command 210

scanning and 88

Selective Color command 214

Color Balance command 199

Color Burn mode 333

color casts. See color balance

color channels

 See also alpha channels, channels, spot 
channels

Color Channels in Color option 359

color corrections

Info palette display 26

See tonal and color adjustments

color depth. See bit depth

Color Dodge mode 333

color dynamics, for brushes 326

color engine 135

Adobe (ACE) 135

color field 166

Color Halftone filter 426

color management

about 109, 122

between Adobe applications 144

black point compensation 136

blending RGB colors 136

color references 109

color values and 117

customizing settings 124

dither option 136

during printing 146

for camera raw files 74

in JPEG 2000 files 575

in PDF presentations 600

loading settings 125

policies 132

predefined settings 123

Print dialog box 147

Print with Preview command 147

rendering intents 135

saving and loading profiles 136

saving documents 566

saving settings 125

soft proofs 140

specifying policies 133

synchronizing settings 144

using color references 118

viewing environment 139

warning dialogs 133

Web images 149

work environment 139

Color Management Module (CMM) 118, 135

Adobe (ACE) 135

Apple CMM 135

Apple ColorSync 135

Microsoft ICM 135

Color Management Off setting 123

Color mode option 334

color models

about 112

CMYK 114

device-dependent 116

device-independent 114, 117

HSB 112

Lab 125

RGB 113

color modes

about 150

Bitmap mode 151

Bitmap to Grayscale 158

CMYK Color 150

conditional mode change 157

converting images between 152, 156, 157, 
160

Duotone mode 152

Grayscale mode 151

Indexed Color mode 152, 160

Lab Color 151

Multichannel 152

number of channels

RGB Color 150

setting in new images 89
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viewing in Adobe Color Picker 164

viewing in the Histogram palette 178

color modes, changing automatically 648

Color palette

about 353

alerts 169

keyboard shortcuts 675

selecting Web-safe colors with 169

Web Color Sliders 169

color palettes

Adaptive 161

Black Body option 164

customizing 164

Exact 161

for indexed-color conversions 160

Grayscale option 164

Mac OS System 161, 164

matte color 162

number of colors 161

Perceptual 161

selecting Web-safe colors 169

Selective 161

specifying background color 162

specifying colors 162

specifying transparency 162

Spectrum option 164

Uniform 161

Web 161

Windows System 161, 164

Color Picker dialog box. See color pickers

color pickers

Adobe Color Picker 171

Apple Color Picker 171

choosing 171

plug-in 171

Windows Color Picker 171

Color Range command 234

Black Matte 235

Fuzziness option 235

Sampled Colors tool 234

White Matte 235

color reduction

modifying with masks 548

color reduction algorithms 538, 549

color reference 118

color samplers

about 182

deleting 182

moving 182

showing and hiding 183

color separations 608

about 151

adjusting traps 621

printing 620

Color Settings

about 122

black point compensation 136

blending RGB colors 136

Color Management Off 123

ColorSync Workflow 123

customizing 124

desaturating monitor colors 136

descriptions 122

dither option 136

for color management 110

loading 125

predefined settings 123

preference file 124

rendering intents 135

RGB working spaces 146, 148, 149

saving 125

saving CMYK custom settings 132

synchronizing between applications 144

Web images 149

color slider 166

color spaces 108

about 115

CMYK 128

converting between 121

converting when printing images 612

of devices 116
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color table

Adaptive 549

adding colors to 550

Black and White 549

Custom 549

deleting colors from 554

editing colors in 552

generating 549

Grayscale 549

including black and white 551

loading 555

locking colors in 554

Mac OS 549

master palette for 555

Perceptual 549

Restrictive (Web) 549

saving 555

selecting colors in 551

Sort By Hue 550

Sort By Luminance 550

Sort by Popularity 550

sorting colors in 550

unified, in Optimize palette 540

Windows 550

Color Table command 163, 164

Color Table palette

reducing colors with 548

viewing color table 548

color tables

about 152, 548

Black Body option 164

customizing 164

for indexed-color conversions 160

Grayscale option 164

loading 555

matte color 162

saving and loading 164

shifting to Web-safe colors 553, 554

specifying background color 162

specifying colors 162

specifying transparency 162

Spectrum option 164

using weighted optimization to generate 
548

color transitions, quality of 63

color traps 621

color values

in the Color palette 183

measuring CMYK 150

previewing 181

specifying 166

using the Eyedropper tool 183

color wheel 112

about 172

complementary colors 172

Colored Pencil filter 420

ColorMatch RGB 127

colors

CIE viewing standard 128

converting between color spaces 121, 142

deleting 554

for type 450

in color tables 548

inverting in images 222

locking in Color Table 554

mapping to transparency 553

reducing with weighted optimization 548

setting printing background 616

shifting to Web palette 553

soft proofs 140

subtractive 114

viewing in an image 552

See also background color

ColorSync 127

workflow 123

columns 41

Combine Slices command 484

Commands palette 33

commands, recording in actions 629

comments, in Version Cue projects 59

Commission Internationale d’Eclairage

Compact View

in the Histogram palette 177
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complementary colors.See color wheel

composite channel 358

compositing

specifying a color range 390

composition, of type 463

compression

about 582

in ZoomView format 581

CompuServe GIF format. See GIF format

Conditional Mode Change command 157, 648

conditionals

about 631

editing in actions 633

inserting in actions 631

conflict alerts, in Version Cue projects 59

Constant option 213

Contact Sheet II command 594

about 594

creating contact sheets

contact sheets. See Contact Sheet II command

Conté Crayon filter 419, 428

context menus 27

Contiguous option 233, 275, 336

continuous-tone images

about 61

printing 608

contours 398

Gloss Contour option 396

layer style option 396

libraries 398

contrast

adjusting 215

adjusting automatically 216

conversions

color 405

Convert Direction Point tool 307

Convert to Paragraph Text command 444

Convert to Point Text command 444

Convert to Profile command 121

Convert to Shapes command 448

convolution 431

cooling filters 203

Copy Frames command 522

Copy Layer Style command 400

Copy Slice command 483

Copy State command 517

copying

and pasting 241

animation frames 522

between applications 245

channels 360

layers between images 376

optimization settings between slices 486

PostScript artwork from Clipboard 245

rollover states 517

selections 241, 243

slices 483

styles 400

textures between tools 329

See also duplicating

copyright information

adding 590

viewing 46

copyright, adding to files 99

correcting mistakes

about 33

reverting to saved image 33

undoing last action 33

Craquelure filter 431

Create Droplet command

in Actions palette 646

in Automate submenu 644

in Optimize palette 558, 648

Create Layers command 402

Create Selection from Slice command 236

Create Slice from Selection command 474

Create Work Path command (for type) 447

Crop command 262

crop marks

printing 617

Crop tool 25, 261
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cropping images

about 261

changing perspective 263

Crosshatch filter 423

Crystallize filter 427

Current Layer option 38

Current Path command 411

cursors. See tool pointers

curves

creating smooth and sharp 301

drawing 296

Curves command

about 189

adding points 191

adjusting color balance 190

adjusting tonal range 190

Auto button 192

Auto options 218

quick adjustments 192

setting highlight values 194

setting shadow values 194

setting target values with 195

shortcuts 192

using the eyedropper tools to adjust 
tonality 192, 193

Custom 431

custom color filter

in the Photo Filter command 204

custom color system 170

Custom color table 549

Custom filter 431

custom ink colors 169

Custom Pattern option 160

Custom Shape tool 290

Custom Spot Function option 619

customizing

grayscale working spaces, customizing 138

spot-color profiles 138

customizing working space for 138

Cut command 247

Cutout filter 420

cylindrical mapping 289

D
D50 lighting 139

Dark Strokes filter 423

Darken mode 332

data sets

applying 653

importing from external files 654

processing all 654

using 652

using batches of 654

data-driven graphics 649

previewing 653

DCS format

about 361, 571, 584

ASCII encoding 570

Binary encoding 570

DCS 1.0 571

DCS 2.0 571

for images with spot channels 621

halftone screen and transfer function 570

Image Interpolation option 570

JPEG encoding 570

PostScript Color Management 570

saving files in 571

Transparent Whites option 570

vector data 570

defaults

mask editing colors 254

restoring palette positions 23

restoring tool settings 19

Define Brush command 319

Define Pattern command 346

Defringe command 247

De-Interlace filter 431

Delete All command 485

Delete Anchor Point tool 290, 307

delete anchor point tool 307

Delete Color command 554

Delete Frame command 521

Delete Slice command 489

Delete Slice Selection command 479

Delete Slices command 485
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Delete Workspace command 23

Deleted-Files folder, for Version Cue projects 
59

deleting

alpha channels 362

animations 521

channels 362

colors from swatch sets 356

colors in color table 554

frames from animations 521

image maps 500

layer-based slices 485

layers 383

locked selections 247

nested tables 489

rollover states 518

selections 247

slice selections 479

slice sets 480

slices 485

user slices 485

Desaturate command 221

Deselect All Colors command 552

Deselect command 229

deselecting selections 229

See also selecting

Designing Web pages

about 471

animations 471

automating the workflow 472

opening in Adobe GoLive 472

optimizations for export 472

page design 471

rollovers 471

slices 471

desktop

selecting a color in 166

desktop printers

profiles 111

using color management 146

Despeckle filter 426

destination channel 367

destination profiles 109

destination selection 244

detection width, Magnetic Lasso tool 233

device profiles 109, 118, 119

device-dependent color models 116

device-independent color models 114, 117

dialog boxes

about 22

pop-up sliders 23

setting position of 22

See also names of individual dialog boxes

Diameter option 319, 326

Diamond Gradient tool 338

DIC Color Guide 170

Difference Clouds filter 427

Difference mode 334

Diffuse filter 429

Diffuse Glow filter 424

Diffusion dither 538, 539, 542

Diffusion Dither preference 153

diffusion dithering 153, 162

Digimarc Detect Watermark plug-in 46

Digimarc filters 432

about 590

before adding 590, 591

Direct Select tool 370

directional light effect 433, 434

discarding changes, in Version Cue projects 59

Displace filter 424

displacement maps 424

Display & Cursors preference 359

disposal method for animation frames 525

Dissolve mode 332

Distort filters 424

distorting images 280

distortions

Liquify filter 278

reconstructing 281

Distribute Layers command (ImageReady) 379

Distribute Linked Layers command 
(Photoshop) 379

Distribute Slices command 485
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distributing

image maps 499

layers 379, 380

linked layers 379

shapes 306

slices 485

Distribution buttons

Bottom Edges 379

Horizontal Centers 379

Left Edges 379

Right Edges 380

Top Edges 379

Vertical Centers 379

dithering 538

about 153, 162

color management and 136

diffusion 153, 162

in animations 526

in linked slices 486

in Optimize palette 538

modifying with masks 547

No Dither 542

Noise 542

noise 162

Pattern 542

pattern 153, 162

shifting to Web-safe colors 553

transparency 539

transparency, in Optimize palette 539

weighted optimization and 547

Divide Slices command 482

Do Not Dispose option 525

document size

about 68

adjusting during printing 611

document window 28

selecting a color in 166

documents

embedding profiles in 120, 126, 133

previewing 141

profiles 118, 119

soft proofs 141

tagging 120

untagged 120

viewing both original and soft proofs 143

viewing in a work environment 139

working spaces 125

Documents folder, for Version Cue projects 59

Dodge tool 276

dot gain

about 129

compensating for with transfer functions 
139

specifying for CMYK color spaces 129

dot loss 617

double-byte type. See Asian type

Downgrade Color Profile option 568

downsampling 66

dpi (dots per inch) 64

drawing

constraining shapes 293

shapes 290

with the pen tools 295

with the shape tools 291

drivers

scanner 86

Drop Shadow effect 394

droplets 644

about 644

applying to slices 486

compatibility issues 646

creating for optimization 557, 647

creating for various operating systems 646

creating from actions 644

creating in ImageReady 645

creating in Photoshop 644

editing 646

editing in ImageReady 646

in actions 635

processing files 646

Dry Brush filter 420

dual brushes 325

Duotone mode 152, 155
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duotones

about 622

creating 623

curves 623

exporting to other applications 626

overprint colors 624

printing 625

saving and loading settings 625

viewing individual plates 625

Duplicate Channel command 360

Duplicate command 39, 566

Duplicate Layers for Layer-Based Slices 
command 483

Duplicate Merged Layers Only option 40

Duplicate Path command 306

Duplicate Rollover States command 483

Duplicate Slice command 483

duplicating

channels 360

image maps 499

images 39

optimized images 40

selections in an image 243

slices 483

See also copying

duplicating commands in actions 639

Dust & Scratches filter 426

Dynamic Color Sliders option 354

dynamic range 88

E
edge effects 419

edge mask

creating 226

for sharpening 226

edge sensitivity, Lasso tool 233

edges

smoothing 310, 312

editing

in Version Cue projects 59

type 442

versions 59

effects

grouping blend 389

modifying with contours 398

removing 401

scaling 401

using 391

eight-bit color displays 153

Elliptical Marquee tool 229

Embed Color Profile option 566

for JPEG 2000 format 573

Embed Watermark command 591

embedding fonts

in SWF files 577

embedding profiles 121

Emboss filter 429

Enable Dynamic Text option 577

Encapsulated PostScript (EPS) format. See EPS 
files

Entire Image option

in the Histogram palette 179

EPS files

about 584

ASCII encoding 570

Binary encoding 570

halftone screen and transfer function 570

Image Interpolation option 570

JPEG encoding 570

opening 104

placing 105

PostScript Color Management 570

saving 571

saving in DCS format 571

Transparent Whites option 570

vector data 570

Equalize command 220

Erase to History mode, Eraser tool 335

Erase to History option 34

Eraser tool 34, 335

erasing

about 335

fastening points 231

lasso segments 231

See also deleting
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Every-line Composer 463

Exact color palette

about 161

Exclusion mode 334

Expand command 238

Expanded View

in the Histogram palette 177

Export Clipboard option 245

Export command

with Version Cue project files 59

Export Original Document command 564, 
565, 579

Export Transparent Image wizard 601

exporting

animation frames as files 580

duotones 626

layers as files 382, 385, 579

paths 603

slices 493

to Adobe Premiere 605

transparency 601

with Version Cue project files 59

exporting animations as files 528

exposure setting 334

external automation 649

external file for batched data sets 654

Extract command 248

about 248

cleaning up edges 250

previewing 250

Extras

choosing from hidden Extras 45

showing and hiding 45

target path 303

turning on or off 45

See also names of individual Extras

Extrude filter 429

Eyedropper tool 182

copying hexadecimal color values with 556

for color correcting 193

for Levels and Curves 192

in the Hue/Saturation command 201

selecting colors with 352

setting black and white points 193

F
Facet filter 427

Fade command 248, 418

fastening point 231

feathering selections 239, 253

File Browser 90

Contact Sheet II command

updating camera raw settings 81

file compression. See compression

file extensions, preferences for saving 593

File formats

Photoshop Save As command 531

file formats

about 582

animation and movie 585

for nonsupported previews 584

Photo CD 151

supporting paths 309

See also compression, Save for Web dialog 
box, and names of individual formats

File Info command 99

file information

about 590

file size

about 64

displaying 46

required for alpha channels 357

scanning and 88

File size tracking 385

file status, in Version Cue projects 59

file versions

using Version Cue 59

files

closing 57

embedding profiles in 121

extensions for 566

options for saving 562

files for batch-processing 641

Fill command 344, 345
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fill layers 402

about 402

creating 402

editing 404

merging 405

fill opacity 387

Fill tool 249

Fill with Neutral Color option 387

filling

layers 344

paths 311

selections 344

type 451

with background color 344

with foreground color 344

with gradients 338

with history state 34

fills

keyboard shortcuts 668

Filmstrip format 585

Filter Gallery 415

changing the display of the preview 415

displaying 415

filters

16-bit images 415

8-bit images 415

applying 417, 418

applying cumulatively 415

Artistic 420

blending effects 418

Blur 421

Brush Stroke 423

Colored Pencil 420

creating backgrounds 419

creating special effects 419

Cutout 420

Digimarc 432, 590

Distort 419, 424

Dry Brush 420

Fine Grain 420

Fresco 420

improving performance with 436

Lens Blur 422

Lighting Effects 432

Neon Glow 420

Noise 425

Other 431

Paint Daubs 420

Pixelate 426

plug-ins 437

previewing 417, 418

Render 427

Repeat Edge Pixels option 419

Sharpen 428

Sketch 428

Stylize 429

using the Filter Gallery 415

Video 431

Wrap Around option 419

See also names of individual filters

Find All Remote Slices command 515

Find and Replace command 458

Find Edges filter 430

Find Remote Slices For State command 515

Fine Grain filter 420

Finger Painting option 275

Fit Image command 648

Fit on Screen command 33

Flash file format. See SWF format

Flatten Frames into Layers command 526

Flatten Image command 385

flattening images 385

flipping

images 260

layers and selections 268

FOCOLTONE colors 170

font family.See fonts

fonts

about 449

font family 449

selecting 449
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foreground color

choosing 351, 355

editing with Color palette 354

filling selections with 344

selecting with Eyedropper tool 353

fractional character widths 455

Fragment filter 427

frame delay 524

Free Transform command 26

about 268

Freeform Pen tool 298

freehand selection 231

Fresco filter 420

fringe 247

Full Document option 37

function keys 680

G
gamma

adjusting for cross-platform differences 197

adjusting manually 198

Gamma command 198

gamma shifts 533

gamut 116

about 184

Gamut Warning command 184

changing the warning color 185

Gaussian Blur filter 422

GCR.See gray component replacement (GCR)

GIF format 585

about 585

indexing color 572

Interlaced option 572

Normal option 572

optimizing images in 537

reducing colors 548

saving files 572

weighted optimization and 546, 547

Glass filter 419, 424

global lighting 398, 399

Glowing Edges filter 430

glyph

about 463

glyph spacing 463

GoLive

opening Photoshop files in 472

Gradient Editor dialog box 339

Gradient Fill tool, measuring distance of 
gradient fill 25

Gradient Map command 223

Gradient tool 25

gradient tools 338

See also individual gradient tool names

gradients

applying 338

creating 339

creating presets 340

deleting 342

editing 339

fill layers 403

keyboard shortcuts 668

layer style option 396

libraries 342, 343

mapping tonal range to 223

saving and loading 342

transparency 340

Grain filter 431

Graphic Pen filter 429

graphics. See vector graphics

gray component replacement (GCR)

Grayscale color table 549

grayscale images 155

about 151

colorizing 202

converting to bitmap images 157

converting to high-contrast black-and-
white images 222

converting to indexed-color images 160

create by mixing channels

creating from color images 221

halftone screen attributes for 619

storing selections in 357

Grayscale mode 151, 155, 157

converting from Bitmap mode 158
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Grayscale preview of color selections 235

grayscale working spaces, customizing 138

grid and guides

about 43

grids 43

Group Slices Into Table command 487

grouping

layers in ImageReady 375

Grow command 239

guides 43

creating slices from 474

Smart Guides 43

Smart Guides, hiding 44

snapping 43

H
halftone cell 65

Halftone Pattern filter 429

halftone screens

defined 65

for Bitmap-mode conversions 159

saving in EPS and DCS files 570

halftones

about 618

Custom Spot Function option 619

loading screen settings 620

saving screen settings 620

selecting attributes for 618

Use Accurate Screens option 619

halftoning 608

halo 247

Hand tool 30

handtinted images 213

hanging punctuation 461

Hard light mode 333

hard proofs 140, 143

Hardness option 321

Healing Brush tool 272

hexadecimal color values 166, 556

Hide All Layer Styles command 394

Hide Auto Slice command 477

Hide Optimization Info command 535

Hide Slice Number command 477

hiding and showing

channels 358

grid and guides 43

layer styles 394

rulers 40

text selections 448

using layer masks 409

High Pass filter 432

high-key images 176, 196

highlights

adjusting 220, 276

Histogram palette

about 177

adjusting histogram view 177

Compact View 177

displaying channels in color 178

Expanded View 177

pixel values 180

previewing adjustments 179

refreshing 179

showing 177

statistics 179

Uncached Refresh 179

viewing a specific channel 178

viewing a specific layer 179

viewing statistics 179

histograms

about 176

cache level 180

clipped values 197

display in Levels command 188

reading 176

Use Cache for Histograms preference 180

History Brush tool 34, 38

History palette

about 34, 316

and batch processing 641

using with actions 629

history states

deleting 36

guidelines 34
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options 36

painting with snapshot 38

replacing 335, 344

replacing existing document 36

reverting to previous 35

HKS 170

Horizontal Centers alignment button 379

Horizontal Centers distribution button 379

horizontal scale of type, adjusting 453

hot spots for tool pointers 18

HSB color model 112

HSB mode

in the Adobe Color Picker 166, 167

selecting colors in 166

HTML

Alt element 491, 497

cell alignment for text 492

for ZoomView format 581

generating with SWF files 577

Message element 491, 497

target frame 491, 497

URLs in image maps 497

URLs in slices 491

HTML output settings 560, 561

hue 112

Hue mode 334

Hue/Saturation command

colorizing grayscale images 202

specifying range of colors 201

using the eyedropper tools to modify the 
range of colors 201

hyphenating

choosing a dictionary 462

turning on or off 462

type 461

Hyphenation command 462

I
ICC Profile option 566

for JPEG 2000 format 573

ICC profiles

scanning and 89

Image Dimensions option 47, 66

Image Interpolation option 568, 570, 600

Image Map tool 494

Image Map Visibility button 496

image maps

about 494

adding links to 497

aligning 499

arranging 499

bounding box areas 496

client-side 500

converting layer-based to tool-based 496

creating 494

deleting 500

duplicating 499

Image Map palette 497

layer-based 495

modifying in image 499

moving 498

options for 497

resizing 498

selecting 498

server-side 500

tool-based 495

tool-based map areas 494

type 500

viewing 496

Image Previews option 566

image previews. See thumbnails

Image Size command

about 62

changing document size 69

changing pixel dimensions 67

recording in actions 635

using Auto option 69

images

16-bit-per-channel 156

8-bit-per-channel 156

about 61

bit depth

color adjustments 174, 180

converting between bit depths 156
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converting between color modes 156, 160

converting to Bitmap mode 157, 158

copying layers between 376

copying selections between 243

creating from history state 36

creating from snapshot 36

creating monochrome images 212

creating new 89

cropping 261

displaying information 46

displaying size of 66

duplicating 39

flattening 385

for video 604

grayscale 151

handtinted images 213

high-key 176

importing 71

importing from PDF files 103

indexed-color conversions 160

loading selections into 257

low-key 176

maximum size 64

moving 31

noise in camera raw files 78

number of colors 161

opening 101

pixel dimensions 63, 67

pixel values 180

placing 105, 601

posterizing 223

preserving highlight and shadow detail 188

previewing in browser 51

print dimensions 68

printing 608

pseudocolor 163

renaming 97

resampling 66

restoring 34

reverting to any state 34, 38

RGB 150

RGB to CMYK 156

rotating or flipping 260

saving 564

scanning 86, 87

selective sharpening 226

sharpening 224, 225

trimming 262

viewing 27, 31

See also bitmap images, optimizing images, 
vector graphics

Import command 70, 86, 103, 105

with Version Cue project files 59

Import Folder As Frames command 529

importing

anti-aliased PICT files 105

artwork by dragging 245

files as animation frames 529

PDF images 103

Photoshop images into other applications 
601

PICT resources 105

with Version Cue project files 59

See also scanning

importing files as animations 529

importing images

digital camera with WIA support 71

scanning with WIA support 87

WIA support 71, 87

In Use By alerts, Version Cue projects 59

indenting paragraphs 460

Indexed Color mode 152, 155

about 160

conversion options 160

converting RGB and grayscale images to 160

Indexed color mode

using type 438

indexed-color images 152

Info palette 182

about 25

color corrections display 26

hexadecimal color values in 556

out-of-gamut colors 25

previewing color changes in 181

information box 66
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ink colors

specifying 128

Ink Outlines filter 423

inkjet printers 64

Inner Glow effect 394

Inner Shadow effect 394

input profiles 119

Insert Conditional command 631

Insert Menu Item command 634

Insert Path command 630

Insert Set Optimization Settings command 
635

Insert Set Output Folder command 635

Insert Stop command 630

integration

between Adobe applications 601

Interlace option 540

for GIF and PNG-8 540

International Color Consortium (ICC) 117

International Press Telecommunications 
Council 81

interpolation methods 67, 265

for printing 617

Intersect with Channel option 256

intersecting selections 229

Inverse command 237

Invert command 222

compared to Negative option 617

Invert option 367

IPTC 81

J
jitter

about 321

angle 322

color 326

count 324

flow 328

opacity 327

roundness 323

size 322

texture depth 325

JP2 format.See JPEG 2000 format

JPEG 2000 format

about 573, 585

alpha channels 575

Compliance option 574

defining a Region of Interest 575

Growing Thumbnail option 575

including metadata 574

JP2 format

JPF format

Metadata Format option 574

optional plug-in 573

preserving transparency 574

Progressive option 575

saving in 573

Tile Size option 574

Wavelet Filter option 574

JPEG compression.See JPEG format

JPEG encoding, in EPS and DCS files 570

JPEG format

about 585

Baseline Optimized option 573

Baseline option 573

compression

Matte option 573

optimizing images in 540

Progressive option 541, 573

Quality option 541

saving files in 572

simulating transparency 573

specifying image quality 573

weighted optimization and 546

JPF format.See JPEG 2000 format

Jump To command 50

jumping between applications 50

justifying type 460

K
kerning type 452

keyboard shortcuts 656

keystone distortion, correcting 263

Kinsoku Shori option 468
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knock out 366

kumimoji 465

L
Lab Color mode 151, 155

in the Adobe Color Picker 166, 168

specifying a color 166

Lab color model 125

as color reference 118

luminance and chromatic components 114

Lab images

blending modes 386

channel display 358

Lasso tool 231

Lasso Width option 233

layer clipping paths

drawing 290

layer comps

applying 407

creating 406

deleting 408

Layer Comps palette 405

restoring 407

updating 407

validating 407

viewing 407

working with 405

Layer Comps palette 405

layer mask channel 410

Layer Mask Hides Effects option 390

layer masks

adjustment layers as 402

applying 412

channels saved as 256

discarding 412

displaying 411

displaying channel 410

editing 244, 410

loading as selections 412

removing 412

thumbnails 244

Layer Match command 510

Layer Move tool 369

Layer Select tool 370

Layer Set from Linked command 373

layer sets 372

creating 371, 372

locking 380

viewing 373

layer style options

bevel 396

color 396

drop shadow behavior 396

gloss 396

glows 397

gradient 396

opacity 396

pattern 397

shading 397

shadow or glow boundaries 396

stroke position 397

texture 397

layer styles

contours 398

editing 401

hiding and showing 394

preset 399

removing 401

rollover styles 516

scaling effects 401

type layers 442

Layer Via Cut command 373

layer-based slices 475

layers

about 369

adjustment 402

applying masks 412

applying preset styles 392

background 371

background layer opacity 386

blending range 390

clipping mask 413

color coding 382

converting styles to 401
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copying and pasting styles 400

copying between images 376

creating 371

creating custom styles 394

creating masks 409

creating slices from 475

creating vector masks 411

deleting 383

discarding masks 412

displaying styles 394

Distribute Layers command 379

Distribute Linked Layers command 379

distributing 379

editing masks 409

editing styles 395

editing vector masks 411

effects 391

effects scaling 401

exporting 382, 385

fill 402

filling 344

filling with neutral color 387

flattening 385

flattening from animation frames 526

flipping or rotating 268

grouping 384

grouping in ImageReady 375

in animations 508, 526, 529

in channel calculations 367

in rollover states 513

knockout 387

linking 378

loading boundaries as selection 412

locking 380

managing 382

masking 408

masks 408

matching across rollover states 509

merging 383

modifying effects 398

moving 241

opacity setting 386

painting transparency 332

printing 609

rasterizing 382

removing effects 401

renaming 382

reordering 377

rotating 266

sampling 381

saving 566

scaling 266

scope of blending options 389

selecting 374

stroking 344

styles 391

thumbnails 371

unifying 381, 509

unlinking masks 412

using masks to select opaque areas 412

using the Move tool 369

viewing 373, 375

See also type layers

Layers as Files command 579

exporting to SWF 577

Layers palette 244, 370

keyboard shortcuts 677

leading

about 451

leading, for Asian type 465

Left Edges alignment button 379

Left Edges distribution button 379

legacy Photoshop serial number 58

Lemple-Zif-Welch (LZW) compression 582

Lens Blur filter 422

Lens Flare filter 428

letter spacing 462

Levels command

about 185

adjusting color balance with 188

adjusting gamma 186

adjusting tonal range with 186

assigning highlight values 194

assigning shadow values 194
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Auto options 218

Input Levels sliders 186

Output Levels sliders 188

Set Gray Point 188

setting target values with 195

Threshold mode 197

using the eyedropper tools to adjust 
tonality 192, 193

libraries, working with 52

ligatures 456

Lighten mode 333

lighting effects 399

Lighting Effects dialog box 436

Lighting Effects filter

about 428, 432

adding 435

creating styles 435

deleting 435

deleting styles 435

dialog box 436

directional light 433, 434

omni light 433

saving styles 435

spotlight 433, 434

Lighting Effects filter styles

Crossing 435

Crossing Down 435

Default 435

Five Lights Down 435

Five Lights Up 435

Flashlight 435

Flood Light 435

Parallel Directional 435

Line tool

about 291

measuring distances with 25

Linear Burn mode 333

Linear Dodge mode 333

Linear Gradient tool 338

Linear Light mode 334

lines, drawing 291, 314, 315

Link Slices for Optimization command 486

Liquify filter

applying a mesh 283

Bloat tool 278, 279

distorting images 278, 280

Freeze tool 280

freezing and thawing areas 280

inverting frozen areas 280

Mirror tool 278

moving pixels right 278

Pucker tool 278

Push Left tool 278

Reconstruct tool 280, 281

reconstructing 281

reconstructing distortions 281

reconstruction modes 283

reconstruct tool modes 283

saving a mesh 283

setting tool options 279

Shift Pixels Left tool 279

Thaw tool 281

thawing areas 281

Turbulence tool 278, 279

Twirl Clockwise tool 278

twirl counter clockwise 278

using a mesh 283

using mask options 281

using selections to freeze areas 280

using the distort tools 278

Warp tool 278

working with backdrops 284

Zoom tool 278

zooming 278

Load Actions command 640

Load Selection button 257

Load Selection command 247

Load Slice Selection command 479

loading

color tables 164, 555

contours 398

duotone curves 624

output settings 559

pattern libraries 345
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selections 247

slice selections 478

tonal and color adjustment settings 183

loading actions 640

local files, in Version Cue projects 59

Lock Slice command 485

Lock Transparency option 247

Lock/Unlock Selected Colors command 554

locking

colors 554

locking layers 380

locking slices 485

looping, in animations 524

lossless compression

CCITT 582

LZW 582

RLE 582

ZIP 582

lossy

modifying with masks in GIF format 546

lossy compression

JPEG format

weighted optimization and 546

low-key images 176, 196

lpi (lines per inch) 65

Luminosity

viewing in the Histogram palette 178

Luminosity mode 334

M
Mac OS color table 549

Mac OS System color palette 161, 164

Macromedia Flash format. See SWF format

Magic Eraser tool 336

Magic Wand tool 233

Magnetic Lasso tool 231

Magnetic Pen tool 298

Make Frames From Layers command 529

Make Selection command 310

Make Work Path command 311

managing layers 382

mapping colors to transparency 553

marquee tools 25, 229

Fixed Size option 230

Mask option, calculations 368

Masked Areas option 254, 255

masking layers 408

masks 408

adding to selection 257

and weighted optimization 545

applying 412

choosing color of 254

clipping 413

color that determines editing 254

creating 409

default colors 251

discarding 412

editing 409

for type 441

in color reduction algorithms 538

loading 257

loading intersecting selections 257

modifying color reduction with 548

modifying dithering 547

modifying GIF lossiness 546

modifying JPEG quality 546

permanent 254

saving as alpha channels 251

saving selections in 251

selecting opaque areas 412

selections as 257

storing in alpha channels 254

subtracting from a selection 257

temporary 252

unlinking from layers 412

varying quality level with 541

vector 411

master palette 555

Match Color command 206

adjusting color with 209

matching color between layers 208

saving and loading settings 210

match print 140

matte color 162
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Matte option 538

Matting command 247

matting, removing 247

Maximum filter 227

mean pixel values 180

Measure tool 42

measuring

about 42

angle of rotation 25

changing units 41

cropping marquee 25

using line tool 25

Median filter 227, 426

median pixel values 180

memory, freeing 34

menu bar 12

Merge Channels command 361

Merge Down command 244, 384

Merge Spot Channel option 365

Merge Visible Layers command 385

Merged for Layer option 367

Merged Layers option 37

merging

adjustment or fill layers 405

channels 361

layers 383

using Stamp 384

Message HTML element 491, 497

metadata 590

Metrics option 452

Mezzotint filter 427

Microsoft ICM 135

midtones

adjusting 220

adjusting with Levels 187

Minimum and Maximum filter 432

mistakes, correcting 33

modal controls

about 633

setting 633

Mode commands 156, 157, 159, 160, 163

models. See color models

modes

Bitmap 151

Bitmap to Grayscale 158

CMYK Color 150

conditional mode change 157

converting between 156, 157

Duotone mode 152

Grayscale mode 151

Indexed Color mode 152

Lab Color 151

Multichannel 152

RGB Color 150

See also blending modes or color modes

Modify Lossiness Setting dialog box 546

Modify Quality Setting dialog box 547

moiré patterns

in halftones 619

in printing 618

Mojikumi option 468

Monitor RGB working space 127

monitoring operations 56

monitors

adjusting display 153

calibrating 119

cross-platform differences 154

desaturating colors 136

eight-bit color 153

Photoshop and ImageReady differences 154

profiles 119

Standard Macintosh Color 198

Standard Windows Color 198

uncompensated color 198

using embedded color profile option 198

monotones. See duotones

Mosaic filter 427

Mosaic Tiles filter 431

Motion Blur filter 423

Move tool 241, 244

moving

image maps 498

paths 305

selection borders 236
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selections 241

shapes 305

slices 480

moving files, in Version Cue projects 59

moving objects

keyboard shortcuts 666

MTX files 581

Multichannel mode 152, 362

duotone mode adjustments 625

using type 438

Multi-Page PDF to PSD command 103

multiple copies. See duplicating

Multiply mode 333

N
named optimization settings 542, 543

Navigator palette 31

Nearest Neighbor interpolation 67

negatives

creating 222

printing 617

Neon Glow filter 420

nested sets, viewing 373

New Channel command 255

New Color command 551

New command 89

New Layer Based Image Map Area command 
495

New Layer Based Slice command 475

New Layer button 372

New Snapshot button 37

New State command 513

New View command 29

New Window command 184, 606

No Break command 462

noise

in camera raw images 78

Noise dither 538, 540, 542

noise dithering 162

Noise filters 425

noise gradients, creating 341

noise, in brushes 328

nonprintable colors 169

non-square pixels 604, 605

Normal mode 332

Normal state, for rollovers 508

Note Paper filter 429

NTSC Colors filter 431

number of colors

weighted optimization 548

numeric values, specifying colors with 166, 
354

O
Ocean Ripple filter 424

Offset filter 432

Oidashi option 468

Oikomi option 468

old style type 456

OLE

about 603

linking and embedding images 603

OLE automation 649

omni light effect 433

one-bit images

See bitmap images

online images

changing size of 67

creating master palette for 555

resolution of 63

See also optimizing images

online services 626

opacity

background layer 386

fill 387

gradients 340

layer mask 411

layers 386

Opacity value, in Info palette 26

painting and editing tools 334

Quick Mask 254

See also transparency
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Open As command 102

Open command 101, 103, 104, 530

with Version Cue projects 59

open paths 301

Open Recent command 102

opening

animated GIF files 529

EPS files 104

images 101

PDF files 102

Photo CD files 104

Version Cue project files 59

See also placing, importing

opening files as animations 529

opening QuickTime movies as animations 530

OpenType fonts 438, 449, 456

operations

canceling 56

monitoring 56

optimization

in PDF presentations 600

optimization settings 536

Optimize by Bounding Box option 527

Optimize by Redundant Pixel Removal option 
527

Optimize palette 534

adding metadata in 540, 541

Auto Regenerate 544

blur 541

color reduction algorithm 538

displaying 534

dithering 538

ICC profile 541

include reference to source file 563

interlaced 540

matte 538, 541

menu 534

optimized 541

progressive 541

quality 541

transparency 538

transparency dithering 539

unified color table 540

Web snap 540

write minimal set of XMP 563

write XMP to separate files 563

Optimize palette droplets 647

Optimize to File Size option 536

optimized images

saving 558

Optimized Information option 47

Optimized JPEG format 541

optimizing

about 531

animations 526

applying optimization settings 536

based on file size 536

Color Table palette 548

droplets for automating settings 557

GIF format 537

ideal image format 537

images 531

JPEG format 540

named settings for 542

PNG-8 format 537

saving optimized images 558

setting preferences 544

slices 485

SWF format 542

using Color Table for slices 548

viewing optimized images in ImageReady 
535

WBMP format 542

weighted optimization 545

optimizing images

automating 557, 635, 644, 647

canceling 544

PNG-24 format 541

preferences for 544

restoring to original version 536

options bar 13

Original view

creating animations in 519

Original/Optimized File Size option 47

Other filters 431

outdated files, in Version Cue projects 59
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Outer Glow effect 394

out-of-gamut 116

about 25

displaying in Info palette 25

out-of-gamut alert 166

out-of-gamut colors

about 184

displaying in Adobe Color Picker 169

selecting 235

output profiles 120

Output Settings dialog box

always add alt attribute 560

always quote attributes 560

attribute case 560

background image 561

BG color 561

close all tags 560

default slice naming 561

displaying predefined output options 559

empty cells 560

encoding 560

file compatibility 562

file naming 562

file saving options 562

generate CSS 561

generate table 560

HTML file naming 560

HTML options 560, 561

image map placement 561

image map type 561

include comments 560

include zero margins on body tag 560

indent 560

line ending 560

loading output settings 559

optimized files 562

output multiple HTML files 560

output XHTML 560

referenced 561

saving options 559

saving output settings 559

spacer cells 560

switching to new set of options 559

tags case 560

use long filename extension 560

view document as 561

Overlay mode 333

overprint colors 624

P
page design 471

page marks 616

Page Setup command 608, 609

Paint Bucket tool 343

Paint Daubs filter 420

Paintbrush tool 315

painting

options 331

with patterns 271

Painting Cursors options 18

painting tools

about 314

Palette Knife filter 421

palette well 13

palettes

about 21

changing display of 21

docking 22

Hide Options command 22

keyboard shortcuts 672

moving 21

pop-up sliders 23

resetting to default positions 23

setting position of 22

Show Options button 22

Show Options command 22

showing and hiding 22

storing in tool options bar 19

See also names of individual palettes

panoramas, creating 284

Paragraph palette 459

paragraph type 438

converting to point type 444

See also type
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paragraphs

about 459

choosing a composition method 464

formatting 459

hanging punctuation 461

indenting 460

spacing 461

word breaks 462

Pass Through blending mode 386

Paste Into command 242, 244

Paste Layer Style command 400

Paste Rollover State command 517

Paste Slice command 483

pasting

decreasing fringe 247

frames 522

PostScript artwork 245

removing halos 247

rollover states 517

selections 243

slices 483

styles 400

Patch tool 273

Patchwork filter 431

path components 301

paths

adjusting 303, 305

clipping 601

copying 306

defining as selection border 310

defining transparency 601

definition of 301

deleting 309

deselecting 300

distributing 306

drawing freehand 298

exporting to Adobe Illustrator 603

filling 311

from selection borders 311

keyboard shortcuts for editing 667

printing 602

recording in actions 630

reordering in the palette 300

repositioning 305

saving 309

selecting 299

Stroke Path command 312

stroking 312

text on a 445

type as work path 447

type on a 445

Paths palette 299

Paths to Illustrator command 603

Pattern buffer 34

Pattern dither 538, 539, 542

pattern dithering 153, 162

Pattern Maker 348

Pattern Stamp tool 271

patterns

fill layers 404

filling selections with 344

for dithering 160

layer style option 397

painting with 271

Pattern Maker 348

PostScript Pattern folder 346

PCD format 104

PCX format 586

PDF files

opening 102

placing 105

PDF files.See PDF format

PDF format

about 586

creating a PDF presentation 598

Downgrade Color Profile option 568

embedding fonts 568

encoding 568

Image Interpolation option 568

including vector data 568

PDF Security options 568

preserving transparency 568

saving files

using outlines for text 568
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PDF Image command 103

PDF Presentation command

about 598

Downgrade Color Profile option 600

embedding fonts 600

Encoding option 600

Image Interpolation option 600

image optimization 600

PDF Security option 600

preserving vector data 600

using outlines for text 600

PDF presentation. See PDF Presentation 
command

pen tools 25, 290, 295

drawing curves 296

drawing straight segments 295

Pencil tool 314, 315, 337

Perceptual color palette

about 161

number of colors 161

Perceptual color table 549

Perceptual rendering intent 135

perspective

applying 269

transforming 263

Photo CD files 104

Photo CD format 151

Photo Filter command 203

cooling filters 203

custom color filters 204

warming filters 203

photo galleries

creating 500, 501

creating new styles 505

customizing styles 504

styles 503

token 504

using tokens in 505

Photocopy filter 429

Photomerge

adjusting perspective 288

advanced blending 289

creating panoramas 284

cylindrical mapping 289

from the File Browser 287

Keep as Layers 287

navigating in the dialog box 286

Rotate tool 286

Select Image tool 286

selecting files to use 287

taking source photographs 285

using the lightbox 286

vanishing point tool 288

Zoom tool 286

zooming in the dialog box 286

Photoshop 2.0 format

about 583

Photoshop Camera Raw plug-in. See camera 
raw files

Photoshop EPS format. See EPS files

Photoshop format

about 583

Photoshop 2.0 format 583

Photoshop PDF format. See PDF format

Photoshop Raw format

about 588

saving in 571

picas 450

PICT files 105

PICT format

about 587

PICT Resource files 587

PICT resources 105

Picture Package command

about 595

adding images 596

customizing layouts 597

Pinch filter 425

Pixar format 587

Pixel Aspect Ratio Correction command 605

pixel aspect ratios

assigning 606

customizing 606

deleting values 606

restoring default values 606

pixel depth. See bit depth
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pixel dimensions

changing 67

changing during optimization 543

maximum 64

new channels 255

new images and 89

resampling and 66

viewing 66

pixel replacement variables 651

pixel values

in the Color palette 183

mean 180

median 180

previewing 181

standard deviation 180

using the Eyedropper tool 183

Pixelate filters 426

pixels

about 61

blending 390

displaying color values 25

histogram display of 180

selecting 229

Place command 105

with Version Cue project files 59

placing

files 105

images in other applications 601

Plaster filter 429

Plastic Wrap filter 421

Playback Options command 637

plug-in modules 57

filters 437

selecting folder for 58

plug-ins

file format 582

scanner 86

Plug-Ins & Scratch Disk preferences 58

PNG format 587

about 587

Interlaced option 576

options 576

saving files in 575

PNG-24 format

optimizing images in 541

PNG-8 format

optimizing images in 537

reducing colors 548

weighted optimization and 547

point type 438

converting to paragraph type 444

See also type

pointers. See tool pointers

Pointillize filter 427

points 450

Polar Coordinates filter 425

policies

options and behaviors 133

specifying 133

Polygon Image Map tool 495

Polygon tool 290

Polygonal Lasso tool 231

pop-up palettes

about 24

changing display of items 25

customizing list of items 25, 53, 318, 342, 
347, 356, 393

deleting items 24

selecting items 24

pop-up sliders 23

positives, creating 222

Poster Edges filter 421

Posterize command 223

scanning and 89

posterizing images 223

PostScript

fonts 438

Level 2 151

Level 3 151

point size 41

PostScript Color Management

in EPS and DCS files 570
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PostScript Language Reference Manual 619

ppi (pixels per inch) 63

See also resolution

preferences

anti-aliasing 104

Asian text 464

Clipboard 245

color management settings 124

color picker 171

displaying eight-bit color 153

file extensions 593

file handling 593

gamut warning color 185

image previews 593

interpolation 67

optimization 544

plug-in modules 58

Plug-Ins & Scratch Disks 60

recent file list 102

restoring to default settings 55

Save Palette Locations 23

setting 55

transparency display 375

Use Cache for Histograms 180

Use Pixel Doubling 153

Version Cue 59

Preserve Transparency option 336

preserving highlight and shadow detail 188

preset brushes 317, 329

preset file sizes

for video 604

Preset menu

saving and resetting optimization settings 
542

preset styles 392, 399

applying 392

presets

contours 398

gradients 340

swatches 354

pressure setting 334

preview

Preview Document command 515

Preview command 198

Preview Document button 653

Preview Document command 515, 653

previewing

animations 526

channel calculations 367

color selections 235

color values 181

extracted objects 250

gamma shifts 533

images 532

in a browser 51

layers 375

printed image 69

rollovers 515

Web pages 472

previewing data-driven graphics 653

Print command 608, 609

print dimensions

changing 68

changing when printing 611

Print One Copy command 609

Print Options command 608

Print Selected Area option 612

Print with Preview command 147, 610

printable colors 169

printer profiles 111

printer’s points 41

printing

about 608

about dpi 64

Adobe RGB (1998) working space 146, 148

background color 616

base output size 611

black generation 130

bleeds 616

borders 616

color separations 620

continuous-tone images 608

creating color traps 621

duotones 625

encoding 621
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halftone attributes for 618

images 608

layers and channels 609

negatives 617

output options 616

overprint colors 624

page marks 616

part of an image 612

PostScript Level 2 151

PostScript Level 3 151

previewing image size 69

Print dialog box 147

Print with Preview command 147

repositioning an image 611

resizing and reposition images 611

scaling an image 611

screen ruling 617

separation type 130

using color management 146

vector graphics 612

printing inks

density 365

printing marks 616

process color inks

about 362

simulating solidity 364, 365

processing data sets 654

profile

for JPEG optimization 541

profiles

about 109, 118

assigning 121

camera 120

converting 121

creating 111

customizing 119, 138

desktop printers 111

destination 109, 120

device 109, 118, 119

document 118, 119

embedding 120, 126

for soft proofs 141, 142

generic 119

input 119

loading 136

monitor 119

output 120

proof profiles 142, 184

saving 136

scanner 120

source 119

tagging documents with 120, 121

working spaces mismatch 132

Progressive option

for JPEG 2000 format 575

for JPEG format 573

projects, Version Cue 59

Promote Layer Based Image Map Area 
command 496

Promote to User-Slice command 475, 476

Proof Color command 184

Proof Colors command 141, 142

proof print 140

proof profiles 142, 184

Proof Setup command 141, 184

Protect Foreground Color option 337

PSD format. See Photoshop format

Pucker tool 278

punctuation, hanging 461

Purge Cache command 100

Purge command 34

pyramid data structure 578

Q
quadtones

See also duotones

Quick Mask mode

about 252, 254

previewing color selection in 235

quick masks, removing 254

QuickTime Movie format

about 587

saving in 576
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QuickTime movies

opening as animations 530

saving animations as 528

R
Radial Blur filter 423

Radial Gradient tool 338

Randomize option 342

raster images. See bitmap images

Rasterize command 382, 443

rasterized shapes

drawing 290

rasterizing 245

Adobe Illustrator artwork 245

PDF files 103, 105

PostScript artwork 104, 105

type layers 442

vector artwork 245

rasterizing layers 382

Read Watermark filter 593

Reconstruct tool 280, 281

reconstructing images 281

recording

actions 628

excluding commands in actions 634

inserting conditionals in 631

inserting stops in 630

paths 630

Pen tools in actions 630

specifying output folders 634

Rectangle Image Map tool 495

rectangle pixels 604

Rectangular Marquee tool 229

Redo command 33

reducing colors in GIF and PNG files 549

reference point 266

Reflected Gradient tool 338

refresh view, in Version Cue projects 59

Regenerate button 544

registration marks

printing 617

Relative Colorimetric rendering intent 135

remote rollovers 508

creating 514

Remove Black Matte command 247

Remove Layer Mask command 412

Remove White Matte command 247

renaming

images 97

layers 382

Render filters 427

Lighting Effects 428

rendering

See also rasterizing

rendering intents

about 135

Absolute Colorimetric 135

Perceptual 135

Relative Colorimetric 135

Saturation 135

renmoji 465

Replace Channel option 256

Replace Color command 210

Repopulate Views command 536

repositioning paths and shapes 305

Resample Image option 68, 69

resampling

about 66

interpolation methods 67

See also resizing

Reselect command 229

Reset Actions command 640

Reset All Tools command 19

Reset Palette Locations to Default option 23

Reset Tool command 19

resetting warning dialogs 56

Resize Image command 65

Resize Table to Slices command 489

Resize Window to Fit command 33

resizing

about 66

during printing 611

image maps 498

images 65, 635



Using Help | Contents | Index Back 739  

Adobe Photoshop CS Help Index 

Using Help | Contents | Index Back 739  

A  B  C  D  E  F  G  H   I   J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

images, automatically 648

images, in Save For Web dialog box 543

placed artwork 106

slices 480

tables 488

type 441

resolution

about 63

changing 67

determining optimal 69

displaying 66

document size 68

dpi 64

file size and 64

screen frequency and 65

Restore Last Document State command 407

Restore to Background option 525

restoring files, in Version Cue projects 59

restoring images 34

restoring layer comps 407

result color 331

Reticulation filter 429

Reveal Location command 91

Reverse Frames command 521

Revert command 34

with Version Cue project files 59

RGB color displays

cross-platform differences 154

Photoshop and ImageReady differences 154

RGB Color mode 150, 155

in the Adobe Color Picker 166, 167

selecting color in 166

tonal and color adjustments in 184

RGB color model 113

RGB color values

in Info palette 26

RGB images 155

channel display 358

converting to indexed-color images 160

specifying colors numerically 166, 354

RGB working spaces 125

Adobe RGB (1998) 126, 146, 148

Advanced Mode options 127

Apple RGB 126

choosing 126

ColorMatch RGB 127

ColorSync RGB 127

Monitor RGB 127

sRGB 149

Right Edges alignment button 379

Right Edges distribution button 380

Ripple filter 425

Rollover Preview button 515

rollovers 508

about 512

animated GIF in 516

changing states 513

copying and pasting 517

copying and pasting states 517

creating 512

creating and editing 512

creating new states 513

creating remote rollovers 514

creating slices for 513

deleting states 518

designing pages with 471

editing layers in 509

matching layers across states 509

Normal state 508

previewing 515

rearranging 518

remote 508

rollover styles 516

saving selected states to Web pages 518

state 508

unifying layers in 509

working with layers in 508

Rotate Canvas command 260

rotating

images 260, 269

layers 266
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layers and selections 268, 269

placed artwork 106

type characters 456

Rough Pastels filter 419, 421

Roundness option 320

rulers

about 40

changing settings 41

zero origin 41

Run Length Encoding (RLE) compression 582

S
Sample Radius option 239

sampling

from layers 381

image with Clone Stamp tool 270

image with Healing Brush tool 271

image with patch tool 273

saturation

about 113

adjusting 200, 220, 277

Saturation mode 334

Saturation rendering intent 135

Save A Version command 59, 564

Save Actions command 640

Save As command 564, 565

with Version Cue project files 59

Save command 564, 565

with Version Cue project files 59

Save for Web command 531, 532, 564

Save for Web dialog box

choosing a version 531

Color Table 548

displaying 532

Image Size panel 543

picture of 532

previewing display 533

previewing images 532

resizing images in 543

selecting a new version 532

switching to ImageReady 533

viewing annotations 533

working with slices 534

Save Image Pyramid option 578

Save Master Palette command 555

Save Optimized As command 558, 564, 635

Save Optimized command 531, 558, 564, 635

Save Palette Locations option 23

Save Path command 309

Save Selection command 246, 256

Save Slice Selection command 479

Save Workspace command 22

saving

16-bits-per-channel images 565

actions in Photoshop 640

alpha channels 566

annotations 566

as a Copy 566

batch-processed files 643

color range 236

color tables 164, 555

color-managed documents 566

copyright information 590

duotone curves 624

duotone settings 625

embedding watermarks 590

file extensions 593

files 565

image previews 566

images 564

layers 566

optimized images 562

options 566

preferences 566

restoring a saved image 34

selection settings 236

selections 256

slice selections 478

spot channels 566

thumbnails 566, 593

tonal and color adjustment settings 183

Use Lower Case option 566

See also names of individual formats
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saving files

Version Cue project files 59

Scale Effects command 401

scaling

about 265

images during printing 611

layers 266

scaling layer styles 401

scanner profiles 120

scanning 87

about 86

avoiding resampling 67

color balance 88

dynamic range 88

file size 88

images 70, 86

selecting devices 70, 87

scattering, for brushes 323

Scitex format

about 588

scratch disks 59

screen frequency

about 65

determining resolution 69

saving settings 620

scanning and 87

setting 618

Screen mode 333

screen ruling 617, 618

searching, in Version Cue projects 59

secondary rollover. See remote rollover. 512

Select All Colors command 552

Select All From Selection command 552

Select All User Slices command 479

Selected Areas option 254

Selected Layer option

in the Histogram palette 179

Selecting

new versions of images to view 532

selecting

channels 366

color ranges 234

contiguous pixels 233, 275

image maps 498

layers 374

multiple layers in ImageReady 369

multiple slices 479

pixels 229

similar pixels 239

slices 478

snapshots 38

tables 488

type 448

unselected areas 237

using the marquee tools 229

selecting an RGB color 166

selecting colors in color table 551

Selecting new versions 532

selecting objects

keyboard shortcuts 666

selection borders

anti-aliasing 239

closing 231

converting to paths 311

defining paths 311

feathering 239

for type 441

framing with selection 238

from paths 310

hiding and showing 237

moving 236

snapping behavior 43

stroking 239

selections

adding to 237, 238

adding to channel 256

adjusting 236

aligning 230

anti-aliasing 230, 253

applying effects to 265

converting from slices 236

converting to layer 373

copying 243

copying between applications 245
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copying within Photoshop 241

creating edge effects with 419

customizing 232, 233

deleting 247

deselecting 229

dragging between documents 243

editing as masks 252

feathering 239, 253

filling 344

flipping or rotating 268

freehand 231

from temporary masks 253

intersecting 237, 238

intersecting in channel 256

library 360

loading 257

loading from another image 258

moving 241

pasting 243

previewing 235

refining 234

removing halos around 247

replacing in channel 256

saving 256

saving as channel 256

smoothing 239

snapping behavior 43

softening 235

softening edges of 239

stroking 344

subtracting from 237, 238

subtracting from channel 256

tools and commands for making 229

Selective Color command 214

Selective color palette 161

number of colors 161

Selective color table 549

selective sharpening 226

Send Backward command 377

Send to Back command 377

separations. See color separations

serial numbers, legacy 58

server, see Adobe Version Cue 59

server-side image maps 500

Set Black Point eyedropper tool 193

setting target color 194

Set Gray Point eyedropper tool 188

setting target color 194

Set Optimization Settings command 635

Set White Point eyedropper tool 193

setting target color 194

setting HTML output options 489

Shadow/Highlight command 204

showing more options 205

shadows

adjusting 220, 276

adjusting with Levels 186

CMYK Color mode 150

shape dynamics, for brushes 322

shape layers

creating 291

shapes

distributing 306

drawing 290, 291

drawing constrained 293

editing 305

options 293

repositioning 305

type as 447

sharing files, with Adobe Version Cue 59

Sharpen Edges filter 428

Sharpen filter 428

Sharpen filters 224

Sharpen More filter 428

Sharpen tool 276

sharpening images 224, 225

sharpness

in camera raw images 78

Shear filter 425

shifting colors 552

dithering 553

shortcuts 656

Show Actions command 627

Show All Layer Styles command 394
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Show Auto Slice command 477

Show Channels command 358

Show Character command 449

Show Color Table command 548

Show Info command 25

Show Optimization Info command 535

Show Options button 22

Show Options command 19

Show Paragraph command 459

Show Rulers command 40

Show Slice Number command 477

showing. See hiding and showing

sidecar XMP files 81

viewed in the File Browser 81

Similar command 239

Single Column Marquee tool 229

Single Row Marquee tool 229

Single-line Composer 463

size

tracking file space needs 385

Size/Download Time option 47

Sketch filters 428

skewing

about 269

placed artwork 106

Slice Options dialog box 473, 489

Slice Select tool 478

slice sets

about 479

creating 479

deleting 480

toggling visibility 480

Slice tool 474

slices 490

about 472

adding HTML text to 492

adding links to 491

aligning 484

arranging layer-based 484

arranging user-based 484

auto slices

badges 476

change stacking order 484

combining 483

compared to image maps 494

converting auto to user 475

converting layer-based to user 475

converting to selections 236

copying 483

creating 472

creating from guides 474

creating from layers 475

creating from selections 474

creating user slices 474

creating with the Slice tool 474

deleting 485

deleting layer-based 485

deleting nested tables 489

deleting selections 479

deleting user 485

designing pages with 471

distributing 485

dithering 486

duplicating 483

export options for 489

export options for layout 493

layer-based slices 475

linking 486

locking 485

modifying 484

moving 480

nesting tables in 487

optimizing 485

pasting 483

promoting 475

resizing 480

resizing tables in 488

selecting 478

selecting multiple 479

selecting tables in 488

slice colors 476

slice lines 476

slice numbers 476

specifying browser messages in export 
options 491
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specifying in output settings 489

table slices 473

tables in 487

types of 473

unlocking 485

user slices

viewing 472, 476

viewing tables in 488

slices in actions 635

Slices palette 489

Small Caps command 454

Smart Blur filter 423

Smart Guides 43

hiding 44

Smart Highlighting option 249

smoothing edges of a selection 310, 312

smoothing selections 239

Smudge Stick filter 421

Smudge tool 275

Snap command 230, 246

Snap Neutral Midtones option 219

Snapshot command 37

snapshots

clearing 35

deleting 38

of state 34

snapshots in undo 637

Soft light mode 333, 334

soft proofs 140, 184

about 140

comparing with original image 143

previewing documents 141

setting up proof profiles 141

Solarize filter 430

Solidity option 363

Sort by Hue command 550

Sort by Luminance command 550

Sort by Popularity command 550

source channel 367

source profiles 119

source selection 244

Spacing option, brush 321, 326

special characters 456

special effects

applying to selections 265

with filters 419

specifying a color in Lab Color mode 166

specifying browser messages 491

spell-checking text 457

Spherize filter 425

Splatter filter 423

Split Channels command 361

Sponge filter 421

Sponge tool 277

spot channels

adding 362

merging 365

options 365

saving 566

spot colors 138

about 362

customizing working space for 138

preventing knock out 365

trapping 366

spotlight effect 433, 434

Sprayed Strokes filter 424

square pixels 604

sRGB working space 127, 149

stacking order

arranging for slices 484

image maps 499

Stained Glass filter 431

Stamp filter 429

standard deviation pixel values 180

Standard Macintosh Color 198

Standard mode 253

standard screen mode 28

Standard Windows Color 198

statistics

viewing in the Histogram palette 179

status bar 45

status, of Version Cue project files 59

stops, inserting in recordings 630

straight-edged selection border 231
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striking through type 454

Stroke command 345

Stroke effect 394

Stroke Path command 346

strokes

keyboard shortcuts 668

stroking

paths 312

selection borders 239

selections 344

styles

applying preset 392

converting to layers 401

copying and pasting 400

creating custom 394

displaying 394

editing 395

global lighting 398

layers 391

preset 392

Styles palette 392

Stylize filters 429

stylus tablet 233

subscript type 454

subslice 473

Subtract from Channel option 256

Subtract option 368

subtracting from a selection 229

subtractive colors 114

Sumi-e filter 424

superscript type 454

swatches

deleting 356

libraries 354

Swatches palette 354

keyboard shortcuts 679

loading a table 164

swatches, sharing with Version Cue projects 
59

SWF format 542

about 589

bitmap options 577

embedding fonts 577

Enable Dynamic Text option 577

Preserve Appearance option 577

preserving layers 576

saving in 576

text options 577

synchronizing, in Version Cue projects 59

synthetic states 516

System Layout command 455

T
Table palette 493

table slices 473

tables

about 487

creating 487

deleting nested 489

nesting 487

resizing 488

selecting 488

viewing 488

Tagged-Image File Format (TIFF). See TIFF 
format

tagging 120

Targa format 589

about 589

saving in 578

target channel 358

target color

for eyedropper tools 194

target values, setting with Levels or Curves 
194

Tate-Chuu-Yoko command 465

templates, for data-driven graphics 649

text

keyboard shortcuts 669

text on a path 445

Text Selection command 448

text. See type

texture

copying between tools 329

for brushes 324

protecting in brush strokes 329

Texture Channel 436
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Texture filters 431

textures

for special effects 436

in Lighting Effects filter 436

Texturizer filter 419, 431

Thaw tool 281

This Layer option 390

Threshold command 195, 196, 197, 222

Threshold mode 197

Threshold slider 426

thumbnails

displaying in Windows desktop 594

in Version Cue projects 59

layer 244, 371

resizing in Channels palette 359

resizing in Paths palette 300

saving 566

viewing in Open dialog box 101

TIFF format 589

about

Byte Order option 578

Image Compression option 578

Layer Compression option 579

preserving transparency 578

Save Image Pyramid option 578

saving files in 578

Tile command 29

Tile Maker filter 432

Tiles filter 430

token 504

tokens

syntax 505

using in Web photo gallery 505

Tolerance values 233, 343

tonal adjustments

for camera raw files 77

tonal and color adjustment

adjustment layers 402

tonal and color adjustments

adjustment layers 180

Auto Contrast command 217

automatic adjustments 216, 217

Brightness/Contrast command 215

canceling 181

generalized adjustments 219

Hue/Saturation command 200

Match Color command 209

quick tools for 215

Replace Color command 210

saving 183

Selective Color command 214

sharpening images 224

special-purpose tools for 221

tonal range check 176

using tools and commands for 180

tonal range

adjusting with Curves 190

adjustment layers 180, 402

brightness and contrast adjustments 215

generalized adjustments 219

quality check in histogram 176

remapping pixels in channel 223

scanning and 88

tool options bar

about 18

pop-up palettes 24

storing palettes 19

tool pointers

about 18

appearance 18

hot spots 18

options 18

toolbox 13

tools

default settings 19

fill 249

hidden 17

keyboard shortcuts 656

layer sampling 381

Magic Eraser 336

marquee 229

Modal 629

opacity 334

options bar 18
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painting 314

recording in actions 629, 634

selecting 17

snapping behavior 43

Toning 634

tool pointers 18

Top Edges alignment button 379

Top Edges distribution button 379

Torn Edges filter 429

Toyo colors 171

Trace Contour filter 430

tracking type 452

transfer functions 139, 617

Transform command

about 25

in Info palette 26

transformations

reference point 266

type layers 442

See also individual transform commands

transforming

type 441

transforming objects

keyboard shortcuts 669

transparency

canvas 259

channel display 358

creating in new images 89

dithering 539

document display 375

from mask 253

gradients 340

in Bitmap mode 570

optimizing 538

preserving in PDF format 568, 600

preserving in TIFF files 578

using advanced blending options 247

See also opacity

Transparency & Gamut option 375

Trap command 622

trapping colors 366

Trim command 262

trimming an image 262

tritones

See also duotones

TrueType fonts 438, 449

TRUMATCH color 171

Tsume option 465

TWAIN 70, 86

tweening 522

Twirl Clockwise tool 278

Twirl filter 425

2-D transformations 266

type

about 438

aligning 459

baseline shift 453

bounding box 441

changing case 453

committing 439

composition 463

converting between point type and 
paragraph type 444

converting to shapes 447

creating 438

editing 442

filling 451

finding and replacing 458

font family

formatting characters 448

formatting paragraphs 459

fractional character widths 455

hanging punctuation 461

hyphenating 461

kerning and tracking 452

leading 451

ligatures 456

orientation 443

paragraph type 438, 440

point type 438, 439

resizing 441

rotating 456

saving in EPS or DCS format 570

saving in PDF format 568, 600

selecting 448



Using Help | Contents | Index Back 748  

Adobe Photoshop CS Help Index 

Using Help | Contents | Index Back 748  

A  B  C  D  E  F  G  H   I   J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z

selection border 441

special characters 456

spell-checking 457

superscript and subscript 454

text on a path 445

transforming 441

type size 450

type style

underlining or striking through 454

unwarping type layers 445

using the Character palette 449

warping type layers 444

work path for 447

See also Asian type, type layers

Type 1 fonts 449

type layers

about 442

anti-aliased 443

changing orientation 443

rasterizing 442

transforming 442

unwarping 445

warping 444

type style

about

Type tool 439

type, formatting

keyboard shortcuts 670

U
UCA. See undercolor addition

UCR. See undercolor removal

Uncached Refresh, in the Histogram palette 
179

Uncompensated Color 198

undercolor addition (UCA) 131

undercolor removal (UCR) 130

underlining type 454

Underlying Layer option 390

Underpainting filter 419, 421

Undo command 33

Undo/Redo Status option 47

undoing changes 33

Ungroup command 414

ungrouping clipping groups 414

Uniform color palette

about 161

number of colors 161

Unify Layer Position button 510

Unify Layer Style button 510

Unify Layer Visibility button 510

unifying

layers 509

layers in ImageReady 381

Unlink All command 486

Unlink Slices command 486

unlocking

colors 554

unlocking slices 485

Unsharp Mask filter 224

about 224

after resampling 67

selective sharpening 226

using an edge mask 226

Unsharpen Mask filter 428

Unshift All Colors command 553

unwarping type layers 445

updating, Version Cue project files 59

URLs

assigning to image maps 497

assigning to slices 491

Use Accurate Screens option 619, 625

Use All Layers option 234, 381

Use Embedded Color Profile command 154

Use Pixel Doubling preference 153

Use Printer’s Default Screens option 619

Use Shift Key for Tool Switch 17

Use Unified Color Table option 540

Use Video Alpha option 375

user slices. See slices

users, in Version Cue projects 59

using actions 635

Using templates with other Adobe 
applications 654
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V
variables 649

Variations command 219

varnish 364, 365

See also process color inks

vector artwork 245

vector graphics

about 61

printing 612

resizing 65

saving in EPS or DCS format 570

saving in PDF format 568, 600

type 438, 447

Vector Mask Hides Effects option 390

Version Cue 59

Versions command 59

versions, using Version Cue 59

Vertical Center alignment button 379

Vertical Centers distribution button 379

vertical scale of type, adjusting 453

VGA color palette 586

video

saving images for 604

Video filters

De-Interlace 431

NTSC Colors 431

view box 31

viewing

image maps 496

images 31

See also hiding and showing

viewing artwork

keyboard shortcuts 665

viewing layers 375

Viewpoint Media Player 581

vignetting

correcting in camera raw image files 80

in camera raw images 79

virtual memory 59

visibility variables 651

Vivid light mode 333

W
Wacom tablet 321

warming filters 203

warning dialogs

color management policies 133

resetting 56

Warp Text command 444

Warp tool 278

warping type layers 444

Water Paper filter 429

Watercolor filter 421

watermarks

about 46

embedding 590, 591

viewing info in status bar 47

Watermark Durability Setting 592

Wave filter 425

WBMP format 542

Web

GoLive integration 472

optimizing images for 531

Web color palette

about 161

Web Color Sliders command 169

Web Content palette

annotated picture of 511

using 510

Web photo galleries

creating 500, 501

creating new styles 505

customizing 503

customizing styles 504

styles 503

token 504

using tokens in 505

Web Photo Gallery command 500

Web Shift/Unshift Selected Colors command 
553

Web-Data folder, for Version Cue projects 59

WebDAV, see Adobe Version Cue 59

Web-Files folder, for Version Cue projects 59

Web-safe alert 166
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Web-safe color table 549

Web-safe colors

about 168

changing to 169

identifying with the Adobe Color Picker 168

selecting 169

weighted optimization

about 545

GIF and PNG-8 color reduction 548

GIF and PNG-8 dithering 547

GIF lossiness 546

JPEG quality 546

masks and 545

Welcome screen 12

wet edges 328

white balance

for camera raw files 75

WIA support 71, 87

importing with digital camera 71

scanning 87

Wind filter 431

Windows Color Picker 171

Windows color table 550

Windows System color palette 161, 164

wizards/assistants

Export Transparent Image 601

Resize Image 65

word breaks, preventing 462

word spacing 462

work paths

converting selection to path 311

creating 290, 300, 308

workgroup, see Adobe Version Cue 59

working spaces

about 125

Adobe RGB (1998) 126, 146, 148

Apple RGB 126

choosing 126, 127

CMYK 126

color management policies 132, 133

ColorMatch RGB 127

ColorSync RGB 127

customizing grayscale profiles 138

customizing spot-color profiles 138

embedding a profile 126

loading profiles 137

mismatches 132

Monitor RGB 127

RGB 125

saving profiles 137

sRGB 127, 149

workspace 59

X
XMP

sidecar XMP files 81

XMP files

viewed in the File Browser 81

Z
zero origin 41

ZigZag filter 425

ZIP compression 582

zoom commands 31

Zoom tool 25, 31

ZoomView format 581

image compression 581

image tile options 581

MTX files 581

path to broadcast license 581

ZVT files 581

ZVT files 581


	Using Help
	About Help
	Navigating in Help
	Printing Help

	Contents
	Learning Photoshop CS
	Welcome
	Getting help
	Working with Photoshop and ImageReady
	If you work with digital photos
	If you want the color on your prints and monitor to match
	If you design Web pages
	If you design video graphics
	If you perform the same tasks on several files


	What’s New in Photoshop CS
	Photoshop CS for All Users
	Photoshop CS for photographers
	Photoshop CS for graphic Designers
	Photoshop CS for video and filmmakers
	ImageReady CS for Web professionals

	Looking at the Work Area
	Using the Welcome window
	Getting familiar with the work area
	About the work area

	Using the toolbox
	Toolbox overview (1 of 3)
	Toolbox overview (2 of 3)
	Toolbox overview (3 of 3)
	Using the tools
	Using the tool pointers

	Using the options bar
	Using the palette well
	Using tool presets (Photoshop)
	Using palettes
	Tips for rearranging the palette display
	Showing and hiding palettes
	Docking palettes together
	Saving workspaces
	Using pop-up sliders
	Using pop-up palettes
	Using the Info palette

	Using context menus
	Viewing images
	Changing the screen mode
	Viewing multiple images
	Navigating the view area
	Magnifying and reducing the view

	Correcting mistakes
	About the History palette
	Tips for using the History palette
	Using the History palette
	Setting history options (Photoshop)
	Making a snapshot of an image (Photoshop)
	Painting with a state or snapshot of an image (Photoshop)
	Working with the Edit History Log

	Duplicating images
	Using rulers, columns, the Measure tool, guides, and the grid
	Using rulers
	Using columns (Photoshop)
	Using the Measure tool (Photoshop)
	Using guides and the grid

	Working with Extras
	Displaying status information (Photoshop)
	Displaying file and image information
	Annotating images (Photoshop)
	Adding notes and audio annotations
	Opening and editing annotations

	Jumping between applications
	Jumping between Photoshop and ImageReady
	Jumping to other applications

	Previewing an image in a browser
	Managing libraries with the Preset Manager (Photoshop)
	Customizing keyboard shortcuts
	Setting preferences
	Resetting all warning dialogs
	Monitoring operations
	Closing files and quitting
	Using plug-in modules
	Working with Adobe Version Cue managed projects
	Assigning scratch disks

	Getting Images into Photoshop and ImageReady
	Working with bitmap images and vector graphics
	About bitmap images
	About vector graphics

	Understanding image size and resolution
	Pixel dimensions and image resolution
	File size
	Monitor resolution
	Printer resolution
	Screen frequency

	Changing image size and resolution
	Displaying image size information
	About resampling
	Choosing an interpolation method
	Changing the pixel dimensions of an image
	Changing the print dimensions and resolution of an image (Photoshop)
	Determining a recommended resolution for an image (Photoshop)

	Getting images from digital cameras
	Importing an image using the TWAIN interface
	Importing images from digital cameras using Windows Image Acquisition (WIA)

	Working with camera raw image files
	About camera raw files
	About the Camera Raw plug-in
	Opening camera raw image files
	Adjusting the image attributes
	Setting the white balance
	Making tonal adjustments
	Using the Sharpness slider to reduce blur
	Reducing noise
	Compensating for chromatic aberration
	Compensating for lens vignetting
	Correcting a shadow color cast
	Making advanced color adjustments
	About Photoshop Camera Raw plug-in settings
	Saving, applying, and updating Photoshop Camera Raw settings
	Creating an action to open camera raw image files

	Scanning images
	Importing scanned images
	Importing scanned images using the TWAIN interface
	Importing scanned images using WIA (Windows Image Acquisition) Support
	Scanning using the resolution setting (Photoshop)
	Scanning using the file size setting (Photoshop)
	Optimizing the dynamic range of the scan (Photoshop)
	Eliminating unwanted color casts (Photoshop)

	Creating new images
	Using the File Browser (Photoshop)
	About the File Browser window
	Customizing the File Browser window
	Viewing images
	Selecting and opening images
	Working with files and folders
	Working with keywords
	Sorting and ranking files
	Flagging files
	Searching for files
	Running automated tasks from the File Browser
	Renaming files and folders
	Working with the metadata palette
	Adding metadata to files
	Working with the cache
	Setting File Browser preferences

	Opening and importing images
	Opening files
	Opening and importing PDF files
	Opening PostScript artwork
	Turning off anti-aliasing for PDF and EPS files (ImageReady)
	Opening Photo CD files
	Importing anti-aliased PICT files (Mac OS)
	Importing PICT resources (Mac OS)

	Placing files

	Producing Consistent Color (Photoshop)
	An introduction to color management
	Why colors change
	Solving color inconsistency with color management
	Basic steps for producing consistent color

	Understanding color
	Using color models to describe color
	HSB model
	RGB model
	CMYK model
	Lab model

	Why colors sometimes don’t match
	Understanding color space and gamut
	Why each device has a different color space
	Device-dependent color models
	Device-independent color models

	Using color management to produce consistent color
	How color management works

	Calibrating and creating profiles
	Calibrating and creating a profile of your monitor
	Creating profiles of your input devices
	Creating profiles of your output devices
	Embedding a profile in a document
	Changing the color profile of a document

	Using the Photoshop Color Settings
	Specifying color management settings
	Using predefined color management settings
	Customizing color management settings
	Saving and loading color management settings

	About working spaces
	Choosing an RGB working space
	Choosing a CMYK working space
	Specifying a CMYK working space
	Specifying ink colors
	Specifying dot gain
	Adjusting the separation type and black generation

	About color management policies
	Using color management policies
	Working with policy warnings and messages
	Specifying color management policies

	Customizing advanced color management settings
	About the Color Management Module (CMM)
	Handling colors with a rendering intent
	Using black point compensation
	Using dither
	Desaturating monitor colors
	Blending RGB colors

	Saving and loading custom working space profiles
	Creating custom grayscale and spot-color profiles
	Creating a viewing environment for color management
	Compensating for dot gain in film using transfer functions
	Soft-proofing colors
	Previewing colors using a soft proof
	Comparing the soft proof to the original image

	Printing a hard proof
	Keeping color consistent between Photoshop and other Adobe applications
	Producing consistent color with a desktop printer
	Producing consistent color when sending images to press
	Producing consistent color when creating images for the Web

	Working with Color
	About the different color modes (Photoshop)
	RGB Color mode
	CMYK Color mode
	Lab Color mode
	Bitmap mode
	Grayscale mode
	Duotone mode
	Indexed Color mode
	Multichannel mode

	Adjusting the monitor display
	Specifying 8-bit color display (Photoshop)
	Making previews display more quickly (Photoshop)
	Adjusting color display for cross-platform variations

	Channels and bit depth (Photoshop)
	About color channels
	About bit depth
	Converting between bit depths

	Converting between color modes (Photoshop)
	Converting an image to another mode
	Making a conditional mode change

	Converting images to Bitmap mode (Photoshop)
	Converting a color or grayscale image to Bitmap mode
	Converting an image from Bitmap mode to Grayscale mode
	Specifying halftone screens for Bitmap-mode images
	Specifying custom halftone screens for Bitmap-mode images

	Converting to indexed color (Photoshop)
	Conversion options for indexed-color images (Photoshop)
	Palette type
	Number of colors
	Color inclusion and transparency
	Dithering

	Customizing indexed color tables (Photoshop)
	Using the color table to edit colors and assign transparency
	Using predefined color tables
	Saving and loading color tables

	Using the Adobe Color Picker
	About the Adobe Color Picker
	Specifying a color using the color field and color slider
	Specifying a color using numeric values
	Working with the Adobe Color Picker in HSB mode
	Working with the Adobe Color Picker in RGB mode
	Working with the Adobe Color Picker in Lab mode (Photoshop)
	Using Web-safe colors
	Warning alert for nonprintable colors (Photoshop)
	Choosing custom colors (Photoshop)
	Choosing a custom color system (Photoshop)

	Using other color pickers
	Using the color wheel

	Making Color and Tonal Adjustments
	Before making color and tonal adjustments
	Basic steps for correcting images
	Using a histogram to view the tonal range of an image (Photoshop)
	Reading a histogram
	About the Histogram palette
	Viewing statistical information about pixel values

	Using the color adjustment tools
	Making color adjustments
	Viewing the color values of pixels (Photoshop)
	Saving and reapplying settings

	Comparing corrections in CMYK and RGB (Photoshop)
	Identifying out-of-gamut colors (Photoshop)
	Using the Levels dialog box
	Using Levels to set highlights, shadows, and midtones
	Using Levels to preserve highlight and shadow details for printing
	Using Levels to adjust color (Photoshop)

	Using the Curves dialog box (Photoshop)
	About the Curves dialog box
	Adjusting color and tonality with Curves
	Quick adjustments in the Curves dialog box
	Keyboard shortcuts for Curves

	Using the eyedropper tools in the Levels or Curves dialog box
	Using the eyedropper tools to set the black and white points
	Using the eyedropper tools to remove a color cast

	Setting highlight and shadow target values (Photoshop)
	Adjusting the gamma value of an image (ImageReady)
	Using the Color Balance command (Photoshop)
	Using the Hue/Saturation command
	Using the Photo Filter command (Photoshop)
	Using the Shadow/Highlight command (Photoshop)
	Using the Match Color command (Photoshop)
	Matching colors
	Adjusting color in an image using the Match Color command
	Saving and reusing Match Color settings

	Using the Replace Color command (Photoshop)
	Mixing color channels (Photoshop)
	Using the Selective Color command (Photoshop)
	Making quick overall adjustments to an image
	Using the Brightness/Contrast command
	Using the Auto Levels command
	Using the Auto Contrast command
	Using the Auto Color command (Photoshop)
	Setting auto color correction options (Photoshop)
	Using the Variations command
	Using the Equalize command (Photoshop)

	Applying special color effects to images
	Using the Desaturate command
	Using the Invert command
	Using the Threshold command (Photoshop)
	Using the Posterize command (Photoshop)
	Using the Gradient Map command (Photoshop)

	Sharpening images
	About the Photoshop sharpening filters
	Using the Unsharp Mask filter
	Selective sharpening


	Selecting
	About selections
	Using the Select menu
	Using the marquee tools
	Using the Lasso, Polygonal Lasso, and Magnetic Lasso tools
	Setting options for the Lasso, Polygonal Lasso, and Magnetic Lasso tools
	Using the Magic Wand tool
	Using the Color Range command (Photoshop)
	Creating selections from slices (ImageReady)

	Adjusting pixel selections
	Moving, hiding, or inverting a selection
	Adjusting selections manually
	Adjusting selections numerically

	Softening the edges of a selection
	Moving, copying, and pasting selections and layers
	Moving selections and layers within an image
	Copying selections or layers
	Using drag and drop to copy between applications
	Using the Clipboard to copy between applications

	Using the Snap command
	Saving and loading selections
	Deleting selections
	Removing fringe pixels from a selection (Photoshop)
	Using the Extract filter (Photoshop)
	About masks (Photoshop)
	Using Quick Mask mode to make selections (Photoshop)
	Storing masks in alpha channels
	Tips for using alpha channels (Photoshop)
	Creating alpha channels (Photoshop)
	Saving a mask selection
	Modifying alpha channels (Photoshop)
	Loading a selection into an image


	Transforming and Retouching
	Changing the size of the work canvas
	Rotating and flipping entire images
	Cropping images
	Using the Crop tool
	Using the Crop and Trim commands
	Transforming perspective while cropping (Photoshop)
	Using the Crop and Straighten Photos command (Photoshop)

	Transforming objects
	Specifying what to transform
	Setting the reference point
	Applying transformations
	Using the Free Transform command

	Retouching and repairing images
	Using the Clone Stamp tool
	Using the Pattern Stamp tool
	Using the Healing Brush tool (Photoshop)
	Using the Patch tool (Photoshop)
	Using the Color Replacement tool
	Using the Smudge tool (Photoshop)
	Using the Blur tool (Photoshop)
	Using the Sharpen tool (Photoshop)
	Using the Dodge tool and the Burn tool (Photoshop)
	Using the Sponge tool (Photoshop)

	Using the Liquify filter
	Using the Liquify dialog box
	Using the distort tools
	Setting liquify tool options
	Distorting images
	Freezing areas
	Using mask options
	Thawing areas
	Reconstructing distortions
	About reconstruction modes
	About Reconstruct tool modes
	Working with meshes
	Working with backdrops

	Creating panoramic images using Photomerge (Photoshop)
	Taking pictures for use with Photomerge
	Using the Photomerge dialog box
	Creating a Photomerge composition
	Changing Photomerge composition settings


	Drawing
	About shapes and paths
	Using the shape tools
	Creating shapes
	Using custom shapes (Photoshop)
	Creating rasterized shapes
	Setting shape tool options

	Editing shapes (Photoshop)
	Using the pen tools (Photoshop)
	Drawing with the Pen tool
	Drawing straight segments with the pen tool
	Drawing curves with the Pen tool
	Drawing with the Freeform Pen tool

	Working with paths (Photoshop)
	Using the Paths palette (Photoshop)
	Creating a work path (Photoshop)
	About anchor points, direction lines, direction points, and components
	Selecting paths (Photoshop)
	Moving, reshaping, and deleting path segments
	Moving, reshaping, copying, and deleting path components
	Aligning and distributing path components
	Adding, deleting, and converting anchor points

	Managing paths (Photoshop)
	Converting between paths and selection borders (Photoshop)
	Converting paths to selection borders
	Converting selection borders to paths

	Adding color to paths (Photoshop)
	Filling paths with color
	Stroking to paint path borders


	Painting
	Using the painting tools (Photoshop)
	Using the painting tools
	Using the Art History Brush tool (Photoshop)
	Working with brushes
	Using the Brushes palette (Photoshop)
	Selecting preset brushes
	Customizing brush tips (Photoshop)
	Setting brush tip shape options:
	About brush dynamics (Photoshop)
	Specifying brush shape dynamics (Photoshop)
	Specifying brush scattering (Photoshop)
	Creating textured brushes (Photoshop)
	Creating dual brushes (Photoshop)
	Specifying color dynamics (Photoshop)
	Specifying paint dynamics (Photoshop)
	Adding noise to brush strokes (Photoshop)
	Using wet brush edges (Photoshop)
	Creating airbrush effects (Photoshop)
	Smoothing brush strokes (Photoshop)
	Protecting texture in brush strokes (Photoshop)
	Copying textures between tools (Photoshop)
	Clearing brush options (Photoshop)
	Creating and managing preset brushes (Photoshop)

	Setting options for painting and editing tools
	Selecting a blending mode
	Specifying opacity, flow, strength, or exposure

	Erasing
	Using the Eraser tool
	Using the Magic Eraser tool
	Using the Background Eraser tool (Photoshop)
	Using the Auto Erase option

	Using the Gradient tool (Photoshop)
	Applying a gradient fill
	Creating smooth gradient fills
	Specifying the gradient transparency
	Creating noise gradient fills
	Managing gradients

	Using the Paint Bucket tool
	Filling and stroking selections and layers
	Filling a selection or layer with colors or patterns
	Stroking a selection or layer with color

	Creating and managing patterns
	Defining patterns
	Managing patterns (Photoshop)

	Using the Pattern Maker
	Generating patterns
	Previewing patterns
	Reviewing tiles and pattern previews
	Specifying pattern smoothness and detail

	Choosing foreground and background colors
	Using color settings in the toolbox
	Using the Eyedropper tool
	Using the Color palette
	Using the Swatches palette


	Using Channels
	About channels
	Using the Channels palette (Photoshop)
	Viewing channels
	Changing the display of the palette
	Selecting and editing channels

	Managing channels (Photoshop)
	Rearranging and renaming channels
	Duplicating channels
	Splitting channels into separate images
	Merging channels
	Deleting channels

	Adding spot colors (Photoshop)
	About spot colors
	Creating spot channels
	Modifying spot channels
	Adjusting overlapping spot colors

	Using channel calculations to blend layers and channels (Photoshop)
	Using the Apply Image command
	Using the Calculations command
	About the Add and Subtract blending modes


	Using Layers
	About layers
	Working with layers (ImageReady)
	Using the Move tool with layers
	Manipulating layer content

	Using the Layers palette
	Creating layers and layer sets
	About the background layer
	Creating new layers and layer sets

	Working with layered images
	Viewing layers and layer sets
	Selecting layers
	Displaying the contents of layers
	Grouping layers (ImageReady)
	Duplicating layers
	Changing the stacking order of layers
	Linking layers
	Aligning layers

	Distributing layers
	Locking layers
	Unifying layers (ImageReady)
	Sampling from layers

	Managing Layers
	Renaming layers
	Color coding layers
	Rasterizing layers
	Deleting layers
	Merging and stamping layers
	Flattening all layers
	Tracking file size
	Exporting layers (ImageReady)

	Setting opacity and blending options
	Setting layer opacity
	Choosing a blending mode
	Filling new layers with a neutral color
	Specifying fill opacity
	Specifying knockout options
	Restricting blending to channels (Photoshop)
	Grouping blend effects
	Specifying a range for blending layers (Photoshop)

	Using layer effects and styles
	About layer effects and styles
	Applying preset styles
	Creating custom styles
	Displaying layer styles
	Editing styles
	Modifying layer effects with contours
	Applying global lighting
	Creating and managing preset styles
	Copying and pasting styles
	Scaling layer effects
	Removing layer effects
	Converting layer styles to layers

	Using adjustment layers and fill layers (Photoshop)
	About adjustment layers and fill layers
	Creating adjustment layers or fill layers
	Editing adjustment layers or fill layers
	Merging adjustment layers or fill layers

	Working with layer comps
	About layer comps and the Layer Comps palette
	Creating a layer comp
	Viewing layer comps
	Applying layer comps
	Updating layer comps
	Restoring layer comps
	Validating layer comps
	Deleting layer comps

	Masking layers
	About masking layers
	Creating and editing layer masks
	Creating and editing vector masks
	Unlinking layers and masks
	Applying and discarding layer masks
	Selecting opaque areas on a layer

	Creating clipping masks

	Applying Filters for Special Effects
	Using filters
	Using the Filter Gallery
	Applying filters using the Filter Gallery dialog box

	Applying filters individually
	Blending filter effects (Photoshop)
	Defining undistorted areas
	Using texture and glass surface controls

	Tips for creating special effects
	Choosing a filter effect
	Artistic filters
	Blur filters
	Brush Stroke filters
	Distort filters
	Noise filters (Photoshop)
	Pixelate filters
	Render filters
	Sharpen filters
	Sketch filters
	Stylize filters
	Texture filters
	Video filters
	Other filters
	Digimarc filters

	The Lighting Effects filter
	Using the Lighting Effects filter
	Choosing a Lighting Effects type
	Choosing a Lighting Effects style
	Using a Lighting Effects texture

	Loading images and textures
	Improving filter performance
	About plug-in filters

	Using Type
	About type
	Creating type
	About using the type tools (Photoshop)
	Entering point type
	Entering paragraph type
	Creating a type selection border (Photoshop)

	Working with type layers
	Editing text in type layers
	Rasterizing type layers
	Changing type layer orientation
	Specifying anti-aliasing
	Converting between point type and paragraph type
	Warping type layers
	Creating text on a path (Photoshop)
	Creating a work path from type (Photoshop)
	Converting type to shapes (Photoshop)

	Formatting characters
	Selecting characters
	Using the Character palette
	Choosing a font
	Choosing a type size
	Changing the type color
	Specifying leading
	Specifying kerning and tracking
	Adjusting horizontal or vertical scale
	Specifying baseline shift
	Changing case
	Making characters superscript or subscript
	Applying underline and strikethrough
	Using Dynamic Shortcuts
	Using fractional character widths
	Viewing text using the operating system layout
	Rotating vertical type

	Applying Open Type features to characters
	Checking for spelling errors (Photoshop)
	Finding and replacing text (Photoshop)
	Formatting paragraphs
	Selecting paragraphs and showing the Paragraph palette
	Aligning and justifying type
	Indenting paragraphs
	Changing space above or below paragraphs
	Specifying hanging punctuation

	Controlling hyphenation and justification
	Adjusting hyphenation
	Preventing unwanted word breaks
	Adjusting spacing

	Working with composition
	About composition methods
	Choosing a composition method

	Setting options for Asian type (Photoshop)
	Displaying Asian type options
	Adjusting tsume
	Specifying how leading is measured
	Using tate-chuu-yoko
	Specifying left and right underlining
	Using Asian Open Type fonts
	Working with Japanese composition
	Using burasagari


	Designing Web Pages
	About designing Web pages with Photoshop and ImageReady
	Creating and viewing slices
	About slices
	Types of slices
	Creating user slices
	Creating layer-based slices
	Converting auto slices to user slices
	Converting layer-based slices to user slices
	Viewing slices

	Selecting and modifying slices
	Selecting slices
	Using slice sets (ImageReady)
	Moving and resizing user slices
	Resizing and moving slices using numeric coordinates
	Dividing user slices and auto slices
	Duplicating slices
	Combining slices (ImageReady)
	Arranging user slices and layer-based slices
	Aligning user slices (ImageReady)
	Distributing user slices (ImageReady)
	Deleting user slices and layer-based slices
	Locking slices (Photoshop)
	Optimizing slices
	Linking slices (ImageReady)

	Working with tables (ImageReady)
	Creating tables
	Viewing tables
	Selecting tables
	Resizing tables
	Deleting nested tables slices

	Setting HTML output options
	Setting and viewing slice options
	Choosing a content type
	Specifying slice names
	Specifying slice background colors
	Assigning a URL to an Image slice
	Specifying browser messages
	Adding HTML text to a slice
	Setting slice table export options (ImageReady)

	Working with image maps (ImageReady)
	Creating image maps
	Viewing image maps
	Specifying image map options
	Selecting image maps
	Moving and resizing tool-based image maps
	Duplicating image maps
	Arranging image maps
	Aligning and distributing tool-based image maps
	Deleting image maps
	Selecting an image map type

	Creating Web photo galleries (Photoshop)
	Customizing and creating Web photo gallery styles (Photoshop)
	About Web photo gallery styles
	Customizing Web photo gallery styles
	Creating new Web photo gallery styles
	Using tokens in Web photo gallery styles


	Creating Complex Web Graphics (ImageReady)
	About rollovers and states
	About working with layers in rollovers and animations
	Editing layers in rollover states and animation frames
	Unifying and matching layer rollovers and animations

	Using the Web Content palette
	Creating and editing rollovers
	Creating rollovers
	Creating slices for rollovers
	Creating and changing rollover states
	Creating remote rollovers
	Previewing rollover states
	Adding animation to rollover states
	Applying and creating rollover styles
	Copying and pasting rollover states
	Duplicating rollover states
	Rearranging and deleting rollover states
	Saving selected rollover states to Web pages

	Animations
	About animation
	Creating and editing animations
	Using the Animation palette
	Adding frames
	Selecting frames
	Editing frames
	Rearranging and deleting frames
	Copying and pasting frames
	Tweening frames
	Specifying looping
	Specifying delay for frames
	Adding layers to frames
	Setting the frame disposal method
	Flattening frames into layers

	Viewing animations
	Optimizing animations
	Viewing animated images in Photoshop
	Saving animations
	Saving animation frames as separate files
	Saving animations as animated GIFs
	Saving animations as QuickTime movies

	Exporting animation frames as files
	Opening and importing files as animations
	Opening animated GIFs
	Opening Photoshop files as animations
	Opening QuickTime movies as animations


	Preparing Graphics for the Web
	About optimization
	Optimizing images
	Using the Save for Web dialog box (Photoshop)
	Predicting final display in the Save for Web dialog box (Photoshop)
	Working with slices in the Save for Web dialog box (Photoshop)
	Using the Optimize palette (ImageReady)
	Viewing optimized images (ImageReady)
	Applying optimization settings
	Determining ideal image format
	Optimization options for GIF and PNG-8 formats
	Optimization options for JPEG format
	Optimization options for PNG-24 format
	Optimization options for WBMP format
	Optimizing and saving images as SWF files (ImageReady)
	Saving and resetting optimization settings
	Resizing the image during optimization (Photoshop)
	Controlling optimization (ImageReady)
	Setting optimization preferences (ImageReady)

	Using weighted optimization
	About masks and weighted optimization
	Using masks to modify JPEG quality
	Using masks to modify GIF lossiness
	Using masks to modify dithering
	Using masks to modify color reduction

	Optimizing colors in GIF and PNG-8 images
	Viewing a color table
	Generating a color table
	Changing the display of the color table
	Adding new colors to the color table
	Including black and white in a color table
	Selecting colors
	Shifting colors
	Shifting to Web-safe colors
	Mapping colors to transparency
	Locking colors in the color table
	Deleting colors from the color table
	Loading and saving color tables
	Using master palettes (ImageReady)

	Working with hexadecimal values for color
	Viewing hexadecimal values for colors in the Info palette
	Copying colors as hexadecimal values

	Using a droplet to automate optimization settings (ImageReady)
	Saving optimized images
	Setting output options
	Using the Output Settings dialog box
	Setting HTML output options
	Saving HTML files (ImageReady)
	Setting slice output options
	Setting image map output options (ImageReady)
	Setting background options
	Setting file saving options
	Adding title and copyright information to Web pages
	Including image metadata (ImageReady)


	Saving and Exporting Images
	Saving images
	About the save commands
	Saving files
	Setting the file saving options (Photoshop)
	Saving large documents (Photoshop)
	Saving files in Photoshop PDF format (Photoshop)
	Saving files in Photoshop EPS format (Photoshop)
	Saving files in Photoshop DCS format (Photoshop)
	Saving files in Photoshop Raw format (Photoshop)
	Saving files in BMP format
	Saving 16-bit-per-channel files in Cineon format (Photoshop)
	Saving files in GIF format (Photoshop)
	Saving files in JPEG format (Photoshop)
	Saving files in JPEG 2000 format (Photoshop optional plug-in)
	Saving files in PNG format (Photoshop)
	Saving files in the QuickTime Movie format (ImageReady)
	Saving files in SWF format (ImageReady)
	Saving files in Targa format
	Saving files in TIFF format

	Exporting layers as files (ImageReady)
	Exporting animation frames as files (ImageReady)
	Exporting images in ZoomView format (Photoshop)
	About file formats
	About file compression
	Photoshop format (PSD)
	Photoshop 2.0 (Photoshop)
	QuickTime Movie (ImageReady)
	BMP
	Photoshop EPS
	Photoshop DCS 1.0 and 2.0 (Photoshop)
	Cineon
	Filmstrip
	GIF
	IFF
	JPEG
	JPEG 2000 (Photoshop optional plug-in)
	Large Document Format (PSB)
	PCX
	PDF
	PICT File
	PICT Resource
	Pixar
	PNG
	QuickTime Movie (ImageReady)
	Photoshop Raw (Photoshop)
	Scitex CT (Photoshop)
	SWF (ImageReady)
	Targa
	TIFF

	Adding file information (Photoshop)
	Adding digital copyright information
	Before adding a digital watermark
	Embedding digital watermarks
	Using the Watermark Durability setting
	Using the signal strength meter

	Setting preferences for saving files (Photoshop)
	Creating multiple-image layouts (Photoshop)
	Creating contact sheets
	Creating picture packages
	Customizing picture package layouts

	Creating a PDF presentation
	Placing Photoshop images in other applications (Photoshop)
	Using image clipping paths to create transparency
	Printing image clipping paths
	Exporting paths to Adobe Illustrator
	Object linking and embedding (OLE) (Windows only)
	Saving images for use in video
	Saving images for use in motion graphics


	Printing (Photoshop)
	About printing
	Printing images to a desktop printer
	Desktop printing considerations
	Printing images
	Positioning and scaling images

	Printing part of an image
	Printing vector graphics
	Using color management when printing
	Printing with the printer driver’s built-in profiles
	Printing with custom profiles
	Printing a hard proof
	Printing targets for custom profiles

	Printing images to a commercial printing press
	Preparing images for press
	Specifying prepress options
	Setting output options
	Selecting halftone screen attributes
	Printing color separations
	Choosing a print encoding method
	Creating color traps

	Printing duotones
	About duotones
	Modifying the duotone curve
	Specifying overprint colors
	Saving and loading duotone settings
	Viewing individual printing plates
	Printing duotones
	Exporting duotone images to other applications

	Using online services

	Automating Tasks
	About actions
	Using the Actions palette
	Recording actions
	Creating a new action
	Recording paths (Photoshop)
	Inserting stops
	Inserting Conditionals (ImageReady)
	Editing conditionals
	Setting modal controls
	Excluding commands
	Inserting nonrecordable commands (Photoshop)
	Specifying an output folder (ImageReady)
	Recording image size options (ImageReady)
	Inserting optimization settings for selected slices (ImageReady)

	Playing actions
	Setting playback options (Photoshop)
	Editing actions
	Rearranging actions and commands
	Recording additional commands
	Rerecording and duplicating actions and commands
	Deleting actions and commands
	Changing action options

	Managing actions in the Actions palette
	Saving and loading actions
	Organizing sets of actions (Photoshop)

	Using the Batch command (Photoshop)
	Using droplets
	Creating a droplet from an action
	Creating droplets for use on different operating systems
	Using droplets to process files
	Editing droplets (ImageReady)
	Using droplets to automate optimization settings (ImageReady)

	Using the Automate commands (Photoshop)
	External automation
	Supported Scripting Languages and Platform Issues

	Creating templates for data-driven graphics (ImageReady)
	About data-driven graphics
	Using variables
	Using data sets
	Applying data sets
	Previewing data-driven graphics
	Saving templates for use with other Adobe products
	Processing all data sets
	Importing data sets from external files


	Keyboard Shortcuts
	Keys for selecting tools
	Keys for selecting tools in the Extract toolbox (Photoshop)
	Keys for selecting tools in the Liquify toolbox
	Keys for working with Extract*, Liquify, and Pattern Maker*
	Keys for using the File Browser (Photoshop)
	Keys for using the Filter Gallery
	Keys for using the Camera Raw dialog box (Photoshop)
	Keys for using Photomerge (Photoshop)
	Keys for working with blending modes
	Keys for viewing images
	Keys for selecting and moving objects
	Keys for editing paths (Photoshop)
	Keys for painting objects
	Keys for transforming selections, selection borders, and paths
	Keys for selecting, editing, and navigating through text
	Keys for formatting type
	Keys for slicing and optimizing
	Keys for using palettes
	Keys for using the Actions palette
	Keys for using the Animation palette (ImageReady)
	Keys for using the Brushes palette
	Keys for using the Channels palette (Photoshop)
	Keys for using the Color palette
	Keys for using the Color Table palette (ImageReady)
	Keys for using the History palette
	Keys for using the Info palette
	Keys for using the Layer Comps palette
	Keys for using the Layers palette
	Keys for using the Paths palette (Photoshop)
	Keys for using the Swatches palette
	Keys for using the Web Content palette (ImageReady)
	Function keys

	Tutorials
	Image correction made easy with the Levels command
	Remove red-eye in images
	Create an image using layers
	Using Photoshop selection tools
	Produce great prints using Print with Preview
	Using Photoshop shapes

	Legal Notices
	Copyright


	Index
	A
	B
	C
	D
	E
	F
	G
	H
	I
	J
	K
	L
	M
	N
	O
	P
	Q
	R
	S
	T
	U
	V
	W
	X
	Z


